Definizione della forma della scheda

Altium Training

Altium Essentials: PCB Configuration

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

A colpo d'occhio

Questo articolo spiega come funziona la forma della scheda in Altium Designer, quali aspetti controlla in un progetto PCB o rigido-flessibile e i diversi modi per definirla, crearla e modificarla nelle modalità rigido-flessibile Standard e Avanzata. Descrive come la forma della scheda sia costituita da una o più regioni della scheda, dove è disponibile, qual è la forma predefinita in un nuovo documento PCB e quali comandi utilizzare nelle modalità di pianificazione della scheda, 2D e 3D per modificare il contorno della scheda finita. Se desideri capire meglio come impostare e perfezionare i limiti fisici della scheda nell'editor PCB, questa guida fa al caso tuo.

- Scopri che cosa definisce la forma della scheda, come viene utilizzata dal software e quali differenze presenta nei progetti con una singola regione e in quelli rigido-flessibili.
- Esamina i metodi disponibili per creare e modificare il contorno della scheda, inclusi gli strumenti interattivi, gli oggetti selezionati e la definizione basata su corpi 3D.
- Comprendi quali comandi sono disponibili nelle modalità rigido-flessibile Standard e Avanzata e come le modalità di visualizzazione influiscono sul flusso di lavoro di modifica.
Approfondisci con l'IA:

Nel software di progettazione PCB di Altium sono disponibili due modalità di progettazione rigido-flessibile. La modalità originale, o standard, denominata Rigid-Flex, supporta progetti rigido-flessibili semplici. Se il progetto presenta requisiti rigido-flessibili più complessi, come regioni flessibili sovrapposte, è necessario utilizzare la modalità Advanced Rigid-Flex (nota anche come rigid-flex 2.0). La modalità si seleziona nel menu Tools del gestore dello stackup.

► Scopri di più sulla progettazione rigido-flessibile

La sagoma della scheda definisce la forma complessiva della scheda finita. Scorri le diapositive per vedere le tre regioni della scheda che compongono la sagoma rigido-flessibile e la scheda finita in 3D.

La sagoma della scheda definisce la forma complessiva della scheda finita. Scorri le diapositive per vedere le tre regioni della scheda che compongono la sagoma rigido-flessibile e la scheda finita in 3D.

La sagoma della scheda definisce la forma complessiva della scheda finita. Scorri le diapositive per vedere le tre regioni della scheda che compongono la sagoma rigido-flessibile e la scheda finita in 3D.

La sagoma della scheda definisce la forma complessiva della scheda finita. Scorri le diapositive per vedere le tre regioni della scheda che compongono la sagoma rigido-flessibile e la scheda finita in 3D.

La sagoma della scheda definisce la forma complessiva della scheda finita. Scorri le diapositive per vedere le tre regioni della scheda che compongono la sagoma rigido-flessibile e la scheda finita in 3D.

La sagoma della scheda definisce la forma complessiva della scheda finita. Scorri le diapositive per vedere le tre regioni della scheda che compongono la sagoma rigido-flessibile e la scheda finita in 3D.

 

Panoramica

La sagoma della scheda, detta anche contorno della scheda, è una forma poligonale chiusa che definisce i limiti complessivi della scheda. La sagoma della scheda può essere costituita da un'unica regione della scheda (per un PCB rigido tradizionale) o da più regioni della scheda (per un PCB rigido-flessibile). Il software utilizza la sagoma della scheda per:

  • Fornire una guida visiva dei limiti dello spazio disponibile per il posizionamento e lo sbroglio del progetto.
  • Definire l'arretramento dei piani di alimentazione rispetto al bordo e i riferimenti al bordo per suddividere un piano di alimentazione in zone a tensioni diverse. Scopri di più sulla definizione e gestione delle aree di rame.
  • Calcolare il bordo della scheda durante l'esportazione dei dati di progetto verso altri strumenti.
Per un progetto PCB vuoto o per documenti PCB aggiuntivi inseriti in un progetto esistente, la sagoma predefinita della scheda è rettangolare (6 pollici x 4 pollici, oppure 6000 mil x 4000 mil, oppure 152,4 mm x 101,6 mm). Nei modelli di progetto specifici utilizzabili per creare un nuovo progetto PCB, il documento PCB associato presenta una sagoma della scheda specifica, in base al fattore di forma della scheda.

Disponibilità

La sagoma della scheda è disponibile solo nell'editor PCB. Quando viene creato un nuovo file PCB, questo si apre con una sagoma della scheda rettangolare costituita da un'unica regione della scheda.

La sagoma complessiva della scheda può essere creata:

  • Definendo interattivamente la sagoma della scheda nella modalità di pianificazione della scheda.
  • Creando la sagoma della scheda a partire da oggetti pista/arco selezionati che formano un contorno chiuso. Se si utilizza la modalità Advanced Rigid-Flex, è possibile creare più regioni della scheda a partire dagli oggetti selezionati nello spazio di progettazione.
  • Per un progetto rigido-flessibile (in modalità standard o avanzata), suddividendo la sagoma della scheda nelle varie regioni della scheda necessarie per il progetto.
  • Posizionando una o più regioni della scheda per comporre la sagoma complessiva della scheda (modalità Advanced Rigid-Flex).
La sagoma predefinita della scheda in un nuovo documento PCB è rettangolare (6 pollici x 4 pollici, oppure 6000 mil x 4000 mil, oppure 152,4 mm x 101,6 mm). Nei modelli di progetto specifici utilizzabili per creare un nuovo progetto PCB, il documento PCB associato presenta una sagoma della scheda specifica in base al fattore di forma della scheda.
La modalità di visualizzazione corrente del documento PCB può essere modificata utilizzando i comandi corrispondenti nel menu principale View . In alternativa, è possibile cambiare rapidamente vista utilizzando le scorciatoie da tastiera 1 (modalità di pianificazione della scheda), 2 (2D) e 3 (3D).

Definizione e modifica interattiva della sagoma della scheda

La sagoma della scheda viene creata a partire da una o più regioni della scheda. Per chi lavora a un progetto di scheda con un'unica regione, è possibile utilizzare i seguenti comandi per definire la sagoma della scheda:

  • Board Planning Mode (standard Rigid-Flex mode - the Active Bar at the top of the graphical editing space has two buttons):
    • Design » Redefine Board Shape - utilizza questo comando per ridisegnare in modo interattivo la forma della scheda. Nota che questo comando non è disponibile se la modalità Rigid-Flex avanzata è stata abilitata in Layer Stack Manager. Se la scheda è in modalità Rigid-Flex avanzata, è sufficiente fare clic per selezionare la forma e modificarla utilizzando le tecniche standard di modifica degli oggetti poligonali.

    • Design » Edit Board Shape - utilizza questo comando per spostare e rimodellare i bordi della forma della scheda, utilizzando le tecniche standard di modifica degli oggetti poligonali.

      • Nota che questo comando non è disponibile se la modalità Rigid-Flex avanzata è stata abilitata in Layer Stack Manager. Se la scheda è in modalità Rigid-Flex avanzata, è sufficiente fare clic per selezionare la forma e modificarla utilizzando le tecniche standard di modifica degli oggetti poligonali.

      • Prima di selezionare il comando, assicurati che l'opzione Other sia abilitata nel Filtro di selezione, in modo da poter utilizzare il comando ().

  • Board Planning Mode (Advanced Rigid-Flex mode - the Active Bar at the top of the graphical editing space has six buttons):
    • Place » Board Region - utilizza questo comando per definire in modo interattivo la regione della scheda (per una scheda con un'unica regione, la regione della scheda ne definisce la forma). Scopri di più sul Posizionamento di una regione della scheda.
  • 2D Layout Mode:
    • Design » Board Shape » Define Board Shape from Selected Objects - seleziona un insieme di primitive di linea e/o arco che definiscono una forma chiusa, quindi utilizza questo comando per ridefinire la forma della scheda in modo che corrisponda a tale forma.

    • Design » Board Shape » Create Primitives from Board Shape - crea un insieme di primitive lungo il contorno della forma della scheda, in base alle impostazioni configurate nella finestra di dialogo Primitive di linea/arco dalla forma della scheda.

  • 3D Layout Mode:
    • Design » Board Shape » Define Board Shape from 3D body - utilizza questo comando per definire la forma della scheda selezionando la superficie desiderata di un modello 3D.

Inoltre, quando sei in modalità di pianificazione della scheda, puoi utilizzare i seguenti comandi:

  • Design » Modify Board Shape - utilizza questo comando per modificare la forma della scheda esistente posizionando ulteriori vertici e definendo così ulteriormente la sagomatura del contorno.

  • Design » Move Board Shape - utilizzare questo comando per spostare la sagoma della scheda in un'altra posizione nel documento corrente. Questo comando sposta solo la sagoma della scheda. Il progetto vero e proprio e gli oggetti che lo compongono rimangono nella posizione originale.

    Dopo aver avviato il comando, una copia del contorno della sagoma verrà agganciata al cursore tramite l'angolo inferiore sinistro. Spostare la sagoma nella nuova posizione desiderata all'interno dell'area di lavoro, quindi fare clic oppure premere Enter per confermare il posizionamento. Durante lo spostamento, premere Spacebar per ruotare la sagoma della scheda in senso antiorario oppure Shift+Spacebar per ruotarla in senso orario (l'ampiezza di Rotation Step è definita nella pagina PCB Editor – General della finestra di dialogo Preferences), oppure premere i tasti X o Y per specchiare la sagoma della scheda rispettivamente lungo l'asse X o Y. Per annullare senza spostare la sagoma, fare clic con il pulsante destro del mouse oppure premere Esc.

  • Design » Move Board - utilizzare questo comando per spostare l'intera scheda, ovvero la sagoma della scheda e tutti gli oggetti di progetto al suo interno, in un'altra posizione nel documento corrente.

    Dopo aver avviato il comando, una copia del contorno della sagoma della scheda verrà agganciata al cursore tramite l'angolo inferiore sinistro. Spostare la sagoma nella nuova posizione desiderata all'interno dell'area di progettazione, quindi fare clic oppure premere Enter per confermare il posizionamento. Anche tutti gli oggetti che compongono il progetto verranno spostati per mantenere la propria posizione all'interno della sagoma della scheda. Per annullare senza effettuare lo spostamento, fare clic con il pulsante destro del mouse oppure premere Esc.

La differenza tra il comando Define Board Shape from Selected Objects e il comando Create Board Region from Selected Objects è che il primo sostituisce tutte le regioni della scheda esistenti con la nuova regione creata all'esecuzione del comando, mentre il secondo crea una regione della scheda aggiuntiva, senza rimuovere quelle esistenti.

Definizione della sagoma della scheda a partire da oggetti selezionati

La sagoma della scheda può essere definita anche a partire da oggetti selezionati (in modalità layout 2D). In genere si tratta di un insieme di linee e/o archi posizionati sul layer Keepout o su un layer meccanico.

Procedere come segue:

  1. Impostare la modalità di visualizzazione su 2D Layout Mode (menu View).
  2. Aprire il pannello View Configuration e fare doppio clic per modificare il layer meccanico che contiene la sagoma della scheda. Si aprirà la finestra di dialogo Edit Layer, in cui è possibile impostare Layer Type su Board Shape, come mostrato nel video seguente.
  3. Rendere attivo il layer meccanico che contiene la sagoma e selezionare gli oggetti. Il comando Edit » Select » All on Layer è ideale a questo scopo; l'insieme degli oggetti selezionati deve includere solo le piste e gli archi che costituiscono il contorno della scheda.
  4. Una volta selezionati tutti gli oggetti, eseguire il comando Design » Board Shape » Define Board Shape from Selected Objects. La sagoma della scheda verrà aggiornata seguendo il percorso definito dalle linee selezionate. Se il software non riesce a seguire la linea mediana degli oggetti selezionati, verrà visualizzata una finestra di avviso. La modalità di visualizzazione passerà a Board Planning Mode.

Dimostrazione della sagoma della scheda in modalità Rigid-Flex standard

Il video mostra come creare la sagoma della scheda a partire da oggetti selezionati e quindi posizionare le linee di divisione per creare le tre regioni necessarie.

Dimostrazione della sagoma della scheda in modalità Rigid-Flex avanzata

Il video mostra innanzitutto come creare la sagoma della scheda a partire da oggetti selezionati e quindi suddividerla per creare le tre regioni necessarie. Mostra poi un approccio alternativo, in cui
le tre regioni della scheda vengono definite a partire da oggetti selezionati. Si noti che queste dimostrazioni utilizzano le funzionalità Rigid-Flex 2.0, come descritto all'inizio di questa pagina.

Il software tenterà di individuare la sagoma in base alla linea mediana degli oggetti selezionati. Se le coordinate dell'estremità di un segmento di pista/arco non corrispondono esattamente a quelle del segmento di pista/arco successivo, l'algoritmo di identificazione del contorno non riuscirà a completare l'operazione e verrà visualizzato un messaggio che indica la posizione del problema. Verrà proposto di utilizzare invece un algoritmo di tracciamento. Si noti che l'algoritmo di tracciamento segue il bordo esterno degli oggetti pista/arco, quindi la sagoma della scheda sarà leggermente diversa da quella creata a partire dalle linee mediane. Scegliere questa opzione solo se il progetto può tollerare gli effetti di tale differenza.

Importazione di un contorno da utilizzare per la sagoma della scheda

La sagoma della scheda può essere definita a partire da un contorno chiuso importato come dati DXF/DWG.

Combinando la possibilità di importare dati DXF/DWG in un layer meccanico con la definizione della sagoma della scheda a partire da oggetti selezionati, è possibile trasferire nell'editor PCB una sagoma definita in un software CAD meccanico.

Per preparare la nuova scheda all'importazione:

  1. Selezionare File » New » PCB. Si aprirà un nuovo PCB vuoto; la regione nera rappresenta la sagoma attuale della scheda.
  2. Prima di importare una nuova sagoma, configurare le seguenti impostazioni in base alle esigenze del progetto e alla sagoma da importare:
  • Unità di misura - impostare le unità desiderate nella sezione Other del Properties pannello in modalità Board (mostra immagine).
  • Griglia - fare doppio clic sulla griglia di aggancio globale della scheda e configurarla secondo necessità nella sezione Grid Manager del Properties pannello in modalità Board (mostra immagine).
  • Origine - Per un nuovo PCB, la posizione predefinita dell'origine definibile dall'utente coincide con l'origine assoluta, nell'angolo inferiore sinistro dell'area di progettazione. Selezionare Edit » Origin » Set dai menu principali, quindi fare clic per definire la posizione dell'origine definibile dall'utente, ad esempio nell'angolo inferiore sinistro della sagoma attuale della scheda. È utile impostarla in modo che corrisponda alla posizione dell'origine del contorno da importare.

Il passaggio successivo consiste nell'importare la sagoma della scheda come file .DXF o .DWG. Si noti che la sagoma da importare deve essere chiusa e che le aperture interne non vengono create automaticamente (ma possono essere definite in seguito a partire dagli oggetti importati).

  1. Selezionare File » Import » DXF/DWG per aprire la finestra di dialogo Import File, quindi assicurarsi che File Type in basso a destra nella finestra sia AutoCAD Files (*.DXF, *.DWG) e individuare il file desiderato. 
  2. Facendo clic sul pulsante Open, si apre la finestra di dialogo Import from AutoCAD (mostra immagine).
  3. Impostare Scale, Default Line Width e Layer Mappings secondo necessità, quindi fare clic su OK.
  4. Ogni oggetto DXF/DWG verrà mappato su un oggetto e visualizzato nell'area di progettazione. 
  5. Rendere attivo il layer meccanico che contiene gli oggetti della sagoma della scheda, quindi selezionare tutti gli oggetti su quel layer (Edit » Select » All on Layer).
  6. Per aggiornare la sagoma della scheda in modo che corrisponda al contorno selezionato, eseguire il comando Design » Board Shape » Define from Selected Objects.
  7. Se la scheda include aperture, è possibile crearle selezionando il contorno dell'apertura ed eseguendo il comando Tools » Convert » Create Board Cutout from Selected Primitives.

Il software tenterà di individuare la sagoma in base alla linea mediana degli oggetti selezionati. Se le coordinate dell'estremità di un segmento di pista/arco non corrispondono esattamente a quelle del segmento di pista/arco successivo, l'algoritmo di identificazione del contorno non riuscirà a completare l'operazione e verrà visualizzato un messaggio che indica la posizione del problema. Verrà proposto di utilizzare invece un algoritmo di tracciamento. Si noti che l'algoritmo di tracciamento segue il bordo esterno degli oggetti pista/arco, pertanto la sagoma della scheda sarà leggermente diversa da quella creata a partire dalle linee mediane. Scegliere questa opzione solo se il progetto può tollerare l'impatto di tale differenza.

Definizione della sagoma della scheda a partire da un corpo 3D

Questa funzionalità ridefinisce la sagoma della scheda in base a una superficie (faccia) di un modello 3D importato. I formati di modello supportati includono: STEP (*.Stp o *.STEP), Parasolid (*.x_t o *x_b) o un file di parte SOLIDWORKS (*.SldPrt). Può essere utilizzata per creare rapidamente una sagoma complessa della scheda e facilita l'integrazione tra la progettazione elettronica e quella meccanica. Il processo si articola in due fasi: prima si importa il modello STEP, quindi si seleziona la sagoma desiderata dal modello STEP. 

Per definire la sagoma della scheda è possibile utilizzare solo una superficie piatta (planare).

Per procedere:

  1. Passare a View » 3D Layout Mode (scorciatoia: 3).
  2. Per importare il modello 3D, posizionare un corpo 3D (Place » 3D Body).
  3. Nella finestra di dialogo Choose Model, individuare e selezionare il file del modello. Il modello 3D verrà importato nell'editor PCB e memorizzato all'interno di un oggetto corpo 3D. Si noti che, se necessario, questo modello può essere eliminato dal PCB dopo aver ridefinito la sagoma della scheda.
  4. Selezionare Design » Board Shape » Define Board Shape from 3D body.
  5. La barra di stato richiederà di Pick a 3D body. Fare clic sul corpo 3D importato per selezionarlo. Il modello diventerà trasparente.
  6. Il cursore assumerà la forma di un mirino e la barra di stato richiederà di Choose Face. Passando il cursore su ciascuna faccia, ne verrà evidenziato il contorno. Quando sotto il cursore viene rilevata una superficie piana, questa diventa opaca con un sottile bordo blu. Fare clic per selezionare la faccia corretta.
  7. Verrà visualizzata la finestra di dialogo Board Outline Creation Successful , con le opzioni per scegliere quale superficie del PCB allineare alla superficie selezionata (in genere il layer superiore) e se nascondere il modello 3D alla vista ed escluderlo dal controllo delle regole di progettazione. Se necessario, le impostazioni di visibilità e disattivazione possono essere modificate in seguito nella modalità Modelli 3D del pannello PCB.

Si noti che, se si mantiene il modello STEP incorporato nel file PCB o collegato a esso, si riceverà una notifica ogni volta che il file STEP viene modificato. Verrà inoltre richiesto di aggiornare la sagoma, una funzione utile quando questa è ancora in fase di sviluppo e sono previsti aggiornamenti.

Per creare la sagoma della scheda è possibile utilizzare solo superfici allineate al piano X-Y. Se si seleziona una superficie del modello che richiede l'allineamento al piano X-Y, una finestra di dialogo di conferma richiederà di allineare la superficie prima di continuare. Questa finestra consente inoltre di posizionare il modello utilizzando la faccia selezionata rispetto alla superficie superiore o inferiore della scheda. Ciò significa che è possibile impostare contemporaneamente anche la posizione verticale del modello. Dopo l'allineamento, sarà necessario selezionare nuovamente Design » Board Shape » Define from 3D Body. Una volta ridefinita la sagoma della scheda, verrà offerta la possibilità di nascondere il corpo 3D.

Creazione di primitive a partire dalla sagoma della scheda

Oltre a definire la sagoma della scheda a partire dalle primitive selezionate, è possibile creare primitive dalla sagoma della scheda utilizzando il comando Design » Board Shape » Create Primitives from Board Shape. Questo comando apre la finestra di dialogo Line/Arc Primitives from Board.

La finestra di dialogo Line/Arc Primitives From Board Shape
La finestra di dialogo Line/Arc Primitives From Board Shape

Utilizzare questo comando quando la sagoma della scheda esiste, ma lungo il suo contorno non sono presenti oggetti. Tra le situazioni in cui questo comando può risultare utile:

  • Quando si desidera modificare la sagoma della scheda (o le aperture della scheda) modificando prima le primitive pista e arco.
  • Quando è necessario un contorno di esclusione per la scheda o contorni di esclusione per le aperture della scheda sul layer Keep-Out. Questo argomento è trattato più dettagliatamente nella sezione Considerazioni importanti di progettazione per l'utilizzo delle aperture della scheda riportata di seguito.

    Se il layer di destinazione specificato è il layer Keep-Out, gli oggetti di esclusione specifici per tipo di oggetto verranno posizionati direttamente sul layer (piste e archi di esclusione).

Creazione di un foro nella sagoma della scheda

Un ritaglio della scheda può essere posizionato in qualsiasi punto della sagoma della scheda. Per posizionare un ritaglio, passa alla visualizzazione della scheda in modalità Layout 2D quindi utilizza il comando Design » Board Shape » Define Board Cutout dai menu principali (in alternativa, puoi utilizzare anche il comando Place » Define Board Cutout in modalità Pianificazione scheda). Nota che il ritaglio è in realtà un oggetto Regione configurato come oggetto negativo.

Un ritaglio della scheda è stato posizionato sulla sagoma della scheda.Un ritaglio della scheda è stato posizionato sulla sagoma della scheda.

Se il ritaglio della scheda ha una forma particolare, ad esempio circolare, può essere più semplice crearne il contorno utilizzando piste e archi (ad esempio, Place » Arc » Full Circle), selezionare la forma e quindi convertirla in un ritaglio della scheda (Tools » Convert » Create Board Cutout from Selected Primitives).

Considerazioni progettuali importanti quando si utilizzano i ritagli della scheda

Mantenere un poligono a distanza dal bordo di un ritaglio della scheda

I poligoni che si sovrappongono a un ritaglio della scheda costituito da una regione piena verranno riempiti fino alla distanza minima dal bordo del ritaglio consentita dalla regola di progettazione Clearance applicabile. Se necessario, è possibile creare una regola di progettazione Clearance specifica, il cui ambito di applicazione potrebbe, ad esempio, essere definito tra IsBoardCutoutRegion e InPolygon.

Definire un percorso utensile di fresatura lungo il bordo della scheda e dei ritagli

Un metodo comune per separare la scheda finita dal pannello di produzione consiste nel fresarne il contorno. Anche i ritagli della scheda possono essere realizzati mediante fresatura. Il percorso utensile di fresatura viene definito posizionando oggetti Linea e/o Arco su un layer meccanico. Questa operazione può essere eseguita manualmente o automaticamente dal software.

Per definire un percorso utensile di fresatura per la scheda e gli eventuali ritagli:

  1. Con la scheda in modalità Layout 2D, esegui il comando Design » Board Shape » Create Primitives From Board Shape. Si aprirà la finestra di dialogo Line/Arc Primitives From Board Shape.

  2. Definisci un valore adeguato di Width per gli oggetti che definiranno il percorso utensile di fresatura. In caso di dubbi, consulta il produttore.

  3. Seleziona un layer meccanico disponibile. Questo layer deve essere riservato esclusivamente alla definizione del percorso utensile di fresatura.

  4. Abilita l'opzione Include Cutouts se la scheda contiene ritagli.

  5. Abilita l'opzione Route Tool Outline. Quando questa opzione è abilitata, gli oggetti linea/arco vengono posizionati in modo che il loro bordo tocchi il bordo della sagoma della scheda e quello del ritaglio.

  6. Fai clic su OK per creare gli oggetti del percorso utensile di fresatura sul layer meccanico scelto. 

  7. Il layer meccanico utilizzato deve essere impostato come layer Route Tool. Per farlo, accedi alla scheda Layers & Colors del pannello View Configuration. Fai clic con il pulsante destro del mouse all'interno di una griglia dei layer e scegli il comando Add Mechanical Layer. Nella finestra di dialogo Edit Layer che si apre, imposta Layer Type su Route Tool Path.  Questo tipo di layer viene utilizzato per indicare il layer che contiene le informazioni di fresatura meccanica.

    Nota che non è consentito utilizzare un nome definito dall'utente quando Layer Type è impostato su Route Tool Path. Questo perché le versioni precedenti del software utilizzano il nome del layer Route Tool Path per identificare il layer che contiene le informazioni di fresatura (indicate anche come informazioni di rout). Mantenere fisso il nome di questo layer garantisce che il progetto continui a funzionare correttamente nelle versioni precedenti.

Le immagini seguenti mostrano il percorso utensile di fresatura definito su un layer meccanico.

Un ritaglio della scheda nella prima immagine, con un percorso utensile di fresatura definito nella seconda. Un ritaglio della scheda nella prima immagine, con un percorso utensile di fresatura definito nella seconda.

Keepout e sagoma della scheda

Oltre alla sagoma della scheda, è opportuno definire anche un limite per il posizionamento e lo sbroglio lungo il bordo della scheda. Questo limite può essere creato automaticamente a partire dalla sagoma stessa utilizzando il comando Design » Board Shape » Create Primitives From Board Shape (in modalità Layout 2D) e impostando Layer nella finestra di dialogo Line/Arc Primitives from Board su Keep-Out Layer.

In alternativa, è possibile farlo manualmente posizionando oggetti sul layer keepout. Gli oggetti posizionati su questo layer definiscono un limite no-crossing-allowed per i componenti e lo sbroglio. In genere, è necessario che oggetti quali componenti e piste si trovino a una determinata distanza dal bordo della scheda; questa distanza può essere controllata impostando le regole di progettazione applicabili allo sbroglio e al posizionamento dei componenti. È inoltre possibile definire altre aree di keepout per piste e componenti in corrispondenza di elementi meccanici, come le teste delle viti, o per altre esigenze di montaggio.

Un limite di keepout definito posizionando oggetti linea standard sul layer keepout (viola).Un limite di keepout definito posizionando oggetti linea standard sul layer keepout (viola).

  • I limiti di keepout possono essere definiti posizionando qualsiasi oggetto di progettazione standard, come linee, archi, riempimenti e regioni, sul layer Keepout. Gli oggetti posizionati sul layer Keepout creano un keepout su tutti i layer di segnale.
  • È inoltre possibile definire keepout specifici per un layer su qualsiasi layer di rame. Per farlo:
  1. Fai clic sulla scheda del layer desiderato.
  2. Definisci il contorno o l'area di keepout posizionando oggetti keepout specifici per il layer (sottomenu Place » Keepout). I keepout specifici per un layer sono oggetti standard con l'attributo Keepout abilitato. Vengono visualizzati nello stesso colore del layer, con un bordo nel colore dei keepout. Nota che gli oggetti keepout specifici per un layer non sono inclusi nei file di output Gerber o ODB++.
AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents