Lavorare con i layer meccanici
Altium Essentials: PCB Configuration
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
A colpo d'occhio
- Scopri quando utilizzare un singolo layer meccanico oppure una coppia di layer dei componenti, in particolare per le informazioni che riguardano uno o entrambi i lati della scheda.
- Scopri come aggiungere, configurare e gestire i layer meccanici nel pannello View Configuration, inclusi nomi, numeri, visibilità e tipi di layer.
- Comprendi come i tipi di layer predefiniti e le impostazioni delle librerie PCB influiscono sulla creazione e sulla mappatura automatiche dei layer nel progetto della scheda.
Anche la scheda più semplice richiede dettagli di progettazione oltre alle piste e alle piazzole che realizzano il circuito. Può trattarsi delle dimensioni della scheda o dei dettagli di fabbricazione, delle aree di ingombro dei componenti oppure dei modelli 3D dei componenti. In Altium Designer, questo tipo di informazioni aggiuntive viene riportato sui layer meccanici.
Layer meccanici e coppie di layer dei componenti
Se le informazioni da includere su un layer meccanico non riguardano un lato specifico della scheda, ad esempio note di fabbricazione che descrivono l'ordine dei layer, viene aggiunto un individual mechanical layer.
Se le informazioni sono necessarie su entrambi i lati della scheda, ad esempio le aree di ingombro dei componenti, vengono assegnati due layer meccanici: uno contiene i dettagli dell'area di ingombro quando il componente è posizionato sul lato superiore della scheda; l'altro contiene l'immagine speculare degli stessi dettagli quando il componente viene ribaltato sul lato inferiore della scheda. In questo caso, viene aggiunta una coppia di layer meccanici come Component Layer Pair. Quando i layer meccanici vengono aggiunti come coppia di layer dei componenti, vengono visualizzati nella sezione Component Layer Pairs del pannello View Configuration, come mostrato di seguito. Sotto di essa si trovano i singoli Mechanical Layers.

Sono state aggiunte diverse coppie di layer dei componenti definite dall'utente.
| Display of Layer Pairs | Nell'area di progettazione, i due layer di una coppia di layer dei componenti vengono visualizzati in schede separate con i nomi Top <LayerPairName> e Bottom <LayerPairName> |
| In the Library editor | Nell'editor delle librerie PCB, gli oggetti di progettazione aggiuntivi necessari nel footprint di un componente vengono posizionati sul layer superiore della coppia di layer dei componenti. Quando il componente viene ribaltato sul lato inferiore della scheda durante il layout del PCB (scorciatoia L durante lo spostamento del componente), il contenuto del layer superiore della coppia viene automaticamente riportato specularmente sul layer inferiore della coppia. |
| Automatic layer creation | Se a un layer meccanico o a una coppia di layer dei componenti definiti nella libreria PCB è assegnato un tipo di layer, tale layer meccanico o coppia di layer viene creato automaticamente sul PCB quando viene posizionato un componente che utilizza quei layer. Se il PCB contiene già un layer meccanico o una coppia di layer con quel tipo di layer, i contenuti vengono associati di conseguenza. |
| Layers without a Layer Type |
Per i layer meccanici o le coppie di layer definiti nella libreria PCB a cui non è assegnato un tipo di layer nella libreria, sul PCB vengono creati layer meccanici singoli. In questo caso, prima di posizionare il componente, definire sul PCB il layer meccanico o la coppia di layer utilizzando gli stessi numeri di layer, poiché il software ricorrerà alla corrispondenza per numero di layer se non riesce a trovare una corrispondenza per tipo di layer. |
Aggiunta di layer meccanici al progetto
I layer meccanici vengono aggiunti, modificati e rimossi nel pannello Configurazione vista, come mostrato di seguito. Nel pannello si configurano anche la visibilità e il colore. Utilizzare il pulsante
in basso a destra nell'area di progettazione, quindi selezionare View Configuration, oppure premere il tasto di scelta rapida L per visualizzare il pannello.
Fare clic con il pulsante destro del mouse in un punto qualsiasi dell'area Layers del pannello per visualizzare il menu contestuale, che contiene i comandi per Add Component Layer Pair (una coppia di layer meccanici) e Add Mechanical Layer (un singolo layer meccanico).
I layer meccanici singoli o in coppia vengono aggiunti tramite il menu contestuale del pannello View Configuration.
Aggiunta di un singolo layer meccanico
Quando si seleziona il comando Add Mechanical Layer dal menu contestuale del pannello View Configuration per aggiungere un singolo layer meccanico, si apre la finestra di dialogo Edit Layer.
Configurare il nuovo layer meccanico.
Finestra di dialogo Modifica layer |
|
| Layer Name | Può essere un nome di layer definito dall'utente oppure assegnato dal sistema se viene scelto un tipo predefinito nel menu a discesa Layer Type. Se si seleziona un tipo di layer predefinito e poi si inserisce un nome definito dall'utente in questo campo, il tipo di layer assegnato apparirà tra parentesi accanto al nome definito dall'utente nel pannello View Configuration. |
| Layer Number | Il numero del layer meccanico che si sta configurando; viene proposto il primo numero di layer disponibile. Se viene selezionato un altro numero già in uso, apparirà un'icona di avviso Per continuare, è necessario assegnare un numero di layer non utilizzato. |
| Layer Type | Il tipo di layer può essere non assegnato (N/A), oppure è possibile selezionare un tipo dall'elenco. I tipi di layer disponibili sono descritti di seguito. |
Tipi di layer meccanici disponibili
| Assembly Notes | Spesso utilizzato per descrivere l'ordine di montaggio dei componenti e/o istruzioni di assemblaggio importanti. |
| Board | Utilizzare questo layer per istruzioni o dettagli relativi alla scheda. |
| Board Shape | Utilizzare questo layer per il contorno complessivo della scheda (forma della scheda). |
| Dimensions | Utilizzato per definire i dettagli dimensionali necessari per la scheda. |
| Fab Notes | Utilizzato per riportare importanti note di fabbricazione. |
| Route Tool Path | Utilizzato per indicare il layer che contiene le informazioni sulla fresatura meccanica. Si noti che, quando si utilizza questo tipo di layer, non è consentito un nome definito dall'utente |
| Sheet | Utilizzare questo layer per definire il bordo esterno del modello di disegno del documento. Per i dettagli, consultare la sezione Rappresentazione e impostazioni del foglio di seguito. |
| V Cut | Utilizzato per definire i dettagli dei tagli a V. I tagli a V servono a separare le schede mediante l'incisione di una scanalatura a "V" sui lati superiore e inferiore del circuito stampato, lasciando una quantità minima di materiale per tenere unite le schede nel pannello. |
Aggiunta di una coppia di layer dei componenti
Quando si seleziona il comando Add Component Layer Pair dal menu contestuale del pannello View Configuration, accessibile con il tasto destro del mouse, si apre la finestra di dialogo Edit Layers Pair.
Finestra di dialogo Edit Layers Pair |
|
| Layer Name | Può essere un nome di layer definito dall'utente oppure assegnato dal sistema se si sceglie un tipo predefinito nel menu a discesa Layer Type. Se si seleziona un tipo di layer predefinito e poi si inserisce un nome personalizzato in questo campo, il tipo di layer assegnato apparirà tra parentesi accanto al nome personalizzato nel pannello View Configuration. |
| Layer Number | I numeri dei layer meccanici in fase di configurazione; vengono proposti i primi numeri di layer disponibili. Se si seleziona un altro numero già in uso, apparirà un'icona di avviso Per continuare sarà necessario assegnare un numero di layer non utilizzato. |
| Layer Type | Il tipo di layer può essere non assegnato (N/A), oppure è possibile selezionare un tipo dall'elenco. I tipi di layer disponibili sono descritti di seguito. |
Tipi disponibili di coppie di layer dei componenti
| Assembly | Utilizzato per disegnare e dettagliare i dati di assemblaggio del componente. Questo layer può essere incluso in una vista di assemblaggio della scheda in Draftsman e quindi selezionato come Geometry Source per i componenti nella finestra di dialogo Component Display Properties di Draftsman. Scopri di più su Draftsman. |
| Coating | Utilizzato per definire le aree del componente che richiedono un rivestimento protettivo. |
| Component Center | Utilizzato per indicare il centroide del componente, fornendo nella documentazione di assemblaggio un riferimento visivo della posizione utilizzata dalla macchina di piazzamento dei componenti. |
| Component Outline | Utilizzato per definire il contorno del corpo del componente, che rappresenta l'area occupata dal componente sulla scheda. |
| Courtyard | Utilizzato per definire lo spazio necessario per il posizionamento di un componente. In genere, il Courtyard delinea il componente e le piazzole, includendo un adeguato margine di rispetto il contorno verde è il Courtyard). Scopri di più sulla creazione di footprint personalizzati. La forma definita sul layer Courtyard viene utilizzata anche per la selezione dei componenti, per definire l'area del componente e per il rilevamento delle collisioni quando il componente non include un corpo 3D. |
| Designator | Utilizza questo layer per posizionare la stringa speciale .Designator. Questa coppia di layer può quindi essere inclusa nei disegni di assemblaggio che richiedono la visualizzazione del designatore del componente. Scopri di più sulle stringhe speciali. |
| Dimensions | Utilizzato per definire i dettagli dimensionali richiesti per i componenti. |
| Glue Points | Utilizzato per definire i punti di colla dei componenti. |
| Gold Plating | Utilizzato per definire i requisiti di doratura selettiva dei componenti. |
| Value | Utilizza questo layer per posizionare la stringa speciale .Comment. Questa coppia di layer può quindi essere inclusa nei disegni di assemblaggio che richiedono la visualizzazione del valore del componente. Scopri di più sulle stringhe speciali. |
| 3D Body | Utilizza questo layer per il modello meccanico 3D del componente. Scopri di più sul posizionamento dei corpi 3D. |
| Die | Utilizza questo layer per le piazzole e i corpi 3D del die durante la creazione di un componente Chip-on-Board. Scopri di più sul wire bonding. |
| Wire Bonding | Utilizza questo layer per i fili di bonding durante la creazione di un componente Chip-on-Board o direttamente in un documento PCB. Scopri di più sul wire bonding. |
Il vantaggio di assegnare un tipo di layer
Un approccio comune alla gestione dell'utilizzo dei layer meccanici consiste nell'assegnare un numero di layer dedicato a ciascuna funzione meccanica richiesta. Questo approccio richiede che tutti i progettisti rispettino lo stesso schema di assegnazione e numerazione dei layer. Può inoltre creare difficoltà quando si utilizzano componenti provenienti da altre fonti che non seguono lo stesso schema di assegnazione e numerazione. Se è stato utilizzato uno schema diverso, gli oggetti di progettazione devono essere spostati dal layer meccanico attuale a quello assegnato alla funzione corrispondente.
Questo problema viene risolto assegnando una proprietà Layer Type. Quando un componente viene posizionato da una libreria nell'editor PCB, copiato da una libreria a un'altra o creato da IPC Footprint Wizard, le assegnazioni esistenti dei tipi di layer vengono associate automaticamente, indipendentemente dai numeri dei layer meccanici assegnati a tali tipi. Gli oggetti vengono spostati sui layer corretti in base al tipo di layer. Se il software non riesce a trovare una corrispondenza per tipo di layer, utilizzerà il numero del layer.
Sia per i singoli layer meccanici sia per le coppie di layer dei componenti, è possibile selezionare un tipo di layer da un elenco di tipi predefiniti. Le immagini seguenti mostrano l'elenco dei tipi di layer disponibili. È possibile accedere alle finestre di dialogo mostrate di seguito facendo clic con il tasto destro del mouse su un singolo layer e selezionando il comando Edit Layer o Add Component Layer dal menu.

Seleziona il tipo di layer dall'elenco dei tipi predefiniti; a sinistra sono mostrati i singoli layer meccanici, a destra le coppie di layer dei componenti.
Assegnazione dei nomi ai layer con un tipo di layer assegnato
Quando si assegna un tipo di layer, la proprietà del nome del layer viene modificata automaticamente in modo da coincidere con il tipo di layer. Se necessario, è possibile sostituirla inserendo un nome personalizzato. Quando a un layer sono assegnati sia un nome personalizzato sia un tipo di layer, vengono visualizzati entrambi, con il tipo di layer tra parentesi, come mostrato di seguito per la coppia di layer GP (Gold Plating).
Il tipo di layer viene utilizzato per assegnare il nome al layer; se necessario, è possibile modificarlo.
Il tipo di layer Route Tool Path
Esiste un'eccezione al comportamento di assegnazione del nome appena descritto quando viene assegnato un tipo di layer: non è consentito un nome personalizzato quando Layer Type è impostato su Route Tool Path. Questo perché le versioni precedenti del software utilizzano il nome del layer Route Tool Path per identificare il layer che contiene le informazioni di fresatura (denominate anche informazioni di rout). Mantenere fisso il nome di questo layer garantisce che il progetto continui a funzionare correttamente nelle versioni precedenti.
Il tipo di layer Route Tool Path viene utilizzato per indicare il layer che contiene le informazioni di fresatura meccanica. Un approccio tipico all'utilizzo di questo layer consiste nel posizionare tracce e archi lungo il bordo esterno della sagoma della scheda per definire il percorso e la larghezza di lavorazione. Vengono lasciati tratti di materiale pieno per mantenere la scheda all'interno del pannello, quindi si inserisce una serie di piccoli fori attraverso ciascun tratto pieno per creare perforazioni (spesso chiamate mouse-bites), che consentono di staccare la scheda dal pannello una volta completato il processo di assemblaggio.
Quando la scheda è visualizzata in modalità 3D, gli oggetti rilevati sul layer Route Tool Path vengono visualizzati come un'asola fresata nella scheda, come mostrato di seguito.

Gli oggetti rilevati sul layer Route Tool Path vengono utilizzati per visualizzare la scheda fresata in modalità 3D.
Utilizzare la finestra di dialogo Line/Arc Primitives from Board Shape per tracciare il contorno esterno della scheda con piste e archi (come mostrato di seguito). Abilitare l'opzione Route Tool Outline nella finestra di dialogo per posizionare gli oggetti all'esterno della forma della scheda anziché centrarli lungo il bordo. Alcuni progettisti preferiscono aggiungere le informazioni di fabbricazione quando utilizzano la funzione Embedded Board Array per creare un pannello di assemblaggio, anziché includere questi dettagli nel file della singola scheda.
Ulteriori informazioni sulla pannellizzazione delle schede mediante un Embedded Board Array
Definizione del tipo di layer nell'editor delle librerie PCB
Se a un layer meccanico o a una coppia di layer del componente definiti nella libreria PCB è assegnato un tipo di layer, tale layer meccanico o coppia di layer viene creato automaticamente sul PCB quando viene posizionato un componente che utilizza quei layer. Se il PCB contiene già un layer meccanico o una coppia di layer di quel tipo, i contenuti di tali layer vengono mappati di conseguenza.
Ove possibile, si consiglia di modificare la libreria di origine e assegnare i tipi di layer. Quando il footprint di un componente viene posizionato (o copiato) da una libreria, i layer meccanici e le coppie di layer del componente di quei tipi vengono creati automaticamente nella scheda (o nella libreria) di destinazione, se non esistono già. Se tali tipi di layer sono già presenti nella scheda (o nella libreria) di destinazione, i contenuti dei layer vengono mappati automaticamente sul layer corretto.
Ulteriori informazioni sulla gestione dei requisiti speciali specifici dei layer nell'editor delle librerie PCB
Utilizzo dei layer meccanici
I layer meccanici vengono aggiunti, modificati, eliminati e visualizzati tramite il pannello View Configuration nell'editor PCB. Non vengono visualizzati né modificati in Layer Stack Manager.
Visualizzazione
Configurare la visibilità dei layer nel pannello View Configuration e salvare le combinazioni di layer utilizzate di frequente come set di layer definiti dall'utente.
| Controlling layer visibility | Fare clic sull'icona di visibilità accanto al nome del layer per attivare o disattivare la visualizzazione di quel layer meccanico. In alternativa, fare clic per selezionare il nome del layer e quindi premere Spacebar (questa operazione attiva o disattiva la visualizzazione di entrambi i layer di una coppia di layer del componente). |
| Include in Single Layer Mode | I layer meccanici dispongono di una funzione di visualizzazione aggiuntiva: possono essere impostati in modo da rimanere visibili quando la visualizzazione è in modalità a layer singolo. Tenere premuto |
| Include in 3D View Mode | I layer meccanici possono essere inclusi anche nella visualizzazione 3D, quando nelle impostazioni 3D è abilitata l'opzione Colors - By Layer. Abilitare l'opzione nella scheda View Options del pannello View Configuration quando la scheda è visualizzata in modalità 3D. Verranno inclusi i layer meccanici attualmente configurati come visibili |
Modifica ed eliminazione
Per modificare le impostazioni di una coppia di layer del componente o di un layer meccanico esistente, fare doppio clic direttamente sulla relativa voce nel pannello View Configuration (oppure fare clic con il pulsante destro del mouse sulla voce desiderata e scegliere Edit Layer dal menu contestuale). Apportare le modifiche necessarie nella finestra di dialogo Edit Layers Pair / Edit Layer. La visibilità e il colore dei layer meccanici vengono configurati direttamente nel pannello View Configuration.
Per eliminare un layer, fare clic con il pulsante destro del mouse sul layer desiderato e selezionare Delete Layer. A seconda di come viene utilizzato il layer, si possono verificare tre casi:
| Nothing on the layer | Se sul layer non sono presenti primitive, viene eliminato immediatamente quando si seleziona Delete Layer (senza conferma). |
| Contains unlocked primitives | Se sul layer sono presenti primitive non bloccate, viene visualizzata una finestra popup che richiede la conferma dell'eliminazione. |
| Contains locked primitives | Se sul layer sono presenti primitive bloccate, ad esempio primitive che appartengono a un componente, viene visualizzata una finestra popup di errore che segnala l'impossibilità di completare l'operazione. |
Esportazione e importazione
La struttura dei layer meccanici e delle coppie di layer del componente aggiunti a un PCB può essere duplicata su un altro PCB esportandola in un file dal documento PCB di origine e quindi importando il file nel documento PCB di destinazione.
Esportazione / importazione dei layer
-
Nel documento PCB di origine in cui è stata aggiunta la struttura desiderata di layer meccanici e coppie di layer del componente, utilizzare il comando Tools » Export Mechanical Layers dai menu principali. Nella finestra di dialogo Export Mechanical Layers che si apre, definire il nome e la cartella del file
*.stackupche conterrà i dati sulla struttura dei layer meccanici. -
Nel documento PCB di destinazione, utilizzare il comando Tools » Import Mechanical Layers dai menu principali e, nella finestra di dialogo Import Mechanical Layers che si apre, selezionare il file
*.stackupsalvato. La struttura aggiunta di layer meccanici e coppie di layer del componente è visibile nel pannello View Configuration.
Copia / incolla dei contenuti dei layer
Si noti che i comandi di importazione/esportazione trasferiscono la struttura dei layer meccanici e delle coppie di layer del componente, ma non il contenuto di questi layer.
Per copiare il contenuto di:
-
Un singolo layer meccanico, utilizzare il comando Edit » Select » All on Layer quando il layer desiderato è quello attivo nel PCB di origine, quindi utilizzare la procedura standard di copia/incolla per replicare i dati nel PCB di destinazione.
-
Più layer meccanici: configurare la visibilità dei layer nel pannello View Configuration in modo da visualizzare solo i layer meccanici necessari, quindi trascinare un rettangolo di selezione per intersezione (da destra a sinistra) intorno a tutte le primitive richieste nel PCB di origine e utilizzare la procedura standard di copia/incolla per replicare i dati nel PCB di destinazione.
Impostazioni di presentazione e di output
I layer meccanici vengono spesso utilizzati per riportare informazioni da includere nelle stampe o nei file di output per la fabbricazione. Queste possono comprendere modelli di disegno, istruzioni di fabbricazione, istruzioni di assemblaggio e così via. Se necessario, è possibile farlo direttamente nell'editor PCB.
Se necessario, le informazioni della documentazione di produzione della scheda possono essere incluse nei layer meccanici.
In alternativa, queste attività di documentazione possono essere svolte in Draftsman, un ambiente di editing grafico avanzato e flessibile per la creazione di documenti di produzione della scheda. Dotato di un set dedicato di strumenti di disegno, il sistema di disegno Draftsman offre un approccio interattivo per riunire disegni di fabbricazione e assemblaggio con modelli personalizzati, annotazioni, quote, richiami e note.
Scopri di più su Draftsman
Presentazione e impostazioni del foglio
L'immagine sopra mostra uno sfondo bianco che si adatta esattamente agli oggetti di disegno posizionati per rappresentare il modello del foglio. Questo sfondo viene creato aggiungendo un layer meccanico con Layer Type impostato su Sheet, che viene quindi utilizzato per definire il bordo esterno del modello di disegno del documento.
Le dimensioni di questo sfondo bianco sono definite da Sheet Settings, che può essere personalizzato nel pannello Properties quando non è selezionato alcun elemento nell'area di modifica. I valori X/Y dell'angolo inferiore sinistro del foglio, nonché Width e Height, possono essere configurati manualmente. In alternativa, quando l'opzione Get Size From Sheet Layer è abilitata, lo sfondo del foglio viene calcolato automaticamente a partire dal rettangolo di delimitazione dell'insieme di oggetti posizionati sul layer meccanico di tipo Sheet.
Le dimensioni dello sfondo del foglio possono essere determinate automaticamente in base agli oggetti posizionati sul layer di tipo Sheet.
Il colore e la visibilità dello sfondo del foglio vengono configurati nella sezione System Colors del pannello View Configuration. Fare clic sul pulsante del colore per modificare il colore di Sheet Line e Area Color. Passare a
/
per mostrare/nascondere il foglio.
Inclusione dei layer meccanici nell'output
I layer meccanici vengono utilizzati per un'ampia varietà di attività, riportando informazioni utili durante la progettazione, la fabbricazione e l'assemblaggio della scheda e la documentazione del prodotto. Per soddisfare tutte queste esigenze, i layer meccanici possono essere esclusi o inclusi in tutte le forme di generazione di output basate sui layer, comprese la stampa e la generazione di file di output.
Output di stampa
Qualsiasi layer presente nel progetto, compresi i layer meccanici, può essere incluso nella definizione di una stampa del PCB. Le stampe vengono configurate aggiungendo i layer richiesti e impostandone l'ordine nella finestra di dialogo Print.

È possibile creare disegni di fabbricazione e assemblaggio altamente dettagliati posizionando gli oggetti sui layer meccanici.
Scopri di più su Preparazione dell'output PCB 2D per la stampa
Output generati
Tutti gli output per la fabbricazione, come Gerber e ODB++, consentono di includere i layer meccanici come Layer to Plot di output oppure di aggiungerli come dettagli a ogni layer da tracciare. L'output viene generato quando viene eseguito il generatore di output configurato, ad esempio utilizzando un generatore di output ODB in un file di configurazione OutputJob (*.OutJob).

I layer meccanici possono essere tracciati oppure, se necessario, aggiunti a tutti i tracciati.
Scopri di più su Preparazione del progetto per la produzione
).
).



).