템플릿을 통한 패드 작업

개요

이 문서에서는 Altium Designer가 Pad 및 비아 템플릿을 활용하여 PCB 설계의 재사용성, 일관성 및 관리 효율을 높이는 방법을 설명합니다. 보드에서 로컬 템플릿이 자동으로 생성되는 방식, 외부 Pad Via Template 라이브러리를 사용할 수 있도록 설정하는 방법, PCB Pad Via Templates Panel을 중심으로 템플릿 정의를 확인, 배치, 필터링 및 관리하는 방법을 살펴봅니다. 또한 템플릿이 라이브러리 소스와의 연결을 유지하는 방식, 이러한 연결이 편집에 미치는 영향, 설계 워크플로 전반에서 템플릿을 적용할 수 있는 위치도 설명합니다. 이 도구들을 통해 작업 효율과 제어 수준을 높이는 방법을 알아보세요.

- 로컬 Pad 및 비아 템플릿과 외부 Pad Via 라이브러리에 저장된 템플릿의 차이점, 그리고 PCB 설계에서 각 템플릿을 사용하는 방법을 알아봅니다.
- PCB Pad Via Templates Panel에서 템플릿을 배치하고, 사용 가능한 라이브러리를 검토하고, 템플릿 목록을 필터링하고, 현재 보드에서 이미 사용 중인 템플릿을 확인하는 방법을 살펴봅니다.
- 템플릿 이름이 생성되는 방식, 연결된 라이브러리 템플릿이 편집 가능 여부에 미치는 영향, 설계 규칙 및 PCB 워크플로에서 템플릿을 적용할 수 있는 위치를 알아봅니다.
AI로 더 깊이 알아보기:
 

Track 객체와 함께 Pad와 비아는 모든 회로 기판 설계의 기본 요소입니다. 각 Pad와 비아는 배치 중이나 배치 후에 사용자 지정 객체로 구성할 수 있습니다.

3D로 표시된 Pad와 비아 
3D로 표시된 Pad와 비아

PCB 설계에서 Pad와 비아의 설계 재사용 및 관리 기능을 향상하기 위해 Altium Designer는 Pad 및 비아 템플릿 자동 생성, Pad 및 비아 템플릿 라이브러리, 관련 Pad 및 비아 관리 Panel도 지원합니다.

라이브러리에 모아 둘 수 있는 Pad 및 비아 템플릿의 개념은 PCB 풋프린트 라이브러리와 유사하지만, 좀 더 단순합니다. Pad 비아 템플릿 라이브러리는 실제 Pad와 비아를 저장하는 대신, Pad 또는 비아 인스턴스를 배치할 때 적용되는 사전 구성된 정의를 저장합니다. 저장된 Pad 비아 템플릿 라이브러리를 로드하여 모든 PCB 설계 또는 PCB 풋프린트에 사전 정의된 Pad와 비아의 인스턴스를 배치할 수 있습니다.

Pad 비아 라이브러리 생성에 대한 자세한 내용은 Pad 및 비아 템플릿과 라이브러리 생성 페이지를 참조하세요.

앞서 설명한 대로 기존 템플릿을 Pad 및 비아 템플릿 라이브러리에 저장하거나 새 템플릿을 생성할 수 있습니다. 이러한 라이브러리의 템플릿은 PCB Pad Via Templates 패널을 통해 사용할 수 있습니다. 로컬 템플릿도 패널에 표시되므로, 이 패널은 Pad 및 비아 템플릿 라이브러리 작업의 중심 역할을 합니다.

PCB Pad 비아 템플릿 Panel

PCB Pad Via Templates 패널은 현재 PCB 문서에 저장된 Pad/비아 템플릿(Local)과, 설치되었거나 현재 설계 프로젝트에 포함된 Pad 비아 라이브러리에서 사용할 수 있는 템플릿(Available libraries)을 모두 표시하는 전용 패널입니다.

설계 공간의 오른쪽 하단에 있는 버튼을 클릭한 다음 PCB Pad Via Templates을 선택하여 패널을 엽니다.

이 패널에서는 로컬 템플릿과 라이브러리 기반 템플릿에 모두 접근할 수 있습니다.
이 패널에서는 로컬 템플릿과 라이브러리 기반 템플릿에 모두 접근할 수 있습니다.

패널에 표시되는 두 가지 라이브러리 개념은 다음과 같이 요약할 수 있습니다.

  • Available Pad/Via Template Libraries – 로드되거나 설치된 Pad 비아 라이브러리(Pad/비아 템플릿의 파일 기반 모음)입니다. 패널의 이 영역에는 현재 선택된 Pad 비아 라이브러리에 포함된 템플릿이 표시됩니다.
  • Local Pad & Via Library – 현재 기판 설계에 사용되는 Pad/비아 템플릿을 통칭하며, Pad 비아 라이브러리에서 가져오거나 추가한 템플릿도 포함됩니다. 패널의 이 영역에는 현재 기판 설계의 Pad/비아에 적용되는 템플릿이 표시됩니다.

로컬 Pad 및 비아 라이브러리

패널 하단의 Local Pad & Via Library 영역에 표시되는 항목은 현재 기판 설계에서 사용되고 저장된 패드/비아 구성(템플릿)을 나타냅니다. 선택한 템플릿의 미리보기는 해당 영역의 하단에 표시됩니다.

여기에 표시되는 템플릿은 PCB 파일 내에 저장된 Pad 비아 템플릿이며, 별도로 정의된 '라이브러리'에 포함된 것은 아닙니다. 선택한 템플릿을 레이아웃으로 드래그하거나 패널의 마우스 오른쪽 버튼 컨텍스트 메뉴에서 Place을 선택하면 현재 기판에서 새 Pad 또는 비아 인스턴스로 재사용할 수 있습니다.

로컬 Pad 템플릿 인스턴스 배치.
로컬 Pad 템플릿 인스턴스 배치.

사용 가능한 Pad 및 비아 템플릿 파일 라이브러리

패널 상단의 Available Pad/Via template Libraries 영역에서는 Pad 비아 템플릿 파일 라이브러리 작업을 수행합니다.

패널에서 드래그하거나 마우스 오른쪽 버튼 컨텍스트 메뉴를 사용하여 선택한 라이브러리의 템플릿을 PCB에 배치할 수 있습니다. Pad/비아가 외부 템플릿 파일 라이브러리에서 배치되므로, 아래 오른쪽에 표시된 Properties 패널 이미지에서 볼 수 있듯이 PCB에서 해당 속성을 편집할 수 없습니다. 라이브러리 기반 패드/비아의 속성을 편집하려면 템플릿의 연결을 해제해야 합니다. 자세한 내용은 라이브러리에서 템플릿 연결 해제 섹션을 참조하세요.

활성 Pad 비아 라이브러리의 템플릿입니다. 이 예에서는 Preferred.PvLib입니다. 두 번째 이미지에는 선택한 Pad의 배치된 인스턴스 속성이 표시되어 있습니다. 패드 모양과 홀 크기 같은 물리적 속성은 편집할 수 없습니다. 
활성 Pad 비아 라이브러리의 템플릿입니다. 이 예에서는 Preferred.PvLib입니다. 두 번째 이미지에는 선택한 Pad의 배치된 인스턴스 속성이 표시되어 있습니다. 패드 모양과 홀 크기 같은 물리적 속성은 편집할 수 없습니다.

파일 기반 Pad 또는 비아 템플릿을 기판 설계에 배치하면 원본 라이브러리 템플릿 및 원본 라이브러리 이름과의 연결이 유지됩니다. 원본이 외부 파일이므로 해당 템플릿을 사용하는 Pad 또는 비아의 물리적 속성은 편집할 수 없으며, 이를 통해 외부 라이브러리 파일에 있는 원본 템플릿의 무결성이 보호됩니다. 파일 기반 Pad 또는 비아 템플릿을 편집하려면 연결을 해제할 수 있습니다. 자세한 내용은 라이브러리에서 템플릿 연결 해제 섹션을 참조하세요.

패널 상단의 드롭다운에서 사용 가능한 라이브러리 중 활성화할 라이브러리를 선택합니다. 아래 이미지에서는 ExampleViaLib.PvLib이 선택되어 있습니다.  버튼을 사용하면 템플릿 라이브러리 파일을 추가하거나 제거할 수 있는 Available Libraries 대화상자가 열립니다. 사용 가능한 라이브러리는 아래에서 설명합니다. Filter 필드를 사용하면 Name이 해당 문자열로 시작하는 템플릿만 표시할 수 있습니다.

Filter 필드를 사용하여 템플릿 목록을 빠르게 필터링하세요.
Filter 필드를 사용하여 템플릿 목록을 빠르게 필터링하세요.

Pad 비아 템플릿 라이브러리를 사용할 수 있도록 설정하기

Available Libraries은 현재 기판 설계에서 템플릿을 사용할 수 있는 Pad 비아 템플릿 라이브러리를 의미합니다. 여기에는 현재 프로젝트에 추가된 템플릿 라이브러리와 Altium Designer에 설치된 템플릿 라이브러리가 모두 포함됩니다. 두 유형 모두 Available Libraries 대화상자에서 확인하고 관리할 수 있습니다. PCB Pad Via Templates 패널 상단의  버튼을 클릭하여 대화상자를 엽니다.

외부 Pad 비아 라이브러리를 설치하거나 Project 탭을 사용하여 기존 라이브러리를 현재 프로젝트에 추가하세요.
외부 Pad 비아 라이브러리를 설치하거나 Project 탭을 사용하여 기존 라이브러리를 현재 프로젝트에 추가하세요.

  • 대화상자의 Project 탭에는 프로젝트에 포함된 모든 PvLib 파일이 표시되며, 프로젝트에서 라이브러리를 추가하거나 제거하는 버튼도 있습니다.
  • Installed 탭에는 현재 Altium Designer 설치 환경에서 사용할 수 있는 모든 Pad 비아 템플릿 라이브러리가 표시됩니다. 따라서 이 라이브러리는 모든 PCB 설계 프로젝트에서 사용할 수 있습니다. 설치된 라이브러리는 관련 Activated 옵션을 활성화하거나 비활성화하여 사용 가능 여부를 제어할 수 있습니다. 이를 통해 라이브러리를 반복해서 제거하고 다시 추가할 필요가 없습니다.

설계에서 템플릿 사용하기

PCB Pad Via Templates 패널에 표시된 템플릿은 현재 기판 설계에서 다음과 같은 방식으로 사용할 수 있습니다.

  • 배치 – 패널에서 로컬 또는 템플릿 라이브러리의 Pad 비아를 직접 배치합니다.
  • Template 드롭다운에서 선택 – Pad 또는 비아가 선택된 상태에서 Properties 패널을 통해 선택합니다. 이 방법을 사용하면 선택한 Pad 또는 비아가 다른 템플릿을 사용하도록 변경할 수 있습니다.
  • Rule 제약 조건으로 사용 – 라우팅 비아 스타일 설계 규칙에서 Pad 비아 템플릿을 제약 조건으로 선택할 수 있습니다(아래 참조).
  • Rule 적용 범위로 사용 – 설계 규칙의 적용 범위를 지정할 때 다음 쿼리 키워드를 사용할 수 있습니다(예: 테스트포인트 스타일 설계 규칙).
  • 비아 스티칭/차폐의 경우 – Net에 스티칭 추가 대화 상자 또는 Net에 차폐 추가 대화 상자에서 필요한 Via Template을 선택합니다.

라우팅 비아 스타일 설계 규칙에서 또는 Net에 비아 스티칭을 추가할 때 비아 템플릿을 사용합니다.
라우팅 비아 스타일 설계 규칙에서 또는 Net에 비아 스티칭을 추가할 때 비아 템플릿을 사용합니다.

Pad 비아 템플릿 및 명명 방식

보드 설계에 배치된 각각의 고유한 Pad 또는 비아에 대해 Pad/비아 템플릿이 자동으로 생성되고 이름이 지정되어 보드 파일에 저장됩니다. 템플릿에는 크기, 모양, 패드스택 유형, Paste/솔더 마스크 및 홀 정보 등을 포함한 Pad/비아의 기본 구성이 저장됩니다. 이 구성의 이름은 IPC 표준(구체적으로 IPC-7251/7351 패드스택 명명 규칙)에 따라 자동으로 지정됩니다. 설계에 사용되는 모든 Pad와 비아는 해당 템플릿을 참조하며, 아래와 같이 Properties 패널에서 이를 확인할 수 있습니다.

IPC 명명 체계는 미터법을 기반으로 하며, 한 단위는 100분의 1밀리미터(10-5미터, 10µm)에 해당합니다. 예를 들어, 0.8mm 홀이 있는 1.5mm 원형 패드의 템플릿 이름은 c150h80입니다. 여기서 c은 원형을 나타내며 h는 홀 크기 앞에 붙는 접두사입니다. 이름이 r155_125인 패드는 크기가 1.55mm x 1.25mm인 직사각형 표면 실장 패드이고, 이름이 s160h100인 패드는 크기가 1.6mm이고 1.0mm 홀이 있는 정사각형 스루홀 패드입니다. 사용자 지정 형상 패드 템플릿의 이름 앞에는 u 접두사가 붙습니다. 지정된 Paste/솔더 마스크 속성에 따라 추가 문자/정수 조합이 붙습니다.

이 동작을 확인하려면 기존 Pad 또는 비아 객체를 두 번 클릭하거나, 객체를 선택한 다음 마우스 오른쪽 버튼 클릭 컨텍스트 메뉴에서 Properties을 선택하여 관련 Properties 패널에서 속성을 확인합니다.

Properties 패널에 표시된 자동 생성 Pad 또는 비아 템플릿 이름.
Properties 패널에 표시된 자동 생성 Pad 또는 비아 템플릿 이름.

패널의 Pad/Via Template 영역에 지정된 Template 이름을 확인합니다. IPC 지침에 따라 이름은 치수, 모양, 홀, Paste/솔더 마스크 구성과 같은 기본 Pad/비아 속성에서 파생됩니다. 이러한 속성이 변경되면 새 구성을 반영하도록 템플릿 이름도 변경됩니다. 예상할 수 있듯이 미터법 대신 야드파운드법 단위를 사용할 때는 Pad 또는 비아의 속성과 템플릿 이름 사이의 관계가 덜 명확합니다.

PCB 설계 공간에서 Pad 또는 비아 찾기

Place 메뉴 또는 Active Bar을 사용하여 PCB 설계에 고유한 크기의 Pad 또는 비아를 배치할 때마다 보드 파일에 새 Pad/비아 템플릿이 자동으로 생성됩니다. 이러한 템플릿을 <Local> 템플릿이라고 합니다. 현재 PCB에 사용된 모든 Pad 및 비아 템플릿 목록은 PCB 패널을 Pad & 비아 템플릿 모드로 설정하여 확인할 수 있습니다.

Pad &amp; Via Templates 모드의 PCB 패널
Pad & Via Templates 모드의 PCB 패널

Pad & Via Templates 모드에서는 현재 PCB 문서에 사용된 Pad 및 비아 템플릿을 세밀하게 제어할 수 있습니다. 이 모드에서 패널은 세 개의 섹션으로 나뉩니다.

  • Library Name
  • Templates
  • Pads/Vias

라이브러리 이름

이 목록은 설계의 Pad & 비아 템플릿 인스턴스를 가상 및 물리적 라이브러리 모음으로 표시합니다. 이 항목들은 하단 패널 섹션의 목록에 포함될 템플릿을 필터링하며 다음과 같이 구성됩니다.

  • All – Pad & 비아 라이브러리에서 사용된 템플릿을 포함한 모든 Pad 및 비아 템플릿을 표시합니다.
  • Pads – 로컬 및 라이브러리 기반의 모든 Pad를 표시합니다.
  • Vias – 로컬 및 라이브러리 기반의 모든 비아를 표시합니다.
  • Local – 보드에 적용된 모든 Pad 및 비아 템플릿을 표시하되, Pad 비아 라이브러리에서 추가된 템플릿은 제외합니다.
  • Pad & Via Libraries – 선택한 Pad 비아 라이브러리에서 적용된 Pad 및 비아 템플릿만 표시합니다.

템플릿

이 영역에는 현재 PCB 설계에 사용되는 모든 Pad/비아 템플릿 목록이 표시됩니다. 열에는 템플릿 소스 Library Name(로컬 또는 Pad 비아 라이브러리 이름)와 각 템플릿의 Pad/비아 인스턴스 수(Count)가 포함됩니다.

패널의 Library Name 섹션을 특정 Pad 비아 라이브러리로 설정하면 Template 섹션에 Count의 인스턴스 수가 0인 항목이 표시될 수 있습니다. 이는 해당 템플릿이 현재 보드 레이아웃의 어떤 Pad/비아에서도 사용되지 않지만 설계 프로젝트에서는 사용되고 있음을 나타냅니다. 예를 들어, 기본 Pad/비아 설정으로 사용되거나 라우팅 비아 스타일과 같은 설계 규칙의 제약 조건을 정의하는 데 사용될 수 있습니다.

목록에 있는 템플릿은 원하는 수만큼 별도의 Pad 비아 라이브러리에 저장할 수 있습니다. 이렇게 하려면 표준 Shift+Click 및 Ctrl+Click 선택 방법으로 여러 템플릿을 선택하고 Save as Library 버튼을 클릭합니다. 라이브러리가 프로젝트에 자동으로 추가되며, 프로젝트 패널에서 File » Save As을 사용하여 원하는 *.PvLib 파일 이름으로 저장할 수 있습니다. Pad 비아 템플릿 라이브러리 생성에 대한 자세한 내용은 Pad 비아 템플릿 라이브러리 생성 및 편집 페이지를 참조하십시오.

Templates 섹션에서는 Place 버튼을 사용하여 Pad 비아 라이브러리 기반 템플릿을 PCB 설계에 배치할 수도 있습니다. 이 기능을 활성화하려면 패널 상단의 Library Name 섹션에서 원하는 Pad 비아 라이브러리를 선택합니다.

선택한 Pad/비아 템플릿이 Pad 비아 템플릿 라이브러리에 있는 경우 Place 버튼을 사용하여 해당 템플릿을 배치할 수 있습니다. 로컬 Pad/비아를 배치하려면 아래에 설명된 대로 PCB Pad Via Templates 패널을 사용합니다.

Pad/비아

패널의 이 영역에는 위의 Templates 섹션에서 선택한 템플릿의 개별 Pad/비아 인스턴스가 표시됩니다.

각 Pad/비아 인스턴스를 선택하면 PCB 패널 상단에 있는 패널의 표준 강조 표시, 확대/축소 및 선택 옵션에 따라 설계 공간에서 해당 객체가 그래픽으로 강조 표시됩니다. 그런 다음 Properties 패널의 Template 드롭다운에서 필요한 템플릿을 선택하여, 선택한 Pad 또는 비아가 다른 템플릿을 사용하도록 편집할 수 있습니다.

이 영역에 나열된 각 인스턴스에는 Changed 표시 상자가 함께 제공됩니다. 연결된 라이브러리의 소스 템플릿이 로컬 Pad 또는 비아에 사용된 템플릿과 다르면, 즉 소스 Pad 비아 라이브러리가 업데이트되면 이 상자가 선택됩니다. 로컬 Pad/비아의 패드스택 유형이 변경된 경우에도 Changed 표시 상자가 선택됩니다. 예를 들어, Pad 인스턴스가 로컬에서 다중 레이어에서 싱글 레이어로 변경된 경우가 이에 해당합니다.

모든 경우에 PCB Pad 비아 템플릿 패널 Update 버튼을 사용하여 로컬 버전의 Pad 또는 비아를 소스 Pad 비아 라이브러리의 현재 템플릿으로 업데이트하거나 되돌릴 수 있습니다.

Pad/비아 템플릿 편집 및 관리 작업

이 섹션에서는 Pad 또는 비아 템플릿을 편집해야 하는 다양한 상황을 설명합니다.

기존 Pad/비아에 다른 템플릿 적용

기존 Pad 또는 비아에 다른 템플릿을 적용해야 할 때가 있습니다(예를 들어 설계에 사용되는 비아의 종류를 줄이는 경우). 이때는 PCB Panel의 Pad & Via Templates 모드를 사용하여 변경할 Pad/비아를 찾아 선택합니다. 그런 다음 Properties Panel의 Template 드롭다운에서 원하는 템플릿을 선택하여 선택한 Pad 또는 비아에 다른 템플릿을 적용할 수 있습니다.

다른 템플릿을 적용하는 모습.
다른 템플릿을 적용하는 모습.

라이브러리에서 템플릿 연결 해제

파일 기반 템플릿 라이브러리의 템플릿을 사용하는 Pad/비아의 속성은 편집할 수 없습니다. 편집하면 로컬 인스턴스가 참조하는 라이브러리 템플릿과 더 이상 일치하지 않기 때문입니다. 라이브러리 템플릿을 참조하는 Pad 또는 비아를 편집하려면 템플릿의 연결을 해제해야 합니다.

Linked button, click to copy the template from the file library to the local library and reference the local template 버튼을 클릭하여 템플릿의 연결을 해제합니다. 이 버튼을 클릭하면 해당 템플릿의 복사본이 로컬 라이브러리에 생성되고, 선택한 Pad/비아 인스턴스는 이 로컬 템플릿을 참조하게 됩니다. Linked button, click to copy the template from the file library to the local library and reference the local template 버튼이 회색으로 비활성화되어 있다면 해당 템플릿이 이미 로컬 템플릿임을 의미합니다.

클릭하여 파일 기반 라이브러리에서 템플릿의 연결을 해제합니다. 템플릿이 로컬 라이브러리로 복사되고 해당 템플릿이 사용됩니다.
클릭하여 파일 기반 라이브러리에서 템플릿의 연결을 해제합니다. 템플릿이 로컬 라이브러리로 복사되고 해당 템플릿이 사용됩니다.

연결을 해제하는 Pad/비아에 Pad 비아 템플릿 라이브러리에서 정의한 Custom 이름이 있는 경우, 이 이름은 제거되고 로컬 템플릿에는 IPC 표준 명명 규칙이 적용됩니다.

로컬 라이브러리에 라이브러리 템플릿 추가

필요한 경우 라이브러리 템플릿을 로컬 라이브러리에 추가할 수 있습니다. 템플릿 이름을 마우스 오른쪽 버튼으로 클릭하고 상황에 맞는 메뉴에서 Add to Internal Library을 선택하거나, Panel의 Pad/Via Library Region에서 템플릿을 끌어 Local Pad & Via Library Region의 빈 공간에 놓으면 됩니다.

마우스 오른쪽 버튼 메뉴 또는 드래그 앤 드롭으로 로컬 라이브러리에 Pad/비아 템플릿을 추가합니다.
마우스 오른쪽 버튼 메뉴 또는 드래그 앤 드롭으로 로컬 라이브러리에 Pad/비아 템플릿을 추가합니다.

사용하지 않는 Pad/비아 라이브러리 템플릿은 Removed Unused Pad/Via 버튼을 클릭하여 로컬 라이브러리에서 제거할 수 있습니다.

이는 Pad 비아 라이브러리 템플릿을 기반으로 Pad/비아를 배치한 다음 보드에서 삭제하여 해당 템플릿을 로컬에서 사용 가능한 상태로 등록하는 것과 같습니다. 로컬 목록에 템플릿을 추가하는 대신 로컬 템플릿을 replace하려면 아래의 로컬 템플릿 교체를 참조하세요.

Pad 비아 라이브러리에서 업데이트

보드 설계에 이미 사용된 Pad/비아 템플릿이 라이브러리에서 업데이트된 경우, PCB Pad Via Templates Panel의 Update 버튼을 클릭하여 설계의 Pad/비아 템플릿을 업데이트합니다. 업데이트는 보드에서 해당 템플릿을 사용하는 모든 Pad/비아 인스턴스에 자동으로 반영됩니다.

라이브러리에서 업데이트된 템플릿을 사용하는 Pad/비아는 PCB Pad Via Templates Panel의 Update 버튼을 사용하여 PCB 설계에서 업데이트할 수 있습니다.
라이브러리에서 업데이트된 템플릿을 사용하는 Pad/비아는 PCB Pad Via Templates Panel의 Update 버튼을 사용하여 PCB 설계에서 업데이트할 수 있습니다.

업데이트를 시작하면 Update Pads/Vias on Board 대화 상자가 열리고, 적용할 변경 사항의 세부 정보가 표시됩니다.

원본 라이브러리 버전과 다른 것으로 감지된 Pad/비아 템플릿은 라이브러리에서 PCB 설계로 업데이트할 수 있습니다.
원본 라이브러리 버전과 다른 것으로 감지된 Pad/비아 템플릿은 라이브러리에서 PCB 설계로 업데이트할 수 있습니다.

대화 상자에서는 업데이트 과정을 제어하는 세 가지 옵션을 제공합니다.

  • Update locked objects – 잠금 상태와 관계없이 Pad/비아 객체의 템플릿을 강제로 업데이트합니다.
  • Update free objects – 독립 Pad 및 비아에 적용되는 Pad/비아 템플릿만 업데이트합니다.
  • Update component objects – 컴포넌트에 사용되는 Pad 및 비아에 적용되는 Pad/비아 템플릿만 업데이트합니다.

이 동기화 동작은 Pad 및 비아의 Library 속성으로 설정됩니다. 이 속성은 Pad 또는 비아를 선택한 후 Properties Panel에서 해당 속성을 확인할 때 표시됩니다. 로컬 버전의 템플릿과 원본 템플릿 사이에 차이가 있으면 PCB Panel의 Pad & 비아 템플릿 모드에 있는 Pads/Vias Region의 Changed 열에 표시됩니다.

원본 Pad 비아 라이브러리에서 템플릿 이름이 변경되더라도, 보드 설계 데이터에 저장된 템플릿의 GUID 참조를 통해 PCB 설계의 Pad/비아와 템플릿 간 연결이 유지됩니다.

대화 상자 하단 Region에는 업데이트할 Pad/비아가 나열됩니다. 각 항목에 대해 Type, Description, Library, Template 및 Action 등의 정보가 표시됩니다. 또한 각 Pad/비아에 Locked 및/또는 In Component 표시를 지정할 수 있습니다. 이러한 옵션을 활성화하면 해당 객체에 대화 상자 상단 Region의 제어 설정이 적용됩니다.

로컬 템플릿 교체

라이브러리 기반 Pad/비아 템플릿으로 로컬 템플릿을 replace할 수도 있습니다. 이렇게 하면 보드에서 해당 로컬 템플릿을 사용하는 Pad 또는 비아가 업데이트됩니다.

이 작업을 수행하려면 Panel의 Pad/Via Library Region에서 원하는 라이브러리 템플릿을 끌어 Panel의 Local Pad & Via Library Region으로 이동합니다. 단, 이 경우에는 라이브러리 템플릿을 기존 로컬 템플릿 Entry on top of 놓아야 합니다. 해당 템플릿을 사용하는 독립 Pad/비아 또는 컴포넌트 Pad/비아의 모든 인스턴스가 새 라이브러리 템플릿 스타일로 업데이트됩니다.

아래 애니메이션에서 C1 및 C2 컴포넌트 Pad의 실제 형상이 드롭한 라이브러리 템플릿에 지정된 유형에 따라 r110_100에서 s120으로 변경되는 것을 확인할 수 있습니다.

로컬 템플릿 Entry 위에 라이브러리 템플릿을 놓으면 설계의 모든 인스턴스에서 해당 템플릿이 교체됩니다.
로컬 템플릿 Entry 위에 라이브러리 템플릿을 놓으면 설계의 모든 인스턴스에서 해당 템플릿이 교체됩니다.

사용하지 않는 Pad/비아 제거

로컬 라이브러리에 나열되는 템플릿 이름은 현재 PCB 레이아웃의 Pad 및 비아를 기반으로 생성됩니다. 따라서 특정 로컬 Pad/비아 구성의 모든 인스턴스를 보드에서 삭제하면 해당 템플릿도 로컬 목록에서 제거됩니다.

그러나 배치된 Pad 또는 비아가 Pad 비아 라이브러리에서 가져온 것이라면, 해당 Pad/비아의 모든 인스턴스를 보드에서 제거해도 템플릿은 로컬 목록에 유지됩니다. 더 이상 필요하지 않은 Pad 비아 라이브러리 템플릿 인스턴스는 Remove Unused Pad/Via 버튼을 사용하여 로컬 ‘데이터베이스’ 기록에서 제거할 수 있습니다. Update Templates from Library 대화 상자가 열리면 로컬 Pad & 비아 라이브러리에서 제거할 Pad 및 비아 템플릿을 선택할 수 있습니다. Templates 버튼 또는 마우스 오른쪽 버튼 메뉴를 사용하여 목록의 모든 템플릿을 선택/선택 해제하거나 선택을 반전할 수 있습니다.

Update Templates from Library 대화 상자
Update Templates from Library 대화 상자

AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Nav
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents