트랙 및 아크 작업
개요
- 주요 명령과 단축키를 사용하여 PCB Editor에서 Track 세그먼트를 배치, 편집, 이동하고 재라우팅하는 방법을 알아봅니다.
- 인터랙티브 라우팅이 네트, 레이어, 코너 모드, 충돌 해결 방식 및 적용되는 설계 규칙에 따라 어떻게 동작하는지 이해합니다.
- 환경설정과 규칙이 사용 가능한 라우팅 폭에 미치는 영향을 비롯하여, 라우팅 폭이 결정되고 조정되는 방식을 살펴봅니다.
Track 작업하기
Track 세그먼트는 정해진 폭을 가진 직선입니다. Track을 사용하여 PCB 설계 공간에 직선을 정의합니다. Track은 Signal 레이어에 배치되어 컴포넌트의 Pad 사이에 전기적 상호 연결, 즉 라우팅을 형성합니다. 비전기적 레이어에 배치된 Track은 선이라고 하며, 컴포넌트 외곽선, 안내 정보, Keepout 경계 등을 만드는 범용 그리기 요소로 사용됩니다. Track은 치수 및 좌표와 같은 그룹 설계 객체에도 사용됩니다.

Track 객체는 라우팅 및 범용 선 그리기에 사용됩니다. 위 이미지에는 배치된 Track 세그먼트가 네 개 있으며, 또 하나는 배치 중입니다.
Track과 선은 실제로 동일한 객체이지만 배치 중 소프트웨어의 동작 방식이 다르므로 서로 다른 명령을 사용합니다. Interactive Routing와 같은 Track 배치 명령을 실행하면 소프트웨어가 클릭 위치를 모니터링하고 해당 위치 아래에 있는 기존 객체(예: Pad)의 Net 이름을 자동으로 적용합니다. 또한 적용 가능한 모든 Design Rule을 모니터링하고 준수합니다. 선 배치 명령(Place » Line)을 실행하면 이러한 모니터링 동작이 수행되지 않습니다.
Track은 PCB Editor와 PCB 라이브러리 Editor 모두에서 배치할 수 있습니다. 사용하는 명령(라우팅/Track 또는 선 배치)에 관계없이 기본 배치 동작은 동일합니다. 명령을 실행하면 커서가 십자형으로 바뀌고 Track 배치 모드로 들어갑니다. 다음 순서에 따라 배치합니다.
- 클릭하거나 Enter 키를 눌러 첫 번째 Track 세그먼트의 시작점을 고정합니다. 라우팅 유형의 배치 명령을 실행 중이고 기존 객체를 클릭하여 배치를 시작하면 Track에 해당 객체의 Net 이름이 적용됩니다. 라우팅 시 폭은 적용 가능한 라우팅 폭 Design Rule에 따라 결정됩니다. 이 설정은 특정 인터랙티브 라우팅 옵션으로 재정의할 수 있으며, 자세한 내용은 아래에서 설명합니다.
- 커서를 이동하여 Track 세그먼트를 정의한 다음 클릭하거나 Enter 키를 눌러 첫 번째 세그먼트의 끝점을 고정합니다. 이 점은 다음에 연결되는 세그먼트의 시작점이기도 합니다.
- 계속해서 커서 위치를 지정한 다음 클릭하거나 Enter 키를 눌러 일련의 연결된 Track 세그먼트를 정의하는 꼭짓점들을 고정합니다.
- 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 현재의 연결된 Track 세그먼트 배치를 종료합니다.
배치 중에는 다음 작업도 수행할 수 있습니다.
- 숫자 키패드의 * 키를 눌러 사용 가능한 Signal 레이어를 순환합니다. 또는 Shift+Ctrl+Wheel Roll 조합을 사용하여 라우팅 레이어 사이를 이동합니다. 마우스 휠을 한 칸 움직일 때마다 사용 가능한 다음(또는 이전) Signal 레이어로 이동합니다.
- 숫자 키패드의 + 및 - 키를 눌러 설계에서 현재 표시되는 모든 레이어를 앞뒤로 순환합니다.
Track 세그먼트를 배치할 때는 다섯 가지 코너 모드를 사용할 수 있으며, 이 중 네 가지에는 코너 방향 하위 모드도 있습니다. 배치 중에는 다음을 수행할 수 있습니다.
- Shift+Spacebar 키를 눌러 사용 가능한 코너 모드를 순환합니다.
- Spacebar 키를 눌러 두 가지 코너 방향 하위 모드 사이를 전환합니다.
- 두 가지 Arc 코너 모드 중 하나를 사용하는 경우 , 또는 . 키를 길게 눌러 Arc를 축소하거나 확대합니다. 키를 누를 때 Shift 키를 함께 누르면 Arc 크기가 더 빠르게 변경됩니다.
- 1 단축키를 눌러 클릭할 때마다 세그먼트 하나를 배치하는 방식(아래 첫 번째부터 다섯 번째 이미지)과 세그먼트 두 개를 배치하는 방식(아래 마지막 이미지) 사이를 전환합니다. 첫 번째 모드에서 속이 빈 Track 세그먼트는 미리보기 세그먼트라고 합니다.
- Backspace 키를 눌러 마지막 꼭짓점을 제거합니다.



Shift+Spacebar 키를 눌러 사용 가능한 다섯 가지 코너 모드를 순환하고, Spacebar 키를 눌러 코너 방향을 전환하며, 1 단축키를 눌러 세그먼트 하나 또는 두 개를 배치하는 방식 사이를 전환합니다.
그래픽 편집 방식을 사용하면 설계 공간에서 배치된 Track 객체를 직접 선택하고 크기, 모양 또는 위치를 그래픽으로 변경할 수 있습니다.
Track 객체를 선택하면 다음 편집 핸들을 사용할 수 있습니다.
- A을(를) 클릭하고 드래그하여 Track 끝점의 위치를 변경합니다.
- B을(를) 클릭하고 드래그하여 Track의 모양을 변경합니다.
PCB Editor에는 라우팅 배치를 유지하면서 보드의 Track 세그먼트를 이동할 수 있는 정교한 알고리즘이 포함되어 있습니다. 이 Track 세그먼트 슬라이딩 기능은 먼저 Track 세그먼트를 클릭하여 선택한 다음 특수 커서가 나타나면 마우스 버튼을 누른 채 세그먼트를 밀어서 실행하거나, Track 세그먼트에서 바로 마우스 버튼을 누른 채 밀어서 인터랙티브하게 실행할 수 있습니다. 슬라이딩 동작은 Preferences 대화 상자의 PCB Editor - Interactive Routing 페이지에 있는 Dragging 옵션으로 구성할 수 있습니다. 이 옵션을 사용하면 Track에 이동 동작을 지정할 수 있으며, 이는 개별 Track 세그먼트를 자유롭게 이동하려는 경우 유용합니다.

Preferences 수준에서 설정한 드래그 옵션으로 Track 슬라이딩 동작을 제어합니다.
이 옵션을 통해 Move 동작을 지정하면 이동 중에 Track 세그먼트를 회전하거나 반전할 수 있습니다.
인터랙티브 라우팅 및 적용 가능한 Design Rule
인터랙티브 라우팅 중 소프트웨어의 기본 동작은 적용 가능한 전기 및 라우팅 Design Rule에 따라 Track 세그먼트가 배치되도록 하는 것입니다. 즉, 소프트웨어는 다른 Net에 속한 기존 Track 세그먼트와의 규칙을 위반하는 새 Track 세그먼트의 배치를 허용하지 않습니다. 대신 Design Rule을 충족하도록 Track 세그먼트를 잘라냅니다. 이러한 인터랙티브 라우팅 동작을 Routing Conflict Resolution 모드라고 합니다. 기본 모드는 Stop at First Obstacle입니다(현재 모드는 상태 표시줄에 표시됨). Shift+R 키를 눌러 사용 가능한 모드를 순환합니다.
applicable design rules이라는 용어는 배치 중인 객체에 적용되는 모든 규칙을 의미합니다. Design Rule 엔진은 각 Rule을 적용할 객체의 범위를 정확하게 지정하는 방식으로 작동합니다. 배치 중에는 Design Rule 엔진에 쿼리하여 현재 배치 상황에 적용되는 최우선 순위의 Rule을 결정합니다. 인터랙티브 라우팅 중에 적용되는 Rule은 다음과 같습니다.
- 전기적 클리어런스
- 라우팅 폭
- 라우팅 비아 스타일
아래 애니메이션은 실제 라우팅 동작을 보여줍니다. GND Net이 정의된 적용 가능한 라우팅 폭 Design Rule에 따라 라우팅되고 있습니다. 커서를 +12V Net에 연결된 비아 위로 이동하면 적용 가능한 전기적 클리어런스 제약 조건 Design Rule을 충족하도록 라우팅 경로가 자동으로 잘리는 점에 유의하세요.

인터랙티브 라우팅 중에는 적용 가능한 라우팅 폭 및 클리어런스 Design Rule이 자동으로 준수됩니다.
라우팅 폭이 결정되는 방식
규칙 엔진이 비활성화되어 있지 않은 한, 소프트웨어는 항상 라우팅 폭이 해당 라우팅 폭 Design Rule에서 허용하는 범위 내에 있도록 하는 것을 최우선으로 합니다. 일반적으로 Net에 여러 폭을 허용하여 해당 Net의 전류 용량 요구 사항을 충족하면서도 경로를 유연하게 배치할 수 있도록 합니다. 이를 위해 라우팅 폭 Design Rule에는 PCB Rules and Constraints Editor의 Min, Preferred, Max 설정이 있으며, 폭 범위를 허용하도록 구성하거나 모두 같은 값으로 설정하여 특정 폭을 사용하도록 지정할 수 있습니다. 폭은 임피던스 기준으로도 구성할 수 있으며, 각 Signal 레이어에 서로 다른 범위를 지정할 수도 있습니다.

새 PCB에서는 Default 라우팅 폭 Design Rule이 모든 Net에 적용됩니다.
설계자는 라우팅을 시작할 때 가장 적합한 라우팅 폭을 선택하는 데 도움이 되는 여러 옵션을 사용할 수 있습니다. 이러한 옵션은 아래 그림과 같이 Preferences 대화 상자의 PCB Editor — 대화형 라우팅 페이지에서 구성합니다.

Interactive Routing Width Sources 옵션은 경로를 시작할 때 사용할 크기를 결정합니다.
그림에서 Track Width Mode이 Rule Preferred으로 설정되어 있다는 점에 유의하세요. 이는 Pad와 같은 기존 Net 객체에서 경로를 시작하면 이 폭이 사용됨을 의미합니다. 하지만 기존 Track에서 경로를 시작하면 Pickup Track Width From Existing Routes 옵션이 Track Width Mode보다 우선하여 새 폭을 기존 폭과 일치하도록 설정합니다.
설계자는 라우팅 중에 Shift+W 단축키를 눌러 다른 폭을 선택할 수 있는 대화 상자를 열거나, Tab를 눌러 Properties panel 을 열고 새 Width 값을 입력할 수도 있습니다. 선택하거나 입력한 값은 해당 Rule에 정의된 Min과 Max 설정 사이에 있어야 합니다. 이 범위를 벗어나면 가장 가까운 경계값으로 자동 제한됩니다.
대화형 라우팅 단축키
라우팅 중에는 여러 단축키를 사용할 수 있습니다. 예를 들어 Shift+R를 눌러 사용 가능한 충돌 해결 모드를 순환하거나, Backspace을 눌러 마지막으로 배치한 꼭짓점(모서리)을 삭제할 수 있습니다. 라우팅 중에 단축키 목록을 표시하려면 Shift+F1를 누르세요. 사용 가능한 대화형 단축키 메뉴가 표시됩니다. 필요한 단축키를 선택하거나 Esc를 눌러 메뉴를 닫고 단축키 조합을 사용하세요.

대화형 라우팅 중에 Shift+F1을 누르면 사용 가능한 대화형 단축키 메뉴가 표시됩니다.
Track 이동
Edit » Move 하위 메뉴와 Active Bar의 이동 명령 메뉴에는 Track의 위치나 형상을 변경하는 데 사용할 수 있는 여러 명령이 있습니다.
재라우팅
이 명령을 사용하면 보드의 기존 Track을 수동으로 재라우팅할 수 있습니다. 명령을 실행하면 커서가 십자 모양으로 바뀌고 Track을 선택하라는 메시지가 표시됩니다. 원하는 Track 위에 커서를 놓고 클릭하거나 Enter를 누르세요. 이 기능의 동작은 Preferences 대화 상자의 PCB Editor - 대화형 라우팅 페이지에서 Preserve Angle When Dragging 옵션이 활성화되어 있는지에 따라 달라집니다.
- Preserve Angle Dragging enabled - Track이 분할되고 직교/대각선 연결을 유지하기 위한 새 세그먼트가 추가됩니다. 커서를 움직여 이 세그먼트를 원하는 위치로 밀어 이동한 다음 클릭하여 배치합니다. 이 시점에서 마우스 오른쪽 버튼을 클릭하거나 Esc 를 누르세요. 그렇지 않으면 새 세그먼트가 다시 분할되어 추가 세그먼트가 생성됩니다. Shift+R 단축키를 사용하여 드래그 중 장애물 처리 방식을 제어하는 옵션(Ignore Obstacles, Avoid Obstacles, Avoid Obstacles (Snap Grid))을 순환할 수 있습니다. 장애물 회피 모드 중 하나가 활성화되어 있으면 드래그 중에도 규칙이 준수되므로 세그먼트를 규칙 위반 위치로 드래그할 수 없습니다.
- Preserve Angle Dragging disabled - Track 세그먼트의 양 끝이 고정되며, 그 사이에 새 Track 세그먼트를 배치할 수 있습니다. 클릭하거나 Enter을 눌러 새 Track 세그먼트를 배치합니다. 재라우팅을 위한 새 Track 세그먼트를 계속 배치하거나, 마우스 오른쪽 버튼을 클릭하거나 Esc을 눌러 중지합니다.
다른 Track을 계속 재라우팅하거나, 마우스 오른쪽 버튼을 클릭하거나 Esc를 눌러 종료합니다.
Track 분할
이 명령을 사용하면 Track 세그먼트에 꼭짓점(또는 분할점)을 만들 수 있습니다. 명령을 실행하면 커서가 십자 모양으로 바뀌고 Track을 선택하라는 메시지가 표시됩니다. 분할점을 삽입하려는 Track 세그먼트의 정확한 위치에 커서를 놓고 클릭하거나 Enter을 누르세요. 꼭짓점이 삽입되면서 원래 세그먼트가 두 개로 분할됩니다.
꼭짓점을 원하는 위치로 이동한 다음 클릭하거나 Enter 를 눌러 배치합니다. 연결된 Track 세그먼트의 동작은 Preferences 대화 상자의 PCB Editor - 대화형 라우팅 페이지에 있는 Preserve Angle When Dragging 옵션 설정에 따라 달라집니다.
- Preserve Angle When Dragging 활성화 - 인접한 Track 세그먼트와의 각도가 보존되어 라우팅 스타일이 유지됩니다.
- Preserve Angle When Dragging 비활성화 - 두 개의 개별 Track 세그먼트가 이동에 맞춰 고무줄처럼 늘어나거나 줄어들며, 기존 라우팅 스타일은 유지되지 않습니다.
다른 Track 세그먼트를 계속 분할하거나, 마우스 오른쪽 버튼을 클릭하거나 Esc을 눌러 종료합니다.
Track 끝 드래그
이 명령을 사용하면 라우팅된 Track 세그먼트의 끝을 수동으로 재배치하거나 드래그할 수 있습니다. 명령을 실행하면 커서가 십자 모양으로 바뀌고 객체를 선택하라는 메시지가 표시됩니다. Track 위에 커서를 놓고 클릭하거나 Enter를 누르세요. 커서가 가장 가까운 Track 세그먼트의 끝으로 이동하고, Track 끝이 커서에 붙습니다. Track 끝을 원하는 위치로 이동한 다음 클릭하거나 Enter을 눌러 배치합니다.
- 선택한 Track 세그먼트의 끝점이 다른 Track 세그먼트와 연결되지 않은 꼭짓점인 경우, 꼭짓점을 원하는 위치로 이동합니다.
- 선택한 Track 세그먼트의 끝점이 두 Track 세그먼트가 연결된 꼭짓점인 경우, 꼭짓점을 이동하면 연결된 Track 세그먼트가 러버밴드 방식으로 늘어납니다.
- Track 세그먼트의 끝점이 컴포넌트 Pad에 연결되어 있는 경우, 끝점을 이동하면 Pad와의 연결이 해제됩니다. 끝점의 위치를 변경한 후에는 Preferences 대화 상자의 PCB Editor – 일반 페이지에서 Smart Track Ends 옵션이 활성화되어 있으면 Track 끝점에서 Pad까지 Logical Connection 선이 표시됩니다.
- Track 세그먼트의 끝점이 자유 Pad에 연결되어 있는 경우, Pad가 커서에 붙어 위치를 변경할 수 있는 상태가 됩니다. Pad에 연결된 모든 Track은 이에 따라 러버밴드 방식으로 늘어납니다.
- Track 세그먼트의 끝점이 비아에 연결되어 있는 경우, 비아가 커서에 붙어 위치를 변경할 수 있는 상태가 됩니다. 비아에 연결된 모든 Track은 이에 따라 러버밴드 방식으로 늘어납니다.
다른 Track 끝점을 계속 드래그하거나, 마우스 오른쪽 버튼을 클릭하거나, Esc 키를 눌러 종료합니다.
Track 이동 / 크기 조정
이 명령은 선택한 여러 Track 세그먼트의 끝점을 이동하여 세그먼트의 크기를 조정하는 데 사용됩니다. 명령을 실행하면 커서가 십자 모양으로 바뀌고 Track 끝점을 선택하라는 메시지가 표시됩니다. Track을 이동하거나 크기를 조정하려면 다음을 수행합니다.
- 선택한 세그먼트 중 하나의 끝점에 커서를 놓은 다음 클릭하거나 Enter 키를 누릅니다.
- 커서를 이동합니다. 선택한 모든 Track 세그먼트는 서로 간의 원래 거리와 각도를 유지하면서 동적으로 크기가 조정됩니다. 각 세그먼트의 반대쪽 끝은 기존 연결 및 위치를 유지하도록 러버밴드 방식으로 늘어납니다.
- 세그먼트가 원하는 위치에 오면 클릭하거나 Enter 키를 눌러 배치를 확정하고 이동 모드를 종료합니다.
- 작업을 취소하려면 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 누릅니다.
세그먼트를 이동하는 동안 다음과 같은 추가 제어 기능을 사용할 수 있습니다.
- Tab 키를 누르면 선택한 각 Track 세그먼트의 끝점 사이에서 커서가 차례로 이동합니다.
- 이동하는 동안 Alt 키를 누르고 있으면 처음 이동한 방향에 따라 특정 방향으로 이동이 제한됩니다. 수평, 수직 및 45도 방향으로 이동할 수 있습니다.
- Spacebar 키를 두 번 누르면 모든 Track 세그먼트의 끝점이 수평 또는 수직 방향으로 일직선에 정렬됩니다. Spacebar 키를 다시 빠르게 두 번 누르면 이전 크기로 돌아갑니다.
Track 절단
Track Slicer 도구를 사용하면 하나 이상의 Track 세그먼트를 간편하게 둘로 절단할 수 있으며, 현재 Signal 레이어 또는 표시된 모든 Signal 레이어의 Track을 절단할 수 있습니다. 도구를 사용하려면 기본 메뉴에서 Edit » Slice Tracks 명령을 선택합니다.
명령을 실행하면 커서가 십자 모양으로 바뀌고 절단 시작 위치를 선택하라는 메시지가 표시됩니다. 또한 워크스페이스에 Track 객체만 표시되도록 필터링이 적용됩니다. Track Slicer의 현재 설정에 따라 표시된 모든 Signal 레이어의 Track이 표시되거나 현재 Signal 레이어의 Track만 표시됩니다. 하나 이상의 Track을 절단하려면 다음을 수행합니다.
- 커서를 배치한 다음 클릭하거나 Enter 키를 눌러 절단 시작점을 고정합니다.
- 절단하려는 하나 이상의 Track 지점을 가로질러 커서를 이동합니다. 절단 도구의 경로가 선으로 표시되며 예상 절단 위치도 시각적으로 표시됩니다.
- 클릭하거나 Enter 키를 눌러 절단 도구 경로의 끝점을 고정합니다.
- 다른 Track 세그먼트를 계속 절단하거나, 마우스 오른쪽 버튼을 클릭하거나, Esc 키를 눌러 절단 모드를 종료합니다.
절단 시작점을 고정한 후 '절단선'을 이동하는 동안 다음과 같은 추가 작업을 수행할 수 있습니다.
- B 키를 누르면 현재 Signal 레이어의 Track만 절단하는 모드와 표시된 모든 Signal 레이어의 Track을 절단하는 모드가 차례로 전환됩니다.
- Spacebar 키를 누르면 절단 각도가 45도 단위 또는 임의 각도로 전환됩니다.
- N 키를 누르면 절단 날의 위치가 왼쪽, 오른쪽 및 중앙으로 차례로 전환됩니다.
- / 키를 누르면 절단된 모든 Track이 선택됩니다.
- "," 키를 누르면 절단 도구의 왼쪽에 있는 절단된 Track이 선택됩니다.
- "." 키를 누르면 절단 도구의 오른쪽에 있는 절단된 Track이 선택됩니다.
- M 키를 누르면 절단된 Track이 선택되지 않도록 합니다.
-
Tab 키를 누르면 Slicer Properties 대화 상자가 열리며, 여기에서 Track Slicer의 속성을 즉시 변경할 수 있습니다.

Slicer Properties 대화 상자
Track을 모따기된 경로로 변환
90도 라우팅 코너의 모따기는 마이크로파 주파수의 라우팅 경로에서 코너로 인해 발생하는 반사를 줄이는 기법입니다. 원호를 사용할 수도 있지만 반경은 라우팅 폭의 최소 3배여야 합니다. 모따기(마이터링이라고도 함)는 코너의 바깥쪽 꼭짓점을 잘라내는 대안입니다. Altium Designer의 Track 객체는 끝부분이 둥글기 때문에 모따기된 코너를 만드는 데 사용할 수 없습니다. 모따기된 코너를 만들려면 선택한 Track 세그먼트를 Region 객체로 대체해야 합니다.
모따기할 Track 세그먼트를 모두 선택한 다음 기본 메뉴에서 Tools » Convert » Convert Selected Tracks to Chamfered Path 명령을 선택합니다. Convert Tracks to Chamfered Path 대화 상자가 열립니다. 이 대화 상자에서 모따기를 설정한 다음 OK을 클릭합니다. 선택한 각 Track 세그먼트 쌍(문제가 되는 90도 각도를 이루는 쌍)은 모따기된 코너로 대체되며, 각 쌍의 원래 Track 세그먼트는 하나의 솔리드(구리) Region 객체로 변환됩니다.

선택한 Track의 각 직각 코너가 지정한 크기만큼 모따기됩니다.
대화 상자에서 다음 옵션을 사용하여 모따기를 설정합니다.
- Chamfer - 잘라내거나 모따기할 바깥쪽 코너의 크기이며, 기존 코너의 대각선 거리에 대한 백분율로 지정합니다.
- Inside Chamfer - 안쪽 코너에 추가할 재료의 양이며, 기존 코너의 대각선 거리에 대한 백분율로 지정합니다.
How big should the Chamfer be?
마이터 백분율은 마이터링하지 않은 굽힘부의 안쪽 코너와 바깥쪽 코너 사이 대각선에서 잘라내는 부분의 비율입니다.
Douville과 James는 다양한 마이크로스트립 형상에 대한 최적의 마이터를 실험적으로 결정했습니다. 이들은 최적의 마이터 백분율에 잘 부합하는 식을 다음과 같이 제시했습니다.
조건은
이며, 기판의 유전 상수는
입니다.
이 공식은
와 완전히 무관합니다. Douville과 James가 근거를 제시한 실제 매개변수 범위는
및
입니다. 이들은 공식으로 산출한 값에서 4%(원래
기준) 이내의 마이터 백분율에 대해 VSWR이 1.1보다 우수하다(즉, 반사 수준이 −26 dB보다 낮다)고 보고했습니다.
의 최솟값인 0.25에서 마이터 백분율은 98.4%이므로 스트립이 거의 완전히 절단됩니다.
Track 속성

Properties Panel의 Track 모드입니다.
Net 정보
이 영역에는 Track이 속한 Net에 대한 정보와 해당 Net이 속한 Differential Pair 및/또는 xSignal에 대한 정보가 표시됩니다. 해당하는 경우 클래스 정보도 표시됩니다. Delay, Length, Max Current 및 Resistance 값도 제공됩니다.
Net 정보에 대한 자세한 내용은 PCB 배치 및 편집 기법 페이지를 참조하십시오.
위치
-
(X/Y)
- X (첫 번째 필드) – 현재 설계 공간 원점을 기준으로 한 Track 기준점의 현재 X(수평) 좌표입니다. Track의 X 위치를 변경하려면 이 값을 편집합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력하십시오.
- Y (두 번째 필드) – 현재 원점을 기준으로 한 Track 기준점의 현재 Y(수직) 좌표입니다. Track의 Y 위치를 변경하려면 이 값을 편집합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력하십시오.
속성
- Component – 이 필드는 선택한 Track이 PCB 컴포넌트의 구성 요소일 때만 PCB Editor에 표시되며, Parent PCB 컴포넌트의 Designator를 표시합니다. 클릭 가능한 Component 링크를 선택하여 Parent 컴포넌트의 Properties 패널의 컴포넌트 모드를 엽니다.
- Net – Track의 Net을 선택하는 데 사용합니다. 활성 보드 설계의 모든 Net이 드롭다운 목록에 표시됩니다. 이미 Net에 연결된 기존 객체와 동일한 위치에서 객체 배치를 시작하면 새 객체의 Net 속성이 해당 Net에 자동으로 할당됩니다. Track이 어떤 Net에도 연결되지 않도록 지정하려면 No Net 을 선택합니다. 프리미티브의 Net 속성은 Design Rule 검사기가 PCB 객체의 배치가 규칙에 부합하는지 판단하는 데 사용합니다. 또는 Assign Net 아이콘을 클릭하여 설계 공간에서 객체를 선택할 수 있습니다. 해당 객체의 Net이 선택한 Track에 할당됩니다.
- Layer – 드롭다운을 사용하여 Track이 위치한 레이어를 선택합니다.
- Width – Track의 현재 폭을 표시합니다. Track 폭을 0.001mil~10000mil 범위 내에서 변경하려면 이 필드를 편집합니다.
- Start (X/Y) – 현재 원점을 기준으로 한 Track 시작점의 현재 X/Y 좌표를 표시합니다.
- End (X/Y) – 현재 원점을 기준으로 한 Track 끝점의 현재 X/Y 좌표를 표시합니다.
-
Length – Track의 현재 길이를 표시합니다. Track 길이를 0.001mil~10000mil 범위 내에서 변경하려면 이 필드를 편집합니다.
Paste Mask Expansion
- Rule/Manual – 원하는 Paste Mask Expansion Configuration을 선택합니다. Track의 Paste Mask Expansion이 해당 Paste Mask Expansion Design Rule에 정의된 값을 따르도록 하려면 Rule를 선택합니다. 해당 Design Rule을 재정의하고 Track의 Paste Mask Expansion 값을 지정하려면 Manual를 선택합니다. 그런 다음 활성화하고 원하는 치수를 입력할 수 있습니다.
Solder Mask Expansion
- Rule/Manual – 원하는 Solder Mask Expansion Configuration을 선택합니다. Track의 Solder Mask Expansion이 해당 Solder Mask Expansion Design Rule에 정의된 값을 따르도록 하려면 Rule를 선택합니다. 해당 Design Rule을 재정의하고 Track의 Solder Mask Expansion 값을 지정하려면 Manual를 선택합니다. 그런 다음 활성화하고 원하는 치수를 입력할 수 있습니다.
Arc 작업하기
Arc는 기본 설계 객체입니다. 본질적으로 모든 레이어에 배치할 수 있는 원형 Track 세그먼트입니다. Arc는 PCB 레이아웃에서 다양하게 활용할 수 있습니다. 예를 들어 오버레이 레이어에서 컴포넌트 Outline을 정의하거나, 기계 레이어에서 보드 Outline과 컷아웃의 가장자리 등을 표시하는 데 사용할 수 있습니다. 또한 대화형 라우팅 중에 곡선 경로를 만드는 데도 사용할 수 있습니다. Arc는 열린 형태로 만들거나 닫아서 원을 만들 수 있습니다(이를 흔히 완전한 원형 Arc라고 합니다).

배치된 두 개의 Arc. 왼쪽은 완전한 원형 Arc이고, 오른쪽은 편집을 위해 선택된 Arc입니다.
Arc는 PCB Editor와 PCB Library Editor 모두에서 배치할 수 있습니다. Arc 배치 모드에는 네 가지가 있습니다(중심, 가장자리, 임의 각도, 완전한 원). Arc를 배치하는 방식은 선택하여 실행한 배치 방법에 따라 달라집니다.
-
Place arc by center – 이 방법을 사용하면 Arc의 중심을 시작점으로 하여 Arc 객체를 배치할 수 있습니다.
명령을 실행하면 커서가 십자 모양으로 바뀌고 Arc 배치 모드로 전환됩니다. 다음 순서로 배치합니다.
- 클릭하거나 Enter를 눌러 Arc의 중심점을 고정합니다.
- 커서를 움직여 Arc의 반지름을 조정한 다음 클릭하거나 Enter를 눌러 설정합니다.
- 커서를 움직여 Arc의 시작점을 조정한 다음 클릭하거나 Enter를 눌러 고정합니다.
- 커서를 움직여 Arc의 끝점 위치를 변경한 다음 클릭하거나 Enter를 눌러 고정하고 Arc 배치를 완료합니다.
- Arc를 계속 배치하거나 마우스 오른쪽 버튼을 클릭하거나 Esc를 눌러 배치 모드를 종료합니다.
-
Place arc by edge – 이 방법을 사용하면 Arc의 가장자리를 시작점으로 하여 Arc 객체를 배치할 수 있습니다. Arc의 각도는 90°로 고정됩니다.
명령을 실행하면 커서가 십자 모양으로 바뀌고 Arc 배치 모드로 전환됩니다. 다음 순서로 배치합니다.
- 클릭하거나 Enter를 눌러 Arc의 시작점을 고정합니다.
- 커서를 움직여 Arc의 끝점 위치를 변경한 다음 클릭하거나 Enter를 눌러 고정하고 Arc 배치를 완료합니다.
- Arc를 계속 배치하거나 마우스 오른쪽 버튼을 클릭하거나 Esc를 눌러 배치 모드를 종료합니다.
-
Place arc by edge (any angle) – 이 방법을 사용하면 Arc의 가장자리를 시작점으로 하여 Arc 객체를 배치할 수 있습니다. Arc의 각도는 임의의 값으로 설정할 수 있습니다.
명령을 실행하면 커서가 십자 모양으로 바뀌고 Arc 배치 모드로 전환됩니다. 다음 순서로 배치합니다.
- 클릭하거나 Enter를 눌러 Arc의 시작점을 고정합니다.
- 커서를 움직여 Arc의 반지름을 조정한 다음 클릭하거나 Enter를 눌러 중심점을 고정합니다.
- 커서를 움직여 Arc의 끝점 위치를 변경한 다음 클릭하거나 Enter를 눌러 고정하고 Arc 배치를 완료합니다.
- Arc를 계속 배치하거나 마우스 오른쪽 버튼을 클릭하거나 Esc를 눌러 배치 모드를 종료합니다.
-
Place full circle arc – 이 방법을 사용하면 360°(완전한 원) Arc를 배치할 수 있습니다.
명령을 실행하면 커서가 십자 모양으로 바뀌고 Arc 배치 모드로 전환됩니다. 다음 순서로 배치합니다.
- 클릭하거나 Enter를 눌러 Arc의 중심점을 고정합니다.
- 커서를 움직여 Arc의 반지름을 조정한 다음 클릭하거나 Enter를 눌러 설정하고 Arc 배치를 완료합니다.
- Arc를 계속 배치하거나 마우스 오른쪽 버튼을 클릭하거나 Esc를 눌러 배치 모드를 종료합니다.
배치 중에 수행할 수 있는 추가 작업은 다음과 같습니다.
- 모든 방법에서(완전한 원형 Arc 제외) Arc의 끝점을 정의하기 전에 Spacebar를 누르면 Arc가 반대 방향으로 그려집니다.
- L 키를 누르면 Arc를 보드의 반대쪽 면으로 뒤집을 수 있습니다. 이 작업은 Arc의 시작점/중심점을 고정하기 전에만 가능합니다.
- 숫자 키패드의 + 및 - 키를 누르거나 Shift+Ctrl+Wheelroll 단축키를 사용하면 설계에서 보이는 모든 레이어를 앞뒤로 순환하며 배치 레이어를 빠르게 변경할 수 있습니다.
그래픽 편집 방법을 사용하면 설계 공간에서 배치된 Arc 객체를 직접 선택하여 크기, 모양 또는 위치를 그래픽 방식으로 변경할 수 있습니다.
Arc 객체를 선택하면 다음 편집 핸들을 사용할 수 있습니다.

선택된 Arc
- A를 클릭하고 드래그하여 반지름을 조정합니다.
- B를 클릭하고 드래그하여 끝점(시작 및 끝 각도)을 조정합니다.
-
Arc에서 편집 핸들이 아닌 임의의 지점을 클릭한 다음 드래그하여 위치를 변경합니다. 또는 Arc의 중심점을 클릭하고 드래그합니다. 드래그하는 동안 Arc를 회전하거나 대칭 반전할 수 있습니다.
- Spacebar 키를 누르면 Arc가 반시계 방향으로 회전하고, Shift+Spacebar 키를 누르면 시계 방향으로 회전합니다. 회전은 Preferences 대화 상자의 PCB Editor – 일반 페이지에서 정의한 Rotation Step 값에 따라 수행됩니다.
- X 또는 Y 키를 누르면 Arc가 X축 또는 Y축을 기준으로 대칭 이동합니다.
Arc 속성
Net 정보
이 영역에는 Arc가 속한 Net에 대한 정보와 해당 Net이 Differential Pair 및/또는 xSignal의 멤버인 경우 관련 정보가 표시됩니다. 해당하는 경우 클래스 정보도 표시됩니다. Delay, Length, Max Current, Resistance 값도 제공됩니다.
Net 정보에 대한 자세한 내용은 PCB 배치 및 편집 기법 페이지를 참조하세요.
위치
-
(X/Y)
- X (첫 번째 필드) - 이 필드는 현재 원점을 기준으로 Arc 중심의 현재 X 위치를 표시합니다. 필드의 값을 편집하여 현재 원점에 대한 Arc의 위치를 변경할 수 있습니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위와 다른 단위로 값을 입력할 때는 단위를 함께 입력하세요. Default 단위(미터법 또는 야드파운드법)는 Board 모드(설계 공간에서 아무 객체도 선택하지 않았을 때 액세스)의 Properties 패널에 있는 Other 영역의 Units 설정에 따라 결정되며, 단위를 지정하지 않으면 이 단위가 사용됩니다.
- Y (두 번째 필드) - 이 필드는 현재 원점을 기준으로 Arc 중심의 현재 Y 위치를 표시합니다. 필드의 값을 편집하여 현재 원점에 대한 Arc의 위치를 변경할 수 있습니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위와 다른 단위로 값을 입력할 때는 단위를 함께 입력하세요. Default 단위(미터법 또는 야드파운드법)는 Board 모드(설계 공간에서 아무 객체도 선택하지 않았을 때 액세스)의 Properties 패널에 있는 Other 영역의 Units 설정에 따라 결정되며, 단위를 지정하지 않으면 이 단위가 사용됩니다.
속성
- Component – 이 필드는 선택한 Arc가 PCB 컴포넌트의 구성 요소인 경우에만 PCB Editor에 표시되며, 상위 PCB 컴포넌트의 Designator를 표시합니다. 클릭 가능한 Component 링크를 선택하면 상위 컴포넌트에 대한 Properties 패널의 컴포넌트 모드가 열립니다.
- Net – Arc의 Net을 선택하는 데 사용합니다. 활성 보드 설계의 모든 Net이 드롭다운 목록에 표시됩니다. 이미 Net에 연결된 기존 객체와 같은 위치에서 객체 배치를 시작하면 새 객체의 Net 속성이 해당 Net으로 자동 지정됩니다. No Net 을 선택하면 Arc가 어떤 Net에도 연결되지 않도록 지정할 수 있습니다. 프리미티브의 Net 속성은 Design Rule 검사기가 PCB 객체의 배치가 규칙에 맞는지 판단하는 데 사용됩니다. 또는 Assign Net 아이콘을 클릭하여 설계 공간에서 객체를 선택할 수 있습니다. 해당 객체의 Net이 선택한 Arc에 지정됩니다.
- Layer - 이 필드는 Arc가 현재 지정된 레이어를 표시합니다. Arc는 사용 가능한 모든 레이어에 지정할 수 있습니다. 지정된 레이어를 변경하려면 필드를 클릭하고 드롭다운 목록에서 레이어를 선택하세요.
- Width - 이 필드는 Arc 선의 폭을 표시합니다. 필요한 경우 다른 폭 값을 입력하세요.
- Radius - 이 필드는 중심점에서 Arc 선의 중심까지 측정한 Arc의 반지름을 표시합니다. 필요한 경우 다른 반지름 값을 입력하세요.
- Start Angle - 이 필드는 제1사분면(평면 기하학)의 X축을 기준으로 측정한 Arc의 시작 각도를 표시합니다. 필요한 경우 다른 시작 각도 값을 입력하세요.
- End Angle - 이 필드는 Arc의 끝 각도를 표시합니다. 필요한 경우 다른 끝 각도 값을 입력하세요.
- Propagation Delay - 이 필드는 Signal이 해당 경로를 따라 전파되는 데 걸리는 시간을 표시합니다.
Paste Mask Expansion
- Rule - Arc의 Paste Mask Expansion이 해당 Paste Mask Expansion Design Rule에 정의된 값을 따르도록 하려면 선택하세요. 이 옵션을 선택하면 관련 Expansion 값이 비활성화됩니다.
- Manual - 해당 Design Rule을 재정의하고 아래 필드에서 Arc의 Paste Mask Expansion 값을 지정하려면 선택하세요.
Solder Mask Expansion
- Rule - Arc의 Solder Mask Expansion이 해당 Solder Mask Expansion Design Rule에 정의된 값을 따르도록 하려면 체크박스를 선택하세요. 이 옵션을 선택하면 관련 Expansion 값이 비활성화됩니다.
- Manual - 해당 Design Rule을 재정의하고 아래 필드에서 Arc의 Solder Mask Expansion 값을 지정하려면 체크박스를 선택하세요.
Track과 Arc로 선택한 객체의 외곽선 만들기
메인 메뉴의 Tools » Outline Selected Objects 명령을 사용하면 설계에서 선택한 독립 프리미티브 주위에 Track과 Arc로 외곽선을 배치할 수 있습니다. 이 기능은 외곽선을 접지에 연결하여 중요한 Net을 전기적으로 격리하려는 경우 특히 유용합니다. 명령을 실행하면 객체 주위에 Track 및/또는 Arc로 외곽선이 만들어집니다. 외곽선을 구성하는 Track/Arc는 폭이 8mil로 배치되며, Net 속성은 No Net로 설정됩니다.
설계의 클리어런스, 폭 및 단락 Design Rule이 적용되므로, 클리어런스 위반은 Design Rule 검사기에서 표시됩니다.
직사각형 작업하기
직사각형은 모든 레이어에 배치할 수 있습니다. 다양한 크기의 직사각형을 조합하여 불규칙한 모양의 영역을 덮을 수 있으며, Track 또는 Arc 세그먼트와 조합할 수도 있습니다.
직사각형은 비전기적 레이어에도 배치할 수 있습니다. 예를 들어 Keep-Out 레이어에 직사각형을 배치하여 자동 라우팅의 '진입 금지' 영역을 지정할 수 있습니다. Power Plane, Solder Mask 또는 Paste Mask 레이어에 직사각형을 배치하면 해당 레이어에 빈 영역을 만들 수 있습니다.

배치된 직사각형
PCB 및 PCB 라이브러리 Editor 모두에서 다음 방법으로 직사각형을 배치할 수 있습니다.
- PCB Editor - 다음 방법으로 액세스할 수 있습니다:
- 메인 메뉴에서 Place » Rectangle 을 선택합니다.
- 설계 공간 상단에 있는 Active Bar 의 드롭다운에서 Rectangle 버튼을 클릭합니다. (Active Bar 버튼을 길게 클릭하면 관련된 다른 명령에 액세스할 수 있습니다. 명령을 사용하면 해당 명령이 Active Bar의 해당 섹션에서 맨 위 항목이 됩니다.)
- 설계 공간에서 마우스 오른쪽 버튼을 클릭한 다음 컨텍스트 메뉴에서 Place » Rectangle 을 클릭합니다.
-
PCB Library Editor - 다음 방법으로 액세스할 수 있습니다:
- 메인 메뉴에서 Place » Rectangle 을 선택합니다.
- 설계 공간 상단에 있는 Active Bar 의 드롭다운에서 Rectangle 버튼을 클릭합니다. (Active Bar 버튼을 길게 클릭하면 관련된 다른 명령에 액세스할 수 있습니다. 명령을 사용하면 해당 명령이 Active Bar의 해당 섹션에서 맨 위 항목이 됩니다.)
- 설계 공간에서 마우스 오른쪽 버튼을 클릭한 다음 컨텍스트 메뉴에서 Place » Rectangle 을 선택합니다.
명령을 실행하면 커서가 십자 모양으로 바뀌고 사각형 배치 모드로 들어갑니다. 다음 순서로 사각형을 배치합니다:
- 클릭하거나 Enter을 눌러 사각형의 첫 번째 모서리를 고정합니다.
- 커서를 움직여 사각형 크기를 조정한 다음 클릭하거나 Enter을 눌러 대각선 반대편 모서리를 고정하고 사각형 배치를 완료합니다.
- 계속해서 사각형을 더 배치하거나 마우스 오른쪽 버튼을 클릭하거나 Esc을 눌러 배치 모드를 종료합니다.
배치 중에는 다음 작업도 수행할 수 있습니다:
- Tab 키를 눌러 배치를 일시 중지하고 Properties Panel의 사각형 모드에 액세스하여 속성을 즉시 변경할 수 있습니다. 설계 공간에 오버레이로 표시되는 일시 중지 버튼을 클릭하면 배치가 재개됩니다.
- 스페이스바 를 눌러 다양한 모서리 모드를 순환합니다. 직각 모서리는 Rectangle , 둥근 모서리는 Fillet , 경사진 모서리는 Chamfer를 선택합니다.
- 숫자 키패드의 + 및 - 키를 눌러 설계에서 표시되는 모든 레이어를 정방향 또는 역방향으로 순환하며 배치 레이어를 빠르게 변경합니다.
- Alt 키를 길게 누르면 초기 이동 방향에 따라 이동 방향이 수평 또는 수직 축으로 제한됩니다.
그래픽 편집 방식에서는 설계 공간에서 배치된 사각형 객체를 직접 선택하여 크기, 모양 또는 위치를 그래픽으로 변경할 수 있습니다.
사각형 객체를 선택하면 다음 편집 핸들을 사용할 수 있습니다.
선택된 사각형
- 모서리(A)를 클릭하고 드래그하여 사각형의 세로 및 가로 크기를 동시에 조정합니다.
- 변의 중앙(B)을 클릭하고 드래그하여 사각형의 세로 및 가로 크기를 각각 조정합니다.
-
편집 핸들이 아닌 사각형의 아무 곳이나 클릭하고 드래그하여 위치를 변경합니다. 드래그하는 동안 사각형을 회전하거나 대칭 이동할 수 있습니다:
- Spacebar을 누르면 사각형이 반시계 방향으로 회전하고, Shift+Spacebar을 누르면 시계 방향으로 회전합니다. 회전은 Preferences 대화 상자의 PCB Editor – 일반 페이지에 정의된 Rotation Step 값에 따라 이루어집니다.
- X 또는 Y 키를 눌러 사각형을 X축 또는 Y축 기준으로 대칭 이동합니다.
사각형 속성

Properties Panel의 Rectangle 모드.
위치
-
(X/Y)
- X (첫 번째 필드) - 현재 설계 공간 원점을 기준으로 한 사각형 기준점의 현재 X(수평) 좌표입니다. 이 값을 편집하여 사각형의 X 위치를 변경합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있으며, 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력합니다.
- Y (두 번째 필드) - 현재 원점을 기준으로 한 사각형 기준점의 현재 Y(수직) 좌표입니다. 이 값을 편집하여 Fill의 Y 위치를 변경합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있으며, 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력합니다.
- Rotation - 0도( 3 o'clock 수평)를 기준으로 반시계 방향으로 측정한 사각형의 회전 각도(도 단위)입니다. 이 값을 편집하여 사각형의 회전을 변경합니다. 최소 각도 분해능은 0.001°입니다.
속성
-
Corner Mode - 드롭다운을 사용하여 다음 옵션 중 원하는 사각형 모서리 모드를 선택합니다:
- Rectangle - 배치되는 사각형의 모서리를 직각으로 지정합니다.
- Fillet - 배치되는 사각형의 모서리를 둥글게 지정합니다.
- Chamfer - 배치되는 사각형의 모서리를 경사지게 지정합니다.
- Track Width - Track의 현재 폭을 표시합니다. 이 필드를 편집하여 Track 폭을 0.001mil~10000mil 범위에서 변경합니다.
- Fillet/Chamfer Size - Corner Mode 드롭다운에서 Fillet 또는 Chamfer 을 선택하거나 배치 중에 필렛 또는 모따기 모드를 선택한 경우에만 사용할 수 있습니다.
- Layer - 사각형이 현재 할당된 레이어입니다. 사각형은 사용 가능한 모든 레이어에 할당할 수 있습니다. 드롭다운을 사용하여 다른 레이어를 선택합니다.
- Width - 선택한 사각형의 (X축) 폭을 표시합니다.
- Height - 선택한 사각형의 (Y축) 높이를 표시합니다.
-
- 이 아이콘을 클릭하면 사각형의 기존 X 대 Y 비율이 유지됩니다.

