Incluindo detalhes do projeto
Num relance
- Saiba quais detalhes da documentação de PCBs podem ser adicionados no editor de PCB ou no editor de bibliotecas de PCB e como as camadas mecânicas são usadas para organizá-los.
- Veja o que as tabelas de empilhamento de camadas e as tabelas de furação incluem, onde podem ser posicionadas e como são atualizadas ou refletem o projeto atual da placa.
- Entenda as principais opções de posicionamento, movimentação, redimensionamento e propriedades que controlam como esses elementos de documentação aparecem nos arquivos de saída do seu PCB.
Muitas das saídas que você gera exigirão detalhes adicionais. Por exemplo, o desenho de fabricação precisará de cotas, o desenho de montagem poderá precisar de uma vista ampliada de uma área específica da placa, e o desenho de fabricação precisará de uma Tabela de Empilhamento de Camadas e de uma Tabela de Furação. Esses tipos de detalhe podem ser adicionados no editor de PCB ou no editor de Bibliotecas de PCB.
Camadas de Desenho de Uso Geral
No editor de PCB, detalhes como cotas e instruções de fabricação e montagem são adicionados em camadas mecânicas. O software oferece suporte a um número ilimitado de camadas mecânicas de uso geral, que são habilitadas no painel Configuração de Visualização. Essas camadas podem receber nomes conforme necessário (clique com o botão direito no nome e selecione Edit Layer) e ser incluídas em impressões e saídas de fabricação baseadas em camadas.
Tabela de Empilhamento de Camadas

Uma Tabela de Empilhamento de Camadas pode ser inserida em um documento de PCB ao lado do próprio projeto. Ela fornece um resumo detalhado dos empilhamentos de camadas da placa e de como os grupos de camadas são atribuídos.
Uma Tabela de Empilhamento de Camadas é um objeto gráfico tabular que documenta as camadas, os materiais, as espessuras e as constantes dielétricas implementados no projeto de PCB atual. Ela é inserida e posicionada ao lado do projeto da placa na área de projeto e também inclui uma legenda gráfica e um mapa de opções que mostra o empilhamento de camadas usado em cada região da placa. Uma Tabela de Empilhamento de Camadas reflete as configurações de camadas definidas por meio do Layer Stack Manager e é um recurso de documentação importante para projetos com uma estrutura complexa de empilhamento de camadas, como um projeto rígido-flexível.
A Tabela de Empilhamento de Camadas está disponível no editor de PCB quando a visualização da área de projeto está definida para o modo 2D normal (atalho 2). Após iniciar o comando de inserção da Tabela de Empilhamento de Camadas (Place » Layer Stack Table), o cursor mudará para uma mira e você entrará no modo de inserção da Tabela de Empilhamento de Camadas. A inserção é realizada executando a seguinte sequência de ações:
- Clique para inserir a tabela.
- O editor permanece no modo de inserção da Tabela de Empilhamento de Camadas, pronto para inserir outra tabela, se necessário. Caso contrário, clique com o botão direito ou pressione Esc para sair do modo de inserção.
Outras ações que podem ser executadas durante a inserção, enquanto a tabela de empilhamento de camadas ainda está flutuando no cursor e antes de seu ponto central ser fixado, são:
- Pressione a tecla Alt para restringir a direção do movimento ao eixo horizontal ou vertical, dependendo da direção inicial do movimento.
- Pressione Spacebar para girar a tabela de empilhamento de camadas no sentido anti-horário ou Shift+Spacebar para girá-la no sentido horário. A rotação ocorre em incrementos de 90°.
Para mover uma Tabela de Empilhamento de Camadas, clique na tabela, mantenha o botão pressionado e arraste-a até o local desejado.

Selecione e arraste para reposicionar uma Tabela de Empilhamento de Camadas.
Propriedades da Tabela de Empilhamento de Camadas

O modo Layer Stack Table do painel Properties.
Localização
-
(X/Y)
- X (primeiro campo) - a coordenada X (horizontal) atual do ponto de referência do objeto, em relação à origem atual da área de projeto. Edite para alterar a posição X do objeto. O valor pode ser inserido no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades não sejam as padrão atuais.
- Y (segundo campo) - A coordenada Y (vertical) atual do ponto de referência do objeto, em relação à origem atual. Edite para alterar a posição Y do objeto. O valor pode ser inserido no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades não sejam as padrão atuais.
- Rotation - o ângulo de rotação do objeto (em graus), medido no sentido anti-horário a partir de zero (a 3 o'clock horizontal). Edite para alterar a rotação do objeto. A resolução angular mínima é de 0,001°.
Propriedades
- Layer - a camada à qual a tabela está atribuída atualmente. Use a lista suspensa para selecionar outra camada.
- Alignment - use a lista suspensa para selecionar o alinhamento desejado.
-
Units - use a lista suspensa para selecionar
Metric (mm)ouImperial (mil). - Show Board Map - habilite para exibir um contorno da placa que mostra como os vários empilhamentos de camadas são atribuídos às regiões da placa. Use o controle deslizante para alterar a escala do contorno da placa exibido.
- Show Total Board Thickness - habilite para exibir a espessura total da placa abaixo da grade na tabela de empilhamento de camadas.
- Line Width - especifique a largura do traço do texto na tabela. Line Width afeta a espessura do traço do texto.
- Text Height - a altura atual dos caracteres do texto. Especifique a altura do texto na tabela. Text Height também afeta o tamanho da tabela. Se a altura do texto for aumentada, a tabela será expandida automaticamente.
Tipo de Fonte
-
TrueType - use este campo para escolher a fonte TrueType desejada. A lista suspensa Font é preenchida com as fontes TrueType e OpenType (um superconjunto de TrueType) encontradas na pasta
\Windows\Fonts. Observe que a lista incluirá apenas entradas para fontes raiz detectadas (e com nomes exclusivos). Use as opções B (bold) e I (Italic) para dar ênfase ao texto. -
Stroke
-
Font - use este campo para escolher a fonte de traço desejada. As opções disponíveis são:
-
Default- uma fonte vetorial simples que permite plotagem com caneta e fotoplotagem vetorial. -
Serif- uma fonte mais complexa que torna mais lenta a geração de saídas vetoriais, como Gerber. -
Sans Serif- uma fonte mais complexa que torna mais lenta a geração de saídas vetoriais, como Gerber.
-
-
Font - use este campo para escolher a fonte de traço desejada. As opções disponíveis são:
-
Stroke Width - exibe a largura atual do traço.
Colunas
Use esta região para especificar quais colunas deseja exibir na tabela de empilhamento de camadas, o alinhamento do texto em cada coluna e a largura total da coluna.
- Caption - o título da coluna a ser exibida.
- Align - clique na célula de alinhamento do título que deseja alinhar. Continue clicando para percorrer as opções de alinhamento (à esquerda, centralizado e à direita). Cada clique no campo de alinhamento altera o alinhamento do texto dessa coluna na tabela.
-
Width - clique no campo para editar a largura da coluna selecionada. Quando
Autoé especificado, o sistema ajusta automaticamente a largura da coluna de acordo com o texto inserido nela. Se desejar, você pode inserir a largura necessária. - Add - use a lista suspensa para adicionar uma coluna à tabela de empilhamento de camadas a partir das opções disponíveis. Na lista suspensa, clique no título que deseja exibir na tabela.
- Up - clique para mover a coluna com o título selecionado uma posição para a esquerda na tabela. Use o botão Up repetidamente para mover a coluna selecionada mais posições para a esquerda.
- Down - clique para mover a coluna com o título selecionado uma posição para a direita na tabela. Use o botão Down repetidamente para mover a coluna selecionada mais posições para a direita.
-
- clique para excluir o título selecionado da tabela. Uma confirmação aparece na tabela perguntando se você deseja excluir o item selecionado. Clique em Yes se desejar excluí-lo; No caso contrário.
Tabela de furação

A tabela de furação apresenta um resumo em tempo real de todos os furos presentes na placa
Uma tabela de furação (também conhecida como tabela do desenho de furação ou legenda do desenho de furação) é um elemento padrão necessário para a fabricação de uma placa de circuito impresso. A tabela de furação lista o tamanho e a quantidade de furos para cada broca usada na placa. Cada diâmetro de broca pode ser representado por um símbolo, uma letra ou pelo tamanho real do furo. Quando um desenho de furação é gerado para a placa, cada local de furação é marcado com um símbolo. A tabela de furação é atualizada em tempo real, ou seja, à medida que objetos que contêm furos, como pads e vias, são inseridos ou removidos do projeto da PCB, a tabela é atualizada.
Uma tabela de furação só pode ser inserida no Editor de PCB. Após iniciar o comando, uma tabela de furação aparecerá anexada ao cursor. Posicione a tabela em um local adequado fora da placa e clique ou pressione Enter para inseri-la.
Outras ações que podem ser executadas durante a inserção, enquanto a tabela de furação ainda estiver flutuando no cursor e antes de ser fixada, são:
- Pressione a tecla Tab para pausar a inserção e acessar o modo Tabela de furação do painel Properties , onde suas propriedades podem ser alteradas em tempo real. Clique no botão de pausa sobreposto para retomar a inserção.
- Pressione a tecla Alt para restringir a direção do movimento ao eixo horizontal ou vertical, dependendo da direção inicial do movimento.
Como mover uma tabela de furação
Clique e mantenha pressionado em qualquer ponto dentro da tabela de furação e mova-a para o local desejado na área de projeto do Editor de PCB.
Redimensionamento interativo de uma tabela de furação
A tabela de furação é dimensionada automaticamente com base na configuração Text Height especificada, bem como na quantidade de diâmetros de furo diferentes (linhas) e no número de colunas definidas. Para redimensionar a tabela de forma interativa, clique uma vez para selecioná-la, clique e mantenha pressionado em um vértice de canto e mova-o para redimensioná-la conforme necessário. Observe que o redimensionamento interativo da tabela também aumentará ou diminuirá o tamanho da fonte.
Alternância interativa do par de camadas a visualizar
Quando a placa inclui pares de camadas, o par exibido é controlado pela opção Layers Pairs no modo Drill Table do painel Properties .
O par de camadas escolhido também pode ser alternado usando:
-
O menu de contexto do Editor de PCB - clique com o botão direito na tabela de furação e selecione o par de camadas desejado no submenu Drill Table, conforme mostrado na imagem abaixo.

Clique com o botão direito na tabela de furação para exibir outro par de camadas -
O menu de seleção de pares de camadas, acessado pela aba de camada na parte inferior da área de projeto, conforme mostrado na imagem abaixo.
Propriedades da tabela de furação

O modo Drill Table do painel Properties
Ações
Refresh – clique no botão para atualizar a tabela de furação com os dados atuais dos símbolos de furação da PCB.
Localização
-
(X/Y) – as posições X e Y atuais do ponto de referência da tabela de furação. O ponto de referência é o canto inferior esquerdo se Alignment =
Bottom, ou o canto superior esquerdo se Alignment =Top. - Rotation – ângulo, em graus, de rotação da tabela de furação.
Propriedades
-
Layer Pairs – a tabela de furação oferece suporte a placas multicamadas que utilizam furação por pares de camadas. Use a lista suspensa para selecionar um par de camadas definido na guia Tipos de via do Gerenciador de empilhamento de camadas ou uma das seguintes opções:
- All Layer Pairs (Composite table) – exibe informações de todos os pares de camadas.
-
All Layer Pairs (Separate tables) – exibe informações de cada par de camadas em uma tabela separada.
- Top - Bottom – mostra apenas os furos passantes.
- Counterhole Bottom – mostra apenas os furos com rebaixo (cilíndrico/cônico) no lado inferior da PCB.
- Counterhole Top – mostra apenas os furos com rebaixo (cilíndrico/cônico) no lado superior da PCB.
- Text Height – exibe a altura do texto.
Tipo de fonte
-
TrueType – selecione para usar as fontes disponíveis no seu PC (na pasta \Windows\Fonts). As fontes TrueType oferecem suporte completo a Unicode. Por padrão, o software cria um vínculo com a fonte TrueType utilizada (elas não são armazenadas no arquivo PCB), o que significa que a mesma fonte deve estar presente em cada PC para o qual o projeto for transferido. Como alternativa, incorpore as fontes TrueType utilizadas ao arquivo PCB usando as opções na página Editor de PCB – Fontes TrueType da caixa de diálogo Preferences, na qual você também pode selecionar uma Substitution Font a ser usada caso uma fonte não incorporada não esteja disponível.
- Font – use a lista suspensa para selecionar a fonte TrueType desejada. Use B para aplicar negrito ou I para aplicar itálico ao texto.
-
Stroke
-
Font – use a lista suspensa para selecionar a fonte de traço desejada. As opções são:
-
Default– uma fonte vetorial simples desenvolvida para plotagem com caneta e fotoplotagem vetorial. -
Sans Serif -
Serif
-
- Stroke Width – exibe a largura do traço.
-
Font – use a lista suspensa para selecionar a fonte de traço desejada. As opções são:
- Show Footer – alterne para habilitar/desabilitar a exibição do rodapé da tabela.
- Alignment – a tabela pode ser construída de baixo para cima (Bottom) ou de cima para baixo (Top). Use esta configuração para permitir alterações no tamanho da tabela sem afetar os objetos ao redor na área de projeto.
- Table Border Width – largura das linhas usadas para criar a borda da tabela.
-
Drill Symbols – clique para abrir a caixa de diálogo Drill Symbols, na qual você pode atribuir símbolos/letras aos diâmetros dos furos.
Opções e controles da caixa de diálogo Símbolos de furação
Grid Area
A área da grade exibe informações detalhadas sobre a associação de um símbolo a um diâmetro de furo. Ela pode ser personalizada clicando e arrastando o cabeçalho de uma coluna para alterar a ordem das colunas e clicando com o botão direito em um cabeçalho de coluna e marcando/desmarcando a caixa de seleção para mostrar/ocultar a coluna.
Grouping
Clique no botão Grouping para definir quais propriedades serão usadas para controlar a atribuição de símbolos às ocorrências de furação (furos). Os furos são agrupados inicialmente pelo diâmetro e, em seguida, recebem símbolos distintos sempre que uma opção de agrupamento que os identifique de forma exclusiva estiver habilitada. Por exemplo, o projeto pode incluir um pad redondo com um furo de 1 mm e outro pad quadrado com um furo de 1 mm. Se Pad Shape não estiver habilitado em Grouping, eles receberão o mesmo símbolo. Mas, se Pad Shape estiver habilitado em Grouping, eles receberão símbolos distintos.
Graphic Symbol
Cada posição de furo pode ser representada por um símbolo, uma letra ou uma sequência de caracteres que mostre o diâmetro real do furo. Estas opções controlam o estilo e o tamanho do símbolo:
-
Symbol - selecione para usar um símbolo em cada posição de furo. O software inclui 15 estilos de símbolo predefinidos, conforme mostrado na imagem abaixo. Se houver mais de 15 diâmetros de furo, caracteres alfabéticos serão atribuídos automaticamente.
- Character - selecione para usar um caractere alfabético em cada posição de furo.
- Symbol Size - a altura do símbolo/letra exibido na camada de desenho de furação. Observe que esta configuração se aplica a todos os símbolos/letras usados no desenho de furação.
Draw Symbols
Estas opções controlam o estilo dos símbolos de furação e quando eles devem ser exibidos:
- Show Symbols - mostra um símbolo em cada posição de furo.
- Show Hole Size - mostra o diâmetro real de furação em cada posição de furo como um valor numérico.
- Show Drill Symbols - o comportamento padrão é não mostrar os símbolos de furação na camada de desenho de furação. Habilite esta opção para exibir os símbolos de furação.
-
-
– clique para atualizar a tabela sempre que houver alterações no projeto que afetem a tabela de furação. Observe que a tabela é atualizada automaticamente durante a geração das saídas.
Unidades
-
Primary Units – use a lista suspensa para definir as unidades primárias como
Metric (mm)ouImperial (mil). -
Dual Units – use a lista suspensa para definir as unidades secundárias como
Metric (mm)ouImperial (mil). Use
ou
para determinar se essas unidades serão exibidas ou ocultadas (respectivamente) na área de projeto.
Precisão
- Primary Precision – use a lista suspensa para definir a precisão necessária (número de dígitos após a vírgula decimal).
- Dual Precision – use a lista suspensa para definir a precisão das unidades secundárias (número de dígitos após a vírgula decimal).
Colunas
- Grid – exibe todos os cabeçalhos de coluna (Caption) na tabela de furação, a configuração Align, que reposiciona o conteúdo dentro da grade, o Width e a Order em que as informações de cada coluna são exibidas. Para alternar entre a ordem crescente e a decrescente e vice-versa, clique na coluna Order para acessar um menu suspenso e selecione a ordem desejada: Asc – crescente ou Dsc – decrescente.
-
Edit Columns – clique para abrir a caixa de diálogo Columns, que permite adicionar novas colunas à tabela de furação ou editar as colunas existentes.
A caixa de diálogo apresenta todas as colunas existentes, juntamente com os dados associados (somente leitura). Use os seguintes botões abaixo da grade para selecionar e organizar os dados a serem apresentados na tabela:
- Add Column - use para adicionar uma nova coluna à tabela de furação. Clique para abrir um menu de colunas disponíveis. As colunas que já estão em uso ou não estão disponíveis aparecem esmaecidas no menu. Este comando também está disponível no menu do botão direito.
- Remove Column - clique para remover as colunas selecionadas. Observe que não há uma caixa de diálogo de confirmação; ao clicar no botão, a coluna é excluída. Este comando também está disponível no menu do botão direito.
- Change Header - clique para abrir a caixa de diálogo Alterar cabeçalho da coluna, na qual você pode alterar o título da coluna selecionada. Este comando (chamado Change column header) também está disponível no menu do botão direito.
Os seguintes comandos adicionais estão disponíveis no menu de contexto do botão direito:
-
Text Alignment - use para alinhar o texto na coluna selecionada. As opções incluem:
Left,CentereRight. -
Set column width - use para definir a largura da coluna selecionada. As opções incluem:
Autosize(padrão) eManual. Clicar emManualabre a caixa de diálogo Definir largura da coluna, na qual você pode inserir a largura desejada.
Vista do projeto

Posicione uma vista do projeto para mostrar uma área específica da placa. Este exemplo foi ampliado para 200%.
O objeto Vista do projeto da PCB é uma captura gráfica de qualquer região retangular da placa atual ou de outra placa. Ele pode ser posicionado em qualquer lugar do espaço de projeto e dimensionado para qualquer tamanho.
Uma vista do projeto só pode ser posicionada no Editor de PCB. Após iniciar o comando de posicionamento de vista do projeto (Place » Design View), uma vista do projeto aparecerá anexada ao cursor. Posicione a vista do projeto em um local adequado e clique ou pressione Enter para posicioná-la.
As ações adicionais que podem ser executadas durante o posicionamento, enquanto a vista do projeto ainda estiver flutuando no cursor e antes de ser fixada, são:
- Pressione a tecla Alt para restringir a direção do movimento ao eixo horizontal ou vertical, dependendo da direção inicial do movimento.
Após posicionar a vista do projeto, você pode definir a exibição das camadas desejadas seguindo estas etapas:
- Com a vista do projeto selecionada no espaço de projeto, abra o painel Propriedades clicando duas vezes ou clicando com o botão direito e escolhendo Properties no menu de contexto.
- Use o botão Define no painel Properties para definir interativamente a área de interesse.
-
Na seção Layers do painel Properties , clique no ícone
(para alternar seu estado) e habilitar a exibição das camadas desejadas. Quando habilitadas no painel Properties , as camadas desejadas exibirão o ícone
.
As vistas do projeto são incluídas nas saídas impressas e em PDF. A vista do projeto mantém suas próprias configurações de visibilidade de camadas na saída, permitindo que seja apresentada conforme necessário na impressão ou no PDF. Observe que as primitivas nas camadas usadas na vista do projeto continuam seguindo as configurações de exibição definidas para essa camada na caixa de diálogo Imprimir. Por exemplo, se a camada de serigrafia superior for exibida na vista do projeto e estiver configurada para exibir trilhas no modo Rascunho para essa saída no Output Job, as trilhas da serigrafia superior na vista do projeto também serão apresentadas no modo Rascunho.
Depois que uma vista do projeto for posicionada no espaço de projeto, você poderá ajustar interativamente sua posição, escala, tamanho e foco.
- Change the position – Click+Drag o objeto Vista do projeto para um novo local no espaço de projeto da PCB.
- Adjusting the Scale – clique uma vez para selecionar a vista do projeto e, em seguida, Click+Drag em uma alça de canto para ampliar (arraste para fora) ou reduzir (arraste para dentro) a vista do projeto.
- Adjusting the View Size – clique uma vez para selecionar a vista do projeto e, em seguida, Ctrl+Click+Drag em uma alça de canto para redimensionar a vista do projeto.
- Changing the Focus – Ctrl+Click+Drag em qualquer lugar dentro da vista do projeto para deslocar a área atualmente visualizada dentro da janela da vista do projeto.

Ctrl+Click+Drag para deslocar e ajustar a área atualmente exibida na vista do projeto.
Propriedades da vista do projeto

O modo Design View do painel Properties.
Localização
- (X/Y) - as coordenadas X e Y atuais do ponto de referência da vista do projeto.
Propriedades
- This document - selecione para especificar as propriedades do documento atualmente ativo.
-
Specify document - selecione para especificar as propriedades de outro documento. Quando selecionado, clique em
no campo Document e procure o documento desejado.
-
Document - clique em
para procurar e selecionar o documento desejado quando Specify document estiver selecionado.
- Mirrored - clique para habilitar uma imagem invertida (espelhada) da área da placa na vista do projeto.
- Scale - clique para definir o tamanho do objeto como um fator multiplicador.
- Title - insira o título da vista do projeto.
- Text Height - insira a altura do texto do título da vista do projeto.
- Font - use o menu suspenso para selecionar a fonte desejada para o título. Use a caixa de cor para abrir um seletor de cores para o texto do título. Observe que a cor deve contrastar com a cor de fundo do espaço de projeto para garantir a visibilidade.
- Define - clique para retornar ao espaço de projeto com um cursor em forma de cruz e, em seguida, clique e arraste para definir a região retangular da vista.
Camadas
Esta região fornece uma lista de todas as camadas da placa, que podem ser configuradas para exibir camadas específicas na vista do projeto.
-
Name - o nome da camada. Use o
ou
ícone para mostrar ou ocultar (respectivamente) a camada listada na Visualização do projeto.
- Type - o tipo de camada.
Objeto OLE

Uma sequência de objetos OLE inseridos – uma imagem, células de planilha e texto de um documento do Word (de cima para baixo)
A tecnologia Object Linking and Embedding (OLE) no editor de PCB permite incorporar a um projeto de PCB dados fornecidos por aplicativos OLE do Windows, mantendo um vínculo ativo com o aplicativo de origem. Em muitos casos, isso permite editar os dados incorporados à PCB no aplicativo que os criou.
Os objetos OLE típicos que podem ser inseridos em um documento de PCB incluem documentos comuns do Excel, documentos do Word ou objetos gráficos de um aplicativo de imagens compatível com OLE. Os tipos de arquivo compatíveis incluem formatos universais, como planilhas nos formatos CSV e XLS, documentos de texto DOC e RTF e arquivos de imagem BMP.
Os objetos OLE podem ser inseridos/incorporados no Editor de PCB. Após executar o comando Place » Object From File, escolha o arquivo desejado na caixa de diálogo Choose File e clique para inserir o objeto no espaço de projeto.
O recurso Colagem inteligente da Altium também permite copiar e colar (Edit » Paste) uma seleção de um aplicativo OLE no documento de PCB como um objeto OLE. A opção de colagem de texto (Edit » Paste Text) pode ser usada para extrair os elementos de texto de um objeto OLE, se necessário. Eles serão inseridos como objetos de texto de PCB.
Após a inserção, os objetos incorporados podem ser redimensionados proporcionalmente clicando, mantendo pressionadas e arrastando suas alças de seleção. Para objetos baseados em texto, como documentos do Word e do Excel, o tamanho e a espessura do texto incorporado são ajustados automaticamente às novas dimensões.
- Um objeto OLE também pode ser convertido em um conjunto de objetos primitivos livres usando o comando Tools » Convert » Explode OLE Object to Free Primitives. Isso dividirá o objeto em objetos de região e/ou texto apropriados.
- Uma opção de conversão em primitivas livres também é oferecida se o aplicativo OLE correspondente não for encontrado ao tentar editar um objeto OLE.
Propriedades do objeto OLE

O modo OLE Object do painel Properties.
Localização
- (X/Y) - a coordenada X (horizontal) atual e a coordenada Y (vertical) atual do ponto de referência do objeto em relação à origem atual do espaço de projeto. Edite para alterar a posição do objeto.
- Rotation - o ângulo de rotação do objeto (em graus), medido no sentido anti-horário a partir de zero (a 3 o'clock horizontal). Edite para alterar a rotação do objeto. A resolução angular mínima é de 0,001°.
Propriedades
- Layer - a camada à qual o objeto está atribuído no momento. Use a lista suspensa para selecionar uma camada diferente.
- Edit Data - clique para abrir o objeto (no aplicativo associado) e fazer as edições necessárias. Após fazer as edições e fechar o aplicativo associado, no painel Propriedades, clique em Save para salvar as edições ou em Cancel.
Cotas
Os editores de PCB e de Biblioteca de PCB incluem uma variedade de ferramentas de cotagem para atender a diferentes requisitos de projeto.
| Objeto de cota | Descrição |
|---|---|
| Angular Dimension | Permite cotar distâncias angulares. |
| Baseline Dimension | Permite cotar a distância linear de um conjunto de referências em relação a uma única referência base. O primeiro ponto escolhido é a “base”. Todos os pontos subsequentes são relativos a esse primeiro ponto. Portanto, o valor da cota em cada caso é a distância entre cada ponto de referência e a “base”, medida nas unidades padrão. As referências podem ser trilhas, arcos, pads, vias, textos, preenchimentos, polígonos ou componentes. |
| Center Dimension | Permite marcar o centro de um arco ou círculo. |
| Leader Dimension | Permite rotular um objeto, ponto ou área. Há três tipos de chamada disponíveis: Automática, Redonda e Quadrada, que indicam se o texto do rótulo fica dentro de um círculo, de um quadrado ou sem contorno. O ponteiro pode ser uma seta ou um ponto. |
| Linear Dimension | Permite cotar uma distância linear. O valor da cota é a distância entre os marcadores inicial e final (pontos de referência selecionados pelo usuário), medida nas unidades padrão. As referências podem ser objetos (trilhas, arcos, pads, vias, textos, preenchimentos, polígonos ou componentes) ou pontos no espaço livre. |
| Linear Diameter Dimension | Permite cotar um arco ou círculo em relação ao diâmetro, em vez do raio. A cota pode ser posicionada interna ou externamente. |
| Ordinate Dimension | Permite cotar a distância linear de um conjunto de objetos em relação a um único objeto de referência. O primeiro objeto escolhido é a “base”. Todos os objetos subsequentes são relativos a esse primeiro objeto. Portanto, o valor da cota em cada caso é a distância entre cada objeto de referência e a “base”, medida nas unidades padrão. As referências podem ser trilhas, arcos, pads, vias, textos, preenchimentos, polígonos ou componentes. |
| Radial Dimension | Permite cotar o raio de um arco ou círculo. A cota pode ser posicionada interna ou externamente. |
| Radial Diameter Dimension | Permite cotar um arco ou círculo em relação ao diâmetro, em vez do raio. A cota pode ser posicionada interna ou externamente em relação à circunferência do arco/círculo. |
| Standard Dimension | Insere informações de cotagem na camada atual da PCB. O valor da cota é a distância entre os marcadores inicial e final, medida nas unidades padrão. |
Os objetos de cota estão disponíveis no submenu Place » Dimension dos menus principais. Ao cotar um objeto, são disponibilizados pontos de ancoragem que destacam onde a cota pode ser fixada. A barra de status exibe informações sobre as ações necessárias para cada etapa ao longo do processo. O ponto mais próximo do cursor será o utilizado e será onde a cota será fixada se você clicar ou pressionar Enter.
Exemplos de inserção de algumas cotas são mostrados no vídeo abaixo.
Outras ações que podem ser executadas durante a inserção são:
- Pressione as teclas + e - (no teclado numérico) para percorrer, respectivamente, para a frente e para trás todas as camadas visíveis do projeto – para alterar rapidamente a camada de inserção.
- Ao posicionar uma cota de linha de base, de centro, de diâmetro linear, linear ou de ordenadas, pressione Spacebar para girar a cota no sentido anti-horário ou Shift+Spacebar para girá-la no sentido horário. A rotação segue o valor de Rotation Step definido na página PCB Editor – General da caixa de diálogo Preferences.
- Ao posicionar uma cota padrão, pressione a tecla L para inverter a cota para o outro lado da placa – observe que isso só é possível antes de fixar o ponto inicial da cota.
O valor de uma cota (quando aplicável) é atualizado automaticamente à medida que seus pontos inicial ou final são movidos. Da mesma forma, se a posição de um objeto ao qual um ponto de referência da cota está fixado for alterada, a cota será atualizada e se expandirá/contrairá para refletir essa alteração. Para uma cota baseada em raio/diâmetro, o valor é atualizado automaticamente conforme o diâmetro do arco ou círculo de referência muda.
Quando a referência ou as referências às quais um objeto de cota está vinculado são excluídas, uma caixa de diálogo é aberta perguntando se a cota também deve ser excluída. Se a cota não for excluída, ela permanecerá no espaço de projeto, mas sem referência.
Um objeto de cota pode ser movido das seguintes maneiras:
- Selecting both the dimension object and the dimensioned object(s). O conjunto pode ser arrastado para um novo local, conforme necessário.
- Selecting a dimensioned object only. O texto da cota acompanhará o objeto apenas em seu plano de alinhamento. As linhas de extensão da cota (ou, no caso de uma cota de diâmetro radial ou radial, seu ponteiro e sua cauda) se expandirão/contrairão para manter a relação entre a cota e o objeto cotado. No caso de uma cota de centro ou com linha de chamada, ela se moverá com o objeto. O segmento da cota com linha de chamada (entre a seta/ponto e o primeiro cotovelo definido) se expandirá/contrairá para manter a relação entre a cota e o objeto cotado.
- Selecting the dimension object only. É importante observar que a cota não pode ser movida de forma independente se estiver referenciada a um objeto do projeto. Para mover apenas a cota, primeiro é necessário desvinculá-la dos objetos que ela está cotando.
Quando um objeto de cota é selecionado, são disponibilizadas alças de edição que permitem editar a cota posicionada diretamente no espaço de projeto, alterando graficamente propriedades como a posição do texto e dos pontos de referência. Exemplos de alças de edição para algumas cotas são mostrados abaixo.
|
Quando um objeto de cota linear é selecionado, as seguintes alças de edição ficam disponíveis:
Quando um objeto de cota angular é selecionado, as seguintes alças de edição ficam disponíveis:
Quando um objeto de cota radial é selecionado, as seguintes alças de edição ficam disponíveis:
Quando um objeto de cota de ordenadas é selecionado, as seguintes alças de edição ficam disponíveis.
|
As alças sobre os objetos cotados (ou mais próximas deles) (por exemplo, C e D para uma cota linear ou C & E e D & F para uma cota angular, conforme mostrado acima) permitem redefinir as referências – assim que a cota é desvinculada de um objeto de referência, ela fica sem referência e pode ser movida para ser vinculada a outro ponto ou objeto de referência. Ao arrastar qualquer uma das alças de edição de uma cota linear, de ordenadas ou de linha de base sem referência, ela pode ser girada.
Propriedades dos objetos de cota
As cotas têm diversas opções de configuração, oferecendo um alto nível de personalização das setas e do texto. Abra o painel Properties para um ou mais objetos de cota selecionados para editar suas propriedades.
| Propriedade | Aplica-se aos objetos | Descrição |
|---|---|---|
Estilo |
||
| Width | Todos, exceto cotas de centro e de ordenadas | A largura atual da linha de cota. |
| Width (na região Extension Line) | Cota angular Cota de linha de base Cota linear Cota de diâmetro linear Cota de ordenadas |
A largura atual das linhas de extensão da cota. |
| Gap | Cota angular Cota de linha de base Cota com linha de chamada Cota linear Cota de diâmetro linear Cota de ordenadas |
|
| Offset | Cota angular Cota de linha de base Cota linear Cota de diâmetro linear |
O deslocamento atual da linha da seta em relação à linha de extensão da cota. |
| Text Gap | Todos, exceto cotas de centro e padrão |
|
| Leader Shape | Cota com linha de chamada | Use a lista suspensa para determinar qual forma será usada para envolver o texto da cota. As opções disponíveis são Automatic, Round e Square. Se Round ou Square forem selecionadas, insira o valor desejado para Size. |
| Arrow Style | Cota com linha de chamada | Use a lista suspensa para selecionar o estilo de linha de chamada desejado. As opções são Arrow ou Dot. Insira o valor desejado para Size. |
| Height | Cota padrão | A altura atual da linha de extensão. |
| Arrow Size | Cota angular Cota de linha de base Cota linear Cota de diâmetro linear Cota radial Cota de diâmetro radial |
O tamanho atual da ponta da seta. O tamanho é medido como a distância entre a ponta da seta e a extremidade das suas “pernas”. |
| Arrow Length | Cota angular Cota de linha de base Cota linear Cota de diâmetro linear Cota radial Cota de diâmetro radial |
O comprimento atual da seta. Observe que o valor inserido neste campo é aplicado apenas quando Arrow Position (na região Properties ) está definido como Outside. |
Propriedades |
||
| Text | Cota com linha de chamada | Insira o texto desejado. |
| Layer | Todas | A camada à qual a cota está atribuída atualmente. Use a lista suspensa para selecionar a camada desejada. As cotas podem ser atribuídas a qualquer camada disponível. |
| Text Position | Todas, exceto cotas de centro e padrão | A posição atual do texto da cota. Use a lista suspensa associada para escolher uma das seguintes opções (o conjunto de opções disponíveis depende do tipo de objeto de cota):
|
| Arrow Position | Cota angular Cota de linha de base Cota linear Cota de diâmetro linear Cota radial Cota de diâmetro radial |
A posição atual das setas da cota. As opções disponíveis são:
|
| Angular Step | Cota de diâmetro radial | A configuração atual do passo angular da cota. Este é o passo de rotação usado ao posicionar a parte da cota que contém a seta. Ao mover a seta ao redor do círculo ou arco durante o posicionamento da cota, o número e a posição dos possíveis pontos de ancoragem da cota são determinados por esse valor de passo angular. |
| Text Height | Todas, exceto cota de centro | A altura atual dos caracteres do texto da cota. A largura dos caracteres usada para exibir ou imprimir o texto é automaticamente proporcional a essa altura. Uma altura mínima de 36mil (0.9mm) permitirá que o texto seja fotoplotado de forma legível. |
| Rotation | Cota de centro Cota linear Cota de diâmetro linear Cota por coordenadas |
O ângulo de alinhamento da cota, medido em graus no sentido anti-horário a partir da horizontal. |
| Size | Cota de centro | O comprimento atual das linhas da cruz de centro da cota (ou o diâmetro do círculo que as envolve). |
| Font Type | Todas, exceto cota de centro |
|
Unidades |
||
| Primary Units | Cota angular Cota de linha de base Cota linear Cota de diâmetro linear Cota por coordenadas Cota radial Cota de diâmetro radial |
A unidade atualmente selecionada para o cálculo e a exibição do valor da cota.
|
| Value Precision | Cota angular Cota de linha de base Cota linear Cota de diâmetro linear Cota por coordenadas Cota radial Cota de diâmetro radial |
A configuração atual do número de casas decimais à direita do separador decimal com que a cota será exibida. |
Valor |
||
| Format | Todas, exceto cotas de centro e de chamada |
A configuração atual do formato do texto da cota. Use a lista suspensa associada para alterar o formato conforme necessário. As opções listadas dependerão de Unit selecionado e serão apresentadas com base no valor real da cota atual. Em termos gerais, as opções disponíveis são (o conjunto de opções disponíveis depende do tipo de objeto de cota):
|
| Prefix | Cota angular Cota de linha de base Cota linear Cota de diâmetro linear Cota por coordenadas Cota radial Cota de diâmetro radial |
O prefixo do valor da cota. Para uma cota de diâmetro linear ou de diâmetro radial, este campo é fixado com o caractere ø. |
| Suffix | Cota angular Cota de linha de base Cota linear Cota de diâmetro linear Cota por coordenadas Cota radial Cota de diâmetro radial |
O sufixo do valor da cota. |
| Sample | Todas, exceto cotas de centro e de chamada |
Este campo apresenta uma amostra de como o texto da cota aparecerá de acordo com Format especificado e quaisquer Prefix e/ou Suffixdefinidos. |
| Start point (X/Y) | Cota padrão | O ponto inicial da cota em X (primeiro valor) e Y (segundo valor). |
| End point (X/Y) | Cota padrão | O ponto final da cota em X (primeiro valor) e Y (segundo valor). |
Conversão de cotas em primitivas
As cotas são objetos de projeto agrupados, ou seja, são compostas por um ou mais segmentos de texto e de trilha. Uma cota pode ser convertida nos objetos primitivos que a constituem usando o comando Tools » Convert » Explode Dimension to Free Primitives.


