Trabalhando com Keepouts Específicos de Objeto em uma Placa
Num relance
- Entenda o que são áreas de exclusão específicas por objeto, como elas se comportam no Altium Designer e onde devem ser usadas no layout de PCB.
- Aprenda a configurar áreas de exclusão para restringir apenas determinados tipos de objetos, obtendo um controle mais flexível sobre o roteamento, o posicionamento de cobre e o comportamento das vias.
- Conheça os fundamentos de posicionamento e edição de objetos de exclusão, incluindo trilhas e arcos de exclusão, nos editores de PCB e de bibliotecas de PCB.
Um Keepout no projeto de PCB é uma área ou um perímetro definido pelo usuário no layout que os objetos de cobre não podem intersectar. Normalmente incluído para controlar a área utilizada por ações automatizadas de posicionamento de cobre, como preenchimentos de polígonos e roteamento interativo, um Keepout também representa um local inválido para o posicionamento manual de objetos de cobre.
Como áreas de exclusão especificadas durante a elaboração do layout, os objetos Keepout utilizam as Regras de Restrição de Folga existentes para controlar o roteamento e detectar violações de posicionamento, mas, ao contrário de outros objetos posicionados, não podem ser atribuídos a uma rede e não são exibidos nas saídas geradas nem nas impressões. Em sua forma mais simples, um Keepout atua como um objeto de “interferência” que impede que outros objetos de cobre intersectem sua área, conforme especificado pela Regra de Folga global. Os objetos Keepout podem ser posicionados na camada Keep-out (onde se aplicam a todas as camadas de sinal) ou em uma camada de sinal (onde se aplicam apenas aos objetos dessa camada).
O Altium Designer permite a criação e a aplicação de Keepouts com seu suporte a Object Specific Keepouts. Os objetos Keepout posicionados podem ser configurados para especificar a quais tipos de objetos se aplicam, como trilhas, áreas de cobre, vias e pads, o que aumenta significativamente a flexibilidade e a eficácia dos Keepouts.

Objetos Keepout de diferentes tipos posicionados em um projeto de PCB.
No Editor de PCB e no Editor de Bibliotecas de PCB, os objetos Keepout são exibidos com hachuras cruzadas. Os objetos Keepout posicionados na camada Keep-Out (ou seja, que se aplicam a todas as camadas de sinal) são exibidos na cor da camada Keep-Out, enquanto os Keepouts posicionados em uma camada de sinal específica (ou seja, que se aplicam apenas a essa camada de sinal) aparecem na cor dessa camada.
Os Keepouts são ideais para definir regiões da placa onde o roteamento não é permitido (como áreas eletricamente sensíveis ou de alta tensão), locais específicos com cobre exposto, como em fiduciais e pontos de teste, ou áreas mecanicamente incompatíveis (como furos de montagem ou os cantos de uma PCB). A natureza configurável dos Keepouts específicos por objeto também permite posicioná-los sobre outros objetos quando Keepout Restrictions específicos tiverem sido atribuídos. Quando configurado para restringir apenas vias, por exemplo, um Keepout pode ser posicionado sobre regiões de cobre existentes (como um Preenchimento de Polígono) para controlar a extensão da Costura de Vias automatizada.
Os Keepouts específicos por objeto podem ser posicionados no Editor de PCB e no Editor de Bibliotecas de PCB.
Para obter mais informações sobre o posicionamento e a edição de objetos Keepout de PCB, consulte as seções recolhíveis abaixo:
Keepout de Trilha

Um Keepout de Trilha posicionado
Uma trilha é um objeto de projeto primitivo. Além da trilha padrão utilizada nas tarefas de projeto, há um segundo tipo de trilha disponível, denominado keepout de trilha. Um keepout de trilha pode ser posicionado como um objeto keepout específico de uma camada ou como um keepout para todas as camadas, para atuar, por exemplo, como uma barreira de posicionamento ou roteamento. A diferença entre uma trilha padrão e um keepout de trilha é que os preenchimentos do tipo keepout específicos de uma camada não são incluídos na geração de saídas, como Gerber ou ODB++. Uma região keepout é identificada por um contorno na cor de Keepout.
Após iniciar o comando de posicionamento de keepout de trilha, o cursor mudará para uma mira e você entrará no modo de posicionamento de keepout de trilha. O posicionamento é realizado executando a seguinte sequência de ações:
- Clique ou pressione Enter para fixar o ponto inicial do primeiro segmento de keepout de trilha.
- Mova o cursor para definir o segmento de keepout de trilha e, em seguida, clique ou pressione Enter para fixar o ponto final desse primeiro segmento, que também é o ponto inicial do próximo segmento conectado.
- Continue posicionando o cursor e, em seguida, clique ou pressione Enter para fixar uma série de vértices que definem a série de segmentos de keepout de trilha conectados.
- Clique com o botão direito do mouse ou pressione Esc para encerrar a série atual de segmentos de keepout de trilha conectados.
Outras ações que podem ser realizadas durante o posicionamento incluem:
- Pressione a tecla * no teclado numérico para percorrer as camadas de sinal disponíveis. Como alternativa, use a combinação Shift+Ctrl+Wheel Roll para percorrer as camadas de roteamento; cada passo da roda do mouse passará para a próxima camada de sinal disponível (ou para a anterior).
- Pressione as teclas + e - no teclado numérico para percorrer, para frente e para trás, todas as camadas atualmente visíveis no projeto.
Durante o posicionamento de segmentos de trilha keepout, há cinco modos de canto disponíveis, quatro dos quais também possuem submodos de direção do canto. Durante o posicionamento:
- Pressione Shift+Spacebar para percorrer os cinco modos de canto disponíveis.
- Pressione Spacebar para alternar entre os dois submodos de direção do canto.
- Em qualquer um dos modos de canto em arco, mantenha pressionadas as teclas , ou . para reduzir ou aumentar o arco. Mantenha a tecla Shift pressionada ao pressionar essas teclas para acelerar o redimensionamento do arco.
- Pressione a tecla de atalho 1 para alternar entre posicionar um segmento por clique ou dois segmentos por clique. No primeiro modo, o segmento de trilha sem preenchimento é denominado segmento de antecipação.
- Pressione a tecla Backspace para remover o último vértice.
O método gráfico de edição permite selecionar um objeto keepout de trilha posicionado diretamente no espaço de projeto e alterar graficamente seu tamanho, formato ou localização.
Quando um keepout de trilha é selecionado, as seguintes alças de edição ficam disponíveis:
- Clique nas alças das extremidades para reposicionar os pontos finais da trilha.
- Clique e arraste a alça central para alterar o formato da trilha.
Propriedades do Keepout de Trilha

O modo Keepout - Track do painel Properties.
Localização
-
(X/Y)
- X (primeiro campo) - a coordenada X (horizontal) atual do ponto de referência do keepout de trilha em relação à origem atual. Edite para alterar a posição X do keepout de trilha. O valor pode ser inserido no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades não sejam as padrão atuais.
- Y (segundo campo) - A coordenada Y (vertical) atual do ponto de referência do keepout de trilha em relação à origem atual. Edite para alterar a posição Y do keepout de trilha. O valor pode ser inserido no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades não sejam as padrão atuais.
Propriedades
- Component – este campo é exibido no Editor de PCB somente quando o Keepout de Trilha selecionado faz parte de um Componente de PCB e mostra o designador do componente de PCB ao qual ele pertence. Selecione o elemento clicável Component link para abrir o modo Componente do painel Propriedades para o componente pai.
- Restricted for Layer - use a lista suspensa para selecionar a camada restrita.
- Width - exibe a largura atual da trilha de keepout. Edite este campo para alterar a largura da trilha de keepout no intervalo de 0.001mil a 10000mil.
- Start (X/Y) - exibe a coordenada X/Y atual do ponto inicial da trilha de keepout em relação à origem atual.
- End (X/Y) - exibe a coordenada X/Y atual do ponto final da trilha de keepout, em relação à origem atual.
- Length - exibe o comprimento atual da trilha de keepout. Edite este campo para alterar o comprimento da trilha de keepout no intervalo de 0.001mil a 10000mil.
Restrições de keepout
Use esta região para selecionar quais tipos de objetos serão restringidos pelo keepout. Desmarcar um tipo de objeto fará com que o keepout permita a entrada desse tipo de objeto na região restrita ao não impor a regra de afastamento aplicável. As opções incluem:
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Arco de keepout

Dois arcos de keepout na camada inferior: à esquerda, um arco de keepout de círculo completo; à direita, um arco de keepout selecionado para edição.
Um arco de keepout é um objeto primitivo de projeto. Trata-se essencialmente de um segmento circular de trilha que pode ser colocado em qualquer camada. Além do arco padrão usado em tarefas de projeto, como definir o contorno de um componente ou realizar roteamento curvo, existe um segundo tipo de arco disponível, chamado arco de keepout. Um arco de keepout pode ser colocado em uma camada de sinal para criar uma barreira ou região proibida específica dessa camada. Também pode ser colocado na camada Keepout, onde será aplicado a todas as camadas de sinal. A diferença entre um arco padrão e um arco de keepout é que os arcos do tipo keepout específicos de uma camada não são incluídos na geração de arquivos de saída, como Gerber ou ODB++. Um arco de keepout é identificado por ter um contorno na cor de Keepout.
A forma como um arco é colocado depende do método de posicionamento que você escolheu acionar. Há quatro métodos diferentes de posicionamento de arcos:
- Place arc by center – este método permite colocar um objeto de arco usando o centro do arco como ponto inicial.
- Place arc by edge – este método permite colocar um objeto de arco usando a extremidade do arco como ponto inicial. O ângulo do arco é fixado em 90°.
- Place arc by edge (any angle) – este método permite colocar um objeto de arco usando a extremidade do arco como ponto inicial. O ângulo do arco pode ter qualquer valor.
- Place full circle arc – este método permite colocar um arco de 360° (círculo completo).
Placing a Keepout Arc Starting at the Center
Após acionar o comando, o cursor mudará para uma mira e você entrará no modo de posicionamento de arcos de keepout. O posicionamento é realizado executando a seguinte sequência de ações:
- Clique ou pressione Enter para fixar o ponto central do arco de keepout.
- Mova o cursor para ajustar o raio do arco de keepout e clique ou pressione Enter para defini-lo.
- Mova o cursor para ajustar o ponto inicial do arco de keepout e clique ou pressione Enter para fixá-lo.
- Mova o cursor para alterar a posição do ponto final do arco de keepout e clique ou pressione Enter para fixá-lo e concluir o posicionamento do arco de keepout.
- Continue colocando outros arcos de keepout ou clique com o botão direito do mouse ou pressione Esc para sair do modo de posicionamento.
Placing a Keepout Arc Starting at the Edge
Após acionar o comando, o cursor mudará para uma mira e você entrará no modo de posicionamento de arcos de keepout. O posicionamento é realizado executando a seguinte sequência de ações:
- Clique ou pressione Enter para fixar o ponto inicial do arco de keepout.
- Mova o cursor para alterar a posição do ponto final do arco de keepout e clique ou pressione Enter para fixá-lo e concluir o posicionamento do arco de keepout.
- Continue colocando outros arcos de keepout ou clique com o botão direito do mouse ou pressione Esc para sair do modo de posicionamento.
Placing a Keepout Arc Starting at the Edge (any angle)
Após acionar o comando, o cursor mudará para uma mira e você entrará no modo de posicionamento de arcos de keepout. O posicionamento é realizado executando a seguinte sequência de ações:
- Clique ou pressione Enter para fixar o ponto inicial do arco de keepout.
- Mova o cursor para ajustar o raio do arco de keepout e clique ou pressione Enter para fixar o ponto central.
- Mova o cursor para alterar a posição do ponto final do arco de keepout e clique ou pressione Enter para fixá-lo e concluir o posicionamento do arco de keepout.
- Continue colocando outros arcos de keepout ou clique com o botão direito do mouse ou pressione Esc para sair do modo de posicionamento.
Placing a Full Circle Keepout Arc
Após acionar o comando, o cursor mudará para uma mira e você entrará no modo de posicionamento de arcos de keepout. O posicionamento é realizado executando a seguinte sequência de ações:
- Clique ou pressione Enter para fixar o ponto central do arco de keepout.
- Mova o cursor para ajustar o raio do arco de keepout e clique ou pressione Enter para defini-lo e concluir o posicionamento do arco de keepout.
- Continue colocando outros arcos de keepout ou clique com o botão direito do mouse ou pressione Esc para sair do modo de posicionamento.
Em todos os métodos (exceto arcos de círculo completo), pressione Spacebar antes de definir o ponto final do arco de keepout para desenhar o arco no sentido oposto.
O método de edição gráfica permite selecionar um objeto de arco já colocado diretamente no espaço de projeto e alterar graficamente seu tamanho, sua forma ou sua localização.
Quando um objeto de arco de keepout é selecionado, as seguintes alças de edição ficam disponíveis:

Um arco de keepout selecionado
- Clique e arraste A para ajustar o raio.
- Clique e arraste B para ajustar os pontos das extremidades (ângulos inicial e final).
-
Clique em qualquer lugar do arco longe das alças de edição e arraste para reposicioná-lo. Como alternativa, clique e arraste o ponto central do arco. Durante o arraste, o arco pode ser girado ou espelhado:
- Pressione Spacebar para girar o arco no sentido anti-horário ou Shift+Spacebar para girá-lo no sentido horário. A rotação segue o valor de Rotation Step definido na página Editor de PCB – Geral da caixa de diálogo Preferences.
- Pressione as teclas X ou Y para espelhar o arco em relação ao eixo X ou ao eixo Y, respectivamente.
Propriedades da área de exclusão em arco

O modo Keepout - Arc do painel Properties.
Localização
-
(X/Y)
- X (primeiro campo) - a coordenada X (horizontal) atual do ponto de referência da área de exclusão em arco, em relação à origem atual do espaço de projeto. Edite para alterar a posição X da área de exclusão em arco. O valor pode ser inserido no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades não sejam as unidades padrão atuais.
- Y (segundo campo) - A coordenada Y (vertical) atual do ponto de referência da área de exclusão em arco, em relação à origem atual. Edite para alterar a posição Y da área de exclusão em arco. O valor pode ser inserido no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades não sejam as unidades padrão atuais.
Propriedades
- Component – este campo é exibido no editor de PCB somente quando a área de exclusão em arco selecionada faz parte de um componente de PCB e exibe o designador do componente de PCB ao qual ela pertence. Selecione o link clicável Component para abrir o modo Componente do painel Propriedades para esse componente.
- Restricted Layer - este campo exibe a camada restrita à qual a área de exclusão em arco está atualmente atribuída. Para alterar a camada, clique no campo e selecione uma camada na lista suspensa.
- Width - este campo exibe a largura da linha da área de exclusão em arco. Insira um valor diferente para a largura, se necessário.
- Radius - este campo exibe o raio do arco, medido do ponto central até o centro da linha da área de exclusão em arco. Insira um valor diferente para o raio, se necessário.
- Start Angle - este campo exibe o ângulo inicial da área de exclusão em arco, medido a partir do eixo X no primeiro quadrante (geometria plana). Insira um valor diferente para o ângulo inicial, se necessário.
- End Angle - este campo exibe o ângulo final da área de exclusão em arco. Insira um valor diferente para o ângulo final, se necessário.
Restrições da área de exclusão
Use esta região para selecionar quais tipos de objeto serão restringidos pela área de exclusão. Desmarcar um tipo de objeto fará com que a área de exclusão permita a presença desse tipo de objeto em seu interior (sem excluí-lo) ao não aplicar a regra de espaçamento correspondente. As opções incluem:
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Área de exclusão em região

Uma área de exclusão em região
Uma área de exclusão em região é um objeto primitivo de projeto. Além da região padrão usada nas tarefas de projeto, há um segundo tipo de região disponível, chamado de área de exclusão em região. Uma área de exclusão em região pode ser posicionada como um objeto de exclusão específico de uma camada ou como uma área de exclusão em todas as camadas, para atuar, por exemplo, como uma barreira ao posicionamento ou ao roteamento. A diferença entre uma região padrão e uma região de exclusão é que os preenchimentos do tipo exclusão específicos de uma camada não são incluídos na geração de arquivos de saída, como Gerber ou ODB++. Uma região de exclusão é identificada por ter um contorno na cor de exclusão.
Após iniciar o comando de posicionamento de área de exclusão em região (Place » Keepout » Solid Region), o cursor mudará para uma mira e você entrará no modo de posicionamento de área de exclusão em região. O posicionamento é feito executando a seguinte sequência de ações:
- Posicione o cursor e clique para fixar o vértice inicial da área de exclusão em região.
- Mova o cursor para posicionar o segundo vértice. O comportamento padrão é posicionar duas arestas a cada clique, com um formato de canto definido pelo usuário entre elas.
- Continue movendo o mouse e clicando para posicionar mais vértices.
- Após posicionar o último vértice, clique com o botão direito ou pressione Esc para fechar e concluir o posicionamento da área de exclusão em região. Não é necessário fechar a região manualmente, pois o software completará automaticamente a forma conectando o ponto inicial ao último ponto posicionado.
- Continue posicionando outras áreas de exclusão em região ou clique com o botão direito ou pressione Esc para sair do modo de posicionamento.
O método gráfico de edição permite selecionar um objeto posicionado diretamente no espaço de projeto e alterar graficamente seu tamanho, forma ou localização.

Uma área de exclusão em região selecionada
Move Region Vertices
As áreas de exclusão em região contêm dois tipos de pontos, ou “alças”, com os quais é possível editar a forma da região.
- Full Handles - localizadas nos cantos da área de exclusão em região.
- Empty Handles - localizadas no centro dos segmentos criados pelas alças preenchidas.
Uma área de exclusão em região existente pode ser remodelada movendo essas alças, ou vértices, localizadas em cada canto ou no centro de cada aresta.
Para modificar a forma da área de exclusão em região:
-
Clique e selecione uma área de exclusão em região, o que destacará seus vértices e mudará o cursor para uma mira.
- Click em uma alça preenchida para mover esse canto.
- Click ao longo de uma aresta para mover a aresta inteira.
- Click em uma alça vazia para mover todo o lado (tanto para trilhas quanto para arcos).
- Ctrl+Click em uma alça vazia para dividir essa aresta em duas. Ctrl só precisa ser mantida pressionada no início do movimento. Os atalhos Shift+Spacebar podem então ser usados para alternar entre os modos (arco, chanfro e qualquer ângulo).
- Se o modo de posicionamento “qualquer ângulo” criar vértices indesejados, ou para remover vértices extras em geral, clique Ctrl e segure a alça preenchida central. Um ícone X aparece sobre a alça, e arrastar a aresta reduzirá os vértices dessa aresta a um.
Modify Region Border
Além da edição de vértices, você também pode usar o comando Modify Region Border para alterar facilmente a forma dos polígonos. O comando é executado clicando com o botão direito no polígono desejado e selecionando Polygon Actions » Modify Polygon Border. Após iniciar o comando, o cursor se torna uma mira. A cada clique, um novo vértice é adicionado. Assim como durante o posicionamento de uma área de exclusão em região, os atalhos Shift+Spacebar podem ser usados para alterar os formatos dos cantos.
Propriedades da área de exclusão em região

O modo Keepout - Region do painel Properties.
Propriedades
- Component – este campo é exibido no editor de PCB somente quando a região de exclusão selecionada faz parte de um componente de PCB e mostra o designador do componente de PCB ao qual pertence. Selecione o link clicável Component para abrir o modo Componente do painel Propriedades para o componente ao qual pertence.
- Restricted for Layer - use a lista suspensa para selecionar a camada na qual a região de exclusão está localizada.
- Arc Approximation - insira o desvio máximo em relação a um arco perfeito.
- Area - a área total do objeto posicionado.
- Locked (somente no painel Properties) - habilite para bloquear a região de exclusão.
Vértices do contorno
Esta seção é usada para modificar os vértices individuais do objeto de região atualmente selecionado. Você pode modificar as posições dos vértices existentes, adicionar novos vértices ou removê-los conforme necessário. É possível definir conexões em arco entre os pontos dos vértices, e também há suporte para exportar informações dos vértices para um arquivo no formato CSV e importá-las desse arquivo.
-
Vertices Grid - lista todos os pontos de vértice atualmente definidos para a região em termos de:
- Index - o índice atribuído ao vértice (não editável).
- X - a coordenada X (horizontal) do vértice. Clique para editar.
- Y - a coordenada Y (vertical) do vértice. Clique para editar.
- Arc Angle (Neg = CW) - o ângulo de um arco desenhado para conectar este ponto de vértice ao próximo. Por padrão, as conexões são segmentos de reta, e este campo permanece em branco. Clique para editar e insira um ângulo de arco conforme necessário. A inserção de um valor positivo resultará em um arco desenhado no sentido anti-horário. Para desenhar um arco no sentido horário, insira um valor negativo.
-
Add - clique para adicionar um novo ponto de vértice. O novo vértice será adicionado abaixo da entrada de vértice atualmente em foco e terá inicialmente as mesmas coordenadas X,Y dessa entrada. Clique em
para remover o vértice atualmente selecionado.
Restrições de exclusão
Use esta seção para selecionar quais tipos de objeto serão restringidos pela área de exclusão. Ao desmarcar um tipo de objeto, a área de exclusão permitirá que objetos desse tipo a invadam (não serão excluídos) por não impor a regra de espaçamento aplicável. As opções incluem:
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Preenchimento de exclusão
Um preenchimento de exclusão é um objeto primitivo de projeto que pode ser posicionado em qualquer camada. Além do preenchimento padrão usado para tarefas de projeto, como definir o contorno de um componente, há um segundo tipo de preenchimento disponível, denominado preenchimento de exclusão. Um preenchimento de exclusão pode ser posicionado como um objeto de exclusão específico de uma camada ou como uma área de exclusão em todas as camadas para atuar, por exemplo, como uma barreira de posicionamento ou roteamento. A diferença entre um preenchimento padrão e um preenchimento de exclusão é que os preenchimentos de exclusão específicos de uma camada não são incluídos na geração de arquivos de saída, como Gerber ou ODB++. Um preenchimento de exclusão é identificado por seu contorno na cor de exclusão.
Após iniciar o comando de posicionamento de preenchimento de exclusão, o cursor mudará para uma cruz e você entrará no modo de posicionamento de preenchimento de exclusão. O posicionamento é realizado por meio da seguinte sequência de ações:
- Clique ou pressione Enter para fixar o primeiro canto do preenchimento de exclusão.
- Mova o cursor para ajustar o tamanho do preenchimento de exclusão e clique ou pressione Enter para fixar o canto diagonalmente oposto e concluir o posicionamento do preenchimento de exclusão.
- Continue posicionando outros preenchimentos de exclusão ou clique com o botão direito ou pressione Esc para sair do modo de posicionamento.
O método de edição gráfica permite selecionar um objeto posicionado diretamente na área de projeto e alterar graficamente seu tamanho, sua forma ou sua posição.
Quando um objeto de preenchimento de exclusão é selecionado, as seguintes alças de edição ficam disponíveis:

Um preenchimento de exclusão selecionado
- Clique, mantenha pressionado e arraste as alças dos cantos para redimensionar o preenchimento de exclusão nas direções vertical e horizontal simultaneamente.
- Clique, mantenha pressionado e arraste as alças laterais, superior e inferior para redimensionar o preenchimento de exclusão nas direções vertical e horizontal separadamente.
- Clique, mantenha pressionado e arraste a alça central para girar o preenchimento de exclusão em torno de seu ponto central.
-
Clique em qualquer ponto do preenchimento de exclusão longe das alças de edição e mantenha pressionado e arraste para reposicioná-lo. Durante o arraste, o preenchimento de exclusão pode ser girado ou espelhado:
- Pressione Spacebar para girar o preenchimento de exclusão no sentido anti-horário ou Shift+Spacebar para girá-lo no sentido horário. A rotação segue o valor de Rotation Step definido na página Editor de PCB – Geral da caixa de diálogo Preferences.
- Pressione as teclas X ou Y para espelhar o preenchimento de exclusão ao longo do eixo X ou do eixo Y.
Propriedades do preenchimento de exclusão

O modo Keepout - Fill do painel Properties.
Localização
-
(X/Y)
- X (primeiro campo) - a coordenada X (horizontal) atual do ponto de referência do preenchimento de exclusão, em relação à origem atual da área de projeto. Edite para alterar a posição X do preenchimento de exclusão. O valor pode ser inserido no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades não sejam as padrão atuais.
- Y (segundo campo) - a coordenada Y (vertical) atual do ponto de referência do preenchimento de exclusão, em relação à origem atual. Edite para alterar a posição Y do preenchimento de exclusão. O valor pode ser inserido no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades não sejam as padrão atuais.
- Rotation - o ângulo de rotação do preenchimento de exclusão (em graus), medido no sentido anti-horário a partir de zero (a 3 o'clock horizontal). Edite para alterar a rotação do preenchimento de exclusão. A resolução angular mínima é de 0,001°.
Propriedades
- Component – este campo é exibido no editor de PCB somente quando o preenchimento de exclusão selecionado faz parte de um componente de PCB e mostra o designador do componente de PCB ao qual pertence. Selecione o link clicável Component para abrir o modo Componente do painel Propriedades para o componente ao qual pertence.
- Restricted for Layer - use a lista suspensa para selecionar a camada restrita.
- Area - fornece a área do objeto posicionado.
- Length - exibe o comprimento atual do preenchimento de exclusão. Edite este campo para alterar o comprimento no intervalo de 0.001mil a 10000mil.
- Width - exibe a largura atual do preenchimento de exclusão. Edite este campo para alterar a largura no intervalo de 0.001mil a 10000mil.
Restrições da área de exclusão
Use esta região para selecionar quais tipos de objeto serão restringidos pela área de exclusão. Desmarcar um tipo de objeto fará com que a área de exclusão permita a entrada desse tipo de objeto (sem excluí-lo) ao não impor a regra de espaçamento aplicável. As opções incluem:
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Posicionamento de áreas de exclusão
Uma área de exclusão é posicionada no espaço de projeto do editor pelo menu Place » Keepout, e o estilo de área de exclusão escolhido (Trilha, Preenchimento, Região ou Arco) será posicionado na camada atualmente ativa. Selecione as propriedades da área de exclusão para editar suas características físicas, camada ou restrições de tipos de objeto. As propriedades relacionadas de Keepout são:
- Restricted for Layer – define a camada da área de exclusão e, portanto, a camada da placa na qual os objetos de cobre serão restringidos (excluídos). Para uma área de exclusão em todas as camadas, selecione Keep-Out Layer.
- Keepout Restrictions – determina quais tipos de objeto serão restringidos pela área de exclusão. Desmarcar um tipo de objeto fará com que a área de exclusão permita a entrada desse tipo de objeto (sem excluí-lo), ao não impor a regra de espaçamento aplicável.
Na imagem abaixo, os dois preenchimentos de exclusão têm diferentes restrições de camada e de objeto aplicadas. Essas restrições permitem que o preenchimento de exclusão da camada superior (à esquerda) aceite um pad de furo passante (TH), restringindo todos os outros tipos de objeto, e que o da camada de exclusão (à direita) aceite apenas trilhas.

Exemplo de dois preenchimentos de exclusão posicionados em diferentes camadas de uma PCB e configurados para restringir o posicionamento de diferentes tipos de objeto.
A flexibilidade inerente das áreas de exclusão permite seu uso em uma ampla variedade de tarefas para controlar layouts de PCB. Como as áreas de exclusão podem ser sobrepostas, atribuídas a qualquer camada de sinal (como a superior ou a inferior) e configuradas para rejeitar objetos específicos, elas podem ser usadas para controlar com precisão a costura de vias e os preenchimentos poligonais, por exemplo.
Controle de preenchimentos poligonais
No exemplo de layout de PCB mostrado abaixo, foram adicionados preenchimentos de exclusão ao redor dos pads multicamada em uma região de possível alta tensão, que precisa ter isolamento elétrico suficiente em relação aos preenchimentos poligonais conectados ao terra que serão adicionados. Os preenchimentos de exclusão estão definidos para a camada superior e configurados para restringir apenas objetos de cobre, o que rejeitará preenchimentos poligonais, preenchimentos e regiões, mas aceitará trilhas e pads existentes etc. – em outras palavras, a regra de violação de espaçamento será aplicada apenas a objetos classificados como “cobre”.

Preenchimentos de exclusão posicionados na camada de exclusão e configurados para serem aplicados apenas a objetos de cobre.
A disposição de áreas de exclusão acima forçará os preenchimentos poligonais posicionados nas camadas de sinal (neste caso, as camadas superior e inferior) a evitar as três áreas de exclusão. No entanto, o pads da camada superior associado à área em questão não terá um espaçamento adequado em relação ao preenchimento da camada superior.
Nesse caso, podem ser adicionadas outras áreas de exclusão à camada superior para que seu preenchimento poligonal mantenha uma distância adequada de todos os pads relacionados. Na imagem mostrada abaixo, outros dois preenchimentos de exclusão foram adicionados à camada superior, exibida aqui no modo de camada única para maior clareza. Observe que a cobertura de exclusão mostrada poderia ter sido criada com uma única região, em vez de dois preenchimentos sobrepostos.

Preenchimentos de exclusão posicionados na camada superior e configurados para serem aplicados apenas a objetos de cobre.
Quando os preenchimentos poligonais forem finalmente adicionados ao layout, o conjunto de áreas de exclusão controlará os preenchimentos para produzir um formato de espaçamento diferente para cada camada ao redor da região. Observe que, neste exemplo, o espaçamento associado às áreas de exclusão é maior do que o dos objetos normais devido a uma regra de espaçamento de áreas de exclusão personalizada (veja abaixo).

Os preenchimentos poligonais evitam os objetos de exclusão posicionados.
A influência do conjunto de áreas de exclusão sobre os preenchimentos poligonais pode ser vista claramente quando o layout é visualizado no modo 3D de camada única, conforme mostrado abaixo – camada superior à esquerda e camada inferior à direita.

A camada superior (à esquerda) e a camada inferior (à direita) da PCB mostradas no modo 3D de camada única.
Controle de costura de vias
A aplicação de formas de exclusão, configuradas para restringir objetos de via, em áreas de cobre multicamada pode controlar a extensão da costura automática de vias (Tools » Via Stitching/Shielding). As formas de exclusão podem ser definidas para qualquer camada ou para uma das camadas da área de cobre, de modo que as vias entre essas camadas sejam excluídas (restringidas).
No exemplo mostrado abaixo, formas de exclusão foram adicionadas aos cantos superior e inferior esquerdos do layout. Elas estão configuradas para restringir objetos de via, o que impedirá que a costura automática de vias posicione vias dentro desses perímetros.

Regiões de exclusão configuradas para serem aplicadas apenas a vias.
Além de evitar trilhas, pads e vias existentes, como normalmente ocorre, a costura de vias também evita as formas de exclusão, conforme determinado pela regra de espaçamento aplicável.

A PCB após a adição da costura de vias.
Áreas de exclusão em componentes
As áreas de exclusão são adicionadas aos footprints dos componentes no Editor de Bibliotecas de PCB usando a mesma abordagem aplicada no espaço de projeto do Editor de PCB.
A área de exclusão adicionada ao footprint do componente mostrado abaixo está configurada para restringir todos os objetos, mas permitir trilhas – possibilitando, assim, conexões de redes em um layout no qual o componente é usado, enquanto restringe o posicionamento próximo de outros tipos de objeto.

Objetos de exclusão também podem ser adicionados aos footprints dos componentes no Editor de Bibliotecas de PCB.
Trabalhando com áreas de exclusão
A implementação das áreas de exclusão específicas por objeto do Altium Designer se reflete em todas as funções associadas e inclui compatibilidade com as consultas (e, portanto, com as regras de projeto), com o painel PCB List e também com documentos de projeto de PCB importados ou antigos.
Regra de espaçamento de áreas de exclusão
Assim como ocorre com outras primitivas de objeto, a regra de espaçamento elétrico atual determinará as restrições de espaçamento para as áreas de exclusão – veja Design » Rules. Se for necessária uma restrição de espaçamento diferente para as áreas de exclusão, crie uma regra específica aplicando a verificação de atributo IsKeepOut como uma consulta personalizada.
Certifique-se de que a regra personalizada de folga para Keepouts tenha uma prioridade mais alta que a regra de folga existente (global). No exemplo abaixo, foi criada uma regra para Keepouts (Clearance_Keepout) com uma distância de folga duas vezes maior que a da regra de folga base (Clearance). Como mostrado no trecho do layout da placa, a trilha roteada entre os dois pads mantém uma distância maior da região de Keepout (à direita) do que da região na camada superior (à esquerda).

É possível criar uma regra de folga adicional para objetos Keepout.
Converter objetos primitivos em Keepouts
Objetos primitivos existentes nas camadas de sinal podem ser convertidos em Keepouts, na mesma camada, usando o comando Converter primitivos em Keepouts (Tools » Convert » Convert Selected Primitives to Keepout).

Um objeto primitivo pode ser convertido em um objeto Keepout equivalente (e vice-versa).
Acesso pelos painéis
Keepouts específicos por objeto em um projeto de placa podem ser acessados pelos painéis Lista de PCB e Filtro de PCB.
O painel PCB Filter permite usar a palavra-chave de consulta IsKeepOut para localizar e, opcionalmente, selecionar objetos Keepout no projeto.

O painel PCB Filter pode ser usado para localizar objetos Keepout no projeto.
O painel PCB List pode ser usado para listar, selecionar e editar objetos Keepout do tipo selecionado — por exemplo, preenchimentos Keepout, como mostrado na imagem do painel Lista abaixo. Um preenchimento padrão na camada superior (o último da lista) também é mostrado para comparação. Se all os preenchimentos (ou outros tipos de objetos, como regiões) incluídos no projeto forem definidos como Keepouts, o painel PCB List incluirá o conjunto completo de atributos de restrição dos objetos Keepout.

O painel PCB List pode ser usado para listar, selecionar e editar objetos Keepout do tipo selecionado.
Importação de projetos de PCB
O Altium Designer pode importar arquivos de projeto de uma ampla variedade de outras ferramentas de projeto usando os recursos de conversão automatizada fornecidos pelo Assistente de importação (File » Import Wizard). Objetos do tipo Keepout incluídos em arquivos de projeto de PCB de outras ferramentas, alguns dos quais são específicos por objeto, são convertidos pelo assistente em Keepouts específicos por objeto, quando possível.
O processo de conversão de Keepouts do assistente é compatível com projetos de placa de sistemas ECAD populares, como Mentor® Graphics Pads™ e Cadence® Allegro™. A interpretação correta dos Keepouts também ocorre durante o processo de exportação IDF.
