Definindo o Formato da Placa
Altium Essentials: PCB Configuration
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Num relance
- Saiba o que o formato da placa define, como ele é usado pelo software e como difere entre projetos com uma única região e projetos rígido-flexíveis.
- Conheça os métodos disponíveis para criar e editar o contorno da placa, incluindo ferramentas interativas, objetos selecionados e definição baseada em corpos 3D.
- Entenda quais comandos estão disponíveis nos modos rígido-flexível padrão e avançado e como os modos de visualização afetam o fluxo de trabalho de edição.
Resumo
O Formato da Placa, também chamado de contorno da placa, é uma forma poligonal fechada que define os limites gerais da placa. O Formato da Placa pode ser composto por uma única Região da Placa (para uma PCB rígida tradicional) ou por várias regiões da placa (para uma PCB rígido-flexível). O Formato da Placa é usado pelo software para:
- Fornecer uma referência visual dos limites do espaço disponível para o posicionamento e o roteamento do projeto.
- Definir o recuo das bordas dos planos de alimentação e as referências de borda para dividir um plano de alimentação em zonas de tensão separadas. Saiba mais sobre Definição e Gerenciamento de Áreas de Cobre.
- Calcular a borda da placa ao exportar dados do projeto para outras ferramentas.
Disponibilidade
O Formato da Placa está disponível apenas no editor de PCB. Quando um novo arquivo de PCB é criado, ele é aberto com um Formato da Placa retangular criado a partir de uma única Região da Placa.
O Formato da Placa geral pode ser criado das seguintes maneiras:
- Definindo interativamente o Formato da Placa no Modo de Planejamento da Placa.
- Criando o Formato da Placa a partir de objetos de trilha/arco selecionados que formam um contorno fechado. Se você estiver trabalhando no modo Rígido-Flexível Avançado, várias Regiões da Placa poderão ser criadas a partir de objetos selecionados na área de projeto.
- Em um projeto Rígido-Flexível (Modo Padrão ou Avançado), o Formato da Placa pode ser dividido nas várias Regiões da Placa necessárias ao projeto.
- Posicionando uma ou mais Regiões da Placa para compor o Formato da Placa geral (modo Rígido-Flexível Avançado).
Definição e Edição Interativas do Formato da Placa
O Formato da Placa é criado a partir de uma ou mais Regiões da Placa. Para projetistas que trabalham em um projeto de placa com uma única região, os seguintes comandos podem ser usados para definir o Formato da Placa:
-
Board Planning Mode (standard Rigid-Flex mode - the Active Bar at the top of the graphical editing space has two buttons):
-
Design » Redefine Board Shape - use este comando para redesenhar interativamente o contorno atual da placa. Observe que este comando não está disponível se o modo Rígido-Flexível Avançado tiver sido habilitado em Layer Stack Manager. Se a placa estiver no modo Rígido-Flexível Avançado, basta clicar para selecionar o contorno e modificá-lo usando as técnicas padrão de edição de objetos poligonais.
Como usar o comando Redefinir contorno da placa
Após iniciar o comando, o cursor mudará para uma cruz e você entrará no modo padrão de posicionamento de objetos poligonais. A definição do contorno da placa é feita executando a seguinte sequência de ações:
- Posicione o cursor e clique para fixar o vértice inicial do contorno da placa.
- Mova o cursor para posicionar o segundo vértice. O comportamento padrão é posicionar duas arestas a cada clique, com um formato de canto definido pelo usuário entre elas. Consulte a página Edição de objetos de projeto de PCB com formato poligonal para obter mais detalhes sobre como alterar os modos de canto.
- Continue movendo o mouse e clicando para posicionar os demais vértices.
- Após posicionar o último vértice, clique com o botão direito ou pressione Esc para fechar e concluir a definição do contorno da placa. Não é necessário fechar manualmente o contorno da placa, pois o software o concluirá automaticamente conectando o ponto inicial ao último ponto posicionado.
-
Design » Edit Board Shape - use este comando para mover e remodelar as arestas do contorno da placa usando as técnicas padrão de edição de objetos poligonais.
Como usar o comando Editar contorno da placa
Após iniciar o comando, o contorno existente da placa ficará verde. O contorno externo é definido por uma série de arestas, em que cada aresta é representada por um vértice de extremidade exibido como um quadrado branco preenchido, e um vértice central exibido como um quadrado branco vazado. Cada vértice de extremidade representa o ponto em que duas arestas se encontram.
Alças de edição de um exemplo de contorno de placa após entrar no modo de edição.
-
Clique e arraste A para executar uma das seguintes ações, dependendo do modo atual (use Shift+Spacebar para alternar entre os modos):
- Moving Vertex mode - mover livremente o vértice de extremidade, mantendo-o como um vértice de extremidade.
- Miter to Segment mode - criar uma nova aresta reta, com o vértice de extremidade movido tornando-se o vértice central dessa aresta.
- Miter to Arc mode - criar uma nova aresta curva, com o vértice de extremidade movido tornando-se o vértice central dessa aresta.
-
Clique e arraste B para executar uma das seguintes ações, dependendo do modo atual (use Shift+Spacebar para alternar entre os modos):
- Move mode - mover livremente toda a aresta, incluindo seus vértices de extremidade. O vértice central movido permanece como o vértice central dessa aresta.
- Break mode - mover o vértice central, transformando-o em um novo vértice de extremidade e dividindo a aresta original em duas. Os vértices de extremidade permanecem fixos em suas posições originais.
- Incurvate mode - adicionar curvatura à aresta, com os vértices de extremidade fixos em suas posições originais. O vértice central movido permanece como o vértice central dessa aresta.
- Clique em qualquer ponto de uma aresta, longe das alças de edição, e arraste para deslocar essa aresta — encurtando ou alongando a aresta movida para manter a posição das arestas adjacentes.
- Ctrl+clique em qualquer ponto de uma aresta, longe das alças de edição, para inserir um novo vértice de extremidade.
- Clique e mantenha pressionado sobre um vértice de extremidade (A) e, em seguida, pressione Delete para remover esse vértice. Como alternativa, mantenha Ctrl pressionado e passe o mouse sobre o vértice de extremidade (A) a ser removido. Uma cruz branca aparecerá. Clique e mantenha pressionado por um instante para remover o vértice.
Saia do modo de edição clicando em qualquer lugar do espaço de projeto (sobre o contorno da placa ou fora dele).
-
Clique e arraste A para executar uma das seguintes ações, dependendo do modo atual (use Shift+Spacebar para alternar entre os modos):
-
-
Board Planning Mode (Advanced Rigid-Flex mode - the Active Bar at the top of the graphical editing space has six buttons):
- Place » Board Region - use este comando para definir interativamente a região da placa (em uma placa com uma única região, a região da placa define o contorno da placa). Saiba mais sobre Como posicionar uma região da placa.
-
2D Layout Mode:
-
Design » Board Shape » Define Board Shape from Selected Objects - selecione um conjunto de primitivas de linha e/ou arco que definam uma forma fechada e use este comando para redefinir o contorno da placa de modo que corresponda a essa forma.
-
Design » Board Shape » Create Primitives from Board Shape - crie um conjunto de primitivas ao longo do limite do contorno da placa, de acordo com as configurações definidas na caixa de diálogo Primitivas de linha/arco a partir do contorno da placa.
-
-
3D Layout Mode:
- Design » Board Shape » Define Board Shape from 3D body - use este comando para definir o contorno da placa selecionando a superfície desejada de um modelo 3D.
Além disso, você pode usar os seguintes comandos no modo de planejamento da placa:
-
Design » Modify Board Shape - use este comando para modificar o contorno existente da placa posicionando vértices adicionais e, assim, definir novas formas para a borda.
Como usar o comando Modificar contorno da placa
Após iniciar o comando, o cursor mudará para uma cruz e você entrará no modo de modificação do contorno da placa. Um novo vértice de extremidade aparecerá na borda existente. À medida que você mover o cursor, esse vértice também se moverá ao longo da borda. Para modificar a borda:
- Posicione o novo vértice no local desejado ao longo do contorno existente e clique para inseri-lo.
- Posicione o cursor e clique para inserir vértices adicionais e, assim, definir novas formas para o contorno. Você pode estender o contorno original para fora da forma existente e/ou voltar para dentro do contorno original para, essencialmente, “remover” uma área existente.
- Quando a forma estiver como desejado, certifique-se de retornar o cursor a um ponto no contorno original e clique nesse ponto para concluir a modificação e aplicar a alteração.
- Para sair sem modificar, basta clicar com o botão direito ou pressionar Esc.
-
Design » Move Board Shape - use este comando para mover a forma da placa para outra posição no documento atual. Somente a forma da placa é movida com este comando. O projeto em si e seus objetos constituintes permanecem no lugar.
Após executar o comando, uma cópia do contorno da forma ficará presa ao cursor pelo canto inferior esquerdo. Mova a forma para o novo local desejado na área de trabalho e, em seguida, clique ou pressione Enter para confirmar o posicionamento. Durante o movimento, pressione Spacebar para girar a forma da placa no sentido anti-horário ou Shift+Spacebar para girá-la no sentido horário (o valor de Rotation Step é definido na página Editor de PCB – Geral da caixa de diálogo Preferências) ou pressione as teclas X ou Y para espelhar a forma da placa ao longo do eixo X ou Y, respectivamente. Para cancelar sem mover, clique com o botão direito ou pressione Esc.
-
Design » Move Board - use este comando para mover a placa inteira — a forma da placa e todos os objetos do projeto dentro dela — para outra posição no documento atual.
Após executar o comando, uma cópia do contorno da forma da placa ficará presa ao cursor pelo canto inferior esquerdo. Mova a forma para o novo local desejado no espaço de projeto e, em seguida, clique ou pressione Enter para confirmar o posicionamento. Todos os objetos constituintes do projeto também serão movidos para manter sua posição dentro da forma da placa. Para cancelar sem mover, clique com o botão direito ou pressione Esc.
Definição da forma da placa a partir de objetos selecionados
A forma da placa também pode ser definida a partir de objetos selecionados (no modo de layout 2D). Normalmente, trata-se de um conjunto de linhas e/ou arcos inseridos na camada Keepout ou em uma camada mecânica.
Siga esta sequência de etapas:
- Defina o modo de visualização como 2D Layout Mode (menu View).
-
Abra o painel Configuração de visualização e clique duas vezes para editar a camada mecânica que contém a forma da placa. A caixa de diálogo Edit Layer será aberta, permitindo definir Layer Type como
Board Shape, conforme mostrado no vídeo abaixo. - Torne ativa a camada mecânica que contém a forma e selecione os objetos. O comando Edit » Select » All on Layer é ideal para isso; o conjunto selecionado deve incluir apenas as trilhas e os arcos que formam o contorno da placa.
- Quando todos os objetos estiverem selecionados, execute o comando Design » Board Shape » Define Board Shape from Selected Objects. A forma da placa será atualizada para seguir o caminho definido pelas linhas selecionadas. Uma caixa de diálogo de aviso será exibida se o software não conseguir seguir a linha central dos objetos selecionados. O modo de visualização mudará para Board Planning Mode.
Demonstração da forma da placa no modo rígido-flexível padrão
O vídeo demonstra a criação da forma da placa a partir de objetos selecionados e, em seguida, a inserção de linhas de divisão para criar as três regiões necessárias.
Demonstração da forma da placa no modo rígido-flexível avançado
O vídeo demonstra primeiro a criação da forma da placa a partir de objetos selecionados e, em seguida, o recorte da forma para criar as três regiões necessárias. Depois, mostra uma abordagem alternativa, na qual
as três regiões da placa são definidas a partir de objetos selecionados. Observe que essas demonstrações usam recursos do Rigid-Flex 2.0, conforme descrito no início desta página.
Importação de um contorno para usar como forma da placa
A forma da placa pode ser definida a partir de um contorno fechado importado como dados DXF/DWG.
Ao combinar a capacidade de importar dados DXF/DWG para uma camada mecânica com a definição da forma da placa a partir de objetos selecionados, é possível transferir para o editor de PCB uma forma definida em um software de CAD mecânico.
Para preparar a nova placa para a importação:
- Selecione File » New » PCB. Uma nova PCB em branco será aberta; a região preta representa a forma atual da placa.
- Antes de importar uma nova forma, configure os itens a seguir conforme necessário para atender aos requisitos do seu projeto e da forma que será importada:
- Unidades - defina as unidades conforme necessário na Other seção do Properties painel no modo Board (mostrar imagem).
- Grade - clique duas vezes na grade global de ajuste da placa e configure-a conforme necessário na Grid Manager seção do Properties painel no modo Board (mostrar imagem).
- Origem - Em uma nova PCB, a localização padrão da origem definida pelo usuário é a origem absoluta, no canto inferior esquerdo do espaço de projeto. Selecione Edit » Origin » Set nos menus principais e clique para definir a localização da origem definida pelo usuário, por exemplo, no canto inferior esquerdo da forma atual da placa. É útil ajustá-la de acordo com a localização da origem do contorno que será importado.
O próximo passo é importar o contorno da placa como um arquivo .DXF ou .DWG. Observe que o contorno a ser importado deve ser fechado e que os recortes internos não são criados automaticamente (mas podem ser definidos posteriormente a partir dos objetos importados).
- Selecione File » Import » DXF/DWG para abrir a caixa de diálogo Import File, certifique-se de que File Type, no canto inferior direito da caixa de diálogo, esteja definido como AutoCAD Files (*.DXF, *.DWG) e procure o arquivo desejado.
- Quando o botão Open for clicado, a caixa de diálogo Import from AutoCAD será aberta (ver imagem).
- Defina Scale, Default Line Width e Layer Mappings conforme necessário e clique em OK.
- Cada objeto DXF/DWG será mapeado para um objeto e será exibido na área de projeto.
- Torne ativa a camada mecânica que contém os objetos do contorno da placa e selecione todos os objetos dessa camada (Edit » Select » All on Layer).
- Para atualizar o contorno da placa de modo que corresponda ao contorno selecionado, execute o comando Design » Board Shape » Define from Selected Objects.
- Se a placa incluir recortes, eles poderão ser criados selecionando o contorno do recorte e executando o comando Tools » Convert » Create Board Cutout from Selected Primitives.
Definição do contorno da placa a partir de um corpo 3D
Esse recurso redefine o contorno da placa com base em uma superfície (face) de um modelo 3D importado. Os formatos de modelo compatíveis incluem: STEP (*.Stp ou *.STEP), Parasolid (*.x_t ou *x_b) ou arquivo de peça do SOLIDWORKS (*.SldPrt). Ele pode ser usado para criar rapidamente um contorno de placa complexo e facilita a integração entre as áreas de projeto eletrônico e mecânico. Esse processo tem duas etapas: primeiro, o modelo STEP é importado; depois, o contorno desejado é selecionado no modelo STEP.
Para fazer isso:
- Alterne para View » 3D Layout Mode (atalho: 3).
- Para importar o modelo 3D, insira um corpo 3D (Place » 3D Body).
- Na caixa de diálogo Choose Model, localize e selecione o arquivo do modelo. O modelo 3D será importado para o editor de PCB e armazenado em um objeto de corpo 3D. Observe que esse modelo pode ser excluído da PCB após a redefinição do contorno da placa, se necessário.
- Selecione Design » Board Shape » Define Board Shape from 3D body.
- A barra de status solicitará que você Pick a 3D body. Clique no corpo 3D importado para selecioná-lo. O modelo ficará transparente.
- O cursor mudará para uma mira e a barra de status solicitará que você Choose Face. Ao passar o cursor sobre cada face, seu contorno será destacado. Quando houver uma superfície plana sob o cursor, ela ficará opaca, com uma borda azul fina. Clique para selecionar a face correta.
- A caixa de diálogo Board Outline Creation Successful será exibida, apresentando opções para escolher qual superfície da PCB deve ser alinhada à superfície selecionada (normalmente a camada superior) e se o modelo 3D deve ser ocultado da visualização e da verificação de regras de projeto. O comportamento de ocultação e desativação pode ser alterado posteriormente, se necessário, no modo 3D Models do painel PCB.
Observe que, se você mantiver o modelo STEP incorporado ao arquivo da PCB ou vinculado a ele, receberá uma notificação sempre que o arquivo STEP for alterado. Também será solicitado que você atualize o contorno, o que é útil quando ele ainda está em desenvolvimento e são esperadas atualizações.
Criação de primitivas a partir do contorno da placa
Além de definir o contorno da placa a partir de primitivas selecionadas, também é possível criar primitivas a partir do contorno da placa usando o comando Design » Board Shape » Create Primitives from Board Shape. Esse comando abrirá a caixa de diálogo Line/Arc Primitives from Board.

A caixa de diálogo Line/Arc Primitives From Board Shape
Opções e controles da caixa de diálogo Line/Arc Primitives From Board Shape
- Width - especifique a largura das primitivas de linha/arco geradas.
-
Layer - escolha uma camada na lista suspensa para as primitivas de linha/arco geradas.
-
Include Cutouts - habilite para incluir recortes ao gerar as primitivas de contorno.
-
Include layer stack regions - habilite para incluir regiões de empilhamento de camadas ao gerar as primitivas de contorno. Uma região de empilhamento de camadas é uma área da PCB definida pelo usuário à qual pode ser atribuído um empilhamento de camadas exclusivo. Uma placa pode ser dividida em várias regiões, cada uma com uma configuração própria de empilhamento de camadas. Os empilhamentos de camadas (definidos no Layer Stack Manager) podem ser configurados para atender tanto às regiões rígidas quanto às flexíveis da placa, facilitando o projeto de PCBs rígido-flexíveis. As regiões de empilhamento de camadas podem ser consultadas no painel PCB configurado no modo Layer Stack Regions.
-
Route Tool Outline - o comportamento padrão é posicionar as primitivas de contorno de modo que suas linhas centrais fiquem sobre a borda do contorno da placa. Quando essa opção é habilitada, os objetos de linha/arco são posicionados de modo que suas bordas toquem a borda do contorno da placa e a borda do recorte, conforme necessário para o contorno de uma ferramenta de fresagem (rout).
-
Delete Existing Non-Net Lines/Arcs On Layer - habilite para excluir as linhas/arcos existentes que não estejam associados a uma rede específica na camada selecionada.
-
Use esse comando quando o contorno da placa já existir, mas não houver objetos ao longo de seu limite. Algumas situações em que esse comando pode ser útil:
- Quando você quiser modificar o contorno da placa (ou os recortes da placa) modificando primeiro as primitivas de trilha e arco.
-
Quando você precisar de um limite de exclusão para a placa ou de limites de exclusão para os recortes da placa na camada Keep-Out. Isso é discutido com mais detalhes abaixo, na seção Considerações importantes de projeto ao usar recortes na placa.
Criação de um furo no contorno da placa
Um recorte da placa pode ser posicionado em qualquer lugar do contorno da placa. Para posicionar um recorte, alterne para a visualização da placa no modo de layout 2D e use o comando Design » Board Shape » Define Board Cutout nos menus principais (como alternativa, você também pode usar o comando Place » Define Board Cutout no modo de planejamento da placa). Observe que o recorte é, na verdade, um objeto de região configurado como um objeto negativo.
Um recorte da placa foi posicionado no contorno da placa.
Considerações importantes de projeto ao usar recortes da placa
Como manter um polígono afastado da borda de um recorte da placa
Polígonos que se sobrepõem a um recorte da placa definido por uma região sólida serão preenchidos tão perto da borda do recorte quanto permitir a regra de projeto de afastamento aplicável. Se necessário, pode ser criada uma regra de projeto de afastamento específica, cujo escopo poderia, por exemplo, ser definido para se aplicar entre IsBoardCutoutRegion e InPolygon.
Como definir um percurso da ferramenta de fresagem ao redor da borda da placa e dos recortes
Uma abordagem comum para separar a placa acabada do painel de fabricação é fresar seu contorno no painel. Os recortes da placa também podem ser fresados. O percurso da ferramenta de fresagem é definido posicionando objetos de linha e/ou arco em uma camada mecânica. Isso pode ser feito manualmente ou automaticamente pelo software.
Para definir um percurso da ferramenta de fresagem para a placa e seus recortes:
-
Com a placa no modo de layout 2D, execute o comando Design » Board Shape » Create Primitives From Board Shape. A caixa de diálogo Primitivas de linha/arco a partir do contorno da placa será aberta.
-
Defina um Width adequado para os objetos que definirão o percurso da ferramenta de fresagem. Consulte seu fabricante se tiver dúvidas sobre isso.
-
Selecione uma camada mecânica disponível. Essa camada deve ser reservada exclusivamente para a definição do percurso da ferramenta de fresagem.
-
Ative a opção Include Cutouts se a placa tiver recortes.
-
Ative a opção Route Tool Outline. Quando essa opção está ativada, os objetos de linha/arco são posicionados de modo que suas bordas toquem a borda do contorno da placa e a borda do recorte.
-
Clique em OK para criar os objetos da ferramenta de fresagem na camada mecânica escolhida.
-
A camada mecânica utilizada deve ser definida como a camada da ferramenta de fresagem. Para isso, acesse a aba Layers & Colors do painel Configuração de visualização. Clique com o botão direito do mouse em uma grade de camadas e escolha o comando Add Mechanical Layer. Na caixa de diálogo Edit Layer que se abre, defina Layer Type como Route Tool Path. Esse tipo de camada é usado para indicar a camada que contém as informações de fresagem mecânica.
As imagens abaixo mostram o percurso da ferramenta de fresagem definido em uma camada mecânica.
Um recorte da placa na primeira imagem, com um percurso da ferramenta de fresagem definido na segunda imagem.
Áreas de exclusão e o contorno da placa
Além do contorno da placa, você também deve definir um limite de posicionamento e roteamento ao redor da borda da placa. Esse limite pode ser criado automaticamente a partir do próprio contorno da placa usando o comando Design » Board Shape » Create Primitives From Board Shape (no modo de layout 2D) e definindo Layer na caixa de diálogo Line/Arc Primitives from Board como Keep-Out Layer.
Como alternativa, isso pode ser feito manualmente posicionando objetos na camada de exclusão. Os objetos posicionados nessa camada definem um limite no-crossing-allowed para componentes e roteamento. Normalmente, deseja-se que objetos como componentes e trilhas fiquem a uma determinada distância da borda da placa; essa distância pode ser controlada configurando as regras de projeto de roteamento e posicionamento de componentes aplicáveis. Você também pode definir outras áreas de exclusão de roteamento e componentes para objetos mecânicos, como cabeças de parafusos ou outros requisitos de montagem.
Um limite de exclusão definido pelo posicionamento de objetos de linha padrão na camada de exclusão (roxa).
- Os limites de exclusão podem ser definidos posicionando quaisquer objetos de projeto padrão, como linhas, arcos, preenchimentos e regiões, na camada de exclusão. Os objetos posicionados na camada de exclusão criam uma área de exclusão em todas as camadas de sinal.
- Você também pode definir áreas de exclusão específicas de camada em qualquer camada de cobre. Para isso:
- Clique na aba da camada desejada.
- Defina o limite ou a área de exclusão posicionando objetos de exclusão específicos de camada (submenu Place » Keepout). As áreas de exclusão específicas de camada são objetos padrão com o atributo Keepout ativado. Elas são exibidas na mesma cor da camada, com uma borda na cor de exclusão. Observe que os objetos de exclusão específicos de camada não são incluídos nos arquivos de saída Gerber ou ODB++.






).