Включая детали дизайна
Краткий обзор
- Узнайте, какие элементы документации печатной платы можно добавлять в редакторе печатных плат или редакторе библиотек посадочных мест и как использовать механические слои для их упорядочивания.
- Посмотрите, что содержат таблицы стека слоев и таблицы сверловки, где их можно размещать и как они обновляются или отражают текущее состояние проекта платы.
- Разберитесь в основных возможностях размещения, перемещения, изменения размеров и настройки свойств, которые определяют, как эти элементы документации отображаются в выходных данных проекта печатной платы.
Для многих формируемых выходных документов потребуются дополнительные сведения. Например, на производственном чертеже понадобятся размеры, на сборочном чертеже может потребоваться увеличенный вид определенного участка платы, а на чертеже изготовления — таблица стека слоев и таблица сверловки. Такие сведения можно добавить в редакторе печатных плат или в редакторе библиотек печатных плат.
Слои для чертежей общего назначения
В редакторе печатных плат такие элементы, как размеры и указания по изготовлению и сборке, размещаются на механических слоях. ПО поддерживает неограниченное количество механических слоев общего назначения, которые включаются на панели View Configuration. Этим слоям можно присваивать нужные имена (щелкните имя правой кнопкой мыши и выберите Edit Layer), а также включать их в печатные документы и послойные выходные данные для изготовления.
Таблица стека слоев

Таблицу стека слоев можно разместить в документе печатной платы рядом с самим проектом. Она содержит подробную сводку о стеках слоев платы и назначении групп слоев.
Таблица стека слоев — это графический объект в виде таблицы, который документирует слои, материалы, толщины и значения диэлектрической проницаемости, используемые в текущем проекте печатной платы. Таблица размещается в рабочей области рядом с проектом платы и также содержит графические обозначения и карту, показывающую, какой стек слоев используется в каждой области платы. Таблица стека слоев отражает конфигурации слоев, заданные с помощью Layer Stack Manager, и является важной частью документации для проектов со сложной структурой стека слоев, например гибко-жестких плат.
Таблица стека слоев доступна в редакторе печатных плат, когда для рабочей области выбран обычный режим 2D (сочетание клавиш 2). После запуска команды размещения таблицы стека слоев (Place » Layer Stack Table) курсор примет вид перекрестия, и будет включен режим размещения таблицы стека слоев. Для размещения выполните следующие действия:
- Щелкните, чтобы разместить таблицу.
- Редактор останется в режиме размещения таблицы стека слоев, позволяя при необходимости разместить еще одну таблицу. Если это не требуется, щелкните правой кнопкой мыши или нажмите Esc, чтобы выйти из режима размещения.
Во время размещения, пока таблица стека слоев еще перемещается вместе с курсором и ее центральная точка не зафиксирована, доступны следующие дополнительные действия:
- Нажмите клавишу Alt, чтобы ограничить перемещение горизонтальной или вертикальной осью в зависимости от исходного направления движения.
- Нажмите Spacebar, чтобы повернуть таблицу стека слоев против часовой стрелки, или Shift+Spacebar, чтобы повернуть ее по часовой стрелке. Поворот выполняется с шагом 90°.
Чтобы переместить таблицу стека слоев, нажмите на нее и, удерживая кнопку мыши, перетащите в нужное место.

Выберите и перетащите таблицу стека слоев, чтобы изменить ее положение.
Свойства таблицы стека слоев

Режим Layer Stack Table панели Properties.
Расположение
-
(X/Y)
- X (первое поле) — текущая координата X (по горизонтали) опорной точки объекта относительно текущего начала координат рабочей области. Измените значение, чтобы изменить положение объекта по оси X. Значение можно ввести в метрических или дюймовых единицах; если единицы отличаются от используемых по умолчанию, укажите их при вводе.
- Y (второе поле) — текущая координата Y (по вертикали) опорной точки объекта относительно текущего начала координат. Измените значение, чтобы изменить положение объекта по оси Y. Значение можно ввести в метрических или дюймовых единицах; если единицы отличаются от используемых по умолчанию, укажите их при вводе.
- Rotation — угол поворота объекта (в градусах), отсчитываемый против часовой стрелки от нулевого направления (горизонталь 3 o'clock). Измените значение, чтобы повернуть объект. Минимальный шаг изменения угла составляет 0,001°.
Свойства
- Layer — слой, которому в данный момент назначена таблица. Выберите другой слой в раскрывающемся списке.
- Alignment — выберите нужное выравнивание в раскрывающемся списке.
-
Units — выберите в раскрывающемся списке
Metric (mm)илиImperial (mil). - Show Board Map — включите, чтобы отобразить контур платы, показывающий, как различные стеки слоев назначены областям платы. Используйте ползунок, чтобы изменить масштаб отображаемого контура платы.
- Show Total Board Thickness — включите, чтобы отобразить общую толщину платы под сеткой таблицы стека слоев.
- Line Width — задайте толщину линий текста в таблице. Line Width влияет на толщину линий текста.
- Text Height — текущая высота символов текста. Задайте высоту текста в таблице. Text Height также влияет на размер таблицы. При увеличении высоты текста таблица автоматически увеличивается.
Тип шрифта
-
TrueType — используйте это поле для выбора нужного шрифта TrueType. Раскрывающийся список Font содержит шрифты TrueType и OpenType (расширенный набор TrueType), найденные в папке
\Windows\Fonts. Обратите внимание, что в список включаются только обнаруженные основные шрифты с уникальными именами. Используйте параметры B (bold) и I (Italic) для выделения текста. -
Stroke
-
Font - используйте это поле для выбора требуемого штрихового шрифта. Доступны следующие варианты:
-
Default- простой векторный шрифт, поддерживающий вывод на перьевой плоттер и векторный фотоплоттер. -
Serif- более сложный шрифт, замедляющий формирование векторных выходных данных, например Gerber. -
Sans Serif- более сложный шрифт, замедляющий формирование векторных выходных данных, например Gerber.
-
-
Font - используйте это поле для выбора требуемого штрихового шрифта. Доступны следующие варианты:
-
Stroke Width - отображает текущую толщину штриха.
Столбцы
В этой области можно указать, какие столбцы должны отображаться в таблице стека слоев, задать выравнивание текста в каждом столбце и его общую ширину.
- Caption - заголовок отображаемого столбца.
- Align - нажмите ячейку выравнивания для нужного заголовка. Последовательными нажатиями можно переключать варианты выравнивания (по левому краю, по центру и по правому краю). Каждое нажатие поля выравнивания изменяет выравнивание текста соответствующего столбца в таблице.
-
Width - нажмите поле, чтобы изменить ширину выбранного столбца. Если указано
Auto, система автоматически подстраивает ширину столбца под введенный в нем текст. При необходимости можно ввести требуемую ширину. - Add - используйте раскрывающийся список, чтобы добавить в таблицу стека слоев столбец из доступных вариантов. Выберите в списке заголовок, который должен отображаться в таблице.
- Up - нажмите, чтобы переместить выбранный заголовок на один столбец влево в таблице. Нажимайте кнопку Up повторно, чтобы переместить выбранный столбец дальше влево.
- Down - нажмите, чтобы переместить выбранный заголовок на один столбец вправо в таблице. Нажимайте кнопку Down повторно, чтобы переместить выбранный столбец дальше вправо.
-
- нажмите, чтобы удалить выбранный заголовок из таблицы. В таблице появится запрос на подтверждение удаления выбранного элемента. Нажмите Yes , чтобы удалить его, или No , чтобы отменить удаление.
Таблица сверловки

Таблица сверловки отображает актуальную сводку по всем отверстиям в плате
Таблица сверловки (также называемая таблицей чертежа сверловки или легендой чертежа сверловки) — стандартный элемент, необходимый для изготовления печатной платы. В ней указаны размеры и количество отверстий для каждого используемого на плате сверла. Каждый диаметр сверления может быть представлен символом, буквой или фактическим размером отверстия. При формировании чертежа сверловки платы каждое место сверления отмечается символом. Таблица сверловки обновляется в реальном времени: при добавлении в проект печатной платы или удалении из него объектов с отверстиями, таких как контактные площадки и переходные отверстия, таблица обновляется.
Таблицу сверловки можно разместить только в редакторе печатных плат. После запуска команды таблица сверловки появится у курсора. Переместите таблицу в подходящее место за пределами платы, затем нажмите кнопку мыши или клавишу Enter, чтобы разместить ее.
Во время размещения, пока таблица сверловки привязана к курсору и еще не зафиксирована, доступны следующие дополнительные действия:
- Нажмите клавишу Tab, чтобы приостановить размещение и перейти в режим Drill Table панели Properties , где можно изменять свойства таблицы на лету. Нажмите кнопку паузы, отображаемую поверх рабочей области , чтобы возобновить размещение.
- Нажмите клавишу Alt, чтобы ограничить перемещение горизонтальной или вертикальной осью в зависимости от исходного направления движения.
Перемещение таблицы сверловки
Нажмите и удерживайте кнопку мыши в любом месте таблицы сверловки, затем переместите ее в нужное место в рабочей области редактора печатных плат.
Интерактивное изменение размеров таблицы сверловки
Размер таблицы сверловки определяется автоматически на основе заданного параметра Text Height, а также количества различных диаметров отверстий (строк) и заданных столбцов. Чтобы интерактивно изменить размер таблицы, нажмите ее один раз для выбора, затем нажмите и удерживайте угловую вершину и переместите ее до получения нужного размера. Обратите внимание: при интерактивном изменении размеров таблицы размер шрифта также увеличивается или уменьшается.
Интерактивное переключение отображаемой пары слоев
Если плата содержит пары слоев, отображаемая пара задается параметром Layers Pairs в режиме Drill Table панели Properties .
Выбранную пару слоев также можно переключить следующими способами:
-
Контекстное меню редактора печатных плат — нажмите таблицу сверловки правой кнопкой мыши и выберите требуемую пару слоев в подменю Drill Table, как показано на изображении ниже.

Нажмите таблицу сверловки правой кнопкой мыши, чтобы переключить ее на отображение другой пары слоев -
Меню выбора пары слоев, доступное через вкладку слоя в нижней части рабочей области, как показано на изображении ниже.
Свойства таблицы сверловки

Режим Drill Table панели Properties
Действия
Refresh – нажмите кнопку, чтобы обновить таблицу сверловки актуальными данными о символах сверловки из печатной платы.
Расположение
-
(X/Y) – текущие координаты X и Y опорной точки таблицы сверления. Опорная точка находится в левом нижнем углу, если Alignment =
Bottom, или в левом верхнем углу, если Alignment =Top. - Rotation – угол поворота таблицы сверления в градусах.
Свойства
-
Layer Pairs – таблица сверления поддерживает многослойные платы со сверлением между парами слоев. В раскрывающемся списке выберите пару слоев, заданную на вкладке Via Types в Layer Stack Manager, или один из следующих вариантов:
- All Layer Pairs (Composite table) – отображение информации обо всех парах слоев.
-
All Layer Pairs (Separate tables) – отображение информации о каждой паре слоев в отдельной таблице.
- Top - Bottom – отображение только сквозных отверстий.
- Counterhole Bottom – отображение только отверстий с цековкой или зенковкой на нижней стороне печатной платы.
- Counterhole Top – отображение только отверстий с цековкой или зенковкой на верхней стороне печатной платы.
- Text Height – отображение высоты текста.
Тип шрифта
-
TrueType – выберите, чтобы использовать шрифты, доступные на вашем компьютере (в папке \Windows\Fonts). Шрифты TrueType обеспечивают полную поддержку Unicode. По умолчанию программа сохраняет ссылку на используемый шрифт TrueType (сам шрифт не сохраняется в файле печатной платы), поэтому этот шрифт должен быть установлен на каждом компьютере, на который переносится проект. Кроме того, используемые шрифты TrueType можно встроить в файл печатной платы с помощью параметров на странице PCB Editor – True Type Fonts диалогового окна Preferences, где также можно выбрать Substitution Font для использования в случае отсутствия невстроенного шрифта.
- Font – выберите нужный шрифт TrueType в раскрывающемся списке. Используйте B для полужирного или I для курсивного начертания текста.
-
Stroke
-
Font – выберите нужный штриховой шрифт в раскрывающемся списке. Доступные варианты:
-
Default– простой векторный шрифт, предназначенный для перьевых и векторных фотоплоттеров. -
Sans Serif -
Serif
-
- Stroke Width – отображение толщины штриха.
-
Font – выберите нужный штриховой шрифт в раскрывающемся списке. Доступные варианты:
- Show Footer – включение/отключение отображения нижнего колонтитула таблицы.
- Alignment – таблица может формироваться снизу вверх (Bottom) или сверху вниз (Top). Используйте этот параметр, чтобы изменение размеров таблицы не затрагивало окружающие объекты в рабочей области.
- Table Border Width – толщина линий рамки таблицы.
-
Drill Symbols – нажмите, чтобы открыть диалоговое окно Drill Symbols, в котором можно назначить символы/буквы размерам отверстий.
Параметры и элементы управления диалогового окна Drill Symbols
Grid Area
В области таблицы отображается подробная информация о соответствии символов размерам отверстий. Ее можно настроить: перетащите заголовок столбца, чтобы изменить порядок столбцов, или щелкните заголовок столбца правой кнопкой мыши и установите/снимите флажок, чтобы отобразить/скрыть столбец.
Grouping
Нажмите кнопку Grouping, чтобы задать свойства, определяющие назначение символов операциям сверления (отверстиям). Сначала отверстия группируются по размеру, а затем им назначаются отдельные символы, если включен параметр группировки, позволяющий их различать. Например, проект может содержать круглую контактную площадку с отверстием 1 мм и квадратную контактную площадку с отверстием 1 мм. Если параметр Pad Shape не включен в Grouping, им будет назначен один и тот же символ. Но если параметр Pad Shape включен в Grouping, им будут назначены разные символы.
Graphic Symbol
Каждое отверстие может обозначаться символом, буквой или строкой с фактическим размером отверстия. Следующие параметры определяют стиль и размер символов:
-
Symbol - выберите, чтобы обозначать каждое отверстие символом. Программа включает 15 предустановленных стилей символов, показанных на изображении ниже. Если размеров отверстий больше 15, автоматически назначаются буквенные обозначения.
- Character - выберите, чтобы обозначать каждое отверстие буквой.
- Symbol Size - высота символа/буквы, отображаемых на слое Drill Drawing. Обратите внимание, что этот параметр применяется ко всем символам/буквам на чертеже сверления.
Draw Symbols
Следующие параметры определяют вид символов сверления и условия их отображения:
- Show Symbols - отображать символ в месте каждого отверстия.
- Show Hole Size - отображать фактический диаметр сверления в месте каждого отверстия в виде числового значения.
- Show Drill Symbols - по умолчанию символы сверления на слое Drill Drawing не отображаются. Включите этот параметр, чтобы отобразить символы сверления.
-
-
– нажмите, чтобы обновить таблицу после изменений в проекте, влияющих на таблицу сверления. Обратите внимание, что при формировании выходных данных таблица обновляется автоматически.
Единицы измерения
-
Primary Units – в раскрывающемся списке выберите основные единицы измерения:
Metric (mm)илиImperial (mil). -
Dual Units – в раскрывающемся списке выберите дополнительные единицы измерения:
Metric (mm)илиImperial (mil). Используйте
или
, чтобы соответственно отобразить или скрыть эти единицы в рабочей области.
Точность
- Primary Precision – в раскрывающемся списке задайте требуемую точность (количество знаков после десятичного разделителя).
- Dual Precision – в раскрывающемся списке задайте точность для дополнительных единиц измерения (количество знаков после десятичного разделителя).
Столбцы
- Grid – отображает все заголовки столбцов (Caption) в таблице сверления, настройку Align, которая изменяет положение содержимого в ячейках, Width и Order, в котором отображается информация в каждом столбце. Чтобы изменить порядок сортировки с возрастающего на убывающий и наоборот, щелкните в столбце Order, чтобы открыть раскрывающееся меню, затем выберите нужный порядок: Asc — по возрастанию или Dsc — по убыванию.
-
Edit Columns — нажмите, чтобы открыть диалоговое окно Columns, в котором можно добавить новые столбцы в таблицу сверления или изменить существующие.
В диалоговом окне представлены все существующие столбцы и связанные с ними данные (только для чтения). Используйте следующие кнопки под таблицей, чтобы настроить данные, отображаемые в таблице сверления:
- Add Column — добавление нового столбца в таблицу сверления. Нажмите, чтобы открыть меню доступных столбцов. Уже используемые или недоступные столбцы отображаются в меню серым цветом. Эта команда также доступна в контекстном меню.
- Remove Column — нажмите, чтобы удалить выбранные столбцы. Обратите внимание: диалоговое окно подтверждения не отображается; столбец удаляется сразу после нажатия кнопки. Эта команда также доступна в контекстном меню.
- Change Header — нажмите, чтобы открыть диалоговое окно Изменение заголовка столбца, в котором можно изменить заголовок выбранного столбца. Эта команда (под названием Change column header) также доступна в контекстном меню.
В контекстном меню доступны следующие дополнительные команды:
-
Text Alignment — выравнивание текста в выбранном столбце. Доступные варианты:
Left,CenterиRight. -
Set column width — настройка ширины выбранного столбца. Доступные варианты:
Autosize(по умолчанию) иManual. При нажатииManualоткрывается диалоговое окно Задание ширины столбца, в котором можно ввести нужную ширину.
Вид проекта

Разместите вид проекта, чтобы показать определенную область платы. В этом примере установлен масштаб 200%.
Объект «Вид проекта» представляет собой графический снимок любой прямоугольной области текущей или другой платы. Его можно разместить в любом месте рабочего пространства и масштабировать до любого размера.
Вид проекта можно разместить только в редакторе печатных плат. После запуска команды размещения вида проекта (Place » Design View) к курсору будет прикреплен вид проекта. Переместите его в подходящее место, затем щелкните или нажмите Enter, чтобы разместить его.
Во время размещения, пока вид проекта прикреплен к курсору и еще не зафиксирован, доступны следующие дополнительные действия:
- Нажмите клавишу Alt, чтобы ограничить перемещение горизонтальной или вертикальной осью в зависимости от начального направления движения.
После размещения вида проекта можно настроить отображение нужных слоев следующим образом:
- Выделив вид проекта в рабочем пространстве, откройте панель Свойства двойным щелчком или щелкните правой кнопкой мыши и выберите Properties в контекстном меню.
- Используйте кнопку Define на панели Properties , чтобы интерактивно задать нужную область.
-
В разделе Layers панели Properties щелкните значок
, чтобы включить отображение нужных слоев. После включения на панели Properties для выбранных слоев будет отображаться значок
.
Виды проекта включаются в печатные материалы и PDF-файлы. При выводе вид проекта сохраняет собственные настройки видимости слоев, что позволяет получить требуемое представление при печати и в PDF. Обратите внимание: примитивы на слоях, используемых в виде проекта, по-прежнему подчиняются настройкам отображения соответствующего слоя в диалоговом окне Печать. Например, если в виде проекта отображается слой Top Overlay и в задании Output Job для этого слоя настроено отображение дорожек в черновом режиме, то дорожки слоя Top Overlay в виде проекта также будут отображаться в черновом режиме.
После размещения вида проекта в рабочем пространстве можно интерактивно изменить его положение, масштаб, размер и отображаемую область.
- Change the position — Click+Drag объект вида проекта в новое место рабочего пространства печатной платы.
- Adjusting the Scale — щелкните один раз, чтобы выделить вид проекта, затем Click+Drag угловой маркер, чтобы увеличить (перетаскивая наружу) или уменьшить (перетаскивая внутрь) масштаб вида проекта.
- Adjusting the View Size — щелкните один раз, чтобы выделить вид проекта, затем Ctrl+Click+Drag угловой маркер, чтобы изменить размер вида проекта.
- Changing the Focus – Ctrl+Click+Drag в любом месте внутри вида проекта, чтобы переместить отображаемую область в пределах окна вида проекта.

Ctrl+Click+Drag для перемещения и настройки области, отображаемой в виде проекта.
Свойства вида проекта

Режим Design View панели Properties.
Расположение
- (X/Y) — текущие координаты X и Y опорной точки вида проекта.
Свойства
- This document — выберите, чтобы задать свойства для текущего активного документа.
-
Specify document — выберите, чтобы задать свойства для другого документа. После выбора нажмите
в поле Document и укажите нужный документ.
-
Document — нажмите
, чтобы найти и выбрать нужный документ, если выбран вариант Specify document .
- Mirrored — нажмите, чтобы включить зеркальное отображение области платы в виде проекта.
- Scale — нажмите, чтобы задать размер объекта с помощью масштабного коэффициента.
- Title — введите заголовок вида проекта.
- Text Height — введите высоту текста заголовка вида проекта.
- Font — выберите нужный шрифт заголовка в раскрывающемся списке. Щелкните поле цвета, чтобы открыть окно выбора цвета текста заголовка. Обратите внимание: для хорошей видимости цвет текста должен контрастировать с цветом фона рабочего пространства.
- Define — нажмите, чтобы вернуться в рабочее пространство с курсором в виде перекрестия, затем задайте прямоугольную область вида, перетаскивая курсор с нажатой кнопкой мыши.
Слои
В этом разделе представлен список всех слоев платы, в котором можно настроить отображение отдельных слоев в виде проекта.
-
Name — имя слоя. Используйте
или
, чтобы соответственно показать или скрыть указанный слой в представлении проекта.
- Type — тип слоя.
Объект OLE

Размещенные объекты OLE: изображение, ячейки электронной таблицы и текст документа Word (сверху вниз)
Технология связывания и внедрения объектов (Object Linking and Embedding, OLE) в редакторе печатных плат позволяет внедрять в проект печатной платы данные из Windows-приложений, поддерживающих OLE, сохраняя активную связь с исходным приложением. Во многих случаях это позволяет редактировать внедренные в плату данные в приложении, в котором они были созданы.
Типичные объекты OLE, которые можно разместить в документе печатной платы, включают обычные документы Excel, документы Word или графические объекты из подходящего графического приложения с поддержкой OLE. Поддерживаемые типы файлов включают распространенные форматы: электронные таблицы CSV и XLS, текстовые документы DOC и RTF, а также изображения BMP.
Объекты OLE можно размещать и внедрять в редакторе печатных плат. После запуска команды Place » Object From File выберите нужный файл в диалоговом окне Choose File, затем щелкните в рабочей области, чтобы разместить объект.
Функция интеллектуальной вставки Smart Paste в Altium также позволяет скопировать выделенный фрагмент в приложении с поддержкой OLE и вставить его (Edit » Paste) в документ печатной платы как объект OLE. При необходимости можно использовать вариант вставки текста (Edit » Paste Text), чтобы извлечь текстовые элементы из объекта OLE. Они будут размещены как текстовые объекты печатной платы.
После размещения внедренные объекты можно пропорционально масштабировать, перетаскивая маркеры выделения с нажатой кнопкой мыши. Для текстовых объектов, таких как документы Word и Excel, размер и толщина линий внедренного текста автоматически изменяются в соответствии с новыми габаритами.
- Объект OLE также можно преобразовать в набор свободных примитивов с помощью команды Tools » Convert » Explode OLE Object to Free Primitives. При этом объект будет разбит на соответствующие области и/или текстовые объекты.
- Преобразование в свободные примитивы также предлагается, если при попытке редактирования объекта OLE не удается найти соответствующее приложение с поддержкой OLE.
Свойства объекта OLE

Режим OLE Object панели Properties.
Расположение
- (X/Y) — текущие координаты X (по горизонтали) и Y (по вертикали) опорной точки объекта относительно текущего начала координат рабочей области. Измените значения, чтобы переместить объект.
- Rotation — угол поворота объекта (в градусах), измеряемый против часовой стрелки от нулевого направления (горизонталь 3 o'clock). Измените значение, чтобы повернуть объект. Минимальный шаг изменения угла составляет 0,001°.
Свойства
- Layer — слой, которому в данный момент назначен объект. Используйте раскрывающийся список, чтобы выбрать другой слой.
- Edit Data — нажмите, чтобы открыть объект в связанном приложении и внести необходимые изменения. После внесения изменений и закрытия связанного приложения на панели Properties нажмите Save , чтобы сохранить изменения, или Cancel.
Размеры
Редакторы печатных плат и библиотек печатных плат включают набор инструментов нанесения размеров для различных требований проектирования.
| Размерный объект | Описание |
|---|---|
| Angular Dimension | Позволяет наносить угловые размеры. |
| Baseline Dimension | Позволяет наносить линейные размеры для набора опорных точек относительно одной базовой точки. Первая выбранная точка является базовой. Все последующие точки отсчитываются от нее. Таким образом, значение каждого размера представляет собой расстояние между соответствующей опорной точкой и базовой точкой, выраженное в единицах измерения по умолчанию. В качестве опорных объектов могут выступать дорожки, дуги, контактные площадки, переходные отверстия, текст, заливки, полигоны или компоненты. |
| Center Dimension | Позволяет обозначать центр дуги или окружности. |
| Leader Dimension | Позволяет добавлять выноску к объекту, точке или области. Доступны три типа выносок: автоматическая, круглая и квадратная; текст выноски при этом отображается без рамки, в круглой или квадратной рамке соответственно. Указатель может иметь вид стрелки или точки. |
| Linear Dimension | Позволяет наносить линейный размер. Значение размера представляет собой расстояние между начальным и конечным маркерами (опорными точками, выбранными пользователем), выраженное в единицах измерения по умолчанию. В качестве опорных элементов могут выступать объекты (дорожки, дуги, контактные площадки, переходные отверстия, текст, заливки, полигоны или компоненты) либо точки в свободном пространстве. |
| Linear Diameter Dimension | Позволяет наносить размер диаметра дуги или окружности, а не радиуса. Размер можно разместить внутри или снаружи. |
| Ordinate Dimension | Позволяет наносить линейные размеры для набора объектов относительно одного опорного объекта. Первый выбранный объект является базовым. Все последующие объекты отсчитываются от него. Таким образом, значение каждого размера представляет собой расстояние между соответствующим опорным объектом и базовым объектом, выраженное в единицах измерения по умолчанию. В качестве опорных объектов могут выступать дорожки, дуги, контактные площадки, переходные отверстия, текст, заливки, полигоны или компоненты. |
| Radial Dimension | Позволяет наносить размер радиуса дуги или окружности. Размер можно разместить внутри или снаружи. |
| Radial Diameter Dimension | Позволяет наносить размер диаметра дуги или окружности, а не радиуса. Размер можно разместить внутри или снаружи относительно линии дуги/окружности. |
| Standard Dimension | Размещает размерную информацию на текущем слое печатной платы. Значение размера представляет собой расстояние между начальным и конечным маркерами, выраженное в единицах измерения по умолчанию. |
Размерные объекты доступны в подменю Place » Dimension главного меню. При нанесении размера объекта отображаются точки привязки, подсвечивающие места, к которым можно прикрепить размер. На протяжении всего процесса в строке состояния отображается информация о действиях, необходимых на каждом шаге. Используется ближайшая к курсору точка: именно к ней будет прикреплен размер, если щелкнуть кнопкой мыши или нажать Enter.
Примеры размещения некоторых размеров показаны в видео ниже.
Дополнительные действия, доступные во время размещения:
- Нажимайте клавиши + и - (на цифровой клавиатуре), чтобы переключаться между всеми видимыми слоями проекта вперед и назад соответственно — это позволяет быстро менять слой размещения.
- При размещении размера от общей базы, обозначения центра, линейного диаметрального, линейного или ординатного размера нажмите Spacebar, чтобы повернуть размер против часовой стрелки, или Shift+Spacebar — по часовой стрелке. Поворот выполняется в соответствии со значением Rotation Step, заданным на странице PCB Editor – General диалогового окна Preferences.
- При размещении стандартного размера нажмите клавишу L, чтобы перенести размер на другую сторону платы. Обратите внимание: это возможно только до фиксации начальной точки размера.
Значение размера (если применимо) автоматически обновляется при перемещении его начальной или конечной точки. Аналогично, при изменении положения объекта, к которому привязана опорная точка размера, размер обновляется и увеличивается или уменьшается в соответствии с изменением. Для радиального или диаметрального размера значение автоматически обновляется при изменении диаметра опорной дуги или окружности.
При удалении опорного объекта или объектов, к которым привязан размер, открывается диалоговое окно с запросом на удаление самого размера. Если размер не удалять, он останется в рабочей области, но без привязки.
Размер можно перемещать следующими способами:
- Selecting both the dimension object and the dimensioned object(s). Весь размер можно перетащить в нужное место.
- Selecting a dimensioned object only. Текст размера следует за объектом только в плоскости своего выравнивания. Выносные линии размера (а для радиального диаметрального или радиального размера — его указатель и хвостовая часть) удлиняются или укорачиваются, сохраняя связь между размером и измеряемым объектом. Обозначение центра или размер с выноской перемещается вместе с объектом. Сегмент размера с выноской между стрелкой или точкой и первым заданным изломом удлиняется или укорачивается, сохраняя связь между размером и измеряемым объектом.
- Selecting the dimension object only. Важно отметить, что размер нельзя переместить отдельно, если он привязан к объекту проекта. Чтобы переместить только размер, сначала необходимо отсоединить его от измеряемого объекта или объектов.
При выборе размера появляются маркеры редактирования, с помощью которых можно изменять размещенный размер непосредственно в рабочей области, графически меняя такие свойства, как положение текста и опорных точек. Ниже приведены примеры маркеров редактирования для некоторых типов размеров.
|
При выборе линейного размера доступны следующие маркеры редактирования:
При выборе углового размера доступны следующие маркеры редактирования:
При выборе радиального размера доступны следующие маркеры редактирования:
При выборе ординатного размера доступны следующие маркеры редактирования.
|
Маркеры на измеряемых объектах или рядом с ними (например, C и D для линейного размера или C и E, а также D и F для углового размера, как показано выше) позволяют переопределять привязки — после отсоединения от опорного объекта размер теряет привязку, и его можно переместить для привязки к другой опорной точке или объекту. При перетаскивании любого маркера редактирования линейного, ординатного размера или размера от общей базы без привязки такой размер можно поворачивать.
Свойства размеров
Для размеров предусмотрен широкий набор параметров, позволяющий гибко настраивать стрелки и текст. Чтобы изменить свойства одного или нескольких выбранных размеров, откройте панель Properties.
| Свойство | Применяется к объектам | Описание |
|---|---|---|
Стиль |
||
| Width | Все, кроме обозначений центра и ординатных размеров | Текущая толщина размерной линии. |
| Width (в области Extension Line) | Угловой размер Размер от общей базы Линейный размер Линейный диаметральный размер Ординатный размер |
Текущая толщина выносных линий размера. |
| Gap | Угловой размер Размер от общей базы Размер с выноской Линейный размер Линейный диаметральный размер Ординатный размер |
|
| Offset | Угловой размер Размер от общей базы Линейный размер Линейный диаметральный размер |
Текущее смещение линии со стрелкой относительно выносной линии размера. |
| Text Gap | Все, кроме обозначений центра и стандартных размеров |
|
| Leader Shape | Размер с выноской | В раскрывающемся списке выберите фигуру, в которую будет заключен текст размера. Доступные варианты: Automatic, Round и Square. Если выбран вариант Round или Square, задайте требуемое значение Size. |
| Arrow Style | Размер с выноской | В раскрывающемся списке выберите требуемый стиль выноски. Доступные варианты: Arrow или Dot. Задайте требуемое значение Size. |
| Height | Стандартный размер | Текущая высота выносной линии. |
| Arrow Size | Угловой размер Размер от общей базы Линейный размер Линейный диаметральный размер Радиальный размер Радиальный диаметральный размер |
Текущий размер наконечника стрелки. Размер измеряется как расстояние от острия стрелки до концов ее боковых линий. |
| Arrow Length | Угловой размер Размер от общей базы Линейный размер Линейный диаметральный размер Радиальный размер Радиальный диаметральный размер |
Текущая длина стрелки. Обратите внимание: введенное в это поле значение применяется только в том случае, если для параметра Arrow Position (в области Properties ) задано значение Outside. |
Свойства |
||
| Text | Размер с выноской | Введите требуемый текст. |
| Layer | Все | Слой, которому в данный момент назначен размер. Выберите требуемый слой в раскрывающемся списке. Размеры можно назначать любому доступному слою. |
| Text Position | Все, кроме обозначения центра и стандартного размера | Текущее положение текста размера. В соответствующем раскрывающемся списке выберите один из следующих вариантов (набор доступных вариантов зависит от типа размерного объекта):
|
| Arrow Position | Угловой размер Размер от общей базы Линейный размер Линейный диаметральный размер Радиальный размер Радиальный диаметральный размер |
Текущее положение стрелок размера. Доступны следующие варианты:
|
| Angular Step | Радиальный диаметральный размер | Текущее значение углового шага размера. Это шаг поворота, используемый при размещении части размера со стрелкой. При перемещении стрелки вдоль окружности или дуги во время размещения размера количество и положение возможных точек привязки размера определяются этим значением углового шага. |
| Text Height | Все, кроме обозначения центра | Текущая высота символов текста размера. Ширина символов, используемая при отображении или печати текста, автоматически определяется пропорционально этой высоте. Минимальная высота 36mil (0.9mm) обеспечивает разборчивость текста при выводе на фотоплоттер. |
| Rotation | Обозначение центра Линейный размер Линейный диаметральный размер Ординатный размер |
Угол ориентации размера, измеряемый в градусах против часовой стрелки от горизонтали. |
| Size | Обозначение центра | Текущая длина линий перекрестия обозначения центра (или диаметр охватывающей окружности). |
| Font Type | Все, кроме обозначения центра |
|
Единицы измерения |
||
| Primary Units | Угловой размер Размер от базы Линейный размер Линейный диаметральный размер Ординатный размер Радиальный размер Радиальный диаметральный размер |
Текущая единица измерения, выбранная для расчета и отображения значения размера.
|
| Value Precision | Угловой размер Размер от базы Линейный размер Линейный диаметральный размер Ординатный размер Радиальный размер Радиальный диаметральный размер |
Текущее количество знаков после десятичного разделителя, с которым отображается значение размера. |
Значение |
||
| Format | Все, кроме обозначений центра и выносок |
Текущий формат размерного текста. При необходимости измените формат с помощью соответствующего раскрывающегося списка. Доступные варианты зависят от выбранного Unit и отображаются с учетом фактического значения текущего размера. В общем случае доступны следующие варианты (их набор зависит от типа размерного объекта):
|
| Prefix | Угловой размер Размер от базы Линейный размер Линейный диаметральный размер Ординатный размер Радиальный размер Радиальный диаметральный размер |
Префикс значения размера. Для линейного диаметрального или радиального диаметрального размера в этом поле задан фиксированный символ ø. |
| Suffix | Угловой размер Размер от базы Линейный размер Линейный диаметральный размер Ординатный размер Радиальный размер Радиальный диаметральный размер |
Суффикс значения размера. |
| Sample | Все, кроме обозначений центра и выносок |
В этом поле показан образец размерного текста с учетом заданного Format и указанных Prefix и/или Suffix. |
| Start point (X/Y) | Стандартный размер | Координаты начальной точки размера по X (первое значение) и Y (второе значение). |
| End point (X/Y) | Стандартный размер | Координаты конечной точки размера по X (первое значение) и Y (второе значение). |
Преобразование размеров в примитивы
Размеры — это групповые объекты проекта, то есть они состоят из одного или нескольких текстовых объектов и сегментов дорожек. Размер можно преобразовать в составляющие его примитивы с помощью команды Tools » Convert » Explode Dimension to Free Primitives.


