Создание связности цепей в ваших схемах

Altium Training

Altium Essentials: Creating Hierarchy

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Краткий обзор

В этой статье объясняется, как формируются электрические связи на принципиальных схемах в Altium Designer: как физические — с помощью проводов, так и логические — с помощью меток цепей и других идентификаторов цепей. Вы также узнаете, как связи могут распространяться между листами схемы в зависимости от структуры проекта и как встроенные инструменты, например Connectivity Insight, помогают просматривать, отслеживать и исследовать связи между цепями во всём проекте. Кроме того, в статье представлен практический обзор объектов схемы, используемых для задания связей, и приведены важные пояснения о том, как имена и область действия влияют на правильность соединений. Если вы хотите лучше разобраться в создании и проверке связей на схемах, эта статья станет отличной отправной точкой. Читайте дальше, чтобы увереннее работать над своими проектами.

- Узнайте, чем физические связи отличаются от логических и в каких случаях каждый из этих подходов полезен при работе со схемой.
- Познакомьтесь с объектами схемы, которые формируют связи: проводами, метками цепей, портами, портами питания, шинами и входами листов.
- Узнайте, как Altium Designer помогает проверять соединения и переходить между ними с помощью Connectivity Insight и связанных инструментов выделения и подсветки.
Узнайте больше с ИИ:

Именно компоненты и соединения между ними образуют вашу уникальную электронную схему. На принципиальной схеме вы создаете логическое представление устройства, соединяя выводы компонентов; при проектировании печатной платы вы размещаете физические компоненты и создаете те же соединения с помощью трассировки.

Если вы изучаете принципы организации проекта и создания соединений, вам могут быть полезны следующие страницы.

► Подробнее о проверке проекта

► Подробнее о многолистовых и иерархических проектах

► Подробнее о создании многоканального проекта

► Подробнее об объединении нескольких цепей в шины и сигнальные жгуты

► Подробнее о синхронизации проекта

Физические и логические соединения

На принципиальной схеме соединение можно создать, проведя проводник от одного компонента к другому. Такое соединение называется физическим.

Также можно соединить один вывод с другим, разместив на каждом из них короткий проводник и метку цепи. Программа распознает эти два участка цепи и объединит их в одну цепь. Такой тип соединения называется логическим.

Физические соединения позволяют проследить каждый проводник при изучении схемы, однако большое количество проводников может сделать ее перегруженной и трудночитаемой. Метки цепей, напротив, сокращают количество проводников, но пользователю приходится просматривать весь лист, чтобы найти все возможные соединения. Как разработчик, вы можете выбрать наиболее подходящий для вашего проекта способ соединения, в том числе сочетать оба подхода.

Animated image showing the difference between physical connectivity and logical connectivity

Размещайте проводники для создания физических соединений или используйте метки цепей для создания логических соединений.

Помимо создания логических соединений within листа схемы, существуют объекты для создания логических соединений between листами схемы. Способ создания таких соединений зависит от структуры схемы: плоской или иерархической. Подробнее об этом ниже.

Для соединения цепей между листами можно использовать различные идентификаторы цепей.
Для соединения цепей между листами можно использовать различные идентификаторы цепей.

Connectivity Insight

Функция Connectivity Insight в Altium Designer (входящая в состав Design Insight) позволяет мгновенно просматривать взаимосвязи соединений в проекте. Информация представлена в виде дерева документов с возможностью предварительного просмотра схем. Выбираемые элементы обеспечивают быструю и наглядную навигацию по структуре соединений проекта.

При настройках по умолчанию функция Connectivity Insight отображает:

  • Информацию о соединениях соответствующей цепи при наведении курсора на объект соединения схемы (проводник, порт и т. п.).
  • Карту соединений в виде дерева при применении Alt+Double-click к объекту.

Эти возможности дополняет функция, доступная при наведении курсора на объект сигнальной цепи и последующем нажатии Ctrl+Alt. При этом открывается дерево с выбираемыми элементами. Щелкните нужный лист в дереве, чтобы быстро перейти к этому документу. 

Эту функцию можно включить или отключить на странице System - Design Insight диалогового окна Preferences , установив или сняв флажок Mouse Hover для пункта Document Tree .

Соединения цепи по всему проекту также можно подсветить на всех схемах, удерживая клавишу Alt при выборе цепи щелчком по проводнику (Alt+Click).
Чтобы выбрать все электрически соединенные объекты для заданной точки схемы, можно воспользоваться командой Edit » Select » Connection из главного меню или командой Select Connection на Active Bar. Щелкните объект, электрически соединенные с которым объекты требуется выбрать. Будут выбраны все объекты, электрически соединенные с ним, а все остальные объекты на листе будут приглушены с помощью фильтрации.

Объекты для создания соединений

Редактор схем содержит следующие объекты для создания соединений. Общее название этих объектов — net identifiers.

Идентификатор цепи Назначение
Шина Используется для объединения набора цепей, например Data[0..7]. Цепи должны иметь последовательные имена, соответствующие определенному шаблону (например, Data0, Data1, ... Data7). Эти имена определяют имя шины, например Data[0..7].
Вход в шину Графический элемент, позволяющий вывести две разные цепи с противоположных сторон линии шины, не создавая короткого замыкания между ними. В остальных случаях не требуется.
Межлистовой соединитель Используется для соединения цепи одного листа схемы с другим листом (но не в пределах одного листа). Поддерживает только горизонтальные соединения (плоские проекты). По сравнению с портами межлистовые соединители обладают ограниченными возможностями.
Метка цепи Идентификатор цепи, используемый для создания соединений с другими метками цепей с тем же именем на том же листе схемы. Имя цепи автоматически задается меткой цепи. Метки цепей можно размещать на выводах компонентов, проводниках и шинах. Обратите внимание: метки цепей не создают соединений между листами, если только в параметрах проекта для Net Identifier Scope не задано значение Global.
Вывод Выводы размещаются в редакторе символов схемы и представляют физические выводы компонента. Только один конец вывода является электрически активным; иногда его называют «горячим» концом вывода.
Порт Используется для соединения цепи одного листа схемы с другим листом. Соединения могут быть вертикальными в иерархическом проекте или горизонтальными в плоском проекте (вертикальная и горизонтальная структуры описаны ниже). Имена портов используются для именования цепей, если параметр Allow Ports to Name Nets включен на вкладке Параметры диалогового окна Project Options . В этом случае порты также создают соединения в пределах одного листа схемы, но не соединяются с метками цепей с тем же именем (подробнее).
Порт питания Создает соединение со всеми остальными портами питания с тем же именем во всем проекте схемы независимо от его структуры. Имя цепи автоматически задается портом питания. При необходимости область действия этой цепи можно ограничить определенным листом схемы (подробнее).
Вход листа Размещается внутри символа листа для создания соединения с одноименным портом на дочернем листе этого символа. Имена входов листа используются в качестве имен цепей, если параметр Allow Sheet Entries to Name Nets включен на вкладке Options диалогового окна Project Options .
Сигнальный жгут Используется для объединения любых сочетаний цепей, шин и сигнальных жгутов нижнего уровня.
Проводник Примитив электрической схемы в виде ломаной линии, используемый для создания электрических соединений между точками на схеме. Аналог физического провода.
  • Разные типы идентификаторов цепей с одинаковым именем не соединяются друг с другом автоматически. Это зависит от настройки параметров именования цепей. Эти параметры рассматриваются ниже.

  • Обратите внимание: имена цепей, заданные идентификаторами цепей, не зависят от регистра. Например, если двум проводам присвоены метки цепей abc и ABC, они будут отнесены к одной цепи abc (если это допускается настройкой проекта Net Identifier Scope).

  • Не используйте апостроф (') в конце имени цепи, поскольку этот символ является оператором в языке запросов и после него ожидается другой параметр, отсутствие которого может привести к ошибке.

Как структура проекта влияет на электрические связи

Related page: Многолистовые и иерархические проекты

Если схема не помещается на одном листе, ее можно распределить по нескольким листам. Существуют две разные модели организации многолистовой схемы и создания связей в ней: плоский проект, который можно представить как один большой лист схемы, разделенный на несколько меньших листов, и иерархический проект, в котором листы связаны в многоуровневую структуру с родительскими и дочерними листами.

Многолистовые проекты создаются путем размещения символа листа на родительском листе. Этот символ представляет дочерний лист и ссылается на него, как показано на изображении ниже.

Символы листов представляют листы нижнего уровня и ссылаются на них. В плоском проекте такая структура может иметь глубину только в один уровень; в иерархическом проекте глубина не ограничена.
Символы листов представляют листы нижнего уровня и ссылаются на них. В плоском проекте такая структура может иметь глубину только в один уровень; в иерархическом проекте глубина не ограничена.

Что же определяет, является проект плоским или иерархическим? Это задается настройкой области действия идентификаторов цепей, которая определяет способ создания связей между листами. Эта настройка находится на вкладке Параметры диалогового окна Project Options .

Важно помнить, что иерархический проект может содержать только один лист верхнего уровня. На все остальные исходные документы должны ссылаться символы листов. При проверке проекта для выявления несоблюдения этого условия можно использовать проверку нарушения «Несколько документов верхнего уровня». Кроме того, символ листа не должен ссылаться на лист, на котором он расположен, или на любой лист выше по иерархии, поскольку это создаст неразрешимый цикл в структуре.

Плоский проект

Related page: Многолистовые и иерархические проекты

Проект называется плоским, если связи создаются непосредственно между листами. Они не проходят через символы листов на родительском листе. В плоском проекте символы листов лишь представляют дочерние листы и ссылаются на них. Все листы проекта отображаются на одном уровне на панели Projects, поскольку иерархия отсутствует. На обоих изображениях ниже показан плоский проект.

Плоские проекты проще создавать. Плоский проект может включать лист верхнего уровня с символом листа для каждого дочернего листа, но это необязательно, поскольку лист верхнего уровня не используется для создания связей между листами. Для небольшого проекта, содержащего всего два или три листа схемы, можно решить, что лист верхнего уровня не дает никаких преимуществ. При увеличении числа листов лист верхнего уровня помогает читателю понять функциональность схемы по тому, как на нем расположены логические блоки (символы листов).

Один и тот же проект без листа верхнего уровня (слева) и с листом верхнего уровня (справа) — оба варианта являются примерами плоского проекта.  Projects panel showing a simple project that is a flat design, with a top sheet
Один и тот же проект без листа верхнего уровня (слева) и с листом верхнего уровня (справа) — оба варианта являются примерами плоского проекта.

В плоском проекте связи между листами можно создавать с помощью портов, межлистовых соединителей, портов питания и меток цепей, как показано в увеличенном фрагменте на изображении выше. Рекомендуется использовать метки цепей within каждого листа, а порты — для соединения between листами. Порты предоставляют больше возможностей, чем межлистовые соединители, включая возможность добавления перекрестных ссылок портов, благодаря которым к каждому порту добавляется SheetName[GridReference], указывающая на соответствующий порт на другом листе, как показано на изображении ниже.

Количество листов в плоском проекте не ограничено.

Рядом с каждым портом добавлены перекрестные ссылки, указывающие целевой лист и координаты соответствующего порта в сетке листа.
Рядом с каждым портом добавлены перекрестные ссылки, указывающие целевой лист и координаты соответствующего порта в сетке листа.

Проект является плоским, когда связи создаются непосредственно между листами. Такой способ формирования связей задается настройкой области действия идентификаторов цепей со значением Automatic, Flat или Global. Обратите внимание: если для создания связей между листами используется сочетание портов и меток цепей, вариант Automatic использовать нельзя. В этом случае необходимо вручную установить для Net Identifier Scope значение Global.

Иерархический проект

Main page: Многолистовые и иерархические проекты

Проект называется иерархическим, если связи между листами проходят от символа листа вниз к дочернему листу, на который ссылается этот символ. На уровне цепей связь создается между входом листа в этом символе и портом на дочернем листе, имя которого совпадает с именем входа листа. Такой тип связей также называют вертикальным, поскольку связи между листами создаются только вверх и вниз между родительским и дочерним листами.

В иерархическом проекте связь на уровне цепей проходит от входа листа на родительском листе вниз к соответствующему порту на дочернем листе.
В иерархическом проекте связь на уровне цепей проходит от входа листа на родительском листе вниз к соответствующему порту на дочернем листе.

У иерархических проектов есть два основных преимущества.

  1. Первое — возможность показать читателю функциональность проекта через структуру листов схемы и их представление в виде логических блоков (символов листов). Схема верхнего уровня представляет проект как набор функциональных блоков высокого уровня, расположение которых отражает их место в традиционном потоке сигналов общей схемы: слева направо, от входа к выходу. При необходимости эти блоки можно дополнительно разделить на более мелкие. Это позволяет сделать схемы самого нижнего уровня, на которых размещены компоненты, относительно простыми и с небольшим количеством компонентов. Поскольку каждый лист относительно прост, его физический размер можно оставить небольшим, что дает значительное преимущество при печати схемы.
  2. Еще одно важное преимущество заключается в том, что в иерархическом проекте обычно гораздо проще проследить прохождение сигнала: достаточно сопоставить вход листа на родительском листе с портом на дочернем листе, а затем проследить сигнал по проводникам внутри каждого листа.

Создание иерархического проекта требует дополнительной работы. Для символов листов необходимо создать входы листов, а на верхнем листе — проложить проводники для передачи сигналов от одного символа листа к другому. В программе есть инструмент для синхронизации входов листов с портами дочерних листов (Design » Synchronize Sheet Entries and Ports для всех символов листов; для отдельного символа листа щелкните по нему правой кнопкой мыши и выберите Sheet Symbol Actions » Synchronize Sheet Entries and Ports). Также предусмотрены инструменты для разделения крупного проекта на небольшие части (Edit » Refactor » Move Selected Subcircuit to Different Sheet). Подробнее об этих инструментах реструктуризации и рефакторинга см. на странице  Рефакторинг проекта.

Иерархический проект может иметь любую глубину вложенности и включать любое количество листов схемы.

Проект является иерархическим, если связи между листами устанавливаются только между входами листов на родительском листе и соответствующими портами на дочернем листе. Такой способ соединения задается настройкой области действия идентификаторов цепей: Automatic, Hierarchical или Strict Hierarchical.

Многоканальное проектирование

Main article: Создание многоканального проекта

Электронные проекты нередко содержат повторяющиеся участки схемы. Это может быть стереоусилитель или 64-канальный микшерный пульт. Такие проекты полностью поддерживаются набором функций multi-channel design. В многоканальном проекте повторяющуюся схему создают один раз, а затем указывают программе повторить ее: либо размещают несколько символов листов, ссылающихся на одну и ту же дочернюю схему, либо настраивают один символ листа так, чтобы указанная в нем дочерняя схема повторялась нужное количество раз. Скомпилированный проект разворачивается в памяти компьютера, при этом все компоненты и связи повторяются нужное количество раз в соответствии с заданной пользователем схемой именования.

Слева показаны четыре символа листов, ссылающихся на один и тот же дочерний лист (PortIO.SchDoc). Справа лист InputChannel.SchDoc повторяется восемь раз с помощью ключевого слова Repeat .  An example of a multi-channel design where the child schematic is repeated by including the Repeat keword in its Sheet Symbol
Слева показаны четыре символа листов, ссылающихся на один и тот же дочерний лист (PortIO.SchDoc). Справа лист InputChannel.SchDoc повторяется восемь раз с помощью ключевого слова Repeat .

Создаваемый логический проект никогда не преобразуется в плоскую структуру: он всегда остается многоканальной схемой. При передаче проекта в редактор печатных плат физические компоненты и цепи дублируются нужное количество раз, при этом сохраняется полный доступ к инструментам перекрестного перехода и перекрестного выделения, описанным в разделе Работа со схемой и платой. В редакторе печатных плат также есть инструмент, позволяющий скопировать размещение компонентов и трассировку одного канала на все остальные каналы, а затем легко перемещать и поворачивать каждый канал целиком. Подробнее о многоканальном проектировании см. в документе Многоканальное проектирование. 

Многоканальный проект должен быть иерархическим, поскольку программа использует эту структурную модель для создания экземпляров каналов в памяти.

Для многоканального проекта задайте для Net Identifier Scope значение Automatic, Hierarchical или Strict Hierarchical.

При дублировании компонентов и цепей программа использует схему именования, выбранную на вкладке Multi-Channel диалогового окна Project Options .

Настройка области действия идентификаторов цепей

Dialog page: Параметры проекта

Программа использует текущее значение Net Identifier Scope, чтобы определить, как создаются связи между листами схемы. Параметр Net Identifier Scope настраивается на вкладке Параметры диалогового окна Project Options (Project » Project Options).

Выберите режим Net Identifier Scope в соответствии со структурой проекта.
Выберите режим Net Identifier Scope в соответствии со структурой проекта.

Принцип работы режимов Global, Flat и Hierarchical показан на изображениях ниже.

Простые примеры создания связей для каждого из трех основных режимов: глобального, плоского и иерархического. Configuring the Net Identifier Scope, example of what connects with the Flat option Configuring the Net Identifier Scope, example of what connects with the Hierarchical option
Простые примеры создания связей для каждого из трех основных режимов: глобального, плоского и иерархического.

Помимо трех перечисленных выше режимов, также доступен вариант Automatic. Как правило, для Net Identifier Scope лучше оставить значение Automatic. Программа выберет наиболее подходящий из трех режимов с учетом структуры листов и наличия или отсутствия портов и входов листов.

При выборе значения Automatic программа автоматически определяет, какой из трех основных режимов идентификаторов цепей использовать, на основании следующих критериев:

  • Если на верхнем листе есть входы листов, используется Hierarchical.
  • Если входов листов нет, но есть порты, используется Flat.
  • Если нет ни входов листов, ни портов, используется Global.

Режим Strict Hierarchical ограничивает область действия всех портов питания отдельными листами. В этом режиме все цепи питания и земли необходимо подводить к каждому дочернему листу с помощью портов и входов листов. Это можно сделать и для отдельных листов без использования режима Strict Hierarchical: достаточно разместить входы листов и порты для тех цепей питания, область действия которых требуется ограничить. Подробнее см. в разделе Цепи питания.

Как присваиваются имена цепям

Каждый раз, прокладывая проводник между выводами компонентов, вы создаете электрическое соединение. Каждой цепи в проекте присваивается имя. Если вы не разместили идентификатор цепи, который можно использовать для ее именования, программа присвоит цепи имя на основе одного из ее выводов, например, NetR7_1, как показано на изображении ниже. Если впоследствии позиционное обозначение компонента изменится, автоматически сформированное имя цепи тоже изменится. Эти изменения необходимо передавать между схемой и печатной платой, чтобы поддерживать их согласованность.

Цепям без идентификатора присваивается автоматически сформированное имя на основе одного из выводов цепи.
Цепям без идентификатора присваивается автоматически сформированное имя на основе одного из выводов цепи.

Метки цепей всегда задают имена цепям, к которым они подключены. По умолчанию точка подключения находится в левом нижнем углу метки цепи и при перемещении обозначается небольшим крестиком.

Другие идентификаторы цепей задают имя цепи, если соответствующая опция включена в разделе Netlist Options на вкладке Параметры диалогового окна Project Options.

Идентификаторы цепей разных типов не соединяются друг с другом автоматически. Например, порт с именем Inta не будет соединен с меткой цепи с именем Inta, даже если в диалоговом окне Project Options включена опция Allow Ports to Name Nets. Их необходимо соединить проводником. Пример показан на изображениях ниже.

  

Несколько идентификаторов на одной цепи

В пределах одного листа схемы нельзя размещать на одной цепи несколько меток цепи с разными именами. Такая ситуация будет обнаружена при проверке и отмечена как ошибка. Однако допускается использовать несколько идентификаторов одной цепи на разных листах, на которых она присутствует.

Эта возможность позволяет:

  • Изменять имя цепи на разных уровнях иерархии, чтобы точнее отразить ее назначение на соответствующем листе.
  • Повторно использовать дочерний лист схемы без необходимости переименовывать на нем цепи.

По умолчанию предполагается, что несколько идентификаторов цепи не допускаются. Если они будут обнаружены при проверке, появится предупреждение. Если они необходимы в вашем проекте, потребуется выполнить одно из следующих действий:

  • Изменить настройку проверки Nets with multiple names на вкладке Error Reporting диалогового окна Project Options  или
  • Подавить отдельные предупреждения, разместив маркер No ERC на каждом из них, а затем выбрать Specific Violations в режиме No ERC панели Properties , чтобы указать, какие ошибки следует подавлять. Обратите внимание: маркеры No ERC можно размещать, щелкнув правой кнопкой мыши по предупреждению в списке на панели Messages или по цветной волнистой линии, отмечающей нарушение на листе схемы. Форму и цвет маркера No ERC можно изменить на панели Properties при выбранном маркере.

Параметры управления именованием цепей

Dialog page: Параметры проекта

В конечном счете каждая цепь на печатной плате может иметь только одно имя (одна цепь платы не может иметь два имени, если только вы не соединяете две цепи намеренно с помощью Net Tie). Программа автоматически выбирает для цепей с несколькими именами одно имя в проекте, однако оно может оказаться не тем, которое вы ожидаете. Управлять выбором имени можно с помощью ряда параметров в разделе Netlist Options на вкладке Options диалогового окна Project Options. Подробное описание каждого параметра приведено на странице диалогового окна Параметры проекта.

Рекомендуется включить параметры Allow Ports to Name Nets и Higher Level Names Take Priority. В сочетании с продуманным размещением меток на значимых цепях каждого листа это позволит присвоить имена всем важным цепям, в том числе проходящим через несколько листов, и использовать на схемах нижнего уровня имена, заданные на схемах верхнего уровня.

Если включено несколько параметров именования цепей, приоритет выбора имени следующий:

  • Если параметр Power Port Names Take Priority выключен: метки цепей, порты питания, порты, выводы.
  • Если параметр Power Port Names Take Priority включен: порты питания, метки цепей, порты, выводы.

Две отдельные цепи с одинаковым именем

Еще одна возможная проблема именования возникает, когда на разных листах схемы одно и то же имя используется для обозначения разных цепей. Это будет обнаружено при проверке Duplicate Nets. Переносить проект на печатную плату при наличии такой ситуации нельзя: при переносе эти две отдельные цепи будут объединены в одну цепь платы.

Эту ситуацию можно устранить, включив параметр Append Sheet Numbers to Local Nets на вкладке Параметры диалогового окна Project Options . При включенном параметре к именам всех локальных цепей добавляется значение параметра SheetNumber, как показано на изображениях ниже.

Example of how a duplicated net name, Input, appears on the schematic Editor tab  Example of how a duplicated net name, Input, appears on the schematic compiled tab
Поскольку метка цепи Input используется на нескольких листах, включен параметр Append Sheet Numbers to Local Net, позволяющий избежать ошибки дублирования цепей.
Результат можно увидеть, перейдя на вкладку скомпилированного листа (изображение справа): обратите внимание, что к имени цепи добавлено _2.

Параметр Append Sheet Numbers to Local Nets работает только в том случае, если каждому листу схемы присвоено уникальное значение SheetNumber. Параметр SheetNumber задается для каждого листа схемы на вкладке Parameters в режиме Document Options панели Properties. Вместо ручного назначения уникального номера каждому листу можно выполнить команду Tools » Annotation » Number Schematic Sheets, которая открывает диалоговое окно Нумерация листов проекта. В этом окне можно назначить всем листам уникальные значения SheetNumber (простой порядковый номер листа) и DocumentNumber (обычно используется для нумерации документов по правилам компании).

Намеренное соединение двух цепей

Иногда требуется намеренно соединить две разные цепи. Это не просто вопрос именования: речь идет о непосредственном соединении двух цепей в соответствии с требованиями проекта. Например, может потребоваться соединить аналоговую и цифровую землю в определенной точке.

Для этого две цепи соединяют через компонент Net Tie. Компонент Net Tie представляет собой контролируемое короткое замыкание, позволяющее выбрать место на плате, где цепи будут соединены. На схеме компонент Net Tie имеет два или более выводов, каждый из которых подключен к одной из соединяемых цепей. Свойству Component Type компонента присваивается значение Net Tie, как показано ниже.

Компонент Net Tie используется на схеме для подключения одного тактового сигнала к двум тактовым входам FPGA.
Компонент Net Tie используется на схеме для подключения одного тактового сигнала к двум тактовым входам FPGA.

Обратите внимание: выводы not соединены друг с другом проводником на схеме (на схеме они не замкнуты), но are соединены внутри посадочного места на печатной плате.

На печатной плате посадочное место имеет столько же контактных площадок, сколько выводов у условного графического обозначения на схеме, и эти площадки соединены медью. В примере на изображении ниже две квадратные контактные площадки соединены отрезком дорожки. Это соединение создается внутри посадочного места в редакторе библиотеки печатных плат. Свойству Component Type компонента на плате также присваивается значение Net Tie.

Программа автоматически игнорирует короткие замыкания внутри компонента Net Tie на печатной плате, поэтому ошибка DRC не возникает.

Тот же компонент Net Tie на печатной плате; контактные площадки (выделены) в посадочном месте Net Tie замкнуты дорожкой.
Тот же компонент Net Tie на печатной плате; контактные площадки (выделены) в посадочном месте Net Tie замкнуты дорожкой.

Когда компонент Net Tie используется для соединения двух разных цепей, каждая цепь сохраняет собственное имя как на схеме, так и на печатной плате.

  • При создании условного обозначения и посадочного места Net Tie доступны два варианта типа компонента Net Tie: один включает Net Tie в спецификацию BOM (например, если Net Tie представляет собой замыкающую перемычку), другой исключает его из BOM (если Net Tie — это просто участок меди). Выберите нужный тип компонента.
  • При трассировке Net Tie на плате для прокладки дорожки away от контактной площадки Net Tie можно использовать любой режим трассировки. Для прокладки дорожки into к контактной площадке Net Tie необходимо переключиться в режим Ignore Obstacle.

► Демонстрация трассировки компонента Net Tie

Цепи питания

По умолчанию настройки предполагают, что цепи питания являются глобальными, то есть доступны на каждом листе схемы. Для подключения к цепи питания разместите порт питания с нужным именем цепи, затем соедините компоненты с этим портом питания проводами. При компиляции проекта все выводы, подключенные к каждой цепи питания, будут объединены в эту цепь на всех листах проекта.

Цепь, к которой подключается порт питания, определяется именем цепи, а не стилем его символа: все три выделенных порта питания подключены к цепи питания GND.
Цепь, к которой подключается порт питания, определяется именем цепи, а не стилем его символа: все три выделенных порта питания подключены к цепи питания GND.

Локализация цепей питания — глобально

Как упоминалось ранее, в иерархическом проекте цепи питания можно сделать локальными для каждого листа схемы, выбрав вариант Strict Hierarchical для параметра Область действия идентификаторов цепей. При таком подходе все цепи питания на каждом листе становятся локальными, поэтому их необходимо соединять между собой вручную, так же как сигнальные цепи. Если они не соединены, для каждой цепи питания на каждом листе схемы будет выдана ошибка Duplicate Net Name. Также потребуется изменить настройки матрицы соединений, чтобы разрешить подключение портов к портам питания.

Если для Net Identifier Scope задано значение Strict Hierarchical, 
Если для Net Identifier Scope задано значение Strict Hierarchical, каждую цепь питания необходимо вручную подключить ко всем листам, на которых она используется.

Соединение локализованной цепи питания между листами

Локализованная цепь питания в иерархическом проекте подключается так же, как любая другая цепь: от порта на дочернем листе к входу листа в символе листа на родительском листе. Обратите внимание: для цепей питания этот способ поддерживает только отдельные цепи, но не цепи питания, объединенные в шину ().

Если вы создаете многоканальный проект и хотите подать на каждый канал отдельную, уникальную цепь питания с помощью выражения Repeat (как показано ниже), это возможно, поскольку через каждую пару «вход листа — порт» в канал передается только одна цепь. Пока через каждую такую пару от родительского листа к дочернему передается отдельная цепь питания, список соединений будет сформирован корректно.

Локализованные цепи питания можно распределять по каналам многоканального проекта, если они передаются между уровнями иерархии как отдельные цепи, а не как шина.Локализованные цепи питания можно распределять по каналам многоканального проекта, если они передаются между уровнями иерархии как отдельные цепи, а не как шина.

Если вы предпочитаете объединить несколько цепей питания в шину и передавать ее через иерархию проекта, эти цепи должны быть обычными цепями: подключать их с помощью портов питания нельзя.

Локализация цепи питания — по отдельности

Конкретную цепь питания в иерархическом проекте (то есть в проекте, где для Net Identifier Scope задано значение Hierarchical, или в проекте, содержащем входы листов на верхнем листе, в котором для Net Identifier Scope задано значение Automatic — подробнее см. Настройка области действия идентификаторов цепей) можно также локализовать на определенном листе, соединив порт питания с портом на этом листе схемы.

Здесь цепь питания 3V3 локализована только для этого листа, поэтому на родительском листе ее также необходимо подключить вручную. Цепи GND и 5V остаются глобальными цепями питания.
Здесь цепь питания 3V3 локализована только для этого листа, поэтому на родительском листе ее также необходимо подключить вручную. Цепи GND и 5V остаются глобальными цепями питания.

Цепи питания и скрытые выводы питания

В более ранних версиях программного обеспечения Altium для проектирования были предусмотрены функции и настройки для работы со скрытыми выводами компонентов схемы. Эта возможность была полезна, когда в проекте имелись одна цепь питания и одна цепь земли: скрытие выводов питания позволяло автоматически подключать все выводы питания всех устройств к соответствующим цепям. Чаще всего этот подход применялся для многосекционных компонентов, избавляя от необходимости отображать их выводы питания на схеме.  

Сегодня электронные проекты обычно содержат несколько цепей питания и земли. Эти цепи уже недостаточно просто подвести к соответствующим выводам питания: организация питания стала важнейшим условием успешного проектирования платы. 

По мере изменения подходов к проектированию сетей распределения питания потребность в скрытии выводов компонентов и их автоматическом подключении средствами ПО снизилась настолько, что большинство разработчиков выступают против такой практики. Поэтому программное обеспечение больше не поддерживает назначение вывода скрытым с предварительным указанием имени его цепи. При открытии старых проектов, использующих этот подход, в последней версии программного обеспечения Altium список соединений по-прежнему будет формироваться корректно.

Динамическая компиляция

Related page: Проверка проекта

Соединяя два вывода проводом, вы обозначаете свой замысел, а не создаете фактическую цепь. Цепь создается только при компиляции проекта. Помимо сведений о компонентах и их соединениях, при компиляции также извлекается подробная информация о параметрах компонентов и проекта. Скомпилированная модель проекта называется единой моделью данных (Unified Data Model).

Модель данных проекта пошагово обновляется после каждого действия пользователя благодаря динамической компиляции — так формируется динамическая модель данных (Dynamic Data Model, DDM). Компилировать проект вручную не требуется: все выполняется автоматически. Благодаря динамической компиляции модель соединений проекта также пошагово обновляется после каждого действия пользователя. Для проекта автоматическая компиляция выполняет три функции:

  1. Создает экземпляры элементов иерархии проекта.
  2. Устанавливает соединения цепей между всеми листами проекта.
  3. Формирует внутреннюю динамическую модель данных (DDM) проекта.

Это гарантирует, что любые изменения проекта немедленно отражаются в Navigator и на панели «Проекты» .

Чтобы проверить проект на логические и электрические ошибки, а также ошибки оформления с учетом DDM и настроек компилятора, необходимо выполнить проверку проекта. Для этого выберите команду Project » Validate Project  в главном меню либо щелкните правой кнопкой мыши запись проекта на панели «Проекты» и выберите команду Validate Project в контекстном меню.  

Все нарушения, обнаруженные компилятором, будут перечислены в виде предупреждений и/или ошибок на панели Messages. При проверке исходных документов на нарушения компилятор использует параметры, заданные на вкладках Сообщения об ошибках и  Матрица соединений диалогового окна Project Options (в зависимости от типа проекта).

Динамическая модель данных

Основополагающим элементом программного обеспечения является единая модель данных (Unified Data Model, UDM). В ходе автоматической динамической компиляции создается единая целостная модель, занимающая центральное место в процессе проектирования. Различные редакторы и службы программного обеспечения, в том числе редакторы схем и печатных плат, могут получать доступ к данным модели и изменять их. Вместо отдельных хранилищ данных для разных областей проектирования используется UDM, структура которой позволяет хранить всю информацию обо всех аспектах проекта, включая компоненты и связи между ними. Эта единая целостная модель, лежащая в основе процесса проектирования, создается в результате динамической компиляции проекта. Это означает, что единая модель данных доступна с момента открытия проекта и не требует дополнительной ручной компиляции — это по-настоящему динамическая модель данных (Dynamic Data Model, DDM). Поэтому модель поэтапно обновляется (компилируется) после каждой операции пользователя. Вы можете свободно размещать и соединять объекты, менять их расположение и имена, добавлять и удалять содержимое схемы.

Процесс компиляции проекта печатной платы управляется программным кодом, работающим вне редакторов схем и печатных плат. У этого подхода есть ряд преимуществ, главное из которых заключается в том, что единая модель данных проекта существует независимо от отдельных редакторов схем и печатных плат. UDM содержит подробные описания каждого компонента проекта и связей между компонентами.

Программное обеспечение управляет данными о соединениях между схемой и печатной платой.
Программное обеспечение управляет данными о соединениях между схемой и печатной платой.

Поскольку компиляция выполняется динамически, при работе со следующими панелями и выполнении следующих операций дополнительные действия по ручной компиляции проекта не требуются:

  • Navigator и панель Projects
  • ActiveBOM
  • Выполнение ECO
  • Перекрестное зондирование
  • Цветовое выделение цепей
  • Перестановка выводов
  • Перекрестные ссылки компонентов

Чтобы обновить представление проекта и панель Navigator после динамической компиляции, воспользуйтесь командой Refresh из контекстного меню панелей Projects и Navigator. Чтобы представление проекта и панель Navigator обновлялись после динамической компиляции автоматически, включите параметр Schematic.DynamicCompiler.Navigator.Autorefresh в диалоговом окне Advanced Settings.

Разместите маску компиляции, чтобы hide участки проекта, которые еще не готовы к проверке ошибок или переносу в редактор печатных плат. Когда эти участки будут готовы, нажмите элемент управления, чтобы свернуть маску и включить открывшийся участок схемы в процесс компиляции и переноса проекта.

Маски компиляции относятся к классу объектов, называемых директивами проектирования. Используйте их для добавления на схему указаний, действующих на уровне проекта, например: принадлежность к классу цепей, место, где компилятор должен игнорировать определенное нарушение, группа цепей, образующих дифференциальные пары, и т. д. Наведите указатель на изображение, чтобы увидеть демонстрацию работы маски компиляции.

Как же взаимодействовать с единой моделью данных, например чтобы проследить цепь по всему проекту? Для этого используется панель Navigator.

Анализ соединений

Panel page: Панель Navigator

Если проект большой и занимает много листов, отслеживание и проверка соединений могут вызывать затруднения. Для упрощения этой задачи используйте панель Navigator. Она позволяет просматривать весь скомпилированный проект. 

Основной порядок работы с панелью:

  • Настройте параметры навигации: нажмите кнопку  Ellipsis button on the Navigator panel, click to configure the navigation preferences в верхней части панели, чтобы открыть диалоговое окно Preferences, и включите нужные Highlight Methods. Также можно щелкнуть правой кнопкой мыши по нужному объекту на панели и настроить навигацию с помощью команд меню, как показано на изображении ниже.
  • Задайте область навигации в разделе Documents for панели. Чтобы просматривать весь проект, выберите Flattened Hierarchy.
  • Щелкните компонент в разделе Instance списка, чтобы перейти к нему. Разверните компонент, чтобы найти нужный вывод или перейти к нему.
  • Щелкните цепь или шину в разделе Net /Bus, чтобы перейти к этой цепи или шине.
  • При щелчке удерживайте клавишу Alt, чтобы перейти к этому объекту одновременно на схеме и на печатной плате.

Щелкните компонент или цепь на панели Navigator, чтобы найти этот компонент или цепь и проследить соединения по всему проекту. Щелкните правой кнопкой мыши, чтобы открыть параметры отображения. Наведите указатель на изображение, чтобы увидеть одновременный переход к компоненту на схеме и на печатной плате (при щелчке на панели Navigator удерживайте Alt, чтобы также перейти к объекту на печатной плате).
Щелкните компонент или цепь на панели Navigator, чтобы найти этот компонент или цепь и проследить соединения по всему проекту. Щелкните правой кнопкой мыши, чтобы открыть параметры отображения. Наведите указатель на изображение, чтобы увидеть одновременный переход к компоненту на схеме и на печатной плате (при щелчке на панели Navigator удерживайте Alt, чтобы также перейти к объекту на печатной плате).

Навигация по компонентам на плате

Помимо поиска компонентов на схеме и печатной плате (при удержании Alt) с помощью панели Navigator, вы также можете переходить к выводам, компонентам, цепям, шинам и жгутам на печатной плате непосредственно со схемы.

Например, щелкая компонент для его поиска на схеме, вы можете одновременно найти тот же компонент на печатной плате.

Для этого:

  • Включите параметр Selecting в Highlight Methods, а также нужные параметры в разделе Cross Select Mode на странице System - Navigation диалогового окна Preferences.
  • Включите перекрестное выделение (Tools » Cross Select Mode) в редакторе схем и в редакторе печатных плат.

Эти параметры определяют поведение навигации и перекрестного выделения.
Эти параметры определяют поведение навигации и перекрестного выделения.

Теперь при выделении выводов, компонентов, цепей, шин и жгутов на схеме эти объекты также будут выделяться на печатной плате, как показано на изображении ниже.

При выделении компонентов и цепей на схеме эти объекты также выделяются на печатной плате. Перекрестное выделение работает и в обратном направлении — с печатной платы на схему.
При выделении компонентов и цепей на схеме эти объекты также выделяются на печатной плате. Перекрестное выделение работает и в обратном направлении — с печатной платы на схему.

Поиск компонентов и цепей в структуре проекта

Перемещайтесь по структуре на панели, чтобы найти нужный компонент или цепь, а затем дважды щелкните объект, чтобы отобразить его экземпляры в документах схем проекта. Используйте параметры на странице System - Navigation диалогового окна Preferences, чтобы задать поведение подсветки объектов (масштабирование, затемнение, выделение и т. д.).

Щелкните правой кнопкой мыши в рабочей области и выберите команду Clear Filter, чтобы снять подсветку и выделение объектов в редакторе схем или печатных плат.

Навигация по объектам проекта также доступна на панели Navigator, которая отображает подробную иерархическую структуру объектов проекта и связанных с ними данных. Настройки на странице System - Navigation определяют поведение подсветки объектов для обеих панелей: Project и Navigator.

Подсветка соединений

Режим навигации по соединениям позволяет отображать связи объекта, выбранного на панели Projects. Дважды щелкните запись, например цепь, в иерархическом списке объектов панели, чтобы подсветить ее соединения на схеме.

Функция предварительного просмотра включается с помощью параметра Connectivity Graph в разделе Highlight Methods на странице Система — Навигация диалогового окна Preferences. Установите также дополнительный флажок «Включить Power Parts», чтобы просматривать соединения объектов питания, связанных с выбранным объектом.

Глобальная подсветка цепей

Чтобы подсветить соединения цепи на всех схемах проекта, удерживайте клавишу Alt при выборе цепи щелчком по проводу (Alt+Click). Все вхождения цепи на схемах подсвечиваются, а остальные объекты затемняются. Таким образом, одним простым действием можно наглядно отобразить распространение сигнала или питания в проекте.

Подсветка цепи сбрасывается щелчком по свободному месту, а ее поведение определяется настройками Highlight Methods на странице Система — Навигация диалогового окна Preferences. Обратите внимание: снятие флажка Dimming отключает функцию подсветки цепей.

Перекрестное зондирование и перекрестное выделение

Помимо выделения объектов из одного редактора в другом (перекрестного выделения), Altium Designer также поддерживает перекрестное зондирование. У перекрестного зондирования есть два режима: непрерывный (с сохранением фокуса в исходном редакторе) и с переходом (с переключением в целевой редактор). Перекрестное зондирование также доступно из различных панелей и диалоговых окон, например из панели Messages и диалогового окна Engineering Change Order. Подробнее см. на странице Перекрестное зондирование и выделение.

Настройка цвета цепей

Main page: Назначение цвета цепям

Чтобы повысить читаемость схемы и упростить работу с цепями и трассами в редакторе печатных плат, можно назначить цвета проводам на схеме, а также цепям и трассам на плате.

Цвет подсветки цепи или шины в редакторе схем можно задать с помощью команд подменю View » Set Net Colors, как показано на изображении ниже. Эти цвета можно в любой момент передать в редактор печатных плат с помощью команды Update PCB.

В редакторе печатных плат цвет и видимость Connection Lines по умолчанию настраиваются в разделе System Colors панели Конфигурация отображения. Обратите внимание: этот цвет по умолчанию применяется при создании цепей (во время первоначального переноса проекта из схемы). При изменении этого параметра цвет существующих линий связи не изменится.

В редакторе печатных плат цвет, назначенный каждой цепи, отображается в режиме «Цепи» панели PCB. Обратите внимание на цвет фона флажка рядом с именем цепи, как показано в правом нижнем углу изображения ниже.

Цвет всегда применяется к неразведенным цепям (линиям связи). Чтобы отображать цвет разведенных цепей, установите флажок рядом с именем цепи на панели PCB и настройте параметры отображения на странице Переопределение цветов Board Insight диалогового окна Preferences. На изображении ниже для параметра «Базовый узор» переопределяющего цвета выбрано значение Solid, а для параметра «Поведение при уменьшении масштаба» — Override Color Dominates.

Цвета цепей, назначенные на схеме, передаются на плату командой «Обновить плату». Настройте функции переопределения цветов платы, чтобы управлять их отображением на плате.Цвета цепей, назначенные на схеме, передаются на плату командой «Обновить плату». Настройте функции переопределения цветов платы, чтобы управлять их отображением на плате.

Нажмите F5, чтобы включить или отключить функцию переопределения цветов цепей в редакторе схем или редакторе печатных плат. Также может потребоваться обновить экран (End).

Изменение цвета цепей на плате

Не всегда возможно назначить цвета проводам на схеме и передать их на плату. В этом случае цвет линий связи и трасс можно задать непосредственно в редакторе печатных плат. Чтобы изменить цвет цепи после переноса проекта, дважды щелкните имя цепи в режиме Nets панели PCB. Цвет отдельной цепи можно изменить в диалоговом окне Редактирование цепи.

Чтобы изменить цвет нескольких цепей, используйте режим Nets панели PCB:

  • Используйте стандартные способы множественного выделения Windows (Shift+click или Ctrl+click), чтобы выбрать несколько классов цепей или несколько отдельных цепей.
  • Щелкните правой кнопкой мыши по выбранному объекту и выберите команду Change Net Color в контекстном меню, чтобы назначить выбранным цепям новый цвет.
  • Щелкните правой кнопкой мыши еще раз и выберите Display Override » Selected On, чтобы включить функцию переопределения цветов для выбранных цепей.

Сделайте цепи более заметными, изменив цвет их линий связи и включив функцию переопределения отображения.
Сделайте цепи более заметными, изменив цвет их линий связи и включив функцию переопределения отображения.

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents