Travailler avec des corps 3D extrudés, sphériques et cylindriques
En un coup d'œil
- Découvrez les différences entre les corps 3D extrudés, cylindriques et sphériques, ainsi que la manière de définir et de placer chacun d’eux.
- Apprenez à utiliser le panneau Properties et les raccourcis disponibles pendant l’exécution d’une commande pour contrôler les dimensions, l’apparence et le comportement de placement des formes.
- Comprenez comment générer et gérer des corps 3D à partir de formes d’empreinte existantes à l’aide du Component Body Manager, notamment grâce aux options de traitement des composants individuels et de mise à jour par lots.
Bien que le placement de modèles 3D génériques soit la méthode recommandée pour utiliser les objets Corps 3D, car il fournit une représentation précise et détaillée des composants sur le PCB et permet une détection plus précise des collisions 3D dans l’éditeur de PCB, un objet Corps 3D peut également être utilisé pour placer des formes extrudées, sphériques et cylindriques. Trois types d’objets Corps 3D simples peuvent être placés :
| Extruded | Dans le plan X-Y (vue de dessus), l’objet extrudé est défini de manière interactive, comme les autres objets polygonaux dans l’éditeur de PCB. L’objet est ensuite extrudé vers le haut (ou vers le bas) dans le plan Z, en fonction des propriétés Overall Height et Standoff Height définies dans le mode 3D Body du panneau Properties, ainsi que de l’option Body Projection. Vous pouvez également appliquer un fichier de texture, tel qu’un logo, à la surface d’un objet Corps 3D extrudé. |
| Cylindrical | Les propriétés de cette forme sont définies dans le mode 3D Body du panneau Properties. |
| Spherical | Les propriétés de cette forme sont définies dans le mode 3D Body du panneau Properties. |
Placement d’objets Corps 3D extrudés, sphériques ou cylindriques
Placement direct
Les objets Corps 3D extrudés, sphériques et cylindriques peuvent être placés dans l’éditeur de PCB et dans l’éditeur d’empreintes de PCB en procédant comme suit :
- Choisissez la commande Place » Extruded 3D Body dans les menus principaux.
- Repérez et utilisez la commande Corps 3D extrudé dans Active Bar.
Pour placer un objet Corps 3D extrudé, sphérique ou cylindrique :
- Après le lancement de la commande, le curseur prend la forme d’une croix et vous passez en mode de placement par défaut, pour placer un objet Corps 3D extrudé.
- Appuyez sur Tab pour suspendre le placement et afficher le panneau Properties en mode Corps 3D. Le bouton de pause en superposition apparaît dans l’espace de conception, indiquant que vous pouvez accéder aux champs du panneau Properties.
- Dans le panneau Properties, saisissez un nom pour le Corps 3D dans le champ Identifier. Cette étape est facultative ; l’identifiant peut être utile lorsque plusieurs Corps 3D sont placés et peut également servir à cibler ce Corps 3D dans une règle de conception, si nécessaire.
-
Sélectionnez le Board Side souhaité ; il est généralement défini sur
Top. Dans l’éditeur de bibliothèques de PCB, l’empreinte est créée pour la face supérieure de la carte ; elle peut être retournée sur la face inférieure au cours de la conception du PCB, si nécessaire. - Sélectionnez la Layer mécanique sur laquelle le Corps 3D doit être placé. Les couches mécaniques de type composant doivent être associées à une seconde couche mécanique afin que, si le composant est retourné de la face supérieure vers la face inférieure de la carte, ses éléments mécaniques, tels que le Corps 3D, soient transférés sur la couche mécanique associée. Les couches mécaniques sont associées dans l’onglet Layers and Colors du panneau Configuration de l’affichage. Consultez la page consacrée à ce panneau pour plus d’informations.
- Sélectionnez le 3D Model Type parmi les formes disponibles : Extruded, Cylinder ou Sphere.
-
Les dimensions de chaque forme doivent être définies avant son placement. Si la forme choisie est :
- Extruded – définissez le Overall Height.
- Cylinder – définissez le Height et le Radius.
- Sphere – définissez le Radius.
- Dans la zone Display du panneau, cliquez sur le bouton Color pour définir la couleur et ajustez le Opacity selon vos besoins.
-
Une fois les modifications terminées, cliquez sur le bouton de pause en superposition pour revenir à l’espace de conception.
-
Si la forme est un Cylinder ou un Sphere :
- Le curseur se déplace dans l’espace de conception avec une forme rectangulaire attachée ; cliquez pour placer le Corps 3D.
- Faites un clic droit ou appuyez sur Esc pour terminer le placement des objets Corps 3D.
-
Si la forme est Extruded, le curseur apparaît, prêt à définir la forme polygonale de base du Corps 3D extrudé :
- Cliquez pour définir le premier sommet.
- Déplacez le curseur pour placer le deuxième sommet. Par défaut, chaque clic place deux arêtes, avec un angle de forme définie par l’utilisateur entre elles. Consultez la section Modes de placement des Corps 3D extrudés ci-dessous pour en savoir plus.
- Continuez à déplacer la souris et à cliquer pour placer les sommets suivants.
- Après avoir placé le dernier sommet, faites un clic droit ou appuyez sur Esc pour fermer le Corps 3D et terminer son placement. Il n’est pas nécessaire de fermer manuellement le Corps 3D, car le logiciel complète automatiquement la forme en reliant le point de départ au dernier point placé.
-
Si la forme est un Cylinder ou un Sphere :
Modes de placement des Corps 3D extrudés
Lors du placement d’un Corps 3D extrudé, cinq modes d’angle sont disponibles, dont quatre disposent également de sous-modes d’orientation de l’angle. Pendant le placement :
- Appuyez sur Shift+Spacebar pour parcourir les cinq modes d’angle disponibles.
- Appuyez sur Spacebar pour basculer entre les deux sous-modes d’orientation de l’angle.
-
Dans l’un des modes d’angle en arc, maintenez la touche
ou
enfoncée pour réduire ou agrandir l’arc. Maintenez également la touche Shift enfoncée pour accélérer le redimensionnement de l’arc.
- Appuyez sur la touche de raccourci 1 pour basculer entre le placement de deux arêtes par clic et celui d’ une arête par clic. Dans le second mode, l’arête en pointillés est appelée look-ahead segment.
- Appuyez sur la touche Backspace pour supprimer le dernier sommet.

Un objet Corps 3D extrudé ; notez le point de référence affiché dans les vues 2D et 3D.
Création à partir de formes fermées
Pour accélérer la création de la forme du composant à partir de corps 3D, le logiciel peut créer une série d’objets de corps 3D extrudés à partir des formes fermées détectées dans l’empreinte. Cette fonctionnalité peut être utile si le composant présente une forme inhabituelle, déjà représentée par les formes définies dans la sérigraphie de l’empreinte. Vous pouvez également ajouter des objets supplémentaires à l’empreinte sur des couches mécaniques, puis les utiliser pour créer d’autres objets de corps 3D, par exemple pour représenter les broches.
Les images ci-dessous montrent l’empreinte d’un transistor TO-92. Le contour dessiné sur la couche Top Overlay sert à définir le corps du transistor sur la paire de couches de corps 3D choisie (désignée par Registration Layer dans la boîte de dialogue). Trois petits carrés ont également été créés sur une couche mécanique (chaque carré étant constitué de quatre lignes). Ils servent à définir les broches du composant sur la paire de couches de corps 3D choisie ; les paramètres sont présentés dans l’image de la boîte de dialogue ci-dessous.

Les objets existants dans l’empreinte peuvent servir à créer de nouveaux objets de corps 3D.
Pour créer des objets de corps 3D à partir des formes de l’empreinte, exécutez la commande Tools » Manage 3D Bodies for Current Component ; la boîte de dialogue Component Body Manager s’ouvre. Elle permet de voir quels corps 3D sont actuellement utilisés dans le composant et lesquels ne le sont pas. Vous pouvez ajouter des corps au composant ou en supprimer selon vos besoins. Les corps peuvent être de trois types distincts :
- Un corps 3D placé délibérément (désigné par Component Body dans sa description).
- Une forme rectangulaire créée automatiquement par le logiciel à partir d’un rectangle englobant.
- Une forme polygonale fermée créée automatiquement par le logiciel à partir de primitives de conception.
Vous pouvez également modifier d’autres propriétés d’un corps, telles que les hauteurs, la projection du corps, la couche de référence, ainsi que la couleur et l’opacité. Notez que la colonne Body State indique que quatre formes vont être utilisées pour créer des objets de corps 3D.
Une fois les corps 3D du composant définis selon vos besoins, cliquez sur le Close bouton pour appliquer les modifications.

Le logiciel peut créer des objets de corps 3D à partir de la forme d’objets existants.
Remarques sur l’utilisation de cette boîte de dialogue :
- L’algorithme de détection propose soit une forme rectangulaire créée à partir du rectangle englobant, soit une forme polygonale qui suit le contour formé par les primitives (tracé le long de l’axe central des pistes et des arcs, si leurs extrémités coïncident).
- Pour créer un corps 3D à partir d’un objet existant, cliquez sur le texte bleu dans la colonne Body State.
- La valeur par défaut de Overall Height correspond à Height, défini dans le panneau Properties de l’empreinte.
- Pour une broche de composant qui traverse la carte vers le bas, réglez Body Projection sur Bottom Side.
- Les objets de corps 3D sont créés lorsque vous cliquez sur le bouton Close dans la boîte de dialogue. Si l’affichage est déjà en mode 3D, vous devrez peut-être l’actualiser (raccourci End), passer en mode 2D puis revenir en mode 3D, ou basculer l’option Show 3D Bodies entre Off et On dans l’onglet View Options du panneau View Configurations pour voir les nouveaux objets.
- Pour modifier les corps 3D de tous les composants de la bibliothèque d’empreintes de PCB active actuellement ouverte dans l’éditeur d’empreintes de PCB, choisissez la commande Tools » Manage 3D Bodies for Library dans les menus principaux.
- Pour modifier les corps 3D dans l’éditeur de PCB à l’aide de cette boîte de dialogue, vous pouvez y accéder en sélectionnant la commande Tools » Manage 3D Bodies for Components on Board dans les menus principaux ou en faisant un clic droit sur un composant et en sélectionnant Actions du composant » Gérer les corps 3D dans le menu contextuel.
-
Lorsque vous accédez à la boîte de dialogue à l’aide de la commande Tools » Manage 3D Bodies for Components on Board (dans l’éditeur de PCB) ou de la commande Tools » Manage 3D Bodies for Library (dans l’éditeur d’empreintes de PCB), la zone Components est disponible en haut de la boîte de dialogue. Cette zone répertorie chaque empreinte de composant de la bibliothèque active (dans la conception elle-même, il s’agit de la liste de tous les composants de la carte). Pour chaque entrée, le repère (disponible uniquement côté conception), le nom de l’empreinte, la hauteur et les informations sur la bibliothèque source sont affichés.
Un onglet Batch Update supplémentaire est également disponible. Cet onglet permet d’ajouter rapidement des objets de corps 3D à tous les composants ou aux composants sélectionnés, par lot. Vous pouvez définir des critères de recherche pour détecter et créer les corps 3D, ainsi que pour définir leurs propriétés. Après avoir défini toutes les options du traitement par lot selon vos besoins, cliquez sur le bouton Execute Batch Update . La recherche est effectuée pour chaque composant inclus dans le traitement et, lorsqu’une forme de corps 3D est détectée et créée, ce corps est ajouté au composant avec les propriétés définies. Dans ce mode, les modifications sont appliquées lors de l’exécution de la mise à jour par lot.
- La boîte de dialogue permet de gérer les corps 3D du composant depuis un emplacement unique, sans avoir à ouvrir le panneau Properties pour chaque corps 3D.
Options et commandes de la boîte de dialogue Component Body Manager

La boîte de dialogue Component Body Manager (à l’arrière-plan) et la boîte de dialogue Gestionnaire des corps du composant pour le composant (au premier plan)
Composants
La zone supérieure de la boîte de dialogue répertorie chaque empreinte de composant de la bibliothèque active (dans la conception elle-même, il s’agit de la liste de tous les composants de la carte). Pour chaque entrée, le repère (disponible uniquement côté conception), le nom de l’empreinte, la hauteur et les informations sur la bibliothèque source sont affichés.
Onglet interactif

L’onglet Interactive de la boîte de dialogue Component Body Manager
La version Component Body Manager de la boîte de dialogue comporte deux onglets : l’onglet Interactive et l’onglet Batch Update. L’onglet Interactive permet de consulter facilement les informations sur le composant sélectionné, notamment les aperçus des corps du composant et du corps sélectionné.
Corps de composant existants et potentiels
-
Existing and Potential Component Bodies - cette zone répertorie tous les corps de composant existants (corps 3D) qui sont utilisés ou pourraient être utilisés pour le composant. Chaque corps de composant est décrit à l’aide des éléments suivants :
-
Description - une description de la manière dont le corps a été créé. Il peut s’agir d’un corps 3D placé délibérément (désigné par Component Body dans sa description), d’une forme rectangulaire créée à partir d’un rectangle englobant ou d’une forme polygonale fermée créée à partir de primitives de conception. La description de chaque corps (qu’il ait été placé ou créé automatiquement) indique également la couche mécanique sur laquelle il se trouve (ou sur laquelle se trouvent les objets à partir desquels il a été créé), ainsi que sa superficie. Les corps rectangulaires et polygonaux se distinguent par
et
icônes respectivement.
- Body State - indique si le corps est utilisé dans le composant (In Component <ComponentDesignator>) ou non (Not In Component <ComponentDesignator>). Cliquez sur l’entrée pour modifier cet état selon vos besoins.
- Standoff Height - la distance entre la surface de la carte et la face inférieure du corps extrudé. Utilisez une valeur négative pour les corps extrudés qui doivent traverser le PCB vers le bas.
- Overall Height - la distance entre la surface de la carte et la face supérieure du corps extrudé.
- Body Projection - le côté de la carte à partir duquel le corps 3D sera projeté. Utilisez la liste déroulante du champ pour choisir Top Side ou Bottom Side (projection vers le haut ou vers le bas). Ce paramètre est automatiquement modifié si l’objet corps 3D est retourné de l’autre côté de la carte lors du retournement d’un composant.
- Registration Layer - la couche mécanique sur laquelle se trouve le corps 3D. Utilisez la liste déroulante du champ pour choisir parmi toutes les couches mécaniques actuellement activées. Si la couche mécanique choisie est appariée, lorsque le corps est retourné de l’autre côté de la carte avec son composant, il est également déplacé vers la couche mécanique appariée.
- Body 3D Color - la couleur actuellement utilisée pour le corps 3D. Cliquez sur l’échantillon de couleur pour accéder à la boîte de dialogue standard Choose Color et attribuer une autre couleur selon vos besoins.
- Body 3D Opacity - le niveau de transparence actuel du corps 3D. Utilisez la liste déroulante du champ pour choisir parmi Solid (complètement opaque), Hide (corps invisible), 25% Opacity, 50% Opacity et 75% Opacity.
-
Description - une description de la manière dont le corps a été créé. Il peut s’agir d’un corps 3D placé délibérément (désigné par Component Body dans sa description), d’une forme rectangulaire créée à partir d’un rectangle englobant ou d’une forme polygonale fermée créée à partir de primitives de conception. La description de chaque corps (qu’il ait été placé ou créé automatiquement) indique également la couche mécanique sur laquelle il se trouve (ou sur laquelle se trouvent les objets à partir desquels il a été créé), ainsi que sa superficie. Les corps rectangulaires et polygonaux se distinguent par
- Component bodies in: <ComponentDesignator> - affiche l’empreinte 2D du composant avec, en superposition, les corps 3D dont le paramètre Body State est actuellement défini sur In Component <ComponentDesignator>. L’aperçu est dynamique et évolue à mesure que des corps sont inclus ou exclus.
- Selected Body - affiche le corps actuellement sélectionné dans la liste ci-dessus. La zone de titre de la fenêtre reprend également la description du corps.
Onglet de mise à jour par lot

L’onglet Batch Update de la boîte de dialogue Component Body Manager
L’onglet Batch Update permet d’ajouter rapidement des objets corps 3D à toutes les empreintes d’une bibliothèque ou à une sélection d’entre elles, ou encore à toutes les empreintes placées dans une conception ou à une sélection d’entre elles.
Zone de grille
Utilisez cette zone pour définir les critères de recherche servant à détecter et à créer des corps 3D, ainsi que leurs propriétés, telles que Projection side (également appelée projection du corps), Registration Layer, Standoff Height, Overall Height et 3D Body Color.
Chaque entrée de la liste définit un périmètre différent en termes de couches à explorer lors de la détection et de la création de formes de corps 3D potentielles. Chaque recherche est activée individuellement à l’aide de l’option de la colonne Enabled. Vous pouvez activer plusieurs recherches, mais gardez à l’esprit qu’un corps 3D sera ajouté pour chaque recherche aboutie. En général, vous activerez une recherche sur une couche particulière — ou un ensemble de couches — selon l’endroit où vous placez habituellement les primitives ou les informations de contour du composant pour une empreinte. Par défaut, une recherche sur All Layers est effectuée.
Le champ Detection Method vous permet de contrôler la manière dont chaque forme de corps 3D est définie :
- Bounding Rectangle - utiliser le rectangle englobant de l’empreinte.
- Closed Shapes - utiliser une forme polygonale fermée créée à partir des primitives de l’empreinte du composant.
- Both (Prefer Closed Shapes) - détecter un rectangle englobant ou une forme polygonale fermée à partir des primitives de l’empreinte. Si les deux sont détectés, utiliser la forme polygonale fermée.
La colonne d’option Prefer component height if not 0 vous permet de déterminer si l’attribut de hauteur défini pour une empreinte de composant est utilisé comme Overall Height pour le corps 3D. Lorsque cette option est activée, pour chaque composant dont l’attribut de hauteur défini est supérieur à zéro, cette hauteur est affectée au paramètre Overall Height du corps 3D ajouté et son paramètre Standoff Height est défini sur zéro.
Le paramètre Body 3-D Color définit la couleur de rendu du corps 3D. Cliquez sur la couleur pour la modifier dans la boîte de dialogue Choose Color.
Options
- Apply Only To Selected Components - activez cette option si vous souhaitez appliquer les critères de corps 3D uniquement à un groupe d’empreintes sélectionnées. Assurez-vous que ces composants sont sélectionnés dans la partie supérieure de la boîte de dialogue (utilisez les fonctions standard Ctrl+Click et Shift+Click pour effectuer une sélection multiple). Si cette option est désactivée, le processus d’ajout par lot s’applique à toutes les empreintes de la bibliothèque (ou à tous les composants de la carte).
- Delete Existing Bodies In Components - activez cette option pour supprimer tous les corps 3D actuellement définis pour les empreintes ciblées par le traitement par lot. Utilisez la fenêtre d’aperçu en bas à droite de l’onglet pour visualiser l’aspect du corps 3D ajouté en fonction de l’empreinte de composant actuellement sélectionnée et de l’entrée de recherche actuellement sélectionnée (et activée). Après avoir défini toutes les options du traitement par lot selon vos besoins, cliquez sur le bouton Execute Batch Update. La recherche est effectuée pour chaque empreinte incluse dans le traitement et, lorsqu’une forme de corps 3D est détectée et créée, ce corps est ajouté à l’empreinte avec les propriétés définies.
Aperçu de l’opération par lot
Permet de prévisualiser les corps 3D définis sur différentes couches.
Commande supplémentaire
- Execute Batch Update - cliquez pour lancer la mise à jour de chaque empreinte incluse dans le traitement. Lorsqu’une forme de corps 3D est détectée et créée, ce corps est ajouté à l’empreinte avec les propriétés définies.
Création à partir de primitives sélectionnées
Outre le placement interactif d’un corps 3D, vous pouvez également en créer un à partir d’un ensemble d’objets existants de type piste, arc et région pleine définissant une forme fermée. Cette méthode est particulièrement adaptée lorsque le modèle est simple. Pour définir un corps 3D à partir d’une forme fermée existante :
- Sélectionnez toutes les primitives qui constituent la forme fermée.
- Cliquez sur Tools » Convert » Create 3D Body From selected primitives.
Le corps 3D est créé sur la couche supérieure à partir du contour fermé formé par les primitives, quelle que soit la couche sur laquelle se trouvent les pistes sélectionnées. Vous pouvez donc définir la forme sur une couche mécanique. Notez que les primitives initialement sélectionnées subsistent après la création de la région et restent sélectionnées. Le contour du corps 3D suit l’axe médian des objets piste qui le délimitent, et le corps 3D n’est pas sélectionné.
Comme l’algorithme Create 3D Body From selected primitives utilise l’axe médian des objets sélectionnés, il exige que les points de début et de fin des objets qui se touchent coïncident exactement (aux mêmes coordonnées X, Y). Si ce n’est pas le cas, une boîte de dialogue Confirm s’affiche et indique l’emplacement où l’algorithme a échoué. Elle permet également de demander à l’algorithme de tenter de définir le corps 3D à partir des bords des objets. Tant que les objets sélectionnés se chevauchent légèrement, cette option devrait créer un corps 3D dont le contour suit le bord extérieur des objets sélectionnés.
Modification graphique
La méthode d’édition graphique vous permet de sélectionner un objet corps 3D placé directement dans l’espace de conception et de modifier graphiquement sa taille, sa forme ou sa position.
Pour un corps 3D extrudé, cliquez une fois sur l’objet pour le sélectionner et le mettre en mode édition. Le contour de l’objet corps 3D est défini par une série d’arêtes : chaque arête possède un sommet à chaque extrémité, représenté par un carré blanc plein (A dans l’image ci-dessous), et un sommet central, représenté par un carré blanc vide (B dans l’image ci-dessous). Chaque sommet d’extrémité correspond au point de jonction de deux arêtes.
Les techniques standard d’édition des formes polygonales permettent de modifier la forme.
Lors de l’édition d’un objet polygonal, trois modes d’édition sont disponibles : Slide/Miter, Incurvate (arc) et Move. Vous pouvez changer le mode actif while dragging a vertex or an edge en appuyant sur Shift+Spacebar pour parcourir les trois modes.
- Slide/Miter – cliquez sur une arête ou un sommet central et maintenez le bouton enfoncé pour faire glisser cette arête ; cliquez sur un sommet d’extrémité et maintenez le bouton enfoncé pour chanfreiner le coin.
- Incurvate – cliquez sur une arête ou un sommet central et maintenez le bouton enfoncé pour courber cette arête ; cliquez sur un sommet d’extrémité et maintenez le bouton enfoncé pour arrondir le coin.
- Move – cliquez sur une arête ou un sommet central et maintenez le bouton enfoncé pour diviser cette arête en deux ; cliquez sur un sommet d’extrémité et maintenez le bouton enfoncé pour déplacer librement ce coin.
Pendant l’édition, vous pouvez également :
- Ctrl+click and hold n’importe où sur une arête à l’écart des poignées d’édition pour insérer un nouveau sommet.
- Pour supprimer un sommet, cliquez dessus et maintenez le bouton enfoncé, puis appuyez sur la touche Delete.
-
Cliquez n’importe où sur le corps 3D, à l’écart des poignées d’édition, puis faites-le glisser pour le repositionner. Pendant le déplacement, vous pouvez faire pivoter le corps 3D ou lui appliquer une symétrie :
- Appuyez sur Spacebar pour faire pivoter le corps 3D dans le sens antihoraire ou sur Shift+Spacebar pour le faire pivoter dans le sens horaire. La valeur de Rotation Step est définie sur la page PCB Editor – General de la boîte de dialogue Preferences.
- Appuyez sur les touches X ou Y pour appliquer une symétrie au corps 3D selon l’axe X ou Y.
Conversion au format STEP
Un objet corps 3D extrudé, cylindrique ou sphérique sélectionné peut être converti en modèle STEP. Le modèle STEP est automatiquement intégré au fichier de conception. Pour convertir un objet corps 3D libre, sélectionnez-le dans l’espace de conception, puis faites un clic droit et choisissez la commande Convert To STEP dans le menu contextuel. Cette commande n’est pas disponible si aucun objet n’est sélectionné ou si plusieurs objets sont sélectionnés. Une fois converti au format STEP, un objet ne peut plus être redimensionné dans l’espace de conception.

Convertissez une forme extrudée au format STEP si vous devez la faire pivoter autour des axes X ou Y.
Point de référence d’un objet corps 3D extrudé, sphérique ou cylindrique
Un objet corps 3D extrudé, sphérique ou cylindrique possède un point de référence, ou origine.
- Pour un cylindre ou une sphère, le point de référence est le centre de la forme circulaire de l’objet dans le plan X-Y.
- Pour un objet extrudé, le point de référence est situé aux coordonnées Longueur en X/2, Longueur en Y/2 en vue de dessus.
- C’est la position de ce point de référence dans l’espace de conception qui est indiquée dans les Location X/Y du panneau Properties.

Les objets corps 3D extrudés, sphériques et cylindriques possèdent un point de référence, comme le montrent les images. Notez que les lignes du point de référence sont courtes et peuvent donc ne pas apparaître à l’extérieur de l’objet.
Ajout d’une texture à un corps 3D extrudé
Les objets extrudés peuvent également comporter une image superposée à leur surface supérieure, ce qui rend votre carte plus réaliste lorsqu’elle est visualisée en 3D. Lorsqu’une Texture File est ajoutée, elle est automatiquement étirée pour recouvrir toute la surface supérieure du corps 3D, comme le montre l’image ci-dessous. Notez que le fichier de texture est lié au fichier de bibliothèque ou de carte.
Les formats de fichiers de texture pris en charge sont les suivants : *.bmp ; *.dds ; *.dib ; *.hdr ; *.jpg ; *.pfm ; *.png ; *.ppm ; et *.tga.

Une texture ou un logo peut être ajouté à un objet corps 3D extrudé.
Vous pouvez ajuster cet élément en modifiant sa position Center ainsi que les paramètres Size et Rotation dans le mode 3D Body du panneau Properties.
Vous pouvez également modifier la position d’un objet texture associé à un modèle 3D extrudé donné en choisissant la commande Tools » 3D Body Placement » Move Texture Location dans les menus principaux lorsque l’éditeur est en mode de disposition 3D. Après le lancement de la commande, le curseur prend la forme de cônes bleus (indiquant le mode de sélection 3D) et vous êtes invité à sélectionner un corps 3D extrudé auquel une texture est associée. Placez le curseur sur le corps 3D souhaité, puis cliquez ou appuyez sur Enter. Cliquez ou appuyez sur Enter une deuxième fois pour « saisir » la texture par son coin le plus proche. Déplacez la texture à la position souhaitée, puis cliquez ou appuyez sur Enter pour la placer. Les actions supplémentaires standard de déplacement des objets (Spacebar/Shift+Spacebar pour faire pivoter, X ou Y pour appliquer une symétrie, les touches fléchées pour déplacer légèrement la texture) peuvent être effectuées pendant le déplacement, tant que la texture reste attachée au curseur.
Vous pouvez aussi déplacer la texture d’un corps 3D extrudé sélectionné par un cliquer-glisser avec la souris.