압출, 구형 및 원통형 3D 바디로 작업하기
개요
- 돌출형, 원통형, 구형 3D Body 객체의 차이점과 각 객체를 정의하고 배치하는 방법을 알아보세요.
- Properties 패널과 명령 실행 중 사용할 수 있는 단축키를 통해 형상의 치수, 외관, 배치 동작을 제어하는 방법을 살펴보세요.
- 컴포넌트 Body Manager를 사용하여 기존 풋프린트 형상으로부터 3D Body를 생성하고 관리하는 방법과 개별 컴포넌트 및 일괄 업데이트에 사용할 수 있는 옵션을 알아보세요.
범용 3D 모델 배치는 PCB에서 컴포넌트를 정확하고 상세하게 표현하고 PCB Editor에서 더욱 정확한 3D 충돌 검사를 수행할 수 있으므로 3D Body 객체를 사용하는 권장 방식입니다. 하지만 3D Body 객체를 사용하여 돌출형, 구형 및 원통형 3D Body 형상을 배치할 수도 있습니다. 배치할 수 있는 단순 3D Body 객체에는 세 가지 유형이 있습니다.
| Extruded | X-Y 평면(상단 뷰)에서 돌출형 객체는 PCB Editor의 다른 다각형 객체와 동일한 방식으로 대화형으로 정의됩니다. 그런 다음 Properties Panel의 3D Body 모드에서 정의한 Overall Height 및 Standoff Height 속성과 Body Projection 옵션에 따라 객체가 Z 평면에서 위쪽(또는 아래쪽)으로 돌출됩니다. 돌출형 3D Body 객체의 표면에 로고와 같은 텍스처 파일을 적용할 수도 있습니다. |
| Cylindrical | 이 형상의 속성은 Properties Panel의 3D Body 모드에서 정의합니다. |
| Spherical | 이 형상의 속성은 Properties Panel의 3D Body 모드에서 정의합니다. |
돌출형, 구형 또는 원통형 3D Body 객체 배치
직접 배치
다음 방법으로 PCB 및 PCB 풋프린트 Editor에서 돌출형, 구형 및 원통형 3D Body 객체를 배치할 수 있습니다.
- 메인 메뉴에서 Place » Extruded 3D Body 명령을 선택합니다.
- Active Bar에서 돌출형 3D Body 명령을 찾아 사용합니다.
돌출형, 구형 또는 원통형 3D Body 객체를 배치하려면 다음 단계를 따릅니다.
- 명령을 실행하면 커서가 십자형으로 바뀌고 돌출형 3D Body 객체를 배치하는 Default 배치 모드로 전환됩니다.
- Tab을 눌러 배치를 일시 중지하고 3D Body 모드의 Properties Panel을 표시합니다. 설계 공간에 일시 중지 버튼 오버레이가 나타나 Properties Panel의 필드에 접근할 수 있음을 나타냅니다.
- Properties Panel의 Identifier 필드에 3D Body의 이름을 입력합니다. 이는 선택 사항입니다. 식별자는 여러 3D Body를 배치할 때 유용하며, 필요한 경우 Design Rule에서 이 3D Body를 타겟으로 지정하는 데 사용할 수도 있습니다.
-
필요한 Board Side을 선택합니다. 일반적으로
Top로 설정합니다. PCB 라이브러리 Editor에서는 보드 상단면을 기준으로 풋프린트를 작성하며, 필요한 경우 PCB 설계 과정에서 하단면으로 뒤집을 수 있습니다. - 3D Body를 배치할 기계 Layer을 선택합니다. 컴포넌트 유형의 기계 레이어는 다른 기계 레이어와 쌍으로 지정해야 합니다. 그러면 컴포넌트를 보드 상단면에서 하단면으로 뒤집을 때 3D Body와 같은 기계적 세부 요소가 쌍으로 지정된 기계 레이어로 이동합니다. 기계 레이어는 View Configuration Panel의 Layers and Colors 탭에서 쌍으로 지정합니다. 자세한 내용은 해당 Panel 페이지를 참조하십시오.
- 사용 가능한 형상인 Extruded, Cylinder 또는 Sphere 중에서 3D Model Type을 선택합니다.
-
각 형상은 배치하기 전에 크기를 정의해야 합니다. 선택한 형상이 다음과 같다면:
- Extruded – Overall Height을 정의합니다.
- Cylinder – Height 및 Radius을 정의합니다.
- Sphere – Radius을 정의합니다.
- Panel의 Display 영역에서 Color 버튼을 클릭하여 색상을 설정하고 필요에 따라 Opacity을 조정합니다.
-
편집이 완료되면 일시 중지 버튼 오버레이를 클릭하여 설계 공간으로 돌아갑니다.
-
형상이 Cylinder 또는 Sphere인 경우:
- 설계 공간에서 커서에 직사각형 형상이 붙어 이동합니다. 클릭하여 3D Body를 배치합니다.
- 마우스 오른쪽 버튼을 클릭하거나 Esc을 눌러 3D Body 객체 배치를 종료합니다.
-
형상이 Extruded인 경우 커서가 나타나 돌출형 3D Body의 다각형 밑면 형상을 정의할 준비가 됩니다.
- 클릭하여 첫 번째 꼭짓점을 정의합니다.
- 커서를 이동하여 두 번째 꼭짓점을 배치할 준비를 합니다. Default 동작은 클릭할 때마다 두 개의 모서리를 배치하고 그 사이에 사용자가 정의한 코너 형상을 만드는 것입니다. 자세한 내용은 아래의 돌출형 3D Body 배치 모드 섹션을 참조하십시오.
- 계속해서 마우스를 이동하고 클릭하여 추가 꼭짓점을 배치합니다.
- 마지막 꼭짓점을 배치한 후 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 3D Body를 닫고 배치를 완료합니다. 소프트웨어가 시작점과 마지막으로 배치한 점을 연결하여 형상을 자동으로 완성하므로 3D Body를 수동으로 닫을 필요는 없습니다.
-
형상이 Cylinder 또는 Sphere인 경우:
돌출형 3D Body 배치 모드
돌출형 3D Body를 배치할 때 사용할 수 있는 코너 모드는 다섯 가지이며, 그중 네 가지에는 코너 방향 하위 모드도 있습니다. 배치 중에 다음 작업을 수행할 수 있습니다.
- Shift+Spacebar 키를 눌러 사용 가능한 다섯 가지 코너 모드를 순환합니다.
- Spacebar 키를 눌러 두 코너 방향 하위 모드 간에 전환합니다.
-
두 Arc 코너 모드 중 하나에서는
또는
키를 길게 눌러 Arc를 줄이거나 늘립니다. 이때 Shift 키를 함께 누르면 Arc 크기를 더 빠르게 조정할 수 있습니다.
- 1 단축키를 눌러 클릭당 두 개의 모서리 배치와 클릭당 한 개의 모서리 배치 간에 전환합니다. 두 번째 모드에서 점선 모서리는 look-ahead segment이라고 합니다.
- Backspace 키를 눌러 마지막 꼭짓점을 제거합니다.

돌출형 3D Body 객체. 2D 및 3D 뷰에 표시된 기준점에 주목하십시오.
닫힌 형상에서 생성
3D Body로 컴포넌트 형상을 구성하는 작업을 빠르게 진행할 수 있도록, 소프트웨어는 풋프린트에서 감지된 닫힌 형상을 기반으로 일련의 돌출형 3D Body 객체를 생성할 수 있습니다. 이 기능은 컴포넌트의 형상이 특이하고 해당 형상이 이미 풋프린트의 컴포넌트 오버레이에 반영되어 있을 때 유용합니다. 또한 풋프린트의 기계 레이어에 객체를 추가한 다음, 이를 기반으로 추가 3D Body 객체를 생성할 수 있습니다. 예를 들어 핀을 만드는 데 사용할 수 있습니다.
아래 이미지는 TO-92 트랜지스터 풋프린트를 보여줍니다. 여기서는 Top Overlay 레이어에 그려진 Outline을 사용하여 선택한 3D Body 레이어 쌍(대화 상자에서는 Registration Layer로 표시)에 트랜지스터 본체를 정의합니다. 또한 기계 레이어에 작은 정사각형 세 개를 만들었으며(각 정사각형은 네 개의 선으로 구성), 이를 사용하여 선택한 3D Body 레이어 쌍에 컴포넌트 핀을 정의합니다. 설정은 아래 대화 상자 이미지에 표시되어 있습니다.

풋프린트의 기존 객체를 사용하여 새로운 3D Body 객체를 생성할 수 있습니다.
풋프린트의 형상에서 3D Body 객체를 생성하려면 Tools » Manage 3D Bodies for Current Component 명령을 실행합니다. 그러면 Component Body Manager 대화 상자가 열립니다. 이 대화 상자에서 현재 컴포넌트에 사용 중인 3D Body와 사용하지 않는 3D Body를 확인할 수 있습니다. 필요에 따라 컴포넌트에 본체를 추가하거나 컴포넌트에서 본체를 제거할 수 있습니다. 본체는 다음 세 가지 유형으로 구분됩니다.
- 직접 배치한 3D Body(설명에 Component Body 로 표시).
- 소프트웨어가 경계 사각형을 기반으로 자동 생성한 직사각형 형상.
- 소프트웨어가 설계 기본 요소를 기반으로 자동 생성한 닫힌 다각형 형상.
높이, 본체 투영, 등록 레이어, 색상 및 불투명도 등 본체의 다른 속성도 수정할 수 있습니다. Body State 열에는 3D Body 객체 생성에 사용될 형상 네 개가 표시되어 있습니다.
컴포넌트의 3D Body를 원하는 대로 정의한 후 Close 버튼을 클릭하면 변경 사항이 적용됩니다.

소프트웨어는 기존 객체의 형상을 기반으로 3D Body 객체를 생성할 수 있습니다.
이 대화 상자 사용 시 참고 사항:
- 감지 알고리즘은 경계 사각형에서 생성한 직사각형 형상 또는 기본 요소의 Outline이 형성하는 형상의 Outline을 따라가는 다각형 형상을 제시합니다(트랙/호의 끝점이 일치하면 중심선을 따라 추적).
- 기존 객체에서 3D Body를 생성하려면 Body State 열의 파란색 텍스트를 클릭합니다.
- Overall Height의 기본값은 풋프린트의 Properties 패널에 정의된 Height입니다.
- 보드를 아래쪽으로 관통하는 컴포넌트 핀의 경우 Body Projection를 Bottom Side로 설정합니다.
- 대화 상자에서 Close 버튼을 클릭하면 3D Body 객체가 생성됩니다. 화면이 이미 3D 모드로 설정되어 있다면 새 객체를 보기 위해 화면을 새로 고침하거나(End 단축키), 2D로 전환한 다음 다시 3D로 전환하거나, View Configurations 패널의 View Options 탭에서 Show 3D Bodies 옵션을 Off 및 On으로 전환해야 할 수 있습니다.
- PCB 풋프린트 Editor에 현재 열려 있는 활성 PCB 풋프린트 라이브러리의 모든 컴포넌트에 대한 3D Body를 편집하려면 메인 메뉴에서 Tools » Manage 3D Bodies for Library 명령을 선택합니다.
- 이 대화 상자를 사용하여 PCB Editor에서 3D Body를 편집하려면 메인 메뉴에서 Tools » Manage 3D Bodies for Components on Board 명령을 선택하거나, 컴포넌트를 마우스 오른쪽 버튼으로 클릭한 후 컨텍스트 메뉴에서 컴포넌트 작업 » 3D Body 관리 를 선택합니다.
-
PCB Editor에서 Tools » Manage 3D Bodies for Components on Board 명령을 사용하거나 PCB 풋프린트 Editor에서 Tools » Manage 3D Bodies for Library 명령을 사용하여 대화 상자를 열면, 대화 상자 상단에 Components Region이 표시됩니다. 이 Region에는 활성 라이브러리의 각 컴포넌트 풋프린트가 나열됩니다(실제 설계에서는 보드에 있는 모든 컴포넌트 목록이 표시됨). 각 Entry에는 Designator(설계 측에서만 제공), 풋프린트 이름, 높이 및 원본 라이브러리 정보가 표시됩니다.
또한 Batch Update 탭이 추가로 표시됩니다. 이 탭에서는 전체 또는 선택한 컴포넌트에 3D Body 객체를 빠르게 일괄 추가할 수 있습니다. 3D Body 감지 및 생성과 3D Body 속성 정의를 위한 검색 조건을 지정할 수 있습니다. 일괄 처리에 필요한 모든 옵션을 정의한 후 Execute Batch Update 버튼을 클릭합니다. 처리 대상에 포함된 각 컴포넌트를 검색하며, 3D Body 형상이 감지되어 생성되면 정의한 속성 조건을 적용하여 해당 본체를 컴포넌트에 추가합니다. 이 모드에서는 일괄 업데이트를 실행할 때 변경 사항이 적용됩니다.
- 이 대화 상자에서는 한곳에서 컴포넌트의 3D Body를 모두 관리할 수 있으므로, 각 3D Body마다 Properties 패널을 열 필요가 없습니다.
컴포넌트 본체 관리자 대화 상자의 옵션 및 컨트롤

Component Body Manager 대화 상자(뒤)와 컴포넌트용 컴포넌트 본체 관리자 대화 상자(앞)
컴포넌트
대화 상자의 상단 Region에는 활성 라이브러리의 각 컴포넌트 풋프린트가 나열됩니다(실제 설계에서는 보드에 있는 모든 컴포넌트 목록이 표시됨). 각 Entry에는 Designator(설계 측에서만 제공), 풋프린트 이름, 높이 및 원본 라이브러리 정보가 표시됩니다.
대화형 탭

Component Body Manager 대화 상자의 Interactive 탭
대화 상자의 Component Body Manager 버전에는 Interactive 탭과 Batch Update 탭의 두 가지 탭이 있습니다. Interactive 탭에서는 컴포넌트 본체와 선택한 본체의 미리보기를 비롯하여 선택한 컴포넌트에 대한 정보를 쉽게 확인할 수 있습니다.
기존 및 사용 가능한 컴포넌트 본체
-
Existing and Potential Component Bodies - 이 Region에는 컴포넌트에 사용 중이거나 사용할 수 있는 모든 기존 컴포넌트 본체(3D Body)가 나열됩니다. 각 컴포넌트 본체에는 다음 정보가 표시됩니다.
-
Description - 본체가 생성된 방식에 대한 설명입니다. 직접 배치한 3D Body(설명에 Component Body로 표시), 경계 사각형에서 생성한 직사각형 형상 또는 설계 기본 요소에서 생성한 닫힌 다각형 형상일 수 있습니다. 각 본체의 설명에는 직접 배치했는지 자동 생성되었는지에 관계없이 해당 본체가 위치한 기계 레이어(또는 본체 생성에 사용된 객체가 위치한 레이어)와 면적도 포함됩니다. 직사각형 본체와 다각형 본체는
및
로 구분됩니다. 각각의 아이콘입니다.
- Body State - 바디가 컴포넌트에서 사용 중인지(In Component <ComponentDesignator>) 아닌지(Not In Component <ComponentDesignator>)를 나타냅니다. 필요에 따라 항목을 클릭하여 상태를 전환합니다.
- Standoff Height - 보드 표면에서 돌출 바디의 밑면까지의 거리입니다. PCB를 관통하여 아래로 내려가야 하는 돌출 바디에는 음수 값을 사용합니다.
- Overall Height - 보드 표면에서 돌출 바디의 윗면까지의 거리입니다.
- Body Projection - 3D Body가 돌출되는 보드 면입니다. 필드의 드롭다운에서 Top Side 또는 Bottom Side을 선택합니다(위쪽 또는 아래쪽으로 돌출). 컴포넌트를 뒤집는 과정에서 3D Body 객체가 보드 반대쪽으로 뒤집히면 이 설정도 자동으로 변경됩니다.
- Registration Layer - 3D Body가 있는 기계 레이어입니다. 필드의 드롭다운에서 현재 활성화된 모든 기계 레이어 중 하나를 선택합니다. 선택한 기계 레이어가 페어로 구성되어 있으면, 컴포넌트와 함께 바디를 보드 반대쪽으로 뒤집을 때 바디도 페어로 연결된 기계 레이어로 이동합니다.
- Body 3D Color - 현재 3D Body에 사용되는 색상입니다. 색상 견본을 클릭하여 표준 Choose Color 대화 상자를 열고 필요에 따라 다른 색상을 지정합니다.
- Body 3D Opacity - 3D Body의 현재 투명도입니다. 필드의 드롭다운에서 Solid (완전히 불투명), Hide (바디가 보이지 않음), 25% Opacity, 50% Opacity, 75% Opacity 중 하나를 선택합니다.
-
Description - 본체가 생성된 방식에 대한 설명입니다. 직접 배치한 3D Body(설명에 Component Body로 표시), 경계 사각형에서 생성한 직사각형 형상 또는 설계 기본 요소에서 생성한 닫힌 다각형 형상일 수 있습니다. 각 본체의 설명에는 직접 배치했는지 자동 생성되었는지에 관계없이 해당 본체가 위치한 기계 레이어(또는 본체 생성에 사용된 객체가 위치한 레이어)와 면적도 포함됩니다. 직사각형 본체와 다각형 본체는
- Component bodies in: <ComponentDesignator> - 컴포넌트의 2D 풋프린트와 함께, 현재 Body State이 In Component <ComponentDesignator>로 설정된 3D Body를 겹쳐서 표시합니다. 미리보기는 바디를 포함하거나 제외할 때마다 동적으로 변경됩니다.
- Selected Body - 위 목록에서 현재 선택한 바디를 표시합니다. 창의 제목 영역에도 바디의 설명이 표시됩니다.
일괄 업데이트 탭

Component Body Manager 대화 상자의 Batch Update 탭
Batch Update 탭에서는 라이브러리의 모든 풋프린트 또는 선택한 풋프린트에, 혹은 설계에 배치된 모든 풋프린트 또는 선택한 풋프린트에 3D Body 객체를 빠르게 추가할 수 있습니다.
Grid 영역
이 영역에서 3D 바디를 감지하고 생성하기 위한 검색 기준을 정의하고, Projection side(바디 돌출이라고도 함), Registration Layer, Standoff Height, Overall Height, 3D Body Color 등의 3D 바디 속성을 정의합니다.
목록의 각 항목은 가능한 3D 바디 형상을 감지하고 생성할 때 검색할 레이어의 범위를 서로 다르게 지정합니다. 각 검색은 Enabled 열의 옵션을 사용하여 개별적으로 활성화합니다. 여러 검색을 활성화할 수 있지만, 검색이 성공할 때마다 3D 바디가 하나씩 추가된다는 점에 유의하세요. 일반적으로 풋프린트의 프리미티브나 컴포넌트 외곽선 정보를 배치하는 위치에 따라 특정 레이어 또는 레이어 집합 하나에 대한 검색을 활성화합니다. 기본적으로 All Layers 검색이 수행됩니다.
Detection Method 필드에서는 각 3D 바디 형상을 정의하는 방식을 지정할 수 있습니다.
- Bounding Rectangle - 풋프린트의 경계 사각형을 사용합니다.
- Closed Shapes - 컴포넌트 풋프린트 프리미티브로 만든 다각형 폐곡선을 사용합니다.
- Both (Prefer Closed Shapes) - 풋프린트의 프리미티브를 기반으로 경계 사각형 또는 다각형 폐곡선을 감지합니다. 둘 다 감지되면 다각형 폐곡선을 사용합니다.
Prefer component height if not 0 옵션 열에서는 컴포넌트 풋프린트에 정의된 높이 속성을 3D 바디의 Overall Height로 사용할지 여부를 지정할 수 있습니다. 이 옵션을 활성화하면 높이 속성이 0보다 크게 정의된 각 컴포넌트에 대해 해당 높이가 추가된 3D 바디의 Overall Height로 설정되고, Standoff Height은 0으로 설정됩니다.
Body 3-D Color은 3D 바디를 렌더링할 색상을 지정합니다. 색상을 클릭하면 Choose Color 대화 상자에서 변경할 수 있습니다.
옵션
- Apply Only To Selected Components - 선택한 풋프린트 그룹에만 3D 바디 기준을 적용하려면 이 옵션을 활성화합니다. 대화 상자 상단 영역에서 해당 컴포넌트가 선택되어 있는지 확인하세요(여러 항목을 선택하려면 표준 Ctrl+Click 및 Shift+Click 기능 사용). 이 옵션을 비활성화하면 라이브러리의 모든 풋프린트 또는 보드의 모든 컴포넌트에 일괄 추가 작업이 적용됩니다.
- Delete Existing Bodies In Components - 일괄 처리 대상 풋프린트에 현재 정의된 3D 바디를 모두 제거하려면 이 옵션을 활성화합니다. 탭 오른쪽 아래의 미리보기 창에서 현재 선택한 컴포넌트 풋프린트와 현재 선택하고 활성화한 검색 항목을 기준으로 추가될 3D 바디의 모습을 확인할 수 있습니다. 일괄 처리에 필요한 모든 옵션을 정의한 후 Execute Batch Update 버튼을 클릭합니다. 처리에 포함된 각 풋프린트에 대해 검색이 진행되며, 3D 바디 형상이 감지되어 생성되면 정의된 속성 기준에 따라 해당 바디가 풋프린트에 추가됩니다.
일괄 작업 미리보기
서로 다른 레이어에 정의된 3D 바디를 미리 확인하는 데 사용합니다.
추가 컨트롤
- Execute Batch Update - 클릭하면 처리에 포함된 각 풋프린트의 업데이트가 진행되며, 3D 바디 형상이 감지되어 생성되면 정의된 속성 기준에 따라 해당 바디가 풋프린트에 추가됩니다.
선택한 프리미티브에서 생성하기
3D Body는 대화형으로 배치할 수 있을 뿐 아니라, 닫힌 형상을 정의하는 기존 Track, Arc 및 솔리드 Region 객체 집합으로도 생성할 수 있습니다. 모델이 단순할 때 매우 유용한 방법입니다. 기존의 닫힌 형상에서 3D Body를 정의하려면 다음을 수행합니다.
- 닫힌 형상을 구성하는 모든 프리미티브를 선택합니다.
- Tools » Convert » Create 3D Body From selected primitives을 클릭합니다.
선택한 Track이 위치한 레이어와 관계없이, 프리미티브가 형성하는 닫힌 경계를 기반으로 Top 레이어에 3D Body가 생성됩니다. 따라서 기계 레이어에서 형상을 정의할 수도 있습니다. Region이 생성된 후에도 원래 선택한 프리미티브는 그대로 존재하며 선택 상태도 유지됩니다. 3D Body의 경계는 경계를 구성하는 Track 객체의 중심선을 따르며, 생성된 3D Body는 선택되지 않습니다.
Create 3D Body From selected primitives 알고리즘은 선택한 객체의 중심선을 사용하므로, 서로 맞닿는 객체의 끝점과 시작점이 정확히 일치해야 합니다(동일한 X, Y 위치). 그렇지 않으면 Confirm 대화 상자가 나타나 알고리즘이 실패한 위치를 알려 주며, 대신 객체의 가장자리를 기준으로 3D Body를 정의하도록 알고리즘에 지시할 수 있습니다. 선택한 객체가 약간 겹쳐 있기만 하면, 이 옵션으로 선택한 객체의 바깥쪽 가장자리를 따라 경계가 형성되는 3D Body를 생성할 수 있습니다.
그래픽 편집
그래픽 편집 방식을 사용하면 설계 공간에 배치된 3D Body 객체를 직접 선택하고 크기, 형상 또는 위치를 그래픽으로 변경할 수 있습니다.
돌출형 3D Body의 경우 객체를 한 번 클릭하여 선택하면 편집 모드로 전환됩니다. 3D Body 객체의 외곽 형상은 일련의 모서리로 정의됩니다. 각 모서리의 양 끝에는 흰색으로 채워진 사각형(아래 이미지의 A)으로 표시되는 끝 꼭짓점이 있고, 중앙에는 속이 빈 흰색 사각형(아래 이미지의 B)으로 표시되는 중앙 꼭짓점이 있습니다. 각 끝 꼭짓점은 두 모서리가 만나는 위치를 나타냅니다.
표준 다각형 형상 편집 기법을 사용하여 형상을 편집할 수 있습니다.
다각형 객체를 편집할 때는 Slide/Miter, Incurvate(호), Move의 세 가지 편집 모드를 사용할 수 있습니다. Shift+Spacebar을 눌러 세 가지 모드를 순환하며 현재 모드를 while dragging a vertex or an edge 변경할 수 있습니다.
- Slide/Miter – 모서리 또는 중앙 꼭짓점을 클릭한 채로 드래그하면 해당 모서리가 평행 이동합니다. 끝 꼭짓점을 클릭한 채로 드래그하면 모퉁이를 모따기할 수 있습니다.
- Incurvate – 모서리 또는 중앙 꼭짓점을 클릭한 채로 드래그하면 해당 모서리를 곡선으로 만들 수 있습니다. 끝 꼭짓점을 클릭한 채로 드래그하면 모퉁이를 둥글게 처리할 수 있습니다.
- Move – 모서리 또는 중앙 꼭짓점을 클릭한 채로 드래그하면 해당 모서리를 두 개의 모서리로 나눌 수 있습니다. 끝 꼭짓점을 클릭한 채로 드래그하면 해당 모퉁이를 자유롭게 이동할 수 있습니다.
편집 중에는 다음 작업도 수행할 수 있습니다.
- Ctrl+click and hold 편집 핸들에서 떨어진 모서리 위의 임의 지점에서 수행하여 새 꼭짓점을 삽입합니다.
- 꼭짓점을 제거하려면 해당 꼭짓점을 클릭한 상태에서 Delete 키를 누릅니다.
-
편집 핸들에서 떨어진 3D Body의 임의 지점을 클릭한 다음 드래그하여 위치를 변경합니다. 드래그하는 동안 3D Body를 회전하거나 대칭 이동할 수 있습니다.
- Spacebar을 누르면 3D Body가 시계 반대 방향으로 회전하고, Shift+Spacebar을 누르면 시계 방향으로 회전합니다. Rotation Step 크기는 Preferences 대화 상자의 PCB Editor – General 페이지에서 정의합니다.
- X 또는 Y 키를 누르면 3D Body가 X축 또는 Y축을 기준으로 대칭 이동합니다.
STEP으로 변환
선택한 돌출형/원통형/구형 3D Body 객체를 STEP 모델로 변환할 수 있습니다. STEP 모델은 설계 파일에 자동으로 내장됩니다. 독립적인 3D Body 객체를 변환하려면 설계 공간에서 해당 객체를 선택한 다음 마우스 오른쪽 버튼을 클릭하고 상황에 맞는 메뉴에서 Convert To STEP 명령을 선택합니다. 선택된 객체가 없거나 두 개 이상의 객체가 선택된 경우에는 이 명령을 사용할 수 없습니다. 객체를 STEP으로 변환한 후에는 설계 공간에서 더 이상 크기를 조정할 수 없습니다.

돌출형 형상을 X축 또는 Y축을 중심으로 회전해야 하는 경우 STEP으로 변환하십시오.
돌출형, 구형 또는 원통형 3D Body 객체의 기준점
돌출형, 구형 또는 원통형 3D Body 객체에는 기준점 또는 원점이 있습니다.
- 원통형과 구형의 기준점은 X-Y 평면에서 객체의 원형 형상의 중심점입니다.
- 돌출형 객체의 기준점은 위에서 보았을 때 X 길이/2, Y 길이/2 위치로 설정됩니다.
- Properties 패널의 X/Y Location에 표시되는 값은 설계 공간에서 이 기준점의 위치입니다.

이미지에 표시된 것처럼 돌출형, 구형 및 원통형 3D Body 객체에는 기준점이 있습니다. 기준점 표시선은 길이가 짧으므로 객체 바깥쪽에서는 보이지 않을 수 있습니다.
돌출형 3D Body에 텍스처 추가
돌출형 객체의 최상단 표면에는 이미지를 덧씌울 수도 있어 3D로 볼 때 보드를 더욱 사실적으로 표현할 수 있습니다. Texture File를 추가하면 아래 이미지와 같이 3D Body의 상단 표면 전체를 덮도록 자동으로 늘어납니다. 텍스처 파일은 라이브러리 또는 보드 파일에 연결됩니다.
지원되는 텍스처 파일 형식은 다음과 같습니다. *.bmp; *.dds; *.dib; *.hdr; *.jpg; *.pfm; *.png; *.ppm; 및 *.tga.

돌출형 3D Body 객체에 텍스처나 로고를 추가할 수 있습니다.
이는 Properties 패널의 3D Body 모드에서 Center 위치, Size 및 Rotation 설정을 변경하여 조정할 수 있습니다.
또한 편집기가 3D 레이아웃 모드로 설정되어 있을 때 주 메뉴에서 Tools » 3D Body Placement » Move Texture Location 명령을 선택하여 선택한 돌출형 3D 모델과 연결된 텍스처 객체의 위치를 수정할 수 있습니다. 명령을 실행하면 커서가 파란색 원뿔 모양(3D 선택 모드를 의미함)으로 바뀌고, 텍스처가 연결된 돌출형 3D Body를 선택하라는 메시지가 표시됩니다. 원하는 3D Body 위에 커서를 놓은 다음 클릭하거나 Enter을 누릅니다. 다시 클릭하거나 Enter 을 눌러 가장 가까운 모퉁이를 기준으로 텍스처를 '집어 듭니다'. 텍스처를 원하는 위치로 이동한 다음 클릭하거나 Enter을 눌러 배치합니다. 텍스처가 커서에 붙어 이동하는 동안 일반적인 객체 이동 추가 동작(Spacebar/Shift+Spacebar으로 회전, X 또는 Y으로 대칭 이동, 화살표 키로 텍스처 미세 이동)을 수행할 수 있습니다.
또는 마우스로 클릭하여 드래그하는 방식으로 선택한 돌출형 3D Body의 텍스처를 이동할 수 있습니다.