ActiveRoute
개요
- ActiveRoute가 자동 라우터와 어떻게 다른지, 그리고 선택한 네트를 가이드에 따라 고품질로 라우팅하는 데 왜 더 적합한지 알아보세요.
- 라우트 가이드, 다중 레이어 라우팅, 글로싱, 튜닝, 미앤더 제어, 핀 스와핑 등 ActiveRoute의 주요 기능을 살펴보세요.
- PCB ActiveRoute Panel을 사용하여 설계 Rule과 라우팅 목표에 맞게 ActiveRoute를 설정하고 실행하는 방법을 확인해 보세요.
보드 설계에서 가장 시간이 많이 걸리는 단계 중 하나는 Net을 라우팅하는 작업입니다. 규칙 시스템이 폭, 비아 크기, 클리어런스 등의 설계 제약 조건을 처리하지만, 보드의 라우팅을 완료하는 데 필요한 수천 개의 Track 세그먼트를 배치하는 일은 설계자의 몫입니다.
자동 라우터는 이러한 부담을 줄여 줄 수 있지만, 일반적으로 다음과 같은 이유로 충분하지 않다고 여겨집니다.
-
설계자가 라우팅 중 직관적으로 적용하는 수많은 세밀한 설계 제약 조건을 올바르게 고려하지 못합니다.
-
모든 설정을 완료하는 데 시간이 너무 오래 걸려, 보드를 인터랙티브 방식으로 직접 라우팅하는 편이 더 효율적인 경우가 많습니다.
-
결과를 정리하는 과정이 너무 길고 어려워, 보드를 인터랙티브 방식으로 라우팅하는 편이 더 효율적인 경우가 많습니다.
PCB 라우팅의 궁극적인 목표는 설계자의 제어하에 설계 규칙을 준수하는 고품질 결과를 빠르게 얻는 것입니다. ActiveRoute는 바로 이 과제를 해결하고자 합니다.
ActiveRoute란?
ActiveRoute는 효율적인 다중 Net 라우팅 알고리즘을 제공하는 자동화된 인터랙티브 라우팅 기술로, 사용자가 선택한 특정 Net 또는 연결에 적용됩니다. 또한 ActiveRoute를 사용하면 설계자가 라우팅 경로나 가이드를 인터랙티브 방식으로 정의할 수 있으며, 이를 통해 새 라우팅이 따라갈 the river을 정의할 수 있습니다.
일반적인 인터랙티브 라우팅과 자동 라우팅의 조합보다 이 접근 방식을 훨씬 효과적으로 만들어 주는 ActiveRoute의 주요 기능은 다음과 같습니다.
- 수동 라우팅에서 가장 시간이 많이 소요되는 핀/비아 배열의 탈출 라우팅을 자동으로 최적화합니다.
- 높은 성능을 제공합니다. Signal Net 하나를 라우팅하는 데 1초 미만이 걸립니다.
- 우선순위에 따라 Net 및 Net 클래스별 폭, 클리어런스, 레이어, 토폴로지, 룸에 대한 설계 규칙을 준수합니다.
- 여러 레이어에서 동시에 라우팅하고 해당 레이어들에 라우팅을 분산합니다.
- 설계자가 라우팅 배치를 유도하는 데 사용할 수 있는 직관적인 Route Guide를 제공합니다.
- River Route 방식을 사용하여 비아 없이도 높은 완료율을 달성합니다.
- 폴리곤 평면을 통과해 라우팅하고 다시 채울 수 있습니다(다시 채우기 옵션이 활성화된 경우).
- 싱글 엔디드 Net과 Differential Pair Net을 모두 지원합니다.
- 모서리 수를 더욱 줄이고 라우팅 길이를 단축하는 강력한 Glossing 도구로 마무리합니다.
PCB ActiveRoute Panel
ActiveRoute는 PCB 설계 규칙에 정의된 기준과 제한 사항을 따르므로, 원하는 연결이나 Net을 선택한 다음 실행하기만 하면 됩니다. 또한 PCB ActiveRoute Panel에서 설정하는 여러 전용 제어 기능도 제공합니다. PCB ActiveRoute Panel에서는 인터랙티브 ActiveRoute 실행, Route Guide 및 가이드 내 라우팅 간격 정의, 자동 길이 튜닝 활성화, 자동 핀 스와핑 활성화 등 ActiveRoute가 제공하는 다양한 기능을 설정하고 실행할 수 있습니다. ActiveRoute를 시작하기 전에 PCB ActiveRoute Panel을 열어 두는 것이 좋습니다.
PCB가 활성 문서일 때 PCB ActiveRoute Panel을 열려면 다음과 같이 하세요.
-
워크스페이스 오른쪽 아래의
버튼을 클릭한 다음 PCB ActiveRoute 메뉴 옵션을 선택합니다.
-
View » Panels » PCB ActiveRoute을 클릭합니다.
PCB ActiveRoute Panel을 사용하여 ActiveRoute 프로세스를 제어합니다.
PCB ActiveRoute Panel은 다음 용도로 사용됩니다.
- ActiveRoute가 연결을 라우팅할 수 있는 Signal 레이어를 활성화합니다.
- 선택한 연결에 대해 ActiveRoute를 실행합니다.
- ActiveRoute 실행 후 Glossing 처리를 활성화합니다.
-
Route Guide를 정의합니다.
- Route Guide 내에서 사용할 Track 간 간격을 설정합니다.
- ActiveRoute로 배치한 라우팅의 길이 튜닝을 설정하고 활성화합니다.
- Meander 옵션을 설정하여 ActiveRoute가 더 긴 라우팅 경로를 정의할 수 있도록 합니다. 이를 통해 완료율을 높일 수 있습니다.
- 핀 스와핑을 설정하고 활성화합니다. ActiveRoute는 라우팅 중 핀을 스와핑하여 라우팅 품질을 개선할 수 있습니다.
PCB ActiveRoute Panel의 내용은 접을 수 있는 섹션으로 구성되어 있으며, 각 섹션 제목의 ► 아이콘을 사용하여 열고 닫을 수 있습니다. 아래의 속성 제어 정보도 동일한 섹션 구성으로 정리되어 있으며, 접을 수 있는 각 섹션은 같은 방식으로 열고 닫을 수 있습니다.
작업
ActiveRoute를 제어하는 데 사용되는 주요 옵션입니다.
-
ActiveRoute - Panel의
버튼을 클릭하여 선택한 연결에 대해 ActiveRoute를 실행합니다. ActiveRoute는 선택한 연결의 라우팅을 시도하며, 패드나 비아가 선택된 경우 해당 Net의 모든 연결에 대해 라우팅을 시도합니다. 선택 기법에 대한 자세한 내용은 ActiveRoute 페이지를 참조하세요.
-
Route Guide - Route Guide는 ActiveRoute가 선택한 연결을 라우팅할 영역을 지정하는 사용자 정의 경로입니다. ActiveRoute의 주요 목표 중 하나는 전체 라우팅 길이의 합이 가장 짧은 경로를 찾는 것이지만, 이 경로가 모든 연결 집합에 대해 원하는 경로인 것은 아닐 수 있습니다. Route Guide는 선택한 연결이 따라가도록 원하는 특정 경로를 설계자가 그릴 수 있는 도구를 제공합니다. Route Guide의 색상은 선택한 연결의 ActiveRoute에 사용할 수 있도록 지정한 레이어에 따라 결정됩니다. 싱글 레이어만 활성화되어 있으면 해당 레이어 색상으로 표시되고, 여러 레이어가 활성화되어 있으면 Default Route Guide 색상으로 표시됩니다.
-
Route Guide를 정의하려면 먼저 가이드 내에서 라우팅할 연결을 선택한 다음
을 클릭합니다. 패널의 버튼을 클릭한 다음, 클릭하여 가이드 시작 위치를 지정하고 마우스를 움직이며 계속 클릭하여 경로를 정의합니다. 경로를 정의한 후 ActiveRoute 버튼을 클릭하면 선택한 연결이 해당 경로를 따라 라우팅됩니다.
-
Route Guide를 배치하는 동안
또는
키를 눌러 가이드 폭을 넓히거나 좁힐 수 있습니다. 기본 폭은 선택한 연결에 적용되는 폭+클리어런스 설계 규칙의 합을 레이어 수로 나눈 다음 1.3을 곱한 값입니다. 다른 경로를 정의해야 하는 경우 Backspace 키를 눌러 가이드를 되돌립니다.
- ActiveRoute는 설계 규칙에 따라 배선 간격을 조정하며, Route Guide 내에서 배선을 넓게 분산하거나 사용 가능한 공간을 모두 활용하려고 하지는 않습니다. Route Guide 내에서 배선을 분산하려면 이 페이지 뒷부분에서 설명하는 Route Guide 내 Track 간 간격 기능을 사용하십시오.
-
Route Guide를 정의하려면 먼저 가이드 내에서 라우팅할 연결을 선택한 다음
-
Tune Selected - 이 옵션을 활성화하면 패널의 Tune 섹션에서 활성화된 적용 가능한 Matched Lengths 규칙 중 우선순위가 가장 높은 규칙이 적용됩니다.
-
Pin Swap Routing – PCB 편집기는 핀 스와핑을 지원합니다. ActiveRoute가 라우팅 과정에서 핀 스와핑을 수행하도록 하려면 이 옵션을 활성화하십시오. 이 옵션을 활성화하는 것 외에도 아래 설명과 같이 패널의 Pin Swap 섹션에서 필요한 컴포넌트를 활성화해야 합니다. 핀 스와핑 시스템에 대한 자세한 내용은 핀, 페어 및 파트 스와핑 페이지를 참조하십시오.
-
Gloss Results – ActiveRoute 결과에 자동으로 Gloss를 적용하려면 이 옵션을 활성화하십시오. 선택한 기존 배선에도 Glossing을 적용할 수 있습니다. 이렇게 하려면 Route » Gloss Selected 명령(Ctrl+Alt+G)을 실행하십시오. 자세한 내용은 기존 배선의 Glossing 및 Retracing 페이지를 참조하십시오.
레이어
ActiveRoute는 여러 레이어에서 동시에 라우팅할 수 있습니다. 레이어를 변경하기 위한 비아를 배치할 수는 없지만, 사용 가능한 레이어에 연결과 네트를 분산할 수 있습니다. 사용 가능한 레이어는 패널의 Layers 섹션에서 구성합니다.
- Show Signal Layers Only – 기본적으로 사용 가능한 모든 신호 및 평면 레이어가 표시됩니다. 신호 레이어만 표시하려면 이 옵션을 활성화하십시오.
- List of Layers – ActiveRoute가 신호를 라우팅할 수 있는 신호 레이어를 활성화합니다. ActiveRoute는 사용 가능한 신호 레이어에 연결을 분산합니다. ActiveRoute는 레이어를 변경하기 위한 비아를 배치하지 않습니다.
제어
이 제어 항목은 ActiveRoute가 적용 가능한 클리어런스 설계 규칙에 맞춰 트랙 간격을 조정하는 데 집중하는 정도를 완화하고, 연결을 완료하기 위해 다소 우회하는 경로를 사용할 수 있도록 합니다.
- Track-Track Space in Route Guide – 이 제어 항목은 Route Guide를 따라 라우팅되는 연결을 어느 정도 간격으로 분산할지(트랙 중심 간 거리) ActiveRoute에 지정하는 데 사용됩니다. 간격에 맞춰 가이드 폭을 올바르게 계산할 수 있도록 Route Guide를 정의하기 전에 설정해야 합니다. 슬라이더로 값을 선택하거나 편집 상자에 거리를 입력하십시오.
-
Meander % Over Manhattan Length – ActiveRoute는 선택한 연결을 가능한 한 최단 경로로, 즉 우회를 최소화하여 라우팅하려고 합니다. ActiveRoute의 완료율이 예상보다 낮다면 허용되는 우회량을 늘려 완료율을 높일 수 있습니다. 기본 최대 Meander 설정은 100%이며, 이는 배선의 총 라우팅 길이가
Manhattan Length + 100% of Manhattan Length까지 허용된다는 의미입니다. 슬라이더로 값을 선택하거나 편집 상자에 백분율을 입력하십시오. Route Guide는 우회량이 크게 증가할 수 있는 경로를 정의하는 용도로 사용되므로, Route Guide를 사용할 때는 Meander 설정이 무시됩니다.
튜닝
ActiveRoute는 현재 라우팅 중인 연결이나 선택한 기존 배선에 길이 튜닝을 적용할 수 있습니다.
-
Match Length Rules for Selected – 정의된 모든 Matched Lengths 설계 규칙이 여기에 나열됩니다. 선택한 연결에 대해 ActiveRoute가 사용할 규칙을 활성화하십시오.
-
Single Ended – 싱글 엔드 신호를 튜닝하는 데 사용할 튜닝 아코디언의 속성입니다.
- Max Amplitude - 튜닝 아코디언에 허용되는 최대 진폭입니다. 기존 패드, 비아 또는 트랙과 같은 장애물이 있으면 설계 규칙의 클리어런스를 유지하도록 진폭이 자동으로 줄어듭니다.
- Min Space - 아코디언 형상의 영점 교차 구간 사이에서 가장자리 간 최소 간격입니다.
-
Differential Pair - 차동 쌍을 튜닝하는 데 사용할 튜닝 아코디언의 속성입니다.
- Max Amplitude - 차동 쌍의 바깥쪽 구성원에 대한 튜닝 아코디언의 최대 허용 진폭입니다. 배치 장애물이 있으면 설계 규칙의 클리어런스를 유지하도록 진폭이 자동으로 줄어듭니다.
- Min Space - 차동 쌍의 안쪽 구성원에 대한 아코디언 형상의 영점 교차 구간 사이에서 가장자리 간 최소 간격입니다.
핀 스와핑
컴포넌트에서 기능적으로 동등한 핀은 서로 교환할 수 있도록 구성할 수 있습니다. 이렇게 하려면 Tools » Pin/Part Swapping » Configure 명령을 선택하십시오. 핀 스와핑을 대화형으로 수행하든 ActiveRoute로 수행하든, 프로젝트를 열 때마다 먼저 프로젝트를 컴파일해야 합니다(Project 메뉴).
- Components with Pin Swap Enabled – 핀 스와핑이 활성화된 모든 컴포넌트가 여기에 나열됩니다. ActiveRoute 실행 중 자동 스와핑에 사용할 컴포넌트를 활성화하십시오.
ActiveRoute의 추가 기능
ActiveRoute는 자동화된 대화형 라우터이며 사용 방법은 간단하고 직관적입니다. 연결을 선택한 다음 Shift+A 키를 누르면 설계 규칙에 따라 ActiveRoute로 라우팅됩니다. ActiveRoute에는 설계자가 특정 기능과 동작을 더 세밀하게 제어할 수 있도록 다양한 추가 기능과 제어 항목이 포함되어 있습니다.
여기에는 다음이 포함됩니다.
- Route Guide를 배치하여 라우팅 경로와 트랙 간격을 정의합니다.
- Meander 제어 항목으로 더 긴 라우팅 경로를 허용합니다.
- 길이 튜닝으로 배선 길이를 자동으로 일치시킵니다.
- 핀 스와핑을 허용하여 라우팅을 더 쉽게 만듭니다.
각 항목을 좀 더 자세히 살펴보겠습니다.
Route Guide로 경로 정의하기
ActiveRoute의 주요 목표 중 하나는 전체 배선 길이가 가장 짧은 경로 조합을 찾는 것입니다. 하지만 이것이 모든 연결 집합에서 원하는 경로는 아닐 수 있습니다. Route Guide는 최단 경로가 아니더라도 선택한 연결이 따라가도록 원하는 특정 경로를 설계자가 작성할 수 있는 도구입니다.
-
Defining the Route Guide - 먼저 가이드 내에서 라우팅할 연결을 선택한 다음,
PCB ActiveRoute Panel의 버튼을 클릭한 다음, 클릭하여 가이드의 시작 위치를 지정하고 마우스를 계속 이동하면서 클릭하여 경로를 지정합니다. 경로를 지정한 후 ActiveRoute 버튼을 클릭하면 선택한 연결이 해당 경로를 따라 라우팅됩니다. 자세한 내용은 이 페이지 뒷부분의 라우팅 가이드 정의 섹션을 참조하세요.
-
Changing the Route Guide Width - 라우팅 가이드를 배치하는 동안
또는
키를 눌러 가이드의 폭을 넓히거나 좁힐 수 있습니다. 기본 폭은 선택한 연결에 적용되는 폭+클리어런스 설계 규칙의 합을 레이어 수로 나눈 다음 1.3을 곱한 값입니다. 다른 경로를 지정해야 하는 경우 Backspace 키를 눌러 가이드를 역순으로 되돌립니다.
- The Route Guide color - 선택한 연결의 ActiveRoute에 사용할 수 있도록 설정된 레이어에 따라 결정됩니다. 활성화된 레이어가 하나이면 해당 레이어 색상으로 표시되고, 여러 레이어가 활성화되어 있으면 기본 라우팅 가이드 색상으로 표시됩니다.
- The track spacing within the Route Guide - 기본적으로 ActiveRoute는 설계 규칙에 따라 배선 간격을 설정하며, 라우팅 가이드 안의 사용 가능한 공간 전체를 활용하거나 배선을 넓게 분산하려고 시도하지 않습니다. 라우팅 가이드 안에서 배선을 분산하려면 이 페이지 뒷부분에 설명된 라우팅 가이드 내 Track 간 간격 기능을 사용하세요.

라우팅 가이드를 배치하면서 폭을 대화식으로 변경하는 과정을 보여주는 동영상입니다.
라우팅 가이드 내 Track 간 간격
라우팅 가이드 내 Track 간 간격 기능을 사용하면 ActiveRoute가 라우팅 가이드의 폭 전체에 걸쳐 배선을 분산하도록 지정할 수 있습니다. 슬라이더로 간격 값을 선택하거나 입력 상자에 값을 입력하세요. 이 설정을 반영하도록 라우팅 가이드의 크기가 자동으로 조정됩니다. 이를 위해서는 라우팅 가이드를 배치하기 전에 Track-Track Space in Route Guide 설정을 구성해야 합니다. 배치하는 동안
및
키를 눌러 라우팅 가이드의 폭을 추가로 조정할 수 있습니다.

Track 간 간격 기능을 사용하여 라우팅 가이드 안에 배선을 분산합니다.
배선의 우회 허용
ActiveRoute는 선택한 연결을 가능한 한 최단 경로로, 즉 우회를 최소화하여 라우팅하려고 시도합니다. ActiveRoute의 완료율이 예상보다 낮으면 Meander 컨트롤을 통해 ActiveRoute에 허용되는 우회 정도를 늘려 완료율을 높일 수 있습니다. 기본 최대 Meander 설정은 100%이며, 이는 배선의 총 길이가 Manhattan Length + 100% of Manhattan Length까지 허용됨을 의미합니다. 슬라이더로 우회 값을 선택하거나 입력 상자에 백분율을 입력하세요.
라우팅 가이드는 우회 정도를 크게 늘릴 수 있는 경로를 지정하는 데 사용되므로, 라우팅 가이드를 사용할 때는 우회 설정이 무시됩니다.
배선 길이 튜닝
ActiveRoute는 현재 라우팅 중인 연결이나 선택한 기존 배선에 길이 튜닝을 적용할 수 있습니다. ActiveRoute는 선택한 Matched Lengths 설계 규칙을 충족하려고 시도합니다.
ActiveRoute에서 길이 튜닝을 수행하도록 구성하려면:
-
Panel의 Action Region에서 Tune Selected 체크박스를 활성화합니다.
-
Panel의 Tune Region에서 필요한 Matched Lengths 설계 규칙을 활성화합니다.
-
Panel의 Tune Region에서 필요한 Max Amplitude 및 Min Space 설정(싱글 엔디드 또는 Differential Pair)을 구성합니다.
핀 스와핑
이 소프트웨어에는 Schematic 편집기와 PCB 편집기 간에 연동되는 강력한 핀 및 파트 스와핑 시스템이 포함되어 있습니다. ActiveRoute는 핀 스와핑 설정에 접근할 수 있으며, 전체 배선 길이를 줄이고 배선 품질을 개선할 수 있다면 라우팅 중에 핀을 스와핑할 수 있습니다.
핀 스와핑을 사용하려면:
- 핀 스와핑을 수행하려면(대화식으로 수행하든 ActiveRoute로 수행하든) 프로젝트를 열 때마다 먼저 프로젝트를 컴파일해야 합니다(Project 메뉴).
- 부품의 핀 스와핑 설정을 구성하고 관리하려면 Tools » Pin/Part Swapping » Configure 명령을 실행하여 Configure Swapping Information in Components 대화 상자를 엽니다.
- PCB ActiveRoute Panel의 Action Region에서 Pin Swap Routing 옵션을 활성화합니다.
- PCB ActiveRoute Panel의 Pin Swap Region에서 필요한 부품을 활성화합니다.
ActiveRoute 사용 준비
2. 기존 폴리곤 보류
Preferences 대화 상자의 PCB Editor - 일반 페이지에서 Repour Polygons after Modification 옵션을 활성화하면 ActiveRoute가 기존 폴리곤을 통과하여 라우팅할 수 있습니다. 또는 Tools » Polygon Pours » Shelve Polygons 명령을 사용하여 폴리곤을 보류할 수 있습니다(설계에는 유지하되 보이지 않게 함).
3. 설계 규칙 구성
- 클리어런스 – ActiveRoute는 해당 클리어런스 설계 규칙을 우선순위에 따라 적용합니다.
- 라우팅 폭 – 해당 폭 규칙의 Preferred 설정을 사용합니다. 인터랙티브 라우팅과 마찬가지로 특정 영역에서 폭을 변경하려면, 예를 들어 배선이 BGA 아래를 통과하는 경우, 더 좁은 Preferred 폭의 폭 설계 규칙을 적용하는 Room을 정의하십시오. Preferred 폭으로 수동 라우팅할 수 없다면 ActiveRoute로도 라우팅할 수 없습니다.
- 차동 쌍 – ActiveRoute는 차동 쌍을 라우팅할 수 있습니다. 차동 쌍이 올바르게 정의되어 있는지 확인하고(PCB Panel의 Differential Pairs Editor 모드에서 확인), Differential Pairs 라우팅 규칙이 올바르게 구성되어 있는지 확인하십시오(Preferred 값이 사용됨).
- Pad Entry – ActiveRoute는 예각을 만들지 않으면서 규칙을 준수하는 가장 직접적인 Pad 진입/진출 경로를 사용하려고 시도합니다. SMT to Corner 및 SMT Pad Entry 규칙을 준수하지만, Track을 항상 Pad 중앙에 배치하지는 않습니다(인터랙티브 라우터는 SMT to Corner 규칙이 활성화되어 있으면 중앙에 배치함). 차동 쌍 Pad를 위한 특수 알고리즘이 포함되어 있어, 정돈된 배선을 유지하면서 쌍의 결합에 중점을 둡니다.
4. 네트 토폴로지 구성
ActiveRoute는 연결선 패턴을 따릅니다. DDR3/4 플라이바이처럼 특정 토폴로지가 필요한 네트 그룹이 있다면 xSignals를 사용하여 시작점과 끝점의 연결 순서를 정의할 수 있습니다. xSignals Multi-Chip Wizard(Design » xSignals » Run xSignals Wizard)는 DDR3/4 및 USB 3.0 유형의 신호 전송을 포함하는 설계에 대해 xSignals를 생성할 수 있습니다. 또는 PCB Panel의 From-To Editor 모드에서 From-To를 생성하여 네트의 지점 간 연결선 패턴을 정의할 수 있습니다.
5. 설계 팬아웃
ActiveRoute는 비아를 배치하지 않으므로, SMT 핀을 사용하는 BGA, 커넥터 및 개별 컴포넌트에 대해 팬아웃을 생성해야 합니다(외층에서 라우팅할 핀은 제외).
6. 전원 및 접지 라우팅
ActiveRoute는 신호 네트용이며, 전원 플레인에 할당된 네트와 핀이 20개를 초과하는 네트는 무시합니다(이러한 네트는 전원 네트로 간주됨). 이전에 완성한 설계에 ActiveRoute를 사용하려면 신호 배선은 삭제하되, 전원 및 접지 라우팅과 팬아웃은 유지하십시오.
7. 필요한 라우팅 레이어 활성화
PCB ActiveRoute Panel에서 필요한 라우팅 레이어를 활성화하십시오. 자세한 내용은 아래에서 설명합니다.
ActiveRoute 실행
ActiveRoute를 실행하려면:
1. 라우팅할 연결 선택
라우팅 선택 전략 페이지에 설명된 방법을 사용하여 라우팅할 연결/네트를 선택하십시오. 연결을 직접 선택하거나 핀, Track, 비아 또는 컴포넌트와 같은 배선 객체를 선택할 수 있습니다. 커서를 다른 객체 위로 이동하기 전까지 상태 표시줄에 방금 선택한 연결 수가 표시됩니다.
- 연결을 선택하면 해당 라우팅 폭 설계 규칙에 정의된 Preferred 폭으로 라우팅됩니다.
- 기존 배선을 선택하면, 선택한 Track에 연결된 연결이 해당 Track의 폭으로 라우팅됩니다.
- 컴포넌트 Pad를 선택하면 선택한 Pad의 모든 연결이 Preferred 규칙 설정으로 라우팅됩니다.
2. ActiveRoute를 실행할 레이어 활성화
PCB ActiveRoute Panel에서 선택한 연결을 라우팅할 레이어를 활성화하십시오. ActiveRoute는 이 레이어들에 배선을 분산합니다.
레이어를 선택하지 않으면 기본 PCB Editor 창 하단에서 선택된 탭에 해당하는 활성 레이어에서 라우팅합니다.
PCB ActiveRoute Panel에서는 라우팅할 레이어를 선택하고, Route Guide를 생성하고, ActiveRoute를 시작할 수 있습니다.
3. 필요한 경우 Route Guide 정의
Route Guide를 배치하려면:
- Route Guide를 따라 라우팅할 연결을 선택하십시오. 커서를 다른 객체 위로 이동하기 전까지 상태 표시줄에 방금 선택한 연결 수가 표시됩니다.
- PCB ActiveRoute Panel에서 Route Guide 버튼을 클릭하십시오.
- 커서가 선택한 모든 연결을 holding하는 것처럼 표시되며, 이는 이 연결 그룹이 Guide를 통과해야 함을 나타냅니다. 정의하려는 경로의 양 끝 중 적절한 시작 위치로 커서를 이동하십시오.
- 클릭하여 Guide의 시작 위치를 정의하십시오. 들어오는 연결이 Guide의 곡선 끝부분으로 진입할 수 있도록 공간을 확보하십시오.
- Guide는 매우 넓은 Track처럼 배치됩니다. Guide의 첫 번째 코너가 될 위치로 커서를 이동한 다음 클릭하여 해당 코너를 정의하십시오.
- 이러한 경로 정의 과정을 계속하되, 연결선이 끝나는 지점에서 어느 정도 떨어진 곳에서 멈추십시오. 연결이 Guide에서 빠져나와 타겟 Pad/비아/Track 끝으로 이어질 수 있도록 공간을 확보하십시오.
- Up Arrow 키를 눌러 Guide를 넓히거나 Down Arrow 키를 눌러 Guide를 좁히십시오.
- Backspace을 눌러 마지막 Guide 코너를 제거하십시오.
- 마우스 오른쪽 버튼을 클릭하여 Guide 배치 모드를 종료하십시오.
한 번에 하나의 Route Guide만 정의할 수 있습니다.
4. ActiveRoute 실행
ActiveRoute를 실행하려면 다음 방법을 사용할 수 있습니다.
- Route » ActiveRoute 명령을 선택합니다.
-
Active Bar에서 ActiveRoute (
) 버튼을 클릭합니다.
- PCB ActiveRoute Panel에서 ActiveRoute 버튼을 클릭합니다.
- Shift+A 단축키를 사용합니다.
5. 진행 상황 모니터링 및 피드백 확인
- PCB Editor의 상태 표시줄에 ActiveRoute 진행 상황이 표시됩니다.
- Messages Panel에 완료율이 표시됩니다.
숙련도 높이기
-
ActiveRoute에 숙달하려면 단축키에 익숙해지는 것이 중요합니다. 가장 자주 사용하게 될 키 조합은 다음과 같습니다.
- Alt+Click - 개별 Connection 선을 선택합니다.
- Alt+Click&Drag - 영역 내의 Connection을 선택합니다. 오른쪽에서 왼쪽으로 드래그하면 닿는 모든 Connection이 선택되고, 왼쪽에서 오른쪽으로 드래그하면 선택 사각형 안에 완전히 포함된 항목만 선택됩니다. Tab 키를 누르면 동일한 Net에 있는 다른 Connection까지 선택 범위가 확장됩니다. 커서를 다른 객체 위로 이동할 때까지 방금 선택한 Connection 수가 상태 표시줄에 표시됩니다.
- Ctrl+Click&Drag - 컴포넌트의 Pad를 선택합니다. 오른쪽에서 왼쪽으로 드래그하면 닿는 모든 Pad가 선택되고, 왼쪽에서 오른쪽으로 드래그하면 선택 사각형 안에 완전히 포함된 항목만 선택됩니다. Tab 키를 누르면 동일한 Net에 있는 다른 라우팅 객체까지 선택 범위가 확장됩니다. Tab 키를 반복해서 누르면 가능한 모든 선택 상태가 차례로 전환됩니다.
- Click&Drag - 기존 Track 세그먼트를 선택합니다. 오른쪽에서 왼쪽으로 드래그하면 닿는 모든 Track이 선택되고, 왼쪽에서 오른쪽으로 드래그하면 선택 사각형 안에 완전히 포함된 항목만 선택됩니다. Tab 키를 누르면 동일한 Net에 있는 다른 라우팅 객체까지 선택 범위가 확장됩니다. Tab 키를 반복해서 누르면 가능한 모든 선택 상태가 차례로 전환됩니다.
- 다른 항목을 선택하는 동안 현재 선택을 유지하려면 Shift 키를 함께 사용합니다.
- Shift+A 현재 선택 항목에 ActiveRoute를 실행합니다.
- Ctrl+Alt+G - 현재 선택 항목에 Gloss를 실행합니다.
-
선택 작업은 표시된 객체에만 적용됩니다(Ctrl+A 제외).
- Shift+S 키를 눌러 싱글 레이어 모드를 켜거나 꺼서 관심 있는 레이어만 표시되도록 합니다.
- 설계에서 배치 룸을 사용하는 경우, 설계 규칙에서 룸을 정의할 때 잠그거나 숨겨서 클릭&드래그 작업 중 선택되거나 이동되지 않도록 할 수 있습니다. 룸은 View Configuration Panel의 View Options 탭에서 숨길 수 있습니다.
-
SMD Pad를 팬아웃합니다. ActiveRoute는 레이어를 변경하지 않으므로 SMD Pad를 팬아웃해야 합니다. 팬아웃 작업 속도를 높이려면 다음 방법을 사용합니다.
- Connection을 라우팅하는 동안 / 단축키(숫자 키패드)를 누르면 비아를 배치하고 해당 Connection의 라우팅을 종료합니다. 숫자 키패드가 없는 경우 2 단축키를 사용합니다(작업을 중단하지 않고 비아를 배치).
- 기존 팬아웃을 복사하여 붙여넣으면 PCB Editor가 Net 이름을 자동으로 업데이트합니다. 여러 팬아웃에 대해서도 이 작업을 수행할 수 있습니다.
-
기존 팬아웃을 유지합니다. ActiveRoute는 더 나은 방법이 있으면 팬아웃을 수정합니다. 변경하지 않으려면 팬아웃을 잠그세요. 팬아웃을 잠그는 가장 쉬운 방법은 팬아웃 Track과 비아를 선택하고(이 작업에는 Properties Panel 상단의 Selection Filter을 활용), F11 키를 눌러 Properties Panel을 연 다음 Locked 체크박스를 활성화하는 것입니다. 이렇게 하면 선택한 모든 객체를 한 번에 잠글 수 있습니다.
-
Route Guide를 사용할 때 완료율이 낮다면 경로에 장애물이 너무 많아 가이드의 폭을 넓혀야 하는 것일 수 있습니다. 배치 중에 Up 화살표 키를 누르면 가이드의 폭이 넓어집니다.
-
ActiveRoute가 완료되면 글로싱이 적용됩니다(PCB ActiveRoute Panel에서 활성화한 경우). ActiveRouting 완료 직후의 라우팅 상태를 확인하려면 Ctrl+Z 키를 한 번 눌러 글로싱을 실행 취소합니다. Gloss 명령(Route » Gloss Selected)은 ActiveRoute로 생성한 라우팅뿐 아니라 모든 라우팅의 Track을 매끄럽게 다듬고 Pad 진입부를 개선하는 데 사용할 수 있습니다. 특히 차동 쌍의 Pad 진입부 품질을 높이는 데 중점을 두었습니다. 글로싱에 대한 자세한 내용은 기존 라우팅의 글로싱 및 리트레이싱 페이지를 참조하세요.
-
ActiveRoute가 작동하지 않는 경우는 대개 규칙이 올바르게 설정되지 않았기 때문입니다. ActiveRoute가 실패하는 가장 흔한 원인은 Track을 배치할 공간이 부족한 것입니다. 규칙이 적절한지 확인하세요. 예를 들어 새 PCB 파일의 기본 규칙은 고밀도 BGA 유형의 설계에 적용하기에는 값이 너무 클 수 있습니다.
-
ActiveRoute는 레이어별, 룸별, 클래스별로 설정된 폭, 클리어런스 및 차동 쌍 간격에 대한 라우팅 규칙을 준수합니다. ActiveRoute는 원호나 임의 각도의 Track으로 라우팅하지 않습니다.