Uzyskiwanie dostępu, definiowanie i zarządzanie opcjami projektu
Altium Essentials: Schematic Electrical Rules Validation
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Karty General, Error Reporting i Options w oknie dialogowym Project Options
Podsumowanie
Z istniejącym lub nowo utworzonym projektem powiązany jest zestaw ustawień opcji specyficznych dla tego projektu. Są one zapisywane w pliku projektu (na przykład *.PrjPcb) i różnią się w zależności od typu projektu. Ustawienia opcji konfiguruje się w oknie dialogowym Project Options.
Dostęp
Okno dialogowe Project Options można otworzyć na jeden z następujących sposobów:
- Kliknij prawym przyciskiem myszy pozycję projektu w panelu Projects, a następnie kliknij Project Options w menu kontekstowym.
-
Kliknij ikonę
w panelu Projects, gdy wybrany jest w nim odpowiedni projekt.
- W dowolnym edytorze wybierz Project » Project Options z menu głównego.
Karty okna dialogowego
Ogólne

Karta General w oknie dialogowym Project Options
Karta General w oknie dialogowym Project Options umożliwia sterowanie dostępnością online i synchronizacją projektu w przestrzeni roboczej.
Opcje i elementy sterujące
Jeśli okno zostanie otwarte dla projektu bez połączenia z jego przestrzenią roboczą, jedyną dostępną opcją jest przycisk Turn Off Synchronization.
W przypadku projektu spoza przestrzeni roboczej karta General okna dialogowego Project Options wyświetla tylko przycisk Make Project Available Online. Kliknij ten przycisk, aby otworzyć okno dialogowe Udostępnij online, które po wykonaniu wymaganych kroków doda projekt do przestrzeni roboczej. Po zakończeniu wszystkie opcje na tej karcie okna dialogowego będą dostępne.
Ogólne
- Description — w tym polu możesz podać opcjonalny opis projektu, który będzie widoczny w polu opisu podczas przeglądania projektu w interfejsie przeglądarkowym przestrzeni roboczej.
Dostępność online i synchronizacja
-
Version Control — stan tego pola wyboru odzwierciedla bieżący sposób udostępniania online. Włącz tę opcję, aby przechowywać projekt pod kontrolą systemu VCS w repozytorium projektowym Git Versioned Storage przestrzeni roboczej, lub wyłącz ją, aby korzystać z prostej synchronizacji. Włączenie pełnej kontroli wersji umożliwia wielu użytkownikom pracę nad projektem, co oznacza, że zostanie on udostępniony wszystkim pozostałym współpracownikom połączonym z Twoją przestrzenią roboczą.
-
Migrate to Altium 365 Versioned Storage — włącz tę opcję, aby przenieść projekt korzystający z zewnętrznego systemu VCS do natywnego systemu VCS przestrzeni roboczej Altium 365. Przekonwertowany projekt zachowa dotychczasową historię zatwierdzeń VCS i będzie mógł korzystać z natywnych funkcji kontroli wersji przestrzeni roboczej, takich jak oś czasu historii oparta na zdarzeniach. Ta opcja jest dostępna tylko dla projektu lustrzanego.
-
Server Folder — folder w przestrzeni roboczej, w którym znajduje się projekt.
-
Enable Conflict Prevention Notifications — włącz tę opcję, aby zarządzać dostępem do edycji plików dzięki powiadomieniom, gdy członek zespołu edytuje ten sam dokument projektu w przestrzeni roboczej, i uniknąć potencjalnych konfliktów danych.
-
Turn Off Synchronization — kliknij ten przycisk, aby wyłączyć synchronizację. Lokalna kopia projektu nie będzie już powiązana z kopią znajdującą się w przestrzeni roboczej. Projekt w przestrzeni roboczej pozostanie bez zmian.
Wymagania
-
Link Requirements — jeśli blok z portalu Requirements Portal nie jest powiązany z projektem, kliknij ten przycisk, aby otworzyć okno dialogowe Link Requirements , w którym możesz wybrać blok do powiązania z projektem.
-
Linked Requirements — jeśli blok z portalu Requirements Portal jest powiązany z projektem, ta pozycja pokazuje powiązany blok Kliknij łącze, aby zmienić bieżące powiązanie projektu z blokiem. Kliknij przycisk Unlink, aby usunąć powiązanie.
Więcej informacji znajdziesz na stronie Wymagania w projekcie.
Raportowanie błędów

Karta Error Reporting w oknie dialogowym Project Options (dla projektu PCB)
Karta Error Reporting w oknie dialogowym Project Options umożliwia określenie poziomów raportowania dla każdego z możliwych naruszeń elektrycznych i rysunkowych, które mogą wystąpić w źródłowych dokumentach schematów podczas walidacji projektu. Podczas walidacji projektu ustawienia te są używane wraz z ustawieniami na karcie macierzy połączeń do sprawdzania dokumentów źródłowych pod kątem naruszeń połączeń.
Opcje i elementy sterujące
Lista naruszeń
Ta lista przedstawia wszystkie możliwe naruszenia elektryczne i rysunkowe, które mogą wystąpić w dokumentach źródłowych projektu. Naruszenia są pogrupowane w następujące kategorie:
PCB Design:
Multi-board Design:
Harness Design:
Każdy typ naruszenia jest przedstawiony za pomocą następujących pól:
- Violation Type Description — krótki opis typu naruszenia.
-
Report Mode — użyj tego pola, aby określić poziom istotności wykrytego naruszenia. Z listy rozwijanej wybierz jeden z następujących poziomów raportowania:
-
Menu kontekstowe
W menu kontekstowym dostępnym po kliknięciu prawym przyciskiem myszy znajdują się następujące polecenia:
- All Off — ustaw Report Mode dla wszystkich typów naruszeń na No Report.
- All Warning — ustaw Report Mode dla wszystkich typów naruszeń na Warning.
- All Error — ustaw Report Mode dla wszystkich typów naruszeń na Error.
- All Fatal — ustaw Report Mode dla wszystkich typów naruszeń na Fatal Error.
- Selected Off — ustaw Report Mode dla wszystkich zaznaczonych typów naruszeń na No Report.
- Selected To Warning — ustaw Report Mode dla wszystkich zaznaczonych typów naruszeń na Warning.
- Selected To Error - ustaw Report Mode dla wszystkich wybranych typów naruszeń na Error.
- Selected To Fatal - ustaw Report Mode dla wszystkich wybranych typów naruszeń na Fatal Error.
- Default - przywróć ustawienia domyślne Report Mode dla wszystkich typów naruszeń.
- Report Suppressed Violations in Messages Panel - włącz tę opcję, aby wyświetlać naruszenia w panelu Messages, nawet jeśli zostały one wyciszone na tej karcie.
Opcja dodatkowa
- Set To Installation Defaults - kliknij, aby przywrócić domyślne ustawienia instalacyjne opcji na tej karcie.
Macierz połączeń

Karta Connection Matrix w oknie dialogowym Project Options
Karta Connection Matrix w oknie dialogowym Project Options udostępnia macierz umożliwiającą określanie reguł połączeń między wyprowadzeniami komponentów a identyfikatorami sieci, takimi jak porty i wejścia arkuszy. Definiuje ona warunki logiczne lub elektryczne, które mają być zgłaszane jako ostrzeżenia lub błędy. Na przykład połączenie wyprowadzenia wyjściowego z innym wyprowadzeniem wyjściowym jest zwykle uznawane za błąd, natomiast połączenie dwóch wyprowadzeń pasywnych — nie. Podczas walidacji projektu te ustawienia naruszeń będą używane (w połączeniu z ustawieniami zdefiniowanymi na karcie zgłaszania błędów) do sprawdzania dokumentów źródłowych pod kątem naruszeń.
Opcje i elementy sterujące
Macierz połączeń
Macierz przedstawia wszystkie możliwe kontrole połączeń między kombinacjami wyprowadzeń, portów i wejść arkuszy, a także kontrole elementów niepodłączonych. Macierz odczytuje się w poziomie i w pionie, a kolor elementu na przecięciu wiersza i kolumny określa sposób reakcji kompilatora podczas sprawdzania danego warunku.
Aby zmienić tryb zgłaszania dla kontroli naruszenia w macierzy, kliknij kolorowy kwadrat na przecięciu wiersza i kolumny dwóch elementów. Każde kliknięcie powoduje przejście do następnego poziomu zgłaszania. Obsługiwane są następujące poziomy:
- No Report
- Warning
- Error
- Fatal Error
Menu kontekstowe
W menu kontekstowym otwieranym prawym przyciskiem myszy dostępne są następujące polecenia:
- All Off - ustaw wszystkie pozycje w macierzy na No Report.
- All Warning - ustaw wszystkie pozycje w macierzy na Warning.
- All Error - ustaw wszystkie pozycje w macierzy na Error.
- All Fatal - ustaw wszystkie pozycje w macierzy na Fatal Error.
- Default - przywróć wartości domyślne wszystkich pozycji.
Opcja dodatkowa
- Set To Installation Defaults - kliknij, aby przywrócić domyślne ustawienia instalacyjne opcji na tej karcie.
Generowanie klas

Karta Class Generation w oknie dialogowym Project Options
Karta Class Generation w oknie dialogowym Project Options umożliwia konfigurowanie i kontrolowanie generowania klas. Klasy to logiczne zbiory obiektów projektowych określonego typu. Na przykład powiązane komponenty można zgrupować we własną klasę komponentów, która następnie może posłużyć jako podstawa do utworzenia reguły dotyczącej tej grupy. Ta karta udostępnia elementy sterujące pozwalające określić, które klasy są generowane automatycznie oraz które klasy zdefiniowane przez użytkownika są generowane podczas synchronizacji źródłowych dokumentów schematów z dokumentem projektu PCB.
Opcje i elementy sterujące
Klasy generowane automatycznie
-
Generate Net Classes for Buses - zaznacz tę opcję, aby automatycznie generować klasę sieci dla każdej magistrali w projekcie. Do klasy będą należeć poszczególne sieci wchodzące w skład magistrali, na podstawie której wygenerowano tę klasę.
-
Generate Net Classes for Components - zaznacz tę opcję, aby automatycznie generować klasę sieci dla każdego komponentu w projekcie. Do klasy będą należeć sieci, do których podłączone są wyprowadzenia komponentu, na podstawie którego wygenerowano tę klasę.
-
Generate Separate Net Classes for Bus Sections - zaznacz tę opcję, aby automatycznie generować osobną klasę sieci dla każdej sekcji magistrali. Sekcję magistrali tworzy się przez zdefiniowanie magistrali będącej w rzeczywistości częścią większej magistrali, na przykład
D[15..8]z magistraliD[15..0]. -
Generate Net Classes for Named Signal Harnesses - włącz tę opcję, aby automatycznie generować klasę sieci dla każdej nazwanej wiązki sygnałowej w projekcie. Do klasy będą należeć sieci powiązane z sygnałami zebranymi w nazwanej wiązce sygnałowej, na podstawie której wygenerowano klasę.
-
Sheet-Level Class Generation Grid - ta sekcja umożliwia sterowanie automatycznym generowaniem klas komponentów i/lub sieci na poziomie poszczególnych arkuszy schematu. Wymienione są tu wszystkie źródłowe arkusze schematu projektu, a dla każdego z nich prezentowane są następujące informacje:
- Sheet Name - nazwa dokumentu schematu.
- Full Path - bezwzględna ścieżka do folderu, w którym znajduje się dokument.
-
Component Classes - zaznacz tę opcję, aby wygenerować klasę komponentów dla arkusza.
- Generate Rooms - zaznacz tę opcję, aby wygenerować obszar Room dla klasy komponentów.
-
Net Classes Scope - użyj tego pola, aby określić, czy dla arkusza ma zostać wygenerowana klasa sieci, a jeśli tak, to jaki ma być zakres jej generowania. Lista rozwijana tego pola zawiera następujące opcje:
- None - nie generuj klasy sieci dla tego arkusza.
- Local Nets Only - wygeneruj klasę sieci dla tego arkusza, ale uwzględnij w niej tylko sieci lokalne dla arkusza.
- All Nets - wygeneruj klasę sieci dla tego arkusza, która zawiera wszystkie sieci powiązane z arkuszem (lokalne oraz te, które prowadzą poza arkusz).
-
Structure Classes Generate Structure - zaznacz tę opcję, aby wygenerować klasę strukturalną dla arkusza.
Klasa strukturalna to specjalny typ klasy, której elementami mogą być klasy dowolnego typu (klasy sieci, klasy komponentów itp.). Automatyczne generowanie klasy strukturalnej dla każdego arkusza schematu w projekcie — zawierającego komponenty i/lub sieci — podczas przenoszenia projektu na PCB umożliwia wierne odwzorowanie struktury projektu po stronie PCB. Klasy strukturalne nie tylko pozwalają odtworzyć strukturę dokumentów schematu w środowisku PCB na potrzeby zaawansowanej nawigacji, ale mogą też być używane w zapytaniach logicznych, na przykład przy określaniu zakresu reguł projektowych lub filtrowaniu.
Klasy zdefiniowane przez użytkownika
- Generate Component Classes - zaznacz tę opcję, aby generować klasy komponentów zdefiniowane przez użytkownika podczas przenoszenia projektu na PCB. Klasy komponentów definiuje się ręcznie na schemacie, dodając do wybranych komponentów parametr ClassName i ustawiając jego wartość na żądaną nazwę klasy.
- Generate Rooms for Component Class - zaznacz tę opcję, aby generować obszary Room na podstawie klas komponentów zdefiniowanych przez użytkownika. Komponenty te muszą mieć parametr komponentu o nazwie „ClassName”.
- Generate Net Classes - zaznacz tę opcję, aby generować klasy sieci zdefiniowane przez użytkownika podczas przenoszenia projektu na PCB. Klasy sieci definiuje się ręcznie na schemacie za pomocą dyrektywy Net Class. Aby przypisać sieć do klasy sieci, dołącz dyrektywę Net Class do odpowiedniego przewodu lub magistrali (albo obiektu Blanket) i ustaw wartość jej parametru ClassName na żądaną nazwę klasy.
► Dowiedz się, jak utworzyć klasę sieci zdefiniowaną przez użytkownika
► Dowiedz się, jak utworzyć klasę komponentów zdefiniowaną przez użytkownika
Opcja dodatkowa
- Set To Installation Defaults - kliknij, aby przywrócić domyślne ustawienia instalacyjne opcji na tej karcie.
Uwagi
-
Aby generować klasy (automatyczne i/lub zdefiniowane przez użytkownika) podczas przenoszenia projektu na PCB, należy upewnić się, że odpowiednie ustawienia porównywania mają wartość Find Differences na karcie Porównywanie w oknie dialogowym Project Options, zgodnie z poniższym opisem:
- Klasy sieci — ustaw typ porównania Extra Net Classes (w kategorii Differences Associated with Nets) na Find Differences.
- Klasy komponentów — ustaw typ porównania Extra Component Classes (w kategorii Differences Associated with Components) na Find Differences.
-
Ponadto na karcie Generowanie ECO w oknie dialogowym Project Options należy upewnić się, że odpowiednie ustawienia ECO mają wartość Generate Change Orders.
- Klasy sieci — ustaw typ modyfikacji Add Net Classes (w kategorii Modifications Associated with Nets) na Generate Change Orders.
- Klasy komponentów — ustaw typ modyfikacji Add Component Classes (w kategorii Modifications Associated with Components) na Generate Change Orders.
Porównywanie

Karta Comparator okna dialogowego Project Options
Karta Comparator okna dialogowego Project Options umożliwia określenie, które typy różnic mają być wykrywane, a które ignorowane podczas porównywania dokumentów. Dla każdego dostępnego typu porównania możesz wybrać wykrywanie lub ignorowanie różnic za pomocą odpowiedniej listy rozwijanej w kolumnie Mode. W zależności od potrzeb możesz skonfigurować wykrywanie różnic dotyczących komponentów, sieci, parametrów i obiektów fizycznych.
Opcje/Elementy sterujące
To okno dialogowe jest podzielone na dwa główne obszary:
- Górny obszar, zatytułowany Comparison Type Description/Mode, zawiera opis i tryb porównywania dla każdego dostępnego typu porównania.
- Dolny obszar, zatytułowany Object Matching Criteria, służy do definiowania kryteriów dopasowania dla Net, Net Class, Component Class, Differential Pair i Structure Class.
Opis typu porównania/Tryb
- Comparison Type Description - ten obszar zawiera opisy wszystkich typów porównania dostępnych w projekcie. Użyj paska przewijania po prawej stronie, aby przewinąć do Differences Associated with Components, Differences Associated with Nets, Differences Associated with Parameters, Differences Associated with Physical i Differences Associated with Structure Classes w celu wyświetlenia lub zmiany trybów porównywania w poszczególnych obszarach.
-
Mode - kliknij pozycję, aby zmienić tryb porównywania za pomocą listy rozwijanej:
-
Find Differences- wybierz tę opcję, aby wykrywać różnice w ramach tego typu porównania. -
Ignore Differences- wybierz tę opcję, aby ignorować wszelkie różnice w ramach tego typu porównania (porównanie tego typu nie będzie wykonywane).
-
Kryteria dopasowania obiektów
- Object Type - lista typów obiektów, takich jak Net, Net Class, Component Class, Differential Pair i Structure Class.
- Min Match % - wprowadź żądany minimalny procent dopasowania lub kliknij po prawej stronie kolumny, a następnie użyj klawiszy strzałek w górę i w dół, aby zwiększyć lub zmniejszyć wartość.
- Min Matched Members - wprowadź żądaną minimalną liczbę dopasowanych elementów lub kliknij po prawej stronie kolumny, a następnie użyj klawiszy strzałek w górę i w dół, aby zwiększyć lub zmniejszyć wartość.
- Use Name Matching - kliknij pozycję lub użyj listy rozwijanej, aby wybrać After member matching lub Never.
- Show Manual Matching Dialog - kliknij wpis lub użyj listy rozwijanej, aby wybrać For unmatched objects lub Never.
Opcje dodatkowe
- Ignore Rules Defined in PCB Only - zaznacz tę opcję, aby ignorować reguły zdefiniowane wyłącznie na PCB w obrębie projektu. Na przykład podczas realizacji zlecenia zmian inżynierskich zmiany mogą być przenoszone ze schematu na PCB, a jeśli ta opcja jest włączona, reguły występujące tylko na PCB są ignorowane. Jeśli na arkuszach schematu tego samego projektu nie ma odpowiadających im reguł, komparator nie będzie próbował dodawać nowych reguł.
- Set To Installation Defaults - kliknij, aby przywrócić domyślne ustawienia instalacyjne opcji na tej karcie.
Generowanie ECO

Karta ECO Generation okna dialogowego Project Options
Karta ECO Generation okna dialogowego Project Options umożliwia skonfigurowanie typów zmian, które mogą być uwzględniane podczas generowania zlecenia zmian inżynierskich (ECO) na podstawie różnic wykrytych przez komparator.
Opcje i elementy sterujące
Lista typów zmian
Ta lista przedstawia wszystkie możliwe zmiany, które można wprowadzić za pomocą zlecenia zmian inżynierskich podczas synchronizacji źródłowych dokumentów schematu z dokumentem projektu PCB. Wpisy na liście obejmują kategorie typów zmian związanych z Components, Nets, Parameters, Structure Classes itd.
Każdy typ zmiany obejmuje następujące pola:
- Modification Type Description – krótki opis typu zmiany (działania, które ma wykonać synchronizator).
-
Mode – to pole pozwala określić, czy dany typ zmiany ma być uwzględniany w generowanych zleceniach ECO. Z listy rozwijanej wybierz jedną z następujących opcji:
- Generate Change Orders - uwzględnij typ zmiany w generowanym ECO.
- Ignore Differences - wyklucz typ zmiany z generowanego ECO.
Menu kontekstowe
W menu kontekstowym otwieranym prawym przyciskiem myszy dostępne jest następujące polecenie:
- Report – użyj tego polecenia, aby wygenerować raport aktualnie skonfigurowanych trybów zmian. Pojawi się okno dialogowe Report Preview z już wczytanym raportem. Użyj tego okna, aby przejrzeć raport za pomocą różnych elementów sterowania stronami i powiększeniem przed wyeksportowaniem go do pliku lub wydrukowaniem.
Opcje dodatkowe
- Push Component Designator Changes to Annotation File (if any) – zaznacz, aby uwzględniać zmiany oznaczeń elementów w pliku adnotacji.
- Set To Installation Defaults – kliknij, aby przywrócić domyślne ustawienia instalacyjne opcji na tej karcie.
Opcje

Karta Options okna dialogowego Project Options
Karta Options okna dialogowego Project Options umożliwia określenie ścieżki wyjściowej i powiązanych opcji dla plików wyjściowych generowanych dla projektu. Można również określić różne opcje tworzenia listy połączeń oraz zakres identyfikatorów sieci.
Opcje i elementy sterujące
-
Output Path – domyślna ścieżka wyjściowa do generowania plików wyjściowych bieżącego projektu (
*.PrjPcb). - ECO Log Path – domyślna ścieżka wyjściowa plików dziennika ECO.
-
Schematic Template Location – użyj tego pola, aby określić katalog źródłowy plików szablonów schematów (
*.SchDot,*.SchDoc) dla projektu.
Opcje wyjściowe
- Open outputs after compile – włącz, aby otwierać pliki wygenerowane po kompilacji projektu. W przypadku projektu pakietu biblioteki zintegrowanej włącz tę opcję, aby instalować bibliotekę zintegrowaną po skompilowaniu projektu pakietu.
-
Timestamp folder – włącz, aby tworzyć folder ze znacznikiem czasu dla generowanych plików wyjściowych, takich jak raport BOM (Reports » Bill of Materials). Nazwa folderu ma format
<FolderName> Date Time, gdzie<FolderName>jest określany w polu Output Path, aDateiTimemają format zgodny z ustawieniami systemowymi. - Archive project document – włącz, aby archiwizować dokument projektu. Na przykład podczas generowania plików produkcyjnych z projektu PCB (File » Fabrication Outputs i File » Assembly Outputs) docelowy folder wyjściowy będzie zawierał kopię powiązanego dokumentu PCB.
- Use separate folder for each output type – włącz, aby tworzyć osobne foldery dla każdego typu plików wyjściowych generowanych dla projektu. Ta struktura folderów będzie również odzwierciedlona w panelu Projects.
Opcje listy połączeń
- Allow Ports to Name Nets – włącz, aby nadawać sieci nazwę na podstawie właściwości Name podłączonego portu zamiast domyślnej nazwy sieci generowanej przez system.
- Allow Sheet Entries to Name Nets – włącz, aby nadawać sieci nazwę na podstawie nazwy wejścia arkusza zamiast domyślnej nazwy sieci generowanej przez system.
- Allow Single Pin Nets – włącz, aby dopuszczać istnienie sieci zawierających tylko jedno wyprowadzenie.
-
Append Sheet Numbers to Local Net – włącz, aby do nazw sieci lokalnych dla danego arkusza dodawać wartość parametru Sheet Number dokumentu schematu (parametru na poziomie dokumentu). Sieć lokalna to sieć, która nie wychodzi poza arkusz. Ta opcja nie ma zastosowania do sieci wychodzącej poza arkusz (a więc nielokalnej).
- Higher Level Names Take Priority – włącz, aby etykiety sieci używane na arkuszach wyżej w hierarchii określały nazwy sieci na arkuszach niżej w hierarchii.
-
Power Port Names Take Priority – oprogramowanie umożliwia nadanie globalnej sieci zasilania charakteru lokalnego przez połączenie portu zasilania ze zwykłym portem. Powoduje to umieszczenie wszystkich wyprowadzeń na danym arkuszu podłączonych do tego portu zasilania w osobnej sieci. Włączenie tej opcji wymusza nadawanie sieci nazwy przypisanej do portu zasilania.
Zakres identyfikatorów sieci
Projekty wieloarkuszowe są definiowane na poziomie elektrycznym (czyli połączeń) za pomocą identyfikatorów sieci. Identyfikatory sieci (etykiety sieci, porty, wejścia arkuszy, porty zasilania i ukryte piny) tworzą połączenia logiczne między punktami należącymi do tej samej sieci. Mogą one występować w obrębie jednego arkusza lub obejmować wiele arkuszy. Połączenia fizyczne istnieją wtedy, gdy jeden obiekt jest połączony bezpośrednio z innym obiektem elektrycznym za pomocą przewodu. Połączenia logiczne powstają, gdy dwa identyfikatory sieci tego samego typu (np. dwie etykiety sieci) mają taką samą wartość właściwości Net .
Podczas tworzenia modelu połączeń projektu należy określić sposób łączenia identyfikatorów sieci ze sobą — służy do tego ustawienie Net Identifier Scope. Istnieją zasadniczo dwa sposoby łączenia arkuszy w projekcie wieloarkuszowym: poziomo, bezpośrednio między kolejnymi arkuszami, lub pionowo, od arkusza podrzędnego do reprezentującego go symbolu arkusza na arkuszu nadrzędnym. W połączeniach poziomych łączone są porty z portami (możliwe jest również łączenie etykiet sieci z etykietami sieci). W połączeniach pionowych łączone są wejścia arkuszy z portami.
Z listy rozwijanej można wybrać następujące zasięgi:
-
Automatic (Based on project contents) — ten tryb automatycznie wybiera tryb identyfikatorów sieci na podstawie następujących kryteriów: jeśli na arkuszu najwyższego poziomu występują wejścia arkuszy, używany jest Hierarchical; jeśli nie ma wejść arkuszy, ale występują porty, używany jest Flat; jeśli nie ma ani wejść arkuszy, ani portów, używany jest Global.
- Flat (Only ports global) — porty łączą się globalnie na wszystkich arkuszach projektu. Przy tej opcji etykiety sieci są lokalne dla każdego arkusza, tzn. nie tworzą połączeń między arkuszami. Wszystkie porty o tej samej nazwie zostaną połączone na wszystkich arkuszach. Opcji tej można używać w płaskich projektach wieloarkuszowych. Nie jest zalecana w dużych projektach, ponieważ śledzenie przebiegu sieci między arkuszami może być trudne.
- Hierarchical (Sheet entry <-> port connections, power ports global) — połączenia są tworzone pionowo między portem a odpowiadającym mu wejściem arkusza. Ta opcja tworzy połączenia między arkuszami wyłącznie za pośrednictwem wejść symboli arkuszy i odpowiadających im portów na arkuszach podrzędnych. Porty na arkuszach służą do wyprowadzania sieci lub magistral do wejść odpowiednich symboli arkuszy na arkuszu nadrzędnym. Porty bez odpowiadającego im wejścia arkusza nie zostaną połączone, nawet jeśli na innym arkuszu istnieje port o tej samej nazwie. Etykiety sieci są lokalne dla każdego arkusza, tzn. nie tworzą połączeń między arkuszami. Porty zasilania są jednak globalne — wszystkie porty zasilania o tej samej nazwie są połączone w całym projekcie. Opcji tej można używać do tworzenia projektów o dowolnej głębokości lub hierarchii. Umożliwia ona również śledzenie przebiegu sieci w całym projekcie na wydrukowanym schemacie.
- Strict Hierarchical (Sheet entry <-> port connections, power ports local) — ten tryb połączeń działa tak samo jak tryb Hierarchical , z tą różnicą, że porty zasilania pozostają lokalne dla każdego arkusza, tzn. nie łączą się z portami zasilania o tej samej nazwie na innych arkuszach.
- Global (Netlabels and ports global) — porty i etykiety sieci łączą się na wszystkich arkuszach projektu. Przy tej opcji wszystkie sieci z taką samą etykietą sieci zostaną połączone ze sobą na wszystkich arkuszach. Również wszystkie porty o tej samej nazwie zostaną połączone na wszystkich arkuszach. Jeśli sieć połączona z portem ma również etykietę sieci, jej nazwą będzie nazwa etykiety sieci. Opcji tej można również używać w płaskich projektach wieloarkuszowych, jednak śledzenie połączeń między arkuszami jest trudne, ponieważ wzrokowe odnajdywanie nazw sieci na schemacie nie zawsze jest łatwe.
Zezwalaj na zamianę pinów przy użyciu tych metod
W edytorze PCB zamiana pinów, par różnicowych i części odbywa się przez zamianę sieci przypisanych do pól lutowniczych komponentów oraz odpowiadającej im miedzi. Podczas przenoszenia zmian do schematów zamianę pinów można obsłużyć na dwa sposoby:
-
Adding / Removing Net-Labels — włącz, aby zezwolić na zamianę pinów w symbolu komponentu. Przeprowadzenie zamiany na schemacie przez zamianę etykiet sieci jest możliwe tylko wtedy, gdy połączenia są tworzone za pomocą etykiet sieci, tzn. gdy piny nie są połączone bezpośrednio przewodami.
-
Changing Schematic Pins — włącz, aby zezwolić na zamianę etykiet sieci na przewodach podłączonych do pinów komponentu. Zamiana pinów będzie jedyną dostępną opcją, gdy sieci są fizycznie połączone z komponentem za pomocą przewodów. Metodę tę można stosować w przypadku prostych komponentów (takich jak drabinka rezystorowa) lub wtedy, gdy struktura schematu nie pozostawia innej możliwości.
Ogólne
- Automatic Sheet Numbering — włącz tę opcję, aby automatycznie numerować arkusze schematu w tym projekcie. Umożliwia to kontrolowanie oznaczeń arkuszy i zapisywanie ich jako parametrów w odpowiednich dokumentach schematu.
-
Automatic Cross References — włącz tę opcję, aby automatycznie dodawać informacje o odsyłaczach dla portów, złączy międzyarkuszowych i wejść arkuszy do wszystkich źródłowych dokumentów schematu w aktywnym projekcie. Ta funkcja pomaga śledzić połączenia sieci w projekcie niehierarchicznym.
- New Indexing of Sheet Symbols — włącz, aby używać dowolnej cyfry lub liczby jako pierwszego lub ostatniego indeksu powtarzanego symbolu arkusza, w tym 0. Liczby ujemne nie są dozwolone. Ostatni indeks musi być zawsze większy od pierwszego.
Odsyłacze
-
Sheet Style – wybierz jeden z poniższych stylów oznaczania arkuszy w odsyłaczach portów na jednym lub wielu arkuszach schematu w projekcie.
-
None– do ciągów odsyłaczy wszystkich portów nie jest dodawane oznaczenie arkusza. -
Name– do ciągów odsyłaczy dodawane są nazwy arkuszy, z którymi połączone są porty. -
Number– do ciągów odsyłaczy dodawane są numery arkuszy, z którymi połączone są porty.
-
-
Location Style – wybierz jeden z poniższych stylów oznaczania lokalizacji w odsyłaczach portów na jednym lub wielu arkuszach schematu w projekcie.
-
None– do ciągów odsyłaczy wszystkich portów nie jest dodawane oznaczenie lokalizacji. -
Zone– do ciągów odsyłaczy wszystkich portów powiązanych z obiektami nadrzędnymi dodawana jest numeracja stref odniesienia (strefy są oznaczone na obramowaniu arkusza), wskazująca na przykład położenie symboli arkuszy. -
Location X,Y– lokalizacje portów są umieszczane w nawiasach w ciągach odsyłaczy wszystkich portów powiązanych z obiektami nadrzędnymi, wskazując na przykład położenie symboli arkuszy.
-
- Follow Cross References settings in Preferences – po włączeniu tej opcji wartości opcji Sheet Style i Location Style będą dziedziczone z ustawień w sekcji Port Cross References na stronie Schemat – Ogólne okna dialogowego Preferences.
-
Display Cross References for:
-
Ports – z listy rozwijanej wybierz sposób wyświetlania odsyłaczy dla portów.
-
Disabled– do portów nie są dodawane żadne odsyłacze. -
Only Related Sheet Entry– wyświetlaj odsyłacz do powiązanego wejścia arkusza na nadrzędnym arkuszu schematu. -
Only Related Ports– wyświetlaj odsyłacze do powiązanych portów. -
Sheet Entry & Ports– wyświetlaj odsyłacze zarówno do wejścia arkusza, jak i do portów.
-
- Off-sheet Connectors – włącz tę opcję, aby wyświetlać odsyłacze dla obiektów złączy pozaarkuszowych.
- Sheet Entries – włącz tę opcję, aby wyświetlać odsyłacze dla obiektów wejść arkusza.
-
Ports – z listy rozwijanej wybierz sposób wyświetlania odsyłaczy dla portów.
Pary różnicowe
-
Custom Diff Pair Suffix Grid – zawiera domyślne przyrostki par różnicowych (
_P/_N) oraz wszystkie zdefiniowane niestandardowe przyrostki par różnicowych, z podziałem na:- Positive Suffix – przyrostek dodatniej sieci pary różnicowej.
- Negative Suffix – przyrostek ujemnej sieci pary różnicowej.
- Add – kliknij, aby dodać nową parę przyrostków do listy.
- Remove – kliknij, aby usunąć wybrane pary przyrostków z listy.
Tworzenie xNets
- Sources/Destinations – zdefiniuj rozdzielaną przecinkami listę przedrostków oznaczników komponentów, które mogą być używane jako komponenty źródłowe lub docelowe w xNets.
- Discretes – zdefiniuj rozdzielaną przecinkami listę przedrostków oznaczników komponentów, które mogą być używane jako komponenty szeregowe w xNets.
Projekty wielokanałowe

Karta Multi-Channel okna dialogowego Project Options
Karta Multi-Channel okna dialogowego Project Options umożliwia zdefiniowanie schematu nazewnictwa obszarów Room oraz formatu oznaczników komponentów używanych w projektach wielokanałowych. Projektowanie wielokanałowe umożliwia wielokrotne odwoływanie się do tego samego arkusza podrzędnego w projekcie. Można to osiągnąć przez umieszczenie wielu symboli arkuszy odwołujących się do tego samego arkusza podrzędnego lub przez dodanie słowa kluczowego Repeat do oznacznika symbolu arkusza w celu utworzenia wielu jego instancji.
Altium Designer oferuje pełną obsługę projektowania wielokanałowego, co oznacza możliwość wielokrotnego odwoływania się do pojedynczych arkuszy w projekcie. Wszelkie wymagane zmiany można wprowadzić w jednym miejscu, a ponowna kompilacja projektu przeniesie je do każdej instancji. Altium Designer nie tylko obsługuje wiele kanałów, ale także umożliwia ich zagnieżdżanie.
Mapowanie pojedynczego komponentu logicznego na schemacie na wiele jego fizycznych instancji na PCB jest kontrolowane przez schemat oznaczników dla projektów wielokanałowych zdefiniowany na tej karcie.
Opcje i elementy sterujące
Nazewnictwo obszarów Room
-
Room Naming Style – użyj tego pola, aby określić styl nazewnictwa obszarów Room. Po wybraniu stylu z listy poniższa ilustracja jest aktualizowana tak, aby przedstawiała konwencję nazewnictwa, która zostanie zastosowana w projekcie. Podczas kompilacji projektu dla każdego arkusza tworzony jest obszar Room, w tym dla każdej grupy kanałów i każdego kanału niższego poziomu. Dostępnych jest pięć stylów — dwa płaskie i trzy hierarchiczne (uwzględniające ścieżkę):
- Flat Numeric With Names
- Flat Alpha With Names
- Numeric Name Path
- Alpha Name Path
- Mixed Name Path
-
Level Separator for Paths – użyj tego pola, aby określić znak lub symbol rozdzielający informacje o ścieżce w hierarchicznych stylach nazewnictwa (uwzględniających ścieżkę). Domyślnie używany jest znak podkreślenia (_).
- Preview – podczas wprowadzania zmian w Room Naming Style i/lub Designator Format ilustracja w tej sekcji jest dynamicznie aktualizowana, aby przedstawiała konwencję nazewnictwa, która zostanie zastosowana w projekcie. Ilustracja przedstawia przykład projektu z zagnieżdżonymi kanałami w układzie 2 x 2. Większe zakreskowane obszary reprezentują dwa kanały wyższego poziomu (lub grupy kanałów), a zacienione obszary wewnątrz nich — kanały niższego poziomu (w każdym pokazano po dwa przykładowe komponenty).
Nazewnictwo komponentów
-
Designator Format - użyj tego pola, aby określić format stosowany podczas przypisywania oznaczeń komponentom projektu. Na liście rozwijanej tego pola dostępnych jest osiem predefiniowanych formatów: pięć płaskich i trzy przeznaczone do stosowania w strukturze hierarchicznej (zawierające nazwy kanałów):
- $Component_$RoomName
- $RoomName_$Component
- $Component$ChannelAlpha
- $Component_$ChannelPrefix$ChannelAlpha
- $Component_$ChannelIndex
- $Component_$ChannelPrefix$ChannelIndex
- $ComponentPrefix_$ChannelIndex_$ComponentIndex
- $ComponentPrefix_$RoomName_$ComponentIndex
Definiowanie własnego formatu oznaczeń
Możesz również zdefiniować własny format oznaczeń komponentów, wpisując go bezpośrednio w polu Designator Format. Podczas tworzenia ciągu formatu można używać następujących słów kluczowych:
- $RoomName - nazwa powiązanego kanału określona przez styl wybrany w polu Room Naming Style .
- $Component- logiczne oznaczenie komponentu.
- $ComponentPrefix - prefiks logicznego oznaczenia komponentu (np. U dla U1).
- $ComponentIndex - indeks logicznego oznaczenia komponentu (np. 1 dla U1).
- $ChannelPrefix - logiczne oznaczenie symbolu arkusza.
- $ChannelIndex - indeks kanału.
- $ChannelAlpha - indeks kanału wyrażony jako znak.
Uwagi
- Indeksowanie kanałów literami jest przydatne tylko wtedy, gdy projekt zawiera łącznie mniej niż 26 kanałów lub gdy używany format oznaczeń ma charakter hierarchiczny.
- W przypadku projektu wielokanałowego w dolnej części arkusza schematu w oknie projektu wyświetlane są karty — po jednej dla każdego kanału (lub banku). Nazwy kart składają się z nazw symboli arkuszy i numeru kanału, np. BANKA. Są to skompilowane widoki (widoki fizyczne) projektu, natomiast projekt logiczny pozostaje bez zmian na karcie Editor.
Domyślne wydruki

Karta Default Prints w oknie dialogowym Project Options
Karta Default Prints w oknie dialogowym Project Options umożliwia skonfigurowanie domyślnych wydruków dla różnych edytorów Altium Designer. Te ustawienia domyślne są używane podczas uruchamiania następujących poleceń drukowania z menu głównych edytorów:
- File » Print
- File » Print Preview » Print
Kartę Default Prints okna dialogowego Project Options można również otworzyć z edytora schematów i edytora PCB, wybierając polecenie File » Default Prints z menu głównego.
Opcje i elementy sterujące
Główny obszar karty zawiera listę wszystkich obsługiwanych typów wydruków, które można generować z edytorów schematów i PCB. Typy danych wyjściowych są pogrupowane w następujące kategorie:
-
Assembly Outputs -
Documentation Outputs -
Fabrication Outputs -
Other Outputs -
Report Outputs -
Validation Outputs
Dla każdej pozycji wyświetlane są następujące informacje:
- Output Description – zawartość generowana przy użyciu tego typu wydruku.
- Supports – edytor, w którym ten typ wydruku jest obsługiwany.
-
Default Print – wskazuje, czy ten typ wydruku ma być używany jako domyślny (opcja włączona), czy nie (opcja wyłączona).
Dodatkowe opcje
-
Configure – kliknij ten przycisk, aby otworzyć powiązane okno dialogowe umożliwiające skonfigurowanie aktualnie wybranego wydruku. Dostępne są następujące okna dialogowe:
- Okno dialogowe drukowania – do konfigurowania rysunków montażowych, rysunku zbiorczego, wydruków PCB, wydruków PCBLIB, wydruków schematów, zbiorczego rysunku wierceń, rysunku wierceń/prowadnic, końcowych wydruków dokumentacji produkcyjnej, wydruków płaszczyzn zasilania oraz wydruków maski lutowniczej i maski pasty lutowniczej.
- Okno dialogowe ustawień wydruku PCB 3D – do konfigurowania wydruków PCB 3D.
- Okno dialogowe wideo PCB 3D – do konfigurowania materiałów wideo PCB 3D.
- Okno dialogowe PDF3D – do konfigurowania plików wyjściowych PDF3D i PDF3D MBA.
- Okno dialogowe zaawansowanych właściwości wydruku tekstowego – do konfigurowania wydruków raportów i wydruków tekstowych. Umożliwia zdefiniowanie opcji wydruku (np. nagłówka oraz numeracji stron i wierszy). Można również wskazać konkretną czcionkę.
- Wave Print Properties Form — okno dialogowe do konfigurowania wydruków SimView.
- Okno dialogowe konfiguracji raportu stosu warstw – do konfigurowania raportów stosu warstw płytki.
- Okno dialogowe menedżera raportów – do konfigurowania zestawienia materiałowego i raportów porównania BOM.
- Okno dialogowe konfiguracji eksportu komentarzy – do konfigurowania raportu eksportu komentarzy.
- Okno dialogowe konfiguracji różnic – do konfigurowania raportu różnic.
- Okno dialogowe konfiguracji kontroli reguł elektrycznych – do konfigurowania raportu walidacji kontroli reguł elektrycznych.
- Page Setup – kliknij, aby otworzyć okno dialogowe ustawień strony dla aktualnie wybranego wydruku. W tym oknie można skonfigurować papier, skalowanie i kolory wydruku dla wybranej drukarki. Można również otworzyć odpowiednie okno dialogowe konfiguracji oraz okno ustawień drukarki, wyświetlić podgląd wydruku, a następnie wydrukować go na wybranej drukarce.
Ścieżki wyszukiwania

Karta Search Paths w oknie dialogowym Project Options
Karta Search Paths w oknie dialogowym Project Options umożliwia określenie ścieżek wyszukiwania plików bibliotek i modeli dla projektu.
Opcje i elementy sterujące
Uporządkowana lista ścieżek wyszukiwania
Ta tabela przedstawia uporządkowaną listę ścieżek wyszukiwania plików bibliotek i modeli (np. bibliotek obudów PCB, modeli symulacyjnych i modeli integralności sygnałów). Dla każdej ścieżki można określić filtr i ustawienia przeszukiwania podfolderów.
- Path - lokalizacja ścieżki wyszukiwania.
- Filter - filtr wyszukiwania. Domyślnie filtr wyszukuje wszystkie pliki.
- Recursive - zaznacz, aby przeszukiwać wszystkie podkatalogi katalogu wskazanego w ścieżce wyszukiwania. Kliknij dwukrotnie ścieżkę wyszukiwania, aby ją edytować.
Obsługiwane są następujące typy plików: biblioteki footprintów (*.PcbLib), pliki modeli symulacyjnych (*.mdl), pliki podobwodów symulacyjnych (*.ckt), pliki modeli IBIS (*.ibs).
- Delete - usuwa zaznaczoną ścieżkę wyszukiwania.
- Properties - otwiera okno dialogowe Edit Search Path umożliwiające edycję właściwości zaznaczonej ścieżki wyszukiwania.
- Move Up - przesuwa zaznaczoną ścieżkę wyszukiwania o jeden wiersz w górę.
- Move Down - przesuwa zaznaczoną ścieżkę wyszukiwania o jeden wiersz w dół.
Pliki znalezione we wszystkich ścieżkach wyszukiwania
Ta tabela wyświetla pliki bibliotek i modeli znalezione w ścieżkach z listy Ordered List of Search Paths. Użyj przycisku Refresh List, aby wyświetlić zaktualizowaną listę.
Parametry

Karta Parameters okna dialogowego Project Options
Karta Parameters okna dialogowego Project Options umożliwia zarządzanie parametrami zdefiniowanymi dla projektu, często określanymi jako project-level parameters. Parametry zdefiniowane na poziomie projektu są dostępne we wszystkich arkuszach schematu i dokumentach PCB w projekcie dzięki zastosowaniu ciągów specjalnych: =<ProjectParameterName> na schemacie (np. =Project) oraz .<ProjectParameterName> na PCB (np. .Project). Parametry mogą służyć do dostarczania dodatkowych informacji projektowych. Na przykład parametry na poziomie projektu mogą być używane globalnie jako źródło danych parametrycznych dla ciągów specjalnych dodawanych do arkuszy schematu lub dokumentu PCB — ten ostatni nie obsługuje parametrów lokalnych.
Parametry projektu po stronie Workspace są zapisywane w Workspace wraz z projektem i można je edytować wyłącznie w interfejsie przeglądarkowym Workspace (dowiedz się więcej o Editing a Project w Altium 356 Workspace lub On-Prem Enterprise Workspace). Natomiast parametry projektu po stronie projektu są zapisywane w pliku projektu (*.PrjPcb) i można je edytować w Altium Designer. Parametry projektu po stronie Workspace są wyświetlane na karcie Parameter okna dialogowego Project Options z niebieską ikoną , a parametry po stronie projektu — z pomarańczową ikoną
Opcje/elementy sterujące
-
Parameters Grid – główny obszar zawiera listę wszystkich parametrów aktualnie zdefiniowanych dla projektu, z następującymi informacjami:
- Name – nazwa parametru.
- Value – wartość parametru.
-
Add – kliknij, aby otworzyć okno dialogowe Parameter Properties, w którym możesz dodać parametr. W polach Name i Value podaj odpowiednio opisową nazwę parametru, odzwierciedlającą jego przeznaczenie, oraz jego wartość. Oba pola mogą zawierać maksymalnie 255 znaków.
- Remove – kliknij, aby usunąć zaznaczone parametry z listy parametrów. Ta opcja jest niedostępna dla parametrów projektu po stronie Workspace, ponieważ można je usuwać lub edytować wyłącznie w Workspace.
- Edit – kliknij, aby otworzyć okno dialogowe Parameter Properties, w którym możesz zmodyfikować zawartość aktualnie zaznaczonego parametru. Ta opcja jest niedostępna dla parametrów projektu po stronie Workspace, ponieważ można je usuwać lub edytować wyłącznie w Workspace.
- Refresh – kliknij, aby cofnąć ostatnie zmiany wprowadzone w parametrze po stronie projektu. W przypadku parametrów projektu po stronie Workspace kliknij, aby pobrać najnowszą wersję parametru. Zmiany wprowadzone w parametrach projektu po stronie Workspace w samym Workspace nie będą widoczne w tym oknie dialogowym, dopóki nie użyjesz tej opcji.
Menu kontekstowe
W menu dostępnym po kliknięciu prawym przyciskiem myszy znajdują się następujące polecenia:
-
Edit – umożliwia modyfikację aktualnie zaznaczonego parametru w oknie dialogowym Parameter Properties. To polecenie jest niedostępne dla parametrów projektu po stronie Workspace, ponieważ można je usuwać lub edytować wyłącznie w Workspace.
-
Add – umożliwia dodanie do listy nowego parametru po stronie projektu w oknie dialogowym Parameter Properties.
-
Remove – służy do usuwania wybranych parametrów z listy. To polecenie jest niedostępne dla parametrów projektu pochodzących z przestrzeni roboczej, ponieważ można je usuwać lub edytować wyłącznie w przestrzeni roboczej.
-
Copy – służy do kopiowania wybranych parametrów do schowka systemu Windows.
-
Paste – służy do wklejania parametrów ze schowka systemu Windows na listę parametrów. To polecenie jest niedostępne dla parametrów projektu pochodzących z przestrzeni roboczej, ponieważ można je usuwać lub edytować wyłącznie w przestrzeni roboczej.
Arkusze urządzeń

Karta Device Sheets w oknie dialogowym Project Options
Karta Device Sheets w oknie dialogowym Project Options umożliwia określenie folderów, w których znajdują się arkusze urządzeń, oraz ich kolejności.
Opcje/elementy sterujące
- Main region – wyświetla Device Sheet Folders ścieżki dla bieżącego projektu. Zaznacz Include Sub-folders , aby uwzględnić podfoldery wymienionych folderów nadrzędnych.
- Move Up – służy do przesuwania wybranego folderu arkuszy urządzeń o jedną pozycję w górę.
- Move Down – służy do przesuwania wybranego folderu arkuszy urządzeń o jedną pozycję w dół.
- Add – służy do otwierania okna dialogowego umożliwiającego wyszukanie nowego folderu do dodania.
- Remove – służy do usuwania wybranego folderu arkuszy urządzeń.
Zarządzane zadania wyjściowe

Karta Managed OutputJobs w oknie dialogowym Project Options
Karta Managed OutputJobs w oknie dialogowym Project Options umożliwia skonfigurowanie listy szablonów zadań wyjściowych dostępnych w połączonej przestrzeni roboczej, które mają być używane w projekcie.
Opcje/elementy sterujące
- Outputjob List – wyświetla wszystkie zadania wyjściowe z przestrzeni roboczej wraz z informacjami: Item Revision, Revision State, Description i Name.
- Add – kliknij, aby otworzyć okno dialogowe Select configuration item (Output Jobs) i wybrać żądane zadania wyjściowe.
- Remove – kliknij, aby usunąć wybrane zadania wyjściowe.
Opcje biblioteki

Karta Library Options w oknie dialogowym Project Options
Karta Library Options w oknie dialogowym Project Options umożliwia wybranie formatu projektu biblioteki zintegrowanej.
Opcje/elementy sterujące
-
Integrated Library Format
- Original – wybierz, aby użyć oryginalnego formatu biblioteki zintegrowanej. Służy on do zapewnienia zgodności z oprogramowaniem Protel DXP (DXP 2002), sprzed pojawienia się Altium Designer.
-
Altium Designer– wybierz, aby użyć formatu biblioteki zintegrowanej Altium Designer (stosowanego we wszystkich wersjach oprogramowania od pierwszej wersji Altium Designer 2004).
).
