Praca z pomieszczeniami na płytce drukowanej
W skrócie
- Dowiesz się, czym jest obszar typu Room na PCB i jak służy do kontrolowania rozmieszczenia obiektów oraz wymagań projektowych w wyznaczonej części płytki.
- Poznasz główne metody tworzenia obszarów Room w edytorze PCB, w tym umieszczanie interaktywne, tworzenie na podstawie wybranych komponentów oraz za pomocą ograniczeń projektowych.
- Zrozumiesz, jak obiekty Room współdziałają z ograniczeniami Room Definition w Altium Designer, również w edytorze PCB Rules and Constraints Editor oraz w narzędziu Constraint Manager.
Podsumowanie
Pokój to zdefiniowany obszar na jednej z zewnętrznych warstw PCB. Służy do określania wymagań projektowych w danym obszarze płytki, takich jak: these components must be in this area, route these nets this width lub use routing vias of this size.
Pokój umieszcza się podobnie jak inne obiekty wielokątne — jako prostokąt lub wielokąt.
Oprócz tego, że każdy pokój istnieje na płytce jako nazwany kształt w płaszczyźnie X-Y, automatycznie staje się również nazwanym ograniczeniem projektowym Definicja pokoju Ustawienia tego ograniczenia określają: objects, których dotyczy pokój, czy obiekty te mają pozostawać inside or outside pokoju oraz layer, na której pokój obowiązuje.
Oprócz prostego wymagania keep these objects in (or out), określanego bezpośrednio przez ograniczenie Definicja pokoju, pokój może również służyć do wyznaczania obszaru płytki, w którym obowiązują inne ograniczenia projektowe. Na przykład ścieżki pod układem BGA mogą wymagać określonej szerokości , a prowadzenie par różnicowych pod układem BGA może wymagać zastosowania określonego profilu impedancji
Dostępność
Pokoje można umieszczać i tworzyć wyłącznie w edytorze PCB. Aby utworzyć pokoje, skorzystaj z następujących metod:
-
Wybierz odpowiednie polecenie z podmenu Design » Rooms , a następnie interaktywnie zdefiniuj kształt pokoju (jeśli wybrano polecenie Place) lub utwórz pokój automatycznie (jeśli wybrano polecenie Create).
-
Dodaj nowe ograniczenie projektowe Room Definition, przejdź do jego edycji, a następnie kliknij przycisk Define, aby interaktywnie zdefiniować kształt pokoju wielokątnego.
-
Utwórz pokój na podstawie zaznaczonego zamkniętego obrysu utworzonego z odcinków ścieżek i łuków, korzystając z polecenia Tools » Convert » Create Room from Selected Primitives.
-
Automatycznie twórz pokoje podczas synchronizacji schematu z projektem PCB. Dowiedz się więcej o automatycznie generowanych pokojach (w tym o sposobie wyłączenia ich generowania).
Tworzenie pokoju
Procedura tworzenia pokoju w dokumencie PCB zależy od tego, czy pokój jest umieszczany interaktywnie, czy tworzony, oraz od wybranej metody umieszczania lub tworzenia.
Dostępne są różne techniki umieszczania i tworzenia pokoi.
Interaktywne umieszczanie pokoju
Pokoje prostokątne lub wielokątne można umieszczać na górnej lub dolnej warstwie projektu. Pamiętaj, że choć można je umieszczać przy dowolnej aktywnej warstwie, warstwa, której dotyczą, jest przypisywana w ramach ograniczenia projektowego Definicja pokoju.
Pokój prostokątny
Po uruchomieniu polecenia Design » Rooms » Place Rectangular Room kursor zmieni się w krzyżyk i zostanie włączony tryb umieszczania pokoju. Aby umieścić pokój, wykonaj następujące czynności:
-
Kliknij lub naciśnij Enter, aby ustalić pierwszy narożnik pokoju.
-
Aby na bieżąco edytować właściwości powiązanego ograniczenia Definicja pokoju, podczas umieszczania naciśnij klawisz Tab .
-
Przesuń kursor, aby dostosować rozmiar pokoju, a następnie kliknij lub naciśnij Enter, aby ustalić narożnik po przekątnej i zakończyć umieszczanie pokoju.
-
Kontynuuj umieszczanie kolejnych pokoi lub kliknij prawym przyciskiem myszy albo naciśnij Esc, aby wyjść z trybu umieszczania.
Pokój wielokątny
Po uruchomieniu polecenia Design » Rooms » Place Polygonal Room kursor zmieni się w krzyżyk i zostanie włączony tryb umieszczania pokoju. Aby umieścić pokój, wykonaj następujące czynności:
-
Ustaw kursor, a następnie kliknij, aby ustalić punkt początkowy pokoju.
-
Ustawiaj kursor i klikaj, aby wyznaczyć kolejne wierzchołki definiujące wielokątny kształt pokoju.
-
Po umieszczeniu ostatniego wierzchołka kliknij prawym przyciskiem myszy lub naciśnij Esc, aby zakończyć umieszczanie pokoju. Nie trzeba zamykać wielokąta, ponieważ oprogramowanie automatycznie dopełni kształt, łącząc punkt początkowy z ostatnim umieszczonym punktem.
-
Kontynuuj umieszczanie kolejnych pokoi wielokątnych lub kliknij prawym przyciskiem myszy albo naciśnij Esc, aby wyjść z trybu umieszczania.
Na podstawie zaznaczonych komponentów
Jeśli komponenty są już rozmieszczone na płytce i chcesz utworzyć nowy pokój dopasowany do ich rozmieszczenia, użyj jednego z trzech poleceń Create xxx Room from selected components. Za pomocą tych poleceń można automatycznie tworzyć pokoje nieortogonalne, ortogonalne i prostokątne na podstawie komponentów aktualnie zaznaczonych w obszarze projektowym. W każdym przypadku sposób tworzenia jest taki sam:
-
Zaznacz wszystkie komponenty, dla których chcesz utworzyć pokój. Aby zaznaczyć komponenty PCB ze schematu, uruchom polecenie Tools » Cross Select Mode, a następnie zaznacz komponenty na schemacie.
-
W edytorze PCB uruchom odpowiednie polecenie tworzenia (Design » Rooms » Create xxx Room from selected components). Automatycznie zostanie utworzona klasa komponentów obejmująca zaznaczone komponenty (chyba że taka klasa już istnieje).
-
Następnie tworzony jest obszar typu Room wybranego typu, a jego reguła projektowa Room Definition zostaje automatycznie powiązana z utworzoną klasą komponentów.
-
Rozmiar obszaru Room zostanie odpowiednio dopasowany tak, aby pomieścić wszystkie zaznaczone komponenty, na podstawie ich prostokątów zaznaczenia.
-
Jeśli klikniesz i przeciągniesz obszar Room, aby go przesunąć, przesuną się również wszystkie komponenty należące do powiązanej klasy komponentów.
Ortogonalny obszar Room jest tworzony na podstawie komponentów PCB wybranych wcześniej na schemacie.
Przez dodanie ograniczenia projektowego Room Definition
Nowy obszar Room można również utworzyć, definiując nowe ograniczenie w PCB Rule and Constraints Editor lub w Constraint Manager.
Która metoda definiowania ograniczeń projektowych jest używana?
Altium Designer obsługuje dwie odrębne metody definiowania ograniczeń projektowych: za pomocą Menedżera ograniczeń oraz Edytora reguł i ograniczeń PCB.
PCB Rule and Constraints Editor był pierwszym interfejsem opracowanym do definiowania ograniczeń w edytorze PCB. Jeśli używany jest PCB Rule and Constraints Editor, projektant definiuje: what objects the constraint (rule) applies to oraz how those objects are to be constrained. Zaletą tej metody jest możliwość precyzyjnego wskazania obiektów, które mają podlegać ograniczeniom — mogą one obejmować wszystkie obiekty (na przykład wszystkie sieci) lub dotyczyć konkretnego obiektu na płytce (danego pola lutowniczego). Tę elastyczną metodę wskazywania obiektów projektu zapewnia mechanizm reguł oparty na języku zapytań.
Constraint Manager umożliwia definiowanie ograniczeń z perspektywy obiektów. Projektant pracuje z obiektami, przypisując im różne ograniczenia elektryczne i fizyczne wymagane w projekcie, w interfejsie przypominającym arkusz kalkulacyjny. Obiekty zaznaczone w Constraint Manager są jednocześnie podświetlane w edytorze graficznym. Pozwala to łatwo konfigurować i sprawdzać wszystkie wymagania dotyczące danego obiektu, na przykład: ta klasa sieci ma być trasowana z określoną szerokością i odstępem, przy użyciu określonej przelotki oraz stylu połączenia z poligonem. Można również wymagać, aby dana klasa sieci była trasowana na wskazanych warstwach, z określonymi impedancjami. Taki widok zorientowany na obiekty nie jest dostępny w PCB Rule and Constraints Editor. Ostatecznie oprogramowanie przekształca ograniczenia zorientowane na obiekty do tego samego formatu reguł, który jest definiowany w PCB Rule and Constraints Editor. Aby je wyświetlić, po otwarciu ograniczeń z edytora PCB przełącz się do widoku All Rules.
Na tej stronie dokumentacji przedstawiono ilustracje ograniczeń definiowanych zarówno w oknie dialogowym PCB Rule and Constraints Editor, jak i w Constraint Manager. Należy pamiętać, że terminy constraint i rule są używane zamiennie.
Dodawanie nowego ograniczenia projektowego Room Definition
W Edytorze reguł i ograniczeń PCB
Dla każdego umieszczonego lub utworzonego obszaru Room automatycznie tworzone jest powiązane ograniczenie projektowe Room Definition. Działa to również w drugą stronę: po dodaniu nowej reguły tego typu w przestrzeni projektowej pojawi się odpowiadający jej obiekt Room. Zależność ta dotyczy także usuwania: usunięcie obszaru Room w edytorze graficznym powoduje automatyczne usunięcie ograniczenia, a usunięcie ograniczenia projektowego powoduje usunięcie obiektu graficznego.
Jeśli ograniczenie obszaru Room jest definiowane w PCB Rules and Constraint Editor, tworzony jest domyślny obiekt Room o wymiarach 5 × 5 cali, w odległości 1 cala od bezwzględnego początku układu współrzędnych (w lewym dolnym rogu przestrzeni edycji). Należy pamiętać, że znacznik początku układu współrzędnych wskazuje względny początek układu współrzędnych zdefiniowany przez użytkownika, który można ustawić w dowolnym miejscu przestrzeni edycji.
Po dodaniu nowego ograniczenia obszaru Room w przestrzeni edycji definiowany jest domyślny obszar Room.
Po dodaniu ograniczenia można wrócić do przestrzeni edycji i edytować graficznie obszar Room. Można też w PCB Rules and Constraints Editor edytować ograniczenie obszaru Room, a następnie kliknąć przycisk Define, aby interaktywnie zdefiniować jego kształt. Ponieważ Room wyznacza obszar na płytce, częściej umieszcza się go interaktywnie, co powoduje automatyczne utworzenie ograniczenia projektowego.
Dowiedz się więcej o dodawaniu nowego ograniczenia w Edytorze reguł i ograniczeń PCB.
W Menedżerze ograniczeń
Aby utworzyć nowe ograniczenie obszaru (Room) w Constraint Manager:, przełącz się do widoku All Rules, wybierz Room Definition w kategorii Placement, a następnie kliknij prawym przyciskiem myszy listę reguł zaawansowanych i wybierz Add Advanced Rule z menu kontekstowego, jak pokazano poniżej.
Nowe ograniczenie obszaru Room można dodać w Menedżerze ograniczeń.
Na tym etapie obiekt Room nie istnieje jeszcze w graficznej przestrzeni edycji. Należy teraz kliknąć przycisk Define (co spowoduje przejście do edytora PCB) i zdefiniować kształt obszaru Room. Po wykonaniu tej czynności istnieją już zarówno ograniczenie obszaru Room, jak i sam obiekt Room, a ograniczenia można zapisać.
-
Jeśli ograniczenie obszaru Room ma służyć do wymuszania umieszczania obiektów wewnątrz tego obszaru płytki (lub poza nim), następnym krokiem jest skonfigurowanie Object Match oraz pozostałych ustawień ograniczenia u dołu Constraint Manager. Więcej informacji znajdziesz poniżej.
-
Jeśli ograniczenie obszaru Room ma służyć jako definicja obszaru w innym typie ograniczenia, na przykład szerokości ścieżek, więcej informacji znajdziesz w sekcji Definiowanie ograniczeń wewnątrz obszaru Room.
Dowiedz się więcej o dodawaniu nowego ograniczenia w Menedżerze ograniczeń.
Czym jest ograniczenie obszaru Room?
Jak wspomniano wcześniej, Room to zdefiniowany obszar na jednej z zewnętrznych warstw PCB, służący do określania wymagań projektowych obowiązujących w tej części płytki.
Wszystkie ograniczenia projektowe mają dwa kluczowe elementy:
-
what objects this constraint applies to oraz
-
how those objects are to be constrained
Jeśli ograniczenie obszaru Room zdefiniowano w części płytki, w której nie ma komponentów, kryterium Object Match (the objects this constraint applies to) przyjmuje domyślnie wartość False, co oznacza, że ograniczenie nie dotyczy żadnych obiektów. W razie potrzeby zmień to ustawienie.
Nowo utworzona definicja obszaru Room. Zwróć uwagę, że zakres reguły ma wartość False, co oznacza, że nie dotyczy ona żadnych obiektów.
Ograniczanie klasy komponentów
Typowym sposobem wykorzystania ograniczenia obszaru jest określenie położenia klasy komponentów i przypisanie jej na stałe do określonego obszaru płytki.
Klasa komponentów Encoder jest ograniczona do obszaru o nazwie Room-Encoder na górnej warstwie płytki.
Powyższy obraz przedstawia, jak klasa komponentów Encoder jest ograniczona within obszaru Room-Encoder na Top side płytki w PCB Rules and Constraints Editor (zasadniczo tak samo jak w Constraint Manager Po przypisaniu komponentów do obszaru przemieszczają się one wraz z nim. Aby przesunąć obszar bez przesuwania komponentów, tymczasowo wyłącz powiązaną regułę Room Definition.
Dowiedz się więcej o ograniczeniu projektowym Room Definition.
Edytor PCB zawiera szereg zaawansowanych narzędzi do pracy z obszarami. Więcej informacji znajdziesz w sekcji Praca z obszarami na tej stronie.
Oprócz tego, że obszar sam w sobie stanowi ograniczenie projektowe (Room Definition), może również służyć jako obiekt zawężający zakres innego ograniczenia projektowego do określonej części płytki, na przykład Width, Clearance lub Via Style. Temat ten omówiono w sekcji Definiowanie ograniczeń wewnątrz obszaru na tej stronie.
Tworzenie podczas synchronizacji schematu z projektem PCB
Podczas przenoszenia projektu ze schematu na PCB można utworzyć osobny obszar zawierający komponenty z każdego arkusza schematu. W wielopoziomowym projekcie hierarchicznym może to być mało przydatne, ale w dużym projekcie płaskim osobny obszar dla każdego arkusza może ułatwić rozmieszczanie komponentów na płytce.
Karta Class Generation w oknie dialogowym Project Options zawiera opcje generowania obszarów dla każdego arkusza w projekcie Jeśli opcja Generate Rooms jest zaznaczona, po uruchomieniu polecenia Design » Update dla danego arkusza zostanie utworzony obszar, do którego zostanie przypisana klasa obejmująca wszystkie komponenty z tego arkusza. Pamiętaj, że komponenty z każdego arkusza są dodawane do klasy komponentów, dlatego opcja Generate Rooms wymaga również włączenia odpowiadającej jej opcji Component Class.
Na PCB każde ograniczenie obszaru jest tworzone z zakresem InComponentClass('<SheetSymbolDesignator>'). Obszar nie zostanie utworzony, jeśli arkusz nie zawiera żadnych komponentów. Podczas pierwszego przeniesienia schematu na PCB komponenty należące do każdej klasy są ustawiane w rzędzie, a następnie wokół danej klasy komponentów tworzony jest obszar, jak pokazano na poniższym obrazie.
Odznacz pola wyboru Generate Rooms w oknie dialogowym Project Options, jeśli automatycznie generowane obszary nie są potrzebne.
PCB po początkowej synchronizacji projektu — dla każdego arkusza utworzono obszar i przypisano do niego klasę komponentów z tego arkusza.
Dowiedz się więcej o automatycznym generowaniu obszarów, klas komponentów i klas sieci na podstawie projektu schematu.
Aby dowiedzieć się więcej o synchronizacji projektu, zapoznaj się ze stroną Utrzymywanie synchronizacji schematów i PCB.
Na podstawie zaznaczonych ścieżek i łuków
Obiekt obszaru można zdefiniować za pomocą zamkniętego obrysu utworzonego z zaznaczonych ścieżek i/lub łuków. W tym celu zaznacz w przestrzeni projektowej wszystkie obiekty podstawowe ścieżek i łuków tworzące zamknięty obrys, a następnie wybierz polecenie Tools » Convert » Create Room from Selected Primitives z menu głównego. Poniższy pokaz slajdów przedstawia kolejne kroki.
|
Na warstwie mechanicznej umieszczono ścieżki, aby określić przestrzeń płytki dostępną dla komponentów Encoder. Uruchom polecenie Tools » Convert » Create Room from Selected Primitives, aby utworzyć ograniczenie Room Definition o takim samym kształcie. Pojawi się okno dialogowe Edit Room Definition, w którym można zdefiniować parametry ograniczenia. Do tego obszaru przypisywana jest klasa komponentów Aby dostosować kształt obszaru, kliknij go, aby go zaznaczyć, a następnie uruchom polecenie Design » Rooms » Edit Polygonal Verticies, po czym kliknij wierzchołek lub krawędź, aby zmienić kształt obszaru. |
Edycja obszaru
Kształt obszaru w płaszczyźnie X-Y i jego położenie na płytce można modyfikować interaktywnie. Pamiętaj, że istnieją dwa różne sposoby interaktywnej edycji obszaru: na podstawie jego prostokąta zaznaczenia (opisany w sekcji Zmiana rozmiaru i położenia) lub na podstawie wierzchołków edycji kształtu (opisany w sekcji Zmiana kształtu).
Oprócz korzystania z poleceń w podmenu Design » Rooms można również uzyskać dostęp do poleceń kontekstowych dotyczących obszaru, klikając umieszczony obszar prawym przyciskiem myszy i wybierając podmenu Room Actions.
Kliknij obszar prawym przyciskiem myszy, aby uzyskać dostęp do poleceń dotyczących obszaru.
Zmiana rozmiaru i położenia
Po jednokrotnym kliknięciu obszaru w celu jego zaznaczenia dostępne stają się następujące uchwyty edycji — niezależnie od tego, czy obszar został pierwotnie umieszczony jako prostokąt, czy jako wielokąt:
Uchwyty edycji pojawiają się po kliknięciu obszaru Room w celu jego zaznaczenia.
Zmiana rozmiaru obszaru Room
-
Przeciąganie uchwytów narożnych (A) skaluje obszar Room jednocześnie w poziomie i w pionie.
-
Przeciąganie uchwytu krawędzi (B) skaluje obiekt w danym kierunku (w poziomie lub w pionie).
-
Podczas przeciągania obszar Room można obracać lub odbijać, naciskając:
-
Spacebar, aby obrócić obiekt w lewo, lub Shift+Spacebar , aby obrócić go w prawo. Obrót odbywa się zgodnie z wartością kroku obrotu zdefiniowaną na stronie PCB Editor - General w oknie dialogowym Preferences.
-
X lub Y, aby odbić obiekt względem osi X lub Y.
-
L, aby przenieść obiekt na drugą stronę płytki. Jeśli z obszarem Room są powiązane komponenty, zostaną one przeniesione wraz z nim.
-
Przenoszenie obszaru Room
Kliknij i przeciągnij obszar Room, aby przenieść go w nowe miejsce. Obiekt Room można również przenieść za pomocą polecenia Design » Rooms » Move Room z menu głównego lub polecenia Room Actions » Move Room z menu kontekstowego obszaru Room. Po uruchomieniu polecenia kursor przyjmie postać krzyżyka i zostanie włączony tryb przenoszenia obszarów Room — kliknij obszar Room, aby go przenieść.
Po kliknięciu obszaru Room w celu jego przeniesienia:
-
Obszar Room zostanie dołączony do kursora. Punkt uchwycenia obszaru Room zależy od bieżącego ustawienia Object Snap Options , a kursor jest przyciągany do najbliższego z włączonych punktów przyciągania (pola lutowniczego komponentu, punktu odniesienia komponentu lub wierzchołka obszaru Room).
-
Przenieś obszar Room w żądane miejsce, a następnie kliknij lub naciśnij Enter , aby go umieścić.
-
Kontynuuj przenoszenie kolejnych obszarów Room albo kliknij prawym przyciskiem myszy lub naciśnij Esc, aby zakończyć.
-
Jeśli przenoszony obszar Room zawiera komponenty, podczas przenoszenia można wyświetlić zielone dynamiczne prowadnice wyrównania, naciskając klawisze Shift lub Ctrl. Użyj Shift, aby zachować przyciąganie do aktywnej siatki, lub Ctrl, aby tymczasowo wyłączyć przyciąganie do siatki i wyrównać do istniejącego obiektu znajdującego się poza siatką.
-
Jeśli obszar Room zawiera obiekty nieprzypisane do żadnej sieci i/lub obiekty zablokowane, otworzy się okno dialogowe Room containing No Net/Locked Objects. Określ w nim, czy te obiekty mają być przenoszone wraz z obszarem Room, a następnie kliknij OK. Aby to okno dialogowe było wyświetlane, opcja Ask when moving rooms containing No Net/Locked Objects musi być włączona na stronie PCB Editor - General okna dialogowego Preferences

Okno dialogowe Room containing No Net / Locked Objects
Okno dialogowe obszaru Room zawierającego obiekty bez przypisanej sieci / zablokowane |
|
| No Net Objects | Włącz, aby przenosić obiekty bez przypisanej sieci wraz z obszarem Room. |
| Locked Objects | Włącz, aby przenosić zablokowane obiekty wraz z obszarem Room. |
| Don't ask me about moving room's locked/no net objects until next PCB session (use currently selected settings) | Włącz tę opcję, aby zapisać wybrane ustawienia i korzystać z nich do końca bieżącej sesji edycji PCB. Okno dialogowe nie pojawi się ponownie do czasu rozpoczęcia nowej sesji. |
Zmiana kształtu
Kształt granicy obszaru Room można zmienić za pomocą polecenia Edit Polygonal Room Vertices. Polecenie to jest dostępne w podmenu Design » Rooms lub w podmenu kontekstowym Room Actions otwieranym prawym przyciskiem myszy.
Po uruchomieniu polecenia zostaną wyświetlone uchwyty edycji granicy wielokątnego obszaru Room. Możesz wtedy:
-
Kliknąć uchwyt A, a następnie przesunąć kursor, aby przemieścić dany wierzchołek. Kliknij ponownie w nowym miejscu, aby umieścić wierzchołek.
-
Podczas przesuwania uchwytu A naciśnij klawisz Delete na klawiaturze, aby usunąć ten wierzchołek z obszaru Room.
-
Kliknij B lub kliknij krawędź (pomiędzy uchwytami), a następnie przesuń kursor, aby przesunąć tę krawędź. Naciskaj Shift+Spacebar podczas przesuwania krawędzi, aby przełączać dostępne tryby zachowania krawędzi (przesuwanie, łamanie i zakrzywianie krawędzi).
-
Ctrl+Click B lub Ctrl+Click na krawędzi, a następnie przesuń kursor, aby dodać do niej wierzchołek i go przesunąć. Kliknij ponownie w nowym miejscu, aby umieścić wierzchołek. W efekcie nowy wierzchołek staje się wierzchołkiem A, a między nim a pierwotnymi wierzchołkami A dodawane są nowe wierzchołki B.
-
Aby uzyskać dostęp do uchwytu znajdującego się poza siatką, przytrzymaj klawisz Ctrl, aby tymczasowo wyłączyć przyciąganie do siatki.
-
Kontynuuj modyfikowanie kształtu obszaru Room według potrzeb albo kliknij prawym przyciskiem myszy lub naciśnij Esc, aby zakończyć. Wyświetlany obszar Room zostanie zaktualizowany zgodnie z nowym kształtem granicy.
Tego polecenia można użyć niezależnie od tego, czy dany obszar Room jest zablokowany.
Dzielenie obszaru Room
Dostępne są polecenia umożliwiające graficzne slice umieszczonego obiektu Room na dwa lub więcej oddzielnych obszarów Room. Proces dzielenia przypomina umieszczanie linii i obejmuje te same tryby narożników (w rzeczywistości szerokość obiektu tnącego jest równa bieżącej domyślnej szerokości linii). Należy pamiętać, że obiekty służące do wyświetlania przebiegu cięcia nie są umieszczane w projekcie — służą wyłącznie do pokazania przebiegu cięcia i są usuwane po zakończeniu dzielenia. Nie trzeba też rozpoczynać cięcia dokładnie na krawędzi obszaru Room. Łatwiej jest rozpocząć je nieco poza obszarem Room i również zakończyć nieco poza nim.
Dostępne są dwa polecenia podziału. Proces definiowania ścieżki podziału jest w obu przypadkach taki sam. Polecenia różnią się sposobem obsługi komponentów znajdujących się w dzielonym obszarze Room. Różnice między nimi wyjaśniono po opisie procesu podziału.
|
Kliknij prawym przyciskiem myszy obszar Room, aby uzyskać dostęp do poleceń Slice w menu Room Actions. Zdefiniowano dwie ścieżki podziału, korzystając z procesu opisanego poniżej. Utworzono trzy obszary Room. |
Proces podziału
Po uruchomieniu polecenia Slice:
-
Kursor przyjmuje postać krzyżyka i pojawia się monit o wybranie punktu początkowego ścieżki podziału.
-
Umieść kursor tuż poza obszarem Room, który chcesz podzielić, a następnie kliknij lub naciśnij Enter. Aktywny jest teraz tryb podziału (działający zasadniczo jak tryb wstawiania linii).
-
Przesuń kursor do wnętrza obszaru Room, aby zdefiniować pierwszy odcinek ścieżki podziału, a następnie kliknij lub naciśnij Enter, aby ustalić koniec tego odcinka.
-
Kontynuuj przesuwanie kursora i klikanie, definiując kolejne wierzchołki określające kształt ścieżki podziału.
-
Po wstawieniu ostatniego wierzchołka (tuż poza obszarem Room) kliknij prawym przyciskiem myszy lub naciśnij Esc, aby zakończyć wstawianie tej ścieżki podziału.
-
Możesz teraz rozpocząć kolejną ścieżkę podziału obszaru Room albo kliknąć prawym przyciskiem myszy lub nacisnąć Esc, aby wyjść z trybu podziału.
-
Otworzy się okno dialogowe z potwierdzeniem, informujące, na ile obszarów Room zostanie podzielony pierwotny obszar. Kliknij Yes, aby zatwierdzić wykonane podziały, lub No , aby je odrzucić. Powstałe obiekty Room zostaną odpowiednio zaktualizowane, a odpowiednie reguły Room Definition zostaną utworzone i z nimi powiązane.
-
Podczas podziału naciśnij:
-
Shift+Spacebar, aby przełączać tryby narożników.
-
Spacebar, aby zmienić kierunek narożnika.
-
Każdy odcinek ścieżki podziału wymaga punktu początkowego i końcowego.
-
Jeśli tryb wstawiania ścieżki podziału uwzględnia narożnik, użyj skrótu 1, aby przełączać między wstawianiem jednego a dwóch odcinków na kliknięcie.
-
Backspace, aby usunąć ostatnio wstawiony odcinek ścieżki podziału.
-
Ponowne dopasowywanie istniejącego obszaru Room
Innym sposobem zmiany kształtu istniejącego obszaru Room jest ponowne dopasowanie go do komponentów należących do przypisanej mu klasy. Zarówno podmenu Room Actions dostępne po kliknięciu prawym przyciskiem myszy, jak i podmenu Design » Rooms zawierają trzy polecenia Wrap Room, jak pokazano w pokazie slajdów.
|
Jeśli zmienisz rozmieszczenie komponentów w obszarze Room, użyj jednego z trzech poleceń Wrap , aby zaktualizować jego kształt. Polecenie Wrap Non-Orthogonal umieszcza krawędzie obszaru Room tak, aby łączyły skrajne punkty obrysów komponentów. Polecenie Wrap Orthogonal umieszcza pionowe i poziome krawędzie obszaru Room wokół obrysów komponentów. Polecenie Wrap Rectangular tworzy najmniejszy prostokątny obszar Room obejmujący obrysy komponentów. |
Edycja w panelu Properties
Obiekt Room jest nietypowy, ponieważ stanowi jednocześnie obiekt i ograniczenie projektowe.
Edycja w panelu Properties
Właściwości obiektu Room, w tym jego położenie i kształt w obszarze edycji, można edytować w panelu Properties po zaznaczeniu obszaru Room. Panel można wyświetlić za pomocą przycisku Panels Panels w prawym dolnym rogu obszaru projektowego lub polecenia View » Panels » Properties.
Panel Properties umożliwia edycję właściwości graficznych obszaru Room.
| Name | Bieżąca nazwa obszaru Room (i powiązanej reguły Room Definition). Można ją zmienić w razie potrzeby. Oprócz ułatwiania identyfikacji poszczególnych obszarów Room nazwa umożliwia wskazanie konkretnego obszaru w regule projektowej. |
| (X/Y) (dwa pola) | Bieżące współrzędne X i Y pierwszego wierzchołka obszaru Room względem bieżącego początku układu współrzędnych. Edytuj wartość w polu, aby zmienić położenie obszaru Room względem bieżącego początku układu współrzędnych. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; jeśli używasz jednostek innych niż domyślne, podaj je wraz z wartością. Domyślne jednostki (metryczne lub imperialne) są wyświetlane na pasku stanu i ustawiane w sekcji Other panelu Properties (gdy w przestrzeni projektowej nie są zaznaczone żadne obiekty). Wartości te można edytować tylko wtedy, gdy opcja X/Y jest odblokowana (wyświetlana jest ikona |
Wierzchołki obrysu |
|
| Vertices Grid | Lista wszystkich wierzchołków aktualnie zdefiniowanych dla obszaru Room, w kolejności ich definiowania podczas umieszczania obszaru. Kolejne wierzchołki są łączone odcinkami prostymi. Jeśli zamiast tego chcesz użyć połączenia łukowego, wprowadź odpowiednią wartość Arc Angle. Wartość należy wprowadzić w polu przypisanym do wierzchołka początkowego — łuk będzie łączył ten wierzchołek z następnym wierzchołkiem poniżej na liście. Kliknij prawym przyciskiem myszy, aby wybrać Copy / Paste lub Import / Export to CSV. |
| Index | Indeks przypisany do wierzchołka (nieedytowalny, zgodny z kolejnością umieszczania wierzchołków podczas definiowania obszaru Room). |
| X | Współrzędna X (pozioma) wierzchołka. Kliknij, aby edytować. |
| Y | Współrzędna Y (pionowa) wierzchołka. Kliknij, aby edytować. |
| Arc Angle (Neg = CW) | Kąt łuku łączącego ten wierzchołek z następnym. Domyślnie połączenia są odcinkami prostymi, a to pole pozostaje puste. Kliknij, aby edytować, a następnie wprowadź wymagany kąt łuku. Wprowadzenie wartości dodatniej spowoduje narysowanie łuku przeciwnie do ruchu wskazówek zegara. Aby narysować łuk zgodnie z ruchem wskazówek zegara, wprowadź wartość ujemną. |
Praca z obszarami Room
Oprogramowanie zawiera szereg funkcji ułatwiających pracę z obszarami Room i znajdującymi się w nich obiektami. Obejmują one polecenia umożliwiające rozmieszczanie obszarów Room w układzie siatki, przesuwanie ich do bieżącej siatki przyciągania oraz — w projektach zawierających powtarzające się fragmenty układu — kopiowanie rozmieszczenia elementów i trasowania z jednego obszaru Room do drugiego.
Obszaru Room można również użyć do ograniczenia zakresu obowiązywania innych ograniczeń projektowych do określonego obszaru płytki, wymagając na przykład, aby w tym obszarze sieci były trasowane z określoną szerokością i odstępem lub aby pary różnicowe były trasowane z określonym profilem impedancji.
Mikser 8-kanałowy: rozmieszczono elementy i poprowadzono ścieżki pierwszego kanału wejściowego, a następnie powielono je w pozostałych siedmiu kanałach wejściowych za pomocą polecenia Copy Room Format.
Definiowanie ograniczeń w obszarze Room
Oprócz wymuszania umieszczania obiektów wewnątrz lub na zewnątrz obszaru Room (zgodnie z opisem w sekcji Ograniczenie projektowe definicji obszaru Room), obszar Room może również służyć do ograniczania zakresu obowiązywania innych ograniczeń projektowych. Na przykład ograniczenie szerokości ścieżek może wymagać stosowania innych szerokości pod układem BGA, a ograniczenie odstępów elektrycznych może wymagać innych odstępów w określonym obszarze płytki.
Szerokość ścieżek i odstępy są automatycznie dostosowywane w obrębie obszaru Room zgodnie z ustawieniami jego definicji.
Uzyskuje się to przez dodanie ograniczeń szerokości ścieżek i odstępów elektrycznych pokazanych w poniższym pokazie slajdów.
W menedżerze ograniczeń
Po dodaniu ograniczenia obszaru Room w widoku All Rules w Constraint Manager obiekt tego obszaru Room staje się również dostępny w widoku Physical. W tym widoku można szybko zdefiniować ograniczenia obowiązujące w obrębie obszaru Room, takie jak: szerokość ścieżek, odstępy elektryczne, typ przelotek, właściwości par różnicowych, zwężenia ścieżek i sposób łączenia z poligonami. Poniższy pokaz slajdów przedstawia ograniczenia dla płytki z filmu powyżej.
|
W tym obszarze Room wszystkie obiekty trasowania muszą mieć szerokość mieszczącą się w określonym zakresie. W tym obszarze Room wszystkie obiekty trasowania muszą zachowywać co najmniej taki odstęp od obiektów należących do innych sieci. W tym obszarze Room wszystkie obiekty trasowania muszą zachowywać co najmniej taki odstęp elektryczny. W tym obszarze Room wszystkie pary różnicowe muszą być trasowane z użyciem profilu impedancji |
W edytorze reguł i ograniczeń PCB
Aby uzyskać ten sam efekt w PCB Rules and Constraint Editor, należy utworzyć zapytanie definiujące obszar Room. Obiekty w obszarze Room można wykrywać na dwa sposoby: wybierając obiekty znajdujące się w całości wewnątrz obszaru Room (za pomocą słowa kluczowego WithinRoom) lub obiekty stykające się z obszarem Room (za pomocą słowa kluczowego TouchesRoom). Poniższy pokaz slajdów przedstawia te same ustawienia szerokości ścieżek, odstępów elektrycznych, typu przelotek i właściwości par różnicowych, które pokazano w poprzednim Constraint Manager pokazie slajdów.
Rozmieszczanie zaznaczonych obszarów Room
Aby rozmieścić zaznaczone obszary Room w przestrzeni projektowej, można użyć polecenia Design » Rooms » Arrange Rooms. Zaznacz wymagane obszary Room, a następnie uruchom polecenie, aby otworzyć okno dialogowe Arrange Rooms.
Okno dialogowe Arrange Rooms.
Określ sposób rozmieszczenia obszarów Room oraz kolejność ich umieszczania. Możesz również określić pozycję początkową — wprowadzając współrzędne X-Y w oknie dialogowym lub klikając w obszarze roboczym — a także odstępy między sąsiednimi obszarami Room. Po kliknięciu OK zaznaczone obszary Room zostaną przeniesione na wskazane pozycje.
Kolumny/wiersze |
|
| Columns | Liczba kolumn używanych do rozmieszczenia obszarów Room. W razie potrzeby edytuj to pole. |
| Rows | Liczba wierszy używanych do rozmieszczenia obszarów Room. W razie potrzeby edytuj to pole. Jeśli obszarów Room jest więcej, niż mieści się w zdefiniowanym układzie wierszy i kolumn, u góry zostaną dodane kolejne wiersze. |
Sortuj według |
|
| SortBy | Wyświetla wybraną kolejność sortowania, czyli kryteria określające kolejność obszarów Room. Dostępne opcje opisano poniżej. |
| Channel Name | Sortowanie obszarów Room alfanumerycznie według nazwy kanału. Dowiedz się więcej o projektowaniu wielokanałowym. |
| Room Area | Sortowanie obszarów Room według ich powierzchni. |
| Room Component Count | Sortuj obszary Room według liczby zawartych w nich komponentów. |
| Room Width | Sortuj obszary Room według ich wymiaru X (poziomego). |
| Room Height | Sortuj obszary Room według ich wymiaru Y (pionowego). |
| Sort in Ascending order | Włącz, aby sortować obszary Room rosnąco (od najmniejszego do największego), zgodnie z bieżącymi kryteriami SortBy. Jeśli ta opcja jest wyłączona, sortowanie odbywa się malejąco (od największego do najmniejszego). |
Pozycja |
|
| Origin X | Określa położenie X (w poziomie), od którego rozpocznie się rozmieszczanie obszarów Room. Edytuj to pole, aby zmienić współrzędną X, którą można określić w mm lub milach. Aby określić jednostkę podczas wprowadzania liczby, dodaj do wartości przyrostek mm lub mil . Jednostki domyślne (metryczne lub imperialne) są określane przez ustawienie Units w panelu Właściwości i są używane, jeśli nie podano jednostek. |
| Origin Y | Określa położenie Y (w pionie), od którego rozpocznie się rozmieszczanie obszarów Room. Edytuj to pole, aby zmienić współrzędną Y, którą można określić w mm lub milach. Aby określić jednostkę podczas wprowadzania liczby, dodaj do wartości przyrostek mm lub mil . Jednostki domyślne (metryczne lub imperialne) są określane przez ustawienie Units w panelu Właściwości i są używane, jeśli nie podano jednostek. |
| Select Origin Using Mouse | Jeśli ta opcja jest włączona, pojawi się monit o ręczne ustawienie punktu początkowego rozmieszczenia obszarów Room. Opcja musi być wyłączona, aby można było edytować Origin X i Origin Y. |
| X-Spacing | Określa odstęp X (w poziomie) między sąsiednimi obszarami Room. |
| Y-Spacing | Określa odstęp Y (w pionie) między sąsiednimi obszarami Room. |
| Auto Spacing | Jeśli ta opcja jest włączona, obszary Room są rozmieszczane z jednakowymi odstępami X (w poziomie) i Y (w pionie). Opcja musi być wyłączona, aby można było edytować X-Spacing i Y-Spacing. |
| Place On Grid | Włącz, aby wymusić rozmieszczanie obszarów Room zgodnie z bieżącą siatką przyciągania PCB. |
Przesuwanie obszarów Room do siatki
Aby przesunąć każdy z zaznaczonych obszarów Room do najbliższego punktu bieżącej siatki przyciągania, użyj polecenia Design » Rooms » Move Rooms to Grid. Po uruchomieniu polecenia otworzy się okno dialogowe z pytaniem, czy przesunąć obiekty wraz z zaznaczonymi obszarami Room. Kliknij Yes , aby przesunąć obszary Room wraz z zawartymi w nich obiektami do najbliższego punktu siatki przyciągania, lub kliknij No , aby przesunąć tylko obszary Room.
Kopiowanie formatowania obszarów Room
Jedną z najbardziej przydatnych funkcji obszarów Room jest możliwość kopiowania kształtu obszaru, rozmieszczenia komponentów i trasowania z jednego obszaru do innych obszarów zawierających identyczny zestaw komponentów. Polecenie to jest szczególnie przydatne podczas projektowania układu PCB w projekcie wielokanałowym, ponieważ umożliwia przeniesienie rozmieszczenia i trasowania wykonanego w jednym kanale do wszystkich pozostałych kanałów.
Aby skopiować formatowanie obszaru Room do innych obszarów Room:
-
Wybierz Design » Rooms » Copy Room Formats z menu głównego.
-
Na pasku stanu pojawi się monit o wybranie źródłowego obszaru Room. Umieść kursor nad źródłowym obszarem Room i kliknij lub naciśnij Enter.
-
Na pasku stanu pojawi się monit o wybranie docelowego obszaru Room. Umieść kursor nad obszarem Room, do którego chcesz skopiować formatowanie, i kliknij lub naciśnij Enter. Jeśli zamierzasz zastosować formatowanie do wielu obszarów Room, drugie kliknięcie może wskazywać dowolny z nich.
-
Otworzy się okno dialogowe Confirm Channel Format Copy. Użyj dostępnych opcji, aby określić zakres kopiowania formatowania. Domyślnie formatowanie zostanie skopiowane z wybranego Source Room do wybranego Destination Room. Aby skopiować formatowanie ze źródłowego obszaru Room do każdego z obszarów Room w wykrytej klasie kanałów, włącz opcję Apply to Specified Channels i upewnij się, że odpowiednie pola wyboru Copy dla docelowych obszarów Room są zaznaczone.
-
Kliknij OK w oknie dialogowym, aby zaktualizować docelowe obszary Room.
-
Możesz kontynuować wybieranie kolejnych docelowych obszarów Room lub kliknąć prawym przyciskiem myszy, aby zakończyć.
Obszary Room |
|
| Source Room | Nazwa źródłowego obszaru Room (reprezentującego kanał ze schematu), którego rozmieszczenie komponentów i trasowanie zostaną skopiowane. |
| Destination Room | To pole zawiera nazwę docelowego obszaru Room (reprezentującego kanał ze schematu), do którego zostaną zastosowane skopiowane rozmieszczenie i trasowanie. Jeśli projekt jest wielokanałowy, a kanały źródłowy i docelowy należą do tej samej klasy kanałów, formatowanie zostanie skopiowane do kanałów włączonych w sekcji Channel Class okna dialogowego Pamiętaj, że kanał źródłowy (obszar Room) i kanał docelowy (obszar Room) muszą należeć do tej samej klasy kanałów, jeśli chcesz skopiować formatowanie kanału źródłowego (obszaru Room) do innych kanałów (obszarów Room). |
Opcje |
|
| Copy Component Placement | Kopiuj rozmieszczenie komponentów ze źródłowego obszaru Room do docelowych obszarów Room. |
| Copy Designator and Comment Formatting | Kopiuj format oznaczeń i komentarzy ze źródłowego obszaru Room do docelowego obszaru Room. |
| Copy Routed Nets | Kopiuj układ trasowania (ścieżki/łuki i przelotki użyte do prowadzenia połączeń) ze źródłowego obszaru Room do docelowego obszaru Room. |
| Copy Room Size/Shape | Kopiuj kształt źródłowego obszaru Room i zastosuj go do docelowego obszaru Room. Jeśli opcja Copy Room Orientation jest włączona w oknie dialogowym, kształt docelowego obszaru Room zostanie zmieniony względem jego punktu początkowego (lewego dolnego), tzn. lewy dolny punkt docelowego obszaru Room pozostanie bez zmian. |
| Copy Room Orientation | Kopiuj orientację obszaru Room. Altium Designer wykrywa orientację obszarów Room (na podstawie kąta obrotu komponentu o największej liczbie wyprowadzeń lub, jeśli więcej niż jeden komponent ma taką samą największą liczbę wyprowadzeń, komponentu o największej powierzchni) i wykorzystuje ją do obrócenia docelowego obszaru Room. |
| Copy Selected Objects Only | Kopiuj formatowanie zaznaczonych obiektów ze źródłowego obszaru Room do docelowego obszaru Room. |
Opcje obiektów stykających się |
|
| Copy All Objects Touching the Room | Uwzględnij obiekty (inne niż komponenty oraz ścieżki/łuki i przelotki) znajdujące się całkowicie lub częściowo w obrębie obszaru Room. Ta opcja musi być włączona, aby kopiować między obszarami Room zarówno obiekty przypisane do sieci, jak i bez przypisanej sieci, takie jak regiony, poligony i obszary zabronione (keepout). |
| Exclude NoNet Objects | Wyklucz obiekty, które nie mają przypisanej sieci. |
Tylko całkowicie wewnątrz / Wewnątrz i stykające się z granicą |
|
| Fully Enclosed Objects Only | Jeśli opcja Copy All Objects Touching the Room jest włączona, włącz tę opcję, aby kopiować tylko obiekty znajdujące się całkowicie wewnątrz obszaru. |
| Enclosed & Touching Objects | Jeśli opcja Copy All Objects Touching the Room jest włączona, włącz tę opcję, aby kopiować zarówno obiekty znajdujące się wewnątrz obszaru, jak i stykające się z jego granicą. |
Dopasowywanie komponentów między kanałami |
|
| Match Components by Channel Offsets | Podczas przenoszenia projektu ze schematu na PCB każdemu komponentowi w powtarzanym kanale przypisywany jest offset kanału. Użyj tego offsetu, aby zidentyfikować ten sam komponent w każdym kanale. |
| Match Components by Source Designator | Możesz też użyć oznaczenia źródłowego (ze schematu), aby zidentyfikować odpowiadające sobie komponenty w każdym kanale. |
Usuń powiązane połączenia |
|
| Whole connections | Po skopiowaniu formatu kanału oprogramowanie musi określić sposób usunięcia powiązanych połączeń. Wybranie tej opcji powoduje usunięcie powiązanych połączeń zarówno wewnątrz obszaru Room, jak i poza nim. |
| Touching parts of connections only | Wybranie tej opcji powoduje usunięcie tylko powiązanych połączeń stykających się z obszarem Room. |
| Contained parts of connections only | Wybranie tej opcji powoduje usunięcie tylko powiązanych połączeń wewnątrz obszaru Room. |
Klasa kanałów |
|
| Channel Class | Podczas przenoszenia projektu wielokanałowego ze schematu na PCB powtarzające się układy (kanały) są identyfikowane jako klasa kanałów w oknie dialogowym Object Class Explorer edytora PCB Ta klasa kanałów służy do określenia, do których kanałów ma zostać zastosowane kopiowanie formatu. Jeśli sekcja Channel Class okna dialogowego jest pusta, sprawdź, czy klasa kanałów została prawidłowo zdefiniowana w oknie dialogowym Object Class Explorer (Design » Classes). Jeśli nie zidentyfikowano żadnej klasy kanałów, polecenie kopiowania jest stosowane tylko z obszaru źródłowego Room do obszaru docelowego Room. |
| Channel Members | Ta lista zawiera kanały identyfikowane nazwami ich obszarów Room. Jeśli źródłowy obszar Room należy do zdefiniowanej klasy kanałów, na liście zostanie wyświetlona ta klasa wraz ze wszystkimi jej elementami. Wyświetlana jest również warstwa (strona płytki, na której umieszczono obszar Room) oraz liczba komponentów w każdym kanale. Każdy kanał ma pole wyboru określające, czy ma zostać do niego zastosowane kopiowanie formatu. Pole to staje się dostępne po włączeniu opcji Apply To Specified Channel. |
| Apply To Specified Channel | Domyślnie format jest kopiowany z Source Room do wszystkich kanałów należących do tej samej klasy kanałów co źródłowy obszar Room (kanał). Po włączeniu tej opcji pole wyboru Copy staje się dostępne dla każdego kanału, umożliwiając wybór kanałów w danej klasie, do których ma zostać skopiowany format. |
Ukrywanie obszarów Room
Obszary Room w danym dokumencie można globalnie wyświetlać, ukrywać lub wyświetlać w trybie uproszczonym za pomocą opcji na karcie View Options panelu View Configuration.
Za pomocą suwaka Object Visibility dla obszarów Room można zmniejszyć ich widoczność lub ukryć je w obszarze edycji.
).

).
)
).
).
).




)
).








).