Praca z obiektowymi Keepoutami na tablicy
W skrócie
- Dowiedz się, czym są obszary zabronione dla określonych typów obiektów, jak działają w Altium Designer i gdzie warto je stosować podczas projektowania PCB.
- Naucz się konfigurować obszary zabronione tak, aby ograniczały umieszczanie tylko wybranych typów obiektów, zapewniając większą elastyczność w kontrolowaniu prowadzenia ścieżek, rozmieszczania miedzi i przelotek.
- Poznaj podstawy umieszczania i edytowania obiektów obszarów zabronionych, w tym odcinków ścieżek i łuków, w edytorze PCB i edytorze bibliotek PCB.
W projektowaniu PCB Keepout to zdefiniowany przez użytkownika obszar lub obwód umieszczony w projekcie płytki, którego nie mogą przecinać obiekty miedziane. Strefa zabroniona służy zwykle do ograniczania obszaru wykorzystywanego przez automatyczne operacje umieszczania miedzi, takie jak wylewanie poligonów i trasowanie interaktywne, a także wyznacza niedozwolone miejsce podczas ręcznego umieszczania obiektów miedzianych.
Jako obszary wyłączone z użytkowania podczas projektowania płytki, obiekty stref zabronionych wykorzystują istniejące reguły ograniczeń odstępu do sterowania trasowaniem i wykrywania naruszeń rozmieszczenia, ale w odróżnieniu od innych umieszczanych obiektów nie można przypisać ich do sieci i nie są one widoczne w generowanych danych wyjściowych ani na wydrukach. W najprostszym ujęciu strefa zabroniona działa jak obiekt kolizyjny, który uniemożliwia innym obiektom miedzianym przecinanie jej obszaru zgodnie z globalną regułą odstępu. Obiekty stref zabronionych można umieszczać na warstwie Keep-out Layer (gdzie obowiązują na wszystkich warstwach sygnałowych) lub na warstwie sygnałowej (gdzie dotyczą wyłącznie obiektów na tej warstwie).
Altium Designer umożliwia tworzenie i stosowanie stref zabronionych dzięki obsłudze Object Specific Keepouts. Umieszczone obiekty stref zabronionych można skonfigurować tak, aby określały, jakich typów obiektów dotyczą, na przykład ścieżek, obszarów miedzi, przelotek i padów, co znacznie zwiększa elastyczność i skuteczność stref zabronionych.

Obiekty stref zabronionych różnych typów umieszczone w projekcie PCB.
W edytorze PCB i edytorze bibliotek PCB obiekty stref zabronionych są wyświetlane z kreskowaniem krzyżowym. Obiekty stref zabronionych umieszczone na warstwie Keep-Out Layer (czyli obowiązujące na wszystkich warstwach sygnałowych) są wyświetlane w kolorze warstwy Keep-Out Layer, natomiast strefy zabronione umieszczone na określonej warstwie sygnałowej (czyli obowiązujące tylko na tej warstwie) mają kolor tej warstwy sygnałowej.
Strefy zabronione idealnie nadają się do definiowania obszarów płytki, w których nie można prowadzić ścieżek (takich jak obszary wrażliwe na zakłócenia elektryczne lub obszary wysokiego napięcia), miejsc z celowo odsłoniętą miedzią, takich jak znaczniki referencyjne i punkty testowe, lub obszarów niedostępnych ze względów mechanicznych (takich jak otwory montażowe lub narożniki PCB). Możliwość konfigurowania stref zabronionych dla określonych typów obiektów pozwala również umieszczać je na innych obiektach po przypisaniu odpowiednich Keepout Restrictions. Na przykład strefę zabronioną skonfigurowaną tak, aby ograniczała wyłącznie przelotki, można umieścić na istniejących obszarach miedzi (takich jak wypełnienie poligonowe), aby kontrolować zasięg automatycznego zszywania przelotkami.
Strefy zabronione dla określonych typów obiektów można umieszczać w edytorze PCB i edytorze bibliotek PCB.
Więcej informacji na temat umieszczania i edytowania obiektów stref zabronionych na PCB znajduje się w poniższych rozwijanych sekcjach:
Strefa zabroniona w postaci ścieżki

Umieszczona strefa zabroniona w postaci ścieżki
Ścieżka jest podstawowym obiektem projektowym. Oprócz standardowej ścieżki używanej podczas projektowania dostępny jest drugi typ ścieżki, określany jako strefa zabroniona w postaci ścieżki. Można ją umieścić jako obiekt strefy zabronionej dotyczący określonej warstwy lub wszystkich warstw, aby pełniła na przykład funkcję bariery dla rozmieszczania elementów lub trasowania. Różnica między standardową ścieżką a strefą zabronioną w postaci ścieżki polega na tym, że wypełnienia typu strefa zabroniona przypisane do określonej warstwy nie są uwzględniane przy generowaniu danych wyjściowych, takich jak Gerber lub ODB++. Obszar strefy zabronionej można rozpoznać po obrysie w kolorze stref zabronionych.
Po uruchomieniu polecenia umieszczania strefy zabronionej w postaci ścieżki kursor zmieni się w krzyżyk i zostanie włączony tryb jej umieszczania. Umieszczanie odbywa się w następującej kolejności:
- Kliknij lub naciśnij Enter , aby ustalić punkt początkowy pierwszego segmentu strefy zabronionej w postaci ścieżki.
- Przesuń kursor, aby określić segment strefy zabronionej w postaci ścieżki, a następnie kliknij lub naciśnij Enter , aby ustalić punkt końcowy tego pierwszego segmentu, który jest jednocześnie punktem początkowym następnego połączonego segmentu.
- Kontynuuj przesuwanie kursora, a następnie klikaj lub naciskaj Enter , aby ustalać kolejne wierzchołki definiujące ciąg połączonych segmentów strefy zabronionej w postaci ścieżki.
- Kliknij prawym przyciskiem myszy lub naciśnij Esc , aby zakończyć bieżący ciąg połączonych segmentów strefy zabronionej w postaci ścieżki.
Podczas umieszczania można wykonywać następujące dodatkowe czynności:
- Naciskaj klawisz * na klawiaturze numerycznej, aby przełączać się między dostępnymi warstwami sygnałowymi. Możesz też użyć kombinacji Shift+Ctrl+Wheel Roll , aby przechodzić między warstwami trasowania; każdy skok kółka myszy powoduje przejście do następnej (lub poprzedniej) dostępnej warstwy sygnałowej.
- Naciskaj klawisze + i - na klawiaturze numerycznej, aby przełączać się w przód i w tył między wszystkimi warstwami aktualnie widocznymi w projekcie.
Podczas umieszczania segmentów strefy zabronionej w postaci ścieżki dostępnych jest pięć trybów narożników, z których cztery mają dodatkowo podtryby kierunku narożnika. Podczas umieszczania:
- Naciskaj Shift+Spacebar , aby przełączać się między pięcioma dostępnymi trybami narożników.
- Naciskaj Spacebar , aby przełączać się między dwoma podtrybami kierunku narożnika.
- W jednym z trybów narożników łukowych przytrzymaj klawisz , lub . , aby zmniejszyć lub powiększyć łuk. Podczas naciskania przytrzymaj klawisz Shift , aby przyspieszyć zmianę rozmiaru łuku.
- Naciśnij skrót klawiszowy 1 , aby przełączać się między umieszczaniem jednego lub dwóch segmentów na kliknięcie. W pierwszym trybie segment ścieżki wyświetlany jako sam obrys jest nazywany segmentem wyprzedzającym.
- Naciśnij klawisz Backspace , aby usunąć ostatni wierzchołek.
Graficzna metoda edycji pozwala zaznaczyć umieszczony obiekt strefy zabronionej w postaci ścieżki bezpośrednio w obszarze projektowym i graficznie zmienić jego rozmiar, kształt lub położenie.
Po zaznaczeniu strefy zabronionej w postaci ścieżki dostępne są następujące uchwyty edycji:
- Kliknij uchwyty końcowe , aby zmienić położenie punktów końcowych ścieżki.
- Kliknij i przeciągnij uchwyt środkowy , aby zmienić kształt ścieżki.
Właściwości strefy zabronionej w postaci ścieżki

Tryb Keepout - Track panelu Properties.
Położenie
-
(X/Y)
- X (pierwsze pole) — bieżąca współrzędna X (pozioma) punktu odniesienia strefy zabronionej w postaci ścieżki względem bieżącego początku układu współrzędnych. Edytuj ją, aby zmienić położenie X strefy zabronionej w postaci ścieżki. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; jeśli jednostki wprowadzanej wartości są inne niż bieżące jednostki domyślne, należy je podać.
- Y (drugie pole) — bieżąca współrzędna Y (pionowa) punktu odniesienia strefy zabronionej w postaci ścieżki względem bieżącego początku układu współrzędnych. Edytuj ją, aby zmienić położenie Y strefy zabronionej w postaci ścieżki. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; jeśli jednostki wprowadzanej wartości są inne niż bieżące jednostki domyślne, należy je podać.
Właściwości
- Component — to pole jest wyświetlane w edytorze PCB tylko wtedy, gdy zaznaczona strefa zabroniona w postaci ścieżki jest częścią składową komponentu PCB, i zawiera oznaczenie nadrzędnego komponentu PCB. Wybierz klikalny Component łącze otwierające tryb Component panelu Properties dla komponentu nadrzędnego.
- Restricted for Layer - użyj listy rozwijanej, aby wybrać warstwę objętą ograniczeniem.
- Width - wyświetla bieżącą szerokość ścieżki Keepout. Edytuj to pole, aby zmienić szerokość ścieżki Keepout w zakresie od 0,001 mil do 10000 mil.
- Start (X/Y) - wyświetla bieżące współrzędne X/Y punktu początkowego ścieżki Keepout względem bieżącego początku układu współrzędnych.
- End (X/Y) - wyświetla bieżące współrzędne X/Y punktu końcowego ścieżki Keepout względem bieżącego początku układu współrzędnych.
- Length - wyświetla bieżącą długość ścieżki Keepout. Edytuj to pole, aby zmienić długość ścieżki Keepout w zakresie od 0,001 mil do 10000 mil.
Ograniczenia Keepout
W tej sekcji wybierz typy obiektów, które będą objęte ograniczeniami Keepout. Odznaczenie typu obiektu sprawi, że Keepout będzie zezwalać obiektom tego typu na wkraczanie w jego obszar (nie będą wykluczane) przez niestosowanie odpowiedniej reguły odstępu (Clearance). Dostępne opcje:
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Łuk Keepout

Dwa łuki Keepout na dolnej warstwie: po lewej łuk Keepout w postaci pełnego okręgu; po prawej łuk Keepout zaznaczony do edycji.
Łuk Keepout jest podstawowym obiektem projektowym. Zasadniczo jest to kołowy segment ścieżki, który można umieścić na dowolnej warstwie. Oprócz standardowego łuku używanego do takich zadań projektowych jak definiowanie obrysu komponentu lub prowadzenie zakrzywionych ścieżek dostępny jest drugi typ łuku, określany jako łuk Keepout. Łuk Keepout można umieścić na warstwie sygnałowej, aby utworzyć barierę lub obszar wykluczenia dotyczący tej warstwy. Można go również umieścić na warstwie Keepout, gdzie będzie obowiązywać na wszystkich warstwach sygnałowych. Różnica między standardowym łukiem a łukiem Keepout polega na tym, że łuki typu Keepout przypisane do konkretnej warstwy nie są uwzględniane przy generowaniu danych wyjściowych, takich jak Gerber lub ODB++. Łuk Keepout można rozpoznać po obrysie w kolorze Keepout.
Sposób umieszczania łuku zależy od wybranej metody. Obsługiwane są cztery różne metody umieszczania łuku:
- Place arc by center – ta metoda umożliwia umieszczenie obiektu łuku z wykorzystaniem jego środka jako punktu początkowego.
- Place arc by edge – ta metoda umożliwia umieszczenie obiektu łuku z wykorzystaniem jego krawędzi jako punktu początkowego. Kąt łuku jest ustalony na 90°.
- Place arc by edge (any angle) – ta metoda umożliwia umieszczenie obiektu łuku z wykorzystaniem jego krawędzi jako punktu początkowego. Kąt łuku może mieć dowolną wartość.
- Place full circle arc – ta metoda umożliwia umieszczenie łuku 360° (pełnego okręgu).
Placing a Keepout Arc Starting at the Center
Po uruchomieniu polecenia kursor zmieni się w krzyżyk i zostanie włączony tryb umieszczania łuku Keepout. Umieszczanie odbywa się w następującej kolejności:
- Kliknij lub naciśnij Enter, aby ustalić środek łuku Keepout.
- Przesuń kursor, aby dostosować promień łuku Keepout, a następnie kliknij lub naciśnij Enter, aby go ustawić.
- Przesuń kursor, aby dostosować punkt początkowy łuku Keepout, a następnie kliknij lub naciśnij Enter, aby go ustalić.
- Przesuń kursor, aby zmienić położenie punktu końcowego łuku Keepout, a następnie kliknij lub naciśnij Enter, aby go ustalić i zakończyć umieszczanie łuku Keepout.
- Kontynuuj umieszczanie kolejnych łuków Keepout lub kliknij prawym przyciskiem myszy albo naciśnij Esc, aby wyjść z trybu umieszczania.
Placing a Keepout Arc Starting at the Edge
Po uruchomieniu polecenia kursor zmieni się w krzyżyk i zostanie włączony tryb umieszczania łuku Keepout. Umieszczanie odbywa się w następującej kolejności:
- Kliknij lub naciśnij Enter, aby ustalić punkt początkowy łuku Keepout.
- Przesuń kursor, aby zmienić położenie punktu końcowego łuku Keepout, a następnie kliknij lub naciśnij Enter, aby go ustalić i zakończyć umieszczanie łuku Keepout.
- Kontynuuj umieszczanie kolejnych łuków Keepout lub kliknij prawym przyciskiem myszy albo naciśnij Esc, aby wyjść z trybu umieszczania.
Placing a Keepout Arc Starting at the Edge (any angle)
Po uruchomieniu polecenia kursor zmieni się w krzyżyk i zostanie włączony tryb umieszczania łuku Keepout. Umieszczanie odbywa się w następującej kolejności:
- Kliknij lub naciśnij Enter, aby ustalić punkt początkowy łuku Keepout.
- Przesuń kursor, aby dostosować promień łuku Keepout, a następnie kliknij lub naciśnij Enter, aby ustalić jego środek.
- Przesuń kursor, aby zmienić położenie punktu końcowego łuku Keepout, a następnie kliknij lub naciśnij Enter, aby go ustalić i zakończyć umieszczanie łuku Keepout.
- Kontynuuj umieszczanie kolejnych łuków Keepout lub kliknij prawym przyciskiem myszy albo naciśnij Esc, aby wyjść z trybu umieszczania.
Placing a Full Circle Keepout Arc
Po uruchomieniu polecenia kursor zmieni się w krzyżyk i zostanie włączony tryb umieszczania łuku Keepout. Umieszczanie odbywa się w następującej kolejności:
- Kliknij lub naciśnij Enter, aby ustalić środek łuku Keepout.
- Przesuń kursor, aby dostosować promień łuku Keepout, a następnie kliknij lub naciśnij Enter, aby go ustawić i zakończyć umieszczanie łuku Keepout.
- Kontynuuj umieszczanie kolejnych łuków Keepout lub kliknij prawym przyciskiem myszy albo naciśnij Esc, aby wyjść z trybu umieszczania.
W przypadku wszystkich metod (z wyjątkiem łuków w postaci pełnego okręgu) naciśnij Spacebar przed zdefiniowaniem punktu końcowego łuku Keepout, aby utworzyć łuk w przeciwnym kierunku.
Graficzna metoda edycji pozwala zaznaczyć umieszczony obiekt łuku bezpośrednio w obszarze projektowania i graficznie zmienić jego rozmiar, kształt lub położenie.
Po zaznaczeniu obiektu łuku Keepout dostępne są następujące uchwyty edycji:

Zaznaczony łuk Keepout
- Kliknij i przeciągnij A, aby dostosować promień.
- Kliknij i przeciągnij B, aby dostosować punkty końcowe (kąt początkowy i końcowy).
-
Kliknij w dowolnym miejscu na łuku z dala od uchwytów edycji, a następnie przeciągnij, aby zmienić jego położenie. Możesz też kliknąć i przeciągnąć środek łuku. Podczas przeciągania łuk można obracać lub odbijać lustrzanie:
- Naciśnij Spacebar, aby obrócić łuk przeciwnie do ruchu wskazówek zegara, lub Shift+Spacebar, aby obrócić go zgodnie z ruchem wskazówek zegara. Obrót odbywa się zgodnie z wartością Rotation Step zdefiniowaną na stronie PCB Editor – General w oknie dialogowym Preferences.
- Naciśnij klawisz X lub Y, aby odbić łuk symetrycznie względem odpowiednio osi X lub Y.
Właściwości łukowego obszaru zabronionego

Tryb Keepout - Arc panelu Properties.
Położenie
-
(X/Y)
- X (pierwsze pole) — bieżąca współrzędna X (pozioma) punktu odniesienia łukowego obszaru zabronionego względem bieżącego początku układu współrzędnych przestrzeni projektowej. Edytuj ją, aby zmienić położenie łukowego obszaru zabronionego w osi X. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; jeśli wprowadzana wartość jest podana w jednostkach innych niż aktualnie domyślne, należy dopisać jednostkę.
- Y (drugie pole) — bieżąca współrzędna Y (pionowa) punktu odniesienia łukowego obszaru zabronionego względem bieżącego początku układu współrzędnych. Edytuj ją, aby zmienić położenie łukowego obszaru zabronionego w osi Y. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; jeśli wprowadzana wartość jest podana w jednostkach innych niż aktualnie domyślne, należy dopisać jednostkę.
Właściwości
- Component — to pole jest wyświetlane w edytorze PCB tylko wtedy, gdy wybrany łukowy obszar zabroniony jest częścią komponentu PCB, i pokazuje oznaczenie komponentu nadrzędnego. Kliknij łącze Component, aby otworzyć tryb Component panelu Properties dla komponentu nadrzędnego.
- Restricted Layer — to pole pokazuje warstwę objętą ograniczeniami, do której obecnie przypisany jest łukowy obszar zabroniony. Aby zmienić warstwę, kliknij pole i wybierz warstwę z listy rozwijanej.
- Width — to pole pokazuje szerokość linii łukowego obszaru zabronionego. W razie potrzeby wprowadź inną wartość szerokości.
- Radius — to pole pokazuje promień łuku mierzony od jego środka do osi linii łukowego obszaru zabronionego. W razie potrzeby wprowadź inną wartość promienia.
- Start Angle — to pole pokazuje kąt początkowy łukowego obszaru zabronionego, mierzony od osi X w pierwszej ćwiartce (geometria płaska). W razie potrzeby wprowadź inną wartość kąta początkowego.
- End Angle — to pole pokazuje kąt końcowy łukowego obszaru zabronionego. W razie potrzeby wprowadź inną wartość kąta końcowego.
Ograniczenia obszaru zabronionego
W tej sekcji wybierz typy obiektów, które mają podlegać ograniczeniom obszaru zabronionego. Odznaczenie typu obiektu spowoduje, że obszar zabroniony będzie dopuszczał naruszenia przez obiekty tego typu (nie będą one wykluczane), ponieważ nie będzie dla nich stosowana odpowiednia reguła odstępu (Clearance). Dostępne opcje obejmują:
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Obszar zabroniony typu Region

Obszar zabroniony typu Region
Obszar zabroniony typu Region jest podstawowym obiektem projektowym. Oprócz standardowego regionu używanego w projektowaniu dostępny jest drugi typ regionu, określany jako obszar zabroniony typu Region. Można go umieścić jako obiekt obszaru zabronionego przypisany do konkretnej warstwy lub obejmujący wszystkie warstwy, aby pełnił na przykład funkcję bariery dla rozmieszczania komponentów lub prowadzenia ścieżek. Różnica między standardowym regionem a regionem zabronionym polega na tym, że wypełnienia typu obszar zabroniony przypisane do konkretnej warstwy nie są uwzględniane w generowanych plikach wyjściowych, takich jak Gerber czy ODB++. Region zabroniony można rozpoznać po obrysie w kolorze warstwy Keepout.
Po uruchomieniu polecenia umieszczania obszaru zabronionego typu Region (Place » Keepout » Solid Region) kursor zmieni się w krzyżyk i zostanie włączony tryb umieszczania tego obszaru. Umieszczanie przebiega w następującej kolejności:
- Ustaw kursor, a następnie kliknij, aby ustalić początkowy wierzchołek obszaru zabronionego typu Region.
- Przesuń kursor do miejsca, w którym chcesz umieścić drugi wierzchołek. Domyślnie każde kliknięcie umieszcza dwie krawędzie, pomiędzy którymi znajduje się narożnik o kształcie zdefiniowanym przez użytkownika.
- Kontynuuj przesuwanie myszy i klikanie, aby umieścić kolejne wierzchołki.
- Po umieszczeniu ostatniego wierzchołka kliknij prawym przyciskiem myszy lub naciśnij Esc, aby zamknąć obszar zabroniony typu Region i zakończyć jego umieszczanie. Nie trzeba ręcznie zamykać regionu, ponieważ oprogramowanie automatycznie dopełni kształt, łącząc punkt początkowy z ostatnim umieszczonym punktem.
- Kontynuuj umieszczanie kolejnych obszarów zabronionych typu Region albo kliknij prawym przyciskiem myszy lub naciśnij Esc, aby wyjść z trybu umieszczania.
Graficzna metoda edycji pozwala wybrać umieszczony obiekt bezpośrednio w przestrzeni projektowej i graficznie zmienić jego rozmiar, kształt lub położenie.

Zaznaczony obszar zabroniony typu Region
Move Region Vertices
Obszary zabronione typu Region mają dwa rodzaje punktów, czyli „uchwytów”, służących do edycji kształtu regionu.
- Full Handles — znajdują się w narożnikach obszaru zabronionego typu Region.
- Empty Handles — znajdują się w środkach segmentów wyznaczonych przez pełne uchwyty.
Kształt istniejącego obszaru zabronionego typu Region można zmienić, przesuwając te uchwyty lub wierzchołki znajdujące się w każdym narożniku lub w środku każdej krawędzi.
Aby zmodyfikować kształt obszaru zabronionego typu Region:
-
Kliknij i wybierz obszar zabroniony typu Region, co spowoduje podświetlenie jego wierzchołków i zmianę kursora w krzyżyk.
- Click na pełnym uchwycie, aby przesunąć dany narożnik.
- Click wzdłuż krawędzi, aby przesunąć całą krawędź.
- Click na pustym uchwycie, aby przesunąć cały bok (zarówno w przypadku ścieżki, jak i łuku).
- Ctrl+Click na pustym uchwycie, aby podzielić tę krawędź na dwie. Ctrl wystarczy przytrzymać tylko na początku przesuwania. Następnie można użyć skrótów klawiaturowych Shift+Spacebar, aby przełączać kolejno tryby (łuk, ścięcie narożnika i dowolny kąt).
- Jeśli tryb umieszczania „dowolny kąt” tworzy niepożądane wierzchołki lub chcesz usunąć nadmiarowe wierzchołki, kliknij Ctrl i chwyć środkowy pełny uchwyt. Nad uchwytem pojawi się ikona X, a przeciągnięcie krawędzi zmniejszy liczbę wierzchołków na tej krawędzi do jednego.
Modify Region Border
Oprócz edycji wierzchołków można także użyć polecenia Modify Region Border , aby łatwo zmienić kształt wielokątów. Polecenie uruchamia się, klikając prawym przyciskiem myszy wybrany wielokąt, a następnie wybierając Polygon Actions » Modify Polygon Border. Po uruchomieniu polecenia kursor zmienia się w krzyżyk. Każde kliknięcie dodaje nowy wierzchołek. Podobnie jak podczas umieszczania obszaru zabronionego typu Region, skróty Shift+Spacebar umożliwiają zmianę kształtu narożników.
Właściwości obszaru zabronionego typu Region

Tryb Keepout - Region panelu Properties.
Właściwości
- Component – to pole jest widoczne w edytorze PCB tylko wtedy, gdy wybrany obszar zabroniony jest częścią komponentu PCB, i wyświetla oznaczenie komponentu nadrzędnego. Kliknij łącze Component, aby otworzyć tryb Component panelu Properties dla komponentu nadrzędnego.
- Restricted for Layer - użyj listy rozwijanej, aby wybrać warstwę, na której znajduje się obszar zabroniony.
- Arc Approximation - wprowadź maksymalne odchylenie od idealnego łuku.
- Area - całkowita powierzchnia umieszczonego obiektu.
- Locked (tylko w panelu Properties) - włącz, aby zablokować obszar zabroniony.
Wierzchołki obrysu
Ta sekcja służy do modyfikowania poszczególnych wierzchołków aktualnie wybranego obiektu obszaru. Możesz zmieniać położenie istniejących wierzchołków, dodawać nowe lub usuwać je zależnie od potrzeb. Można definiować połączenia łukowe między wierzchołkami, a także eksportować dane wierzchołków do pliku w formacie CSV i importować je z takiego pliku.
-
Vertices Grid - zawiera listę wszystkich wierzchołków aktualnie zdefiniowanych dla obszaru z następującymi danymi:
- Index - przypisany indeks wierzchołka (bez możliwości edycji).
- X - współrzędna X (pozioma) wierzchołka. Kliknij, aby edytować.
- Y - współrzędna Y (pionowa) wierzchołka. Kliknij, aby edytować.
- Arc Angle (Neg = CW) - kąt łuku łączącego ten wierzchołek z następnym. Domyślnie połączenia są prostymi krawędziami, a to pole pozostaje puste. Kliknij, aby edytować, a następnie wprowadź wymagany kąt łuku. Wprowadzenie wartości dodatniej spowoduje narysowanie łuku przeciwnie do ruchu wskazówek zegara. Aby narysować łuk zgodnie z ruchem wskazówek zegara, wprowadź wartość ujemną.
-
Add - kliknij, aby dodać nowy wierzchołek. Nowy wierzchołek zostanie dodany poniżej aktualnie aktywnego wpisu i początkowo będzie miał takie same współrzędne X,Y jak ten wpis. Kliknij
, aby usunąć aktualnie wybrany wierzchołek.
Ograniczenia obszaru zabronionego
W tej sekcji wybierz typy obiektów, które będą objęte ograniczeniami obszaru zabronionego. Usunięcie zaznaczenia danego typu obiektu pozwoli obiektom tego typu wchodzić w obszar zabroniony — odpowiednia reguła odstępu (Clearance) nie będzie dla nich stosowana. Dostępne opcje:
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Wypełnienie zabronione
Wypełnienie zabronione to podstawowy obiekt projektowy, który można umieścić na dowolnej warstwie. Oprócz standardowego wypełnienia, używanego do takich zadań projektowych jak definiowanie obrysu komponentu, dostępny jest drugi typ wypełnienia, określany jako wypełnienie zabronione. Wypełnienie zabronione może być obiektem przypisanym do konkretnej warstwy lub obejmującym wszystkie warstwy i służyć na przykład jako bariera dla rozmieszczania komponentów lub prowadzenia ścieżek. Różnica między standardowym wypełnieniem a wypełnieniem zabronionym polega na tym, że wypełnienia zabronione przypisane do konkretnej warstwy nie są uwzględniane podczas generowania danych wyjściowych, takich jak Gerber czy ODB++. Wypełnienie zabronione można rozpoznać po obrysie w kolorze Keepout.
Po uruchomieniu polecenia umieszczania wypełnienia zabronionego kursor zmieni się w krzyżyk i zostanie włączony tryb umieszczania wypełnienia zabronionego. Aby umieścić obiekt, wykonaj następujące czynności:
- Kliknij lub naciśnij Enter, aby ustalić pierwszy narożnik wypełnienia zabronionego.
- Przesuń kursor, aby dostosować rozmiar wypełnienia zabronionego, a następnie kliknij lub naciśnij Enter, aby ustalić narożnik po przekątnej i zakończyć umieszczanie wypełnienia zabronionego.
- Kontynuuj umieszczanie kolejnych wypełnień zabronionych lub kliknij prawym przyciskiem myszy albo naciśnij Esc, aby wyjść z trybu umieszczania.
Graficzna metoda edycji umożliwia wybranie umieszczonego obiektu bezpośrednio w przestrzeni projektowej i graficzną zmianę jego rozmiaru, kształtu lub położenia.
Po wybraniu wypełnienia zabronionego dostępne są następujące uchwyty edycji:

Wybrane wypełnienie zabronione
- Kliknij, przytrzymaj i przeciągnij uchwyty narożne, aby zmienić rozmiar wypełnienia zabronionego jednocześnie w pionie i w poziomie.
- Kliknij, przytrzymaj i przeciągnij uchwyty boczne, górny i dolny, aby zmienić rozmiar wypełnienia zabronionego osobno w pionie i w poziomie.
- Kliknij, przytrzymaj i przeciągnij uchwyt środkowy, aby obrócić wypełnienie zabronione wokół jego środka.
-
Kliknij dowolne miejsce wypełnienia zabronionego poza uchwytami edycji, a następnie przytrzymaj i przeciągnij, aby zmienić jego położenie. Podczas przeciągania wypełnienie zabronione można obracać lub odbijać lustrzanie:
- Naciśnij Spacebar, aby obrócić wypełnienie zabronione przeciwnie do ruchu wskazówek zegara, lub Shift+Spacebar, aby obrócić je zgodnie z ruchem wskazówek zegara. Obrót odbywa się zgodnie z wartością Rotation Step zdefiniowaną na stronie PCB Editor – General w oknie dialogowym Preferences.
- Naciśnij klawisz X lub Y, aby odbić wypełnienie zabronione lustrzanie względem osi X lub Y.
Właściwości wypełnienia zabronionego

Tryb Keepout - Fill panelu Properties.
Położenie
-
(X/Y)
- X (pierwsze pole) - aktualna współrzędna X (pozioma) punktu odniesienia wypełnienia zabronionego względem aktualnego początku układu współrzędnych przestrzeni projektowej. Edytuj, aby zmienić położenie X wypełnienia zabronionego. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; jeśli używasz jednostek innych niż aktualnie domyślne, podaj je wraz z wartością.
- Y (drugie pole) - aktualna współrzędna Y (pionowa) punktu odniesienia wypełnienia zabronionego względem aktualnego początku układu współrzędnych. Edytuj, aby zmienić położenie Y wypełnienia zabronionego. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; jeśli używasz jednostek innych niż aktualnie domyślne, podaj je wraz z wartością.
- Rotation - kąt obrotu wypełnienia zabronionego (w stopniach), mierzony przeciwnie do ruchu wskazówek zegara od położenia zerowego (poziomego 3 o'clock). Edytuj, aby zmienić obrót wypełnienia zabronionego. Minimalna rozdzielczość kątowa wynosi 0,001°.
Właściwości
- Component – to pole jest widoczne w edytorze PCB tylko wtedy, gdy wybrane wypełnienie zabronione jest częścią komponentu PCB, i wyświetla oznaczenie komponentu nadrzędnego. Kliknij łącze Component, aby otworzyć tryb Component panelu Properties dla komponentu nadrzędnego.
- Restricted for Layer - użyj listy rozwijanej, aby wybrać warstwę objętą ograniczeniami.
- Area - podaje pole powierzchni umieszczonego obiektu.
- Length - wyświetla bieżącą długość wypełnienia zabronionego. Edytuj to pole, aby zmienić długość w zakresie od 0.001mil do 10000mil.
- Width - wyświetla bieżącą szerokość wypełnienia zabronionego. Edytuj to pole, aby zmienić szerokość w zakresie od 0.001mil do 10000mil.
Ograniczenia obszaru zabronionego
W tej sekcji wybierz typy obiektów, które będą objęte ograniczeniami obszaru zabronionego. Usunięcie zaznaczenia danego typu obiektu pozwoli obiektom tego typu naruszać obszar zabroniony (nie będą wykluczane) w wyniku niestosowania odpowiedniej reguły odstępu. Dostępne opcje:
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Umieszczanie obszarów zabronionych
Obszar zabroniony umieszcza się w przestrzeni projektowej edytora za pomocą menu Place » Keepout. Wybrana postać obszaru zabronionego (ścieżka, wypełnienie, region lub łuk) zostanie umieszczona na aktualnie aktywnej warstwie. Otwórz właściwości obszaru zabronionego, aby edytować jego parametry geometryczne, warstwę lub ograniczenia dotyczące typów obiektów. Powiązane właściwości Keepout to:
- Restricted for Layer – określa warstwę obszaru zabronionego, a tym samym warstwę płytki, na której będą obowiązywały ograniczenia dotyczące obiektów miedzianych. Aby utworzyć obszar zabroniony na wszystkich warstwach, wybierz Keep-Out Layer.
- Keepout Restrictions – określa typy obiektów objęte ograniczeniami obszaru zabronionego. Usunięcie zaznaczenia danego typu obiektu pozwoli obiektom tego typu naruszać obszar zabroniony (nie będą wykluczane) w wyniku niestosowania odpowiedniej reguły odstępu.
Na poniższym rysunku dwa wypełnienia zabronione mają różne ograniczenia dotyczące warstw i obiektów. Dzięki temu wypełnienie zabronione na warstwie górnej (po lewej) dopuszcza pady przewlekane (TH), wykluczając wszystkie pozostałe typy obiektów, natomiast wypełnienie na warstwie Keep-Out Layer (po prawej) dopuszcza wyłącznie ścieżki.

Przykład dwóch wypełnień zabronionych umieszczonych na różnych warstwach PCB i skonfigurowanych tak, aby ograniczały umieszczanie różnych typów obiektów.
Elastyczność obszarów zabronionych pozwala wykorzystywać je do wielu zadań związanych z kontrolą układu PCB. Ponieważ obszary zabronione mogą się nakładać, być przypisywane do dowolnej warstwy sygnałowej (np. górnej lub dolnej) i wykluczać określone obiekty, można ich używać na przykład do precyzyjnego sterowania zszywaniem przelotkami i wylewkami poligonowymi.
Sterowanie wylewkami poligonowymi
W pokazanym poniżej przykładowym projekcie PCB dodano wypełnienia zabronione wokół padów wielowarstwowych w obszarze potencjalnie wysokiego napięcia, który wymaga odpowiedniej izolacji elektrycznej od planowanych wylewek poligonowych połączonych z masą. Wypełnienia zabronione przypisano do warstwy górnej i skonfigurowano tak, aby ograniczenia dotyczyły wyłącznie obiektów miedzianych. Wyklucza to wylewki poligonowe, wypełnienia i regiony, a jednocześnie dopuszcza istniejące ścieżki, pady itp. – innymi słowy, reguła naruszenia odstępu będzie miała zastosowanie wyłącznie do obiektów sklasyfikowanych jako „miedź”.

Wypełnienia zabronione umieszczone na warstwie Keep-Out Layer i skonfigurowane tak, aby dotyczyły wyłącznie obiektów miedzianych.
Powyższy układ obszarów zabronionych wymusi na wylewkach poligonowych umieszczonych na warstwach sygnałowych (w tym przypadku górnej i dolnej) omijanie wszystkich trzech obszarów zabronionych. Jednak wylewka na warstwie górnej nie zapewni odpowiedniego odstępu od pads na tej warstwie, związanego z omawianym obszarem.
W takim przypadku można dodać kolejne obszary zabronione na warstwie górnej, aby jej wylewka poligonowa omijała wszystkie powiązane pady w odpowiedniej odległości. Na poniższym rysunku dodano dwa kolejne wypełnienia zabronione na warstwie górnej, którą dla przejrzystości przedstawiono w trybie jednej warstwy. Zwróć uwagę, że pokazany obszar zabroniony można było utworzyć za pomocą jednego regionu zamiast dwóch nakładających się wypełnień.

Wypełnienia zabronione umieszczone na warstwie górnej i skonfigurowane tak, aby dotyczyły wyłącznie obiektów miedzianych.
Po dodaniu wylewek poligonowych do projektu zestaw obszarów zabronionych wymusi inny kształt odstępu wokół tego obszaru na każdej warstwie. Zwróć uwagę, że w tym przykładzie odstęp związany z obszarami zabronionymi jest większy niż dla zwykłych obiektów ze względu na niestandardową regułę odstępu dla obszarów zabronionych (patrz poniżej).

Wylewki poligonowe omijają umieszczone obiekty obszarów zabronionych.
Wpływ zestawu obszarów zabronionych na wylewki poligonowe jest wyraźnie widoczny podczas wyświetlania projektu w trybie 3D jednej warstwy, jak pokazano poniżej – warstwa górna po lewej, a dolna po prawej.

Warstwa górna (po lewej) i dolna (po prawej) płytki PCB wyświetlone w trybie 3D jednej warstwy.
Sterowanie zszywaniem przelotkami
Zastosowanie obszarów zabronionych skonfigurowanych tak, aby wykluczały przelotki, na wielowarstwowych obszarach miedzi pozwala kontrolować zasięg automatycznego zszywania przelotkami (Tools » Via Stitching/Shielding). Obszary zabronione można przypisać do wszystkich warstw lub jednej z warstw obszaru miedzi, tak aby przelotki między tymi warstwami były wykluczane.
W poniższym przykładzie dodano obszary zabronione w lewym górnym i lewym dolnym narożniku projektu. Skonfigurowano je tak, aby wykluczały przelotki, co uniemożliwi automatycznemu zszywaniu przelotkami umieszczanie przelotek w ich granicach.

Regiony zabronione skonfigurowane tak, aby dotyczyły wyłącznie przelotek.
Oprócz standardowego omijania istniejących ścieżek, padów i przelotek funkcja zszywania przelotkami omija również obszary zabronione zgodnie z obowiązującą regułą odstępu.

Płytka PCB po dodaniu zszywania przelotkami.
Obszary zabronione w komponentach
Obszary zabronione dodaje się do footprintów komponentów w edytorze bibliotek PCB w taki sam sposób jak w przestrzeni projektowej edytora PCB.
Obszar zabroniony dodany do pokazanego poniżej footprintu komponentu skonfigurowano tak, aby wykluczał wszystkie obiekty z wyjątkiem ścieżek. Umożliwia to wykonywanie połączeń sieci w projekcie, w którym używany jest ten komponent, a jednocześnie ogranicza umieszczanie w pobliżu obiektów innych typów.

Obiekt obszaru zabronionego można również dodać do footprintów komponentów w edytorze bibliotek PCB.
Praca z obszarami zabronionymi
Obsługa obszarów zabronionych dla określonych typów obiektów w Altium Designer znajduje odzwierciedlenie we wszystkich powiązanych funkcjach i obejmuje zgodność z zapytaniami (a tym samym z regułami projektowymi), panelem PCB List, a także z importowanymi i starszymi dokumentami projektów PCB.
Reguła odstępu dla obszarów zabronionych
Podobnie jak w przypadku innych obiektów podstawowych, bieżąca reguła odstępu elektrycznego określa wymagane odstępy dla obszarów zabronionych – patrz Design » Rules. Jeśli obszary zabronione wymagają innego odstępu, utwórz osobną regułę, stosując sprawdzenie atrybutu IsKeepOut jako zapytanie niestandardowe.
Upewnij się, że niestandardowa reguła odstępu dla obiektów Keepout ma wyższy priorytet niż istniejąca (globalna) reguła odstępu. W poniższym przykładzie utworzono regułę dla obiektów Keepout (Clearance_Keepout), w której wymagany odstęp jest dwukrotnie większy niż w podstawowej regule odstępu (Clearance). Jak widać na fragmencie układu płytki, ścieżka poprowadzona między dwoma padami omija obszar Keepout (po prawej) z większym odstępem niż obszar na warstwie Top Layer (po lewej).

Można utworzyć dodatkową regułę odstępu dla obiektów Keepout.
Konwersja obiektów podstawowych na obiekty Keepout
Istniejące obiekty podstawowe na warstwach sygnałowych można przekształcić w obiekty Keepout na tej samej warstwie za pomocą polecenia Convert Primitives to Keepouts (Tools » Convert » Convert Selected Primitives to Keepout).

Obiekt podstawowy można przekształcić w odpowiadający mu obiekt Keepout (i odwrotnie).
Dostęp za pośrednictwem paneli
Dostęp do obiektów Keepout z ograniczeniami dla określonych typów obiektów w projekcie płytki jest możliwy za pośrednictwem paneli PCB List i PCB Filter.
Panel PCB Filter umożliwia użycie słowa kluczowego zapytania IsKeepOut do wyszukiwania i (opcjonalnie) zaznaczania obiektów Keepout w projekcie.

Panel PCB Filter można wykorzystać do wyszukiwania obiektów Keepout w projekcie.
Panel PCB List umożliwia wyświetlanie listy, zaznaczanie i edytowanie obiektów Keepout wybranego typu — na przykład wypełnień Keepout, jak pokazano na poniższym obrazie panelu List. Dla porównania pokazano również standardowe wypełnienie na warstwie Top Layer (ostatnia pozycja na liście). Jeśli all wypełnienia (lub inne typy obiektów, takie jak regiony) zawarte w projekcie są oznaczone jako obiekty Keepout, panel PCB List będzie zawierał pełny zestaw atrybutów ograniczeń obiektów Keepout.

Panel PCB List umożliwia wyświetlanie listy, zaznaczanie i edytowanie obiektów Keepout wybranego typu.
Importowanie projektów PCB
Altium Designer umożliwia importowanie plików projektów z wielu innych narzędzi projektowych dzięki funkcjom automatycznej konwersji dostępnym w kreatorze importu (File » Import Wizard). Obiekty typu Keepout zawarte w plikach projektów PCB z innych narzędzi projektowych, z których część dotyczy określonych typów obiektów, są w miarę możliwości przekształcane przez kreator w obiekty Keepout z ograniczeniami dla określonych typów obiektów.
Proces konwersji obiektów Keepout w kreatorze jest zgodny z projektami płytek z popularnych systemów ECAD, takich jak Mentor® Graphics Pads™ i Cadence® Allegro™. Obiekty Keepout są również poprawnie interpretowane podczas eksportu do formatu IDF.
