Altium NEXUS Documentation

Sch_Cmd-DownHierarchyDownHierarchy_AD

Created: December 27, 2021 | Updated: January 21, 2022
This documentation page references Altium NEXUS/NEXUS Client (part of the deployed NEXUS solution), which has been discontinued. All your PCB design, data management and collaboration needs can now be delivered by Altium Designer (with Altium Designer Enterprise Subscription) and a connected Altium 365 Workspace. Check out the FAQs page for more information.

Parent page: Schematic Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: None

Summary

This command is used to move the focus to the next level up, or down, in the design hierarchy, from the current document.

Access

This command can be accessed from the schematic editor by:

  • Choosing the Tools » Up/Down Hierarchy command from the main menus.
  • Clicking the  button on the Schematic Standard toolbar.

Use

After launching the command, the cursor will change to a cross-hair and you will be prompted to choose a navigation point. If you click on a sheet entry you will be presented with the matching port on the sub-sheet, if you click on a sheet symbol you will be presented with the entire sub-sheet. To navigate up through the hierarchy, click a port to be presented with the matching sheet entry on the parent sheet.

Notes

  • When you click on a port, sheet entry, or sheet symbol, the corresponding sheet entry, port, or sheet will become highlighted in the main design window. The visual display is in accordance with the Highlight Methods (Dimming, Zooming, Selecting) defined on the System - Navigation page of the Preferences dialog.
  • If a sheet entry or port is connected to a bus, the first click will pop-up a menu, from where you can select the whole bus or an individual signal in the bus. The corresponding wiring from the sheet entry or port will be highlighted. Clicking on the original sheet entry or port a second time will present you with the corresponding port on the schematic sheet below, or sheet entry on the sheet above, respectively.
  • Hierarchy can also be navigated directly by pressing Ctrl and double-clicking over a port, sheet entry, or sheet symbol.
  • Hierarchy can also be navigated by using the Interactive Navigation feature of the Navigator panel.


Applied Parameters: ContextSensitive=True|Object=SheetEntry

Summary

This command is used to jump from the sheet entry under the cursor, to the corresponding port on the sub-sheet referenced by that entry's parent sheet symbol.

Access

This command is accessed from the schematic editor by right-clicking over a sheet entry in a placed sheet symbol, and choosing the Sheet Entry Actions » Jump to Port <PortName> command, from the context menu.

Use

First, ensure that the cursor is positioned over the sheet entry, whose corresponding port you wish to jump to, in the main design space.

After launching the command, you will be presented with the named port on the child sheet referenced by the sheet entry's parent sheet symbol. Sheet entry, port, and connected wiring, will become highlighted in the space.

Notes

  • The visual display is in accordance with the Highlight Methods (Dimming, Zooming, Selecting) defined on the System - Navigation page of the Preferences dialog.
  • A jump to the sheet entry's corresponding port can also be performed by pressing Ctrl and double-clicking the sheet entry.


Applied Parameters: ContextSensitive=True|Object=Port

Summary

This command is used to jump from the port under the cursor, to the corresponding sheet entry in the parent sheet symbol that references the sub-sheet on which the port resides.

Access

This command is accessed from the schematic editor by right-clicking over a port and choosing the Port Actions » Jump to Sheet Entry <SheetEntryName> command, from the context menu.

Use

First, ensure that the cursor is positioned over the port, whose corresponding sheet entry you wish to jump to, in the main design space.

After launching the command, you will be presented with the named sheet entry in the parent sheet symbol, on the schematic sheet higher in the design hierarchy. Port, sheet entry, and connected wiring, will become highlighted in the design space.

Notes

  • The visual display is in accordance with the Highlight Methods (Dimming, Zooming, Selecting) defined on the System - Navigation page of the Preferences dialog.
  • A jump to the port's corresponding sheet entry can also be performed by pressing Ctrl and double-clicking the port.


Applied Parameters: ContextSensitive=True|Object=FlatPortn (where n is in the range 1 to 20)

Summary

This command is used to jump from the port under the cursor, to another port with the same name, on the indicated target schematic document.

Access

The related indexed commands are accessed from the schematic editor - right-click over a port and choose the required Port Actions » Jump to Port <PortName> (<I/O Type>) on <SchematicDocumentName> command, from the context menu. A maximum of 20 such commands can be presented on the menu.

This command is only available when the Schematic.UseAutomaticCrossReferences option is disabled in the Advanced Settings dialog and the Net Identifier Scope - set on the Options tab of the Options for Project dialog - is set to Flat, or Global.

Use

First, ensure that the cursor is positioned over the port, whose connected ports of the same name you wish to jump to, in the main design space.

After launching the command, the source document for the indicated port will be made the active document, and the cursor will be positioned over the port. All ports of the same name (and any connected wiring) on the target document will be highlighted.

Notes

  • The visual display is in accordance with the Highlight Methods (Dimming, Zooming, Selecting) defined on the System - Navigation page of the Preferences dialog.
  • A jump to a target port can also be performed by pressing Ctrl and double-clicking the source port. If a port with the same name exists across two or more documents, a pop-up menu will appear with which to choose the required port.


Applied Parameters: ContextSensitive=True|Object=Portn (where n is in the range 1 to 20)

Summary

This command is used to jump from the port under the cursor, to another port or sheet entry with the same name, on the indicated target schematic document.

This feature is available when the Automatic Cross References option is enabled and an option other than Disabled is selected from the Ports drop-down on the Options tab of the Options for Project dialog.

Access

The related indexed commands are accessed from the schematic editor - right-click over a port and choose the required Port Actions » Jump to Port <PortName> on <SchematicDocumentName> or Port Actions » Jump to Sheet Entry <PortName> on <SchematicDocumentName> command, from the context menu. A maximum of 20 such commands can be presented on the menu.

Use

First, ensure that the cursor is positioned over the port, whose connected ports or sheet entries of the same name you wish to jump to, in the main design space.

After launching the command, the source document for the indicated port or sheet entry will be made the active document, and the cursor will be positioned over the port or sheet entry. All ports of the same name (and any connected wiring) on the target document will be highlighted.

Notes

  • The visual display is in accordance with the Highlight Methods (Dimming, Zooming, Selecting) defined on the System - Navigation page of the Preferences dialog.
  • In a hierarchical design, a jump to a target sheet entry can also be performed by pressing Ctrl and double-clicking the source port.


Applied Parameters: ContextSensitive=True|Object=SheetEntryn (where n is in the range 1 to 20)

Summary

This command is used to jump from the sheet entry under the cursor, to a port with the same name, on the indicated target schematic document.

This feature is available when the Automatic Cross References and Sheet Entries options are enabled on the Options tab of the Options for Project dialog.

Access

The related indexed commands are accessed from the schematic editor - right-click over a sheet entry and choose the required Sheet Entry Actions » Jump to Port <PortName> on <SchematicDocumentName> command, from the context menu. A maximum of 20 such commands can be presented on the menu.

Use

First, ensure that the cursor is positioned over the sheet entry, whose connected ports of the same name you wish to jump to, in the main design space.

After launching the command, the source document for the indicated port will be made the active document, and the cursor will be positioned over the port. All ports of the same name (and any connected wiring) on the target document will be highlighted.

Notes

  • The visual display is in accordance with the Highlight Methods (Dimming, Zooming, Selecting) defined on the System - Navigation page of the Preferences dialog.
  • A jump to a target port can also be performed by pressing Ctrl and double-clicking the source sheet entry.


Applied Parameters: ContextSensitive=True|Object=CrossSheetn (where n is in the range 1 to 20)

Summary

This command is used to jump from the off-sheet connector under the cursor, to another off-sheet connector with the same name, on the indicated target schematic document.

This feature is available in a flat or global project when the Automatic Cross References and Off-sheet Connectors options are enabled on the Options tab of the Options for Project dialog.

Access

The related indexed commands are accessed from the schematic editor - right-click over an off-sheet connector and choose the required Off Sheet Actions » Jump to Off-sheet Connector <OffSheetConnectorName> on <SchematicDocumentName> command, from the context menu. A maximum of 20 such commands can be presented on the menu.

Use

First, ensure that the cursor is positioned over the off-sheet connector, whose connected off-sheet connectors of the same name you wish to jump to, in the main design space.

After launching the command, the source document for the indicated off-sheet connector will be made the active document, and the cursor will be positioned over the off-sheet connector. All ports of the same name (and any connected wiring) on the target document will be highlighted.

Note

The visual display is in accordance with the Highlight Methods (Dimming, Zooming, Selecting) defined on the System - Navigation page of the Preferences dialog.


Applied Parameters: ContextSensitive=True|Object=SheetSymbol

Summary

This command is used to open the child sheet referenced by the sheet symbol currently under the cursor.

Access

This command is accessed from the schematic editor by right-clicking over a placed sheet symbol and choosing the Sheet Symbol Actions » Open SubSheet "<SchematicDocumentName.SchDoc>" command, from the context menu.

Use

First, ensure that the cursor is positioned over the required sheet symbol in the main design space.

After launching the command, the schematic document referenced by the symbol will be opened (if not already) and made the active document in the main design window.

Notes

  • The child sheet can also be navigated to, by using the Interactive Navigation feature of the Navigator panel, and clicking on the sheet symbol.
  • The child sheet can also be navigated to, by using the Up/Down Hierarchy command, and clicking on the sheet symbol.


Applied Parameters: ContextSensitive=True|Object=ComponentInVault

Summary

This command is used to browse to the Component Item-Revision for the placed Workspace library component currently under the cursor.

Access

This command is accessed from the schematic editor by right-clicking over a placed Workspace library component and choosing the Part Actions » Show <ItemID-RevisionID> (<ItemName>) in Server command, from the context menu.

This command is only available provided the component under the cursor is a Workspace library component, that is, it has been placed from a Workspace.

Use

First, ensure that the cursor is positioned over the required Workspace library component in the main design space.

After launching the command, the Explorer panel will appear, with the specific revision of the corresponding Component Item selected/presented.

Note

The Component Item-Revision can also be browsed directly from the Properties panel, when presenting the properties for the selected component. In the Properties section of the panel (on the General tab) simply click the button to the right of the Design Item ID field.


Applied Parameters: ContextSensitive=True|Object=SheetSymbolInVault

Summary

This command is used to browse to the Managed Schematic Sheet Item-Revision for the placed managed sheet symbol currently under the cursor.

Access

This command is accessed from the schematic editor by right-clicking over a placed managed sheet symbol and choosing the Sheet Symbol Actions » Show <ItemID-RevisionID> (<ItemName>) in Server command, from the context menu.

This command is only available provided the sheet symbol under the cursor is a managed sheet symbol instance, that is, it has been created by placing a revision of a Schematic Sheet Item from a Workspace.

Use

First, ensure that the cursor is positioned over the required managed sheet symbol in the main design space.

After launching the command, the Explorer panel will appear, with the specific revision of the corresponding Schematic Sheet Item selected/presented.

Note

The Schematic Sheet Item-Revision can also be browsed directly from the Properties panel, when presenting the properties for the selected managed sheet symbol instance. In the Properties section of the panel (on the General tab) simply click the button to the right of the Design Item ID field.

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: