Recherche et placement des composants

Altium Training

Altium Essentials: Schematic Capture

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Le cœur de toute conception électronique, ce sont les composants. Le composant que vous souderez finalement sur la carte doit être représenté, ou modélisé, dans chaque domaine de conception : sous forme de symbole dans le schéma, de modèle SPICE dans le simulateur, d’empreinte sur la carte, et de modèle STEP 3D dans le fichier que vous transmettez au concepteur mécanique.

Pour en savoir plus sur la création et la maintenance de vos composants et bibliothèques.

Le panneau Components d'Altium Designer fournit une interface puissante que vous pouvez utiliser pour interagir avec tous vos composants, qu’ils proviennent ou non de l’Espace de travail. Vous pouvez rechercher le composant requis en spécifiant la catégorie et en utilisant le mode de recherche simple en saisissant une requête (nom complet ou partiel du composant, valeur, etc.) dans le champ de recherche. En outre, le panneau fournit une capacité de recherche paramétrique (à facettes) basée sur des filtres pour spécifier les paramètres cibles des composants de votre Espace de travail. Le panneau propose également des options pour modifier un composant de l’Espace de travail via le Component Editor in its Single Component Editing mode, afficher le composant dans son Espace de travail source, et effectuer des fonctions de gestion des composants telles que la création et le clonage de composants ou la modification des Part Choices et du Type du composant sélectionné. Un composant peut être placé sur le schéma en le faisant glisser ou en utilisant la commande Place  du menu contextuel du composant.

Et bien que vous puissiez, bien sûr, créer vos propres composants, Altium Designer fournit un puissant Manufacturer Part Search panel qui peut être utilisé pour rechercher des pièces fabriquées réelles. Si vous disposez d’un Espace de travail, vous pouvez enregistrer ces pièces dans cet Espace de travail puis y accéder via le panneau Components. Ce processus implique la création d’un nouveau composant de l’Espace de travail, à l’aide du Component Editor en mode Single Component Editing, puis son enregistrement dans votre Espace de travail.

Le panneau Components fournit un accès direct aux composants de l’Espace de travail disponibles ainsi qu’aux composants de bibliothèques de base de données et basées sur des fichiers dans Altium Designer.

Le panneau source les composants depuis un Espace de travail connecté et toute bibliothèque ouverte ou installée. Le panneau offre tous les détails du composant sélectionné (paramètres, modèles, Part Choices, données fournisseur, etc.), la comparaison de composants et, pour les composants de l’Espace de travail, une capacité de recherche paramétrique basée sur des filtres pour spécifier les paramètres cibles des composants.

Le panneau Components en mode normal

Le panneau Components en mode compact

 

Le panneau Components utilise les fonctionnalités et l’affichage du moteur de recherche de base appliqués dans le Manufacturer Part Search panel. Alors que le panneau Manufacturer Part Search exploite le service Altium Parts Provider et se concentre sur les recherches de données de fabricants et de fournisseurs de composants, le panneau Components est alimenté avec des composants prêts à être placés issus de votre Espace de travail connecté ainsi que de sources de bibliothèques de base de données et basées sur des fichiers.

Pour les composants de l’Espace de travail, seule la dernière révision de chaque composant est présentée dans le panneau.
Bien qu’une grande partie des fonctionnalités de travail avec les composants soit disponible via le panneau Components, vous pouvez également utiliser le panneau Explorer – essentiellement, le premier fournit un sous-ensemble des fonctionnalités disponibles dans le second, avec un focus sur la gestion des composants. Certaines fonctions liées aux composants eux-mêmes ne peuvent toutefois être réalisées que via le panneau Explorer (ajout de fiches techniques sans modification, changement d’états, suppression en masse de composants et de modèles, etc.), mais celles-ci concernent plutôt des cas atypiques, des cas limites, ou des activités d’administration/structuration de l’Espace de travail. N’oubliez pas que le composant n’est qu’un type de contenu parmi d’autres – le panneau Explorer révèle tout son intérêt pour l’ensemble des types de contenu pris en charge par un Espace de travail. Par exemple, la création et la gestion des modèles de composants – entité très pertinente pour les composants – ne peuvent être effectuées que depuis le panneau Explorer (sauf si les modèles sont créés au moment de l’importation de bibliothèque à l’aide du Library Importer).

Accès au panneau Components

Pour ouvrir le panneau Components, sélectionnez View » Panels » Components dans les menus principaux ou l’option Components du menu du bouton en bas à droite de l’écran principal. En utilisant une configuration de conception réactive, la disposition du panneau s’adapte dynamiquement entre le mode normal plein écran () et son mode compact () où les options Catégories/Filtres se réduisent à des menus.

Depuis un document schématique, utilisez le raccourci clavier P, P pour ouvrir le panneau Components. Vous pouvez également utiliser la commande Place » Part depuis les menus principaux, la commande Place » Part depuis le menu contextuel de l’espace de conception de l’éditeur de schémas, ou le bouton Part () sur le/la Active Bar.

Depuis un document PCB, utilisez le raccourci clavier P, C pour ouvrir le panneau Components. Vous pouvez également utiliser la commande Place » Component depuis les menus principaux, la commande Place » Component depuis le menu contextuel de l’espace de conception de l’éditeur PCB, ou la commande Component () sur le/la Active Bar.

Lors du premier lancement du panneau Components dans la session Altium Designer en cours, les contrôles suivants sont disponibles lorsqu’une connexion à un Espace de travail est établie :

  • Use Existing Components – cliquez pour parcourir le type de composant actuellement sélectionné dans la liste déroulante supérieure du panneau.

  • Delete Existing Components – cliquez pour ouvrir la boîte de dialogue Delete Existing Components, puis la page Data Cleanup de Settings de votre Espace de travail, où vous pouvez sélectionner les types de contenu à supprimer.

  • Import Library – cliquez pour ouvrir la boîte de dialogue Windows standard Open, puis sélectionnez une bibliothèque de base de données ou basée sur des fichiers enregistrée dans votre dossier local ou réseau. Après l’ouverture d’un fichier de bibliothèque, le Library Importer in its Simple mode sera lancé avec la bibliothèque sélectionnée chargée.

  • Create Component – cliquez pour ouvrir la boîte de dialogue Create New Component dialog, puis le Component Editor en Single Component Editing mode prêt à définir un nouveau composant.

Le volet Categories du panneau (ou le menu déroulant en mode compact) répertorie tous les composants disponibles de l’Espace de travail sous l’entrée de catégorie All, ainsi que toutes les bibliothèques disponibles. Lorsque le panneau est en mode normal, cliquez sur l’icône de liste Categories ou sur l’icône « pour réduire ou développer l’affichage de la colonne et utilisez le bouton (en haut à droite) pour basculer la visibilité du volet de composants Details. Lors de la navigation dans le volet Categories, les raccourcis clavier Up/Down et PgUp/PgDn peuvent être utilisés pour parcourir la liste. Les raccourcis clavier Left/Right peuvent être utilisés pour ouvrir et fermer les branches individuelles.

Le regroupement Categories des composants de l’Espace de travail est dérivé des paramètres Component Type associés à chaque composant. Par exemple, si le Component Type d’un composant a été spécifié comme Resistor, ce composant sera alors répertorié dans la catégorie Resistor du panneau Components (indépendamment du dossier d’Espace de travail dans lequel il se trouve).

Pour spécifier ou modifier le type d’un composant à la volée, cliquez avec le bouton droit sur son entrée puis sélectionnez l’option Operations » Change Component Type dans le menu contextuel pour ouvrir la boîte de dialogue Choose component type dialog.

Le paramètre Type d’un composant est défini :

Les types de composants sont gérés (créés/modifiés/supprimés) sur la page Data Management – Component Types page de la boîte de dialogue Preferences. Le bouton Templates de la boîte de dialogue ouvre la boîte de dialogue Edit Templates, où le Component Template associé à chaque type de composant peut être spécifié ou modifié.

NOTE: La Category sous laquelle un composant est répertorié est définie par son paramètre Component Type, et n’est pas liée au dossier de l’Espace de travail dans lequel il réside. Par conséquent, si vous déplacez un composant vers un autre dossier via le panneau Explorer, ce changement ne sera pas reflété dans le panneau Components.

Menu Operations

Les options du menu des opérations vous permettent de définir les préférences des bibliothèques basées sur des fichiers, d’effectuer des recherches et de spécifier si la collection de modèles de composants est visible. Pour accéder à ces options, sélectionnez le bouton de menu des opérations en haut à droite du panneau.

  • Create Component – sélectionnez pour ouvrir la boîte de dialogue Create new component, suivie du Component Editor en Single Component Editing mode prêt à définir un nouveau composant.
  • Import Library – sélectionnez pour ouvrir la boîte de dialogue Windows standard Open et sélectionner une bibliothèque de base de données ou basée sur des fichiers enregistrée dans votre dossier local ou réseau. Après l’ouverture d’un fichier de bibliothèque, le Library Importer in its Simple mode sera lancé avec la bibliothèque sélectionnée chargée.
  • Clean-up Library – sélectionnez pour ouvrir la boîte de dialogue Delete Existing Components, puis la page Data Cleanup de Settings de votre Espace de travail, où vous pouvez sélectionner les types de contenu à supprimer.
  • Models – sélectionnez pour inclure les entrées de collections de modèles de bibliothèque dans la liste Categories. Les entrées supplémentaires dans ce mode de navigation incluent les collections de modèles de symbole, d’empreinte et de simulation issues de l’Espace de travail connecté, ainsi que les bibliothèques d’empreintes PCB installées (*.PcbLib).
  • File-based Libraries Preferences – sélectionnez pour ouvrir la boîte de dialogue Available File-based Libraries, où vous pouvez afficher les contrôles permettant d’ajouter des bibliothèques de base de données et basées sur des fichiers au projet en cours ou d’en supprimer, d’installer des bibliothèques et de spécifier des chemins de recherche de bibliothèques. Reportez-vous à la section Gestion des bibliothèques de base de données et basées sur des fichiers disponibles de la page Recherche de composants dans les bibliothèques basées sur des fichiers et de base de données pour en savoir plus.
  • File-based Library Search – sélectionnez pour ouvrir la boîte de dialogue File-based Libraries Search, où vous pouvez rechercher un composant lorsque vous ne savez pas quelle bibliothèque de base de données ou basée sur des fichiers le contient, ni même s’il est disponible. Reportez-vous à la section Recherche de composants dans les bibliothèques de base de données et basées sur des fichiers de la page Recherche de composants dans les bibliothèques basées sur des fichiers et de base de données pour en savoir plus.
  • Refresh – cliquez pour actualiser rapidement le panneau. La sélection actuelle du composant sera conservée.

Liste des composants

Dans la grille de la liste des composants elle-même, le contenu inclus dans la liste est géré par :

  • Définition de l’ordre de tri de la liste des composants – cliquez sur un en-tête de colonne pour trier la liste des composants selon les données de cette colonne. Cliquez de nouveau sur l’en-tête pour inverser l’ordre de tri.

  • Définition de l’ordre des colonnes affichées – faites glisser-déposer un en-tête de colonne vers une nouvelle position.

  • Spécification des colonnes de paramètres affichées – cliquez avec le bouton droit dans un en-tête de colonne et choisissez Select Columns pour ouvrir la boîte de dialogue Select Columns, à l’aide de laquelle vous pouvez contrôler la visibilité d’une colonne de paramètre et modifier son ordre de position.

    La boîte de dialogue Select columns
    La boîte de dialogue Select columns

    • La boîte de dialogue répertorie toutes les colonnes possibles pouvant être affichées dans le panneau Components. Lorsqu’un élément affiche , cette colonne sera affichée dans le panneau Components . Lorsqu’un élément affiche , cette colonne ne sera pas affichée dans le panneau Components. Cliquez sur les symboles pour basculer la fonction d’affichage/masquage.

    • Vous pouvez également contrôler l’affichage de toutes les colonnes en cliquant sur l’icône / dans la barre d’en-tête des colonnes. Lorsque certaines colonnes sont visibles et d’autres masquées, l’icône  est affichée.

    • Placez le curseur sur la barre d’en-tête de la deuxième colonne et cliquez sur l’icône  pour ouvrir une liste déroulante à partir de laquelle vous pouvez choisir la colonne à afficher.

    • Utilisez les boutons  /  pour déplacer l’élément sélectionné vers le haut ou vers le bas dans la liste. Seuls les éléments définis comme visibles () peuvent être déplacés. Cela détermine l’ordre dans lequel les colonnes apparaîtront dans le panneau Components.

  • Regroupement de la liste par données de colonne – cliquez avec le bouton droit dans un en-tête de colonne, sélectionnez l’option Enable Columns Grouping, puis faites glisser un en-tête de colonne (par ex., Footprint) dans la zone de regroupement en haut de la liste. Les entrées de la liste seront regroupées sous chaque paramètre unique (par ex., type d’empreinte) de la colonne de regroupement spécifiée.

    Lors de l’utilisation de Grouping pour regrouper les composants dans la liste, il existe une limite de 10 000 entrées pouvant être prises en charge.

  • Filtrage de la liste par une entrée de colonne spécifique – sélectionnez dans un en-tête de colonne pour afficher une liste de ses entrées de paramètres uniques, puis sélectionnez une entrée afin de limiter les composants répertoriés à ceux qui incluent le paramètre spécifié (par ex., un code de type d’empreinte). Sélectionnez l’option All pour réinitialiser le filtre. Sélectionnez (Custom) pour ouvrir la boîte de dialogue Filter Editor afin d’affiner davantage le filtrage dans la colonne sélectionnée.

Affichage des colonnes

Il existe différentes manières d’afficher le contenu dans le panneau Components. Lorsque vous cliquez avec le bouton droit sur le nom de chaque colonne (Nom, Description, Empreinte), vous pouvez sélectionner parmi les options suivantes, selon la manière dont vous souhaitez afficher les composants :

  • Best Fit – fusionne le contenu des colonnes Name et Descriptions afin qu’elles soient rapprochées, sans espace excessif entre chaque colonne.

  • Best Fit All Columns – fusionne le contenu de toutes les colonnes afin qu’elles soient rapprochées, sans espace excessif entre chaque colonne.

  • Clear Sorting – utilisé pour annuler le tri des colonnes.

  • Enable Columns Grouping – vous permet de faire glisser les en-têtes de colonnes par une colonne spécifique, ce qui vous permet de modifier l’ordre des colonnes Name, Description et Footprint.

  • Select Columns – ouvre la boîte de dialogue Select Columns, qui vous permet de sélectionner d’autres colonnes que vous souhaitez rendre visibles dans cette section.

  • Apply Column Visibility to Child Categories – dans les cas où la catégorie sélectionnée possède une catégorie enfant, utilisez cette commande pour garantir la possibilité de propager les paramètres de visibilité des colonnes des catégories parentes vers les catégories enfants. Cette commande n’est disponible que lorsqu’une catégorie enfant existe.

Recherche et fonctions des composants

Recherche de composants

Pour rechercher des composants disponibles dans le panneau Components, saisissez une expression dans le champ Search et/ou utilisez les sélections Categories et Filters du panneau pour restreindre la liste des composants à vos besoins spécifiques. Les filtres sont pris en charge uniquement pour les composants de l’Espace de travail et, comme dans le Manufacturer Part Search panel, le panneau Components prend en charge les filtres de recherche tenant compte des unités (texte vers nombre). La fonctionnalité de recherche priorise les résultats selon les critères de recherche saisis.

La fonction Search vous permet de sélectionner puis de modifier ou d’ajouter à une chaîne Search active.

Cliquez sur la chaîne de recherche « active » pour l’entrer dans le champ Search. Vous pouvez réutiliser ou modifier cette recherche depuis le champ Search.

Le champ Search prend également en charge les recherches avec caractères génériques, indiqués par un astérisque (*) dans la chaîne.

La boîte de dialogue Find Similar Components, accessible en cliquant avec le bouton droit sur un composant répertorié puis en sélectionnant Find Similar Components, offre la possibilité de définir des préférences de recherche basées sur le composant sélectionné.

Les résultats finaux de la recherche dépendront du type de composant sélectionné, qu’il s’agisse de composants de l’Espace de travail ou non, ainsi que de l’état de connexion à votre Espace de travail. Par exemple, les composants de l’Espace de travail afficheront souvent plus de paramètres qu’un composant hors Espace de travail. Pour regrouper spécifiquement les composants et paramètres identiques ou différents de celui sélectionné, les listes déroulantes peuvent être utilisées pour choisir les options Same, Any ou Different.

Placement des composants

Un composant sélectionné est placé sur un schéma en le faisant glisser-déposer, en sélectionnant Place dans son menu contextuel par clic droit, en utilisant le bouton dans le volet Details, en double-cliquant sur l’entrée du composant requis, ou en utilisant la touche de raccourci Enter.

Pour placer un composant depuis le panneau, vous pouvez :

  • Cliquer sur le bouton Place dans le volet Component Details – le curseur se déplace automatiquement à l’intérieur des limites de la feuille de schéma et le composant apparaît flottant sur le curseur; positionnez-le puis cliquez pour le placer. Après avoir placé un composant, une autre instance du même composant apparaîtra sur le curseur; cliquez avec le bouton droit pour quitter le mode de placement.

    Components panel, placing from component details pane

  • Cliquez avec le bouton droit sur le composant puis sélectionnez Place dans le menu contextuel. Le composant apparaît flottant sur le curseur; positionnez-le puis cliquez pour le placer. Notez que si le panneau flotte au-dessus de l’espace de conception, il s’estompera pour vous permettre de voir le schéma et de placer le composant. Après avoir placé un composant, une autre instance du même composant apparaîtra sur le curseur; cliquez avec le bouton droit pour quitter le mode de placement.

  • Click, Hold&Drag – cliquez et faites glisser le composant depuis la zone de grille du panneau vers une feuille de schéma. Ce mode nécessite de maintenir le bouton de la souris enfoncé ; le composant est placé lorsque vous relâchez le curseur. Après avoir placé le composant, vous pouvez sélectionner un autre composant ou une autre commande.

    Le glisser-déposer place une seule occurrence du composant. Si vous devez placer plusieurs occurrences, utilisez la commande/le bouton Place , ou double-cliquez sur l’entrée du composant.

Le placement d’un composant est d’une grande simplicité. Mais avant toute chose, assurez-vous d’abord que la feuille de schéma (ou le document PCB) destinée à recevoir le composant est ouverte dans Altium Designer et qu’il s’agit du document actif. Si des documents sont ouverts dans plusieurs fenêtres, assurez-vous également que la fenêtre contenant ce document schématique actif a le focus.

Lorsque vous utilisez Altium Designer dans plusieurs fenêtres, si les panneaux Components ou Explorer sont ancrés, quel que soit le mode, dans une fenêtre ne contenant pas le schéma cible, la commande Place restera grisée. Cela s’explique par le fait qu’un clic dans un panneau ancré donne le focus à la fenêtre à laquelle ce panneau est attaché. En revanche, si le panneau est flottant, la fenêtre Altium requise peut recevoir le focus (celle contenant le schéma cible actif), et cette fenêtre conservera le focus pendant le travail dans le panneau.

Placement d’un composant multi-parties

Si le composant en cours de placement comporte plusieurs parties, la partie sélectionnée sous l’image d’aperçu du symbole dans la zone Models du panneau sera placée initialement.

Une fois qu’une partie d’un composant multi-parties est placée, elle peut être changée pour une autre partie de ce composant à l’aide de la liste déroulante Part dans le panneau Properties lorsque la partie est sélectionnée, ou elle peut être remplacée par la partie disponible suivante à l’aide de la commande Edit » Increment Part Number dans les menus principaux ou de la commande Part Actions » Increment Part Number dans le menu contextuel de la partie.

Altium Designer permet de présenter un composant multi-parties soit sous forme d’un symbole unique (toutes les sous-parties), soit sous forme de plusieurs symboles (un pour chaque sous-partie individuelle), en utilisant un seul composant grâce aux modes d’affichage Normal et Alternatif définis (Afficher l’exemple).

  • Si un composant multi-parties comporte des sous-parties vides dans son mode d’affichage (normal ou alternatif), ces sous-parties sont omises lors du placement (Afficher l’exemple).

  • Si un composant multi-parties n’a des primitives définies que dans une seule sous-partie, le suffixe du désignateur est masqué lorsque cette sous-partie est placée sur une feuille de schéma (Afficher l’exemple).

  • Lorsqu’une sous-partie ne comporte aucune primitive pour le mode d’affichage actuellement sélectionné, ou lorsqu’un mode d’affichage ne comporte aucune primitive pour la sous-partie actuellement sélectionnée, l’entrée correspondante dans la liste déroulante Part de Mode du panneau Properties du composant est grisée (). Lorsqu’une telle entrée est sélectionnée dans la liste déroulante, des icônes d’avertissement s’affichent ().

  • Une violation Unused sub-part in component ne se produira pas lors de l’exécution d’une validation de conception si un composant comporte des sous-parties sans primitives et que ces sous-parties ne sont pas placées sur le schéma.

Filtrage des composants

Lors de l’affichage des composants Workspace, le volet Filters est rempli par les options de filtre sélectionnées selon la recherche actuelle et les paramètres disponibles. Le filtrage paramétrique des composants listés offre d’autres possibilités pour localiser un composant spécifique ou un type de composant. Ouvrez le volet Filters à partir du bouton situé au-dessus du volet Categories. En mode compact du panneau, cliquez sur le bouton pour faire apparaître Filters comme extension du panneau.

Notez que les filtres ne sont pris en charge que pour les composants Workspace. Utilisez le champ Filter Search dans le volet pour trouver un filtre de paramètre spécifique.

Javascript ID : Pnl_Components_Filter
  • La capacité de recherche paramétrique du Filters du panneau repose sur la transmission de données de paramètres de composant appropriées depuis le Workspace qui héberge les composants Workspace. Par conséquent, la fonctionnalité Filter peut être désactivée lorsque le logiciel est connecté à un ancien produit serveur Altium. Pour activer Filter pour les versions précédentes du serveur, activez l’option ComponentSearch.LegacyAFS.Filters dans la boîte de dialogue Advanced Settings dialog.

  • Notez que pour qu’un paramètre apparaisse dans le volet Filters, au moins deux valeurs différentes pour ce paramètre doivent être utilisées par les composants de la catégorie sélectionnée. Notez également qu’un maximum de 100 des paramètres les plus populaires uniquement (ceux utilisés par le plus grand nombre de composants dans le Workspace connecté, tous types de composants confondus) est affiché dans le volet Filters. Les paramètres suivants (ou ceux commençant par les noms suivants) sont toujours affichés en haut du volet : Power, Value, Resistance, Res, Capacitance, Case, Package, Tolerance, RoHS, Lead.

Les options Filters du panneau peuvent être adaptées à vos besoins en sélectionnant certains types de paramètres comme Favorites, lesquels sont alors déplacés en haut de la liste pour la catégorie de composant actuelle. Survolez la droite du nom d’un filtre de paramètre et cliquez sur l’icône pour définir ce filtre comme favori. Les paramètres de filtre favoris s’appliquent à chaque catégorie de composant individuellement et y sont enregistrés.

Pour les composants Workspace, le menu contextuel propose des options permettant de modifier le composant via l’éditeur de composants (Edit) et d’effectuer des fonctions de gestion des composants telles que la création et le clonage de composants, ou la modification des Part Choices et du Type du composant sélectionné (Operations).

 
 
 
 
 

Les options d’informations supplémentaires dans le volet Details du composant incluent : l’affichage d’une image du modèle, l’affichage de fiches techniques en ligne (References), des informations Fournisseur en direct (Part Choices), la visualisation des emplacements où la pièce a été utilisée dans des projets Workspace, des feuilles gérées et des blocs de réutilisation (Where Used), et, via le menu contextuel, la possibilité de copier les données de paramètres du composant sélectionnées ou l’ensemble de celles-ci (détails techniques) dans un format délimité par tabulations, ainsi que de réinitialiser les paramètres marqués comme favoris aux cinq paramètres par défaut.

Lors de la navigation parmi les composants dans un Altium 365 Workspace connecté, et si des problèmes concernant l’état du composant sélectionné sont détectés, une indication sera présentée par l’icône (pour les erreurs) ou (pour les erreurs fatales) sur la ligne Component issues au-dessus de la liste des paramètres du composant. Le nombre à droite de l’icône indique le nombre de problèmes détectés. Cliquez sur la flèche vers le bas à droite du nombre pour afficher les courtes descriptions des problèmes.

Exemple de problèmes d’intégrité de bibliothèque détectés.
Exemple de problèmes d’intégrité de bibliothèque détectés.

L’intégrité de la bibliothèque de votre Workspace peut être explorée plus en détail à l’aide de la page du tableau de bord Library Health accessible depuis l’interface du navigateur du Altium 365 Workspace. Voir Library Health Dashboard pour en savoir plus.

Vous pouvez utiliser la fonctionnalité de filtrage personnalisé pour affiner davantage le filtrage dans le panneau Components. ​​​​​​

La fonctionnalité est disponible en :

  1. cliquant sur l’icône de filtre () dans l’en-tête pour afficher la liste déroulante Filter,

  2. qui prend en charge le filtrage par sélection d’un Filter Value (par défaut), ou par configuration d’une valeur Filter Rule définie par l’utilisateur. Si vous sélectionnez une valeur dans la liste, elle est automatiquement convertie en expression (que vous pouvez ensuite modifier).

  3. Si vous sélectionnez Filter Rules pour définir votre propre filtre, vous choisissez alors un opérateur dans la première liste déroulante,

  4. puis vous sélectionnez ou saisissez une valeur de filtre dans la seconde liste déroulante.

  5. Le filtre actuel s’affiche sous la liste des résultats ; cliquez sur le bouton pour ouvrir la boîte de dialogue Filter Editor et modifier votre filtre.

Où utilisé

Sélectionnez un composant Workspace dans le panneau Components pour afficher des informations sur l’endroit où sa dernière révision est actuellement utilisée dans la zone Where Used. La zone fournit des informations de filtrage rapide pour :

  • Projects – les projets Workspace dans lesquels le composant a été utilisé. Les informations sont only présentées une fois que le projet a été enregistré dans le Workspace.

  • Managed Sheets – les feuilles de schéma gérées sur lesquelles le composant a été utilisé. 

  • Reuse Blocks – les blocs de réutilisation stockés dans le cadre de la bibliothèque d’un Workspace connecté.

Notez que les onglets ne seront affichés que si une entité existe dans le Workspace et utilise le composant sélectionné.

Si un composant n’est pas utilisé dans toutes les design variants d’un projet Workspace, l’entrée du projet dans la zone Where Used affichera le nombre de variantes dans lesquelles le composant est utilisé et le nombre total de variantes pour ce projet, ainsi que la liste des variantes dans lesquelles le composant est utilisé ().

Mise en cache des données de composant

Lors de l’utilisation du panneau Components, les données des composants Workspace sont mises en cache depuis le Workspace sur la machine locale. Cela fournit un mode d’accès hors ligne aux composants Workspace lorsque Altium Designer n’est pas connecté au Workspace, et permet donc une navigation et un placement normaux des composants, etc.

Lors du premier lancement du panneau Components dans la session actuelle de Altium Designer, un avertissement s’affichera dans le panneau en mode hors ligne, accompagné de contrôles permettant soit de continuer à utiliser les données de composant mises en cache, soit d’effacer le cache.

Cliquez sur Use Cached Data pour utiliser les composants mis en cache. Cet état sera indiqué par le texte d’avertissement Offline mode – cached data is being used dans la barre inférieure du volet de liste des composants du panneau. Notez que les Filters ne sont pas activés dans ce mode.

Le cache accumule les données de composant au fil du temps et peut être effacé à tout moment (pour tous les Workspaces) à l’aide de l’option Clear Cache disponible sous Known Servers dans la page Data Management – Servers page de la boîte de dialogue Preferences.

Le comportement de mise en cache ne présentera que les composants mis en cache provenant du/des Workspace(s) actuellement connecté(s), tel que Altium 365 Workspace, ce qui signifie que certaines données mises en cache peuvent être désactivées. Ce comportement peut être géré depuis la page Data Management – Servers de la boîte de dialogue Preferences.

Liste des Part Choices

Modifiez la Part Choices List associée à un composant Workspace en sélectionnant l’option Operations » Create/Edit Part Choices dans le menu contextuel de l’entrée.

Utilisez le bouton Edit Part Choices de la boîte de dialogue suivante pour ouvrir la boîte de dialogue Add Part Choices, qui recherchera automatiquement les fabricants de pièces à partir du paramètre Name du composant sélectionné. Désélectionnez le terme de recherche prédéfini pour rechercher manuellement des alternatives. Sur le plan fonctionnel, la boîte de dialogue est une version modale du panneau Manufacturer Part Search panel.

La liste des Part Choices peut être classée en sélectionnant un niveau d’icône étoile approprié, la liste étant alors automatiquement réordonnée avec le choix fabricant le mieux classé en haut.

Les Part Choices accompagnent le composant partout où ses données sont appliquées, par exemple dans une conception schématique, un document BOM, un rapport de sortie, etc.

Lorsqu’un composant est sélectionné dans le panneau Components, sa liste de choix de pièce peut être consultée dans la zone Part Choices du volet Details. Les informations de base (stock, prix unitaire médian et cycle de vie fabricant) sur le choix de pièce associé sont également disponibles en haut du volet Details. La bande colorée associée indique l’adéquation fondamentale de la pièce à l’usage en fonction de son état de cycle de vie déduit – par exemple, un composant signalé comme Obsolete (rouge) est moins recommandé qu’un composant évalué comme Volume Production (vert). Survolez une bande colorée pour voir son état de cycle de vie fabricant.

Si vous utilisez la fonctionnalité d’intégration Silicon Expert ou Z2 Data, des données et des contrôles supplémentaires peuvent être disponibles en haut du volet Details. Reportez-vous aux pages Pulling Part Data from SiliconExpert et Pulling Part Data from Z2Data pour en savoir plus.

Si vous avez activé la fonctionnalité Part Choice Revision Control pour votre Workspace, la sélection de l’option Operations » Create/Edit Part Choices ouvrira l’éditeur de composants (dans son mode Single Component Editing ou Batch Component Editing) au lieu de la boîte de dialogue Edit Part Choices. Appliquez les modifications nécessaires aux choix de pièce puis enregistrez le ou les composants dans le Workspace en tant que révision(s) suivante(s) du composant.

Menu contextuel du panneau Components

Le menu contextuel accessible par clic droit dans le panneau fournit les commandes suivantes :

  • Place [ComponentName/FootprintName/SimulationModelName] – permet de placer le composant actuellement sélectionné ou le modèle de simulation sur le document schématique actif, ou l’empreinte actuellement sélectionnée sur le document PCB actif.

  • Find Similar Components – permet d’ouvrir la boîte de dialogue Find Similar Components dialog afin de définir des critères de recherche pour trouver des composants similaires au composant sélectionné.

  • Navigate to [ComponentName] – permet d’ouvrir le composant Workspace choisi dans le panneau Explorer panel, où vous pouvez accéder aux informations détaillées de l’élément et gérer les paramètres de révision et de cycle de vie des éléments, ainsi que les détails d’utilisation et de chaîne logistique, entre autres options.

  • Edit – cliquez pour modifier le ou les composants Workspace sélectionnés via l’éditeur de composants (dans son mode Single Component Editing ou Batch Component Editing) ou le modèle de domaine sélectionné (symbole, empreinte ou modèle de simulation) dans son éditeur. Si le type de composant actuel est différent du modèle actuellement utilisé, la boîte de dialogue Change component type s’ouvrira (). Utilisez cette boîte de dialogue pour changer le type de composant du composant sélectionné.

  • Create – cliquez pour ouvrir la boîte de dialogue Create new component afin de sélectionner le type de composant lors de l’ajout d’un nouveau composant.

  • Delete – cliquez pour supprimer le ou les composants sélectionnés de votre Workspace connecté.

  • Operations – permet d’accéder à un menu déroulant de fonctions supplémentaires pour les composants Workspace comme décrit ci-dessous.

    • Submit Request – permet d’accéder aux définitions de processus actives de demande de pièce. Si aucune définition de processus active n’est disponible pour le thème de processus Part Requests, le bouton Submit Request sera grisé (indisponible). Il se peut que vous deviez vous déconnecter du Workspace puis vous reconnecter, ou redémarrer Altium Designer pour actualiser.

    • Download – permet de télécharger le ou les composants sélectionnés vers une Integrated Library compilée compressée (*.IntLib), avec son package de bibliothèque source (*.LibPkg) et ses fichiers de bibliothèque. Sélectionnez plusieurs entrées de composant pour télécharger ces composants en une seule session.

    • Make a copy – cliquez pour copier le composant sélectionné. L’éditeur de composants s’ouvre en mode Single Component Editor.

    • Change Component Type – permet d’ouvrir la boîte de dialogue Choose component type (), à partir de laquelle vous pouvez modifier le type du composant actuel pour l’un des autres types définis existants dans la liste. La boîte de dialogue affiche des informations concernant tout modèle de composant associé à un type de composant ainsi que le dossier du Workspace connecté dans lequel les composants de ce type peuvent être trouvés/enregistrés. Cliquez sur bouton permettant de gérer la liste des types de composants disponibles sur la page Gestion des données – Types de composants de la boîte de dialogue Preferences

    • Change State – permet de modifier l’état de révision du ou des composants sélectionnés. Après utilisation de cette commande, la boîte de dialogue Modification d’état par lot s’ouvre et vous permet de changer l’état de révision du ou des composants.

    • Create/Edit Part Choices – permet d’accéder à la boîte de dialogue Edit Part Choices , dans laquelle vous pouvez créer ou modifier la liste des choix de pièces associée au composant Workspace.

      Si la fonctionnalité Part Choice Revision Control est activée pour votre Workspace, la sélection de cette commande ouvrira l’éditeur de composants dans son mode Édition d’un seul composant ou Édition par lot de composants.
    • Full Item History – permet d’accéder à une vue détaillée du composant actuellement sélectionné, ouverte sous forme de nouvel onglet dans Altium Designer. La vue de l’élément fournit une vue très détaillée de l’historique des révisions et du cycle de vie d’un élément spécifique, tout en affichant également tous les éléments qui le composent. La vue comprend aussi une chronologie. Utilisez la chronologie pour examiner la date et l’heure exactes de toute modification apportée au niveau de révision ou à l’état de cycle de vie de cet élément, ainsi que l’auteur de la modification.

     

  • Refresh – cliquez pour actualiser rapidement le panneau. La sélection actuelle des composants sera conservée.

Fonction de comparaison de composants

La fonctionnalité Compare permet de comparer les paramètres de deux composants (pièces) sélectionnés. Cette fonctionnalité est accessible en sélectionnant deux composants dans la zone de grille avec l’icône activée (bleue). La zone Selected Component Details s’ouvre à droite de la zone de grille. La zone supérieure (zone 1 dans l’image ci-dessous) affiche côte à côte une image, le nom, la description et le prix des composants sélectionnés. Cliquez sur le bouton Datasheet pour ouvrir la fiche technique du fabricant (si disponible) du composant associé. Cliquez sur le bouton Place pour placer le composant dans l’espace de conception. Le composant apparaîtra flottant dans l’espace de conception ; cliquez pour placer le composant à l’emplacement souhaité. Vous pouvez continuer à placer d’autres composants, ou faire un clic droit ou appuyer sur Esc pour quitter le mode de placement et revenir au panneau Components.

La zone inférieure (zone 2 dans l’image ci-dessous) affiche une vue côte à côte des paramètres des composants, avec les différences mises en évidence en rouge pour faciliter la comparaison.

La fonctionnalité Compare est également disponible lorsque le panneau Components est en mode compact, bien qu’elle fonctionne un peu différemment. Cette fonctionnalité est accessible en sélectionnant deux composants dans la zone de grille. La zone Selected Component Details s’ouvre sous la zone de grille. La zone supérieure affiche le nom, le prix et la vue des paramètres des composants, avec les différences mises en évidence en rouge pour faciliter la comparaison. La zone inférieure affiche une vue côte à côte des Symbols et Models des composants.

La fonctionnalité Compare et ses fonctions sont également disponibles dans le panneau Manufacturer Part Search.

Modification des symboles et empreintes de composants

Le symbole et l’empreinte d’un composant donné peuvent être masqués dans la section Models du volet Details, auquel on accède en cliquant sur Info button en haut à droite. Une fois masqués, le symbole et l’empreinte sont remplacés par des liens cliquables qui rétablissent l’affichage d’origine des éléments masqués. Il est également possible de redimensionner les modèles affichés. Pour les symboles comme pour les empreintes, cliquez sur le bord inférieur de la zone du modèle et faites-le glisser pour redimensionner l’image.

Notez que la possibilité de masquer et de redimensionner les vues de modèle est également disponible dans le volet Details du panneau Manufacturer Part Search.

Pour un fichier de bibliothèque schématique (*.SchLib) parcouru dans le panneau Components, le symbole et l’empreinte du composant sélectionné peuvent être modifiés à l’aide du bouton en bas à droite de l’aperçu du modèle.

La possibilité de modifier une empreinte est disponible lors de l’accès au Components, à condition que des empreintes valides et liées soient déjà présentes.

Boîtes de dialogue de sélection de composants

Le moteur de recherche et l’affichage utilisés dans le panneau Components sont également appliqués dans d’autres applications d’Altium Designer où un choix de composant est effectué. La fonctionnalité de recherche de composants est incluse dans ces boîtes de dialogue (modales), avec un bouton de confirmation OK et de légères variations dans les commandes d’action disponibles. La boîte de dialogue s’appelle généralement Component Search.

Accès aux composants génériques et placement de ceux-ci

Cette fonctionnalité est en bêta ouverte et disponible lorsque l’option ComponentSearch.GenericComponents est activée dans la boîte de dialogue Paramètres avancés.

Pour accélérer le processus de mise en place des premières étapes d’une conception, le concept de Generic Components standard et de base est disponible. Les composants génériques peuvent être rapidement placés dans une conception sans qu’il soit nécessaire de rechercher et de choisir une pièce fabricant spécifique parmi les sources de composants disponibles. Les composants génériques sont destinés à servir d’espaces réservés, facilement remplacés par un composant approprié plus tard dans le processus de conception – ils peuvent également être considérés comme des composants virtuels ou paramétriques.

Pour en savoir plus sur la création de composants génériques, consultez la page Création de composants génériques .

Lorsqu’Altium Designer est connecté à un Workspace, les composants génériques disponibles sont accessibles depuis le panneau où ils sont exposés lorsque l’option All est sélectionnée dans le volet Categories – ou depuis le menu déroulant supérieur lorsque le panneau est en mode compact. Cliquez sur le bouton dans une vignette de composant générique pour attacher le composant au curseur en vue de son placement dans le document schématique actif. Lorsqu’un composant est placé dans un schéma, les primitives de broche, de ligne et de bordure du symbole – c’est-à-dire son contour – sont colorées en rouge pour indiquer qu’un composant générique est utilisé. Le fait de sélectionner la vignette elle-même dans le panneau Components ouvrira cette catégorie de type de composant dans le panneau.

Placement d’un composant générique depuis le panneau Components
Placement d’un composant générique depuis le panneau Components

Comme les composants génériques ne doivent pas être utilisés dans une conception finale, ils entraîneront une violation ERC – Composant générique – lorsqu’ils sont placés dans un schéma. Le niveau de cette violation – un Fatal Error par défaut – est défini dans la section Violations associées aux composants des paramètres Rapport d’erreurs de la boîte de dialogue Project Options (Project » Project Options).

Sélectionnez un composant générique placé pour accéder à ses propriétés dans le panneau Propriétés, qui ne fournit que les paramètres pertinents pour ce type de composant. Les paramètres disponibles sont déterminés par le modèle de composant associé (Resistors dans l’exemple présenté ici). Les valeurs de paramètres peuvent être saisies manuellement ou sélectionnées dans une liste déroulante proposant des valeurs issues de tous les composants disponibles de ce type.

Javascript ID: GenericComponents_Parameters

Spécification des paramètres d’un composant générique – sélection des valeurs de paramètre dans les listes déroulantes.

Spécification des paramètres d’un composant générique – résultat.

Prise en charge des composants cavalier

Les cavaliers, également appelés ponts filaires, vous permettent de remplacer le routage par un composant cavalier, ce qui constitue souvent un élément essentiel pour réussir la conception d’une carte simple face. Altium Designer prend en charge l’utilisation de composants cavalier via un type de composant spécial Jumper.

Bien que vous puissiez commencer par placer directement les empreintes de cavalier sur le PCB, un flux de travail recommandé commence au niveau du schéma. Pour en savoir plus, consultez la page Utilisation des composants cavalier.

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contenu