Assegnazione dei punti di test sulla scheda

A colpo d'occhio

Questo articolo spiega perché i punti di test sono importanti nella produzione dei PCB e come Altium Designer ti aiuta ad assegnarli sia per i test delle schede nude sia per quelli delle schede assemblate. Illustra le differenze pratiche tra le strategie di test in fase di fabbricazione e di assemblaggio, i vincoli di posizionamento che determinano dove collocare i punti di test e come designare pad e via come punti di test, manualmente o tramite il Testpoint Manager. Se vuoi realizzare una scheda più facile da testare e capire meglio come Altium Designer supporta questo processo, questo articolo ti fornirà solide basi. Continua a leggere per pianificare i punti di test in modo più efficace.

- Comprendi la differenza tra i test di fabbricazione e quelli di assemblaggio e come ciascuno influisce sul posizionamento dei punti di test.
- Scopri i principali aspetti e vincoli che definiscono una buona strategia per i punti di test, tra cui l'accesso ai lati della scheda, le distanze di isolamento, i requisiti della griglia e l'accessibilità delle sonde.
- Scopri come Altium Designer supporta l'assegnazione manuale e automatica dei punti di test tramite le funzionalità di pad, via e Testpoint Manager.
Approfondisci con l'IA:

Il collaudo è una parte importante del processo di produzione delle schede. Dopo la fabbricazione, la scheda viene generalmente collaudata per verificare l'assenza di cortocircuiti o circuiti aperti. Una volta montati tutti i componenti, la scheda viene spesso collaudata nuovamente per verificare l'integrità dei segnali e il funzionamento dei dispositivi. Per agevolare questo processo, è fondamentale prevedere sulla scheda un insieme di punti - Testpoints - accessibili alle sonde delle apparecchiature di collaudo per eseguire le verifiche richieste.

La posizione dei punti di test su una scheda dipende da diversi fattori, tra cui la modalità di collaudo (collaudo della scheda nuda dopo la fabbricazione, collaudo in-circuit dopo l'assemblaggio, ecc.) e il metodo di collaudo (collaudo automatico con sonde mobili e attrezzature a letto d'aghi, collaudo manuale, ecc.). Ad esempio, durante il collaudo della scheda nuda, i componenti non sono ancora montati, quindi tutte le piazzole e i via sono potenzialmente utilizzabili come punti di test. Le posizioni utilizzate per i punti di test durante il collaudo in-circuit dopo l'assemblaggio, invece, saranno quasi sempre diverse. Con i componenti montati, le sonde potrebbero non avere più accesso alle piazzole dei componenti e certamente non potranno accedere alle piazzole e ai via situati sotto un componente!

Altium Designer offre un potente sistema per gestire le esigenze relative ai punti di test e migliorare la collaudabilità delle schede, consentendo di assegnare separatamente, secondo necessità, i punti di test per il collaudo della scheda nuda e/o per il collaudo in-circuit dopo l'assemblaggio. I punti di test possono essere assegnati manualmente oppure in modo più rapido e automatico, utilizzando la finestra di dialogo Testpoint Manager.

Definire la strategia per i punti di test

Prima di procedere all'assegnazione di piazzole e via da utilizzare come punti di test, è opportuno fare un passo indietro e valutare i requisiti. Di seguito sono riportati alcuni aspetti da considerare quando si definisce una strategia per integrare i punti di test in un progetto:

  • Quando si sceglie il lato della scheda su cui consentire il posizionamento dei punti di test, occorre considerare i processi di collaudo e le relative attrezzature che verranno utilizzati. Ad esempio, le sonde accederanno alla scheda solo dal lato inferiore, solo dal lato superiore o da entrambi i lati?
  • Un punto di test sotto un componente (sullo stesso lato della scheda del componente) viene solitamente utilizzato nella fase di collaudo della scheda nuda. Questo aspetto va tenuto presente quando si pianificano le posizioni dei punti di test per il collaudo della scheda assemblata.
  • È consigliabile collocare tutti i punti di test su un solo lato della scheda, utilizzando i via se necessario. Il motivo è che un'attrezzatura di collaudo a doppia testa comporta un costo maggiore rispetto a una a testa singola.
  • Quanto più la disposizione dei punti di test è complessa e non standard, tanto più costoso sarà configurare un'attrezzatura per collaudare la scheda. L'approccio migliore consiste nello sviluppare una metodologia che garantisca una collaudabilità generalizzata. Una strategia per i punti di test ben definita e adattabile consentirà di collaudare progetti diversi in modo efficiente ed economico.
  • Occorre valutare attentamente eventuali requisiti di copertura dei via con solder mask previsti dal progetto. La copertura di un via designato come punto di test impedirà di fatto il contatto con la sonda di collaudo. Anche una copertura parziale con una solder mask liquida fotoimpressionabile (LPI) causerà problemi di contatto, poiché il liquido della maschera tenderà a defluire attraverso il foro del via. È possibile utilizzare una solder mask pelabile per coprire temporaneamente questi via, ma questa soluzione può spesso risultare piuttosto costosa.
  • Collaborare strettamente con i fornitori di fabbricazione e assemblaggio per assicurarsi che, nella definizione dei punti di test, vengano presi in considerazione tutti i parametri di progetto specifici. Questi possono includere distanze minime tra punti di test e tra punti di test e componenti più restrittive rispetto alle normali distanze minime di posizionamento e sbroglio.

Le sezioni seguenti approfondiscono il collaudo dopo la fabbricazione e dopo l'assemblaggio, inclusi i vincoli specifici dei punti di test e le considerazioni associate a ciascuna fase.

Collaudo dopo la fabbricazione

Il collaudo dopo la fabbricazione riguarda la verifica di un circuito stampato nella fase precedente all'assemblaggio, prima che sulla scheda venga montato qualsiasi componente. Per questo motivo viene spesso definito collaudo della scheda nuda. Questo metodo di collaudo prevede generalmente l'utilizzo di un sistema a sonde mobili per verificare le reti una alla volta. In sostanza, due sonde vengono programmate per funzionare in modo coordinato: una invia un impulso attraverso una rete, mentre l'altra rileva la presenza (o l'assenza) del segnale.

Due scenari di collaudo comuni per le schede nude sono:

  1. Verificare che i percorsi in rame progettati per essere continui da un'estremità all'altra trasmettano un segnale pulito (al di sotto di una soglia di impedenza massima consentita), senza interruzioni.
  2. Verificare che non vi siano cortocircuiti tra le reti.

Collaudo dopo l'assemblaggio

Il collaudo dopo l'assemblaggio riguarda la verifica di un circuito stampato nella fase successiva all'assemblaggio, dopo che sulla scheda sono stati montati tutti i componenti specificati nella relativa distinta base (BOM). Per questo motivo viene spesso definito collaudo in-circuit o elettrico. Questo metodo di collaudo prevede generalmente (ma non esclusivamente!) l'utilizzo di un'attrezzatura a letto d'aghi configurata manualmente. A seconda del tipo di collaudo eseguito con l'attrezzatura, la scheda può essere alimentata oppure no.

Due scenari di collaudo comuni per le schede assemblate con metodo in-circuit sono:

  1. Accedere simultaneamente con le sonde a un punto di test dedicato per ciascuna rete (o rete di interesse). A tale scopo, si invia un impulso attraverso ciascuna sonda singolarmente e si rilevano i risultati della ricezione del segnale su tutte le altre sonde.
  2. Testare componenti/bus specifici per assicurarsi che il dispositivo stesso funzioni correttamente. Si tratta di test specializzati che possono essere eseguiti con diversi metodi di collaudo. Nel caso più semplice, è possibile utilizzare un'attrezzatura a letto d'aghi per eseguire test tra i pad dei componenti.

Supporto dei punti di test su pad e via

Altium Designer offre un supporto completo per i punti di test, consentendo di specificare pad (a foro passante o SMD) e/o via da utilizzare come punti di test nel collaudo di fabbricazione e/o di assemblaggio. Un pad o via viene designato come punto di test impostando le relative proprietà e rispondendo a due domande fondamentali:

  • Il pad/via deve essere utilizzato come punto di test per il collaudo di fabbricazione e/o di assemblaggio?
  • Su quale lato della scheda deve essere utilizzato il pad/via come punto di test: superiore, inferiore o entrambi?

Queste proprietà sono disponibili nel pannello Properties quando nello spazio di progettazione è selezionato, rispettivamente, un oggetto pad (vedere Proprietà dei pad) o via (vedere Proprietà dei via).

Un pad o via selezionato viene designato come punto di test tramite le relative opzioni disponibili nel pannello Properties.Un pad o via selezionato viene designato come punto di test tramite le relative opzioni disponibili nel pannello Properties.

Per semplificare il processo ed evitare di dover impostare manualmente le proprietà dei punti di test dei pad/via, Altium Designer offre un metodo per assegnare automaticamente i punti di test in base alle regole di progettazione definite, utilizzando il Gestore dei punti di test. Questa assegnazione automatica imposta di volta in volta le proprietà pertinenti del pad/via. È inoltre possibile specificare manualmente i punti di test, intervenendo in pratica su ciascun pad/via, per avere il pieno controllo dello schema dei punti di test adottato per la scheda.
Quando si aprono progetti PCB creati con una versione del software precedente alla release Summer 09, tutte le opzioni dei punti di test abilitate diventeranno opzioni dei punti di test Fabrication abilitate.

Regole di progettazione dei punti di test

I vincoli di un progetto PCB devono essere studiati e implementati sotto forma di un insieme ben calibrato di regole di progettazione. Per implementare uno schema efficace dei punti di test, in cui tutti i punti definiti siano accessibili e utilizzabili durante il collaudo della scheda nuda e/o in-circuit, è necessario stabilire vincoli adeguati. A tale scopo, nel sistema delle regole di progettazione dell'editor PCB è possibile definire i seguenti tipi di regole:

Accedere alle regole di questi tipi e definirle nella finestra di dialogo Editor delle regole e dei vincoli PCB (Design » Rules).

Definire regole di progettazione separate per stabilire quali pad e/o via del progetto possano essere utilizzati come punti di test di fabbricazione e di assemblaggio e quali net richiedano punti di test.Definire regole di progettazione separate per stabilire quali pad e/o via del progetto possano essere utilizzati come punti di test di fabbricazione e di assemblaggio e quali net richiedano punti di test.

Le regole di stile e utilizzo dei punti di test sono identiche, in termini di vincoli, per le due modalità di collaudo (fabbricazione e assemblaggio). La regola di stile specifica essenzialmente i vincoli che un pad o via deve soddisfare per poter essere selezionato come punto di test. La regola di utilizzo specifica quali net richiedono un punto di test.

Vincoli predefiniti per le regole di utilizzo dei punti di test (in alto) e di stile dei punti di test (in basso).Vincoli predefiniti per le regole di utilizzo dei punti di test (in alto) e di stile dei punti di test (in basso).

Quando si definisce una regola di stile, è possibile crearne rapidamente l'ambito di applicazione per individuare con precisione gli oggetti pad e/o via da considerare come punti di test, utilizzando le opzioni disponibili nell'area Rule Scope Helper.

Le regole di progettazione dei punti di test vengono utilizzate dal Gestore dei punti di test, dall'Autorouter, dai processi DRC online e batch e anche durante la generazione degli output.

Sono disponibili regole predefinite di stile e utilizzo dei punti di test per la fabbricazione e l'assemblaggio. È opportuno verificare che queste regole soddisfino i requisiti della scheda e modificarle secondo necessità. Se sono necessarie più regole dello stesso tipo, utilizzare la priorità delle regole di progettazione per assicurarsi che quelle con un ambito di applicazione più specifico vengano applicate per prime, ad esempio durante l'esecuzione di un DRC.

Affinché il Testpoint Manager possa assegnare correttamente i punti di test, deve always esistere almeno una regola di stile dei punti di test corrispondente con un ambito di applicazione pari a All.
Quando si aprono progetti PCB o si importano regole di progettazione creati con una versione del software precedente alla release Summer 09, le regole di stile dei punti di test diventeranno regole di stile dei punti di test di fabbricazione e le regole di utilizzo dei punti di test diventeranno regole di utilizzo dei punti di test di fabbricazione.

Gestione dei punti di test

L'assegnazione manuale dei punti di test può essere un'attività meticolosa e laboriosa, a maggior ragione su una scheda complessa, popolata da centinaia di componenti su entrambi i lati. Per semplificare la gestione dei punti di test nei progetti delle schede, Altium Designer mette a disposizione nell'editor PCB un Testpoint Manager. Il Testpoint Manager consente di assegnare automaticamente i punti di test, per il collaudo di fabbricazione della scheda nuda e/o il collaudo in-circuit della scheda assemblata, in base alle regole di progettazione definite. Questa assegnazione automatica imposta, in ciascun caso, le proprietà dei punti di test pertinenti per la piazzola o la via.

Per accedervi, scegliere il comando Tools » Testpoint Manager dai menu principali.

Gestisci i requisiti dei punti di test di fabbricazione e assemblaggio in modo rapido ed efficiente utilizzando il Testpoint Manager.Gestisci i requisiti dei punti di test di fabbricazione e assemblaggio in modo rapido ed efficiente utilizzando il Testpoint Manager.

Utilizza la finestra di dialogo per assegnare e rimuovere automaticamente i punti di test da un'unica comoda posizione. Nella sezione Testpoint Net Status è disponibile un elenco di tutte le reti del progetto, con uno stato che indica la copertura dei punti di test, Complete o Incomplete, sia per il collaudo di fabbricazione della scheda nuda sia per il collaudo in-circuit della scheda assemblata. Fai clic sui pulsanti Fabrication Testpoints o Assembly Testpoints oppure fai clic con il pulsante destro del mouse nella griglia per accedere ai comandi che consentono di assegnare o rimuovere quel tipo di punto di test. Tieni presente che puoi selezionare manualmente le reti nella sezione superiore della finestra di dialogo per assegnare o rimuovere selettivamente i punti di test.

Che si assegnino punti di test ad alcune o a tutte le reti di un progetto, il Testpoint Manager segue le regole di stile e utilizzo definite per i punti di test di fabbricazione e assemblaggio. Per visualizzare l'ordine in cui vengono cercati gli oggetti validi, fai clic sul pulsante Search Order.

Per modificare l'ordine, fai clic con il pulsante destro del mouse su una voce nell'elenco dell'ordine di ricerca e utilizza i comandi del menu contestuale oppure le scorciatoie Shift+Up Arrow e Shift+Down Arrow per spostarla verso l'alto o verso il basso nell'elenco.
Se a una rete è assegnato un punto di test che viola una regola di progettazione applicabile ai punti di test, questo verrà indicato Illegal nella sezione Testpoint Net Status della finestra di dialogo Testpoint Manager. Utilizza la funzionalità di verifica delle regole di progettazione dell'editor PCB per verificare la validità dei punti di test assegnati.

La sezione Status Summaries fornisce un riepilogo completo dello stato dei punti di test della scheda per entrambe le modalità di collaudo. Questa sezione viene aggiornata a ogni operazione di assegnazione o rimozione. Per informazioni più dettagliate, utilizza la sezione Assignment Results. Questa fornisce, ad esempio, dettagli sul numero di piazzole e via sul lato superiore e inferiore coinvolti in un'assegnazione o rimozione, insieme a un'indicazione degli eventuali errori.

Verifica della validità dei punti di test

Le regole definite per i punti di test di fabbricazione e assemblaggio vengono rispettate nell'ambito della funzionalità di verifica delle regole di progettazione (DRC) dell'editor PCB. La verifica DRC online e/o in batch può essere abilitata per i vari tipi di regole nella finestra di dialogo Design Rule Checker (Tools » Design Rule Check).

Includi le regole di progettazione dei punti di test nei processi DRC online o in batch.Includi le regole di progettazione dei punti di test nei processi DRC online o in batch.

Campi di query relativi ai punti di test

Per supportare i vari punti di test di fabbricazione e assemblaggio che possono essere assegnati in un progetto, sono disponibili le seguenti parole chiave da utilizzare per individuare i punti di test mediante espressioni logiche di query. Ciascuna delle seguenti è disponibile nella categoria Funzioni PCB - Campi quando si utilizza l'assistente query:

  • IsAssyTestpoint - è un punto di test di assemblaggio.
  • IsFabTestpoint - è un punto di test di fabbricazione.
  • IsTestpoint - è un punto di test sul lato superiore o inferiore.
  • Testpoint - è un punto di test sul lato superiore o inferiore?
  • TestpointAssy - è un punto di test di assemblaggio?
  • TestpointAssyBottom - è un punto di test di assemblaggio sul lato inferiore?
  • TestpointAssyTop - è un punto di test di assemblaggio sul lato superiore?
  • TestpointBottom - è un punto di test sul lato inferiore?
  • TestpointFab - è un punto di test di fabbricazione?
  • TestpointFabBottom - è un punto di test di fabbricazione sul lato inferiore?
  • TestpointFabTop - è un punto di test di fabbricazione sul lato superiore?
  • TestpointTop - è un punto di test sul lato superiore?

Crea espressioni logiche per le query per individuare e restituire i punti di test nel progetto secondo le tue esigenze. Di seguito sono riportati alcuni esempi di espressioni logiche di query che individuano i punti di test di fabbricazione e assemblaggio:

  1. (ObjectKind = 'Pad') And (TestpointAssy = 'True')
    Individua tutte le piazzole che sono punti di test di assemblaggio.
  2. IsPad And (TestpointAssyTop = 'True')
    Individua tutte le piazzole che sono punti di test di assemblaggio sul lato superiore.
  3. (ObjectKind = 'Pad') And (TestpointFab = 'True')
    Individua tutte le piazzole che sono punti di test di fabbricazione.
  4. ((IsPad Or IsVia)) And (TestpointAssy = 'True')
    Individua tutte le piazzole e le via che sono punti di test di assemblaggio.
  5. ((IsPad Or IsVia)) And IsFabTestpoint
    Individua tutte le piazzole e le via che sono punti di test di fabbricazione.

Generazione dei report dei punti di test

Altium Designer include generatori di report dedicati rispettivamente alla generazione dei report dei punti di test di fabbricazione e assemblaggio. Questi due generatori di report utilizzano le proprietà dei punti di test pertinenti per le primitive piazzola e via presenti in un progetto.

Un report dei punti di test di fabbricazione utilizza solo le impostazioni dei punti di test Fabrication delle piazzole e delle via. Un report dei punti di test di assemblaggio utilizza solo le impostazioni dei punti di test Assembly .

I report possono essere generati in due modi:

  • Direttamente dal documento PCB, utilizzando i comandi File » Fabrication Outputs » Test Point Report e File » Assembly Outputs » Test Point Report.
  • Utilizzando output opportunamente configurati e definiti in un file di configurazione Output Job (*.OutJob).
Per ulteriori informazioni sui file di configurazione Output Job, consulta Preparazione dei dati di produzione con gli Output Job.

Includi e configura gli output dei report dei punti di test di fabbricazione e assemblaggio in un file di configurazione Output Job autonomo e versatile. Una volta definiti, ottieni i tuoi report con un semplice clic!Includi e configura gli output dei report dei punti di test di fabbricazione e assemblaggio in un file di configurazione Output Job autonomo e versatile. Una volta definiti, ottieni i tuoi report con un semplice clic!

Indipendentemente dal metodo utilizzato per generare un report, le relative opzioni vengono definite nella stessa finestra di dialogo. Per un report dei punti di test di fabbricazione, si utilizza la finestra di dialogo di configurazione dei punti di test di fabbricazione. Per un report dei punti di test di assemblaggio, si utilizza la finestra di dialogo di configurazione dei punti di test di assemblaggio. Le opzioni dei report sono identiche nelle due finestre di dialogo.

Definisci le opzioni del report, incluso il formato del file generato, utilizzando la relativa finestra di dialogo di configurazione. 
Definisci le opzioni del report, incluso il formato del file generato, utilizzando la relativa finestra di dialogo di configurazione.

Le impostazioni definite in una finestra di dialogo Testpoint Setup quando si genera un output direttamente dal PCB sono distinte e separate da quelle definite per lo stesso tipo di output in un file di configurazione Output Job. Nel primo caso, le impostazioni vengono memorizzate nel file di progetto, mentre nel secondo vengono memorizzate nel file Output Job.
Le opzioni nella sezione Coordinate Positions di una finestra di dialogo consentono di esportare le posizioni dei punti di test, in tutti i formati di report, rispetto all'origine assoluta della scheda o all'origine corrente della scheda.
Tutti i tipi di report dei punti di test supportano le matrici di schede incorporate. Quando si esegue l'esportazione da un documento PCB contenente più matrici di schede incorporate, vengono prodotti più file di netlist IPC-D-356A.

Ruolo del file di netlist IPC-D-356A

Uno dei tre formati di output dei report dei punti di test è il file di netlist IPC-D-356A. Questo file viene generalmente utilizzato per la modalità di collaudo di fabbricazione della scheda nuda. Il file IPC viene post-elaborato per ottenere i comandi che pilotano un dispositivo di collaudo a sonde mobili.

Indipendentemente dagli elementi specificamente identificati come posizioni dei punti di test in un file IPC-D-356A, i produttori di schede possono generalmente utilizzare i dati del file per eseguire qualsiasi tipo di collaudo desiderino, anche se, a seconda delle circostanze e del contenuto del file, potrebbe essere necessario un intervento manuale.

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents