Inclusi i dettagli di progettazione
A colpo d'occhio
- Scopri quali dettagli della documentazione PCB possono essere aggiunti nell'editor PCB o nell'editor delle librerie PCB e come utilizzare i layer meccanici per organizzarli.
- Scopri cosa includono le tabelle dello stackup dei layer e le tabelle di foratura, dove possono essere posizionate e come si aggiornano o rispecchiano il progetto corrente della scheda.
- Comprendi le principali opzioni di posizionamento, spostamento, ridimensionamento e configurazione delle proprietà che determinano l'aspetto di questi elementi di documentazione negli output del PCB.
Molti degli output generati richiedono dettagli aggiuntivi. Ad esempio, il disegno di produzione richiede quote, il disegno di assemblaggio potrebbe richiedere una vista ingrandita di un'area specifica della scheda e il disegno di fabbricazione richiede una tabella dello stackup e una tabella di foratura. Questi tipi di dettagli possono essere aggiunti nell'editor PCB o nell'editor delle librerie PCB.
Layer di disegno generici
Nell'editor PCB, dettagli come quote e istruzioni di fabbricazione e assemblaggio vengono aggiunti sui layer meccanici. Il software supporta un numero illimitato di layer meccanici generici, che vengono abilitati nel pannello View Configuration. Questi layer possono essere denominati secondo necessità (fai clic con il pulsante destro del mouse sul nome, quindi seleziona Edit Layer) e inclusi nelle stampe e negli output di fabbricazione basati sui layer.
Tabella dello stackup

È possibile posizionare una tabella dello stackup in un documento PCB accanto al progetto stesso. La tabella fornisce un riepilogo dettagliato degli stackup della scheda e dell'assegnazione dei gruppi di layer.
Una tabella dello stackup è un oggetto grafico tabellare che documenta i layer, i materiali, gli spessori e le costanti dielettriche implementati nel progetto PCB corrente. Viene posizionata accanto al progetto della scheda nello spazio di progettazione e include anche una legenda grafica e una mappa delle opzioni che mostra lo stackup utilizzato in ciascuna regione della scheda. Una tabella dello stackup riflette le configurazioni dei layer definite tramite Layer Stack Manager ed è un importante elemento di documentazione per i progetti con una struttura dello stackup complessa, come i progetti rigido-flessibili.
La tabella dello stackup è disponibile nell'editor PCB quando la vista dello spazio di progettazione è impostata sulla modalità 2D normale (scorciatoia 2). Dopo aver avviato il comando di posizionamento della tabella dello stackup (Place » Layer Stack Table), il cursore assume la forma di una croce e viene attivata la modalità di posizionamento della tabella dello stackup. Il posizionamento avviene eseguendo la seguente sequenza di azioni:
- Fai clic per posizionare la tabella.
- L'editor rimane in modalità di posizionamento della tabella dello stackup, pronto a posizionare un'altra tabella, se necessario. In caso contrario, fai clic con il pulsante destro del mouse o premi Esc per uscire dalla modalità di posizionamento.
Durante il posizionamento, mentre la tabella dello stackup è ancora agganciata al cursore e prima che il suo punto centrale venga fissato, è possibile eseguire le seguenti azioni aggiuntive:
- Premi il tasto Alt per vincolare la direzione del movimento all'asse orizzontale o verticale, a seconda della direzione iniziale del movimento.
- Premi Spacebar per ruotare la tabella dello stackup in senso antiorario oppure Shift+Spacebar per ruotarla in senso orario. La rotazione avviene a incrementi di 90°.
Per spostare una tabella dello stackup, fai clic sulla tabella e, tenendo premuto il pulsante del mouse, trascinala nella posizione desiderata.

Seleziona e trascina per riposizionare una tabella dello stackup.
Proprietà della tabella dello stackup

La modalità Layer Stack Table del pannello Properties.
Posizione
-
(X/Y)
- X (primo campo) - la coordinata X (orizzontale) corrente del punto di riferimento dell'oggetto, rispetto all'origine corrente dello spazio di progettazione. Modifica questo valore per cambiare la posizione X dell'oggetto. Il valore può essere inserito in unità metriche o imperiali; includi le unità quando inserisci un valore espresso in unità diverse da quelle predefinite correnti.
- Y (secondo campo) - la coordinata Y (verticale) corrente del punto di riferimento dell'oggetto, rispetto all'origine corrente. Modifica questo valore per cambiare la posizione Y dell'oggetto. Il valore può essere inserito in unità metriche o imperiali; includi le unità quando inserisci un valore espresso in unità diverse da quelle predefinite correnti.
- Rotation - l'angolo di rotazione dell'oggetto (in gradi), misurato in senso antiorario a partire da zero (l'orizzontale 3 o'clock). Modifica questo valore per cambiare la rotazione dell'oggetto. La risoluzione angolare minima è di 0,001°.
Proprietà
- Layer - il layer a cui è attualmente assegnata la tabella. Utilizza il menu a discesa per selezionare un layer diverso.
- Alignment - utilizza il menu a discesa per selezionare l'allineamento desiderato.
-
Units - utilizza il menu a discesa per selezionare
Metric (mm)oImperial (mil). - Show Board Map - abilita questa opzione per visualizzare un contorno della scheda che mostra come i vari stackup sono assegnati alle regioni della scheda. Utilizza il cursore per modificare la scala del contorno della scheda visualizzato.
- Show Total Board Thickness - abilita questa opzione per visualizzare lo spessore totale della scheda sotto la griglia nella tabella dello stackup.
- Line Width - specifica lo spessore del tratto del testo all'interno della tabella. Line Width influisce sullo spessore del tratto del testo.
- Text Height - l'altezza corrente dei caratteri del testo. Specifica l'altezza del testo all'interno della tabella. Text Height influisce anche sulle dimensioni della tabella. Se l'altezza del testo viene aumentata, la tabella viene ingrandita automaticamente.
Tipo di carattere
-
TrueType - utilizza questo campo per scegliere il carattere TrueType desiderato. L'elenco a discesa Font contiene i caratteri TrueType e OpenType (un'estensione di TrueType) presenti nella cartella
\Windows\Fonts. Nota che l'elenco include solo le voci relative ai caratteri di base rilevati con nomi univoci. Utilizza le opzioni B (bold) e I (Italic) per dare enfasi al testo. -
Stroke
-
Font - utilizzare questo campo per scegliere il font a tratti desiderato. Le opzioni disponibili sono:
-
Default- un semplice font vettoriale che supporta il tracciamento a penna e il fotoplotting vettoriale. -
Serif- un font più complesso che rallenta la generazione degli output vettoriali, come Gerber. -
Sans Serif- un font più complesso che rallenta la generazione degli output vettoriali, come Gerber.
-
-
Font - utilizzare questo campo per scegliere il font a tratti desiderato. Le opzioni disponibili sono:
-
Stroke Width - visualizza lo spessore attuale del tratto.
Colonne
Utilizzare quest'area per specificare quali colonne visualizzare nella tabella dello stack dei layer, l'allineamento del testo in ciascuna colonna e la larghezza complessiva delle colonne.
- Caption - il titolo della colonna da visualizzare.
- Align - fare clic sulla cella di allineamento dell'intestazione che si desidera allineare. Continuare a fare clic per scorrere le opzioni di allineamento (sinistra, centro e destra). Ogni clic sul campo di allineamento modifica l'allineamento del testo della colonna corrispondente nella tabella.
-
Width - fare clic nel campo per modificare la larghezza dell'intestazione selezionata. Quando è specificato
Auto, il sistema regola automaticamente la larghezza della colonna in base al testo inserito al suo interno. Se lo si desidera, è possibile inserire la larghezza richiesta. - Add - utilizzare il menu a discesa per aggiungere una colonna alla tabella dello stack dei layer scegliendo tra le opzioni disponibili. Nel menu a discesa, fare clic sull'intestazione che si desidera visualizzare nella tabella.
- Up - fare clic per spostare l'intestazione selezionata di una colonna verso sinistra nella tabella. Utilizzare ripetutamente il pulsante Up per spostare la colonna selezionata di ulteriori colonne verso sinistra.
- Down - fare clic per spostare l'intestazione selezionata di una colonna verso destra nella tabella. Utilizzare ripetutamente il pulsante Down per spostare la colonna selezionata di ulteriori colonne verso destra.
-
- fare clic per eliminare l'intestazione selezionata dalla tabella. Nella tabella viene visualizzata una richiesta di conferma dell'eliminazione dell'elemento selezionato. Fare clic su Yes per eliminarlo; su No per non eliminarlo.
Tabella di foratura

La tabella di foratura presenta un riepilogo aggiornato in tempo reale di tutti i fori presenti sulla scheda
Una tabella di foratura (nota anche come tabella del disegno di foratura o legenda del disegno di foratura) è un elemento standard necessario per la produzione di un circuito stampato. La tabella di foratura elenca le dimensioni e il numero dei fori per ciascuna punta utilizzata sulla scheda. Ogni diametro di foratura può essere rappresentato da un simbolo, una lettera o dalla dimensione effettiva del foro. Quando viene generato un disegno di foratura per la scheda, ogni posizione di foratura viene contrassegnata da un simbolo. La tabella di foratura si aggiorna in tempo reale: quando oggetti contenenti fori, come pad e via, vengono posizionati nel progetto PCB o rimossi da esso, la tabella viene aggiornata.
Una tabella di foratura può essere posizionata solo nell'editor PCB. Dopo l'avvio del comando, al cursore viene agganciata una tabella di foratura. Portare la tabella in una posizione adatta all'esterno della scheda, quindi fare clic o premere Enter per posizionarla.
Durante il posizionamento, mentre la tabella di foratura è ancora agganciata al cursore e prima che venga fissata, è possibile eseguire le seguenti azioni aggiuntive:
- Premere il tasto Tab per sospendere il posizionamento e accedere alla modalità Tabella di foratura del pannello Properties , da cui è possibile modificarne le proprietà al volo. Fare clic sul pulsante di pausa in sovrimpressione per riprendere il posizionamento.
- Premere il tasto Alt per vincolare la direzione del movimento all'asse orizzontale o verticale in base alla direzione iniziale del movimento.
Spostamento di una tabella di foratura
Fare clic e tenere premuto in un punto qualsiasi all'interno della tabella di foratura, quindi spostarla nella posizione desiderata nello spazio di progettazione dell'editor PCB.
Ridimensionamento interattivo di una tabella di foratura
La tabella di foratura viene dimensionata automaticamente in base all'impostazione Text Height specificata, al numero di diametri dei fori diversi (righe) e al numero di colonne definite. Per ridimensionare la tabella in modo interattivo, fare clic una volta per selezionarla, quindi fare clic e tenere premuto su un vertice d'angolo e spostarlo fino a ottenere le dimensioni desiderate. Si noti che il ridimensionamento interattivo della tabella aumenta o diminuisce anche la dimensione del font.
Cambio interattivo della coppia di layer da visualizzare in anteprima
Quando la scheda include coppie di layer, la coppia visualizzata è controllata dall'opzione Layers Pairs nella modalità Drill Table del pannello Properties .
La coppia di layer selezionata può essere cambiata anche utilizzando:
-
Il menu contestuale dell'editor PCB - fare clic con il pulsante destro del mouse sulla tabella di foratura, quindi selezionare la coppia di layer desiderata nel sottomenu Drill Table, come mostrato nell'immagine seguente.

Fare clic con il pulsante destro del mouse sulla tabella di foratura per visualizzare un'altra coppia di layer -
Il menu di selezione della coppia di layer, accessibile dalla scheda del layer nella parte inferiore dello spazio di progettazione, come mostrato nell'immagine seguente.
Proprietà della tabella di foratura

La modalità Drill Table del pannello Properties
Azioni
Refresh – fare clic sul pulsante per aggiornare la tabella di foratura con i dati attuali dei simboli di foratura del PCB.
Posizione
-
(X/Y) – le coordinate X e Y correnti del punto di riferimento della tabella di foratura. Il punto di riferimento è l'angolo inferiore sinistro se Alignment =
Bottom, oppure l'angolo superiore sinistro se Alignment =Top. - Rotation – angolo di rotazione della tabella di foratura, espresso in gradi.
Proprietà
-
Layer Pairs – la tabella di foratura supporta le schede multistrato che utilizzano la foratura per coppie di layer. Utilizza il menu a discesa per selezionare una coppia di layer definita nella scheda Tipi di via del Gestore dello stack dei layer oppure una delle seguenti opzioni:
- All Layer Pairs (Composite table) – visualizza le informazioni per tutte le coppie di layer.
-
All Layer Pairs (Separate tables) – visualizza le informazioni per ciascuna coppia di layer in una tabella separata.
- Top - Bottom – mostra solo i fori passanti.
- Counterhole Bottom – mostra solo i fori con lamatura o svasatura sul lato inferiore del PCB.
- Counterhole Top – mostra solo i fori con lamatura o svasatura sul lato superiore del PCB.
- Text Height – visualizza l'altezza del testo.
Tipo di carattere
-
TrueType – seleziona per utilizzare i caratteri disponibili sul PC (nella cartella \Windows\Fonts). I caratteri TrueType offrono il supporto completo per Unicode. Per impostazione predefinita, il software crea un collegamento al carattere TrueType utilizzato (i caratteri non vengono memorizzati nel file PCB), pertanto lo stesso carattere deve essere presente su ogni PC su cui viene trasferito il progetto. In alternativa, incorpora i caratteri TrueType utilizzati nel file PCB mediante le opzioni nella pagina Editor PCB – Caratteri TrueType della finestra di dialogo Preferences, dove puoi anche selezionare un Substitution Font da utilizzare se un carattere non incorporato non è disponibile.
- Font – utilizza il menu a discesa per selezionare il carattere TrueType desiderato. Utilizza B per applicare il grassetto o I per applicare il corsivo al testo.
-
Stroke
-
Font – utilizza il menu a discesa per selezionare il carattere a tratto desiderato. Le opzioni sono:
-
Default– un semplice carattere vettoriale progettato per il tracciamento a penna e il fotoplotting vettoriale. -
Sans Serif -
Serif
-
- Stroke Width – visualizza lo spessore del tratto.
-
Font – utilizza il menu a discesa per selezionare il carattere a tratto desiderato. Le opzioni sono:
- Show Footer – attiva/disattiva la visualizzazione del piè di pagina della tabella.
- Alignment – la tabella può essere costruita dal basso verso l'alto (Bottom) oppure dall'alto verso il basso (Top). Utilizza questa impostazione per consentire variazioni delle dimensioni della tabella senza influire sugli oggetti circostanti nell'area di progettazione.
- Table Border Width – spessore delle linee utilizzate per creare il bordo della tabella.
-
Drill Symbols – fai clic per aprire la finestra di dialogo Drill Symbols, in cui puoi assegnare simboli/lettere alle dimensioni dei fori.
Opzioni e controlli della finestra di dialogo Simboli di foratura
Grid Area
L'area della griglia visualizza informazioni dettagliate sull'associazione di un simbolo a una dimensione del foro. Può essere personalizzata facendo clic sull'intestazione di una colonna e trascinandola per modificare l'ordine delle colonne, oppure facendo clic con il pulsante destro del mouse sull'intestazione di una colonna e selezionando/deselezionando la casella di controllo per mostrare/nascondere la colonna.
Grouping
Fai clic sul pulsante Grouping per impostare le proprietà da utilizzare per controllare l'assegnazione dei simboli alle forature (fori). I fori vengono inizialmente raggruppati in base alla dimensione, quindi vengono assegnati simboli distinti ogni volta che viene abilitata un'opzione di raggruppamento che li identifica univocamente. Ad esempio, il progetto potrebbe includere un pad rotondo con un foro da 1 mm e un altro pad quadrato con un foro da 1 mm. Se Pad Shape non è abilitato in Grouping, verrà assegnato loro lo stesso simbolo. Se invece Pad Shape è abilitato in Grouping, verranno assegnati loro simboli distinti.
Graphic Symbol
Ogni posizione di foratura può essere rappresentata da un simbolo, una lettera o una stringa che mostra la dimensione effettiva del foro. Queste opzioni controllano lo stile e le dimensioni del simbolo:
-
Symbol - seleziona per utilizzare un simbolo in corrispondenza di ogni foro. Il software include 15 stili di simbolo predefiniti, come mostrato nell'immagine seguente. Se sono presenti più di 15 dimensioni dei fori, vengono assegnati automaticamente caratteri alfabetici.
- Character - seleziona per utilizzare un carattere alfabetico in corrispondenza di ogni foro.
- Symbol Size - l'altezza del simbolo/della lettera visualizzati sul layer del disegno di foratura. Nota che questa impostazione si applica a tutti i simboli/le lettere utilizzati nel disegno di foratura.
Draw Symbols
Queste opzioni controllano lo stile dei simboli di foratura e quando devono essere visualizzati:
- Show Symbols - mostra un simbolo in corrispondenza di ogni foro.
- Show Hole Size - mostra la dimensione effettiva di foratura in corrispondenza di ogni foro come valore numerico.
- Show Drill Symbols - per impostazione predefinita, i simboli di foratura non vengono visualizzati sul layer del disegno di foratura. Abilita questa opzione per visualizzare i simboli di foratura.
-
-
– fai clic per aggiornare la tabella ogni volta che vengono apportate modifiche al progetto che influiscono sulla tabella di foratura. Nota che la tabella viene aggiornata automaticamente durante la generazione degli output.
Unità
-
Primary Units – utilizza il menu a discesa per impostare le unità principali su
Metric (mm)oImperial (mil). -
Dual Units – utilizza il menu a discesa per impostare le unità secondarie su
Metric (mm)oImperial (mil). Utilizza
o
per stabilire se queste unità devono essere visualizzate o nascoste (rispettivamente) nell'area di progettazione.
Precisione
- Primary Precision – utilizza il menu a discesa per impostare la precisione richiesta (numero di cifre dopo la virgola decimale).
- Dual Precision – utilizza il menu a discesa per impostare la precisione delle unità secondarie (numero di cifre dopo la virgola decimale).
Colonne
- Grid – visualizza tutte le intestazioni delle colonne (Caption) nella tabella di foratura, l'impostazione Align, che riposiziona i contenuti all'interno della griglia, Width e Order in cui vengono visualizzate le informazioni di ciascuna colonna. Per passare dall'ordine crescente a quello decrescente e viceversa, fai clic nella colonna Order per accedere a un menu a discesa, quindi seleziona l'ordine desiderato: Asc – crescente o Dsc – decrescente.
-
Edit Columns – fai clic per aprire la finestra di dialogo Columns, con cui aggiungere nuove colonne alla tabella di foratura o modificare quelle esistenti.
La finestra di dialogo presenta tutte le colonne esistenti, insieme ai dati associati (di sola lettura). Utilizza i seguenti pulsanti sotto la griglia per selezionare i dati da presentare nella tabella:
- Add Column - consente di aggiungere una nuova colonna alla tabella di foratura. Fai clic per aprire un menu delle colonne disponibili. Le colonne già utilizzate o non disponibili sono disattivate nel menu. Questo comando è disponibile anche nel menu del pulsante destro del mouse.
- Remove Column - fai clic per rimuovere le colonne selezionate. Nota che non viene visualizzata alcuna finestra di conferma: facendo clic sul pulsante, la colonna viene eliminata. Questo comando è disponibile anche nel menu del pulsante destro del mouse.
- Change Header - fai clic per aprire la finestra di dialogo Modifica intestazione colonna, in cui puoi modificare il titolo della colonna selezionata. Questo comando (denominato Change column header) è disponibile anche nel menu del pulsante destro del mouse.
I seguenti comandi aggiuntivi sono disponibili nel menu contestuale del pulsante destro del mouse:
-
Text Alignment - consente di allineare il testo nella colonna selezionata. Le opzioni includono:
Left,CentereRight. -
Set column width - consente di impostare la larghezza della colonna selezionata. Le opzioni includono:
Autosize(predefinita) eManual. Facendo clic suManualsi apre la finestra di dialogo Imposta larghezza colonna, in cui puoi inserire la larghezza desiderata.
Vista del progetto

Posiziona una vista del progetto per mostrare un'area specifica della scheda. Questo esempio è stato ingrandito al 200%.
L'oggetto Vista del progetto PCB è un'istantanea grafica di qualsiasi area rettangolare della scheda corrente o di un'altra scheda. Può essere posizionato ovunque nello spazio di progettazione e ridimensionato a qualsiasi dimensione.
Una vista del progetto può essere posizionata solo nell'editor PCB. Dopo aver avviato il comando di posizionamento della vista del progetto (Place » Design View), una vista del progetto apparirà agganciata al cursore. Posiziona la vista del progetto in un punto adatto, quindi fai clic o premi Enter per posizionarla.
Durante il posizionamento, mentre la vista del progetto è ancora agganciata al cursore e prima che venga ancorata, è possibile eseguire le seguenti azioni aggiuntive:
- Premi il tasto Alt per vincolare la direzione del movimento all'asse orizzontale o verticale, a seconda della direzione iniziale del movimento.
Dopo aver posizionato la vista del progetto, puoi definire la visualizzazione dei layer desiderati eseguendo i seguenti passaggi:
- Con la vista del progetto selezionata nello spazio di progettazione, apri il pannello Proprietà facendo doppio clic oppure facendo clic con il pulsante destro del mouse e scegliendo Properties dal menu contestuale.
- Utilizza il pulsante Define nel pannello Properties per definire in modo interattivo l'area di interesse.
-
Nella sezione Layers del pannello Properties , fai clic sull'icona
per attivare o disattivare la visualizzazione dei layer desiderati. Quando la visualizzazione è abilitata nel pannello Properties , i layer desiderati mostreranno l'icona
.
Le viste del progetto sono incluse nell'output di stampa e PDF. La vista del progetto mantiene le proprie impostazioni di visibilità dei layer nell'output, consentendo di ottenere la presentazione desiderata nella stampa o nel PDF. Nota che le primitive sui layer utilizzati nella vista del progetto continuano a rispettare le impostazioni di visualizzazione definite per quel layer nella finestra di dialogo Stampa. Ad esempio, se il Top Overlay è visualizzato nella vista del progetto ed è configurato per visualizzare le piste in modalità Bozza per quell'output nell'Output Job, anche le piste del Top Overlay nella vista del progetto saranno visualizzate in modalità Bozza.
Una volta posizionata una vista del progetto nello spazio di progettazione, puoi regolarne in modo interattivo la posizione, la scala, le dimensioni e l'area visualizzata.
- Change the position – Click+Drag l'oggetto Vista del progetto in una nuova posizione nello spazio di progettazione PCB.
- Adjusting the Scale – fai clic una volta per selezionare la vista del progetto, quindi Click+Drag su una maniglia d'angolo per ingrandire la vista del progetto (trascinando verso l'esterno) o rimpicciolirla (trascinando verso l'interno).
- Adjusting the View Size – fai clic una volta per selezionare la vista del progetto, quindi Ctrl+Click+Drag su una maniglia d'angolo per ridimensionare la vista del progetto.
- Changing the Focus – Ctrl+Click+Drag in un punto qualsiasi all'interno della vista del progetto per spostare l'area attualmente visualizzata all'interno della finestra della vista del progetto.

Ctrl+Click+Drag per spostare e regolare l'area attualmente visualizzata nella vista del progetto.
Proprietà della vista del progetto

La modalità Design View del pannello Properties.
Posizione
- (X/Y) - le coordinate X e Y correnti del punto di riferimento della vista del progetto.
Proprietà
- This document - seleziona per specificare le proprietà del documento attualmente attivo.
-
Specify document - seleziona per specificare le proprietà di un documento diverso. Quando questa opzione è selezionata, fai clic su
nel campo Document , quindi cerca il documento desiderato.
-
Document - fai clic su
per cercare e selezionare il documento desiderato quando è selezionato Specify document .
- Mirrored - fai clic per abilitare un'immagine ribaltata (speculare) dell'area della scheda nella vista del progetto.
- Scale - fai clic per definire le dimensioni dell'oggetto mediante un fattore moltiplicativo.
- Title - inserisci il titolo della vista del progetto.
- Text Height - inserisci l'altezza del testo del titolo della vista del progetto.
- Font - utilizza il menu a discesa per selezionare il carattere desiderato per il titolo. Utilizza il riquadro del colore per aprire un selettore di colori per il testo del titolo. Nota che, per essere visibile, il colore deve contrastare con il colore di sfondo dello spazio di progettazione.
- Define - fai clic per tornare allo spazio di progettazione con un cursore a croce, quindi fai clic e trascina per definire l'area rettangolare della vista.
Layer
Quest'area fornisce un elenco di tutti i layer della scheda che è possibile configurare per mostrare layer specifici nella vista del progetto.
-
Name - il nome del layer. Utilizza
o
per mostrare o nascondere (rispettivamente) il layer elencato nella vista di progetto.
- Type - il tipo di layer.
Oggetto OLE

Una sequenza di oggetti OLE posizionati: un'immagine, celle di un foglio di calcolo e testo di un documento Word (dall'alto verso il basso)
La tecnologia Object Linking and Embedding (OLE) nell'editor PCB consente di incorporare in un progetto PCB i dati forniti dalle applicazioni OLE di Windows, mantenendo un collegamento attivo con l'applicazione di origine. In molti casi, questo permette di modificare i dati incorporati nel PCB direttamente nell'applicazione che li ha creati.
Tra gli oggetti OLE che si possono tipicamente posizionare in un documento PCB figurano comuni documenti Excel, documenti Word o oggetti grafici provenienti da un'applicazione OLE per immagini appropriata. I tipi di file supportati includono formati universali come fogli di calcolo CSV e XLS, documenti di testo DOC e RTF e file di immagine BMP.
Gli oggetti OLE possono essere posizionati e incorporati nell'editor PCB. Dopo aver avviato il comando Place » Object From File, scegliere il file desiderato nella finestra di dialogo Choose File, quindi fare clic per posizionare l'oggetto nello spazio di progettazione.
La funzionalità Incolla speciale di Altium consente inoltre di copiare una selezione da un'applicazione OLE e incollarla (Edit » Paste) nel documento PCB come oggetto OLE. Se necessario, è possibile utilizzare l'opzione per incollare il testo (Edit » Paste Text) per estrarre gli elementi di testo da un oggetto OLE. Questi verranno posizionati come oggetti di testo PCB.
Una volta posizionati, gli oggetti incorporati possono essere ridimensionati proporzionalmente facendo clic sulle relative maniglie di selezione e trascinandole tenendo premuto il pulsante del mouse. Per gli oggetti basati su testo, come i documenti Word ed Excel, le dimensioni e lo spessore del testo incorporato vengono adattati automaticamente alle nuove dimensioni.
- Un oggetto OLE può anche essere convertito in un insieme di primitive libere utilizzando il comando Tools » Convert » Explode OLE Object to Free Primitives. L'oggetto verrà scomposto negli oggetti Regione e/o Testo appropriati.
- L'opzione di conversione in primitive libere viene proposta anche se, quando si tenta di modificare un oggetto OLE, non è possibile trovare l'applicazione OLE corrispondente.
Proprietà dell'oggetto OLE

La modalità OLE Object del pannello Properties.
Posizione
- (X/Y) - le coordinate correnti X (orizzontale) e Y (verticale) del punto di riferimento dell'oggetto rispetto all'origine corrente dello spazio di progettazione. Modificarle per cambiare la posizione dell'oggetto.
- Rotation - l'angolo di rotazione dell'oggetto (in gradi), misurato in senso antiorario a partire da zero (l'orizzontale 3 o'clock). Modificarlo per cambiare la rotazione dell'oggetto. La risoluzione angolare minima è di 0,001°.
Proprietà
- Layer - il layer a cui è attualmente assegnato l'oggetto. Utilizzare il menu a discesa per selezionare un layer diverso.
- Edit Data - fare clic per aprire l'oggetto nell'applicazione associata e apportare le modifiche necessarie. Dopo aver apportato le modifiche e chiuso l'applicazione associata, nel pannello Proprietà fare clic su Save per salvare le modifiche oppure su Cancel.
Quote
Gli editor PCB e Libreria PCB includono una serie di strumenti di quotatura per soddisfare diverse esigenze di progettazione.
| Oggetto quota | Descrizione |
|---|---|
| Angular Dimension | Consente di quotare distanze angolari. |
| Baseline Dimension | Consente di quotare la distanza lineare di un insieme di riferimenti rispetto a un unico riferimento di base. Il primo punto scelto è la «base». Tutti i punti successivi sono relativi a questo primo punto. Il valore della quota è quindi, in ciascun caso, la distanza tra ogni punto di riferimento e la «base», misurata nelle unità predefinite. I riferimenti possono essere piste, archi, pad, via, testi, riempimenti, poligoni o componenti. |
| Center Dimension | Consente di contrassegnare il centro di un arco o di un cerchio. |
| Leader Dimension | Consente di etichettare un oggetto, un punto o un'area. Sono disponibili tre tipi di richiamo: Automatico, Rotondo e Quadrato, che determinano se il testo dell'etichetta viene racchiuso in un cerchio, in un quadrato o non viene racchiuso affatto. Il puntatore può essere una freccia o un punto. |
| Linear Dimension | Consente di quotare una distanza lineare. Il valore della quota è la distanza tra i marcatori iniziale e finale (punti di riferimento selezionati dall'utente), misurata nelle unità predefinite. I riferimenti possono essere oggetti (piste, archi, pad, via, testi, riempimenti, poligoni o componenti) oppure punti nello spazio libero. |
| Linear Diameter Dimension | Consente di quotare un arco o un cerchio in relazione al diametro anziché al raggio. La quota può essere posizionata all'interno o all'esterno. |
| Ordinate Dimension | Consente di quotare la distanza lineare di un insieme di oggetti rispetto a un unico oggetto di riferimento. Il primo oggetto scelto è la «base». Tutti gli oggetti successivi sono relativi a questo primo oggetto. Il valore della quota è quindi, in ciascun caso, la distanza tra ogni oggetto di riferimento e la «base», misurata nelle unità predefinite. I riferimenti possono essere piste, archi, pad, via, testi, riempimenti, poligoni o componenti. |
| Radial Dimension | Consente di quotare il raggio di un arco o di un cerchio. La quota può essere posizionata all'interno o all'esterno. |
| Radial Diameter Dimension | Consente di quotare un arco o un cerchio in relazione al diametro anziché al raggio. La quota può essere posizionata all'interno o all'esterno rispetto alla circonferenza dell'arco o del cerchio. |
| Standard Dimension | Inserisce le informazioni di quotatura sul layer PCB corrente. Il valore della quota è la distanza tra i marcatori iniziale e finale, misurata nelle unità predefinite. |
Gli oggetti quota sono disponibili nel sottomenu Place » Dimension dei menu principali. Quando si quota un oggetto, diventano disponibili punti di ancoraggio che evidenziano dove è possibile agganciare la quota. La barra di stato mostra informazioni sulle azioni necessarie in ogni fase del processo. Verrà utilizzato il punto più vicino al cursore, al quale verrà agganciata la quota facendo clic o premendo Enter.
Il video seguente mostra alcuni esempi di posizionamento delle quote.
Durante il posizionamento è inoltre possibile eseguire le seguenti azioni:
- Premere i tasti + e - (sul tastierino numerico) per scorrere rispettivamente in avanti e indietro tutti i layer visibili nel progetto e cambiare rapidamente il layer di posizionamento.
- Durante il posizionamento di una quota da linea di base, al centro, di diametro lineare, lineare o a coordinate, premi Spacebar per ruotare la quota in senso antiorario oppure Shift+Spacebar per ruotarla in senso orario. La rotazione avviene in base al valore di Rotation Step definito nella pagina PCB Editor – General della finestra di dialogo Preferences.
- Durante il posizionamento di una quota standard, premi il tasto L per ribaltare la quota sull'altro lato della scheda. Nota che questa operazione è possibile solo prima di ancorare il punto iniziale della quota.
Il valore di una quota, ove applicabile, si aggiorna automaticamente quando vengono spostati i suoi punti iniziale o finale. Analogamente, se cambia la posizione di un oggetto a cui è ancorato un punto di riferimento della quota, questa si aggiorna e si estende o si contrae di conseguenza. Per una quota basata sul raggio o sul diametro, il valore si aggiorna automaticamente al variare del diametro dell'arco o del cerchio di riferimento.
Quando vengono eliminati uno o più riferimenti a cui è associato un oggetto quota, si apre una finestra di dialogo che chiede se eliminare anche la quota. Se non viene eliminata, la quota rimane nello spazio di progettazione, ma senza riferimenti.
Un oggetto quota può essere spostato nei seguenti modi:
- Selecting both the dimension object and the dimensioned object(s). L'intero oggetto può essere trascinato in una nuova posizione secondo necessità.
- Selecting a dimensioned object only. Il testo della quota segue l'oggetto solo nel proprio piano di allineamento. Le linee di estensione della quota (oppure, per una quota di diametro radiale o radiale, il puntatore e la coda) si estendono o si contraggono per mantenere la relazione tra la quota e l'oggetto quotato. Nel caso di una quota al centro o con linea di richiamo, questa si sposta insieme all'oggetto. Il segmento della quota con linea di richiamo compreso tra la freccia/il punto e il primo gomito definito si estende o si contrae per mantenere la relazione tra la quota e l'oggetto quotato.
- Selecting the dimension object only. È importante notare che la quota non può essere spostata da sola se è associata a un oggetto di progettazione. Per spostare solo la quota, occorre prima scollegarla dagli oggetti che sta quotando.
Quando si seleziona un oggetto quota, diventano disponibili delle maniglie di modifica che consentono di modificarlo direttamente nello spazio di progettazione, intervenendo graficamente su proprietà quali la posizione del testo e dei punti di riferimento. Di seguito sono mostrati alcuni esempi di maniglie di modifica per diversi tipi di quota.
|
Quando si seleziona un oggetto quota lineare, sono disponibili le seguenti maniglie di modifica:
Quando si seleziona un oggetto quota angolare, sono disponibili le seguenti maniglie di modifica:
Quando si seleziona un oggetto quota radiale, sono disponibili le seguenti maniglie di modifica:
Quando si seleziona un oggetto quota a coordinate, sono disponibili le seguenti maniglie di modifica.
|
Le maniglie sugli oggetti quotati, o più vicine a essi (ad esempio, C e D per una quota lineare oppure C e E e D e F per una quota angolare, come mostrato sopra), consentono di ridefinire i riferimenti – una volta scollegata da un oggetto di riferimento, la quota rimane senza riferimenti e può essere spostata per associarla a un punto o a un oggetto di riferimento diverso. Durante il trascinamento di una qualsiasi delle maniglie di modifica di una quota lineare, a coordinate o da linea di base priva di riferimenti, è possibile ruotarla.
Proprietà degli oggetti quota
Le quote dispongono di numerose opzioni di configurazione, che offrono un elevato livello di personalizzazione delle frecce e del testo. Apri il pannello Properties per uno o più oggetti quota selezionati per modificarne le proprietà.
| Proprietà | Oggetti a cui si applica | Descrizione |
|---|---|---|
Stile |
||
| Width | Tutte le quote, tranne quelle al centro e a coordinate | Lo spessore attuale della linea di quota. |
| Width (nella sezione Extension Line) | Quota angolare Quota da linea di base Quota lineare Quota di diametro lineare Quota a coordinate |
Lo spessore attuale delle linee di estensione della quota. |
| Gap | Quota angolare Quota da linea di base Quota con linea di richiamo Quota lineare Quota di diametro lineare Quota a coordinate |
|
| Offset | Quota angolare Quota da linea di base Quota lineare Quota di diametro lineare |
Lo scostamento attuale della linea della freccia rispetto alla linea di estensione della quota. |
| Text Gap | Tutte le quote, tranne quelle al centro e standard |
|
| Leader Shape | Quota con richiamo | Utilizzare il menu a discesa per determinare la forma da usare per racchiudere il testo della quota. Le opzioni disponibili sono Automatic, Round e Square. Se si seleziona Round o Square, immettere il valore desiderato per Size. |
| Arrow Style | Quota con richiamo | Utilizzare il menu a discesa per selezionare lo stile di richiamo desiderato. Le opzioni disponibili sono Arrow o Dot. Immettere il valore desiderato per Size. |
| Height | Quota standard | L'altezza attuale della linea di estensione. |
| Arrow Size | Quota angolare Quota da linea di base Quota lineare Quota diametrale lineare Quota radiale Quota diametrale radiale |
La dimensione attuale della punta della freccia. La dimensione viene misurata come distanza tra la punta della freccia e l'estremità dei suoi due tratti laterali. |
| Arrow Length | Quota angolare Quota da linea di base Quota lineare Quota diametrale lineare Quota radiale Quota diametrale radiale |
La lunghezza attuale della freccia. Si noti che il valore immesso in questo campo viene applicato solo quando Arrow Position (nell'area Properties ) è impostato su Outside. |
Proprietà |
||
| Text | Quota con richiamo | Immettere il testo desiderato. |
| Layer | Tutte | Il layer a cui è attualmente assegnata la quota. Utilizzare il menu a discesa per selezionare il layer desiderato. Le quote possono essere assegnate a qualsiasi layer disponibile. |
| Text Position | Tutte, tranne le quote di centro e standard | La posizione attuale del testo della quota. Utilizzare il relativo elenco a discesa per scegliere una delle seguenti opzioni (le opzioni disponibili dipendono dal tipo di oggetto quota):
|
| Arrow Position | Quota angolare Quota da linea di base Quota lineare Quota diametrale lineare Quota radiale Quota diametrale radiale |
La posizione attuale delle frecce della quota. Le opzioni disponibili sono:
|
| Angular Step | Quota diametrale radiale | L'impostazione attuale del passo angolare della quota. Si tratta dell'incremento di rotazione utilizzato quando si posiziona la parte della quota contenente la freccia. Quando si sposta la freccia lungo il cerchio o l'arco durante il posizionamento della quota, il numero e la posizione dei possibili punti di ancoraggio della quota sono determinati da questo valore del passo angolare. |
| Text Height | Tutte, tranne la quota di centro | L'altezza attuale dei caratteri del testo della quota. La larghezza dei caratteri utilizzata per visualizzare o stampare il testo viene proporzionata automaticamente a questa altezza. Un'altezza minima di 36mil (0.9mm) consentirà di riprodurre il testo in modo leggibile mediante fotoplotter. |
| Rotation | Quota di centro Quota lineare Quota diametrale lineare Quota a coordinate |
L'angolo di allineamento della quota, misurato in gradi in senso antiorario rispetto all'orizzontale. |
| Size | Quota di centro | La lunghezza attuale delle linee del crocino della quota (o il diametro del cerchio che lo racchiude). |
| Font Type | Tutte, tranne la quota di centro |
|
Unità |
||
| Primary Units | Quota angolare Quota con linea di base Quota lineare Quota diametrale lineare Quota per coordinate Quota radiale Quota diametrale radiale |
L'unità attualmente selezionata per il calcolo e la visualizzazione del valore della quota.
|
| Value Precision | Quota angolare Quota con linea di base Quota lineare Quota diametrale lineare Quota per coordinate Quota radiale Quota diametrale radiale |
L'impostazione attuale del numero di cifre decimali da visualizzare dopo il separatore decimale nel valore della quota. |
Valore |
||
| Format | Tutte, tranne le quote di centro e con linea di richiamo |
L'impostazione attuale del formato del testo della quota. Utilizzare il menu a discesa associato per modificare il formato secondo necessità. Le opzioni elencate dipendono da Unit e vengono presentate in base al valore effettivo della quota corrente. In termini generali, le opzioni disponibili sono le seguenti (l'insieme delle opzioni disponibili dipende dal tipo di oggetto quota):
|
| Prefix | Quota angolare Quota con linea di base Quota lineare Quota diametrale lineare Quota per coordinate Quota radiale Quota diametrale radiale |
Il prefisso del valore della quota. Per una quota diametrale lineare o diametrale radiale, questo campo è fisso e contiene il carattere ø. |
| Suffix | Quota angolare Quota con linea di base Quota lineare Quota diametrale lineare Quota per coordinate Quota radiale Quota diametrale radiale |
Il suffisso del valore della quota. |
| Sample | Tutte, tranne le quote di centro e con linea di richiamo |
Questo campo mostra un esempio di come apparirà il testo della quota in base a Format e agli eventuali Prefix e/o Suffix definiti. |
| Start point (X/Y) | Quota standard | Il punto iniziale della quota per X (primo valore) e Y (secondo valore). |
| End point (X/Y) | Quota standard | Il punto finale della quota per X (primo valore) e Y (secondo valore). |
Conversione delle quote in primitive
Le quote sono oggetti di progettazione raggruppati, ovvero sono costituite da uno o più segmenti di testo e di traccia. Una quota può essere convertita negli oggetti primitivi che la costituiscono utilizzando il comando Tools » Convert » Explode Dimension to Free Primitives.


