Definiowanie kształtu płyty

Altium Training

Altium Essentials: PCB Configuration

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

W skrócie

W tym artykule wyjaśniono, jak działa kształt płytki w Altium Designer, co określa w projekcie PCB lub sztywno-elastycznym oraz jak można go definiować, tworzyć i edytować w standardowym i zaawansowanym trybie projektowania płytek sztywno-elastycznych. Opisano, jak kształt płytki jest tworzony z jednego lub większej liczby obszarów płytki, gdzie jest dostępny, jaki jest domyślny kształt w nowym dokumencie PCB oraz których poleceń używać w trybie planowania płytki, 2D i 3D, aby dostosować ostateczny obrys płytki. Jeśli chcesz lepiej zrozumieć, jak określać i dopracowywać fizyczne granice płytki w edytorze PCB, warto zapoznać się z tym przewodnikiem.

- Dowiedz się, co określa kształt płytki, jak jest wykorzystywany przez oprogramowanie i czym różni się w projektach z jednym obszarem płytki oraz w projektach sztywno-elastycznych.
- Poznaj dostępne metody tworzenia i edytowania obrysu płytki, w tym narzędzia interaktywne, metody oparte na zaznaczonych obiektach oraz definiowanie na podstawie bryły 3D.
- Sprawdź, które polecenia są dostępne w standardowym, a które w zaawansowanym trybie projektowania płytek sztywno-elastycznych, oraz jak tryby widoku wpływają na przebieg edycji.
Zagłęb się w temat dzięki AI:

W oprogramowaniu Altium do projektowania PCB dostępne są dwa tryby projektowania płytek sztywno-giętkich. Pierwotny, standardowy tryb, określany jako Rigid-Flex, obsługuje proste projekty płytek sztywno-giętkich. Jeśli projekt ma bardziej złożone wymagania, takie jak nakładające się obszary giętkie, należy użyć trybu Advanced Rigid-Flex (znanego również jako rigid-flex 2.0). Tryb wybiera się w menu Tools w menedżerze stosu warstw.

► Dowiedz się więcej o projektowaniu płytek sztywno-giętkich

Kształt płytki określa ogólny kształt gotowej płytki. Przeglądaj slajdy, aby zobaczyć trzy obszary płytki tworzące kształt płytki sztywno-giętkiej oraz gotową płytkę w 3D.

Kształt płytki określa ogólny kształt gotowej płytki. Przeglądaj slajdy, aby zobaczyć trzy obszary płytki tworzące kształt płytki sztywno-giętkiej oraz gotową płytkę w 3D.

Kształt płytki określa ogólny kształt gotowej płytki. Przeglądaj slajdy, aby zobaczyć trzy obszary płytki tworzące kształt płytki sztywno-giętkiej oraz gotową płytkę w 3D.

Kształt płytki określa ogólny kształt gotowej płytki. Przeglądaj slajdy, aby zobaczyć trzy obszary płytki tworzące kształt płytki sztywno-giętkiej oraz gotową płytkę w 3D.

Kształt płytki określa ogólny kształt gotowej płytki. Przeglądaj slajdy, aby zobaczyć trzy obszary płytki tworzące kształt płytki sztywno-giętkiej oraz gotową płytkę w 3D.

Kształt płytki określa ogólny kształt gotowej płytki. Przeglądaj slajdy, aby zobaczyć trzy obszary płytki tworzące kształt płytki sztywno-giętkiej oraz gotową płytkę w 3D.

 

Podsumowanie

Kształt płytki, nazywany również obrysem płytki, jest zamkniętym wielokątem określającym zewnętrzne granice płytki. Kształt płytki może składać się z jednego obszaru płytki (w przypadku tradycyjnej sztywnej płytki PCB) lub z wielu obszarów (w przypadku płytki sztywno-giętkiej). Oprogramowanie wykorzystuje kształt płytki do:

  • Wizualnego wskazywania granic przestrzeni dostępnej do rozmieszczania elementów i prowadzenia ścieżek w projekcie.
  • Określania odsunięcia krawędzi płaszczyzny zasilania oraz krawędzi odniesienia przy dzieleniu płaszczyzny zasilania na oddzielne strefy napięciowe. Dowiedz się więcej o definiowaniu obszarów miedzi i zarządzaniu nimi.
  • Wyznaczania krawędzi płytki podczas eksportowania danych projektu do innych narzędzi.
W przypadku pustego projektu PCB lub dodatkowych dokumentów PCB dodanych do istniejącego projektu domyślny kształt płytki jest prostokątem (6 cali × 4 cale, czyli 6000 mil × 4000 mil lub 152,4 mm × 101,6 mm). W przypadku konkretnych szablonów projektów, których można użyć podczas tworzenia nowego projektu PCB, powiązany dokument PCB ma określony kształt płytki, zgodny z jej formatem.

Dostępność

Kształt płytki jest dostępny tylko w edytorze PCB. Nowo utworzony plik PCB otwiera się z prostokątnym kształtem płytki utworzonym z jednego obszaru płytki.

Całościowy kształt płytki można utworzyć przez:

  • Interaktywne definiowanie kształtu płytki w trybie planowania płytki.
  • Tworzenie kształtu płytki z wybranych obiektów ścieżek i łuków, które tworzą zamknięty obrys. W trybie Advanced Rigid-Flex można utworzyć wiele obszarów płytki z obiektów zaznaczonych w przestrzeni projektowej.
  • W przypadku projektu płytki sztywno-giętkiej (w trybie standardowym lub zaawansowanym) kształt płytki można podzielić na poszczególne obszary wymagane w projekcie.
  • Umieszczanie jednego lub większej liczby obszarów płytki w celu zbudowania całościowego kształtu płytki (tryb Advanced Rigid-Flex).
Domyślny kształt płytki w nowym dokumencie PCB jest prostokątem (6 cali × 4 cale, czyli 6000 mil × 4000 mil lub 152,4 mm × 101,6 mm). W przypadku konkretnych szablonów projektów, których można użyć podczas tworzenia nowego projektu PCB, powiązany dokument PCB ma określony kształt płytki zgodny z jej formatem.
Bieżący tryb wyświetlania dokumentu PCB można zmienić za pomocą odpowiednich poleceń z menu głównego View . Można też szybko przełączać widoki za pomocą skrótów klawiaturowych 1 (tryb planowania płytki), 2 (2D) i 3 (3D).

Interaktywne definiowanie i edytowanie kształtu płytki

Kształt płytki jest tworzony z jednego lub większej liczby obszarów płytki. Projektanci pracujący nad płytką z jednym obszarem mogą użyć następujących poleceń do zdefiniowania jej kształtu:

  • Board Planning Mode (standard Rigid-Flex mode - the Active Bar at the top of the graphical editing space has two buttons):
    • Design » Redefine Board Shape - użyj tego polecenia, aby interaktywnie przerysować bieżący kształt płytki. Pamiętaj, że to polecenie nie jest dostępne, jeśli w Layer Stack Manager włączono zaawansowany tryb Rigid-Flex. Jeśli płytka jest w zaawansowanym trybie Rigid-Flex, kliknij kształt, aby go zaznaczyć, i zmodyfikuj go za pomocą standardowych technik edycji obiektów wielokątnych.

    • Design » Edit Board Shape - użyj tego polecenia, aby przesuwać i zmieniać kształt krawędzi płytki za pomocą standardowych technik edycji obiektów wielokątnych.

      • Pamiętaj, że to polecenie nie jest dostępne, jeśli w Layer Stack Manager włączono zaawansowany tryb Rigid-Flex. Jeśli płytka jest w zaawansowanym trybie Rigid-Flex, kliknij kształt, aby go zaznaczyć, i zmodyfikuj go za pomocą standardowych technik edycji obiektów wielokątnych.

      • Przed wybraniem polecenia upewnij się, że opcja Other jest włączona w filtrze zaznaczania, aby można było użyć tego polecenia ().

  • Board Planning Mode (Advanced Rigid-Flex mode - the Active Bar at the top of the graphical editing space has six buttons):
    • Place » Board Region - użyj tego polecenia, aby interaktywnie zdefiniować region płytki (w przypadku płytki z jednym regionem region ten definiuje kształt płytki). Dowiedz się więcej o umieszczaniu regionu płytki.
  • 2D Layout Mode:
    • Design » Board Shape » Define Board Shape from Selected Objects - zaznacz zestaw obiektów podstawowych typu linia i/lub łuk, które definiują zamknięty kształt, a następnie użyj tego polecenia, aby przedefiniować kształt płytki zgodnie z tym kształtem.

    • Design » Board Shape » Create Primitives from Board Shape - utwórz zestaw obiektów podstawowych wzdłuż granicy kształtu płytki, zgodnie z ustawieniami skonfigurowanymi w oknie dialogowym Line/Arc Primitives from Board Shape.

  • 3D Layout Mode:
    • Design » Board Shape » Define Board Shape from 3D body - użyj tego polecenia, aby zdefiniować kształt płytki przez wybranie żądanej powierzchni modelu 3D.

Ponadto w trybie planowania płytki możesz korzystać z następujących poleceń:

  • Design » Modify Board Shape - użyj tego polecenia, aby zmodyfikować istniejący kształt płytki przez umieszczenie dodatkowych wierzchołków, a tym samym nadać jej obrysowi nowy kształt.

  • Design » Move Board Shape - użyj tego polecenia, aby przenieść kształt płytki w inne miejsce w bieżącym dokumencie. Polecenie to przenosi wyłącznie kształt płytki. Sam projekt i tworzące go obiekty pozostają na swoich miejscach.

    Po uruchomieniu polecenia kopia obrysu kształtu zostanie dołączona do kursora za lewy dolny narożnik. Przesuń kształt w wybrane miejsce w obszarze roboczym, a następnie kliknij lub naciśnij Enter, aby go umieścić. Podczas przesuwania naciśnij Spacebar, aby obrócić kształt płytki przeciwnie do ruchu wskazówek zegara, lub Shift+Spacebar, aby obrócić go zgodnie z ruchem wskazówek zegara (wielkość Rotation Step jest zdefiniowana na stronie PCB Editor – General w oknie dialogowym Preferences), albo naciśnij klawisz X lub Y, aby odbić kształt płytki względem osi, odpowiednio, X lub Y. Aby anulować bez przesuwania, kliknij prawym przyciskiem myszy lub naciśnij Esc.

  • Design » Move Board - użyj tego polecenia, aby przenieść całą płytkę — jej kształt oraz wszystkie obiekty projektu znajdujące się w jego obrębie — w inne miejsce w bieżącym dokumencie.

    Po uruchomieniu polecenia kopia obrysu kształtu płytki zostanie dołączona do kursora za lewy dolny narożnik. Przesuń kształt w wybrane miejsce w przestrzeni projektowej, a następnie kliknij lub naciśnij Enter, aby go umieścić. Wszystkie obiekty projektu również zostaną przesunięte, aby zachować swoje położenie względem kształtu płytki. Aby anulować bez przesuwania, kliknij prawym przyciskiem myszy lub naciśnij Esc.

Różnica między poleceniem Define Board Shape from Selected Objects a poleceniem Create Board Region from Selected Objects polega na tym, że pierwsze zastępuje wszystkie istniejące regiony płytki nowym regionem utworzonym po uruchomieniu polecenia, natomiast drugie tworzy dodatkowy region płytki bez usuwania istniejących regionów.

Definiowanie kształtu płytki na podstawie zaznaczonych obiektów

Kształt płytki można również zdefiniować na podstawie zaznaczonych obiektów (w trybie układu 2D). Zazwyczaj jest to zestaw linii lub łuków umieszczonych na warstwie Keepout lub na warstwie mechanicznej.

Wykonaj następujące kroki:

  1. Ustaw tryb widoku na 2D Layout Mode (menu View).
  2. Otwórz panel View Configuration i kliknij dwukrotnie, aby edytować warstwę mechaniczną zawierającą kształt płytki. Otworzy się okno dialogowe Edit Layer, w którym możesz ustawić Layer Type na Board Shape, jak pokazano na poniższym filmie.
  3. Ustaw warstwę mechaniczną zawierającą kształt jako aktywną i zaznacz obiekty. Idealnie nadaje się do tego polecenie Edit » Select » All on Layer; zaznaczenie musi obejmować wyłącznie ścieżki i łuki tworzące obrys płytki.
  4. Po zaznaczeniu wszystkich obiektów uruchom polecenie Design » Board Shape » Define Board Shape from Selected Objects. Kształt płytki zostanie zaktualizowany tak, aby odpowiadał przebiegowi zaznaczonych linii. Jeśli oprogramowanie nie będzie w stanie odwzorować linii środkowej zaznaczonych obiektów, pojawi się okno dialogowe z ostrzeżeniem. Tryb widoku zmieni się na Board Planning Mode.

Demonstracja kształtu płytki w standardowym trybie Rigid-Flex

Film przedstawia tworzenie kształtu płytki na podstawie zaznaczonych obiektów, a następnie umieszczanie linii podziału w celu utworzenia trzech wymaganych regionów.

Demonstracja kształtu płytki w zaawansowanym trybie Rigid-Flex

Film najpierw przedstawia tworzenie kształtu płytki na podstawie zaznaczonych obiektów, a następnie dzielenie tego kształtu w celu utworzenia trzech wymaganych regionów. Następnie pokazuje alternatywne podejście, w którym
trzy regiony płytki są definiowane na podstawie zaznaczonych obiektów. Pamiętaj, że te demonstracje wykorzystują funkcje Rigid-Flex 2.0, opisane na początku tej strony.

Oprogramowanie spróbuje wyznaczyć kształt na podstawie linii środkowej zaznaczonych obiektów. Jeśli współrzędne końca jednego segmentu ścieżki lub łuku nie odpowiadają dokładnie współrzędnym kolejnego segmentu, algorytm rozpoznawania granicy nie zadziała i wyświetli się komunikat wskazujący miejsce błędu. Oprogramowanie zaproponuje użycie algorytmu śledzenia obrysu. Pamiętaj, że algorytm ten podąża za zewnętrzną krawędzią ścieżek i łuków, więc kształt płytki będzie nieco inny niż ten utworzony na podstawie linii środkowych. Wybierz tę opcję tylko wtedy, gdy Twój projekt dopuszcza skutki tej różnicy.

Importowanie obrysu do wykorzystania jako kształt płytki

Kształt płytki można zdefiniować na podstawie zamkniętego obrysu zaimportowanego jako dane DXF/DWG.

Połączenie możliwości importowania danych DXF/DWG na warstwę mechaniczną z definiowaniem kształtu płytki na podstawie zaznaczonych obiektów pozwala przenieść kształt zdefiniowany w programie CAD do projektowania mechanicznego do edytora PCB.

Aby przygotować nową płytkę do importu:

  1. Wybierz File » New » PCB. Otworzy się nowa, pusta płytka PCB; czarny obszar przedstawia bieżący kształt płytki.
  2. Przed zaimportowaniem nowego kształtu skonfiguruj poniższe ustawienia odpowiednio do wymagań projektu i importowanego kształtu:
  • Jednostki — ustaw wymagane jednostki w Other sekcji Properties panelu w trybie Board (pokaż obraz).
  • Siatka — kliknij dwukrotnie globalną siatkę przyciągania płytki i skonfiguruj ją zgodnie z potrzebami w Grid Manager sekcji Properties panelu w trybie Board (pokaż obraz).
  • Początek układu współrzędnych — w przypadku nowej płytki PCB domyślne położenie początku układu współrzędnych definiowanego przez użytkownika pokrywa się z absolutnym początkiem układu współrzędnych, w lewym dolnym rogu przestrzeni projektowej. Wybierz Edit » Origin » Set z menu głównego, a następnie kliknij, aby określić położenie początku układu współrzędnych definiowanego przez użytkownika, na przykład w lewym dolnym narożniku bieżącego kształtu płytki. Warto dopasować to ustawienie do położenia początku układu współrzędnych importowanego obrysu.

Następnym krokiem jest zaimportowanie kształtu płytki z pliku .DXF lub .DWG. Pamiętaj, że importowany kształt musi być zamknięty – wewnętrzne wycięcia nie są tworzone automatycznie (można je jednak zdefiniować później na podstawie zaimportowanych obiektów).

  1. Wybierz File » Import » DXF/DWG, aby otworzyć okno dialogowe Import File, a następnie upewnij się, że opcja File Type w jego prawym dolnym rogu jest ustawiona na AutoCAD Files (*.DXF, *.DWG), i wyszukaj wymagany plik. 
  2. Po kliknięciu przycisku Open otworzy się okno dialogowe Import from AutoCAD (pokaż obraz).
  3. Ustaw Scale, Default Line Width i Layer Mappings zgodnie z potrzebami, a następnie kliknij OK.
  4. Każdy obiekt DXF/DWG zostanie przekształcony w obiekt edytora i wyświetlony w obszarze projektowania. 
  5. Ustaw warstwę mechaniczną zawierającą obiekty kształtu płytki jako warstwę aktywną, a następnie zaznacz wszystkie obiekty na tej warstwie (Edit » Select » All on Layer).
  6. Aby dopasować kształt płytki do zaznaczonego obrysu, uruchom polecenie Design » Board Shape » Define from Selected Objects.
  7. Jeśli płytka zawiera wycięcia, można je utworzyć, zaznaczając obrys wycięcia i uruchamiając polecenie Tools » Convert » Create Board Cutout from Selected Primitives.

Oprogramowanie spróbuje wyznaczyć kształt na podstawie osi zaznaczonych obiektów. Jeśli współrzędne końca jednego segmentu ścieżki lub łuku nie pokrywają się dokładnie ze współrzędnymi kolejnego segmentu, algorytm rozpoznawania granicy zakończy się niepowodzeniem i zostanie wyświetlony komunikat wskazujący miejsce problemu. Program zaproponuje wówczas użycie algorytmu śledzenia obrysu. Pamiętaj, że algorytm ten podąża za zewnętrzną krawędzią obiektów ścieżek i łuków, dlatego kształt płytki będzie nieco inny niż kształt utworzony na podstawie ich osi. Wybierz tę opcję tylko wtedy, gdy taka różnica jest dopuszczalna w Twoim projekcie.

Definiowanie kształtu płytki na podstawie bryły 3D

Ta funkcja pozwala ponownie zdefiniować kształt płytki na podstawie powierzchni (ściany) zaimportowanego modelu 3D. Obsługiwane formaty modeli to: STEP (*.Stp lub *.STEP), Parasolid (*.x_t lub *x_b) oraz plik części SOLIDWORKS (*.SldPrt). Funkcja umożliwia szybkie utworzenie złożonego kształtu płytki i ułatwia integrację projektowania elektronicznego z mechanicznym. Proces składa się z dwóch etapów: najpierw importowany jest model STEP, a następnie wybierany jest z niego wymagany kształt. 

Do zdefiniowania kształtu płytki można użyć wyłącznie płaskiej powierzchni.

W tym celu:

  1. Przełącz się na View » 3D Layout Mode (skrót: 3).
  2. Aby zaimportować model 3D, umieść bryłę 3D (Place » 3D Body).
  3. W oknie dialogowym Choose Model znajdź i wybierz plik modelu. Model 3D zostanie zaimportowany do edytora PCB i zapisany w obiekcie bryły 3D. W razie potrzeby można usunąć ten model z PCB po ponownym zdefiniowaniu kształtu płytki.
  4. Wybierz Design » Board Shape » Define Board Shape from 3D body.
  5. Na pasku stanu pojawi się monit Pick a 3D body. Kliknij zaimportowaną bryłę 3D, aby ją zaznaczyć. Model stanie się przezroczysty.
  6. Kursor zmieni się w krzyżyk, a na pasku stanu pojawi się monit Choose Face. Po najechaniu kursorem na dowolną ścianę zostanie ona obrysowana. Jeśli pod kursorem znajduje się płaska powierzchnia, stanie się ona nieprzezroczysta i zostanie otoczona cienką niebieską ramką. Kliknij, aby wybrać właściwą ścianę.
  7. Pojawi się okno dialogowe Board Outline Creation Successful z opcjami pozwalającymi określić, która powierzchnia PCB ma zostać wyrównana do wybranej powierzchni (zwykle jest to warstwa górna) oraz czy model 3D ma zostać ukryty i wyłączony ze sprawdzania reguł projektowych. W razie potrzeby ustawienia ukrywania i wyłączania można później zmienić w trybie 3D Models panelu PCB.

Pamiętaj, że jeśli model STEP pozostanie osadzony w pliku PCB lub z nim połączony, otrzymasz powiadomienie przy każdej zmianie pliku STEP. Pojawi się również monit o aktualizację kształtu, co jest przydatne, gdy kształt jest nadal opracowywany i przewidywane są kolejne zmiany.

Do utworzenia kształtu płytki można użyć wyłącznie powierzchni wyrównanych do płaszczyzny X-Y. Jeśli wybierzesz powierzchnię modelu wymagającą takiego wyrównania, w oknie dialogowym Confirm pojawi się prośba o wyrównanie powierzchni przed kontynuowaniem. Okno to pozwala również ustawić położenie modelu przy użyciu wybranej ściany względem górnej lub dolnej powierzchni płytki. Oznacza to, że jednocześnie można ustawić pionowe położenie modelu. Po wyrównaniu należy ponownie wybrać Design » Board Shape » Define from 3D Body. Po ponownym zdefiniowaniu kształtu płytki będzie można ukryć bryłę 3D.

Tworzenie obiektów podstawowych na podstawie kształtu płytki

Oprócz definiowania kształtu płytki na podstawie zaznaczonych obiektów podstawowych można również tworzyć takie obiekty na podstawie kształtu płytki za pomocą polecenia Design » Board Shape » Create Primitives from Board Shape. Polecenie to otwiera okno dialogowe Line/Arc Primitives from Board.

Okno dialogowe Line/Arc Primitives From Board Shape
Okno dialogowe Line/Arc Primitives From Board Shape

Użyj tego polecenia, gdy kształt płytki jest już zdefiniowany, ale wzdłuż jego granicy nie ma żadnych obiektów. Polecenie to może być przydatne w następujących sytuacjach:

  • Gdy chcesz zmodyfikować kształt płytki (lub jej wycięcia), najpierw modyfikując obiekty ścieżek i łuków.
  • Gdy potrzebujesz granicy obszaru zabronionego dla płytki lub granic obszarów zabronionych dla wycięć na warstwie Keep-Out. Zagadnienie to omówiono bardziej szczegółowo poniżej, w sekcji Ważne kwestie projektowe dotyczące stosowania wycięć w płytce.

    Jeśli jako warstwę docelową wybierzesz Keep-Out, obiekty obszaru zabronionego określające ograniczenia dla poszczególnych typów obiektów zostaną umieszczone bezpośrednio na tej warstwie (ścieżki i łuki obszaru zabronionego).

Wycinanie otworu w kształcie płytki

Wycięcie można umieścić w dowolnym miejscu wewnątrz obrysu płytki. Aby je umieścić, przełącz widok płytki na tryb układu 2D i użyj polecenia Design » Board Shape » Define Board Cutout z menu głównego (alternatywnie możesz użyć polecenia Place » Define Board Cutout w trybie planowania płytki). Pamiętaj, że wycięcie jest w rzeczywistości obiektem Region skonfigurowanym jako obiekt ujemny.

Wycięcie zostało umieszczone wewnątrz obrysu płytki.Wycięcie zostało umieszczone wewnątrz obrysu płytki.

Jeśli wycięcie ma nietypowy kształt, na przykład koła, łatwiejsze może być utworzenie jego konturu za pomocą ścieżek i łuków (na przykład Place » Arc » Full Circle), zaznaczenie tego kształtu, a następnie przekształcenie go w wycięcie płytki (Tools » Convert » Create Board Cutout from Selected Primitives).

Ważne kwestie projektowe dotyczące wycięć w płytce

Zachowanie odstępu poligonu od krawędzi wycięcia w płytce

Poligony nakładające się na wycięcie płytki utworzone jako pełny region zostaną wypełnione tak blisko krawędzi wycięcia, jak pozwala na to obowiązująca reguła projektowa Clearance. W razie potrzeby można utworzyć osobną regułę Clearance, której zakres może na przykład obejmować odstęp między IsBoardCutoutRegion a InPolygon.

Definiowanie toru narzędzia frezującego wokół krawędzi płytki i wycięć

Typowym sposobem oddzielania gotowej płytki od panelu produkcyjnego jest wyfrezowanie jej z panelu. Wycięcia w płytce również można wykonać przez frezowanie. Tor narzędzia frezującego definiuje się przez umieszczenie obiektów linii i/lub łuków na warstwie mechanicznej. Można to zrobić ręcznie lub automatycznie za pomocą oprogramowania.

Aby zdefiniować tor narzędzia frezującego dla płytki i wszystkich jej wycięć:

  1. W trybie układu 2D uruchom polecenie Design » Board Shape » Create Primitives From Board Shape. Otworzy się okno dialogowe Line/Arc Primitives From Board Shape.

  2. Określ odpowiednią wartość Width dla obiektów definiujących tor narzędzia frezującego. Jeśli nie masz pewności, skonsultuj się z producentem płytki.

  3. Wybierz dostępną warstwę mechaniczną. Warstwa ta powinna być zarezerwowana wyłącznie do definiowania toru narzędzia frezującego.

  4. Włącz opcję Include Cutouts, jeśli płytka zawiera wycięcia.

  5. Włącz opcję Route Tool Outline. Gdy ta opcja jest włączona, obiekty linii i łuków są umieszczane tak, aby ich krawędzie stykały się z krawędzią obrysu płytki i krawędzią wycięcia.

  6. Kliknij OK, aby utworzyć obiekty toru narzędzia frezującego na wybranej warstwie mechanicznej. 

  7. Używaną warstwę mechaniczną należy ustawić jako warstwę Route Tool. W tym celu przejdź do karty Layers & Colors w panelu View Configuration. Kliknij prawym przyciskiem myszy w tabeli warstw i wybierz polecenie Add Mechanical Layer. W otwartym oknie dialogowym Edit Layer ustaw Layer Type na Route Tool Path.  Ten typ warstwy wskazuje warstwę zawierającą informacje o frezowaniu mechanicznym.

    Pamiętaj, że nazwa zdefiniowana przez użytkownika nie jest dozwolona, gdy Layer Type ma wartość Route Tool Path. Wynika to z faktu, że starsze wersje oprogramowania używają nazwy warstwy Route Tool Path do identyfikowania warstwy zawierającej informacje o frezowaniu. Stała nazwa tej warstwy zapewnia prawidłowe działanie projektu również w starszej wersji.

Poniższe ilustracje przedstawiają tor narzędzia frezującego zdefiniowany na warstwie mechanicznej.

Pierwsza ilustracja przedstawia wycięcie w płytce, a druga — zdefiniowany tor narzędzia frezującego. Pierwsza ilustracja przedstawia wycięcie w płytce, a druga — zdefiniowany tor narzędzia frezującego.

Obszary zabronione i obrys płytki

Oprócz obrysu płytki należy również zdefiniować wzdłuż jej krawędzi granicę rozmieszczania komponentów i prowadzenia ścieżek. Można ją utworzyć automatycznie na podstawie samego obrysu płytki za pomocą polecenia Design » Board Shape » Create Primitives From Board Shape (w trybie układu 2D), ustawiając Layer w oknie dialogowym Line/Arc Primitives from Board na Keep-Out Layer.

Można to również zrobić ręcznie, umieszczając obiekty na warstwie obszarów zabronionych (Keepout). Obiekty umieszczone na tej warstwie definiują granicę no-crossing-allowed dla komponentów i ścieżek. Zazwyczaj komponenty i ścieżki powinny znajdować się w określonej odległości od krawędzi płytki; odległość tę można kontrolować, ustawiając odpowiednie reguły projektowe dotyczące prowadzenia ścieżek i rozmieszczania komponentów. Można również zdefiniować dodatkowe obszary zakazu prowadzenia ścieżek i umieszczania komponentów dla elementów mechanicznych, takich jak łby śrub, lub zgodnie z innymi wymaganiami montażowymi.

Granica obszaru zabronionego zdefiniowana przez umieszczenie standardowych obiektów linii na warstwie Keepout (fioletowej).Granica obszaru zabronionego zdefiniowana przez umieszczenie standardowych obiektów linii na warstwie Keepout (fioletowej).

  • Granice obszarów zabronionych można definiować przez umieszczanie dowolnych standardowych obiektów projektowych, takich jak linie, łuki, wypełnienia i regiony, na warstwie Keepout. Obiekty umieszczone na warstwie Keepout tworzą obszar zabroniony na wszystkich warstwach sygnałowych.
  • Można również definiować obszary zabronione przypisane do konkretnej warstwy na dowolnej warstwie miedzi. W tym celu:
  1. Kliknij kartę wybranej warstwy.
  2. Zdefiniuj granicę lub powierzchnię obszaru zabronionego, umieszczając obiekty obszaru zabronionego przypisane do danej warstwy (podmenu Place » Keepout). Są to standardowe obiekty z włączonym atrybutem Keepout . Są wyświetlane w kolorze danej warstwy, z krawędzią w kolorze obszaru zabronionego. Pamiętaj, że obiekty obszarów zabronionych przypisane do konkretnej warstwy nie są uwzględniane w plikach wyjściowych Gerber ani ODB++.
AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Nav
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents