Praca z warstwami mechanicznymi
Altium Essentials: PCB Configuration
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
W skrócie
- Dowiedz się, kiedy używać pojedynczej warstwy mechanicznej, a kiedy pary warstw komponentów, zwłaszcza w przypadku informacji dotyczących jednej lub obu stron płytki.
- Zobacz, jak dodawać, konfigurować i porządkować warstwy mechaniczne w panelu View Configuration, w tym ustawiać ich nazwy, numery, widoczność i typy.
- Poznaj wpływ predefiniowanych typów warstw i ustawień bibliotek PCB na automatyczne tworzenie i mapowanie warstw w projekcie płytki.
Nawet najprostsza płytka wymaga szczegółów projektowych wykraczających poza ścieżki i pola lutownicze tworzące obwód. Mogą to być wymiary płytki, szczegóły produkcyjne, obrysy obszarów zajmowanych przez komponenty lub modele 3D komponentów. W Altium Designer tego rodzaju dodatkowe informacje umieszcza się na warstwach mechanicznych.
Warstwy mechaniczne i pary warstw komponentów
Jeśli informacje umieszczane na warstwie mechanicznej nie dotyczą konkretnej strony płytki, na przykład uwagi produkcyjne opisujące kolejność warstw, dodaje się individual mechanical layer.
Jeśli informacje są wymagane po obu stronach płytki, na przykład obrysy obszarów zajmowanych przez komponenty, przypisuje się dwie warstwy mechaniczne: jedną zawierającą obrys obszaru zajmowanego przez komponent umieszczony na górnej stronie płytki; drugą zawierającą lustrzane odbicie tego samego obrysu po przeniesieniu komponentu na dolną stronę płytki. W takiej sytuacji dodaje się parę warstw mechanicznych jako Component Layer Pair. Warstwy mechaniczne dodane jako para warstw komponentów są wyświetlane w sekcji Component Layer Pairs panelu View Configuration, jak pokazano poniżej. Pod nimi znajdują się pojedyncze Mechanical Layers.

Dodano kilka par warstw komponentów zdefiniowanych przez użytkownika.
| Display of Layer Pairs | W obszarze projektowym obie warstwy pary warstw komponentów są wyświetlane na osobnych kartach warstw z nazwami Top <LayerPairName> i Bottom <LayerPairName> |
| In the Library editor | W edytorze bibliotek PCB dodatkowe obiekty projektowe wymagane we wzorcu obudowy komponentu umieszcza się na górnej warstwie pary warstw komponentów. Po przeniesieniu komponentu na dolną stronę płytki podczas projektowania PCB (skrót L podczas przesuwania komponentu) zawartość górnej warstwy pary jest automatycznie odbijana lustrzanie na dolnej warstwie pary. |
| Automatic layer creation | Jeśli warstwa mechaniczna lub para warstw komponentów zdefiniowana w bibliotece PCB ma przypisany typ warstwy, ta warstwa mechaniczna lub para warstw jest automatycznie tworzona na PCB po umieszczeniu komponentu, który z nich korzysta. Jeśli na PCB istnieje już warstwa mechaniczna lub para warstw o takim typie, zawartość tych warstw jest odpowiednio przyporządkowywana. |
| Layers without a Layer Type |
W przypadku warstw mechanicznych lub par warstw zdefiniowanych w bibliotece PCB, którym nie przypisano typu warstwy, na PCB tworzone są pojedyncze warstwy mechaniczne. W takiej sytuacji przed umieszczeniem komponentu należy zdefiniować na PCB warstwę mechaniczną lub parę warstw o tych samych numerach, ponieważ jeśli oprogramowanie nie może dopasować warstw według typu, dopasuje je według numeru. |
Dodawanie warstw mechanicznych do projektu
Warstwy mechaniczne dodaje się, edytuje i usuwa w panelu View Configuration, jak pokazano poniżej. W panelu konfiguruje się również ich widoczność i kolor. Aby wyświetlić panel, użyj przycisku
w prawym dolnym rogu obszaru projektowego i wybierz View Configuration lub naciśnij klawisz skrótu L.
Kliknij prawym przyciskiem myszy w dowolnym miejscu obszaru Layers panelu, aby wyświetlić menu kontekstowe zawierające polecenia Add Component Layer Pair (para warstw mechanicznych) i Add Mechanical Layer (pojedyncza warstwa mechaniczna).
Pojedyncze warstwy mechaniczne lub ich pary dodaje się za pomocą menu kontekstowego panelu View Configuration.
Dodawanie pojedynczej warstwy mechanicznej
Po wybraniu polecenia Add Mechanical Layer z menu kontekstowego panelu View Configuration w celu dodania pojedynczej warstwy mechanicznej otworzy się okno dialogowe Edit Layer.
Skonfiguruj nową warstwę mechaniczną.
Okno dialogowe Edit Layer |
|
| Layer Name | Może to być nazwa warstwy zdefiniowana przez użytkownika lub przypisana przez system, jeśli z listy rozwijanej Layer Type wybrano wstępnie zdefiniowany typ. Jeśli wybrano wstępnie zdefiniowany typ warstwy, a następnie w tym polu wprowadzono własną nazwę, przypisany typ warstwy pojawi się w nawiasach obok nazwy zdefiniowanej przez użytkownika w panelu View Configuration. |
| Layer Number | Numer konfigurowanej warstwy mechanicznej; proponowany jest następny dostępny numer warstwy. Jeśli wybrany zostanie inny numer, który jest już używany, pojawi się ikona ostrzeżenia Aby kontynuować, należy przypisać nieużywany numer warstwy. |
| Layer Type | Typ warstwy może pozostać nieprzypisany (N/A) lub można wybrać go z listy. Dostępne typy warstw opisano poniżej. |
Dostępne typy warstw mechanicznych
| Assembly Notes | Często używana do określania kolejności montażu komponentów i/lub zamieszczania ważnych instrukcji montażowych. |
| Board | Użyj tej warstwy do zamieszczania instrukcji lub szczegółów dotyczących płytki. |
| Board Shape | Użyj tej warstwy do przedstawienia ogólnego obrysu płytki (kształtu płytki). |
| Dimensions | Służy do określania wymaganych wymiarów płytki. |
| Fab Notes | Służy do zamieszczania ważnych uwag produkcyjnych. |
| Route Tool Path | Służy do wskazywania warstwy zawierającej informacje o frezowaniu mechanicznym. Pamiętaj, że w przypadku tego typu warstwy nie można użyć nazwy zdefiniowanej przez użytkownika |
| Sheet | Użyj tej warstwy do zdefiniowania zewnętrznej ramki szablonu rysunkowego dokumentu. Szczegółowe informacje znajdziesz poniżej w sekcji Wyświetlanie i ustawienia arkusza. |
| V Cut | Służy do definiowania szczegółów nacięć V. Nacięcia V służą do rozdzielania płytek drukowanych poprzez wykonanie rowka w kształcie litery „V” na górnej i dolnej stronie płytki, z pozostawieniem minimalnej ilości materiału utrzymującego płytki razem w panelu. |
Dodawanie pary warstw komponentów
Po wybraniu polecenia Add Component Layer Pair z menu kontekstowego panelu View Configuration, otwieranego prawym przyciskiem myszy, otworzy się okno dialogowe Edit Layers Pair.
Okno dialogowe Edit Layers Pair |
|
| Layer Name | Może to być nazwa warstwy zdefiniowana przez użytkownika lub przypisana przez system, jeśli na liście rozwijanej Layer Type wybrano wstępnie zdefiniowany typ. Jeśli wybrano wstępnie zdefiniowany typ warstwy, a następnie w tym polu wprowadzono własną nazwę, przypisany typ warstwy będzie wyświetlany w nawiasach obok nazwy użytkownika w panelu View Configuration. |
| Layer Number | Numery konfigurowanych warstw mechanicznych. Proponowane są kolejne dostępne numery warstw. Jeśli wybrano inny numer, który jest już używany, pojawi się ikona ostrzeżenia Aby kontynuować, należy przypisać nieużywany numer warstwy. |
| Layer Type | Typ warstwy może pozostać nieprzypisany (N/A) lub można wybrać go z listy. Dostępne typy warstw opisano poniżej. |
Dostępne typy par warstw komponentów
| Assembly | Służy do rysowania i szczegółowego przedstawiania danych montażowych komponentu. Tę warstwę można uwzględnić w widoku montażowym płytki w Draftsman, a następnie wybrać jako Geometry Source dla komponentów w oknie dialogowym Component Display Properties programu Draftsman. Dowiedz się więcej o Draftsman. |
| Coating | Służy do definiowania obszarów komponentu wymagających powłoki ochronnej. |
| Component Center | Służy do wskazywania środka komponentu, zapewniając w dokumentacji montażowej wizualne odniesienie do położenia używanego przez automat montażowy. |
| Component Outline | Służy do definiowania obrysu korpusu komponentu, reprezentującego obszar zajmowany przez komponent na płytce. |
| Courtyard | Służy do definiowania przestrzeni wymaganej do umieszczenia komponentu. Zazwyczaj obrys Courtyard obejmuje komponent i pola lutownicze wraz z odpowiednim marginesem odstępu zielony obrys to Courtyard). Dowiedz się więcej o tworzeniu własnych footprintów. Kształt zdefiniowany na warstwie Courtyard służy również do zaznaczania komponentów, definiowania obszaru komponentu oraz wykrywania kolizji, gdy komponent nie zawiera bryły 3D. |
| Designator | Użyj tej warstwy do umieszczenia ciągu specjalnego .Designator. Tę parę warstw można następnie uwzględnić na rysunkach montażowych, na których wymagane jest wyświetlanie oznaczenia komponentu. Dowiedz się więcej o ciągach specjalnych. |
| Dimensions | Służy do definiowania szczegółowych wymiarów wymaganych dla komponentów. |
| Glue Points | Służy do definiowania punktów klejenia komponentów. |
| Gold Plating | Służy do definiowania wymagań dotyczących selektywnego złocenia komponentów. |
| Value | Użyj tej warstwy do umieszczenia ciągu specjalnego .Comment. Tę parę warstw można następnie uwzględnić na rysunkach montażowych, na których wymagane jest wyświetlanie wartości komponentu. Dowiedz się więcej o ciągach specjalnych. |
| 3D Body | Użyj tej warstwy do umieszczenia modelu mechanicznego 3D komponentu. Dowiedz się więcej o umieszczaniu brył 3D. |
| Die | Użyj tej warstwy do umieszczania pól kontaktowych struktury półprzewodnikowej i jej brył 3D podczas tworzenia komponentu Chip-on-Board. Dowiedz się więcej o łączeniu drutowym. |
| Wire Bonding | Użyj tej warstwy do umieszczania drutów połączeniowych podczas tworzenia komponentu Chip-on-Board lub bezpośrednio w dokumencie PCB. Dowiedz się więcej o łączeniu drutowym. |
Zalety przypisywania typu warstwy
Typowym sposobem zarządzania wykorzystaniem warstw mechanicznych jest przypisanie osobnego numeru warstwy do każdej wymaganej funkcji warstwy mechanicznej. Podejście to wymaga, aby wszyscy projektanci przestrzegali tego samego schematu przypisywania i numerowania warstw. Może również powodować trudności, gdy komponenty pochodzą z innych źródeł, w których stosuje się inny schemat przypisywania i numerowania. Jeśli zastosowano inny schemat, obiekty projektu trzeba przenieść z ich bieżącej warstwy mechanicznej na warstwę mechaniczną przypisaną do danej funkcji.
Problem ten rozwiązuje przypisanie właściwości Layer Type. Gdy komponent jest umieszczany z biblioteki w edytorze PCB, kopiowany z jednej biblioteki do drugiej lub tworzony przez IPC Footprint Wizard, istniejące przypisania typów warstw są automatycznie dopasowywane, niezależnie od numerów warstw mechanicznych przypisanych do tych typów. Obiekty są przenoszone na właściwe warstwy zgodnie z ich typem warstwy. Jeśli oprogramowanie nie może dopasować warstw według typu, dopasuje je według numeru.
Zarówno dla pojedynczych warstw mechanicznych, jak i dla par warstw komponentów można wybrać typ warstwy ze wstępnie zdefiniowanej listy. Poniższe ilustracje przedstawiają listę dostępnych typów warstw. Dostęp do pokazanych poniżej okien dialogowych można uzyskać, klikając prawym przyciskiem myszy pojedynczą warstwę, a następnie wybierając z menu polecenie Edit Layer lub Add Component Layer.

Wybierz typ warstwy ze wstępnie zdefiniowanej listy typów; po lewej stronie pokazano pojedyncze warstwy mechaniczne, a po prawej — pary warstw komponentów.
Nadawanie nazw warstwom z przypisanym typem
Po przypisaniu typu warstwy jej właściwość nazwy jest automatycznie zmieniana tak, aby odpowiadała typowi warstwy. W razie potrzeby można ją zastąpić, wpisując własną nazwę. Jeśli warstwa ma nazwę zdefiniowaną przez użytkownika i przypisany typ, wyświetlane są obie informacje, przy czym typ warstwy jest podany w nawiasach, jak pokazano poniżej dla pary warstw GP (Gold Plating).
Typ warstwy służy do nadawania jej nazwy; w razie potrzeby nazwę tę można zastąpić.
Typ warstwy Route Tool Path
Istnieje jeden wyjątek od opisanego powyżej sposobu nadawania nazw po przypisaniu typu warstwy — nazwa zdefiniowana przez użytkownika nie jest dozwolona, gdy Layer Type ma wartość Route Tool Path. Wynika to z faktu, że starsze wersje oprogramowania używają nazwy warstwy Route Tool Path do identyfikowania warstwy zawierającej informacje o frezowaniu (określane również jako informacje rout). Zachowanie stałej nazwy tej warstwy zapewnia poprawne działanie projektu w starszych wersjach.
Typ warstwy Route Tool Path służy do wskazywania warstwy zawierającej informacje o frezowaniu mechanicznym. Typowy sposób wykorzystania tej warstwy polega na umieszczaniu ścieżek i łuków wzdłuż zewnętrznej krawędzi obrysu płytki w celu określenia toru i szerokości obróbki. Pozostawia się pełne odcinki materiału utrzymujące płytkę w panelu, a następnie w każdym z tych odcinków umieszcza się szereg małych otworów tworzących perforację (często nazywaną „mouse-bites”), która umożliwia wyłamanie płytki z panelu po zakończeniu montażu.
Gdy płytka jest wyświetlana w trybie 3D, obiekty wykryte na warstwie Route Tool Path są przedstawiane jako wyfrezowany otwór podłużny w płytce, jak pokazano poniżej.

Obiekty wykryte na warstwie Route Tool Path służą do wizualizacji wyfrezowanej płytki w trybie wyświetlania 3D.
Użyj okna dialogowego Line/Arc Primitives from Board Shape, aby odwzorować zewnętrzny obrys płytki za pomocą ścieżek i łuków (jak pokazano poniżej). Włącz opcję Route Tool Outline w tym oknie, aby obiekty były umieszczane poza obrysem płytki zamiast centralnie na jej krawędzi. Niektórzy projektanci wolą dodawać informacje produkcyjne podczas korzystania z funkcji Embedded Board Array do tworzenia panelu montażowego, zamiast umieszczać je w pliku samej płytki.
Dowiedz się więcej o panelizacji płytek z użyciem funkcji Embedded Board Array
Definiowanie typu warstwy w edytorze bibliotek PCB
Jeśli warstwa mechaniczna lub para warstw komponentu zdefiniowana w bibliotece PCB ma przypisany typ warstwy, ta warstwa mechaniczna lub para warstw jest automatycznie tworzona na PCB po umieszczeniu komponentu korzystającego z tych warstw. Jeśli na PCB istnieje już warstwa mechaniczna lub para warstw o tym typie, zawartość tych warstw jest odpowiednio mapowana.
W miarę możliwości zaleca się edycję biblioteki źródłowej i przypisanie typów warstw. Gdy footprint komponentu jest umieszczany (lub kopiowany) z biblioteki, warstwy mechaniczne i pary warstw komponentu o tych typach są automatycznie tworzone na docelowej płytce (lub w bibliotece), jeśli jeszcze nie istnieją. Jeśli te typy warstw już istnieją na docelowej płytce (lub w bibliotece), zawartość warstw jest automatycznie mapowana na właściwą warstwę.
Dowiedz się więcej o obsłudze specjalnych wymagań dotyczących warstw w edytorze bibliotek PCB
Praca z warstwami mechanicznymi
Warstwy mechaniczne są dodawane, edytowane, usuwane i wyświetlane za pomocą panelu View Configuration w edytorze PCB. Nie są wyświetlane ani edytowane w Layer Stack Manager.
Wyświetlanie
Skonfiguruj widoczność warstw w panelu View Configuration i zapisz często używane grupy warstw jako zestaw warstw zdefiniowany przez użytkownika.
| Controlling layer visibility | Kliknij ikonę widoczności obok nazwy warstwy, aby włączyć lub wyłączyć wyświetlanie tej warstwy mechanicznej. Możesz też kliknąć nazwę warstwy, aby ją zaznaczyć, a następnie nacisnąć Spacebar (przełącza to wyświetlanie obu warstw w parze warstw komponentu). |
| Include in Single Layer Mode | Warstwy mechaniczne mają dodatkową funkcję wyświetlania: można ustawić je tak, aby pozostawały widoczne w trybie pojedynczej warstwy. Przytrzymaj |
| Include in 3D View Mode | Warstwy mechaniczne mogą być również uwzględniane w widoku 3D, gdy w ustawieniach 3D włączona jest opcja Colors - By Layer. Włącz tę opcję na karcie View Options panelu View Configuration, gdy płytka jest wyświetlana w trybie widoku 3D. Uwzględnione zostaną warstwy mechaniczne, które są aktualnie ustawione jako widoczne |
Edycja i usuwanie
Aby edytować ustawienia istniejącej pary warstw komponentu lub warstwy mechanicznej, kliknij dwukrotnie jej pozycję w panelu View Configuration (lub kliknij ją prawym przyciskiem myszy i wybierz Edit Layer z menu kontekstowego). Wprowadź wymagane zmiany w oknie dialogowym Edit Layers Pair / Edit Layer. Widoczność i kolor warstw mechanicznych konfiguruje się bezpośrednio w panelu View Configuration.
Aby usunąć warstwę, kliknij ją prawym przyciskiem myszy i wybierz Delete Layer. W zależności od sposobu wykorzystania warstwy możliwe są trzy sytuacje:
| Nothing on the layer | Jeśli na warstwie nie ma żadnych obiektów podstawowych, zostanie ona usunięta natychmiast po wybraniu Delete Layer (bez potwierdzenia). |
| Contains unlocked primitives | Jeśli na warstwie znajdują się niezablokowane obiekty podstawowe, pojawi się okno z prośbą o potwierdzenie usunięcia. |
| Contains locked primitives | Jeśli na warstwie znajdują się zablokowane obiekty podstawowe, na przykład należące do komponentu, pojawi się okno błędu informujące, że nie można wykonać tej operacji. |
Eksportowanie i importowanie
Strukturę warstw mechanicznych i par warstw komponentu dodanych do PCB można powielić na innej PCB, eksportując ten zestaw do pliku ze źródłowego dokumentu PCB, a następnie importując plik do docelowego dokumentu PCB.
Eksportowanie i importowanie warstw
-
W źródłowym dokumencie PCB, w którym dodano wymaganą strukturę warstw mechanicznych i par warstw komponentu, użyj polecenia Tools » Export Mechanical Layers z menu głównego. W otwartym oknie dialogowym Export Mechanical Layers określ nazwę i katalog pliku
*.stackup, który będzie zawierał dane o strukturze warstw mechanicznych. -
W docelowym dokumencie PCB użyj polecenia Tools » Import Mechanical Layers z menu głównego, a następnie w otwartym oknie dialogowym Import Mechanical Layers wybierz zapisany plik
*.stackup. Dodana struktura warstw mechanicznych i par warstw komponentu będzie widoczna w panelu View Configuration.
Kopiowanie i wklejanie zawartości warstw
Pamiętaj, że polecenia importowania i eksportowania przenoszą strukturę warstw mechanicznych i par warstw komponentu, ale nie przenoszą ich zawartości.
Aby skopiować zawartość:
-
Pojedynczej warstwy mechanicznej, użyj polecenia Edit » Select » All on Layer, gdy wymagana warstwa jest aktywna na źródłowej PCB, a następnie skorzystaj ze standardowej procedury kopiowania i wklejania, aby powielić te dane na docelowej PCB.
-
W przypadku wielu warstw mechanicznych skonfiguruj widoczność warstw w panelu View Configuration tak, aby wyświetlane były tylko wymagane warstwy mechaniczne. Następnie przeciągnij prostokąt zaznaczania obiektów przecinających jego granice (od prawej do lewej) wokół wszystkich wymaganych obiektów podstawowych na źródłowej PCB i użyj standardowej procedury kopiowania i wklejania, aby odtworzyć te dane na docelowej PCB.
Ustawienia prezentacji i danych wyjściowych
Warstwy mechaniczne często służą do umieszczania informacji, które muszą znaleźć się na wydrukach lub w wygenerowanych danych produkcyjnych. Mogą to być szablony rysunków, instrukcje produkcyjne, instrukcje montażowe itp. W razie potrzeby można je przygotować bezpośrednio w edytorze PCB.
W razie potrzeby informacje zawarte w dokumentacji produkcyjnej płytki można umieścić na warstwach mechanicznych.
Alternatywnie dokumentację tę można przygotować w Draftsman, zaawansowanym, elastycznym środowisku edycji graficznej do tworzenia dokumentacji produkcyjnej projektów płytek. System rysunkowy Draftsman, wyposażony w dedykowany zestaw narzędzi do rysowania, umożliwia interaktywne łączenie rysunków produkcyjnych i montażowych z niestandardowymi szablonami, adnotacjami, wymiarami, odnośnikami i uwagami.
Dowiedz się więcej o Draftsman
Prezentacja i ustawienia arkusza
Powyższy obraz przedstawia białe tło dokładnie dopasowane do obiektów rysunkowych tworzących szablon arkusza. Aby je utworzyć, należy dodać warstwę mechaniczną z parametrem Layer Type ustawionym na Sheet, która następnie służy do zdefiniowania zewnętrznej ramki szablonu rysunkowego dokumentu.
Rozmiar tego białego tła jest określany przez Sheet Settings, który można dostosować w panelu Properties, gdy w obszarze edycji nie jest zaznaczony żaden obiekt. Wartości X/Y lewego dolnego narożnika arkusza oraz Width i Height można skonfigurować ręcznie. Alternatywnie, gdy opcja Get Size From Sheet Layer jest włączona, tło arkusza jest automatycznie obliczane na podstawie prostokąta ograniczającego zbiór obiektów umieszczonych na warstwie mechanicznej typu Sheet.
Rozmiar tła arkusza może być automatycznie dopasowywany do obiektów umieszczonych na warstwie typu Sheet.
Kolor i widoczność tła arkusza konfiguruje się w sekcji System Colors panelu View Configuration. Kliknij przycisk koloru, aby zmienić kolor Sheet Line i Area Color. Przełącz na
/
, aby pokazać/ukryć arkusz.
Uwzględnianie warstw mechanicznych w danych wyjściowych
Warstwy mechaniczne służą do wielu różnych zadań i zawierają szczegółowe informacje wykorzystywane podczas projektowania, produkcji i montażu płytki oraz tworzenia dokumentacji produktu. Aby sprostać wszystkim tym wymaganiom, warstwy mechaniczne można wykluczać lub uwzględniać we wszystkich formach generowania danych wyjściowych opartych na warstwach, w tym w wydrukach i plikach wyjściowych.
Wydruki
W definicji wydruku PCB można uwzględnić dowolne warstwy obecne w projekcie, w tym warstwy mechaniczne. Wydruki konfiguruje się, dodając wymagane warstwy i ustawiając ich kolejność w oknie dialogowym Print.

Bardzo szczegółowe rysunki produkcyjne i montażowe można tworzyć, umieszczając obiekty na warstwach mechanicznych.
Dowiedz się więcej o przygotowywaniu wydruków 2D PCB
Generowane dane wyjściowe
Wszystkie dane wyjściowe przeznaczone do produkcji, takie jak Gerber i ODB++, umożliwiają uwzględnienie warstw mechanicznych jako wyjściowych Layer to Plot lub dodanie ich zawartości do każdej generowanej warstwy. Dane wyjściowe są generowane po uruchomieniu skonfigurowanego generatora, na przykład generatora ODB w pliku konfiguracji OutputJob (*.OutJob).

Warstwy mechaniczne można generować osobno lub, w razie potrzeby, dodawać do wszystkich generowanych warstw.
Dowiedz się więcej o przygotowywaniu projektu do produkcji
).
).



).