Поиск и размещение компонентов

Altium Training

Altium Essentials: Schematic Capture

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Краткий обзор

В этой статье рассказывается, как панель Components в Altium Designer помогает находить, просматривать, упорядочивать и размещать компоненты из вашего рабочего пространства, а также из библиотек баз данных и файловых библиотек. Рассматриваются различные способы поиска: просмотр по категориям, поиск по запросу и параметрическая фильтрация компонентов рабочего пространства. Также показано, как панель взаимодействует с другими инструментами, такими как панель Manufacturer Part Search, редактор компонентов и панель Explorer. Вы узнаете, как открыть панель из документов схем и печатных плат, как определяются категории компонентов и какие операции и настройки отображения доступны для оптимизации рабочего процесса. Если вы хотите быстрее находить подходящие компоненты и эффективно размещать их в своих проектах, продолжайте читать — эта статья поможет вам в этом.

- Узнайте, как искать компоненты на панели Components с помощью категорий, поисковых запросов и фильтров по параметрам.
- Разберитесь, откуда поступают компоненты: из рабочего пространства, файловых библиотек, библиотек баз данных и результатов поиска на панели Manufacturer Part Search.
- Узнайте, как размещать компоненты и использовать основные возможности панели для просмотра подробных сведений, редактирования компонентов, управления библиотеками и упорядочивания списка компонентов.
Узнайте больше с ИИ:

Основа любого электронного устройства — компоненты. Компонент, который в итоге будет припаян к плате, должен быть представлен, или смоделирован, в каждой области проектирования: в виде условного обозначения на схеме, SPICE-модели в симуляторе, посадочного места на плате и 3D-модели STEP в файле, передаваемом конструктору-механику.

Подробнее см. в разделе Создание и сопровождение компонентов и библиотек.

Панель Components в Altium Designer предоставляет мощный интерфейс для работы со всеми компонентами — как из рабочего пространства, так и из других источников. Нужный компонент можно найти, указав категорию и воспользовавшись простым режимом поиска: для этого в поле поиска вводится запрос — полное или частичное имя компонента, номинал и т. д. Кроме того, панель поддерживает параметрический (фасетный) поиск на основе фильтров, позволяющий задавать требуемые параметры компонентов рабочего пространства. Панель также позволяет редактировать компонент рабочего пространства в редакторе компонентов в режиме редактирования одного компонента, просматривать компонент в исходном рабочем пространстве и выполнять операции управления компонентами: создавать и клонировать компоненты, а также изменять варианты выбора деталей (Part Choices) и тип (Type) выбранного компонента. Компонент можно разместить на схеме перетаскиванием или с помощью команды Place  в контекстном меню компонента.

Разумеется, вы можете создавать собственные компоненты, однако Altium Designer также предоставляет мощную панель Manufacturer Part Search для поиска реально выпускаемых деталей. Если у вас есть рабочее пространство, эти детали можно сохранить в нем, а затем обращаться к ним через панель Components. Этот процесс включает создание нового компонента рабочего пространства в редакторе компонентов в режиме редактирования одного компонента и его сохранение в рабочем пространстве.

Панель Components обеспечивает прямой доступ к доступным компонентам рабочего пространства, а также к компонентам библиотек на основе баз данных и файловых библиотек в Altium Designer.

Панель получает компоненты из подключенного рабочего пространства и всех открытых или установленных библиотек. Панель предоставляет полные сведения о выбранном компоненте (параметры, модели, варианты выбора деталей, данные поставщиков и т. д.), позволяет сравнивать компоненты, а для компонентов рабочего пространства поддерживает параметрический поиск на основе фильтров с указанием требуемых параметров.

Панель Components в обычном режиме

Панель Components в компактном режиме

 

Панель Components использует базовые функции поискового механизма и представление, применяемые в панели Manufacturer Part Search. При этом панель Manufacturer Part Search использует службу Altium Parts Provider и предназначена для поиска данных производителей и поставщиков компонентов, а панель Components содержит готовые к размещению компоненты из подключенного рабочего пространства, библиотек на основе баз данных и файловых библиотек.

Для компонентов рабочего пространства на панели отображается только последняя ревизия каждого компонента.
Хотя большая часть функций работы с компонентами доступна на панели Components, можно также использовать панель Explorer. По сути, первая предоставляет подмножество функций второй, ориентированное на управление компонентами. Некоторые операции с компонентами по-прежнему можно выполнить только на панели Explorer (добавление документации без редактирования, изменение состояний, массовое удаление компонентов и моделей и т. д.), однако они обычно требуются в нетипичных, исключительных случаях либо при администрировании или структурировании рабочего пространства. Помните, что компонент — лишь один из типов содержимого, а панель Explorer раскрывает свои возможности при работе со всем спектром типов содержимого, поддерживаемых рабочим пространством. Например, создавать шаблоны компонентов — сущности, непосредственно связанные с компонентами, — и управлять ими можно только на панели Explorer (если только шаблоны не создаются при импорте библиотек с помощью Library Importer).

Доступ к панели Components

Чтобы открыть панель Components, выберите View » Panels » Components в главном меню или пункт Components в меню кнопки в правом нижнем углу главного окна. Благодаря адаптивной компоновке панель динамически переключается между полноэкранным обычным режимом () и компактным режимом (), в котором параметры категорий и фильтров сворачиваются в меню.

В документе схемы используйте сочетание клавиш P, P, чтобы открыть панель Components. Также можно воспользоваться командой Place » Part в главном меню, командой Place » Part в контекстном меню рабочей области редактора схем или кнопкой Part () на Active Bar.

В документе печатной платы используйте сочетание клавиш P, C, чтобы открыть панель Components. Также можно воспользоваться командой Place » Component в главном меню, командой Place » Component в контекстном меню рабочей области редактора печатных плат или командой Component () на Active Bar.

При первом открытии панели Components в текущем сеансе Altium Designer, если установлено подключение к рабочему пространству, доступны следующие элементы управления:

  • Use Existing Components — нажмите, чтобы просмотреть компоненты типа, выбранного в верхнем раскрывающемся списке панели.

  • Delete Existing Components — нажмите, чтобы открыть диалоговое окно Delete Existing Components, а затем страницу Data Cleanup в Settings вашего рабочего пространства, где можно выбрать типы содержимого для удаления.

  • Import Library — нажмите, чтобы открыть стандартное диалоговое окно Windows Open, а затем выберите библиотеку на основе базы данных или файловую библиотеку, сохраненную в локальной или сетевой папке. После открытия файла библиотеки запустится Library Importer в простом режиме с загруженной выбранной библиотекой.

  • Create Component — нажмите, чтобы открыть диалоговое окно Create New Component, а затем редактор компонентов в режиме редактирования одного компонента, готовый к созданию нового компонента.

В области Categories панели (или в раскрывающемся меню в компактном режиме) перечислены все доступные компоненты рабочего пространства в категории All, а также все доступные библиотеки. Когда панель находится в обычном режиме, нажмите значок списка Categories или значок «, чтобы свернуть или развернуть столбец, и используйте кнопку (справа вверху), чтобы показать или скрыть область Details компонента. При просмотре области Categories для перемещения по списку можно использовать сочетания клавиш Up/Down и PgUp/PgDn. Сочетания клавиш Left/Right позволяют разворачивать и сворачивать отдельные ветви.

Группировка Categories для компонентов рабочего пространства определяется параметрами Component Type, связанными с каждым компонентом. Например, если для компонента параметр Component Type имеет значение Resistor, этот компонент будет отображаться в категории Resistor на панели Components (независимо от того, в какой папке рабочего пространства он находится).

Чтобы задать или изменить тип компонента на лету, щелкните правой кнопкой мыши его запись и выберите в контекстном меню пункт Operations » Change Component Type, чтобы открыть диалоговое окно выбора типа компонента.

Параметр Type компонента задается:

Управление типами компонентов (создание, редактирование и удаление) выполняется на странице Data Management – Component Types диалогового окна Preferences. Кнопка Templates этого окна открывает диалоговое окно Edit Templates, в котором можно задать или изменить шаблон компонента, связанный с каждым типом компонентов.

NOTE: Категория Category, в которой отображается компонент, определяется его параметром Component Type и не связана с папкой рабочего пространства, в которой он находится. Поэтому перемещение компонента в другую папку через панель Explorer не отразится на панели Components.

Меню операций

Пункты меню операций позволяют настраивать параметры файловых библиотек, выполнять поиск и указывать, следует ли отображать коллекции моделей компонентов. Для доступа к этим пунктам нажмите кнопку меню операций в правом верхнем углу панели.

  • Create Component — выберите, чтобы открыть диалоговое окно Create new component, а затем редактор компонентов в режиме редактирования отдельного компонента, готовый к созданию нового компонента.
  • Import Library — выберите, чтобы открыть стандартное диалоговое окно Windows Open и выбрать библиотеку базы данных или файловую библиотеку, сохраненную в локальной или сетевой папке. После открытия файла библиотеки запустится Library Importer в простом режиме с загруженной выбранной библиотекой.
  • Clean-up Library — выберите, чтобы открыть диалоговое окно Delete Existing Components, а затем страницу Data Cleanup раздела Settings вашего рабочего пространства, где можно выбрать типы содержимого для удаления.
  • Models — выберите, чтобы включить записи коллекций библиотечных моделей в список Categories. В этом режиме просмотра дополнительно отображаются коллекции условных графических обозначений, посадочных мест и моделей для моделирования из подключенного рабочего пространства, а также установленные библиотеки посадочных мест печатных плат (*.PcbLib).
  • File-based Libraries Preferences — выберите, чтобы открыть диалоговое окно Available File-based Libraries, в котором доступны средства добавления библиотек баз данных и файловых библиотек в текущий проект, удаления библиотек из него, установки библиотек и указания путей поиска библиотек. Подробнее см. в разделе Управление доступными библиотеками баз данных и файловыми библиотеками на странице Поиск компонентов в файловых библиотеках и библиотеках баз данных.
  • File-based Library Search — выберите, чтобы открыть диалоговое окно File-based Libraries Search, в котором можно найти компонент, если неизвестно, в какой библиотеке баз данных или файловой библиотеке он находится и доступен ли он вообще. Подробнее см. в разделе Поиск компонентов в библиотеках баз данных и файловых библиотеках на странице Поиск компонентов в файловых библиотеках и библиотеках баз данных.
  • Refresh — нажмите, чтобы быстро обновить панель. Текущий выбор компонентов будет сохранен.

Список компонентов

Содержимым таблицы списка компонентов можно управлять следующими способами:

  • Настройка порядка сортировки списка компонентов — щелкните заголовок столбца, чтобы отсортировать список компонентов по данным этого столбца. Щелкните заголовок еще раз, чтобы изменить порядок сортировки на обратный.

  • Настройка порядка отображения столбцов — перетащите заголовок столбца в новое положение.

  • Выбор отображаемых столбцов параметров — щелкните правой кнопкой мыши заголовок столбца и выберите Select Columns, чтобы открыть диалоговое окно Select Columns, в котором можно управлять видимостью столбцов параметров и изменять их порядок.

    Диалоговое окно Select columns
    Диалоговое окно Select columns

    • В этом окне перечислены все столбцы, которые могут отображаться на панели Components. Если рядом с элементом отображается , соответствующий столбец будет отображаться на панели Components . Если рядом с элементом отображается , соответствующий столбец not будет отображаться на панели Components. Нажимайте эти значки, чтобы переключать отображение и скрытие столбцов.

    • Также можно управлять отображением всех столбцов, нажав значок / в строке заголовков столбцов. Если часть столбцов отображается, а часть скрыта, отображается значок .

    • Наведите указатель на строку заголовка второго столбца и нажмите значок , чтобы открыть раскрывающийся список, в котором можно выбрать отображаемый столбец.

    • Используйте кнопки  / , чтобы переместить выбранный элемент вверх или вниз по списку. Перемещать можно только элементы, для которых включено отображение (). Это определяет порядок столбцов на панели Components.

  • Группировка списка по данным столбца — щелкните правой кнопкой мыши заголовок столбца, выберите пункт Enable Columns Grouping, а затем перетащите заголовок столбца (например, Footprint) в область группировки в верхней части списка. Записи списка будут сгруппированы по каждому уникальному значению параметра (например, типу посадочного места) из указанного столбца группировки.

    При использовании Grouping для группировки компонентов в списке поддерживается не более 10 000 записей.

  • Фильтрация списка по определенному значению в столбце — нажмите в заголовке столбца, чтобы отобразить список уникальных значений его параметра, а затем выберите значение, чтобы оставить в списке только компоненты с указанным параметром (например, кодом типа посадочного места). Выберите пункт All, чтобы сбросить фильтр. Выберите (Custom), чтобы открыть диалоговое окно Filter Editor и дополнительно настроить фильтрацию в выбранном столбце.

Отображение столбцов

Содержимое панели Components можно отображать различными способами. Щелкнув правой кнопкой мыши заголовок любого столбца (Name, Description, Footprint), можно выбрать следующие пункты в зависимости от желаемого способа отображения компонентов:

  • Best Fit — располагает содержимое столбцов Name и Descriptions вплотную друг к другу, без лишнего пространства между столбцами.

  • Best Fit All Columns — располагает содержимое всех столбцов вплотную друг к другу, без лишнего пространства между столбцами.

  • Clear Sorting — отменяет сортировку столбцов.

  • Enable Columns Grouping – позволяет перетаскивать заголовки столбцов, меняя порядок столбцов Name, Description и Footprint.

  • Select Columns – открывает диалоговое окно Select Columns, в котором можно выбрать другие столбцы для отображения в этом разделе.

  • Apply Column Visibility to Child Categories – если у выбранной категории есть дочерняя категория, эта команда позволяет передать настройки видимости столбцов из родительских категорий в дочерние. Команда доступна только при наличии дочерней категории.

Поиск компонентов и работа с ними

Поиск компонентов

Для поиска доступных компонентов на панели Components введите фразу в поле Search и/или используйте параметры Categories и Filters на панели, чтобы отобрать компоненты в соответствии с вашими требованиями. Фильтры поддерживаются только для компонентов рабочего пространства. Как и панель Manufacturer Part Search, панель Components поддерживает поисковые фильтры с учетом единиц измерения (с преобразованием текста в число). Результаты поиска упорядочиваются по приоритету в соответствии с введенными критериями.

Функция Search позволяет выбрать активную строку Search, а затем изменить или дополнить ее.

Нажмите на «активную» строку поиска, чтобы поместить ее в поле Search. В поле Search можно повторно использовать или изменить этот поисковый запрос.

Поле Search также поддерживает поиск с подстановочными знаками, обозначаемыми звездочкой (*) в строке.

Диалоговое окно Find Similar Components, которое открывается щелчком правой кнопкой мыши по компоненту в списке и выбором Find Similar Components, позволяет задать параметры поиска на основе выбранного компонента.

Итоговые результаты поиска зависят от выбранного типа компонентов — компонентов рабочего пространства или компонентов вне рабочего пространства — и состояния подключения к рабочему пространству. Например, для компонентов рабочего пространства часто отображается больше параметров, чем для компонентов вне рабочего пространства. Чтобы отобрать компоненты и параметры, совпадающие с выбранным компонентом или отличающиеся от него, используйте раскрывающиеся списки с вариантами Same, Any или Different.

Размещение компонентов

Выбранный компонент можно разместить на схеме перетаскиванием, выбрав Place в его контекстном меню, нажав кнопку в области Details, дважды щелкнув по записи нужного компонента или воспользовавшись сочетанием клавиш Enter.

Чтобы разместить компонент с панели, можно выполнить одно из следующих действий:

  • Нажмите кнопку Place в области Component Details — курсор автоматически переместится в пределы листа схемы, и к нему будет прикреплен компонент; укажите нужное положение и щелкните для размещения. После размещения компонента к курсору будет прикреплен еще один экземпляр того же компонента; щелкните правой кнопкой мыши для выхода из режима размещения.

    Components panel, placing from component details pane

  • Щелкните по компоненту правой кнопкой мыши и выберите Place в контекстном меню. Компонент будет прикреплен к курсору; укажите нужное положение и щелкните для размещения. Обратите внимание: если плавающая панель находится поверх области проектирования, она станет полупрозрачной, чтобы вы могли видеть схему и разместить компонент. После размещения компонента к курсору будет прикреплен еще один экземпляр того же компонента; щелкните правой кнопкой мыши для выхода из режима размещения.

  • Click, Hold&Drag — нажмите на компонент в табличной области панели и перетащите его на лист схемы. В этом режиме необходимо удерживать кнопку мыши нажатой; компонент размещается при отпускании кнопки. После размещения компонента можно выбрать другой компонент или другую команду.

    При перетаскивании размещается один экземпляр компонента. Если необходимо разместить несколько экземпляров, используйте команду или кнопку Place либо дважды щелкните по записи компонента.

Разместить компонент действительно очень просто. Но прежде всего убедитесь, что лист схемы (или документ печатной платы), на котором требуется разместить компонент, открыт в Altium Designer и является активным документом. Если документы открыты в нескольких окнах, также убедитесь, что фокус ввода находится в окне с активным документом схемы.

При работе с Altium Designer в нескольких окнах, если панель Components или Explorer закреплена в любом режиме в окне, не содержащем целевую схему, команда Place будет недоступна. Это связано с тем, что щелчок внутри закрепленной панели передает фокус окну, к которому она прикреплена. Если же панель плавающая, можно передать фокус нужному окну Altium (с активной целевой схемой), и оно сохранит фокус при работе с панелью.

Размещение многосекционного компонента

Если размещаемый компонент состоит из нескольких секций, первой будет размещена секция, выбранная под изображением предварительного просмотра условного обозначения в области Models панели.

После размещения секции многосекционного компонента ее можно заменить другой секцией этого компонента с помощью раскрывающегося списка Part на панели Properties, когда секция выбрана. Также можно переключиться на следующую доступную секцию с помощью команды Edit » Increment Part Number в главном меню или команды Part Actions » Increment Part Number в контекстном меню секции.

Altium Designer поддерживает представление многосекционного компонента в виде одного символа (все секции) или нескольких символов (по одному для каждой секции) с использованием одного компонента благодаря заданным обычному и альтернативному режимам отображения (Показать пример).

  • Если в режиме отображения многосекционного компонента (обычном или альтернативном) есть пустые секции, они пропускаются при размещении (Показать пример).

  • Если примитивы многосекционного компонента заданы только в одной секции, суффикс позиционного обозначения скрывается при размещении этой секции на листе схемы (Показать пример).

  • Если в секции нет примитивов для выбранного режима отображения или в режиме отображения нет примитивов для выбранной секции, соответствующий пункт раскрывающегося списка Part из Mode на панели Properties компонента отображается серым цветом (). При выборе такого пункта в раскрывающемся списке отображаются значки предупреждения ().

  • При проверке проекта нарушение Неиспользуемая секция компонента не возникает, если у компонента есть секции без примитивов и эти секции не размещены на схеме.

Фильтрация компонентов

При просмотре компонентов рабочего пространства область Filters заполняется вариантами фильтрации на основе текущего поиска и доступных параметров. Параметрическая фильтрация компонентов в списке предоставляет дополнительные возможности поиска конкретного компонента или типа компонентов. Откройте область Filters с помощью кнопки над областью Categories. В компактном режиме панели нажмите кнопку , чтобы открыть Filters в виде дополнительной области панели.

Обратите внимание: фильтры поддерживаются только для компонентов рабочего пространства. Чтобы найти фильтр по определенному параметру, используйте поле Filter Search в этой области.

Javascript ID: Pnl_Components_Filter
  • Возможность параметрического поиска в Filters панели зависит от передачи соответствующих данных о параметрах компонентов из рабочего пространства, в котором хранятся компоненты. Поэтому функция фильтрации может быть недоступна при подключении программы к более старому серверному продукту Altium. Чтобы включить фильтрацию для предыдущих версий сервера, включите параметр ComponentSearch.LegacyAFS.Filters в диалоговом окне Advanced Settings.

  • Чтобы параметр отображался в области Filters, компоненты выбранной категории должны использовать как минимум два разных значения этого параметра. Также обратите внимание, что в области Filters отображается не более 100 наиболее популярных параметров (используемых наибольшим числом компонентов подключенного рабочего пространства среди всех типов компонентов). Следующие параметры (или параметры, имена которых начинаются со следующих названий) всегда отображаются в верхней части области: Power, Value, Resistance, Res, Capacitance, Case, Package, Tolerance, RoHS, Lead.

Параметры фильтрации Filters панели можно настроить в соответствии со своими потребностями, отметив определенные типы параметров как Favorites. После этого они переместятся в начало списка для текущей категории компонентов. Наведите указатель на область справа от имени фильтра параметра и нажмите значок , чтобы добавить фильтр в избранное. Настройки избранных фильтров применяются и сохраняются отдельно для каждой категории компонентов.

Для компонентов рабочего пространства контекстное меню содержит команды редактирования компонента в редакторе компонентов (Edit), а также функции управления компонентами: создание и клонирование компонентов, редактирование вариантов выбора комплектующих и типа выбранного компонента (Operations).

 
 
 
 
 

Дополнительные возможности просмотра информации в области Details компонента включают просмотр изображения модели, технической документации в интернете (References), актуальной информации от поставщиков (Part Choices), сведений о том, где компонент используется в проектах рабочего пространства, управляемых листах и блоках повторного использования (Where Used). Кроме того, через контекстное меню можно скопировать выбранные или все данные параметров компонента (технические характеристики) в формате с разделением табуляцией, а также сбросить набор избранных параметров до пяти параметров по умолчанию.

При просмотре компонентов в подключенной рабочей области Altium 365 Workspace, если обнаружены проблемы с состоянием выбранного компонента, в строке Component issues над списком параметров компонента отображается значок (для ошибок) или (для критических ошибок). Число справа от значка указывает количество обнаруженных проблем. Нажмите стрелку вниз справа от числа, чтобы просмотреть краткие описания проблем.

Пример обнаруженных проблем с состоянием библиотеки.
Пример обнаруженных проблем с состоянием библиотеки.

Более подробно изучить состояние библиотеки рабочей области можно на странице панели мониторинга Library Health, доступной в браузерном интерфейсе Altium 365 Workspace. Подробнее см. в разделе Панель мониторинга состояния библиотеки.

Для более точной фильтрации на панели Components можно использовать настраиваемые фильтры. ​​​​​​

Чтобы воспользоваться этой функцией:

  1. нажмите значок фильтра () в заголовке, чтобы открыть раскрывающийся список Filter,

  2. который позволяет фильтровать данные, выбрав Filter Value (по умолчанию) или настроив пользовательский Filter Rule. При выборе значения из списка оно автоматически преобразуется в выражение, которое затем можно отредактировать.

  3. Если вы выбрали Filter Rules, чтобы задать собственный фильтр, выберите оператор в первом раскрывающемся списке,

  4. а затем выберите или введите значение фильтра во втором раскрывающемся списке.

  5. Текущий фильтр отображается под списком результатов. Нажмите кнопку , чтобы открыть диалоговое окно Filter Editor и отредактировать фильтр.

Где используется

Выберите компонент рабочей области на панели Components, чтобы в области Where Used просмотреть сведения о том, где в настоящее время используется его последняя ревизия. Эта область предоставляет сведения с возможностью быстрой фильтрации по следующим категориям:

  • Projects — проекты рабочей области, в которых используется компонент. Сведения only отображаются после сохранения проекта в рабочей области.

  • Managed Sheets — управляемые листы схем, на которых используется компонент. 

  • Reuse Blocks — блоки повторного использования, хранящиеся в библиотеке подключенной рабочей области.

Обратите внимание: вкладки отображаются только в том случае, если в рабочей области есть объект, использующий выбранный компонент.

Если компонент используется не во всех вариантах исполнения проекта рабочей области, запись проекта в области Where Used будет содержать количество вариантов, в которых используется компонент, общее количество вариантов этого проекта, а также список вариантов, в которых используется компонент ().

Кэширование данных компонентов

При использовании панели Components данные компонентов рабочей области кэшируются из рабочей области на локальном компьютере. Это обеспечивает автономный доступ к компонентам рабочей области, когда Altium Designer не подключен к ней, и позволяет просматривать и размещать компоненты, а также выполнять другие обычные действия.

При первом открытии панели Components в текущем сеансе Altium Designer в автономном режиме на ней отображается предупреждение, а также элементы управления, позволяющие продолжить использование кэшированных данных компонентов или очистить кэш.

Нажмите Use Cached Data, чтобы использовать кэшированные компоненты. Этот режим обозначается предупреждением Offline mode – cached data is being used в нижней строке области списка компонентов панели. Обратите внимание: Filters в этом режиме недоступны.

Данные компонентов постепенно накапливаются в кэше. Его можно в любой момент очистить (для всех рабочих областей) с помощью параметра Clear Cache, доступного в разделе Known Servers на странице Data Management – Servers диалогового окна Preferences.

При кэшировании отображаются только кэшированные компоненты из подключенных в данный момент рабочих областей, например Altium 365 Workspace, поэтому некоторые кэшированные данные могут быть недоступны. Это поведение можно настроить на странице Data Management – Servers диалогового окна Preferences.

Список вариантов компонентов

Чтобы отредактировать список вариантов компонентов, связанный с компонентом рабочей области, выберите пункт Operations » Create/Edit Part Choices в контекстном меню его записи.

В открывшемся диалоговом окне Edit Part Choices нажмите кнопку , чтобы открыть диалоговое окно Add Part Choices, которое автоматически выполнит поиск компонентов производителей по параметру Name выбранного компонента. Снимите выбор предустановленного поискового запроса, чтобы вручную найти альтернативы. Функционально это диалоговое окно представляет собой модальную версию панели Manufacturer Part Search.

Вариантам компонентов в списке можно назначить рейтинг, выбрав соответствующее количество звезд. Список будет автоматически переупорядочен: вариант производителя с наивысшим рейтингом окажется вверху.

Варианты компонентов сохраняются вместе с компонентом везде, где используются его данные: в схеме, документе спецификации, выходном отчете и т. д.

При выборе компонента на панели Components список его вариантов отображается в области Part Choices секции Details. Основные сведения (наличие на складе, медианная цена за единицу и статус жизненного цикла у производителя) о соответствующем варианте компонента также доступны в верхней части секции Details. Цветная полоса указывает на общую пригодность компонента к использованию на основе определенного для него статуса жизненного цикла. Например, компонент с отметкой Obsolete (красный) менее предпочтителен, чем компонент с отметкой Volume Production (зеленый). Наведите указатель на цветную полосу, чтобы увидеть статус жизненного цикла у производителя.

Если вы используете функции интеграции с SiliconExpert или Z2Data, в верхней части панели Details могут быть доступны дополнительные данные и элементы управления. Подробнее см. на страницах Получение данных о деталях из SiliconExpert и Получение данных о деталях из Z2Data.

Если в вашем рабочем пространстве включена функция Контроль ревизий вариантов выбора деталей, при выборе опции Operations » Create/Edit Part Choices вместо диалогового окна Edit Part Choices откроется редактор компонентов (в режиме Редактирование одного компонента или Пакетное редактирование компонентов). Внесите необходимые изменения в варианты выбора деталей и сохраните компоненты в рабочем пространстве, создав для них следующие ревизии.

Контекстное меню панели Components

Контекстное меню панели содержит следующие команды:

 
 
 
 
 
  • Place [ComponentName/FootprintName/SimulationModelName] — позволяет разместить выбранный компонент или модель моделирования в активном документе схемы либо выбранное посадочное место в активном документе печатной платы.

  • Find Similar Components — открывает диалоговое окно Find Similar Components, в котором можно задать критерии поиска компонентов, похожих на выбранный.

  • Navigate to [ComponentName] — открывает выбранный компонент рабочего пространства на панели Explorer, где можно просматривать подробную информацию об элементе, управлять параметрами ревизий и жизненного цикла элементов, а также просматривать сведения об использовании и цепочке поставок и выполнять другие действия.

  • Edit — позволяет редактировать выбранные компоненты рабочего пространства в редакторе компонентов (в режиме Редактирование одного компонента или Пакетное редактирование компонентов) либо выбранную модель предметной области (условное графическое обозначение, посадочное место или модель моделирования) в соответствующем редакторе. Если текущий тип компонента отличается от типа, заданного в используемом шаблоне, откроется диалоговое окно Change component type (). Используйте это окно, чтобы изменить тип выбранного компонента.

  • Create — открывает диалоговое окно Create new component для выбора типа при добавлении нового компонента.

  • Delete — удаляет выбранные компоненты из подключенного рабочего пространства.

  • Operations — открывает раскрывающееся меню дополнительных функций для компонентов рабочего пространства, описанных ниже.

    • Submit Request — предоставляет доступ к активным определениям процессов запросов на создание деталей. Если для категории процессов Part Requests нет активных определений процессов, кнопка Submit Request будет неактивна (недоступна). Для обновления может потребоваться выйти из рабочего пространства и войти снова либо перезапустить Altium Designer.

    • Download — позволяет скачать выбранные компоненты в виде скомпилированной интегрированной библиотеки (*.IntLib), упакованной в ZIP-архив, вместе с исходным пакетом библиотеки (*.LibPkg) и файлами библиотек. Выберите несколько компонентов, чтобы скачать их за один раз.

    • Make a copy — создает копию выбранного компонента. Редактор компонентов открывается в режиме Single Component Editor.

    • Change Component Type — открывает диалоговое окно Choose component type (), в котором можно изменить тип текущего компонента на один из других существующих типов в списке. В окне отображаются сведения о шаблоне компонента, связанном с типом компонента, и папке в подключенном рабочем пространстве, в которой можно найти или сохранить компоненты этого типа. Нажмите кнопку , чтобы настроить список доступных типов компонентов на странице Data Management – Component Types диалогового окна Preferences.

    • Change State — позволяет изменить состояние ревизии выбранных компонентов. После выполнения команды открывается диалоговое окно Batch state change, в котором можно изменить состояние ревизии компонентов.

    • Create/Edit Part Choices — открывает диалоговое окно Edit Part Choices, в котором можно создать или изменить список вариантов выбора деталей, связанный с компонентом рабочего пространства.

      Если в вашем рабочем пространстве включена функция Контроль ревизий вариантов выбора деталей, при выборе этой команды откроется редактор компонентов в режиме Редактирование одного компонента или Пакетное редактирование компонентов.
    • Full Item History — открывает подробное представление выбранного компонента на новой вкладке в Altium Designer. Представление Item View содержит подробную историю ревизий и жизненного цикла конкретного элемента, а также показывает все составляющие этого элемента. Представление также включает временную шкалу. Используйте ее, чтобы узнать точные дату и время любого изменения ревизии или состояния жизненного цикла элемента, а также имя пользователя, внесшего изменение.

  • Refresh — позволяет быстро обновить панель. Текущий выбор компонентов будет сохранен.

Функция сравнения компонентов

Функция Compare позволяет сравнивать параметры двух выбранных компонентов. Для доступа к этой функции выберите два компонента в области таблицы при включенном значке (синего цвета). Справа от области таблицы откроется область Selected Component Details. В верхней области (область 1 на изображении ниже) рядом отображаются изображение, название, описание и цена выбранных компонентов. Нажмите кнопку Datasheet, чтобы открыть техническое описание производителя для соответствующего компонента (если оно доступно). Нажмите кнопку Place, чтобы разместить компонент в рабочей области проекта. Компонент появится в рабочей области, привязанный к курсору; щелкните, чтобы разместить его в нужном месте. Можно продолжить размещение дополнительных компонентов либо нажать правую кнопку мыши или Esc, чтобы выйти из режима размещения и вернуться на панель Components.

В нижней области (область 2 на изображении ниже) рядом отображаются параметры компонентов; для удобства сравнения различия выделены красным цветом.

Функция Compare также доступна, когда панель Components находится в компактном режиме, однако работает несколько иначе. Для доступа к этой функции выберите два компонента в области таблицы. Под областью таблицы откроется область Selected Component Details. В верхней области отображаются название, цена и параметры компонентов; для удобства сравнения различия выделены красным цветом. В нижней области рядом отображаются Symbols и Models компонентов.

Функция Compare и ее возможности также доступны на панели Manufacturer Part Search.

Редактирование символов и посадочных мест компонентов

Символ и посадочное место компонента можно скрыть в разделе Models области Details, доступ к которой открывается нажатием Info button в правом верхнем углу. После скрытия символ и посадочное место заменяются ссылками, нажатие на которые возвращает скрытые элементы к исходному виду. Также можно изменять масштаб отображаемых моделей. Чтобы изменить размер изображения символа или посадочного места, перетащите нижнюю границу области модели.

Обратите внимание, что возможность скрывать представления моделей и изменять их масштаб также доступна в области Details на панели Manufacturer Part Search.

При просмотре файла библиотеки схемных компонентов (*.SchLib) на панели Components символ и посадочное место выбранного компонента можно редактировать с помощью кнопки в правом нижнем углу области предварительного просмотра модели.

Возможность редактирования посадочного места доступна при обращении к Components, если корректные и связанные посадочные места уже существуют.

Диалоговые окна выбора компонентов

Поисковый механизм и представление, используемые в панели Components, также применяются в других инструментах Altium Designer, где требуется выбор компонента. Эти модальные диалоговые окна включают функции поиска компонентов, кнопку подтверждения OK и несколько различающийся набор доступных команд. Обычно такое диалоговое окно называется Component Search.

Доступ к обобщенным компонентам и их размещение

Эта функция находится на стадии открытого бета-тестирования и доступна, если параметр ComponentSearch.GenericComponents включен в диалоговом окне расширенных настроек.

Для ускорения работы на ранних этапах проектирования предусмотрена возможность использования стандартных базовых Generic Components. Обобщенные компоненты можно быстро размещать в проекте без необходимости искать и выбирать конкретный компонент производителя в доступных источниках компонентов. Обобщенные компоненты служат заполнителями, которые легко заменить подходящим компонентом на последующих этапах проектирования. Их также можно рассматривать как виртуальные или параметрические компоненты.

Подробнее о создании обобщенных компонентов см. на странице Создание обобщенных компонентов.

Когда Altium Designer подключен к рабочему пространству, доступные обобщенные компоненты отображаются в панели при выборе параметра All в области Categories или в верхнем раскрывающемся меню, если панель находится в компактном режиме. Нажмите кнопку на плитке обобщенного компонента, чтобы прикрепить компонент к курсору для размещения в активном документе схемы. После размещения компонента на схеме примитивы выводов, линий и границ его символа — фактически его контур — окрашиваются в красный цвет, указывая на использование обобщенного компонента. При выборе самой плитки в панели Components в ней открывается категория соответствующего типа компонентов.

Размещение обобщенного компонента из панели Components
Размещение обобщенного компонента из панели Components

Поскольку обобщенные компоненты не должны использоваться в окончательном проекте, их размещение на схеме вызывает нарушение ERC — Обобщенный компонент. Уровень этого нарушения — по умолчанию Fatal Error — задается в разделе Нарушения, связанные с компонентами в настройках отчетов об ошибках диалогового окна Project Options (Project » Project Options).

Выберите размещенный обобщенный компонент, чтобы открыть его свойства в панели свойств, где представлены только настройки и параметры, относящиеся к данному типу компонентов. Доступные параметры определяются соответствующим шаблоном компонента (Resistors в показанном здесь примере). Значения параметров можно вводить вручную или выбирать из раскрывающегося списка, содержащего значения из всех доступных компонентов данного типа.

Задание параметров обобщенного компонента — выбор значений параметров из раскрывающихся списков.

Задание параметров обобщенного компонента — результат.

 

Поддержка компонентов-перемычек

Перемычки, также называемые проволочными перемычками, позволяют заменять участки трассировки компонентом-перемычкой, что часто необходимо для успешного проектирования односторонней платы. Altium Designer поддерживает использование перемычек благодаря специальному типу компонента Jumper.

Хотя можно начать с размещения посадочных мест перемычек непосредственно на печатной плате, рекомендуемый рабочий процесс начинается со схемы. Подробнее см. на странице Работа с компонентами-перемычками.

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents