Altium Designer Documentation

Status message

Altium Designer 17.0版本现已翻译至中文 跳转至中文界面

Altium Designer 全新功能

Created: March 4, 2021 | Updated: October 9, 2021

Altium Designer 21改进

本页详细介绍了Altium Designer 21初始版本中包含的改进以及后续更新中添加的改进。 除了提供一系列改进措施以发展和完善现有技术外,每次更新还根据客户通过AltiumLive Community BugCrunch系统提出的反馈对软件进行了大量修复和增强,从而帮助设计人员继续创造前沿电子技术。

您可以选择继续使用当前版本,更新当前版本或同时安装旧版本与Altium Designer 21来访问最新功能。 您可以从软件中的扩展和更新中更新版本。 如果您希望将Altium Designer 21与当前版本一起安装,请访问Altium下载页面下载安装程序,然后在安装程序的安装模式页面上选择新建安装

免费试用!

如果您喜欢这项功能但还没成为我们的客户,欢迎试用Altium Designer。只需填写简单的表格,便可以免费试用Altium Designer 15天,完整软件全部开放。没错,您将能全面评估Altium Designer提供的体验,零技术限制,尽情使用世界上最好的PCB设计产品。单击下面的链接,填写表格,亲自了解为什么这么多工程师和设计师选择Altium而不是其他现有产品!

Altium Designer免费试用

Altium Designer 21.7

发布时间:2021年9月29日——版本21.7.1(build :23)

Altium Designer 21.7 发布说明

欢迎使用Altium Designer 21的Update 7。Altium Designer的本次更新继续改进和增强了软件的核心技术,同时解决了客户通过AltiumLive社区的BugCrunch系统提出的诸多问题和建议。

原理图输入在update7中的改进

在打开新版本保存的原理图时弹出警告

实现了“原理图已在新版本中完成”的警告,以通知用户在用于创建原理图的 Altium Designer版本和用于打开原理图文档的版本之间引入了新功能。此功能与PCB编辑器版本的警告相同。

快速打开最后一个活动工作表

此功能处于开放测试阶段,并且在“高级设置”对话框中的 UI.SmartDocumentSwitching选项启用时可用。

单击原理图文档选项卡的文本后,将显示最后一个活动原理图。当选项卡下拉列表中存在大量打开的原理图时,该功能十分有用。

交叉引用选项

交叉引用设置已从“首选项”对话框的“原理图 - 常规”页面移至“项目选项”对话框的“选项”选项卡,该选项卡上也包含可用于选择支持对象的其他选项。

可使用“图纸样式”和“位置样式”下拉列表来设置交叉引用选项。启用所需的受支持对象。

端口到端口交叉引用

在“高级设置”对话框中启用Schematic.EnhancedCrossReferences选项即可使用该功能。该功能处于开放测试阶段,默认值为0。

此外,也需要启用Schematic.UseAutomaticCrossReferences选项。

在项目中添加交叉引用后,您可以轻松地跟踪项目中不同原理图之间的网络连接关系。继Schematic.UseAutomaticCrossReferences选项最近引入交叉引用自动创建和更新支持后,该新增高级选项可支持分层项目中的交叉引用。

在“项目选项”对话框中启用“自动交叉引用”选项,然后右键单击上下文菜单跳转到层次结构中所选的任意目标位置。

Use the Jump to command to jump to a matching Port anywhere in the design hierarchy.使用“跳转到”命令跳转到设计层次结构中任意位置的匹配端口。

该功能支持下述三种模式,可通过设置高级选项的来启用。

  • 0 - 传统模式 - 使用该值启用以下关系:
    1. 端口 <-> 图纸入口
    2. 图纸外 <-> 图纸外
  •  1 - 增强模式 - 使用该值启用以下关系:
    1. 图纸外 <-> 图纸外
    2. 端口 <-> 端口
  • 2 - 增强 + 传统模式 - 使用该值启用以下关系:
    1. 图纸外 <-> 图纸外
    2. 端口 <-> 端口
    3. 端口 <-> 图纸外

     该模式也可启用“端口操作 >> 跳转到端口”。

在当前版本中,“端口到端口”和“端口到图纸入口”的交叉引用均包含为“跳转到”位置。在未来版本中,可配置该功能。

添加了对元件参数“显示更多”功能的用户控制

该功能由“高级设置”对话框中的 Schematic.UI.ShowMoreOrLessParameters选项控制。该功能处于开放测试阶段,默认值为“打开”,这意味着“属性”面板中可显示“显示更多”/“显示更少”的控件。该选项被禁用时,将始终显示所有参数。

显示更多”功能可减少列表上的参数,仅显示已设置的收藏参数,从而简化了元件参数的显示。但是,您也可以选择始终在“属性”面板的“元件”模式中显示所有参数。

The default behavior is to automatically hide parameters that are not marked as favorites. Hover the cursor over the image to demonstrate. 默认行为是自动隐藏未标记为收藏的参数。将光标悬停在图像上即可解除隐藏。

为支持这一功能,禁用新选项时,“显示更多”/“显示更少”功能将被禁用,从而导致所有元件参数始终显示在“属性”面板的“元件”模式中。

The Show More/Show Less feature is disabled when the advanced option is disabled. 当高级选项被禁用时,“显示更多”/“显示更少”功能将被禁用。

update 7中的 PCB设计升级

添加了Room的属性面板模式

现可在“属性”面板中配置和编辑Room的属性。您可以在新的模式下定义Room的名称、坐标和轮廓顶点。

The new Room mode of the Properties panel “属性”面板上的新增Room模式

为焊盘添加了Use Paste选项

该功能默认启用,可通过切换“高级设置”对话框中的 PCB.PasteMask.NoPaste选项来禁用。该功能处于开放测试阶段。

PasteMaskExpansion 设计规则、Properties 面板的 Pad 模式和 Pad Template Editor 中添加了 Use Paste 选项 ,从而无需使用合适的负值来删除Paste。清除该复选框以从目标/选定焊盘上移除Paste。

update7中的 数据管理

简化对内置版本存储的访问

Altium Designer现提供一项增强流程,可帮助您更轻松地将Altium 365中内置的基于Git的版本存储优势用于本地项目。该增强功能如下。

  • 利用以下“添加到版本控制”对话框连接到Altium 365工作区(若可用),并在未配置其他自定义存储库的情况下使当前项目在线可用。在当前未使用任何工作区时,右键单击“项目”面板上的项目名称,然后选择“历史和版本控制 » 将项目添加到版本控制”,即可访问当前版本的对话框。

  • 如果Altium 365工作区中的连接可用,您也可以从“项目”面板中的本地项目右击菜单访问“使项目在线可用”命令,然后在“在线可用”对话框中启用“版本控制”选项。

Update 7中的 电路仿真

参数扫描增强

添加了在“参数扫描”期间扫描两个以上参数的功能。 

添加了输出变量类别

在“添加输出表达式”对话框中添加了“波形”和“函数”下拉菜单,用于选择所需条目。

保存X、Y比例设置

针对打开和保存的.sdf文档,在仿真过程中保存绘图的X、Y比例设置。

新增直流和瞬态分析支持的变量

在直流和瞬态分析中支持以下变量:

  • 电容器电荷输出
  • 电流开关电导输出
  • 电压开关电导输出
  • 独立电流源模型电流输出
  • 功能电压和电流源的电源输出
  • 电容器电压输出
  • 电压开关电压输出
  • 独立电压源电压输出
  • 电流开关电压输出

Altium Designer 21.6

发布时间:2021年8月20日——版本21.6.4(内部版本81)
发布时间:2021年7月22日——版本21.6.1(内部版本37)

Altium Designer 21.6版发行说明

Update 6的亮点

Altium Designer 21.5

发布时间:2021年6月22日– 版本21.5.1 (内部版本 32)

Altium Designer 21.5版发行说明

Update 5的亮点

更新版本5的亮点

欢迎使用Altium Designer 21的Update 5。Altium Designer的本次更新继续改进和增强软件的核心技术,同时解决了客户通过 AltiumLive社区的BugCrunch系统提出的诸多想法。


Schematic Capture 原理图捕捉

Added Toggle Actions in ECO 在ECO中添加了切换操作

添加了使用空格键在“工程变更单”对话框中关闭和打开操作的功能。


PCB Design PCB设计

允许从“选定封装”中“显示元件”

在“元件操作”子菜单的右键单击菜单中添加了“在<服务器>中显示<元件>”命令,该命令可用于打开“资源管理器”面板并选择指定元件。该命令仅适用于作为受管项目一部分的PCB文档。

添加了“PCB输出文件搁置多边形检查”

添加了在生成某些输出之前提醒用户存在搁置多边形的对话框。输出内容包括Gerber、Gerber X2、ODB++、PCB Print和IPC2581。单击“生成输出”可继续输出或“取消”来终止输出生成。如果终止输出生成,则系统将重新对多边形铺铜,然后重新生成输出。

基元放置时的旋转

在PCB或PCBLIB文档上放置基元时,现在的旋转默认值为“0”;可根据需要在放置基元期间更改旋转值。


数据管理

新的“BOM比较”报告

为包含BOM文档(*.BomDoc)的托管项目添加了“BOM比较”报告。不同设计版本之间常常存在元件变更。“BOM比较”报告显示了当前设计和选定的已发布版本之间的变化。

可通过以下方式配置和生成“BOM比较”报告:

  • 在ActiveBOM BomDoc中单击“报告»BOM比较”即可打开“报告管理器”对话框的“BOM比较”版本。可根据需要配置报告,然后单击“导出”。
  • 在原理图编辑器中单击“报告»BOM比较”即可打开“报告管理器”对话框的“BOM比较”版本。可根据需要配置报告,然后单击“导出”。
  • 在PCB编辑器中单击“报告»项目报告»BOM比较”即可打开“报告管理器”对话框的“BOM比较”版本。可根据需要配置报告,然后单击“导出”。
  • 在输出作业中右键单击“报告输出”条目下的[添加新报告输出],然后选择“BOM比较”。配置报告时右键单击新添加的“BOM比较”条目,然后选择“配置”,打开“报告管理器”对话框的“Bom比较”版本。可根据需要配置报告,然后单击“导出”。用户也可以选择所需的输出容器,然后生成报告。

单击此处了解“报告管理器”对话框(如下所示)的“BOM比较”版本中的选项和控件。

下图是作为PDF输出作业生成的“BOM比较”报告的示例。

改进了“项目文档删除”功能

添加了用于选择如何删除文档的决策对话框。用户可以选择永久删除文档或仅从项目中排除文档而非将其完全删除。从所选文档的右键单击菜单中选择“从项目中删除”命令,即可打开对话框。


电路仿真

在“添加波形图”对话框中新增了数学函数

在“添加波形图”对话框的现有列表中添加了新的数学函数。当*.sdf文件是活动文档时,从主菜单中选择“波形»添加波形”即可访问该对话框。

仿真模型对话框中的默认值

 现“仿真模型”对话框中的仿真模型参数为默认值。默认参数值显示为灰色文本;自定义值为白色文本。如果删除自定义值,则恢复默认值。不可设置为空值。

Altium Designer 21.4

发布时间:2021年5月25日 - 版本21.4(内部版本30)

Altium Designer21.5版本发行说明 

更新版本5的亮点

更新版本4的亮点

欢迎使用Altium Designer 21的Update 4。Altium Designer的本次更新继续改进和增强软件的核心技术,同时解决了客户通过 AltiumLive社区的BugCrunch系统提出的诸多想法。


PCB设计

交互式布线

元件和布线同时移动

移动已布线元件时,PCB编辑器有助于管理布线。在“首选项”对话框的PCB编辑器 -“交互式布线”页面上,元件重新布线选项将指示布线引擎在元件断开时尝试对受移动影响的连接重新布线,“移动元件和相关布线”选项将指示布线引擎同时移动相关布线与移动元件。相关布线包括过孔扇出、逃逸布线和元件引脚之间的互连。可使用“Shift+Tab”在移动元件时实施选项开关操作。

如果元件有大量引脚附有相关布线,则处理器可能需要承担高强度任务。为了管理这一操作,添加了最大值选项。在布线引擎不再随元件移动相关布线之前,可使用该选项定义移动元件的最大引脚数。

“任意角度”优化的SMD规则

添加了在“任意角度”优化时的SMD规则(“SMD进入”“SMD布线角”)观察功能。如果此类设计规则存在,则布线现以正交方式退出焊盘并且不会发生一定距离的偏转,从而使走线在接近相邻焊盘之前脱离阻焊层开口。这样可以避免邻近金属暴露问题和焊料桥接风险。

关闭动画功能

在“首选项”对话框的PCB编辑器 -“显示”页面上添加了“使用动画”选项,用于在缩放、翻转电路板和切换图层时打开/关闭动画。

恢复了改变覆盖层颜色的功能

在“视图配置”面板中恢复了改变覆盖层颜色的功能。

增强了“嵌入式板阵列”属性

在“属性”面板中为“嵌入式电路板阵列”对象添加了新控件,以帮助用户更好地定义电路板阵列。从“常规”选项卡上的“附加选项”区可启用/禁用钻孔表、层堆栈表或尺寸。从新的“参数”“层”选项卡上可选择待传输的参数和/或层。在“层”选项卡上配置的设置将体现在输出中,例如,PCB打印输出。

PCB后期处理

为了改进PCB编辑器的响应能力,引入了以下后期处理行为:

  • 如果PCB元件的基元属性经过编辑后未使信号层上的基元发生变更,则设计规则电气检查将不会被触发。
  • 如果PCB元件的基元属性经过编辑后未使信号层上的基元发生变更,则不会触发设计规则多边形铺铜检查。
  • 如果PCB元件的基元属性经过编辑后未使信号层上的基元发生变更,则不会触发设计规则网络分析检查。

可使用“高级设置”对话框中的PCB.Optimization.CommitChanges选项来启用/禁用该功能。


数据管理

迁移Git/SVN存储库

Altium Designer现能够将使用外部VCS系统的项目迁移至完全受管的Altium服务器项目,该项目将设计文件托管在服务器自有Git存储库中。然后,完全托管的项目可受益于服务器的本机VCS功能,例如,基于事件的历史时间线“使项目在线可用”对话框现提供“迁移至<服务器>版本化存储”选项,该选项支持VCS迁移过程,而非简单地在服务器中映射项目结构。

如果外部VCS项目已成为Altium服务器中的受管映射项目(本地服务器同步文件),则可以使用“项目历史”视图、 “项目选项”对话框“项目”面板上“版本控制”右击上下文菜单中的“迁移至版本化存储”命令,将其VCS文件迁移至服务器自有Git存储库。

向元件面板添加了“更改状态”命令

添加了在“元件”面板中更改元件修订状态的功能。右键单击一个或多个元件,然后从上下文菜单中选择“操作»更改状态”,即可访问该命令。可打开“批处理”状态更改对话框,更改元件的修订状态。

增强了“保存到服务器”功能

保存文档

更新后,如果用户尚未保存文档(PCB、SCH、元件等),则系统将显示以下对话框。启用“保存到服务器”选项,然后单击“保存”,即可将更改保存到服务器以及本地。

如果用户更改了文档并将更改保存在本地,则系统将显示以下对话框,提醒用户同时将更改保存到服务器(必要时)。如果用户不想将更改保存到服务器,则单击“不操作”

增强了“确认保存对话框”功能

增强了“确认保存变更文档”对话框的功能,用户可在关闭Altium Designer时选择是否要将未保存的修改文档保存到服务器。使用下拉菜单选择要保存的特定文档,或单击“全部保存到服务器”,即可将所有列出的文档保存到服务器。

如果变更内容也涉及本地文档,则“确认保存变更文档”对话框将列出该等文档,如下所示。


Draftsman文档

在电路板视图中添加了“不显示BOM”选项

添加了“不显示BOM”选项,启用该选项后,即使零部件不在BOM中,电路板视图中亦会显示该零部件。

在“电路板制造”视图中添加了“覆盖颜色”选项

“电路板制造”视图添加了“覆盖颜色”选项,用于为所有层设置默认颜色。

增强了“元件显示属性”

“元件显示属性”对话框(单击“属性”面板上“电路板装配视图”模式中的“元件”按钮即可访问)的下拉列表中添加了评论设计条目ID参数。


导入器/导出器

添加了“Allegro封装文件导入”功能

为简化导入过程,添加了使用“导入向导”导入Allegro封装文件 (*.dra) 的功能。

引入了“Ansys EDB导出选项”对话框

添加了“Ansys EDB导出选项”对话框,用于配置ANSYS导出。单击“文件»导出»Ansys EDB”,然后在打开的Windows对话框中选择所需的文件夹,即可访问该对话框。

访问ANSYS导出器时,必须从“扩展和更新”页面安装“Ansys EDB 导出器”扩展插件。


电路仿真

在“仿真模型”对话框中添加了默认仿真模型列表

在“仿真模型”对话框中添加了一组默认仿真模型,用于从列表中快速选择默认值。从“模型类型”下拉列表中选择所需的模型。


Altium Designer 21.3

发布:2021年4月7日——版本21.3.0(build版本号18)

Altium Designer 21.3 Beta版发布说明

更新3亮点

欢迎使用Altium Designer 21的Update 3版。Altium Designer的本次更新将继续改进和增强软件的核心技术,同时解决客户通过AltiumLive Community BugCrunch系统提出的许多想法。

PCB设计

交互式布线

拖动时自动添加斜接功能

斜接是指在布线过程中为防止形成90度角而自动添加的短对角线段。斜接的大小由当前斜接比确定。默认功能是拖动走线段时,任何附加的斜接也会被拖动。

在此发布版本中,您可以通过“属性”面板上“交互式滑动”模式下的“添加斜接”选项在拖动过程中选择添加或不添加斜接。拖动时按快捷键C可选择在拖动时不添加斜接。再次按C即可重新启用拖动时添加斜接功能。

锯齿调整模式的交互式重新定义

锯齿调整模式现支持使用快捷键,可在位移过程中以交互方式降低/增加调整模式的高度。

刚柔结合板2

锁定3D板区域

为了简化对刚柔结合板PCB折叠过程的控制,已将“3D锁定”复选框添加到“属性”面板的“板区域”模式中。只允许锁定一个“板区域”;在“3D视图”模式下执行板折叠操作时,该区域将成为静止区域。

锁定在刚柔结合板折叠时保持静止的板区域。锁定在刚柔结合板折叠时保持静止的板区域。

在“高级设置”对话框中启用以下选项即可切换到“刚柔结合板2”模式:

  • RigidFlex2.0——在“板规划模式”下启用“刚柔结合板2”功能。请注意:在Altium Designer的早期发布版本中,该选项名为“Legacy.PCB.RigidFlex”。更名后,功能也随之变化;启用旧选项后将恢复旧模式(“刚柔结合板1.0”),启用新选项将启用新模式(“刚柔结合板2.0”)。
  • PCB.RigidFlex.SubstackPlanning——在“层堆栈管理器”中启用板视图

► 了解有关“刚柔结合板设计”的更多信息

添加了“多选拖动选项”

在“高级设置”对话框中添加了“PCB.Rendering.MultiselectionDrag”选项,让您在拖动多个选定对象时控制所显示的基元数量。


数据管理

增强注释功能

本次更新增强了注释功能,允许导出注释,并添加了用于配置导出注释的新对话框。下文将介绍这些新功能。

注释导出

添加了将注释导出到单独文档的功能。该功能可以生成完整的设计审查记录,因此您无需再保留单独的文档或执行重复的工作。

可通过以下方式访问该功能:

  • 从输出作业文档中右键单击[添加新报告输出],然后单击“导出注释”。然后,您可以从要导出的文档列表中选择。
  • 从原理图或PCB文档中单击“报告»项目报告»导出注释”。打开“导出注释属性”对话框,即可在该对话框中配置导出。

添加新的“导出注释”报告输出后,右键单击选择“页面设置”打开“导出注释属性”对话框,即可在该对话框中配置导出。

新的“注释导出配置”对话框

引入新的“注释导出配置”对话框后,可在该对话框中设置注释导出的时间,并在导出注释时根据需要添加屏幕截图。右键单击输出作业文档中“报告输出”项下的“导出注释”即可访问该对话框,然后从该对话框上下文菜单中选择“配置”。单击“导出”即可导出注释,然后在关联的文件类型应用程序中打开注释。

“制造商部件搜索”面板的提速

改进了“制造商部件搜索”面板中的搜索时间,在选择类别或在类别内执行搜索时可提供更快的结果。

必要时可在“高级设置”对话框中启用“ComponentPartSearch.PerformanceMetrics”选项,从而在“制造商部件搜索”面板的底部显示搜索时间。


ECAD/MCAD改进内容

适用栅格的显示

将元件放置在不同栅格上的操作很常见。可为圆形板定义径向栅格,可为特定的板区域自定义元件栅格,或由机械工程师定义机械栅格并使用Altium ECAD-MCAD协作解决方案CoDesigner将其推送至PCB编辑器。

选择元件后,自定义栅格的详细位置信息(例如,用户定义或MCAD定义的元件栅格)将添加进“属性”面板的“位置”区域。自定义栅格可使用与“全局板捕捉栅格”不同的单位,但其将始终以当前PCB编辑器中选择的单位显示。

自定义栅格将在“属性”面板(未选择任何内容时自动显示)的“”模式下定义和编辑。


Draftsman文档

板视图的“显示孔选项”

在“属性”面板的“Board Isometric View”模式中添加“显示孔”选项,用于选择是否显示孔。使用下拉菜单选择所需的显示选项:“不显示”、“全部显示”或“仅显示焊盘”。


电路仿真

添加了“瞬态分析的间隔和周期”字段

添加了在“仿真仪表盘”面板中配置“瞬态分析的间隔和周期”功能。该新字段可用于设置时间间隔、时间数量以及时间点数量。

添加了交流分析的默认值

交流分析的默认值现可已添加入“高级分析设置”对话框中(可通过单击“仿真仪表盘”面板中的“设置”访问)。

添加了对“temper”变量和“idtmod”功能的支持

LTSPICE模型的数学表达式现可支持“temper”变量和“idtmod”函数。

添加了蒙特卡洛组公差设置

蒙特卡洛分析中的组公差设置已添加至“高级分析设置”对话框,可实现更精确的仿真定义。

添加了“RNODETOGND”高级参数

在“高级分析设置”对话框中添加了默认值为“1e12”的“RNODETOGND”高级参数。该参数可用于处理接地直流路径。

Altium Designer 21.2

Released: 19 March 2021– Version 21.2.2 (build 38) - Hot Fix 2
Released: 11 March 2021– Version 21.2.1 (build 34) - Hot Fix

发布日期:2021年3月4日——21.2.0版(build 30)

Altium Designer 21.2版发布说明

欢迎使用Altium Designer 21.2。此Altium Designer更新版本不仅继续改进和增强了软件的核心技术性能,而且还解决了客户通过AltiumLive Community的BugCrunch系统提出的许多问题。


PCB设计

布线改进

在此次更新版本中,Altium专门的布线技术团队继续对交互式布线和拖动功能做出了改进。

差分对布线中的圆弧

改进了对带弧形转角差分对的处理。改进后,转角弧形变成同心弧(共用相同的中心点),从而确保同一差分对内的间距在转角处保持不变。

圆形焊盘进入布线更加干净利落

增强了圆形焊盘进入算法,以便在拖动过程中趋向于以正交或对角线的方式对齐入线,从而减少在拖动过程中,布线在焊盘内增加小的点动或凸点的趋势。

将光标悬停在图像上,以显示上一个的行为。将光标悬停在图像上,以显示上一个的行为。

连同布线移动元器件

使用Ctrl+箭头键快捷键是将所选元器件按1个网格步长进行推挤的普遍做法(按住Shift键可推挤10个网格步长)。现在,您也可以使用这项技术进行元器件重新布线(“首选项”对话框的“交互式布线”页面)——推挤元器件后,布线随之更新。

Rigid-Flex 2

刚柔结合技术目前正在开发中;近期在这方面做出的一些改进包括:在PCB编辑器的“板规划模式”下工作时,新增“板区域”和“弯折线”功能,以及在“层堆栈管理器”中引入了“板”模式。此项新功能集被称为Rigid-Flex 2.0。

在“高级设置”对话框中配置下述选项,以在Rigid-Flex 1.0和Rigid-Flex 2.0之间进行切换:

  • Rigid-Flex 1.0——启用Legacy.PCB.RigidFlex,禁用PCB.RigidFlex.SubstackPlanning
  • Rigid-Flex 2.0——禁用Legacy.PCB.RigidFlex,启用PCB.RigidFlex.SubstackPlanning

在“层堆栈管理器”的“板”模式下调整层厚度的功能

在“层堆栈管理器”的“”模式下,按照能够大致代表每层加工厚度的方式绘制电路板层(使用Ctrl+滚动鼠标的快捷方式缩放此视图)。为了便于处理较厚的高层数电路板,我们添加了“真实比率”选项。禁用此选项后,每一层将继续按照与其在总厚度中的占比成比例的折合厚度显示。

每一层的厚度将按照能够代表其真实厚度的方式绘制。开启/关闭“真实比率”选项时,悬停光标以显示差异。每一层的厚度将按照能够代表其真实厚度的方式绘制。开启/关闭“真实比率”选项时,悬停光标以显示差异。

矩形对象改进

添加了锁定宽高比的功能

添加了锁定矩形对象的宽度和高度的功能。在更改矩形宽高比时,在“属性”面板的“矩形”模式下切换链接图标,可以锁定/解锁宽高比。图标将更改以指示当前的锁定/解锁状态。

矩形宽高比锁定后,将光标悬停在图像上,显示未锁定的图标。 矩形宽高比锁定后,将光标悬停在图像上,显示未锁定的图标。

添加了矩形转换功能

在“工具”»“转换”子菜单中添加了“将矩形分离为自由基元”命令,该命令使您可以将矩形对象转换回其原始基元对象集。


数据管理

New Save to Server Dialog and Projects Panel Command

When a document that belongs to a project on a server has been modified and saved locally, the Projects panel entry displays a Save to Server link, which alerts you to also save the modifications to the server. Clicking the link opens the Save to Server dialog in which you can select the documents to be saved. After clicking OK, the documents are saved to the server and the Save to Server link disappears from the Projects panel.

添加了“从项目中排除”命令

恢复了之前已删除的“从项目中删除”命令,并将其重命名为“从项目中排除”,以更直白地体现该命令的功能。该命令位于“项目”面板的右键菜单中(针对受版本控制的项目)。

增强了项目的“删除”命令

现在,“项目”面板右键单击“删除”命令可以用于所有类型的项目,即不再只适用于受版本控制的项目。

添加了新的重复元器件违规类型

为了防止在“单元件编辑器”中创建重复元件,我们在“首选项”对话框的“数据管理—元器件规则检查”页面上添加了按“名称”重复的元器件按PCL重复的元器件这两种违规类型。两种违规的“报告模式”默认情况为“无报告”。

更改这些违规类型的“报告模式”将影响元器件的发布性能,因为为了搜索重复项,必须对服务器进行额外的查询。


导入器/导出器

增强导入Hyperlynx文件功能

增强了Hyperlynx (*.HYP)导出器,以纳入元器件值(元器件的“”参数)和零部件编号(元器件的“注释”属性)。在之前的版本中,导出的文件仅包含层和位号标识符信息。这一信息简化了在Hyperlynx中分配元器件模型的过程。


电路仿真

添加了对基于SPICE模型放置符号的支持

添加了为SPICE元器件生成使用.MODEL命令描述的特殊符号的功能。请注意,在下图中,示例文件models3.mdl是活动库。在列表中选中支持模型种类后,软件会从“仿真通用元器件”库中自动选择一个合适的元器件符号。这使您可以将所选模型作为符号直接放置在原理图上。

下表列出了支持模型种类以及放置符号的库元器件。

元器件 示例文本 符号
(SIM库设计条目ID)
电阻器 .MODEL <示例名称> RES 电阻器
电容器 .MODEL <示例名称> CAP 电容器
电感器 .MODEL <示例名称> IND 电感器
二极管 .MODEL <示例名称> D 二极管
双极型晶体管 .MODEL <示例名称> NPN BJT NPN 4 MGP
双极型晶体管 .MODEL <示例名称> PNP BJT PNP 4 MGP
结型场效应管 .MODEL <示例名称> NJF JFET N-ch Level2
结型场效应管 .MODEL <示例名称> PJF JFET P-ch Level2
MOSFET .MODEL <示例名称> NMOS MOSFET N-ch Level1
MOSFET .MODEL <示例名称> PMOS MOSFET P-ch Level1

添加了*.CIR文件支持

添加了对*.cir文件(作为SPICE库文件)的支持。

交流、直流和瞬态分析默认值

当前版本支持交流、直流和瞬态分析输入数据字段默认值。

 


Altium Designer 21.1

已发布:2021年2月12日——版本21.1.1(build 26)

Altium Designer版本21.1发布说明

 

更新1的亮点

欢迎使用Altium Designer 21更新1。Altium Designer的本次更新继续改进和增强了软件的核心技术,同时还回应了客户通过AltiumLive Community BugCrunch系统提出的许多想法。


原理图输入

通用元件的简易替换

“通用元件”是可以快速置于设计中的基本元件,无需从可用元件源中查找和选择特定的制造商部件。“通用元件”用作占位符时,可以在后续设计过程中轻松地由合适的元件替换。它们也可以被视为虚拟元件或参数元件。

“属性”面板“通用元件”模式下的“设计项目ID”字段已更改为“替换”按钮。“替换”按钮的功能与之前的“设计项目ID”字段相同,且经过更改其功能更明确。单击“替换”即可打开“替换通用元件”对话框和选择所需元件。选择并单击替换通用元件对话框中的“确定”后,原理图上的通用元件将被替换为所选元件。

只读注释字段也已添加到“属性”面板的“通用元件”模式中。该字段默认显示ComponentType值,也可附加上其他经定义的参数值。

配置“通用元件”的封装

通用元件可以用作占位符元件,并且可以在设计过程中定义属性。为了顺利完成这一过程,现可以访问已连接工作区中所有可用封装的列表。

可用的封装列表包括:

  • 当前已连接的工作区中的封装
  • 具有相同ComponentType的其他元件使用的封装

其他通用元件接口更新包括:

  • 现单击“元件”面板中的“通用元件”展开图即可打开该类型的所有可用元件的列表。
  • 单击“元件”面板上“通用元件”展开图中的按钮,即可调用放置模式——将鼠标悬停在展开图上方即可显示该按钮。

►了解有关“通用元件”的更多信息。

使用原理图模板

When selecting a local schematic sheet template (Design » Sheet Templates » Local), the Choose another file option has been renamed Load From File in order to clarify the function of the command. 选择本地原理图模板(设计»图模板»本地)时,为明确命令功能,“选择另一个文件”选项已重命名为“从文件中加载”。

交叉引用参数可见性

可见性图标()已添加到“端口”和Offsheet Connector对象的CrossRef参数中。可根据需要为每个对象启用/禁用“属性”面板中的图标。下图显示了为原理图上所选端口的CrossRef参数启用的可见性图标。


PCB设计

具有增强层堆栈管理功能的Rigid-Flex 2.0

Rigid-Flex 2.0支持当前所有类型的刚柔结合板PCB设计。第一步是在对象级别上对最近发布的电路板区域和弯折线作出了改进。本次更新在“层堆栈管理器”中增加了板视图模式,这大大简化了刚柔结合板设计中所需的各个子堆栈的定义和组织。

Rigid-Flex 2.0的主要改进包括:

  • “层堆栈管理器”中新的板视图模式提供了各个子堆栈组织的Z平面视图(在“层堆栈管理器”中启用刚柔结合板模式后即可使用该视图)
  • 定义重叠的柔性板区域(通常称为“装订商刚柔结合板”)
  • 覆盖刚性区域的柔性板截面的定义
  • 使用Shift + Click快捷键可选择子堆栈中的特定层
  • 拖放,然后右键单击“插入/复制/粘贴”命令,即可从选定的层/子堆栈中创建新的子堆栈
  • 定义任何子堆栈中柔性到刚性的侵入距离(将“材料用法”设置为“单个”)

“层堆栈管理器”中新的板视图提供了对整个板结构的出色的Z平面视图。由于许多刚柔结合板设计在电路板的不同区域使用的是相同的子堆栈配置,因此加入了可将现有子堆栈快速复制到新位置的命令。选择一个子堆栈,然后单击鼠标右键在任何现有子堆栈之前或之后插入该子堆栈的副本,或将该子堆栈复制并粘贴到新位置(显示“插入所选层”对话框)。

除了选择子堆栈外,您还可以选择子堆栈中的特定层并将其复制/粘贴到新位置。单击层时按住Shift键选择单个层。继续按住Shift键并单击其他层以建立所选层的集合。或者,在所需的第一层上按住Shift键并单击,然后直接移至最后一层,再按住Shift键并单击选中最后一层,即可选中介于两者之间的所有层。

然后,您可以在板视图中水平拖放选定的层集合,并创建新的子堆栈,或右键单击并使用上下文菜单中的命令(如以下视频所示)。

公测版本中提供板视图功能。在“高级设置”对话框中启用“PCB:RigidFlex.SubstackPlanning”选项即可访问该功能。

新的3D视图模式命令

为了完成一组可用的预定义3D视图,已将“翻转等距线视图”添加到3D视图模式下的视图选择中。使用“视图»3D视图控件»翻转等距线视图”菜单命令或Ctrl + Num0快捷键即可打开该视图。


数据管理与设计协作

协作者通知改进

已更新“协作栏”和用户通知,对正在编辑的文档应用“软锁”时,可为同一项目的设计人员提供其他状态信息。软锁与第一个修改文档的设计人员相关联,并且可以被其他设计人员覆盖。当前的协作状态在“项目”面板和“协作栏”中指示,“协作栏”现通过单独的查看和编辑组显示正在协作的用户。

用户界面更新还包括关键协作事件发生时(例如,当您尝试对另一个用户正在编辑(处于修改状态)的文档进行本地更改时)弹出的信息和操作对话框。这种情况可能会导致发生版本冲突,因此该对话框提供恢复本地更改或忽略(覆盖)远程软锁的选择。本对话框替换了先前的“编辑文档”对话框。

两位设计人员在同一文档上工作时的视图。两位设计人员在同一文档上工作时的视图。

►更多相关信息见“协作者可视化和冲突预防”。

请注意:取消选中“项目选项”对话框“项目”»“项目选项”)中“常规”选项卡下的“启用冲突预防通知”选项,即可禁用协作通知。

比较两个发行版之间的“Gerber文件”

许多设计人员采用的常见发布测试做法是将当前发布版本生成的Gerber文件与先前版本的进行比较。一旦项目做好发布准备,即可在“项目发布器”中进行该测试。上述比较在Altium 365中进行。您的默认Web浏览器将打开“公司工作区”并显示结果。

►了解有关Gerber比较功能的更多信息。

模板的使用

在“首选项”对话框的“数据管理-模板”页面上将模板设置为默认模板后,为了与系统默认值区分开,将分别显示“我的默认值”与“默认值”。

现可以访问和选择多板原理图文档的本地和服务器模板。


电路仿真

元件和模型

为简化仿真源和通用元件的使用,已将本地和通用仿真库的浏览合并。“通用”按钮已从“仿真模型”对话框的“源”选择选项中删除,因此该更改体现在用户界面上。选择“本地”选项后,即可访问这两种本地库类型。

分析

现在,更多的电路对象可用作直流分析的扫描变量。电阻器等对象已被加入下拉变量列表中,可供选择,但该列表中不包括电容器和电感器。

仿真引擎现支持用于“瞬态分析”的sdt、ddt和LTspice延迟功能。

绘图和结果

现可以重命名“仿真仪表盘”面板中收集的“仿真”结果项,并添加描述。

图号字段已添加到“添加输出表达式”对话框中,可从该对话框中选择显示仿真数据的图。

►了解有关混合信号电路仿真仿真用户界面更新的更多信息


Altium Designer 21.0

发布时间和版本:2021年1月11日——21.0.9版(build235) 更新1
发布时间和版本:2020年12月17日——21.0.8版 (build223)

Altium Designer 21.0发布说明

增强版文档注释功能

结合Altium 365工作区中的“注释”功能的最新更新,当连接到Altium服务器时,Altium Designer现在提供了一组并行的修订和增强的“注释”功能。

 

设计空间中的“注释”功能在图形、可用性和相关信息方面已明显改善,并且仍与先前放置的注释内容向后兼容。现可直接从“注释”面板中置入注释,包括屏幕截图预览、手绘图、团队成员的提及/分配以及灵活的可见性和过滤选项。

 

阅读全文……

原理图编辑器生产率改进

新增工具和改进后的工具简化了在原理图项目中分析互连性的任务。将鼠标悬停在网络上以检查逻辑(原理图)和物理(PCB)网络名; “Alt +单击”网络以突出显示整个项目中的网络;“Alt + 双击”网络以显示网络所在的所有图表的树,然后单击确认其中一张图表上的网络。

  • 简化后的网络分析和改进后的网络详细信息。
  • “项目”面板上的自动图表编号。
  • 跨页连接符的页面参考。

阅读全文……

设计协作者的可视化和冲突预防

为了满足Altium设计编辑环境中实时文档共享状态和控制的需求,通过对Altium设计和服务器平台进行一系列更新而引入一种新系统,在实现可视化的同时对共享设计文档的当前状态做出反应。

 

该系统允许您实时查看当前正在查看或编辑共享文档的人员,并且文档共享数据可通过Altium工作区(所需的)在设计客户端之间自由流动,从而启用该系统。协作者的可视化通过一系列新的状态图标、协作者栏和其他文件锁定逻辑来实现。

 

阅读全文……

通用元器件

此版本引入了标准通用元器件的概念,该元器件可快速放置于设计中,而无需查找和选择特定的制造商零部件。

 

通用元器件旨在用作占位符,在设计过程的后期可轻易被与参数匹配的实际元器件替换。

 

阅读全文……

SPICE仿真用户界面更新

继最近引入在速度、解决方案收敛性、准确性和可靠性均有改进的Altium Designer新版高级SPICE仿真引擎后,新版本的重点是改进软件混合信号SPICE仿真工作流程的用户界面。

 

仿真界面更新包括新的直观的Simulation Dashboard面板、修正后的Sim Model对话框和通用界面更新。新的(基于Simulation Dashboard)仿真工作流程可替代基于Analyzes Setup对话框的现有方法。更新内容还包括全套即用型模拟通用元器件。

 

阅读全文……

新的设计规则编辑器

新的设计规则编辑器提供了另一种查看、创建和管理用于PCB layouts的设计约束规则的方法。重新设计后的“规则编辑器”作为基于文档的用户界面与现有的“规则和约束编辑器”共存,但是对PCB设计规则和约束采用面向设计的方法而非面向规则的方法。

 

可从现有的“规则和约束编辑器”访问新的“规则编辑器”。新的“规则编辑器”采用一种简化且更直观的方法来创建设计规则,避免了基于查询的规则范围设定,同时按对象类型整合多个规则,可自动推导和应用规则优先级以及……

 

阅读全文……

新的PCB长度调整模式

此版本通过引入新的Trombone(长号)和Sawtooth(锯齿)调整模式,对PCB编辑器的长度调整技术进行了广泛改进。这些新的调整模式呈现在调整套管中,从而可以轻松地沿着布线和拐角滑动相关模式。

 

阅读全文……

改进后的交互拖拽

对编辑中的网络和任何相邻网络均引入“光滑度”控件,从而改进“过孔”拖拽行为。同时也改进了差分对的拖拽——无论拖拽方向如何,差分对现在均保持耦合状态,并且在拖拽过程中过孔对也保持耦合状态。

 

阅读全文……

刚柔结合板设计改进

新版本包括对Altium Designer中刚柔结合板的设计过程作出的重大改进。除了大量的错误修复和增强功能之外,Altium下一阶段的刚柔结合板技术开发(即Rigid-Flex 2.0)将在以下方面作出功能性改进:

  • 可在“板规划模式”中对各个“区”进行交互式定义,从而构建“板形”。阅读全文…
  • “弯折线”的定义简化。阅读全文…
  • 在“属性”面板中改进了对“区”和“弯折线”的编辑。
  • 即将推出——在“层堆栈管理器”实现逼真的堆栈可视化。

其他增强功能和改进之处

除了上述主要更新之外,此版本的重点是完善和改进现有功能集。根据论坛反馈和Altium的BugCrunch系统,此版本还新增许多其他增强功能。其中的一些改进包括:

  • 现在,可使用新的“引脚”面板在“单元器件编辑器”中使用“从元器件引脚到多个焊盘映射”功能。
  • 现可给备用原理图元器件符号赋予用户定义的名称。
  • “PCB元器件间距”设计规则新增选项——现可避免检查不含3D实体的元器件,同时可选择使用元器件边界检查间距。
  • 内层电源平面现可使用与信号层上的多边形相同的铺铜算法,从而改进形状定义和焊盘/过孔连接。
  • 嵌入式板阵列现可支持任意角度的阵列布局。
  • 新PCB层厚特殊字串。
  • “快速布线”和“快速差分布线”工具可提高交互式路由的响应速度。
  • 更新“ODBᐩᐩ设置对话框”——可更好地控制机械层数据合并至输出。
  • 已将新的矩形对象添加到“PCB编辑器”的“放置”菜单中。
  • 通过新的“放置 » 图形”命令简化PCB的图形放置过程。
  • 为“3D视图移动和旋转”动作提供数字键盘支持。
  • 现在机械层可以包含到3D中——这是对3D图像标注的理想选择。
  • 新的“导出”命令可将3D PCB作为图像输出——用户可控制格式和图像分辨率。

阅读全文……


 

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

联系我们

联系原厂或当地办公室

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: