ActiveRoute
Auf einen Blick
- Verstehen Sie, wie sich ActiveRoute von einem Autorouter unterscheidet und warum es sich besser für das gezielte, hochwertige Routing ausgewählter Netze eignet.
- Lernen Sie die wichtigsten Funktionen von ActiveRoute kennen, darunter Routing-Leitpfade, Routing über mehrere Lagen, Glättung, Längenabgleich, Mäandersteuerung und Pin-Tausch.
- Erfahren Sie, wie Sie ActiveRoute im Panel „PCB ActiveRoute“ anhand Ihrer Designregeln und Routing-Ziele konfigurieren und ausführen.
Eine der zeitaufwendigsten Phasen beim Leiterplattendesign ist das Routen der Netze. Während das Regelsystem die Designvorgaben wie Leiterbahnbreiten, Via-Größen, Abstände usw. berücksichtigt, muss der Entwickler die vielen Tausend Leiterbahnsegmente platzieren, die für das vollständige Routen einer Leiterplatte erforderlich sind.
Autorouter können diesen Aufwand verringern, gelten jedoch im Allgemeinen als unzureichend, weil:
-
Sie die unzähligen feinen Designvorgaben nicht angemessen berücksichtigen, die ein Entwickler beim Routen intuitiv anwendet.
-
Ihre vollständige Konfiguration so viel Zeit in Anspruch nimmt, dass es oft effizienter ist, die Leiterplatte direkt interaktiv zu routen.
-
Die Nachbearbeitung so langwierig und schwierig sein kann, dass es oft effizienter ist, die Leiterplatte interaktiv zu routen.
Der heilige Gral des Leiterplatten-Routings besteht darin, unter der Kontrolle des Entwicklers schnell hochwertige Ergebnisse zu erzielen, die den Designregeln entsprechen. Genau dieser Herausforderung stellt sich ActiveRoute.
Was ist ActiveRoute?
ActiveRoute ist eine automatisierte interaktive Routing-Technologie mit effizienten Algorithmen zum Routen mehrerer Netze, die auf die von Ihnen ausgewählten Netze oder Verbindungen angewendet wird. Mit ActiveRoute kann der Entwickler außerdem interaktiv einen Routing-Pfad oder eine Führung definieren, die dann the river festlegt, entlang dessen die neuen Leiterbahnen verlaufen.
Zu den wichtigsten Funktionen von ActiveRoute, die diesen Ansatz deutlich besser machen als eine Kombination aus herkömmlichem interaktivem Routing und Autorouting, gehören:
- Automatische Optimierung der Entflechtung aus Pin-/Via-Anordnungen – dem zeitaufwendigsten Aspekt des manuellen Routings.
- Hohe Leistung – Signalnetze werden jeweils in < 1 Sekunde geroutet.
- Berücksichtigt unter Beachtung der Prioritäten die Designregeln für Breite, Abstand, Lagen, Topologie und Rooms je nach Netz und Netzklasse.
- Routet gleichzeitig auf mehreren Lagen und verteilt die Leiterbahnen auf diese Lagen.
- Eine intuitive Routing-Führung (Route Guide), mit der der Entwickler die Platzierung der Leiterbahnen steuern kann.
- Verwendet einen River-Routing-Ansatz, um ohne Vias einen hohen Fertigstellungsgrad zu erreichen.
- Kann durch Polygonflächen routen und diese neu füllen, sofern die Option zum erneuten Füllen aktiviert ist.
- Unterstützt sowohl Single-Ended-Netze als auch differenzielle Netzpaare.
- Schließt mit einem leistungsstarken Glossing-Werkzeug ab, das die Anzahl der Ecken weiter reduziert und die Leiterbahnführung verkürzt.
Das Panel „PCB ActiveRoute“
ActiveRoute befolgt die durch die Leiterplatten-Designregeln definierten Kriterien und Einschränkungen. Zur Verwendung müssen Sie daher lediglich die gewünschten Verbindungen oder Netze auswählen und ActiveRoute ausführen. Es verfügt über eine Reihe spezifischer Steuerungsfunktionen, die im Panel PCB ActiveRoute konfiguriert werden. Das Panel PCB ActiveRoute dient zum Konfigurieren und Bedienen der verschiedenen Funktionen von ActiveRoute. Dazu gehören das Ausführen eines interaktiven ActiveRoute-Vorgangs, das Definieren einer Routing-Führung und der Abstände zwischen den darin verlaufenden Leiterbahnen, das Aktivieren des automatischen Längenabgleichs sowie das Aktivieren des automatischen Pin-Tauschs. Es wird dringend empfohlen, das Panel PCB ActiveRoute vor dem Start von ActiveRoute zu öffnen.
So öffnen Sie das Panel PCB ActiveRoute, wenn eine Leiterplatte das aktive Dokument ist:
-
Klicken Sie unten rechts im Arbeitsbereich auf die Schaltfläche
und wählen Sie anschließend die Menüoption PCB ActiveRoute.
-
Klicken Sie auf View » Panels » PCB ActiveRoute.
Verwenden Sie das Panel PCB ActiveRoute, um den ActiveRoute-Prozess zu steuern.
Das Panel „PCB ActiveRoute“ dient dazu:
- Die Signallagen zu aktivieren, auf denen ActiveRoute Verbindungen routen darf.
- ActiveRoute für die ausgewählten Verbindungen auszuführen.
- Einen Glossing-Durchlauf im Anschluss an ActiveRoute zu aktivieren.
-
Eine Routing-Führung zu definieren.
- Den gewünschten Leiterbahnabstand innerhalb der Routing-Führung zu konfigurieren.
- Den Längenabgleich der von ActiveRoute platzierten Leiterbahnen zu konfigurieren und zu aktivieren.
- Die Option „Meander“ zu konfigurieren, mit der ActiveRoute einen längeren Routing-Pfad definieren kann, was den Fertigstellungsgrad erhöhen kann.
- Den Pin-Tausch zu konfigurieren und zu aktivieren. ActiveRoute kann beim Routen Pins tauschen, um die Qualität der Leiterbahnführung zu verbessern.
Der Inhalt des Panels PCB ActiveRoute ist in aufklappbare Abschnitte gegliedert, die über das Symbol ► neben der jeweiligen Abschnittsüberschrift geöffnet und geschlossen werden. Die folgenden Informationen zu den Bedienelementen sind nach den entsprechenden Abschnitten gegliedert. Jeder aufklappbare Abschnitt wird auf dieselbe Weise geöffnet bzw. geschlossen.
Aktion
Dies sind die wichtigsten Optionen zur Steuerung von ActiveRoute.
-
ActiveRoute – Klicken Sie im Panel auf die Schaltfläche
, um ActiveRoute für die ausgewählten Verbindungen auszuführen. ActiveRoute versucht, die ausgewählten Verbindungen zu routen. Wenn Pads oder Vias ausgewählt sind, werden alle Verbindungen in den betreffenden Netzen berücksichtigt. Weitere Informationen zu Auswahltechniken finden Sie auf der Seite zu ActiveRoute.
-
Route Guide – Eine Routing-Führung ist ein benutzerdefinierter Pfad, innerhalb dessen ActiveRoute die ausgewählten Verbindungen routen soll. Eines der Hauptziele von ActiveRoute ist es, die Gesamtlänge aller Leiterbahnen zu minimieren. Der daraus resultierende Verlauf ist jedoch möglicherweise nicht für jede Gruppe von Verbindungen erwünscht. Die Routing-Führung bietet dem Entwickler ein Werkzeug, mit dem er einen bestimmten Pfad vorgeben kann, dem die ausgewählten Verbindungen folgen sollen. Die Farbe der Routing-Führung wird durch die Lagen bestimmt, die für das Routen der ausgewählten Verbindungen mit ActiveRoute verfügbar sind. Ist nur eine Lage aktiviert, wird die Führung in der Farbe dieser Lage dargestellt. Sind mehrere Lagen aktiviert, wird sie in der Standardfarbe für Routing-Führungen dargestellt.
-
Um eine Routing-Führung zu definieren, wählen Sie zunächst die Verbindungen aus, die innerhalb der Führung geroutet werden sollen, und klicken Sie auf
Schaltfläche im Panel, klicken Sie dann, um den Startpunkt der Führung festzulegen, und bewegen Sie die Maus weiter und klicken Sie, um den Pfad zu definieren. Sobald der Pfad definiert ist, klicken Sie auf die Schaltfläche ActiveRoute, um die ausgewählten Verbindungen entlang dieses Pfads zu routen.
-
Während der Platzierung des Route Guide können Sie die Führung durch Drücken der Tasten
oder
verbreitern oder verengen. Die Standardbreite ergibt sich aus der Summe der geltenden Designregeln für Breite und Abstand der ausgewählten Verbindungen, geteilt durch die Anzahl der Lagen und multipliziert mit 1,3. Drücken Sie die Taste Backspace, um die Führung schrittweise zurückzunehmen, wenn Sie einen anderen Pfad definieren müssen.
- ActiveRoute versucht, die Leiterbahnen entsprechend den Designregeln anzuordnen. Es versucht nicht, sie aufzufächern oder den gesamten verfügbaren Platz innerhalb eines Route Guide zu nutzen. Um die Leiterbahnen innerhalb eines Route Guide aufzufächern, verwenden Sie die Funktion Leiterbahnabstand im Route Guide, die weiter unten auf dieser Seite beschrieben wird.
-
Um eine Routing-Führung zu definieren, wählen Sie zunächst die Verbindungen aus, die innerhalb der Führung geroutet werden sollen, und klicken Sie auf
-
Tune Selected - Wenn diese Option aktiviert ist, wird die anwendbare Matched-Lengths-Regel mit der höchsten Priorität angewendet, die im Bereich „Tune“ des Panels aktiviert ist.
-
Pin Swap Routing – Der PCB-Editor unterstützt Pin-Tausch. Aktivieren Sie diese Option, damit ActiveRoute während des Routings Pins tauschen darf. Zusätzlich zu dieser Option müssen auch die entsprechenden Bauteile im Bereich Pin Swap des Panels aktiviert werden, wie unten beschrieben. Weitere Informationen zum Pin-Tausch finden Sie auf der Seite Pin-, Paar- und Bauteiltausch.
-
Gloss Results – Aktivieren Sie diese Option, um die ActiveRoute-Ergebnisse automatisch zu glätten. Die Glättung kann auch auf vorhandene, ausgewählte Leiterbahnen angewendet werden. Führen Sie dazu den Befehl Route » Gloss Selected (Ctrl+Alt+G) aus. Weitere Informationen finden Sie auf der Seite Glätten und Nachverfolgen vorhandener Leiterbahnen.
Lagen
ActiveRoute kann auf mehreren Lagen gleichzeitig routen. Es kann zwar keine Vias für einen Lagenwechsel platzieren, aber Verbindungen und Netze auf die verfügbaren Lagen verteilen. Die verfügbaren Lagen werden im Bereich „Layers“ des Panels konfiguriert.
- Show Signal Layers Only – Standardmäßig werden alle verfügbaren Signal- und Versorgungslagen angezeigt. Aktivieren Sie diese Option, um nur die Signallagen anzuzeigen.
- List of Layers – Aktivieren Sie die Signallagen, auf denen ActiveRoute Signale routen darf. ActiveRoute verteilt die Verbindungen auf die verfügbaren Signallagen. Beachten Sie, dass ActiveRoute keine Vias für einen Lagenwechsel platziert.
Steuerung
Mit diesen Bedienelementen können Sie ActiveRoute mehr Spielraum bei der Anordnung der Leiterbahnen gemäß der geltenden Abstandsregel geben und weniger direkte Pfade zulassen, um eine Verbindung fertigzustellen.
- Track-Track Space in Route Guide – Mit diesem Bedienelement legen Sie fest, welchen Abstand ActiveRoute zwischen den entlang des Route Guide gerouteten Verbindungen anstreben soll (von Leiterbahnmitte zu Leiterbahnmitte). Die Einstellung muss vor der Definition des Route Guide erfolgen, damit dessen Breite passend zum Abstand berechnet werden kann. Wählen Sie mit dem Schieberegler einen Wert aus oder geben Sie einen Abstand in das Eingabefeld ein.
-
Meander % Over Manhattan Length – ActiveRoute versucht, die ausgewählten Verbindungen auf dem kürzestmöglichen Weg zu routen, also mit möglichst wenigen Umwegen. Wenn die Fertigstellungsrate von ActiveRoute niedriger als erwartet ist, kann eine Erhöhung der zulässigen Umwege helfen, diese zu verbessern. Die Standardeinstellung für den maximalen Meander-Wert beträgt 100 %. Das bedeutet, dass die Leiterbahnen eine Gesamtlänge von
Manhattan Length + 100% of Manhattan Lengthhaben dürfen. Wählen Sie mit dem Schieberegler einen Wert aus oder geben Sie einen Prozentsatz in das Eingabefeld ein. Beachten Sie, dass die Meander-Einstellung bei Verwendung des Route Guide ignoriert wird, da dieser dazu dient, einen Pfad zu definieren, der erheblich größere Umwege vorgeben kann.
Längenabgleich
ActiveRoute kann einen Längenabgleich auf Verbindungen anwenden, die gerade geroutet werden, oder auf ausgewählte vorhandene Leiterbahnen.
-
Match Length Rules for Selected – Hier werden alle definierten Matched-Lengths-Designregeln aufgelistet. Aktivieren Sie die Regel, die ActiveRoute für die ausgewählten Verbindungen verwenden soll.
-
Single Ended – Eigenschaften der Mäanderstruktur für den Längenabgleich von unsymmetrischen Signalen.
- Max Amplitude - Maximal zulässige Amplitude der Mäanderstruktur. Bei Hindernissen wie vorhandenen Pads, Vias oder Leiterbahnen wird die Amplitude automatisch verringert, um die durch die Designregeln vorgegebenen Abstände einzuhalten.
- Min Space - Der minimale Kantenabstand zwischen den Nulldurchgängen der Mäanderstruktur.
-
Differential Pair - Eigenschaften der Mäanderstruktur für den Längenabgleich von Differenzpaaren.
- Max Amplitude - Maximal zulässige Amplitude der Mäanderstruktur für die äußere Leiterbahn des Differenzpaars. Bei Platzierungshindernissen wird die Amplitude automatisch verringert, um die durch die Designregeln vorgegebenen Abstände einzuhalten.
- Min Space - Der minimale Kantenabstand zwischen den Nulldurchgängen der Mäanderstruktur für die innere Leiterbahn des Differenzpaars.
Pin-Tausch
Funktional gleichwertige Pins eines Bauteils können als tauschbar konfiguriert werden. Wählen Sie dazu den Befehl Tools » Pin/Part Swapping » Configure. Bevor Pins getauscht werden können (interaktiv oder durch ActiveRoute), muss das Projekt nach jedem Öffnen kompiliert werden (Menü Project).
- Components with Pin Swap Enabled – Hier werden alle Bauteile aufgelistet, für die der Pin-Tausch aktiviert ist. Aktivieren Sie diejenigen, die während eines ActiveRoute-Durchlaufs für den automatischen Tausch verfügbar sein sollen.
Weitere ActiveRoute-Funktionen
ActiveRoute ist ein automatisierter interaktiver Router und lässt sich einfach und unkompliziert bedienen: Wählen Sie die Verbindungen aus und drücken Sie dann Shift+A, um sie mit ActiveRoute gemäß den Designregeln zu routen. ActiveRoute bietet eine Reihe weiterer Funktionen und Bedienelemente, mit denen Entwickler bestimmte Funktionen und Abläufe gezielter steuern können.
Dazu gehören:
- Definieren des Routing-Pfads und des Leiterbahnabstands durch Platzieren eines Route Guide.
- Zulassen eines längeren Routing-Pfads mit dem Meander-Bedienelement.
- Automatisches Angleichen der Leiterbahnlängen durch Längenabgleich.
- Zulassen des Pin-Tauschs, um das Routing zu vereinfachen.
Sehen wir uns diese Funktionen genauer an.
Den Pfad mit dem Route Guide definieren
Eines der Hauptziele von ActiveRoute ist es, die Gesamtlänge aller Leiterbahnen so kurz wie möglich zu halten. Dies entspricht jedoch nicht bei jeder Gruppe von Verbindungen dem gewünschten Pfad. Der Route Guide bietet Entwicklern ein Werkzeug, mit dem sie einen bestimmten Pfad vorgeben können, dem die ausgewählten Verbindungen folgen sollen – auch wenn dieser nicht der kürzeste ist.
-
Defining the Route Guide - Wählen Sie zunächst die Verbindungen aus, die innerhalb der Führung geroutet werden sollen, und klicken Sie auf die
Schaltfläche im PCB ActiveRoute-Panel, klicken Sie dann, um den Startpunkt der Führung festzulegen, und bewegen Sie die Maus weiter und klicken Sie, um den Pfad zu definieren. Sobald der Pfad definiert ist, klicken Sie auf die Schaltfläche ActiveRoute, um die ausgewählten Verbindungen entlang dieses Pfads zu routen. Weitere Informationen finden Sie im Abschnitt Eine Routing-Führung definieren weiter unten auf dieser Seite.
-
Changing the Route Guide Width - während der Platzierung der Routing-Führung können Sie diese durch Drücken der Tasten
oder
verbreitern oder verengen. Die Standardbreite ergibt sich aus der Summe der anwendbaren Designregelwerte für Breite und Abstand der ausgewählten Verbindungen, geteilt durch die Anzahl der Lagen und multipliziert mit 1,3. Drücken Sie die Taste Backspace, um die Führung schrittweise zurückzunehmen, wenn Sie einen anderen Pfad definieren möchten.
- The Route Guide color - wird durch die Lagen bestimmt, die für das Routing der ausgewählten Verbindungen mit ActiveRoute verfügbar sind. Wenn nur eine Lage aktiviert ist, wird die Führung in der Farbe dieser Lage dargestellt; sind mehrere Lagen aktiviert, wird sie in der Standardfarbe für die Routing-Führung dargestellt.
- The track spacing within the Route Guide - standardmäßig legt ActiveRoute die Abstände zwischen den Leiterbahnen gemäß den Designregeln fest. Es versucht nicht, die Leiterbahnen aufzufächern oder den gesamten verfügbaren Platz innerhalb einer Routing-Führung zu nutzen. Um die Leiterbahnen innerhalb einer Routing-Führung aufzufächern, verwenden Sie die Funktion Leiterbahnabstand in der Routing-Führung, wie weiter unten auf dieser Seite beschrieben.

Ein Video zeigt die Platzierung einer Routing-Führung, deren Breite während der Platzierung interaktiv geändert wird.
Leiterbahnabstand innerhalb der Routing-Führung
Mit der Funktion „Leiterbahnabstand in der Routing-Führung“ können Sie ActiveRoute anweisen, die Leiterbahnen über die Breite der Routing-Führung zu verteilen. Wählen Sie mit dem Schieberegler einen Abstandswert aus oder geben Sie einen Wert in das Eingabefeld ein. Die Größe der Routing-Führung wird automatisch an diese Einstellung angepasst. Dazu müssen Sie die Einstellung Track-Track Space in Route Guide vor dem Platzieren der Routing-Führung konfigurieren. Sie können die Breite der Routing-Führung während der Platzierung durch Drücken der Tasten
und
weiter anpassen.

Verwenden Sie die Funktion „Leiterbahnabstand“, um die Leiterbahnen in der Routing-Führung aufzufächern.
Umwege beim Routing zulassen
ActiveRoute versucht, die ausgewählten Verbindungen auf dem kürzestmöglichen Pfad zu routen, also mit möglichst wenigen Umwegen. Wenn die Abschlussrate von ActiveRoute niedriger als erwartet ist, können Sie mit dem Regler „Meander“ den für ActiveRoute zulässigen Umfang an Umwegen erhöhen, was die Abschlussrate verbessern kann. Die standardmäßige maximale Meander-Einstellung beträgt 100 %. Das bedeutet, dass die Leiterbahnen eine Gesamtlänge von Manhattan Length + 100% of Manhattan Length haben dürfen. Wählen Sie mit dem Schieberegler einen Wert für die zulässigen Umwege aus oder geben Sie einen Prozentsatz in das Eingabefeld ein.
Beachten Sie, dass die Meander-Einstellung bei Verwendung der Routing-Führung ignoriert wird, da die Routing-Führung dazu dient, einen Pfad zu definieren, der erheblich größere Umwege vorgeben kann.
Abstimmen der Leiterbahnlängen
ActiveRoute kann einen Längenabgleich für die gerade gerouteten Verbindungen oder für ausgewählte vorhandene Leiterbahnen durchführen. Dabei versucht ActiveRoute, die ausgewählte Designregel „Matched Lengths“ einzuhalten.
So konfigurieren Sie ActiveRoute für den Längenabgleich:
-
Aktivieren Sie das Kontrollkästchen Tune Selected im Bereich Action des Panels.
-
Aktivieren Sie die erforderliche Designregel „Matched Lengths“ im Bereich Tune des Panels.
-
Konfigurieren Sie die erforderlichen Einstellungen für Max Amplitude und Min Space (entweder Single-Ended oder Differenzialpaar) im Bereich Tune des Panels.
Pin-Tausch
Die Software verfügt über ein leistungsstarkes System zum Tauschen von Pins und Bauteilsektionen, das Schaltplan- und PCB-Editor miteinander verknüpft. ActiveRoute kann auf die Einstellungen für den Pin-Tausch zugreifen und während des Routings Pins tauschen, wenn dadurch die gesamte Leiterbahnlänge reduziert und die Routing-Qualität verbessert wird.
So verwenden Sie den Pin-Tausch:
- Bevor ein Pin-Tausch durchgeführt werden kann (interaktiv oder durch ActiveRoute), muss das Projekt nach jedem Öffnen kompiliert werden (Menü Project).
- Um die Einstellungen für den Pin-Tausch von Bauteilen zu konfigurieren und zu verwalten, führen Sie den Befehl Tools » Pin/Part Swapping » Configure aus, um das Dialogfeld Configure Swapping Information in Components zu öffnen.
- Aktivieren Sie die Option Pin Swap Routing im Bereich Action des PCB ActiveRoute-Panels.
- Aktivieren Sie die gewünschten Bauteile im Bereich Pin Swap des PCB ActiveRoute-Panels.
Vorbereitung für ActiveRoute
1. Netzklassen erstellen
Für ActiveRoute müssen die Netze ausgewählt sein. Netzklassen können die Auswahl erheblich erleichtern, wenn eine große Anzahl von Netzen mit ActiveRoute geroutet werden soll. Weitere Informationen zu den besten Methoden zur Auswahl von Verbindungen finden Sie im Abschnitt Auswahltechniken weiter unten in diesem Artikel.
2. Vorhandene Polygone zurückstellen
ActiveRoute kann durch vorhandene Polygone routen, wenn die Option Repour Polygons after Modification auf der Seite PCB Editor - General des Dialogs Preferences aktiviert ist. Alternativ können Polygone mit dem Befehl Tools » Polygon Pours » Shelve Polygons zurückgestellt werden (sie werden ausgeblendet, bleiben aber im Design erhalten).
3. Designregeln konfigurieren
- Abstände – ActiveRoute beachtet die geltenden Abstandsregeln und wendet sie in der Reihenfolge ihrer Priorität an.
- Leiterbahnbreiten – Es wird die Einstellung Preferred der geltenden Breitenregeln verwendet. Um die Breite in einem Bereich zu ändern, beispielsweise wenn die Leiterbahn unter einem BGA verläuft, definieren Sie wie beim interaktiven Routing einen Room, in dem eine Breitenregel mit einer geringeren bevorzugten Breite gilt. Wenn Sie die Verbindung nicht manuell mit der bevorzugten Breite routen können, kann ActiveRoute dies ebenfalls nicht.
- Differenzpaare – ActiveRoute kann Differenzpaare routen. Stellen Sie sicher, dass die Differenzpaare korrekt definiert sind (prüfen Sie dies im Modus Differential Pairs Editor des Panels PCB), und vergewissern Sie sich, dass die Routing-Regel(n) für Differenzpaare korrekt konfiguriert sind (es werden die Werte für Preferred verwendet).
- Pad-Anbindung – ActiveRoute versucht, den direktesten regelkonformen Weg in ein Pad bzw. aus einem Pad zu verwenden, ohne spitze Winkel zu erzeugen. Dabei werden die Regeln SMT to Corner und SMT Pad Entry beachtet, die Leiterbahn wird jedoch nicht immer im Pad zentriert (wie es der interaktive Router bei aktivierter Regel „SMT to Corner“ tut). Für die Pads von Differenzpaaren stehen spezielle Algorithmen zur Verfügung, die auf die Kopplung des Paars ausgerichtet sind und gleichzeitig eine saubere Leiterbahnführung gewährleisten.
4. Netztopologie konfigurieren
ActiveRoute folgt dem Verlauf der Verbindungslinien. Wenn bestimmte Netze eine spezielle Topologie erfordern, beispielsweise eine Fly-by-Topologie für DDR3/4, können Sie die From-To-Reihenfolge mithilfe von xSignals definieren. Der xSignals Multi-Chip Wizard (Design » xSignals » Run xSignals Wizard) kann xSignals für Designs mit DDR3/4- und USB-3.0-Signalübertragung erstellen. Alternativ lässt sich für ein Netz ein Punkt-zu-Punkt-Verlauf der Verbindungslinien definieren, indem Sie im Modus From-To Editor des Panels PCB From-Tos erstellen.
5. Fanouts für das Design erstellen
ActiveRoute platziert keine Vias. Daher müssen Sie Fanouts für BGAs, Steckverbinder und diskrete Bauteile mit SMT-Pins erstellen (ausgenommen Pins, die auf den Außenlagen geroutet werden sollen).
6. Versorgungs- und Masseverbindungen routen
ActiveRoute ist für Signalnetze vorgesehen; Netze, die Versorgungslagen zugewiesen sind, sowie Netze mit mehr als 20 Pins werden ignoriert (diese werden als Versorgungsnetze betrachtet). Wenn Sie ActiveRoute auf ein bereits fertiggestelltes Design anwenden möchten, löschen Sie die Signal-Leiterbahnen, behalten Sie jedoch die Versorgungs- und Masse-Leiterbahnen sowie die Fanouts bei.
7. Erforderliche Routing-Lagen aktivieren
Aktivieren Sie die erforderlichen Routing-Lagen im Panel PCB ActiveRoute. Weitere Informationen dazu finden Sie weiter unten.
ActiveRoute ausführen
So führen Sie ActiveRoute aus:
1. Zu routende Verbindung(en) auswählen
Wählen Sie mithilfe der auf der Seite Strategien zur Auswahl der zu routenden Verbindungen beschriebenen Verfahren die zu routenden Verbindungen bzw. Netze aus. Verbindungen können direkt oder durch Auswahl eines Routing-Objekts wie eines Pins, einer Leiterbahn, eines Vias oder eines Bauteils ausgewählt werden. Die Statusleiste zeigt die Anzahl der gerade ausgewählten Verbindungen an, bis der Cursor über ein anderes Objekt bewegt wird.
- Wenn Verbindungen ausgewählt sind, werden sie mit der bevorzugten Breite geroutet, die in der geltenden Designregel für die Leiterbahnbreite festgelegt ist.
- Wenn vorhandene Leiterbahnen ausgewählt sind, wird die mit der ausgewählten Leiterbahn verbundene Verbindung mit deren Breite geroutet.
- Wenn Bauteil-Pads ausgewählt sind, werden alle Verbindungen von den ausgewählten Pads mit der bevorzugten Breiteneinstellung der Regel geroutet.
2. Lagen für ActiveRoute aktivieren
Aktivieren Sie im Panel PCB ActiveRoute die Lage(n), auf denen die ausgewählten Verbindungen geroutet werden sollen. ActiveRoute verteilt die Leiterbahnen auf diese Lagen.
Wenn keine Lage ausgewählt ist, wird auf der aktiven Lage geroutet. Diese entspricht der ausgewählten Registerkarte am unteren Rand des PCB-Editor-Hauptfensters.
Im Panel PCB ActiveRoute können Sie die Lagen für das Routing auswählen, einen Route Guide erstellen und ActiveRoute starten.
3. Bei Bedarf einen Route Guide definieren
So platzieren Sie einen Route Guide:
- Wählen Sie die Verbindungen aus, die entlang des Route Guides geroutet werden sollen. Die Statusleiste zeigt die Anzahl der gerade ausgewählten Verbindungen an, bis der Cursor über ein anderes Objekt bewegt wird.
- Klicken Sie im Panel PCB ActiveRoute auf die Schaltfläche Route Guide.
- Der Cursor scheint nun alle ausgewählten Verbindungen zu holding. Dies zeigt an, dass diese Verbindungen durch den Guide verlaufen müssen. Bewegen Sie den Cursor an eine geeignete Startposition an einem der beiden Enden des Pfads, den Sie definieren möchten.
- Klicken Sie, um die Startposition des Guides festzulegen. Lassen Sie dabei genügend Platz, damit die eingehenden Verbindungen in das abgerundete Ende des Guides geführt werden können.
- Der Guide wird wie eine sehr breite Leiterbahn platziert. Bewegen Sie den Cursor an die Position der ersten erforderlichen Ecke des Guides und klicken Sie, um diese Ecke festzulegen.
- Setzen Sie die Definition des Pfads auf diese Weise fort und beenden Sie ihn in ausreichendem Abstand vor den Endpunkten der Verbindungslinien. So bleibt genügend Platz, um die Verbindungen aus dem Guide zu ihren Ziel-Pads, Vias oder Leiterbahnenden zu führen.
- Drücken Sie die Taste Up Arrow, um den Guide zu verbreitern, oder die Taste Down Arrow, um ihn zu verschmälern.
- Drücken Sie Backspace, um die letzte Ecke des Guides zu entfernen.
- Klicken Sie mit der rechten Maustaste, um den Platzierungsmodus für den Guide zu beenden.
Es kann jeweils nur ein Route Guide definiert werden.
4. ActiveRoute ausführen
Um ActiveRoute auszuführen, können Sie:
- Den Befehl Route » ActiveRoute auswählen.
-
Auf die Schaltfläche ActiveRoute (
) auf Active Bar klicken.
- Im Panel PCB ActiveRoute auf die Schaltfläche ActiveRoute klicken.
- Das Tastenkürzel Shift+A verwenden.
5. Fortschritt überwachen und Rückmeldungen prüfen
- Die Statusleiste des PCB-Editors zeigt den Fortschritt von ActiveRoute an.
- Das Panel Messages zeigt den Fertigstellungsgrad an.
Ihre Fähigkeiten ausbauen
-
Ein wesentlicher Faktor für den sicheren Umgang mit ActiveRoute ist die routinierte Verwendung der Tastenkürzel. Die folgenden Tastenkombinationen werden Sie am häufigsten verwenden:
- Alt+Click – zum Auswählen einer einzelnen Verbindungslinie.
- Alt+Click&Drag – zum Auswählen von Verbindungen innerhalb eines Bereichs. Ziehen Sie von rechts nach links, um alle berührten Verbindungen auszuwählen, oder von links nach rechts, um nur die Verbindungen auszuwählen, die vollständig im Auswahlrechteck liegen. Drücken Sie Tab, um die Auswahl um weitere Verbindungen desselben Netzes bzw. derselben Netze zu erweitern. Die Statusleiste zeigt die Anzahl der gerade ausgewählten Verbindungen an, bis der Mauszeiger über ein anderes Objekt bewegt wird.
- Ctrl+Click&Drag – zum Auswählen von Pads eines Bauteils. Ziehen Sie von rechts nach links, um alle berührten Pads auszuwählen, oder von links nach rechts, um nur die Pads auszuwählen, die vollständig im Auswahlrechteck liegen. Drücken Sie Tab, um die Auswahl um weitere Routing-Objekte desselben Netzes bzw. derselben Netze zu erweitern. Drücken Sie wiederholt Tab, um alle möglichen Auswahlzustände zu durchlaufen.
- Click&Drag – zum Auswählen vorhandener Leiterbahnsegmente. Ziehen Sie von rechts nach links, um alle berührten Leiterbahnen auszuwählen, oder von links nach rechts, um nur die Leiterbahnen auszuwählen, die vollständig im Auswahlrechteck liegen. Drücken Sie Tab, um die Auswahl um weitere Routing-Objekte desselben Netzes bzw. derselben Netze zu erweitern. Drücken Sie wiederholt Tab, um alle möglichen Auswahlzustände zu durchlaufen.
- Halten Sie zusätzlich Shift gedrückt, um die aktuelle Auswahl beizubehalten, während Sie eine weitere Auswahl vornehmen.
- Shift+A zum Routen der aktuellen Auswahl mit ActiveRoute.
- Ctrl+Alt+G – zum Glätten der aktuellen Auswahl.
-
Auswahlaktionen werden nur auf sichtbare Objekte angewendet (mit Ausnahme von Ctrl+A):
- Drücken Sie Shift+S, um in den Einzellagenmodus zu wechseln bzw. ihn zu verlassen, sodass nur die gewünschte Lage angezeigt wird.
- Wenn im Design Platzierungsräume verwendet werden, können diese im Rahmen ihrer Definition in den Designregeln gesperrt oder ausgeblendet werden, damit sie bei Klick-und-Zieh-Aktionen nicht ausgewählt oder verschoben werden. Räume können auf der Registerkarte View Options des Panels View Configuration ausgeblendet werden.
-
Fanout für SMD-Pads erstellen. ActiveRoute wechselt keine Lagen, daher müssen Sie für SMD-Pads ein Fanout erstellen. So beschleunigen Sie den Fanout-Vorgang:
- Drücken Sie beim Routen einer Verbindung das Tastenkürzel / (Ziffernblock), um ein Via zu platzieren und diese Verbindung zu beenden. Verwenden Sie das Tastenkürzel 2, wenn Sie keinen Ziffernblock haben (platziert ein Via, ohne das Routing zu unterbrechen).
- Kopieren Sie ein vorhandenes Fanout und fügen Sie es ein; der PCB-Editor aktualisiert die Netznamen automatisch. Dies ist auch für mehrere Fanouts gleichzeitig möglich.
-
Vorhandene Fanouts beibehalten. ActiveRoute ändert Fanouts, wenn es eine bessere Lösung findet. Sperren Sie die Fanouts, wenn sie nicht geändert werden sollen. Am einfachsten sperren Sie Fanouts, indem Sie die zugehörigen Leiterbahnen und Vias auswählen (verwenden Sie dazu Selection Filter oben im Panel Properties), mit F11 das Panel Properties öffnen und das Kontrollkästchen Locked aktivieren. Dadurch werden alle ausgewählten Objekte in einem Schritt gesperrt.
-
Wenn Sie einen Route Guide verwenden und der Fertigstellungsgrad niedrig ist, befinden sich möglicherweise zu viele Hindernisse entlang des Pfads und der Guide muss breiter sein. Drücken Sie während der Platzierung die Pfeiltaste Up, um den Guide zu verbreitern.
-
Nach Abschluss führt ActiveRoute eine Glättung durch (sofern diese im Panel PCB ActiveRoute aktiviert ist). Um die Leiterbahnen im Zustand unmittelbar nach Abschluss des ActiveRouting zu prüfen, drücken Sie einmal Ctrl+Z, um die Glättung rückgängig zu machen. Mit dem Befehl Gloss (Route » Gloss Selected) können Sie Leiterbahnen glätten und die Pad-Anbindungen beliebiger Routings verbessern, nicht nur die von ActiveRoute. Besonderes Augenmerk wurde auf hochwertige Pad-Anbindungen für differenzielle Paare gelegt. Weitere Informationen zur Glättung finden Sie auf der Seite Glätten und Nachverfolgen vorhandener Leiterbahnen.
-
Wenn ActiveRoute nicht funktioniert, liegt dies meist an nicht korrekt konfigurierten Regeln. Der häufigste Grund für ein Scheitern von ActiveRoute ist, dass nicht genügend Platz für die Leiterbahn(en) vorhanden ist. Prüfen Sie, ob die Regeln geeignet sind. Beispielsweise können die Standardvorgaben in einer neuen PCB-Datei für ein hochdichtes BGA-Design zu groß sein.
-
ActiveRoute berücksichtigt die Routing-Regeln für Leiterbahnbreiten, Abstände und Abstände innerhalb differenzieller Paare sowie lagen-, raum- und klassenspezifische Regeln. ActiveRoute routet nicht mit Kreisbögen oder Leiterbahnen in beliebigen Winkeln.