ActiveRoute

Auf einen Blick

Dieser Artikel erklärt, wie ActiveRoute in Altium Designer das PCB-Routing beschleunigt, indem es Automatisierung mit der Kontrolle durch den Entwickler verbindet, statt auf einen herkömmlichen Autorouter zu setzen. Er erläutert, was ActiveRoute ist und was nicht, welche wesentlichen Vorteile es bietet und wie Sie im Panel „PCB ActiveRoute“ Netze auswählen, Routing-Leitpfade definieren, Lagen auswählen, Glättung, Längenabgleich und Pin-Tausch aktivieren sowie das Routing-Verhalten anpassen. Sie möchten erfahren, wie Sie schneller zu sauberen, regelkonformen Routing-Ergebnissen gelangen und dabei die Kontrolle über den Prozess behalten? Dieser Leitfaden zeigt Ihnen den Einstieg. Lesen Sie weiter und erfahren Sie, wie ActiveRoute Ihren Workflow verbessern kann.

- Verstehen Sie, wie sich ActiveRoute von einem Autorouter unterscheidet und warum es sich besser für das gezielte, hochwertige Routing ausgewählter Netze eignet.
- Lernen Sie die wichtigsten Funktionen von ActiveRoute kennen, darunter Routing-Leitpfade, Routing über mehrere Lagen, Glättung, Längenabgleich, Mäandersteuerung und Pin-Tausch.
- Erfahren Sie, wie Sie ActiveRoute im Panel „PCB ActiveRoute“ anhand Ihrer Designregeln und Routing-Ziele konfigurieren und ausführen.
Mit KI tiefer einsteigen:

Concept image showing routing

Eine der zeitaufwendigsten Phasen beim Leiterplattendesign ist das Routen der Netze. Während das Regelsystem die Designvorgaben wie Leiterbahnbreiten, Via-Größen, Abstände usw. berücksichtigt, muss der Entwickler die vielen Tausend Leiterbahnsegmente platzieren, die für das vollständige Routen einer Leiterplatte erforderlich sind.

Autorouter können diesen Aufwand verringern, gelten jedoch im Allgemeinen als unzureichend, weil:

  • Sie die unzähligen feinen Designvorgaben nicht angemessen berücksichtigen, die ein Entwickler beim Routen intuitiv anwendet.

  • Ihre vollständige Konfiguration so viel Zeit in Anspruch nimmt, dass es oft effizienter ist, die Leiterplatte direkt interaktiv zu routen.

  • Die Nachbearbeitung so langwierig und schwierig sein kann, dass es oft effizienter ist, die Leiterplatte interaktiv zu routen.

Der heilige Gral des Leiterplatten-Routings besteht darin, unter der Kontrolle des Entwicklers schnell hochwertige Ergebnisse zu erzielen, die den Designregeln entsprechen. Genau dieser Herausforderung stellt sich ActiveRoute.

Improving the Completed Routes

Die Funktionen Glossing und Retrace ergänzen ActiveRoute, sind jedoch unabhängig davon. Mit ihnen lässt sich die Qualität jeder vorhandenen Leiterbahnführung verbessern, unabhängig davon, wie sie erstellt wurde.

Glossing ist standardmäßig aktiviert und wird nach Abschluss von ActiveRoute ausgeführt. Bei Bedarf kann dies im Panel PCB ActiveRoute deaktiviert werden. Glossing verfügt außerdem über eigene Optionen, darunter die Möglichkeit, Ecken in der Leiterbahnführung abzurunden.

► Erfahren Sie mehr über Glossing und Retracing vorhandener Leiterbahnführungen

Was ist ActiveRoute?

ActiveRoute ist eine automatisierte interaktive Routing-Technologie mit effizienten Algorithmen zum Routen mehrerer Netze, die auf die von Ihnen ausgewählten Netze oder Verbindungen angewendet wird. Mit ActiveRoute kann der Entwickler außerdem interaktiv einen Routing-Pfad oder eine Führung definieren, die dann the river festlegt, entlang dessen die neuen Leiterbahnen verlaufen.

Zu den wichtigsten Funktionen von ActiveRoute, die diesen Ansatz deutlich besser machen als eine Kombination aus herkömmlichem interaktivem Routing und Autorouting, gehören:

  • Automatische Optimierung der Entflechtung aus Pin-/Via-Anordnungen – dem zeitaufwendigsten Aspekt des manuellen Routings.
  • Hohe Leistung – Signalnetze werden jeweils in < 1 Sekunde geroutet.
  • Berücksichtigt unter Beachtung der Prioritäten die Designregeln für Breite, Abstand, Lagen, Topologie und Rooms je nach Netz und Netzklasse.
  • Routet gleichzeitig auf mehreren Lagen und verteilt die Leiterbahnen auf diese Lagen.
  • Eine intuitive Routing-Führung (Route Guide), mit der der Entwickler die Platzierung der Leiterbahnen steuern kann.
  • Verwendet einen River-Routing-Ansatz, um ohne Vias einen hohen Fertigstellungsgrad zu erreichen.
  • Kann durch Polygonflächen routen und diese neu füllen, sofern die Option zum erneuten Füllen aktiviert ist.
  • Unterstützt sowohl Single-Ended-Netze als auch differenzielle Netzpaare.
  • Schließt mit einem leistungsstarken Glossing-Werkzeug ab, das die Anzahl der Ecken weiter reduziert und die Leiterbahnführung verkürzt.

Was ActiveRoute nicht ist

ActiveRoute ist kein Autorouter. Es ist ein geführter interaktiver Router, der auf eine saubere, hochwertige Leiterbahnführung für eine Gruppe ausgewählter Netze ausgerichtet ist. Verwenden Sie ActiveRoute genauso, wie Sie beim interaktiven Routing vorgehen würden: Wählen Sie die gewünschten Netze aus, aktivieren Sie die Lagen, auf denen diese Netze geroutet werden sollen, überlegen Sie sich den gewünschten Verlauf und routen Sie die Netze.

Wenn Sie alle Netze auf der Leiterplatte auswählen und mit ActiveRoute routen, werden Sie wahrscheinlich enttäuscht sein. ActiveRoute ist kein Autorouter; es kann keine Vias platzieren und bietet keine Routing-Strategien für Versorgungsnetze.

Das Panel „PCB ActiveRoute“

ActiveRoute befolgt die durch die Leiterplatten-Designregeln definierten Kriterien und Einschränkungen. Zur Verwendung müssen Sie daher lediglich die gewünschten Verbindungen oder Netze auswählen und ActiveRoute ausführen. Es verfügt über eine Reihe spezifischer Steuerungsfunktionen, die im Panel PCB ActiveRoute konfiguriert werden. Das Panel PCB ActiveRoute dient zum Konfigurieren und Bedienen der verschiedenen Funktionen von ActiveRoute. Dazu gehören das Ausführen eines interaktiven ActiveRoute-Vorgangs, das Definieren einer Routing-Führung und der Abstände zwischen den darin verlaufenden Leiterbahnen, das Aktivieren des automatischen Längenabgleichs sowie das Aktivieren des automatischen Pin-Tauschs. Es wird dringend empfohlen, das Panel PCB ActiveRoute vor dem Start von ActiveRoute zu öffnen.

So öffnen Sie das Panel PCB ActiveRoute, wenn eine Leiterplatte das aktive Dokument ist: 

  • Klicken Sie unten rechts im Arbeitsbereich auf die Schaltfläche  Panels button, click to enable the display of workspace panels available in the current editor und wählen Sie anschließend die Menüoption PCB ActiveRoute.

  • Klicken Sie auf View » Panels » PCB ActiveRoute.

Um die Funktionen von ActiveRoute in Altium Designer nutzen zu können, muss die Softwareerweiterung ActiveRoute installiert sein. Sie kann manuell installiert oder entfernt werden.

Weitere Informationen zur Verwaltung von Erweiterungen finden Sie auf der Seite Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Verwenden Sie das Panel PCB ActiveRoute, um den ActiveRoute-Prozess zu steuern.Verwenden Sie das Panel PCB ActiveRoute, um den ActiveRoute-Prozess zu steuern.

Das Panel „PCB ActiveRoute“ dient dazu:

  • Die Signallagen zu aktivieren, auf denen ActiveRoute Verbindungen routen darf.
  • ActiveRoute für die ausgewählten Verbindungen auszuführen.
  • Einen Glossing-Durchlauf im Anschluss an ActiveRoute zu aktivieren.
  • Eine Routing-Führung zu definieren.
    • Den gewünschten Leiterbahnabstand innerhalb der Routing-Führung zu konfigurieren.
  • Den Längenabgleich der von ActiveRoute platzierten Leiterbahnen zu konfigurieren und zu aktivieren.
  • Die Option „Meander“ zu konfigurieren, mit der ActiveRoute einen längeren Routing-Pfad definieren kann, was den Fertigstellungsgrad erhöhen kann.
  • Den Pin-Tausch zu konfigurieren und zu aktivieren. ActiveRoute kann beim Routen Pins tauschen, um die Qualität der Leiterbahnführung zu verbessern.
ActiveRoute arbeitet mit den ausgewählten Verbindungen. Einige Bedienelemente im Panel werden erst aktiv, wenn Verbindungen ausgewählt sind.

Der Inhalt des Panels PCB ActiveRoute ist in aufklappbare Abschnitte gegliedert, die über das Symbol ► neben der jeweiligen Abschnittsüberschrift geöffnet und geschlossen werden. Die folgenden Informationen zu den Bedienelementen sind nach den entsprechenden Abschnitten gegliedert. Jeder aufklappbare Abschnitt wird auf dieselbe Weise geöffnet bzw. geschlossen.

Weitere ActiveRoute-Funktionen

ActiveRoute ist ein automatisierter interaktiver Router und lässt sich einfach und unkompliziert bedienen: Wählen Sie die Verbindungen aus und drücken Sie dann Shift+A, um sie mit ActiveRoute gemäß den Designregeln zu routen. ActiveRoute bietet eine Reihe weiterer Funktionen und Bedienelemente, mit denen Entwickler bestimmte Funktionen und Abläufe gezielter steuern können.

Dazu gehören:

  • Definieren des Routing-Pfads und des Leiterbahnabstands durch Platzieren eines Route Guide.
  • Zulassen eines längeren Routing-Pfads mit dem Meander-Bedienelement.
  • Automatisches Angleichen der Leiterbahnlängen durch Längenabgleich.
  • Zulassen des Pin-Tauschs, um das Routing zu vereinfachen.

Sehen wir uns diese Funktionen genauer an.

Den Pfad mit dem Route Guide definieren

Eines der Hauptziele von ActiveRoute ist es, die Gesamtlänge aller Leiterbahnen so kurz wie möglich zu halten. Dies entspricht jedoch nicht bei jeder Gruppe von Verbindungen dem gewünschten Pfad. Der Route Guide bietet Entwicklern ein Werkzeug, mit dem sie einen bestimmten Pfad vorgeben können, dem die ausgewählten Verbindungen folgen sollen – auch wenn dieser nicht der kürzeste ist.

  • Defining the Route Guide - Wählen Sie zunächst die Verbindungen aus, die innerhalb der Führung geroutet werden sollen, und klicken Sie auf die  Route Guide button, click to define a route guide that ActiveRoute will then attempt to route the selected nets along Schaltfläche im PCB ActiveRoute-Panel, klicken Sie dann, um den Startpunkt der Führung festzulegen, und bewegen Sie die Maus weiter und klicken Sie, um den Pfad zu definieren. Sobald der Pfad definiert ist, klicken Sie auf die Schaltfläche ActiveRoute, um die ausgewählten Verbindungen entlang dieses Pfads zu routen. Weitere Informationen finden Sie im Abschnitt Eine Routing-Führung definieren weiter unten auf dieser Seite.

Platzieren Sie die Endpunkte der Routing-Führung nicht direkt auf den Pads, die Sie routen möchten. Die Qualität der Pad-Abgänge ist besser, wenn die Pads nicht innerhalb der Routing-Führung liegen.

  • Changing the Route Guide Width - während der Platzierung der Routing-Führung können Sie diese durch Drücken der Tasten  Keyboard Up arrow key oder  Keyboard Down arrow key verbreitern oder verengen. Die Standardbreite ergibt sich aus der Summe der anwendbaren Designregelwerte für Breite und Abstand der ausgewählten Verbindungen, geteilt durch die Anzahl der Lagen und multipliziert mit 1,3. Drücken Sie die Taste Backspace, um die Führung schrittweise zurückzunehmen, wenn Sie einen anderen Pfad definieren möchten.
  • The Route Guide color - wird durch die Lagen bestimmt, die für das Routing der ausgewählten Verbindungen mit ActiveRoute verfügbar sind. Wenn nur eine Lage aktiviert ist, wird die Führung in der Farbe dieser Lage dargestellt; sind mehrere Lagen aktiviert, wird sie in der Standardfarbe für die Routing-Führung dargestellt.
  • The track spacing within the Route Guide - standardmäßig legt ActiveRoute die Abstände zwischen den Leiterbahnen gemäß den Designregeln fest. Es versucht nicht, die Leiterbahnen aufzufächern oder den gesamten verfügbaren Platz innerhalb einer Routing-Führung zu nutzen. Um die Leiterbahnen innerhalb einer Routing-Führung aufzufächern, verwenden Sie die Funktion Leiterbahnabstand in der Routing-Führung, wie weiter unten auf dieser Seite beschrieben.

Ein Video zeigt die Platzierung einer Routing-Führung, deren Breite während der Platzierung interaktiv geändert wird.
Ein Video zeigt die Platzierung einer Routing-Führung, deren Breite während der Platzierung interaktiv geändert wird.

Breite der Routing-Führung

Die Standardbreite ergibt sich aus der Summe der anwendbaren Designregelwerte für Breite und Abstand der ausgewählten Verbindungen, geteilt durch die Anzahl der Lagen und multipliziert mit 1,3. 

  • RouteGuideWidth = ((W+C)/#Layers)*1.3)
  • Die Führung wird standardmäßig um den Faktor 1,3 verbreitert, damit die Leiterbahnen hineinpassen und Hindernisse im Pfad, etwa Vias, umgehen können. Die Breite bildet eine feste Grenze für das Routing; passen die Leiterbahnen nicht hinein, werden sie nicht platziert.
  • Während der Platzierung der Führung kann die Breite durch Drücken der Tasten  Keyboard Up arrow key oder  Keyboard Down arrow key auf der Tastatur vergrößert bzw. verkleinert werden. Die Mindestgröße verwendet einen Multiplikator von 1,0; die maximale Größe einen Multiplikator von 10,0.

Bearbeiten der Führung

Die Routing-Führung besteht aus einer Reihe von Leiterbahnsegmenten, die auf einer mechanischen Lage platziert sind.

  • Die Leiterbahnsegmente sind standardmäßig gesperrt. Wenn Sie die Sperre aufheben, können Sie die Führung mit den üblichen Verfahren zum Ziehen von Leiterbahnen umformen.
  • Um die Führung zu entfernen, doppelklicken Sie auf ein beliebiges Segment, um es auszuwählen, und drücken Sie anschließend die Taste Delete.

Leiterbahnabstand innerhalb der Routing-Führung

Mit der Funktion „Leiterbahnabstand in der Routing-Führung“ können Sie ActiveRoute anweisen, die Leiterbahnen über die Breite der Routing-Führung zu verteilen. Wählen Sie mit dem Schieberegler einen Abstandswert aus oder geben Sie einen Wert in das Eingabefeld ein. Die Größe der Routing-Führung wird automatisch an diese Einstellung angepasst. Dazu müssen Sie die Einstellung Track-Track Space in Route Guide vor dem Platzieren der Routing-Führung konfigurieren. Sie können die Breite der Routing-Führung während der Platzierung durch Drücken der Tasten  Keyboard Up arrow key und  Keyboard Down arrow key weiter anpassen.

Verwenden Sie die Funktion „Leiterbahnabstand“, um die Leiterbahnen in der Routing-Führung aufzufächern.
Verwenden Sie die Funktion „Leiterbahnabstand“, um die Leiterbahnen in der Routing-Führung aufzufächern.

Umwege beim Routing zulassen

ActiveRoute versucht, die ausgewählten Verbindungen auf dem kürzestmöglichen Pfad zu routen, also mit möglichst wenigen Umwegen. Wenn die Abschlussrate von ActiveRoute niedriger als erwartet ist, können Sie mit dem Regler „Meander“ den für ActiveRoute zulässigen Umfang an Umwegen erhöhen, was die Abschlussrate verbessern kann. Die standardmäßige maximale Meander-Einstellung beträgt 100 %. Das bedeutet, dass die Leiterbahnen eine Gesamtlänge von Manhattan Length + 100% of Manhattan Length haben dürfen. Wählen Sie mit dem Schieberegler einen Wert für die zulässigen Umwege aus oder geben Sie einen Prozentsatz in das Eingabefeld ein.

Beachten Sie, dass die Meander-Einstellung bei Verwendung der Routing-Führung ignoriert wird, da die Routing-Führung dazu dient, einen Pfad zu definieren, der erheblich größere Umwege vorgeben kann. 

Abstimmen der Leiterbahnlängen

ActiveRoute kann einen Längenabgleich für die gerade gerouteten Verbindungen oder für ausgewählte vorhandene Leiterbahnen durchführen. Dabei versucht ActiveRoute, die ausgewählte Designregel „Matched Lengths“ einzuhalten.

So konfigurieren Sie ActiveRoute für den Längenabgleich:

  • Aktivieren Sie das Kontrollkästchen Tune Selected im Bereich Action des Panels.

  • Aktivieren Sie die erforderliche Designregel „Matched Lengths“ im Bereich Tune des Panels.

  • Konfigurieren Sie die erforderlichen Einstellungen für Max Amplitude und Min Space (entweder Single-Ended oder Differenzialpaar) im Bereich Tune des Panels.

PCB ActiveRoute panel, Tune section is used to configure the tuning shapes added by ActiveRoute to match the route lengths

Derzeit ist nur der Abgleichsstil „Mitered Lines“ mit einer Eckenabschrägung von etwa 20 % verfügbar. Die von ActiveRoute platzierten Mäander sind zudem keine Unions. Die Unterstützung des Längenabgleichs durch ActiveRoute wird kontinuierlich weiterentwickelt. Dabei werden weitere Abgleichsstile und Mäander-Unions geprüft.

► Weitere Informationen zu den Einstellungen für den Längenabgleich mit ActiveRoute finden Sie im Abschnitt Längenabgleich auf der Seite zum PCB ActiveRoute-Panel.

► Weitere Informationen zum Längenabgleich vorhandener Leiterbahnen mithilfe anpassbarer Mäanderformen finden Sie im Artikel Längenabgleich.

Pin-Tausch

Die Software verfügt über ein leistungsstarkes System zum Tauschen von Pins und Bauteilsektionen, das Schaltplan- und PCB-Editor miteinander verknüpft. ActiveRoute kann auf die Einstellungen für den Pin-Tausch zugreifen und während des Routings Pins tauschen, wenn dadurch die gesamte Leiterbahnlänge reduziert und die Routing-Qualität verbessert wird.

So verwenden Sie den Pin-Tausch:

  • Bevor ein Pin-Tausch durchgeführt werden kann (interaktiv oder durch ActiveRoute), muss das Projekt nach jedem Öffnen kompiliert werden (Menü Project).
  • Um die Einstellungen für den Pin-Tausch von Bauteilen zu konfigurieren und zu verwalten, führen Sie den Befehl Tools » Pin/Part Swapping » Configure aus, um das Dialogfeld Configure Swapping Information in Components zu öffnen.
  • Aktivieren Sie die Option Pin Swap Routing im Bereich Action des PCB ActiveRoute-Panels.
  • Aktivieren Sie die gewünschten Bauteile im Bereich Pin Swap des PCB ActiveRoute-Panels.

Weitere Informationen zum Pin-Tausch finden Sie unter Pin-, Paar- und Bauteilsektionstausch.

Vorbereitung für ActiveRoute

ActiveRoute kann die Gloss-Funktion (Route » Gloss Selected) nutzen. Diese wird im Rahmen des ActiveRoute-Vorgangs automatisch ausgeführt, wenn sie im Panel PCB ActiveRoute aktiviert ist.

Der häufigste Grund für ein Scheitern von ActiveRoute ist unzureichender Platz für die Leiterbahn(en). Daher ist es wichtig, dass die Breiten- und Abstandsregeln korrekt konfiguriert sind.

ActiveRoute ausführen

So führen Sie ActiveRoute aus:

Ihre Fähigkeiten ausbauen

  1. Ein wesentlicher Faktor für den sicheren Umgang mit ActiveRoute ist die routinierte Verwendung der Tastenkürzel. Die folgenden Tastenkombinationen werden Sie am häufigsten verwenden:

    • Alt+Click – zum Auswählen einer einzelnen Verbindungslinie.
    • Alt+Click&Drag – zum Auswählen von Verbindungen innerhalb eines Bereichs. Ziehen Sie von rechts nach links, um alle berührten Verbindungen auszuwählen, oder von links nach rechts, um nur die Verbindungen auszuwählen, die vollständig im Auswahlrechteck liegen. Drücken Sie Tab, um die Auswahl um weitere Verbindungen desselben Netzes bzw. derselben Netze zu erweitern. Die Statusleiste zeigt die Anzahl der gerade ausgewählten Verbindungen an, bis der Mauszeiger über ein anderes Objekt bewegt wird.
    • Ctrl+Click&Drag – zum Auswählen von Pads eines Bauteils. Ziehen Sie von rechts nach links, um alle berührten Pads auszuwählen, oder von links nach rechts, um nur die Pads auszuwählen, die vollständig im Auswahlrechteck liegen. Drücken Sie Tab, um die Auswahl um weitere Routing-Objekte desselben Netzes bzw. derselben Netze zu erweitern. Drücken Sie wiederholt Tab, um alle möglichen Auswahlzustände zu durchlaufen.
    • Click&Drag – zum Auswählen vorhandener Leiterbahnsegmente. Ziehen Sie von rechts nach links, um alle berührten Leiterbahnen auszuwählen, oder von links nach rechts, um nur die Leiterbahnen auszuwählen, die vollständig im Auswahlrechteck liegen. Drücken Sie Tab, um die Auswahl um weitere Routing-Objekte desselben Netzes bzw. derselben Netze zu erweitern. Drücken Sie wiederholt Tab, um alle möglichen Auswahlzustände zu durchlaufen.
    • Halten Sie zusätzlich Shift gedrückt, um die aktuelle Auswahl beizubehalten, während Sie eine weitere Auswahl vornehmen.
    • Shift+A zum Routen der aktuellen Auswahl mit ActiveRoute.
    • Ctrl+Alt+G – zum Glätten der aktuellen Auswahl.
  2. Auswahlaktionen werden nur auf sichtbare Objekte angewendet (mit Ausnahme von Ctrl+A):

    • Drücken Sie Shift+S, um in den Einzellagenmodus zu wechseln bzw. ihn zu verlassen, sodass nur die gewünschte Lage angezeigt wird.
    • Wenn im Design Platzierungsräume verwendet werden, können diese im Rahmen ihrer Definition in den Designregeln gesperrt oder ausgeblendet werden, damit sie bei Klick-und-Zieh-Aktionen nicht ausgewählt oder verschoben werden. Räume können auf der Registerkarte View Options des Panels View Configuration ausgeblendet werden.
  3. Fanout für SMD-Pads erstellen. ActiveRoute wechselt keine Lagen, daher müssen Sie für SMD-Pads ein Fanout erstellen. So beschleunigen Sie den Fanout-Vorgang:

    • Drücken Sie beim Routen einer Verbindung das Tastenkürzel / (Ziffernblock), um ein Via zu platzieren und diese Verbindung zu beenden. Verwenden Sie das Tastenkürzel 2, wenn Sie keinen Ziffernblock haben (platziert ein Via, ohne das Routing zu unterbrechen).
    • Kopieren Sie ein vorhandenes Fanout und fügen Sie es ein; der PCB-Editor aktualisiert die Netznamen automatisch. Dies ist auch für mehrere Fanouts gleichzeitig möglich.
  4. Vorhandene Fanouts beibehalten. ActiveRoute ändert Fanouts, wenn es eine bessere Lösung findet. Sperren Sie die Fanouts, wenn sie nicht geändert werden sollen. Am einfachsten sperren Sie Fanouts, indem Sie die zugehörigen Leiterbahnen und Vias auswählen (verwenden Sie dazu Selection Filter oben im Panel Properties), mit F11 das Panel Properties öffnen und das Kontrollkästchen Locked aktivieren. Dadurch werden alle ausgewählten Objekte in einem Schritt gesperrt.

  5. Wenn Sie einen Route Guide verwenden und der Fertigstellungsgrad niedrig ist, befinden sich möglicherweise zu viele Hindernisse entlang des Pfads und der Guide muss breiter sein. Drücken Sie während der Platzierung die Pfeiltaste Up, um den Guide zu verbreitern.

  6. Nach Abschluss führt ActiveRoute eine Glättung durch (sofern diese im Panel PCB ActiveRoute aktiviert ist). Um die Leiterbahnen im Zustand unmittelbar nach Abschluss des ActiveRouting zu prüfen, drücken Sie einmal Ctrl+Z, um die Glättung rückgängig zu machen. Mit dem Befehl Gloss (Route » Gloss Selected) können Sie Leiterbahnen glätten und die Pad-Anbindungen beliebiger Routings verbessern, nicht nur die von ActiveRoute. Besonderes Augenmerk wurde auf hochwertige Pad-Anbindungen für differenzielle Paare gelegt. Weitere Informationen zur Glättung finden Sie auf der Seite Glätten und Nachverfolgen vorhandener Leiterbahnen.

  7. Wenn ActiveRoute nicht funktioniert, liegt dies meist an nicht korrekt konfigurierten Regeln. Der häufigste Grund für ein Scheitern von ActiveRoute ist, dass nicht genügend Platz für die Leiterbahn(en) vorhanden ist. Prüfen Sie, ob die Regeln geeignet sind. Beispielsweise können die Standardvorgaben in einer neuen PCB-Datei für ein hochdichtes BGA-Design zu groß sein.

  8. ActiveRoute berücksichtigt die Routing-Regeln für Leiterbahnbreiten, Abstände und Abstände innerhalb differenzieller Paare sowie lagen-, raum- und klassenspezifische Regeln. ActiveRoute routet nicht mit Kreisbögen oder Leiterbahnen in beliebigen Winkeln.

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Nav
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents