ActiveRoute

A colpo d'occhio

Questo articolo spiega come ActiveRoute in Altium Designer consente di velocizzare lo sbroglio dei PCB combinando l'automazione con il controllo del progettista, anziché affidarsi a un autorouter tradizionale. Descrive che cos'è ActiveRoute, che cosa non è, i principali vantaggi che offre e come utilizzare il pannello PCB ActiveRoute per selezionare le net, definire le guide di sbroglio, scegliere i layer, abilitare l'ottimizzazione delle piste, la regolazione delle lunghezze e lo scambio dei pin, e modificare il comportamento dello sbroglio. Se vuoi capire meglio come ottenere uno sbroglio più rapido, pulito e conforme alle regole, mantenendo il controllo del processo, questa guida ti mostrerà da dove iniziare. Continua a leggere per scoprire come ActiveRoute può migliorare il tuo flusso di lavoro.

- Scopri in che cosa ActiveRoute si differenzia da un autorouter e perché è più adatto allo sbroglio guidato e di alta qualità delle net selezionate.
- Esplora le principali funzionalità di ActiveRoute, tra cui le guide di sbroglio, lo sbroglio multistrato, l'ottimizzazione delle piste, la regolazione delle lunghezze, il controllo delle serpentine e lo scambio dei pin.
- Scopri come utilizzare il pannello PCB ActiveRoute per configurare ed eseguire ActiveRoute in base alle regole di progettazione e agli obiettivi di sbroglio.
Approfondisci con l'IA:

Concept image showing routing

Una delle fasi più dispendiose in termini di tempo nella progettazione di una scheda è lo sbroglio delle net. Mentre il sistema di regole gestisce i vincoli di progettazione, come larghezze, dimensioni dei via, distanze di isolamento e così via, spetta al progettista posizionare le migliaia di segmenti di pista necessari per sbrogliare completamente una scheda.

Gli sbrogliatori automatici possono alleggerire questo compito, ma sono generalmente considerati inadeguati perché:

  • Non tengono correttamente conto della miriade di sottili vincoli di progettazione che un progettista applica istintivamente durante lo sbroglio.

  • Richiedono così tanto tempo per essere configurati completamente che spesso è più efficiente procedere direttamente con lo sbroglio interattivo della scheda.

  • Le operazioni di rifinitura possono essere così lunghe e difficili che spesso è più efficiente sbrogliare la scheda in modo interattivo.

Il Santo Graal dello sbroglio dei PCB è produrre rapidamente risultati di alta qualità, conformi alle regole di progettazione, sotto il controllo del progettista. Questa è la sfida che ActiveRoute si propone di affrontare.

Improving the Completed Routes

Le funzionalità Glossing e Retrace sono complementari ad ActiveRoute, ma indipendenti da esso. Possono essere utilizzate per migliorare la qualità di qualsiasi sbroglio esistente, indipendentemente da come è stato creato.

Glossing è attivo per impostazione predefinita e viene eseguito al termine di ActiveRoute; se necessario, può essere disattivato nel pannello PCB ActiveRoute. Glossing dispone inoltre di una propria serie di opzioni, tra cui la possibilità di arrotondare gli angoli delle piste.

► Scopri di più su Glossing e Retrace dei percorsi esistenti

Che cos'è ActiveRoute?

ActiveRoute è una tecnologia di sbroglio interattivo automatizzato che offre efficienti algoritmi di sbroglio multi-net, applicati alle net o alle connessioni specifiche selezionate. ActiveRoute consente inoltre al progettista di definire in modo interattivo un percorso di sbroglio, o guida, che a sua volta definisce the river lungo cui passeranno le nuove piste.

Le principali funzionalità di ActiveRoute che rendono questo approccio nettamente migliore rispetto a una combinazione di sbroglio interattivo tradizionale e sbroglio automatico includono:

  • Ottimizzazione automatica dei percorsi di uscita dalle matrici di pin/via, l'aspetto che richiede più tempo nello sbroglio manuale.
  • Prestazioni elevate: sbroglio delle net di segnale in < 1 secondo ciascuna.
  • Rispetto delle regole di progettazione relative a larghezza, distanza di isolamento, layer, topologia e room per net e classe di net, tenendo conto delle priorità.
  • Sbroglio simultaneo su più layer e distribuzione delle piste tra questi layer.
  • Una Route Guide intuitiva che il progettista può utilizzare per guidare il posizionamento delle piste.
  • Utilizzo di un approccio River Route per ottenere elevate percentuali di completamento senza necessità di via.
  • Capacità di sbrogliare attraverso i piani poligonali e ricalcolarne il riempimento (se l'opzione di ricalcolo del riempimento è abilitata).
  • Supporto sia delle net single-ended sia delle coppie differenziali.
  • Rifinitura finale con un potente strumento di glossing che riduce ulteriormente il numero di angoli e accorcia le piste.

Cosa non è ActiveRoute

ActiveRoute non è uno sbrogliatore automatico. È uno sbrogliatore interattivo guidato che si concentra sullo sbroglio pulito e di alta qualità di un insieme di net selezionate. Utilizza ActiveRoute con lo stesso approccio che adotteresti per lo sbroglio interattivo: scegli le net di interesse, abilita i layer sui quali desideri sbrogliarle, valuta il percorso che dovrebbero seguire e procedi allo sbroglio.

Se selezioni tutte le net della scheda e le sbrogli con ActiveRoute, è probabile che il risultato sia deludente. ActiveRoute non è uno sbrogliatore automatico; non può posizionare via e non include strategie per lo sbroglio delle net di alimentazione.

Il pannello PCB ActiveRoute

ActiveRoute segue i criteri e le restrizioni definiti dalle regole di progettazione del PCB, quindi per utilizzarlo è sufficiente selezionare le connessioni o le net di interesse ed eseguirlo. Dispone comunque di una serie di funzioni di controllo specifiche configurabili nel pannello PCB ActiveRoute. Il pannello PCB ActiveRoute consente di configurare e utilizzare le varie funzionalità offerte da ActiveRoute, tra cui: eseguire uno sbroglio interattivo con ActiveRoute; definire una Route Guide e la spaziatura delle piste al suo interno; abilitare la regolazione automatica delle lunghezze; e abilitare lo scambio automatico dei pin. Si consiglia vivamente di aprire il pannello PCB ActiveRoute prima di avviare ActiveRoute.

Per aprire il pannello PCB ActiveRoute quando il documento attivo è un PCB: 

  • Fai clic sul pulsante  Panels button, click to enable the display of workspace panels available in the current editor in basso a destra nell'area di lavoro, quindi seleziona l'opzione di menu PCB ActiveRoute.

  • Fai clic su View » Panels » PCB ActiveRoute.

Per accedere alle funzionalità di ActiveRoute in Altium Designer, è necessario installare l'estensione software ActiveRoute . È possibile installarla o rimuoverla manualmente.

Per ulteriori informazioni sulla gestione delle estensioni, consulta la pagina Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Utilizza il pannello PCB ActiveRoute per controllare il processo di ActiveRoute.Utilizza il pannello PCB ActiveRoute per controllare il processo di ActiveRoute.

Il pannello PCB ActiveRoute consente di:

  • Abilitare i layer di segnale sui quali ActiveRoute può sbrogliare le connessioni.
  • Eseguire uno sbroglio con ActiveRoute sulle connessioni selezionate.
  • Abilitare un passaggio di Glossing dopo l'esecuzione di ActiveRoute.
  • Definire una Route Guide.
    • Configurare la spaziatura tra le piste da utilizzare all'interno della Route Guide.
  • Configurare e abilitare la regolazione delle lunghezze delle piste posizionate da ActiveRoute.
  • Configurare l'opzione Meander, che consente ad ActiveRoute di definire un percorso di sbroglio più lungo e può contribuire ad aumentare la percentuale di completamento.
  • Configurare e abilitare lo scambio dei pin. ActiveRoute può scambiare i pin durante lo sbroglio per contribuire a migliorare la qualità del risultato.
ActiveRoute opera sulle connessioni selezionate; alcuni controlli del pannello diventano attivi solo quando sono selezionate delle connessioni.

Il contenuto del pannello PCB ActiveRoute è organizzato in sezioni comprimibili, che si aprono e si chiudono tramite l'icona ► associata al titolo di ciascuna sezione. Le informazioni sui controlli delle proprietà riportate di seguito sono organizzate in sezioni corrispondenti e ogni sezione comprimibile si apre e si chiude nello stesso modo.

Funzionalità aggiuntive di ActiveRoute

ActiveRoute è uno strumento di sbroglio interattivo automatizzato e il suo utilizzo è semplice e immediato: seleziona le connessioni, quindi premi Shift+A per instradarle con ActiveRoute nel rispetto delle regole di progettazione. ActiveRoute include numerose altre funzionalità e controlli che offrono al progettista un maggiore controllo su determinate funzioni e capacità.

Tra queste:

  • Definire il percorso di sbroglio e la spaziatura delle piste posizionando una Route Guide.
  • Consentire un percorso più lungo tramite il controllo Meander.
  • Uniformare automaticamente le lunghezze delle piste mediante la regolazione della lunghezza.
  • Consentire lo scambio dei pin per semplificare lo sbroglio.

Esaminiamo ciascuna di queste funzionalità più nel dettaglio.

Definire il percorso con la Route Guide

Uno degli obiettivi principali di ActiveRoute è trovare l'insieme di percorsi con la lunghezza complessiva minima, che potrebbe non corrispondere al percorso desiderato per ogni gruppo di connessioni. La Route Guide offre al progettista uno strumento per tracciare un percorso specifico lungo il quale far passare le connessioni selezionate, anche se non è il più breve.

  • Defining the Route Guide - seleziona innanzitutto le connessioni da instradare all'interno della guida, quindi fai clic su  Route Guide button, click to define a route guide that ActiveRoute will then attempt to route the selected nets along pulsante nel pannello PCB ActiveRoute, quindi fare clic per definire il punto iniziale della guida e continuare a spostare il mouse e fare clic per definire il percorso. Una volta definito il percorso, fare clic sul pulsante ActiveRoute per instradare le connessioni selezionate lungo tale percorso. Per ulteriori dettagli, consultare la sezione Definire una guida di instradamento più avanti in questa pagina.

Evitare di posizionare i punti terminali della guida di instradamento sui pad da instradare. La qualità delle uscite dai pad sarà migliore se questi non sono inclusi nella guida di instradamento.

  • Changing the Route Guide Width - durante il posizionamento della guida di instradamento, è possibile allargarla o restringerla premendo i tasti  Keyboard Up arrow key o  Keyboard Down arrow key. La larghezza predefinita è la somma delle regole di progettazione applicabili relative a larghezza e distanza di isolamento per le connessioni selezionate, divisa per il numero di layer e moltiplicata per 1,3. Premere il tasto Backspace per annullare progressivamente la guida se occorre definire un percorso diverso.
  • The Route Guide color - determinato dai layer resi disponibili per l'instradamento con ActiveRoute delle connessioni selezionate. Se è abilitato un solo layer, la guida viene disegnata nel colore di quel layer; se sono abilitati più layer, viene disegnata nel colore predefinito della guida di instradamento.
  • The track spacing within the Route Guide - per impostazione predefinita, ActiveRoute distanzia le piste in base alle regole di progettazione, senza tentare di distribuirle o di utilizzare tutto lo spazio disponibile all'interno della guida di instradamento. Per distribuire le piste all'interno di una guida di instradamento, utilizzare la funzione Distanza tra piste nella guida di instradamento, come descritto più avanti in questa pagina.

Un video che mostra il posizionamento di una guida di instradamento, con la larghezza modificata interattivamente durante il posizionamento.
Un video che mostra il posizionamento di una guida di instradamento, con la larghezza modificata interattivamente durante il posizionamento.

Larghezza della guida di instradamento

La larghezza predefinita è la somma delle regole di progettazione applicabili relative a larghezza e distanza di isolamento per le connessioni selezionate, divisa per il numero di layer e moltiplicata per 1,3. 

  • RouteGuideWidth = ((W+C)/#Layers)*1.3)
  • La guida viene ampliata di un fattore predefinito di 1,3 per garantire che le piste possano essere contenute al suo interno e aggirare gli ostacoli presenti lungo il percorso, come i via. La larghezza costituisce un limite invalicabile per l'instradamento; se le piste non rientrano nello spazio disponibile, non vengono posizionate.
  • Durante il posizionamento della guida, è possibile aumentarne o diminuirne la larghezza premendo i tasti  Keyboard Up arrow key o  Keyboard Down arrow key sulla tastiera. La dimensione minima utilizza un moltiplicatore di 1,0; la dimensione massima utilizza un moltiplicatore di 10,0.

Modifica della guida

La guida di instradamento è un insieme di piste posizionate su un layer meccanico.

  • I segmenti di pista sono bloccati per impostazione predefinita. Sbloccandoli, è possibile modificare la forma della guida utilizzando le tecniche standard di trascinamento delle piste.
  • Per rimuovere la guida, fare doppio clic su un segmento qualsiasi per selezionarla, quindi premere il tasto Delete.

Distanza tra piste all'interno della guida di instradamento

Utilizzando la funzione Distanza tra piste nella guida di instradamento, è possibile indicare ad ActiveRoute di distribuire le piste su tutta la larghezza della guida. Utilizzare il cursore per selezionare un valore di spaziatura oppure digitare un valore nel campo di modifica. La guida di instradamento verrà dimensionata automaticamente per tenere conto di questa impostazione. A tale scopo, è necessario configurare l'impostazione Track-Track Space in Route Guide prima di posizionare la guida di instradamento. È possibile regolare ulteriormente la larghezza della guida durante il posizionamento premendo i tasti  Keyboard Up arrow key e  Keyboard Down arrow key.

Utilizzare la funzione Distanza tra piste per distribuire le piste nella guida di instradamento.
Utilizzare la funzione Distanza tra piste per distribuire le piste nella guida di instradamento.

Consentire percorsi più tortuosi

ActiveRoute tenta di instradare le connessioni selezionate lungo il percorso più breve possibile, ovvero con il minor numero possibile di deviazioni. Se la percentuale di completamento di ActiveRoute è inferiore al previsto, il controllo Meander consente di aumentare il grado di tortuosità consentito ad ActiveRoute, il che può contribuire ad aumentare la percentuale di completamento. L'impostazione massima predefinita di Meander è 100%, il che significa che le piste possono avere una lunghezza totale di Manhattan Length + 100% of Manhattan Length. Utilizzare il cursore per selezionare un valore di tortuosità oppure digitare una percentuale nel campo di modifica.

Si noti che l'impostazione della tortuosità viene ignorata quando si utilizza la guida di instradamento, poiché quest'ultima è concepita per definire un percorso che può aumentare notevolmente la tortuosità. 

Regolazione delle lunghezze delle piste

ActiveRoute può applicare la regolazione della lunghezza alle connessioni in fase di instradamento o a piste esistenti selezionate. ActiveRoute tenterà di soddisfare la regola di progettazione Lunghezze corrispondenti selezionata.

Per configurare ActiveRoute per la regolazione della lunghezza:

  • Abilitare la casella di controllo Tune Selected nella sezione Action del pannello.

  • Abilitare la regola di progettazione Lunghezze corrispondenti richiesta nella sezione Tune del pannello.

  • Configurare le impostazioni Max Amplitude e Min Space richieste (a terminazione singola o a coppia differenziale) nella sezione Tune del pannello.

PCB ActiveRoute panel, Tune section is used to configure the tuning shapes added by ActiveRoute to match the route lengths

Attualmente è disponibile solo lo stile di regolazione Linee smussate, con uno smusso degli angoli di circa il 20%. Inoltre, le serpentine posizionate da ActiveRoute non sono unioni. Il supporto di ActiveRoute per la regolazione della lunghezza è in continuo sviluppo e sono in fase di valutazione altri stili di regolazione e unioni di serpentine.

► Per ulteriori informazioni sulle impostazioni di regolazione della lunghezza di ActiveRoute, consultare la sezione Regolazione della lunghezza nella pagina del pannello PCB ActiveRoute.

► Per ulteriori informazioni sulla regolazione della lunghezza delle piste esistenti mediante serpentine regolabili, consultare l'articolo Regolazione della lunghezza.

Scambio dei pin

Il software include un potente sistema di scambio di pin e parti, collegato tra gli editor dello schema e del PCB. ActiveRoute può accedere alle impostazioni di scambio dei pin e scambiare i pin durante l'instradamento se ciò riduce la lunghezza complessiva delle piste e migliora la qualità dell'instradamento.

Per utilizzare lo scambio dei pin:

  • Prima di poter eseguire qualsiasi scambio di pin (interattivamente o tramite ActiveRoute), è necessario compilare il progetto (menu Project) ogni volta che viene aperto.
  • Per configurare e gestire le impostazioni di scambio dei pin per i componenti, eseguire il comando Tools » Pin/Part Swapping » Configure per aprire la finestra di dialogo Configure Swapping Information in Components.
  • Abilitare l'opzione Pin Swap Routing nella sezione Action del pannello PCB ActiveRoute.
  • Abilitare i componenti richiesti nella sezione Pin Swap del pannello PCB ActiveRoute.

Per ulteriori informazioni sulla funzione di scambio dei pin, consultare Scambio di pin, coppie e parti.

Preparazione all'uso di ActiveRoute

ActiveRoute può utilizzare la funzione Gloss (Route » Gloss Selected), che viene eseguita automaticamente durante il processo ActiveRoute se è abilitata nel pannello PCB ActiveRoute .

La causa più comune di un mancato instradamento con ActiveRoute è lo spazio insufficiente per le piste; pertanto, è importante assicurarsi che le regole di larghezza e distanza di isolamento siano configurate correttamente.

Eseguire un instradamento con ActiveRoute

Per eseguire un instradamento con ActiveRoute:

Migliorare la propria padronanza

  1. Un elemento fondamentale per padroneggiare ActiveRoute è acquisire dimestichezza con le scorciatoie. Le sequenze di tasti che utilizzerai più spesso sono:

    • Alt+Click - per selezionare una singola linea di connessione.
    • Alt+Click&Drag - per selezionare le connessioni all'interno di un'area, trascina da destra a sinistra per selezionare tutte le connessioni toccate, oppure da sinistra a destra per selezionare solo quelle interamente contenute nel rettangolo di selezione. Premi Tab per estendere la selezione ad altre connessioni appartenenti alle stesse net. La barra di stato mostrerà il numero di connessioni appena selezionate finché il cursore non passerà su un altro oggetto.
    • Ctrl+Click&Drag - per selezionare le piazzole di un componente, trascina da destra a sinistra per selezionare tutte le piazzole toccate, oppure da sinistra a destra per selezionare solo quelle interamente contenute nel rettangolo di selezione. Premi Tab per estendere la selezione ad altri oggetti di routing appartenenti alle stesse net. Continua a premere Tab per scorrere tutti i possibili stati di selezione.
    • Click&Drag - per selezionare segmenti di pista esistenti, trascina da destra a sinistra per selezionare tutte le piste toccate, oppure da sinistra a destra per selezionare solo quelle interamente contenute nel rettangolo di selezione. Premi Tab per estendere la selezione ad altri oggetti di routing appartenenti alle stesse net. Continua a premere Tab per scorrere tutti i possibili stati di selezione.
    • Includi Shift per mantenere la selezione corrente mentre ne esegui un'altra.
    • Shift+A per eseguire ActiveRoute sulla selezione corrente.
    • Ctrl+Alt+G - per applicare il glossing alla selezione corrente.
  2. Le azioni di selezione vengono eseguite solo sugli oggetti visibili (ad eccezione di Ctrl+A):

    • Premi Shift+S per attivare o disattivare la modalità a singolo layer in modo da visualizzare solo il layer di interesse.
    • Se il progetto utilizza room di posizionamento, queste possono essere bloccate durante la loro definizione nelle regole di progettazione oppure nascoste per evitare che vengano selezionate o spostate durante le operazioni di clic e trascinamento. Le room possono essere nascoste nella scheda View Options del pannello View Configuration.
  3. Esegui il fanout delle piazzole SMD. ActiveRoute non cambia layer, quindi dovrai eseguire il fanout delle piazzole SMD. Per accelerare il processo di fanout:

    • Durante lo sbroglio di una connessione, premi la scorciatoia / (tastierino numerico) per posizionare un via e terminare lo sbroglio di questa connessione. Utilizza la scorciatoia 2 se non disponi di un tastierino numerico (posiziona un via senza interrompere lo sbroglio).
    • Copia e incolla un fanout esistente; l'editor PCB aggiornerà automaticamente i nomi delle net. Questa operazione può essere eseguita su più fanout.
  4. Preserva i fanout esistenti. ActiveRoute modifica i fanout se individua una soluzione migliore; se non vuoi che vengano modificati, bloccali. Il modo più semplice per bloccare i fanout è selezionare le piste e i via del fanout (utilizza Selection Filter nella parte superiore del pannello Properties per facilitare questa operazione), premere F11 per aprire il pannello Properties e abilitare la casella di controllo Locked. In questo modo tutti gli oggetti selezionati verranno bloccati con un'unica operazione.

  5. Se utilizzi una Route Guide e noti una bassa percentuale di completamento, potrebbero esserci troppi ostacoli lungo il percorso e potrebbe essere necessario allargare la guida. Premi il tasto freccia Up per allargare la guida durante il posizionamento.

  6. Al termine, ActiveRoute applica il glossing (se abilitato nel pannello PCB ActiveRoute). Per esaminare le piste così com'erano al termine di ActiveRouting, premi Ctrl+Z una volta per annullare il glossing. Il comando Gloss (Route » Gloss Selected) può essere utilizzato per rendere più regolari le piste e migliorare gli ingressi nelle piazzole di qualsiasi tracciato, non solo di quelli generati da ActiveRoute. Particolare attenzione è stata dedicata a garantire ingressi nelle piazzole di alta qualità per le coppie differenziali. Per ulteriori informazioni sul glossing, consulta la pagina Glossing e ritracciamento delle piste esistenti.

  7. Se ActiveRoute non funziona, in genere è perché le regole non sono configurate correttamente. La causa più comune di insuccesso di ActiveRoute è la mancanza di spazio sufficiente per le piste. Verifica che le regole siano appropriate: ad esempio, le regole predefinite presenti in un nuovo file PCB potrebbero prevedere dimensioni troppo grandi per un progetto con BGA ad alta densità.

  8. ActiveRoute rispetta le regole di sbroglio configurate per larghezze, distanze di isolamento e spaziature delle coppie differenziali, per layer, per room e per classe. ActiveRoute non esegue lo sbroglio con archi o piste ad angolo libero.

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents