ActiveRoute
A colpo d'occhio
- Scopri in che cosa ActiveRoute si differenzia da un autorouter e perché è più adatto allo sbroglio guidato e di alta qualità delle net selezionate.
- Esplora le principali funzionalità di ActiveRoute, tra cui le guide di sbroglio, lo sbroglio multistrato, l'ottimizzazione delle piste, la regolazione delle lunghezze, il controllo delle serpentine e lo scambio dei pin.
- Scopri come utilizzare il pannello PCB ActiveRoute per configurare ed eseguire ActiveRoute in base alle regole di progettazione e agli obiettivi di sbroglio.
Una delle fasi più dispendiose in termini di tempo nella progettazione di una scheda è lo sbroglio delle net. Mentre il sistema di regole gestisce i vincoli di progettazione, come larghezze, dimensioni dei via, distanze di isolamento e così via, spetta al progettista posizionare le migliaia di segmenti di pista necessari per sbrogliare completamente una scheda.
Gli sbrogliatori automatici possono alleggerire questo compito, ma sono generalmente considerati inadeguati perché:
-
Non tengono correttamente conto della miriade di sottili vincoli di progettazione che un progettista applica istintivamente durante lo sbroglio.
-
Richiedono così tanto tempo per essere configurati completamente che spesso è più efficiente procedere direttamente con lo sbroglio interattivo della scheda.
-
Le operazioni di rifinitura possono essere così lunghe e difficili che spesso è più efficiente sbrogliare la scheda in modo interattivo.
Il Santo Graal dello sbroglio dei PCB è produrre rapidamente risultati di alta qualità, conformi alle regole di progettazione, sotto il controllo del progettista. Questa è la sfida che ActiveRoute si propone di affrontare.
Che cos'è ActiveRoute?
ActiveRoute è una tecnologia di sbroglio interattivo automatizzato che offre efficienti algoritmi di sbroglio multi-net, applicati alle net o alle connessioni specifiche selezionate. ActiveRoute consente inoltre al progettista di definire in modo interattivo un percorso di sbroglio, o guida, che a sua volta definisce the river lungo cui passeranno le nuove piste.
Le principali funzionalità di ActiveRoute che rendono questo approccio nettamente migliore rispetto a una combinazione di sbroglio interattivo tradizionale e sbroglio automatico includono:
- Ottimizzazione automatica dei percorsi di uscita dalle matrici di pin/via, l'aspetto che richiede più tempo nello sbroglio manuale.
- Prestazioni elevate: sbroglio delle net di segnale in < 1 secondo ciascuna.
- Rispetto delle regole di progettazione relative a larghezza, distanza di isolamento, layer, topologia e room per net e classe di net, tenendo conto delle priorità.
- Sbroglio simultaneo su più layer e distribuzione delle piste tra questi layer.
- Una Route Guide intuitiva che il progettista può utilizzare per guidare il posizionamento delle piste.
- Utilizzo di un approccio River Route per ottenere elevate percentuali di completamento senza necessità di via.
- Capacità di sbrogliare attraverso i piani poligonali e ricalcolarne il riempimento (se l'opzione di ricalcolo del riempimento è abilitata).
- Supporto sia delle net single-ended sia delle coppie differenziali.
- Rifinitura finale con un potente strumento di glossing che riduce ulteriormente il numero di angoli e accorcia le piste.
Il pannello PCB ActiveRoute
ActiveRoute segue i criteri e le restrizioni definiti dalle regole di progettazione del PCB, quindi per utilizzarlo è sufficiente selezionare le connessioni o le net di interesse ed eseguirlo. Dispone comunque di una serie di funzioni di controllo specifiche configurabili nel pannello PCB ActiveRoute. Il pannello PCB ActiveRoute consente di configurare e utilizzare le varie funzionalità offerte da ActiveRoute, tra cui: eseguire uno sbroglio interattivo con ActiveRoute; definire una Route Guide e la spaziatura delle piste al suo interno; abilitare la regolazione automatica delle lunghezze; e abilitare lo scambio automatico dei pin. Si consiglia vivamente di aprire il pannello PCB ActiveRoute prima di avviare ActiveRoute.
Per aprire il pannello PCB ActiveRoute quando il documento attivo è un PCB:
-
Fai clic sul pulsante
in basso a destra nell'area di lavoro, quindi seleziona l'opzione di menu PCB ActiveRoute.
-
Fai clic su View » Panels » PCB ActiveRoute.
Utilizza il pannello PCB ActiveRoute per controllare il processo di ActiveRoute.
Il pannello PCB ActiveRoute consente di:
- Abilitare i layer di segnale sui quali ActiveRoute può sbrogliare le connessioni.
- Eseguire uno sbroglio con ActiveRoute sulle connessioni selezionate.
- Abilitare un passaggio di Glossing dopo l'esecuzione di ActiveRoute.
-
Definire una Route Guide.
- Configurare la spaziatura tra le piste da utilizzare all'interno della Route Guide.
- Configurare e abilitare la regolazione delle lunghezze delle piste posizionate da ActiveRoute.
- Configurare l'opzione Meander, che consente ad ActiveRoute di definire un percorso di sbroglio più lungo e può contribuire ad aumentare la percentuale di completamento.
- Configurare e abilitare lo scambio dei pin. ActiveRoute può scambiare i pin durante lo sbroglio per contribuire a migliorare la qualità del risultato.
Il contenuto del pannello PCB ActiveRoute è organizzato in sezioni comprimibili, che si aprono e si chiudono tramite l'icona ► associata al titolo di ciascuna sezione. Le informazioni sui controlli delle proprietà riportate di seguito sono organizzate in sezioni corrispondenti e ogni sezione comprimibile si apre e si chiude nello stesso modo.
Azione
Queste sono le opzioni principali utilizzate per controllare ActiveRoute.
-
ActiveRoute - fai clic sul pulsante
nel pannello per eseguire uno sbroglio con ActiveRoute sulle connessioni selezionate. ActiveRoute tenta di sbrogliare le connessioni selezionate oppure, se sono selezionati pad o via, tutte le connessioni delle rispettive net. Consulta la pagina di ActiveRoute per saperne di più sulle tecniche di selezione.
-
Route Guide - una guida di sbroglio è un percorso definito dall'utente entro il quale ActiveRoute deve sbrogliare le connessioni selezionate. Uno degli obiettivi principali di ActiveRoute è trovare l'insieme di percorsi con la lunghezza complessiva minima, che potrebbe non corrispondere al percorso desiderato per ogni gruppo di connessioni. La Route Guide offre al progettista uno strumento per tracciare un percorso specifico lungo il quale far passare le connessioni selezionate. Il colore della Route Guide è determinato dai layer resi disponibili per lo sbroglio con ActiveRoute delle connessioni selezionate: se è abilitato un solo layer, viene disegnata nel colore di quel layer; se sono abilitati più layer, viene disegnata nel colore predefinito della Route Guide.
-
Per definire una Route Guide, seleziona prima le connessioni da sbrogliare all'interno della guida, quindi fai clic su
pulsante nel pannello, quindi fai clic per definire la posizione iniziale della guida e continua a spostare il mouse e a fare clic per definirne il percorso. Una volta definito il percorso, fai clic sul pulsante ActiveRoute per instradare le connessioni selezionate lungo tale percorso.
-
Durante il posizionamento della Route Guide, puoi allargare o restringere la guida premendo i tasti
o
. La larghezza predefinita è pari alla somma dei valori delle regole di progettazione applicabili relative a larghezza e distanza di isolamento per le connessioni selezionate, divisa per il numero di layer e moltiplicata per 1,3. Premi il tasto Backspace per annullare progressivamente la guida se devi definire un percorso diverso.
- ActiveRoute tenterà di distanziare le piste in conformità alle regole di progettazione, ma non cercherà di distribuirle su tutto lo spazio disponibile all'interno di una Route Guide. Per distribuire le piste all'interno di una Route Guide, utilizza la funzione Track-Track Space in Route Guide, come descritto più avanti in questa pagina.
-
Per definire una Route Guide, seleziona prima le connessioni da sbrogliare all'interno della guida, quindi fai clic su
-
Tune Selected - quando questa opzione è abilitata, viene applicata la regola Matched Lengths con la priorità più alta tra quelle applicabili abilitate nella sezione Tune del pannello.
-
Pin Swap Routing – lo scambio dei pin è supportato nell'editor PCB; abilita questa opzione per consentire ad ActiveRoute di scambiare i pin durante il processo di sbroglio. Oltre ad abilitare questa opzione, è necessario abilitare anche i componenti desiderati nella sezione Pin Swap del pannello, come descritto di seguito. Per ulteriori informazioni sul sistema di scambio dei pin, consulta la pagina Scambio di pin, coppie e parti.
-
Gloss Results – abilita questa opzione per ottimizzare automaticamente i risultati di ActiveRoute mediante Gloss. L'ottimizzazione può essere applicata anche a piste esistenti selezionate; a tale scopo, esegui il comando Route » Gloss Selected (Ctrl+Alt+G). Per ulteriori informazioni, consulta la pagina Ottimizzazione e ritracciamento delle piste esistenti.
Layer
ActiveRoute può eseguire lo sbroglio su più layer contemporaneamente. Sebbene non possa posizionare via per effettuare un cambio di layer, può distribuire connessioni e net sui layer disponibili. I layer disponibili vengono configurati nella sezione Layers del pannello.
- Show Signal Layers Only – per impostazione predefinita vengono mostrati tutti i layer di segnale e i layer dei piani disponibili; abilita questa opzione per visualizzare solo i layer di segnale.
- List of Layers – abilita i layer di segnale sui quali ActiveRoute può instradare i segnali. ActiveRoute distribuirà le connessioni sui layer di segnale disponibili. Nota che ActiveRoute non posiziona via per effettuare un cambio di layer.
Controllo
Questi controlli consentono di rendere meno rigido il criterio con cui ActiveRoute distanzia le piste per rispettare la regola di progettazione applicabile relativa alla distanza di isolamento, e di consentire l'uso di un percorso meno diretto per completare una connessione.
- Track-Track Space in Route Guide – questo controllo indica ad ActiveRoute a quale distanza tentare di distribuire le connessioni instradate lungo la Route Guide (dal centro di una pista al centro dell'altra). L'impostazione deve essere definita prima di tracciare la Route Guide, in modo che la larghezza della guida possa essere calcolata correttamente in base alla spaziatura. Utilizza il cursore per selezionare un valore oppure digita una distanza nella casella di modifica.
-
Meander % Over Manhattan Length – ActiveRoute tenta di instradare le connessioni selezionate lungo il percorso più breve possibile, ovvero utilizzando il minimo numero di deviazioni. Se la percentuale di completamento di ActiveRoute è inferiore alle aspettative, aumentare la quantità di deviazioni consentite può contribuire a migliorarla. L'impostazione massima predefinita di Meander è 100%, il che significa che le piste possono avere una lunghezza totale di
Manhattan Length + 100% of Manhattan Length. Utilizza il cursore per selezionare un valore oppure digita una percentuale nella casella di modifica. Nota che l'impostazione Meander viene ignorata quando si utilizza la Route Guide, poiché quest'ultima serve a definire un percorso che può aumentare notevolmente le deviazioni.
Regolazione
ActiveRoute può applicare la regolazione della lunghezza alle connessioni in fase di sbroglio oppure alle piste esistenti selezionate.
-
Match Length Rules for Selected – qui sono elencate tutte le regole di progettazione Matched Lengths definite. Abilita la regola che ActiveRoute deve utilizzare per le connessioni selezionate.
-
Single Ended – proprietà della serpentina da utilizzare per regolare la lunghezza dei segnali single-ended.
- Max Amplitude - ampiezza massima consentita della serpentina di regolazione. L'ampiezza viene ridotta automaticamente in presenza di ostacoli, come pad, via o piste esistenti, per garantire il rispetto delle distanze di isolamento previste dalle regole di progettazione.
- Min Space - distanza minima da bordo a bordo tra gli attraversamenti dello zero della serpentina.
-
Differential Pair - proprietà della serpentina da utilizzare per regolare la lunghezza delle coppie differenziali.
- Max Amplitude - ampiezza massima consentita della serpentina di regolazione per il membro esterno della coppia differenziale. L'ampiezza viene ridotta automaticamente in presenza di ostacoli al posizionamento, per garantire il rispetto delle distanze di isolamento previste dalle regole di progettazione.
- Min Space - distanza minima da bordo a bordo tra gli attraversamenti dello zero della serpentina per il membro interno della coppia differenziale.
Scambio dei pin
I pin funzionalmente equivalenti di un componente possono essere configurati come intercambiabili; per farlo, seleziona il comando Tools » Pin/Part Swapping » Configure. Prima di poter eseguire qualsiasi scambio di pin (in modo interattivo o tramite ActiveRoute), il progetto deve essere compilato (menu Project) ogni volta che viene aperto.
- Components with Pin Swap Enabled – qui vengono elencati tutti i componenti abilitati allo scambio dei pin; abilita quelli che desideri rendere disponibili per lo scambio automatico durante un'operazione di ActiveRoute.
Funzionalità aggiuntive di ActiveRoute
ActiveRoute è uno strumento di sbroglio interattivo automatizzato e il suo utilizzo è semplice e immediato: seleziona le connessioni, quindi premi Shift+A per instradarle con ActiveRoute nel rispetto delle regole di progettazione. ActiveRoute include numerose altre funzionalità e controlli che offrono al progettista un maggiore controllo su determinate funzioni e capacità.
Tra queste:
- Definire il percorso di sbroglio e la spaziatura delle piste posizionando una Route Guide.
- Consentire un percorso più lungo tramite il controllo Meander.
- Uniformare automaticamente le lunghezze delle piste mediante la regolazione della lunghezza.
- Consentire lo scambio dei pin per semplificare lo sbroglio.
Esaminiamo ciascuna di queste funzionalità più nel dettaglio.
Definire il percorso con la Route Guide
Uno degli obiettivi principali di ActiveRoute è trovare l'insieme di percorsi con la lunghezza complessiva minima, che potrebbe non corrispondere al percorso desiderato per ogni gruppo di connessioni. La Route Guide offre al progettista uno strumento per tracciare un percorso specifico lungo il quale far passare le connessioni selezionate, anche se non è il più breve.
-
Defining the Route Guide - seleziona innanzitutto le connessioni da instradare all'interno della guida, quindi fai clic su
pulsante nel pannello PCB ActiveRoute, quindi fare clic per definire il punto iniziale della guida e continuare a spostare il mouse e fare clic per definire il percorso. Una volta definito il percorso, fare clic sul pulsante ActiveRoute per instradare le connessioni selezionate lungo tale percorso. Per ulteriori dettagli, consultare la sezione Definire una guida di instradamento più avanti in questa pagina.
-
Changing the Route Guide Width - durante il posizionamento della guida di instradamento, è possibile allargarla o restringerla premendo i tasti
o
. La larghezza predefinita è la somma delle regole di progettazione applicabili relative a larghezza e distanza di isolamento per le connessioni selezionate, divisa per il numero di layer e moltiplicata per 1,3. Premere il tasto Backspace per annullare progressivamente la guida se occorre definire un percorso diverso.
- The Route Guide color - determinato dai layer resi disponibili per l'instradamento con ActiveRoute delle connessioni selezionate. Se è abilitato un solo layer, la guida viene disegnata nel colore di quel layer; se sono abilitati più layer, viene disegnata nel colore predefinito della guida di instradamento.
- The track spacing within the Route Guide - per impostazione predefinita, ActiveRoute distanzia le piste in base alle regole di progettazione, senza tentare di distribuirle o di utilizzare tutto lo spazio disponibile all'interno della guida di instradamento. Per distribuire le piste all'interno di una guida di instradamento, utilizzare la funzione Distanza tra piste nella guida di instradamento, come descritto più avanti in questa pagina.

Un video che mostra il posizionamento di una guida di instradamento, con la larghezza modificata interattivamente durante il posizionamento.
Distanza tra piste all'interno della guida di instradamento
Utilizzando la funzione Distanza tra piste nella guida di instradamento, è possibile indicare ad ActiveRoute di distribuire le piste su tutta la larghezza della guida. Utilizzare il cursore per selezionare un valore di spaziatura oppure digitare un valore nel campo di modifica. La guida di instradamento verrà dimensionata automaticamente per tenere conto di questa impostazione. A tale scopo, è necessario configurare l'impostazione Track-Track Space in Route Guide prima di posizionare la guida di instradamento. È possibile regolare ulteriormente la larghezza della guida durante il posizionamento premendo i tasti
e
.

Utilizzare la funzione Distanza tra piste per distribuire le piste nella guida di instradamento.
Consentire percorsi più tortuosi
ActiveRoute tenta di instradare le connessioni selezionate lungo il percorso più breve possibile, ovvero con il minor numero possibile di deviazioni. Se la percentuale di completamento di ActiveRoute è inferiore al previsto, il controllo Meander consente di aumentare il grado di tortuosità consentito ad ActiveRoute, il che può contribuire ad aumentare la percentuale di completamento. L'impostazione massima predefinita di Meander è 100%, il che significa che le piste possono avere una lunghezza totale di Manhattan Length + 100% of Manhattan Length. Utilizzare il cursore per selezionare un valore di tortuosità oppure digitare una percentuale nel campo di modifica.
Si noti che l'impostazione della tortuosità viene ignorata quando si utilizza la guida di instradamento, poiché quest'ultima è concepita per definire un percorso che può aumentare notevolmente la tortuosità.
Regolazione delle lunghezze delle piste
ActiveRoute può applicare la regolazione della lunghezza alle connessioni in fase di instradamento o a piste esistenti selezionate. ActiveRoute tenterà di soddisfare la regola di progettazione Lunghezze corrispondenti selezionata.
Per configurare ActiveRoute per la regolazione della lunghezza:
-
Abilitare la casella di controllo Tune Selected nella sezione Action del pannello.
-
Abilitare la regola di progettazione Lunghezze corrispondenti richiesta nella sezione Tune del pannello.
-
Configurare le impostazioni Max Amplitude e Min Space richieste (a terminazione singola o a coppia differenziale) nella sezione Tune del pannello.
Scambio dei pin
Il software include un potente sistema di scambio di pin e parti, collegato tra gli editor dello schema e del PCB. ActiveRoute può accedere alle impostazioni di scambio dei pin e scambiare i pin durante l'instradamento se ciò riduce la lunghezza complessiva delle piste e migliora la qualità dell'instradamento.
Per utilizzare lo scambio dei pin:
- Prima di poter eseguire qualsiasi scambio di pin (interattivamente o tramite ActiveRoute), è necessario compilare il progetto (menu Project) ogni volta che viene aperto.
- Per configurare e gestire le impostazioni di scambio dei pin per i componenti, eseguire il comando Tools » Pin/Part Swapping » Configure per aprire la finestra di dialogo Configure Swapping Information in Components.
- Abilitare l'opzione Pin Swap Routing nella sezione Action del pannello PCB ActiveRoute.
- Abilitare i componenti richiesti nella sezione Pin Swap del pannello PCB ActiveRoute.
Preparazione all'uso di ActiveRoute
1. Creare classi di net
ActiveRoute richiede che le net siano selezionate. La presenza di classi di net può agevolare notevolmente il processo di selezione quando è necessario instradare un numero elevato di net con ActiveRoute. Consultare la sezione Tecniche di selezione più avanti in questo articolo per ulteriori informazioni sui metodi migliori per selezionare le connessioni.
2. Sospendere i poligoni esistenti
ActiveRoute può instradare le piste attraverso i poligoni esistenti se l'opzione Repour Polygons after Modification è abilitata nella pagina PCB Editor - General della finestra di dialogo Preferences. In alternativa, i poligoni possono essere sospesi (resi invisibili, ma mantenuti nel progetto) utilizzando il comando Tools » Polygon Pours » Shelve Polygons.
3. Configurare le regole di progettazione
- Distanze di isolamento – ActiveRoute rispetta le regole di progettazione relative alle distanze di isolamento applicabili, applicandole in ordine di priorità.
- Larghezze di instradamento – Utilizza l'impostazione Preferred delle regole di larghezza applicabili. Come per l'instradamento interattivo, per modificare le larghezze in un'area, ad esempio quando il percorso passa sotto un BGA, definire una Room che applichi una regola di progettazione della larghezza con un valore Preferred più stretto. Se non è possibile instradare manualmente con la larghezza preferita, non potrà farlo nemmeno ActiveRoute.
- Coppie differenziali – ActiveRoute può instradare coppie differenziali. Assicurarsi che le coppie differenziali siano definite correttamente (verificare nella modalità Differential Pairs Editor del pannello PCB) e confermare che le regole Differential Pairs Routing siano configurate correttamente (vengono utilizzati i valori Preferred).
- Ingresso nei pad – ActiveRoute tenta di utilizzare il percorso più diretto in ingresso e in uscita da un pad che rispetti le regole senza creare angoli acuti. Rispetta le regole SMT to Corner e SMT Pad Entry, ma non centra sempre la pista nel pad (come fa l'Interactive Router quando la regola SMT to Corner è abilitata). Include algoritmi speciali per i pad delle coppie differenziali, che privilegiano l'accoppiamento della coppia mantenendo una disposizione ordinata.
4. Configurare la topologia delle net
ActiveRoute seguirà la disposizione delle linee di connessione. Se un insieme di net richiede una topologia specifica, ad esempio una topologia fly-by DDR3/4, è possibile definire l'ordine da origine a destinazione utilizzando xSignals. La procedura guidata xSignals Multi-Chip Wizard (Design » xSignals » Run xSignals Wizard) può creare xSignals per progetti che includono segnali di tipo DDR3/4 e USB 3.0. In alternativa, è possibile definire la disposizione delle linee di connessione punto-punto per una net creando dei From-To nella modalità From-To Editor del pannello PCB.
5. Eseguire il fanout del progetto
ActiveRoute non posiziona via, quindi è necessario creare i fanout per BGA, connettori e componenti discreti che utilizzano pin SMT (ad eccezione dei pin da instradare sugli strati esterni).
6. Instradare alimentazione e massa
ActiveRoute è destinato alle net di segnale; ignora le net assegnate ai piani di alimentazione e quelle che contengono più di 20 pin (che vengono considerate net di alimentazione). Se si desidera utilizzare ActiveRoute su un progetto già completato, eliminare le piste di segnale, ma mantenere l'instradamento di alimentazione e massa e i fanout.
7. Abilitare gli strati di instradamento necessari
Abilitare gli strati di instradamento necessari nel pannello PCB ActiveRoute. Ulteriori informazioni sono riportate di seguito.
Eseguire un instradamento con ActiveRoute
Per eseguire un instradamento con ActiveRoute:
1. Selezionare le connessioni da instradare
Utilizzando le tecniche descritte nella pagina Strategie per la selezione dell'instradamento, selezionare le connessioni/net da instradare. Le connessioni possono essere selezionate direttamente oppure selezionando un oggetto di instradamento, come un pin, una pista, un via o un componente. La barra di stato mostrerà il numero di connessioni appena selezionate finché il cursore non passerà sopra un altro oggetto.
- Quando si selezionano le connessioni, queste verranno instradate con la larghezza Preferred definita nella regola di progettazione Routing Width applicabile.
- Quando si seleziona un instradamento esistente, la connessione collegata alla pista selezionata verrà instradata utilizzando la larghezza di quella pista.
- Quando si selezionano i pad di un componente, tutte le connessioni dai pad selezionati verranno instradate con il valore Preferred della regola.
2. Abilitare gli strati su cui utilizzare ActiveRoute
Nel pannello PCB ActiveRoute, abilitare gli strati su cui devono essere instradate le connessioni selezionate. ActiveRoute distribuirà i percorsi su questi strati.
Se non è selezionato alcuno strato, l'instradamento verrà eseguito sullo strato attivo, corrispondente alla scheda selezionata nella parte inferiore della finestra principale dell'editor PCB.
Il pannello PCB ActiveRoute consente di selezionare gli strati su cui instradare, creare una guida di instradamento e avviare ActiveRoute.
3. Definire una guida di instradamento, se necessario
Per posizionare una guida di instradamento:
- Selezionare le connessioni che si desidera instradare lungo la guida. La barra di stato mostrerà il numero di connessioni appena selezionate finché il cursore non passerà sopra un altro oggetto.
- Fare clic sul pulsante Route Guide nel pannello PCB ActiveRoute.
- Il cursore apparirà come se stesse holding tutte le connessioni selezionate, indicando che questo insieme di connessioni deve passare attraverso la guida. Spostare il cursore in una posizione iniziale adatta, a una delle due estremità del percorso che si desidera definire.
- Fare clic per definire la posizione iniziale della guida, lasciando spazio sufficiente affinché le connessioni in ingresso possano confluire nell'estremità curva della guida.
- La guida viene posizionata come se fosse una pista molto larga. Spostare il cursore nella posizione della prima curva che la guida deve compiere, quindi fare clic per definirla.
- Continuare a definire il percorso in questo modo, fermandosi a una certa distanza dal punto in cui terminano le linee di connessione, lasciando spazio sufficiente affinché le connessioni possano uscire dalla guida e raggiungere i pad, i via o le estremità delle piste di destinazione.
- Premere il tasto Up Arrow per allargare la guida o il tasto Down Arrow per restringerla.
- Premere Backspace per rimuovere l'ultima curva della guida.
- Fare clic con il pulsante destro del mouse per uscire dalla modalità di posizionamento della guida.
È possibile definire una sola Route Guide alla volta.
4. Eseguire ActiveRoute
Per eseguire ActiveRoute, puoi:
- Selezionare il comando Route » ActiveRoute.
-
Fare clic sul pulsante ActiveRoute (
) su Active Bar.
- Fare clic sul pulsante ActiveRoute nel pannello PCB ActiveRoute.
- Utilizzare la scorciatoia Shift+A.
5. Monitorare l'avanzamento e verificare i riscontri
- La barra di stato dell'editor PCB mostra l'avanzamento di ActiveRoute.
- Il pannello Messages riporta le percentuali di completamento.
Migliorare la propria padronanza
-
Un elemento fondamentale per padroneggiare ActiveRoute è acquisire dimestichezza con le scorciatoie. Le sequenze di tasti che utilizzerai più spesso sono:
- Alt+Click - per selezionare una singola linea di connessione.
- Alt+Click&Drag - per selezionare le connessioni all'interno di un'area, trascina da destra a sinistra per selezionare tutte le connessioni toccate, oppure da sinistra a destra per selezionare solo quelle interamente contenute nel rettangolo di selezione. Premi Tab per estendere la selezione ad altre connessioni appartenenti alle stesse net. La barra di stato mostrerà il numero di connessioni appena selezionate finché il cursore non passerà su un altro oggetto.
- Ctrl+Click&Drag - per selezionare le piazzole di un componente, trascina da destra a sinistra per selezionare tutte le piazzole toccate, oppure da sinistra a destra per selezionare solo quelle interamente contenute nel rettangolo di selezione. Premi Tab per estendere la selezione ad altri oggetti di routing appartenenti alle stesse net. Continua a premere Tab per scorrere tutti i possibili stati di selezione.
- Click&Drag - per selezionare segmenti di pista esistenti, trascina da destra a sinistra per selezionare tutte le piste toccate, oppure da sinistra a destra per selezionare solo quelle interamente contenute nel rettangolo di selezione. Premi Tab per estendere la selezione ad altri oggetti di routing appartenenti alle stesse net. Continua a premere Tab per scorrere tutti i possibili stati di selezione.
- Includi Shift per mantenere la selezione corrente mentre ne esegui un'altra.
- Shift+A per eseguire ActiveRoute sulla selezione corrente.
- Ctrl+Alt+G - per applicare il glossing alla selezione corrente.
-
Le azioni di selezione vengono eseguite solo sugli oggetti visibili (ad eccezione di Ctrl+A):
- Premi Shift+S per attivare o disattivare la modalità a singolo layer in modo da visualizzare solo il layer di interesse.
- Se il progetto utilizza room di posizionamento, queste possono essere bloccate durante la loro definizione nelle regole di progettazione oppure nascoste per evitare che vengano selezionate o spostate durante le operazioni di clic e trascinamento. Le room possono essere nascoste nella scheda View Options del pannello View Configuration.
-
Esegui il fanout delle piazzole SMD. ActiveRoute non cambia layer, quindi dovrai eseguire il fanout delle piazzole SMD. Per accelerare il processo di fanout:
- Durante lo sbroglio di una connessione, premi la scorciatoia / (tastierino numerico) per posizionare un via e terminare lo sbroglio di questa connessione. Utilizza la scorciatoia 2 se non disponi di un tastierino numerico (posiziona un via senza interrompere lo sbroglio).
- Copia e incolla un fanout esistente; l'editor PCB aggiornerà automaticamente i nomi delle net. Questa operazione può essere eseguita su più fanout.
-
Preserva i fanout esistenti. ActiveRoute modifica i fanout se individua una soluzione migliore; se non vuoi che vengano modificati, bloccali. Il modo più semplice per bloccare i fanout è selezionare le piste e i via del fanout (utilizza Selection Filter nella parte superiore del pannello Properties per facilitare questa operazione), premere F11 per aprire il pannello Properties e abilitare la casella di controllo Locked. In questo modo tutti gli oggetti selezionati verranno bloccati con un'unica operazione.
-
Se utilizzi una Route Guide e noti una bassa percentuale di completamento, potrebbero esserci troppi ostacoli lungo il percorso e potrebbe essere necessario allargare la guida. Premi il tasto freccia Up per allargare la guida durante il posizionamento.
-
Al termine, ActiveRoute applica il glossing (se abilitato nel pannello PCB ActiveRoute). Per esaminare le piste così com'erano al termine di ActiveRouting, premi Ctrl+Z una volta per annullare il glossing. Il comando Gloss (Route » Gloss Selected) può essere utilizzato per rendere più regolari le piste e migliorare gli ingressi nelle piazzole di qualsiasi tracciato, non solo di quelli generati da ActiveRoute. Particolare attenzione è stata dedicata a garantire ingressi nelle piazzole di alta qualità per le coppie differenziali. Per ulteriori informazioni sul glossing, consulta la pagina Glossing e ritracciamento delle piste esistenti.
-
Se ActiveRoute non funziona, in genere è perché le regole non sono configurate correttamente. La causa più comune di insuccesso di ActiveRoute è la mancanza di spazio sufficiente per le piste. Verifica che le regole siano appropriate: ad esempio, le regole predefinite presenti in un nuovo file PCB potrebbero prevedere dimensioni troppo grandi per un progetto con BGA ad alta densità.
-
ActiveRoute rispetta le regole di sbroglio configurate per larghezze, distanze di isolamento e spaziature delle coppie differenziali, per layer, per room e per classe. ActiveRoute non esegue lo sbroglio con archi o piste ad angolo libero.