Lavorare con i corpi 3D estrusi, sferici e cilindrici
A colpo d'occhio
- Scopri le differenze tra corpi 3D estrusi, cilindrici e sferici e come definire e posizionare ciascuno di essi.
- Scopri come utilizzare il pannello Properties e le scorciatoie disponibili durante l'esecuzione dei comandi per controllare le dimensioni delle forme, il loro aspetto e il comportamento durante il posizionamento.
- Comprendi come generare e gestire corpi 3D a partire dalle forme già presenti nelle impronte utilizzando il Component Body Manager, incluse le opzioni per i singoli componenti e gli aggiornamenti in blocco.
Sebbene il posizionamento di modelli 3D generici sia il metodo consigliato per utilizzare gli oggetti Corpo 3D, poiché fornisce una rappresentazione accurata e dettagliata del componente sul PCB e consente verifiche delle collisioni 3D più precise nell'editor PCB, un oggetto Corpo 3D può essere utilizzato anche per posizionare forme di corpo 3D estruse, sferiche e cilindriche. È possibile posizionare tre tipi di oggetti Corpo 3D semplici:
| Extruded | Nel piano X-Y (vista dall'alto), l'oggetto estruso viene definito in modo interattivo, analogamente agli altri oggetti poligonali nell'editor PCB. L'oggetto viene quindi estruso verso l'alto (o verso il basso) lungo l'asse Z, in base alle proprietà Overall Height e Standoff Height definite nella modalità 3D Body del pannello Properties e all'opzione Body Projection. È inoltre possibile applicare un file di texture, ad esempio un logo, alla superficie di un oggetto Corpo 3D estruso. |
| Cylindrical | Le proprietà di questa forma vengono definite nella modalità 3D Body del pannello Properties. |
| Spherical | Le proprietà di questa forma vengono definite nella modalità 3D Body del pannello Properties. |
Posizionamento di oggetti Corpo 3D estrusi, sferici o cilindrici
Posizionamento diretto
Gli oggetti Corpo 3D estrusi, sferici e cilindrici possono essere posizionati sia nell'editor PCB sia nell'editor delle impronte PCB nei seguenti modi:
- Scegliendo il comando Place » Extruded 3D Body dai menu principali.
- Individuando e utilizzando il comando Corpo 3D estruso sulla Active Bar.
Per posizionare un oggetto Corpo 3D estruso, sferico o cilindrico:
- Dopo aver avviato il comando, il cursore assume la forma di un mirino e si attiva la modalità di posizionamento predefinita, che consente di posizionare un oggetto Corpo 3D estruso.
- Premere Tab per sospendere il posizionamento e visualizzare il pannello Properties in modalità Corpo 3D. Il pulsante di pausa sovrapposto apparirà nell'area di progettazione, indicando che è possibile accedere ai campi del pannello Properties.
- Nel pannello Properties, immettere un nome per il Corpo 3D nel campo Identifier. Questa operazione è facoltativa; l'identificatore può essere utile quando si posizionano più Corpi 3D e può anche essere utilizzato per applicare una regola di progettazione a questo specifico Corpo 3D, se necessario.
-
Selezionare il valore Board Side richiesto; in genere è impostato su
Top. Nell'editor delle librerie PCB, l'impronta viene creata per il lato superiore della scheda; se necessario, può essere ribaltata sul lato inferiore durante il processo di progettazione del PCB. - Selezionare il Layer meccanico su cui posizionare il Corpo 3D. I layer meccanici di tipo componente devono essere associati a un secondo layer meccanico, in modo che, se il componente viene ribaltato dal lato superiore a quello inferiore della scheda, i relativi dettagli meccanici, come il Corpo 3D, vengano spostati sul layer meccanico associato. I layer meccanici vengono associati nella scheda Layers and Colors del pannello Configurazione vista. Per ulteriori informazioni, consultare la pagina del pannello.
- Selezionare il 3D Model Type tra le forme disponibili: Extruded, Cylinder o Sphere.
-
Per poter posizionare una forma, è necessario definirne le dimensioni. Se la forma scelta è:
- Extruded – definire Overall Height.
- Cylinder – definire Height e Radius.
- Sphere – definire Radius.
- Nella sezione Display del pannello, fare clic sul pulsante Color per impostare il colore e regolare Opacity secondo necessità.
-
Una volta completate le modifiche, fare clic sul pulsante di pausa sovrapposto per tornare all'area di progettazione.
-
Se la forma è Cylinder o Sphere:
- Il cursore si sposterà nell'area di progettazione con una forma rettangolare agganciata; fare clic per posizionare il Corpo 3D.
- Fare clic con il pulsante destro del mouse o premere Esc per terminare il posizionamento degli oggetti Corpo 3D.
-
Se la forma è Extruded, il cursore sarà pronto per definire la forma poligonale di base del Corpo 3D estruso:
- Fare clic per definire il primo vertice.
- Spostare il cursore nella posizione in cui collocare il secondo vertice. Il comportamento predefinito prevede il posizionamento di due lati a ogni clic, con una forma dell'angolo definita dall'utente tra di essi. Per ulteriori informazioni, consultare la sezione Modalità di posizionamento dei Corpi 3D estrusi di seguito.
- Continuare a spostare il mouse e fare clic per posizionare altri vertici.
- Dopo aver posizionato l'ultimo vertice, fare clic con il pulsante destro del mouse o premere Esc per chiudere e completare il posizionamento del Corpo 3D. Non è necessario chiudere manualmente il Corpo 3D, poiché il software completerà automaticamente la forma collegando il punto iniziale all'ultimo punto posizionato.
-
Se la forma è Cylinder o Sphere:
Modalità di posizionamento dei Corpi 3D estrusi
Durante il posizionamento di un Corpo 3D estruso sono disponibili cinque modalità per gli angoli, quattro delle quali dispongono anche di sottomodalità per la direzione dell'angolo. Durante il posizionamento:
- Premere Shift+Spacebar per scorrere le cinque modalità disponibili per gli angoli.
- Premere Spacebar per passare da una sottomodalità di direzione dell'angolo all'altra.
-
In una delle modalità con angoli ad arco, tenere premuti i tasti
o
per ridurre o ingrandire l'arco. Tenere premuto anche il tasto Shift per accelerare il ridimensionamento dell'arco.
- Premere il tasto di scelta rapida 1 per alternare il posizionamento di due lati per clic o un lato per clic. Nella seconda modalità, il lato tratteggiato viene denominato look-ahead segment.
- Premere il tasto Backspace per rimuovere l'ultimo vertice.

Un oggetto Corpo 3D estruso; si noti il punto di riferimento mostrato nelle viste 2D e 3D.
Creazione da forme chiuse
Per accelerare la creazione della forma del componente mediante corpi 3D, il software può creare una serie di oggetti corpo 3D estrusi a partire dalle forme chiuse rilevate nel footprint. Questa funzione può essere utile se il componente ha una forma insolita, già rappresentata dalle forme definite sulla serigrafia del componente nel footprint. È inoltre possibile aggiungere altri oggetti al footprint sui layer meccanici e utilizzarli per creare ulteriori oggetti corpo 3D, ad esempio per realizzare i pin.
Le immagini seguenti mostrano il footprint di un transistor TO-92. Il contorno disegnato sul layer Top Overlay viene utilizzato per definire il corpo del transistor sulla coppia di layer corpo 3D scelta (indicata come Registration Layer nella finestra di dialogo). Sono stati inoltre creati tre piccoli quadrati su un layer meccanico (ciascuno composto da quattro linee), utilizzati per definire i pin del componente sulla coppia di layer corpo 3D scelta; le impostazioni sono mostrate nell'immagine della finestra di dialogo riportata di seguito.

Gli oggetti esistenti nel footprint possono essere utilizzati per creare nuovi oggetti corpo 3D.
Per creare oggetti corpo 3D dalle forme presenti nel footprint, eseguire il comando Tools » Manage 3D Bodies for Current Component: si aprirà la finestra di dialogo Component Body Manager. Questa consente di vedere quali corpi 3D sono attualmente utilizzati nel componente e quali no. È possibile aggiungere corpi al componente e/o rimuoverli secondo necessità. I corpi possono essere di tre tipi distinti:
- Un corpo 3D posizionato appositamente (indicato come Component Body nella descrizione).
- Una forma rettangolare creata automaticamente dal software a partire da un rettangolo di delimitazione.
- Una forma poligonale chiusa creata automaticamente dal software a partire dalle primitive di progettazione.
È inoltre possibile modificare altre proprietà di un corpo, come le altezze, la proiezione del corpo, il layer di riferimento, il colore e l'opacità. Si noti che la colonna Body State mostra che verranno utilizzate quattro forme per creare oggetti corpo 3D.
Una volta definiti i corpi 3D del componente secondo necessità, fare clic sul pulsante Close per applicare le modifiche.

Il software può creare oggetti corpo 3D in base alla forma di oggetti esistenti.
Note sull'utilizzo di questa finestra di dialogo:
- L'algoritmo di rilevamento proporrà una forma rettangolare creata dal rettangolo di delimitazione oppure una forma poligonale che segue il contorno formato dalle primitive (tracciato lungo la linea centrale di piste/archi, se le loro estremità coincidono).
- Per creare un corpo 3D da un oggetto esistente, fare clic sul testo blu nella colonna Body State.
- Il valore predefinito di Overall Height corrisponde a Height definito nel pannello Properties del footprint.
- Per un pin del componente che attraversa la scheda verso il basso, impostare Body Projection su Bottom Side.
- Gli oggetti corpo 3D vengono creati quando si fa clic sul pulsante Close nella finestra di dialogo. Se la visualizzazione è già impostata sulla modalità 3D, per vedere i nuovi oggetti potrebbe essere necessario aggiornarla (scorciatoia End), passare alla modalità 2D e poi tornare alla modalità 3D, oppure impostare l'opzione Show 3D Bodies su Off e On nella scheda View Options del pannello View Configurations.
- Per modificare i corpi 3D di tutti i componenti nella libreria di footprint PCB attiva attualmente aperta nell'editor di footprint PCB, scegliere il comando Tools » Manage 3D Bodies for Library dai menu principali.
- Per modificare i corpi 3D nell'editor PCB tramite questa finestra di dialogo, è possibile accedervi selezionando il comando Tools » Manage 3D Bodies for Components on Board dai menu principali oppure facendo clic con il pulsante destro del mouse su un componente e selezionando Azioni componente » Gestisci corpi 3D dal menu contestuale.
-
Quando si accede alla finestra di dialogo tramite il comando Tools » Manage 3D Bodies for Components on Board (nell'editor PCB) o il comando Tools » Manage 3D Bodies for Library (nell'editor di footprint PCB), nella parte superiore della finestra sarà disponibile l'area Components. Quest'area elenca tutti i footprint dei componenti nella libreria attiva (nel progetto effettivo, si tratterebbe di un elenco di tutti i componenti sulla scheda). Per ogni voce vengono visualizzati il designatore (disponibile solo nell'ambiente di progettazione), il nome del footprint, l'altezza e le informazioni sulla libreria di origine.
Sarà inoltre disponibile una scheda aggiuntiva Batch Update. Questa scheda consente di aggiungere rapidamente oggetti corpo 3D in blocco a tutti i componenti o a quelli selezionati. È possibile definire i criteri di ricerca per il rilevamento e la creazione dei corpi 3D e per la definizione delle relative proprietà. Dopo aver definito tutte le opzioni per l'elaborazione in blocco secondo necessità, fare clic sul pulsante Execute Batch Update. La ricerca verrà eseguita per ciascun componente incluso nel processo e, quando viene rilevata e creata una forma di corpo 3D, il corpo verrà aggiunto al componente utilizzando i criteri di proprietà definiti. In questa modalità, le modifiche vengono applicate all'esecuzione dell'aggiornamento in blocco.
- La finestra di dialogo consente di gestire i corpi 3D del componente da un'unica posizione, evitando di dover aprire il pannello Properties per ciascun corpo 3D.
Opzioni e controlli della finestra di dialogo Component Body Manager

La finestra di dialogo Component Body Manager (sullo sfondo) e la finestra di dialogo Gestione corpi del componente (in primo piano)
Componenti
L'area superiore della finestra di dialogo elenca tutti i footprint dei componenti nella libreria attiva (nel progetto effettivo, si tratterebbe di un elenco di tutti i componenti sulla scheda). Per ogni voce vengono visualizzati il designatore (disponibile solo nell'ambiente di progettazione), il nome del footprint, l'altezza e le informazioni sulla libreria di origine.
Scheda interattiva

La scheda Interactive della finestra di dialogo Component Body Manager
La versione Component Body Manager della finestra di dialogo presenta due schede: la scheda Interactive e la scheda Batch Update. La scheda Interactive consente di visualizzare facilmente le informazioni sul componente selezionato, incluse le anteprime dei corpi del componente e del corpo selezionato.
Corpi del componente esistenti e potenziali
-
Existing and Potential Component Bodies - quest'area elenca tutti i corpi del componente (corpi 3D) esistenti che vengono utilizzati o che potrebbero essere utilizzati per il componente. Ogni corpo del componente è elencato in base alle seguenti informazioni:
-
Description - una descrizione di come è stato creato il corpo. Può trattarsi di un corpo 3D posizionato appositamente (indicato come Component Body nella descrizione), di una forma rettangolare creata da un rettangolo di delimitazione oppure di una forma poligonale chiusa creata dalle primitive di progettazione. La descrizione di ogni corpo (sia posizionato che creato automaticamente) include anche il layer meccanico su cui si trova (o su cui si trovano gli oggetti da cui è stato creato) e la sua area. I corpi rettangolari e poligonali sono contraddistinti da
e
rispettivamente le icone.
- Body State - indica se il corpo viene utilizzato nel componente (In Component <ComponentDesignator>) oppure no (Not In Component <ComponentDesignator>). Fai clic sulla voce per cambiare lo stato secondo necessità.
- Standoff Height - la distanza dalla superficie della scheda al lato inferiore del corpo estruso. Utilizza un valore negativo per i corpi estrusi che devono attraversare il PCB verso il basso.
- Overall Height - la distanza dalla superficie della scheda al lato superiore del corpo estruso.
- Body Projection - il lato della scheda da cui si estenderà il corpo 3D. Utilizza il menu a discesa del campo per scegliere Top Side o Bottom Side (estensione verso l'alto o verso il basso). Questa impostazione viene modificata automaticamente se l'oggetto corpo 3D viene ribaltato sull'altro lato della scheda durante il ribaltamento di un componente.
- Registration Layer - il layer meccanico su cui si trova il corpo 3D. Utilizza il menu a discesa del campo per scegliere tra tutti i layer meccanici attualmente abilitati. Se il layer meccanico scelto è abbinato, quando il corpo viene ribaltato sull'altro lato della scheda insieme al relativo componente, viene anche spostato sul layer meccanico abbinato.
- Body 3D Color - il colore attualmente utilizzato per il corpo 3D. Fai clic sul campione di colore per accedere alla finestra di dialogo standard Choose Color e assegnare un colore diverso secondo necessità.
- Body 3D Opacity - il livello di trasparenza attuale del corpo 3D. Utilizza il menu a discesa del campo per scegliere tra Solid (completamente opaco), Hide (che rende il corpo invisibile), 25% Opacity, 50% Opacity e 75% Opacity.
-
Description - una descrizione di come è stato creato il corpo. Può trattarsi di un corpo 3D posizionato appositamente (indicato come Component Body nella descrizione), di una forma rettangolare creata da un rettangolo di delimitazione oppure di una forma poligonale chiusa creata dalle primitive di progettazione. La descrizione di ogni corpo (sia posizionato che creato automaticamente) include anche il layer meccanico su cui si trova (o su cui si trovano gli oggetti da cui è stato creato) e la sua area. I corpi rettangolari e poligonali sono contraddistinti da
- Component bodies in: <ComponentDesignator> - mostra il footprint 2D del componente con sovrapposti i corpi 3D il cui Body State è attualmente impostato su In Component <ComponentDesignator>. L'anteprima è dinamica e cambia man mano che i corpi vengono inclusi o esclusi.
- Selected Body - mostra il corpo attualmente selezionato nell'elenco precedente. Anche l'area del titolo della finestra riporta la descrizione del corpo.
Scheda Aggiornamento in batch

La scheda Batch Update della finestra di dialogo Component Body Manager
La scheda Batch Update consente di aggiungere rapidamente oggetti corpo 3D a tutti i footprint di una libreria o solo a quelli selezionati, oppure a tutti i footprint posizionati in un progetto o solo a quelli selezionati.
Area della griglia
Utilizza quest'area per definire i criteri di ricerca per il rilevamento e la creazione dei corpi 3D e per definirne le proprietà, come Projection side (detta anche proiezione del corpo), Registration Layer, Standoff Height, Overall Height e 3D Body Color.
Ogni voce dell'elenco definisce un diverso ambito di ricerca in termini di layer da esaminare per rilevare e creare le possibili forme dei corpi 3D. Ogni ricerca viene abilitata singolarmente utilizzando l'opzione nella colonna Enabled. È possibile abilitare più ricerche; tieni presente, tuttavia, che verrà aggiunto un corpo 3D per ogni ricerca riuscita. In genere, si abilita una ricerca su un layer specifico o su un insieme di layer, a seconda di dove vengono solitamente posizionate le primitive o le informazioni sul contorno del componente per un footprint. Per impostazione predefinita, viene eseguita una ricerca di All Layers.
Il campo Detection Method consente di controllare come viene definita la forma di ciascun corpo 3D:
- Bounding Rectangle - utilizza il rettangolo di delimitazione del footprint.
- Closed Shapes - utilizza una forma poligonale chiusa creata a partire dalle primitive del footprint del componente.
- Both (Prefer Closed Shapes) - rileva un rettangolo di delimitazione oppure una forma poligonale chiusa in base alle primitive del footprint. Se vengono rilevati entrambi, utilizza la forma poligonale chiusa.
La colonna dell'opzione Prefer component height if not 0 consente di controllare se l'attributo di altezza definito per il footprint di un componente viene utilizzato come Overall Height del corpo 3D. Con questa opzione abilitata, per ogni componente con un attributo di altezza definito maggiore di zero, tale altezza viene impostata come Overall Height del corpo 3D aggiunto e il relativo Standoff Height viene impostato su zero.
Il campo Body 3-D Color specifica il colore con cui visualizzare il corpo 3D. Fai clic sul colore per modificarlo nella finestra di dialogo Choose Color.
Opzioni
- Apply Only To Selected Components - abilita questa opzione se desideri applicare i criteri del corpo 3D solo a un gruppo selezionato di footprint. Assicurati che tali componenti siano selezionati nell'area superiore della finestra di dialogo (utilizza le funzionalità standard Ctrl+Click e Shift+Click per la selezione multipla). Se questa opzione è disabilitata, il processo di aggiunta in batch verrà applicato a tutti i footprint della libreria (o a tutti i componenti sulla scheda).
- Delete Existing Bodies In Components - abilita questa opzione per rimuovere tutti i corpi 3D attualmente definiti per i footprint interessati dal processo in batch. Utilizza la finestra di anteprima in basso a destra nella scheda per vedere come apparirà il corpo 3D aggiunto in base al footprint del componente attualmente selezionato e alla voce di ricerca attualmente selezionata e abilitata. Dopo aver definito tutte le opzioni del processo in batch secondo necessità, fai clic sul pulsante Execute Batch Update. La ricerca verrà eseguita per ogni footprint incluso nel processo e, laddove venga rilevata e creata la forma di un corpo 3D, tale corpo verrà aggiunto al footprint utilizzando i criteri definiti per le proprietà.
Anteprima dell'operazione in batch
Consente di visualizzare in anteprima i corpi 3D definiti sui diversi layer.
Comando aggiuntivo
- Execute Batch Update - fai clic per procedere con l'aggiornamento di ogni footprint incluso nel processo e, laddove venga rilevata e creata la forma di un corpo 3D, tale corpo verrà aggiunto al footprint utilizzando i criteri definiti per le proprietà.
Creazione da primitive selezionate
Oltre a essere posizionati in modo interattivo, i corpi 3D possono essere creati a partire da un insieme di oggetti esistenti di tipo traccia, arco e regione piena che definiscono una forma chiusa. Questa è un'ottima scelta quando il modello è semplice. Per definire un corpo 3D da una forma chiusa esistente:
- Seleziona tutte le primitive che formano la forma chiusa.
- Fai clic su Tools » Convert » Create 3D Body From selected primitives.
Il corpo 3D verrà creato sul Top Layer a partire dal contorno chiuso formato dalle primitive, indipendentemente dal layer su cui si trovano le tracce selezionate. Questo significa che puoi definire la forma su un layer meccanico. Tieni presente che le primitive originali selezionate continueranno a esistere dopo la creazione della regione e rimarranno selezionate. Il contorno del corpo 3D segue la linea centrale degli oggetti traccia che lo delimitano e il corpo non viene selezionato.
Poiché l'algoritmo Create 3D Body From selected primitives utilizza la linea centrale degli oggetti selezionati, richiede che i punti iniziali e finali degli oggetti a contatto coincidano esattamente (alle stesse coordinate X, Y). In caso contrario, verrà visualizzata una finestra di dialogo Confirm che indica la posizione in cui l'algoritmo non è riuscito a completare l'operazione e offre anche la possibilità di indicare all'algoritmo di tentare di definire il corpo 3D utilizzando invece i bordi degli oggetti. Purché gli oggetti selezionati si sovrappongano leggermente, questa opzione dovrebbe creare un corpo 3D il cui bordo segue il bordo esterno degli oggetti selezionati.
Modifica grafica
Il metodo di modifica grafica consente di selezionare un oggetto corpo 3D posizionato direttamente nell'area di progettazione e di modificarne graficamente le dimensioni, la forma o la posizione.
Per un corpo 3D estruso, fai clic una volta sull'oggetto per selezionarlo e attivare la modalità di modifica. La forma esterna dell'oggetto corpo 3D è definita da una serie di bordi: ogni bordo è rappresentato da un vertice a ciascuna estremità, visualizzato come un quadrato bianco pieno (A nell'immagine seguente), e da un vertice centrale, visualizzato come un quadrato bianco vuoto (B nell'immagine seguente). Ogni vertice di estremità rappresenta il punto in cui si incontrano due bordi.
Per modificare la forma sono disponibili le normali tecniche di modifica delle forme poligonali.
Quando si modifica un oggetto poligonale, sono disponibili tre modalità di modifica: Slide/Miter, Incurvate (arco) e Move. La modalità corrente può essere cambiata while dragging a vertex or an edge premendo Shift+Spacebar per scorrere ciclicamente le 3 modalità.
- Slide/Miter – fai clic e tieni premuto su un bordo o su un vertice centrale per far scorrere quel bordo; fai clic e tieni premuto su un vertice di estremità per smussare l'angolo.
- Incurvate – fai clic e tieni premuto su un bordo o su un vertice centrale per incurvare quel bordo; fai clic e tieni premuto su un vertice di estremità per arrotondare l'angolo con un arco.
- Move – fai clic e tieni premuto su un bordo o su un vertice centrale per suddividere quel bordo in due bordi; fai clic e tieni premuto su un vertice di estremità per spostare liberamente quell'angolo.
Durante la modifica puoi anche:
- Ctrl+click and hold in un punto qualsiasi lungo un bordo, lontano dalle maniglie di modifica, per inserire un nuovo vertice.
- Per rimuovere un vertice, fai clic e tieni premuto sul vertice, quindi premi il tasto Delete.
-
Fai clic su un punto qualsiasi del corpo 3D lontano dalle maniglie di modifica, quindi trascina per riposizionarlo. Durante il trascinamento, il corpo 3D può essere ruotato o specchiato:
- Premi Spacebar per ruotare il corpo 3D in senso antiorario oppure Shift+Spacebar per ruotarlo in senso orario. L'ampiezza di Rotation Step è definita nella pagina Editor PCB – Generale della finestra di dialogo Preferences.
- Premi i tasti X o Y per specchiare il corpo 3D lungo l'asse X o l'asse Y.
Conversione in STEP
Un oggetto corpo 3D estruso/cilindrico/sferico selezionato può essere convertito in un modello STEP. Il modello STEP viene incorporato automaticamente nel file di progetto. Per convertire un oggetto corpo 3D libero, selezionalo nell'area di progettazione, quindi fai clic con il pulsante destro del mouse e scegli il comando Convert To STEP dal menu contestuale. Il comando non sarà disponibile se non è selezionato alcun oggetto o se è selezionato più di un oggetto. Una volta convertito in STEP, un oggetto non può più essere ridimensionato nell'area di progettazione.

Converti una forma estrusa in STEP se devi ruotarla attorno agli assi X o Y.
Punto di riferimento di un oggetto corpo 3D estruso, sferico o cilindrico
Un oggetto corpo 3D estruso, sferico o cilindrico ha un punto di riferimento, o origine.
- Per un cilindro e una sfera, il riferimento è il centro della forma circolare dell'oggetto sul piano X-Y.
- Per un oggetto estruso, il riferimento è impostato nella posizione lunghezza X/2, lunghezza Y/2 con vista dall'alto.
- La posizione di questo punto di riferimento nell'area di progettazione è quella mostrata in X/Y Location nel pannello Properties.

Gli oggetti corpo 3D estrusi, sferici e cilindrici hanno un punto di riferimento, come mostrato nelle immagini. Nota che le linee del punto di riferimento sono corte e pertanto potrebbero non essere visibili all'esterno dell'oggetto.
Aggiunta di una texture a un corpo 3D estruso
Gli oggetti estrusi possono anche includere un'immagine sovrapposta alla superficie superiore, per rendere più realistica la scheda quando viene visualizzata in 3D. Quando viene aggiunta una Texture File, questa viene automaticamente estesa per coprire l'intera superficie superiore del corpo 3D, come mostrato nell'immagine seguente. Nota che il file della texture è collegato al file della libreria o della scheda.
I formati di file texture supportati includono: *.bmp; *.dds; *.dib; *.hdr; *.jpg; *.pfm; *.png; *.ppm; e *.tga.

È possibile aggiungere una texture o un logo a un oggetto corpo 3D estruso.
La texture può essere regolata modificando la posizione Center e le impostazioni Size e Rotation nella modalità 3D Body del pannello Properties.
Puoi anche modificare la posizione di un oggetto texture associato a un modello 3D estruso selezionato scegliendo il comando Tools » 3D Body Placement » Move Texture Location dai menu principali quando l'editor è configurato in modalità Layout 3D. Dopo aver avviato il comando, il cursore assumerà la forma di coni blu (a indicare la modalità di selezione 3D) e ti verrà richiesto di selezionare un corpo 3D estruso a cui è associata una texture. Posiziona il cursore sul corpo 3D desiderato, quindi fai clic o premi Enter. Fai clic o premi Enter una seconda volta per «agganciare» la texture dall'angolo più vicino. Sposta la texture nella posizione desiderata, quindi fai clic o premi Enter per confermarne il posizionamento. Durante lo spostamento, mentre la texture è ancora agganciata al cursore, è possibile eseguire le normali azioni aggiuntive per lo spostamento degli oggetti (Spacebar/Shift+Spacebar per ruotare, X o Y per specchiare, tasti freccia per spostare la texture di piccoli incrementi).
In alternativa, puoi spostare la texture in un corpo 3D estruso selezionato facendo clic e trascinando con il mouse.