디자인 세부 정보 포함
개요
- PCB Editor 또는 PCB 라이브러리 Editor에서 추가할 수 있는 PCB 문서화 정보와 기계 레이어를 사용해 이를 체계적으로 정리하는 방법을 알아봅니다.
- 레이어 스택 테이블과 드릴 테이블에 포함되는 정보, 배치 가능한 위치, 현재 보드 설계에 따라 업데이트되거나 설계 상태를 반영하는 방식을 살펴봅니다.
- PCB 출력물에서 이러한 문서 요소의 표시 방식을 제어하는 주요 배치, 이동, 크기 조정 및 속성 옵션을 알아봅니다.
생성하는 출력물 중 상당수에는 추가 세부 정보가 필요합니다. 예를 들어 제조 도면에는 치수가 필요하고, 조립 도면에는 보드의 특정 영역을 확대한 뷰가 필요할 수 있으며, 제작 도면에는 레이어 스택 표와 드릴 표가 필요합니다. 이러한 세부 정보는 PCB Editor 또는 PCB 라이브러리 Editor에서 추가할 수 있습니다.
에 대해 자세히 알아보기범용 도면 레이어
PCB Editor에서는 치수, 제작 및 조립 지침과 같은 세부 정보를 기계 레이어에 추가합니다. 소프트웨어는 범용 기계 레이어를 개수 제한 없이 지원하며, 이러한 레이어는 View Configuration Panel에서 활성화할 수 있습니다. 레이어 이름은 필요에 따라 지정할 수 있으며(이름을 마우스 오른쪽 버튼으로 클릭한 다음 Edit Layer 선택), 인쇄물 및 레이어 기반 제작 출력물에 포함할 수 있습니다.
레이어 스택 표

레이어 스택 표는 PCB 문서에서 설계 자체와 나란히 배치할 수 있습니다. 이 표는 보드 레이어 스택업과 레이어 그룹의 할당 방식을 상세하게 요약하여 보여줍니다.
레이어 스택 표는 현재 PCB 설계에 구현된 레이어, 재료, 두께 및 유전율을 문서화하는 표 형식의 그래픽 객체입니다. 설계 공간에서 보드 설계 옆에 배치하며, 보드의 각 영역에 사용된 레이어 스택을 보여주는 그래픽 범례와 옵션 맵도 포함합니다. 레이어 스택 표는 Layer Stack Manager 를 통해 정의된 레이어 구성을 반영하며, 리지드 플렉스 설계와 같이 복잡한 레이어 스택 구조를 가진 설계에서 중요한 문서화 자료입니다.
레이어 스택 표는 설계 공간 뷰가 일반 2D 모드(단축키 2)로 설정되어 있을 때 PCB Editor에서 사용할 수 있습니다. 레이어 스택 표 배치 명령(Place » Layer Stack Table)을 실행하면 커서가 십자 모양으로 바뀌고 레이어 스택 표 배치 모드로 들어갑니다. 다음 순서로 배치합니다.
- 클릭하여 표를 배치합니다.
- Editor는 레이어 스택 표 배치 모드를 유지하므로 필요한 경우 다른 표를 배치할 수 있습니다. 더 이상 배치하지 않으려면 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 배치 모드를 종료합니다.
배치 중 레이어 스택 표가 아직 커서에 붙어 있고 표의 중심점이 고정되기 전에 다음과 같은 추가 작업을 수행할 수 있습니다.
- Alt 키를 누르면 최초 이동 방향에 따라 이동 방향이 수평축 또는 수직축으로 제한됩니다.
- Spacebar 키를 누르면 레이어 스택 표가 시계 반대 방향으로 회전하고, Shift+Spacebar 키를 누르면 시계 방향으로 회전합니다. 회전은 90° 단위로 이루어집니다.
레이어 스택 표를 이동하려면 표를 클릭한 상태로 원하는 위치까지 드래그합니다.

레이어 스택 표를 선택하고 드래그하여 위치를 변경합니다.
레이어 스택 표 속성

Properties Panel의 Layer Stack Table 모드.
위치
-
(X/Y)
- X (첫 번째 필드) - 현재 설계 공간 원점을 기준으로 한 객체 기준점의 현재 X(수평) 좌표입니다. 값을 편집하여 객체의 X 위치를 변경합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있으며, 현재 기본 단위가 아닌 단위로 값을 입력할 때는 단위를 함께 입력해야 합니다.
- Y (두 번째 필드) - 현재 원점을 기준으로 한 객체 기준점의 현재 Y(수직) 좌표입니다. 값을 편집하여 객체의 Y 위치를 변경합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있으며, 현재 기본 단위가 아닌 단위로 값을 입력할 때는 단위를 함께 입력해야 합니다.
- Rotation - 0도(3 o'clock 수평 방향)를 기준으로 시계 반대 방향으로 측정한 객체의 회전 각도(도 단위)입니다. 값을 편집하여 객체의 회전을 변경합니다. 최소 각도 분해능은 0.001°입니다.
속성
- Layer - 표가 현재 할당된 레이어입니다. 드롭다운을 사용하여 다른 레이어를 선택합니다.
- Alignment - 드롭다운을 사용하여 원하는 정렬을 선택합니다.
-
Units - 드롭다운을 사용하여
Metric (mm)또는Imperial (mil)를 선택합니다. - Show Board Map - 활성화하면 다양한 레이어 스택이 보드의 각 영역에 어떻게 할당되어 있는지 보여주는 보드 외곽선이 표시됩니다. 슬라이더 막대를 사용하여 표시된 보드 외곽선의 배율을 변경합니다.
- Show Total Board Thickness - 활성화하면 레이어 스택 표의 격자 아래에 전체 보드 두께가 표시됩니다.
- Line Width - 표 안의 텍스트 선 너비를 지정합니다. Line Width는 텍스트의 선 두께에 영향을 줍니다.
- Text Height - 현재 텍스트 문자의 높이입니다. 표 안의 텍스트 높이를 지정합니다. Text Height는 표 크기에도 영향을 줍니다. 텍스트 높이를 더 크게 설정하면 표가 자동으로 확장됩니다.
글꼴 유형
-
TrueType - 이 필드를 사용하여 원하는 TrueType 글꼴을 선택합니다. Font 드롭다운 목록에는
\Windows\Fonts폴더에 있는 TrueType 및 OpenType(TrueType의 상위 집합) 글꼴이 표시됩니다. 목록에는 감지된 기본 글꼴 중 고유한 이름을 가진 항목만 포함됩니다. B (bold) 및 I (Italic) 옵션을 사용하여 텍스트를 강조할 수 있습니다. -
Stroke
-
Font - 이 필드에서 필요한 스트로크 글꼴을 선택합니다. 사용 가능한 옵션은 다음과 같습니다:
-
Default- 펜 플로팅 및 벡터 포토 플로팅을 지원하는 단순한 벡터 글꼴입니다. -
Serif- Gerber와 같은 벡터 출력 생성 속도를 늦추는 더 복잡한 글꼴입니다. -
Sans Serif- Gerber와 같은 벡터 출력 생성 속도를 늦추는 더 복잡한 글꼴입니다.
-
-
Font - 이 필드에서 필요한 스트로크 글꼴을 선택합니다. 사용 가능한 옵션은 다음과 같습니다:
-
Stroke Width - 현재 스트로크 두께를 표시합니다.
열
이 영역에서 레이어 스택 테이블에 표시할 열, 해당 열의 텍스트 정렬 및 전체 열 너비를 지정합니다.
- Caption - 표시할 열의 제목입니다.
- Align - 정렬할 캡션의 정렬 셀을 클릭합니다. 계속 클릭하면 정렬 옵션(왼쪽, 가운데, 오른쪽)이 차례로 전환됩니다. 정렬 필드를 클릭할 때마다 테이블에서 해당 열의 텍스트 정렬이 변경됩니다.
-
Width - 필드를 클릭하여 선택한 캡션의 너비를 편집합니다.
Auto을 지정하면 시스템이 해당 열에 입력된 텍스트에 따라 열 너비를 자동으로 조정합니다. 원하는 경우 필요한 너비를 직접 입력할 수 있습니다. - Add - 드롭다운에서 사용 가능한 옵션을 선택하여 레이어 스택 테이블에 열을 추가합니다. 드롭다운에서 테이블에 표시할 캡션을 클릭합니다.
- Up - 클릭하면 선택한 캡션이 테이블에서 왼쪽으로 한 열 이동합니다. Up 버튼을 반복해서 누르면 선택한 열을 왼쪽으로 더 이동할 수 있습니다.
- Down - 클릭하면 선택한 캡션이 테이블에서 오른쪽으로 한 열 이동합니다. Down 버튼을 반복해서 누르면 선택한 열을 오른쪽으로 더 이동할 수 있습니다.
-
- 클릭하면 선택한 캡션이 테이블에서 삭제됩니다. 선택한 항목을 삭제할지 묻는 확인 메시지가 테이블에 표시됩니다. 삭제하려면 Yes 을 클릭하고, 삭제하지 않으려면 No 을 클릭합니다.
드릴 테이블

드릴 테이블은 보드에 있는 모든 드릴 홀의 요약 정보를 실시간으로 표시합니다
드릴 테이블 (드릴 도면 테이블 또는 드릴 도면 범례라고도 함)은 인쇄 회로 기판 제조에 필요한 표준 요소입니다. 드릴 테이블에는 보드에 사용되는 각 드릴의 홀 크기와 개수가 나열됩니다. 각 드릴 크기는 심볼, 문자 또는 실제 홀 크기로 표시할 수 있습니다. 보드의 드릴 도면을 생성하면 각 실제 드릴 위치에 심볼이 표시됩니다. 드릴 테이블은 실시간으로 업데이트됩니다. 즉, 패드 및 비아와 같이 홀이 있는 객체를 PCB 설계에 배치하거나 설계에서 제거하면 테이블이 업데이트됩니다.
드릴 테이블은 PCB Editor에서만 배치할 수 있습니다. 명령을 실행하면 드릴 테이블이 커서에 연결된 상태로 나타납니다. 보드 외부의 적절한 위치로 테이블을 이동한 다음 클릭하거나 Enter을 눌러 배치합니다.
드릴 테이블을 배치하는 동안, 테이블이 커서에 연결되어 있고 아직 위치가 고정되지 않은 상태에서 수행할 수 있는 추가 작업은 다음과 같습니다.
- Tab 키를 누르면 배치를 일시 중지하고 Properties Panel의 드릴 테이블 모드에 액세스하여 속성을 즉시 변경할 수 있습니다. 일시 중지 버튼 오버레이를 클릭하면 배치가 재개됩니다.
- Alt 키를 누르면 초기 이동 방향에 따라 이동 방향이 수평 또는 수직 축으로 제한됩니다.
드릴 테이블 이동
드릴 테이블 내부의 아무 곳이나 클릭한 상태로 PCB Editor 설계 공간에서 원하는 위치로 이동합니다.
드릴 테이블 크기를 대화형으로 조정
드릴 테이블의 크기는 지정된 Text Height 설정, 서로 다른 홀 크기의 수(행 수) 및 정의된 열 수에 따라 자동으로 결정됩니다. 테이블 크기를 대화형으로 조정하려면 한 번 클릭하여 선택한 다음, 모서리 꼭짓점을 클릭한 상태로 이동하여 원하는 크기로 조정합니다. 테이블 크기를 대화형으로 조정하면 글꼴 크기도 함께 커지거나 작아집니다.
미리 볼 레이어 쌍을 대화형으로 전환
보드에 레이어 쌍이 포함된 경우 표시되는 레이어 쌍은 Properties Panel의 Drill Table 모드에 있는 Layers Pairs 옵션으로 제어합니다.
선택한 레이어 쌍은 다음 방법으로도 전환할 수 있습니다.
-
PCB Editor 오른쪽 클릭 메뉴 - 드릴 테이블을 마우스 오른쪽 버튼으로 클릭한 다음, 아래 이미지와 같이 Drill Table 하위 메뉴에서 필요한 레이어 쌍을 선택합니다.
-
아래 이미지와 같이 설계 공간 하단의 레이어 탭에서 액세스할 수 있는 레이어 쌍 선택 메뉴입니다.
드릴 테이블 속성

Properties Panel의 Drill Table 모드
작업
Refresh – 버튼을 클릭하면 PCB의 현재 드릴 심볼 데이터로 드릴 테이블이 업데이트됩니다.
위치
-
(X/Y) – 드릴 테이블 기준점의 현재 X 및 Y 위치입니다. Alignment =
Bottom이면 기준점은 왼쪽 아래 모서리이고, Alignment =Top이면 왼쪽 위 모서리입니다. - Rotation – 드릴 테이블이 회전된 각도(도 단위)입니다.
속성
-
Layer Pairs – 드릴 테이블은 레이어 쌍 드릴링을 사용하는 다층 기판을 지원합니다. 드롭다운에서 Layer Stack Manager의 Via Types 탭에 정의된 레이어 쌍이나 다음 옵션 중 하나를 선택합니다.
- All Layer Pairs (Composite table) – 모든 레이어 쌍의 정보를 표시합니다.
-
All Layer Pairs (Separate tables) – 각 레이어 쌍의 정보를 별도 테이블에 표시합니다.
- Top - Bottom – 관통 홀만 표시합니다.
- Counterhole Bottom – PCB 하면의 카운터홀(카운터보어/카운터싱크)만 표시합니다.
- Counterhole Top – PCB 상면의 카운터홀(카운터보어/카운터싱크)만 표시합니다.
- Text Height – 텍스트 높이를 표시합니다.
글꼴 유형
-
TrueType – PC의 \Windows\Fonts 폴더에 있는 글꼴을 사용하려면 선택합니다. TrueType 글꼴은 유니코드를 완벽하게 지원합니다. 기본적으로 소프트웨어는 사용된 TrueType 글꼴에 연결하며, 글꼴은 PCB 파일에 저장되지 않습니다. 따라서 설계를 다른 PC로 옮길 경우 해당 PC에도 동일한 글꼴이 있어야 합니다. 또는 Preferences 대화상자의 PCB Editor – True Type Fonts 페이지에 있는 옵션을 사용하여 사용된 TrueType 글꼴을 PCB 파일에 포함할 수 있습니다. 이 페이지에서는 파일에 포함되지 않은 글꼴을 사용할 수 없을 때 대신 사용할 Substitution Font 도 선택할 수 있습니다.
- Font – 드롭다운에서 원하는 TrueType 글꼴을 선택합니다. B를 사용하여 텍스트를 굵게 표시하거나 I를 사용하여 기울임꼴로 표시합니다.
-
Stroke
-
Font – 드롭다운에서 원하는 스트로크 글꼴을 선택합니다. 선택 가능한 항목은 다음과 같습니다.
-
Default– 펜 플로팅 및 벡터 포토 플로팅용으로 설계된 단순한 벡터 글꼴입니다. -
Sans Serif -
Serif
-
- Stroke Width – 획의 너비를 표시합니다.
-
Font – 드롭다운에서 원하는 스트로크 글꼴을 선택합니다. 선택 가능한 항목은 다음과 같습니다.
- Show Footer – 테이블 바닥글 표시를 활성화/비활성화합니다.
- Alignment – 테이블은 아래에서 위로(Bottom) 또는 위에서 아래로(Top) 확장되도록 구성할 수 있습니다. 이 설정을 사용하면 설계 공간의 주변 객체에 영향을 주지 않고 테이블 크기를 변경할 수 있습니다.
- Table Border Width – 테이블 테두리를 구성하는 선의 너비입니다.
-
Drill Symbols – 클릭하면 홀 크기에 심볼/문자를 할당할 수 있는 Drill Symbols 대화상자가 열립니다.
드릴 심볼 대화상자의 옵션 및 컨트롤
Grid Area
그리드 영역에는 심볼과 홀 크기의 매핑에 대한 상세 정보가 표시됩니다. 열 머리글을 클릭한 채 드래그하여 열 순서를 변경하고, 열 머리글을 마우스 오른쪽 버튼으로 클릭한 다음 체크박스를 선택/해제하여 열을 표시하거나 숨길 수 있습니다.
Grouping
Grouping 버튼을 클릭하여 드릴 작업(홀)에 대한 심볼 할당을 제어할 속성을 설정합니다. 홀은 처음에 홀 크기별로 그룹화되며, 홀을 고유하게 구분하는 그룹화 옵션이 활성화될 때마다 서로 다른 심볼이 할당됩니다. 예를 들어, 설계에 1mm 홀이 있는 원형 패드와 1mm 홀이 있는 사각형 패드가 포함될 수 있습니다. Grouping에서 Pad Shape이 활성화되지 않은 경우 두 패드에 동일한 심볼이 할당됩니다. 반면 Grouping에서 Pad Shape가 활성화된 경우에는 서로 다른 심볼이 할당됩니다.
Graphic Symbol
각 홀 위치는 심볼, 문자 또는 실제 홀 크기를 나타내는 문자열로 표시할 수 있습니다. 다음 옵션은 심볼 스타일과 크기를 제어합니다.
-
Symbol - 각 홀 위치에 심볼을 사용하려면 선택합니다. 소프트웨어에는 아래 이미지와 같이 15가지 사전 정의된 심볼 스타일이 포함되어 있습니다. 홀 크기가 15종을 초과하면 알파벳 문자가 자동으로 할당됩니다.
- Character - 각 홀 위치에 알파벳 문자를 사용하려면 선택합니다.
- Symbol Size - 드릴 도면 레이어에 표시되는 심볼/문자의 높이입니다. 이 설정은 드릴 도면에 사용되는 모든 심볼/문자에 적용됩니다.
Draw Symbols
다음 옵션은 드릴 심볼의 스타일과 표시 시점을 제어합니다.
- Show Symbols - 각 홀 위치에 심볼을 표시합니다.
- Show Hole Size - 각 홀 위치에 실제 드릴 크기를 숫자로 표시합니다.
- Show Drill Symbols - 기본적으로 드릴 도면 레이어에는 드릴 심볼이 표시되지 않습니다. 드릴 심볼을 표시하려면 이 옵션을 활성화합니다.
-
-
– 드릴 테이블에 영향을 주는 설계 변경이 있을 때 클릭하여 테이블을 새로 고칩니다. 출력 생성 중에는 테이블이 자동으로 업데이트됩니다.
단위
-
Primary Units – 드롭다운에서 기본 단위를
Metric (mm)또는Imperial (mil)로 설정합니다. -
Dual Units – 드롭다운에서 보조 단위를
Metric (mm)또는Imperial (mil)로 설정합니다.
또는
을 사용하여 설계 공간에서 이 단위를 각각 표시하거나 숨깁니다.
정밀도
- Primary Precision – 드롭다운에서 필요한 정밀도(소수 자릿수)를 설정합니다.
- Dual Precision – 드롭다운에서 보조 정밀도(소수 자릿수)를 설정합니다.
열
- Grid – 드릴 테이블의 모든 열 제목(Caption), Grid 내에서 내용의 위치를 조정하는 Align 설정, Width, 각 열의 정보가 표시되는 Order을 표시합니다. 오름차순에서 내림차순으로 또는 그 반대로 변경하려면 Order 열을 클릭하여 드롭다운 메뉴를 연 다음 원하는 정렬 순서를 선택합니다: Asc – 오름차순 또는 Dsc – 내림차순.
-
Edit Columns – 클릭하면 드릴 테이블에 새 열을 추가하거나 기존 열을 편집할 수 있는 Columns 대화 상자가 열립니다.
이 대화 상자에는 기존의 모든 열과 관련 데이터(읽기 전용)가 표시됩니다. Grid 아래의 다음 버튼을 사용하여 테이블에 표시할 데이터를 구성합니다:
- Add Column - 드릴 테이블에 새 열을 추가할 때 사용합니다. 클릭하면 사용 가능한 열의 메뉴가 열립니다. 이미 사용 중이거나 사용할 수 없는 열은 메뉴에서 회색으로 표시됩니다. 이 명령은 마우스 오른쪽 버튼 클릭 메뉴에서도 사용할 수 있습니다.
- Remove Column - 클릭하면 선택한 열이 제거됩니다. 확인 대화 상자는 표시되지 않으며, 버튼을 클릭하면 열이 삭제됩니다. 이 명령은 마우스 오른쪽 버튼 클릭 메뉴에서도 사용할 수 있습니다.
- Change Header - 클릭하면 선택한 열의 제목을 변경할 수 있는 열 머리글 변경 대화 상자가 열립니다. 이 명령(Change column header)은 마우스 오른쪽 버튼 클릭 메뉴에서도 사용할 수 있습니다.
마우스 오른쪽 버튼 클릭 컨텍스트 메뉴에서 다음 추가 명령을 사용할 수 있습니다:
-
Text Alignment - 선택한 열의 텍스트를 정렬할 때 사용합니다. 선택 항목은
Left,Center,Right입니다. -
Set column width - 선택한 열의 너비를 설정할 때 사용합니다. 선택 항목은
Autosize(기본값) 및Manual입니다.Manual을 클릭하면 원하는 너비를 입력할 수 있는 열 너비 설정 대화 상자가 열립니다.
설계 뷰

보드의 특정 영역을 표시하려면 설계 뷰를 배치합니다. 이 예는 200%로 확대되어 있습니다.
PCB 설계 뷰 객체는 현재 보드 또는 다른 보드의 직사각형 영역을 그래픽으로 캡처한 스냅샷입니다. 설계 공간의 어느 곳에나 배치할 수 있으며 원하는 크기로 확대하거나 축소할 수 있습니다.
설계 뷰는 PCB Editor에서만 배치할 수 있습니다. 설계 뷰 배치 명령(Place » Design View)을 실행하면 설계 뷰가 커서에 연결된 상태로 나타납니다. 설계 뷰를 적절한 위치로 이동한 다음 클릭하거나 Enter 키를 눌러 배치합니다.
배치 중 설계 뷰가 아직 커서에 연결되어 있고 위치가 확정되기 전에 수행할 수 있는 추가 작업은 다음과 같습니다:
- Alt 키를 누르면 초기 이동 방향에 따라 이동 방향이 수평축 또는 수직축으로 제한됩니다.
설계 뷰를 배치한 후 다음 단계를 수행하여 원하는 레이어의 표시 여부를 지정할 수 있습니다:
- 설계 공간에서 설계 뷰를 선택한 상태로 두 번 클릭하거나 마우스 오른쪽 버튼을 클릭한 다음 컨텍스트 메뉴에서 Properties 을 선택하여 Properties 패널을 엽니다.
- Properties 패널의 Define 버튼을 사용하여 관심 영역을 대화형으로 지정합니다.
-
Properties 패널의 Layers 섹션에서
아이콘을 클릭(전환)하여 원하는 레이어가 표시되도록 설정합니다. Properties 패널에서 활성화하면 해당 레이어에
아이콘이 표시됩니다.
설계 뷰는 인쇄 및 PDF 출력에 포함됩니다. 설계 뷰는 출력 시 자체 레이어 표시 설정을 유지하므로 인쇄/PDF 출력에서 원하는 방식으로 표시할 수 있습니다. 단, 설계 뷰에 사용된 레이어의 프리미티브에는 인쇄 대화 상자에서 해당 레이어에 대해 지정한 표시 설정이 계속 적용됩니다. 예를 들어 설계 뷰에 Top Overlay가 표시되고 Output Job에서 해당 출력의 Top Overlay 트랙을 Draft 모드로 표시하도록 설정한 경우, 설계 뷰의 Top Overlay 트랙도 Draft 모드로 표시됩니다.
설계 공간에 설계 뷰를 배치한 후에는 뷰의 위치, 배율, 크기 및 표시 영역을 대화형으로 조정할 수 있습니다.
- Change the position – 설계 뷰 객체를 PCB 설계 공간의 새 위치로 Click+Drag.
- Adjusting the Scale – 한 번 클릭하여 설계 뷰를 선택한 다음 모서리 핸들에서 Click+Drag하여 설계 뷰를 확대(바깥쪽으로 드래그)하거나 축소(안쪽으로 드래그)합니다.
- Adjusting the View Size – 한 번 클릭하여 설계 뷰를 선택한 다음 모서리 핸들에서 Ctrl+Click+Drag하여 설계 뷰의 크기를 조정합니다.
- Changing the Focus – Ctrl+Click+Drag 설계 뷰 내의 아무 곳에서 수행하면 현재 표시 중인 영역을 설계 뷰 창 안에서 이동할 수 있습니다.

Ctrl+Click+Drag하여 설계 뷰에 현재 표시 중인 영역을 이동하고 조정합니다.
설계 뷰 속성

Properties 패널의 Design View 모드.
위치
- (X/Y) - 설계 뷰 기준점의 현재 X 및 Y 위치입니다.
속성
- This document - 현재 활성 문서의 속성을 지정하려면 선택합니다.
-
Specify document - 다른 문서의 속성을 지정하려면 선택합니다. 선택한 후 Document 필드에서
을 클릭하고 원하는 문서를 찾습니다.
-
Document - Specify document 이 선택된 경우
을 클릭하여 원하는 문서를 검색하고 선택합니다.
- Mirrored - 클릭하면 설계 뷰의 보드 영역을 뒤집힌(미러링된) 이미지로 표시합니다.
- Scale - 클릭하여 객체 크기를 배율로 지정합니다.
- Title - 설계 뷰의 제목을 입력합니다.
- Text Height - 설계 뷰 제목의 텍스트 높이를 입력합니다.
- Font - 드롭다운을 사용하여 제목에 사용할 글꼴을 선택합니다. 색상 상자를 사용하여 제목 텍스트의 색상 선택기를 엽니다. 텍스트가 잘 보이도록 설계 공간의 배경색과 대비되는 색상을 선택해야 합니다.
- Define - 클릭하면 십자형 커서가 표시된 설계 공간으로 돌아갑니다. 그런 다음 클릭하여 드래그하는 방식으로 뷰의 직사각형 영역을 지정합니다.
레이어
이 영역에는 설계 뷰에 특정 레이어가 표시되도록 구성할 수 있는 모든 보드 레이어의 목록이 제공됩니다.
-
Name - 레이어의 이름입니다. 다음을 사용합니다:
또는
아이콘을 사용하여 설계 뷰에서 목록에 있는 레이어를 각각 표시하거나 숨깁니다.
- Type - 레이어 유형입니다.
OLE 개체

배치된 OLE 개체 모음 – 이미지, 스프레드시트 셀, Word 문서 텍스트(위에서 아래 순)
PCB 편집기의 개체 연결 및 삽입(OLE) 기술을 사용하면 Windows OLE 애플리케이션에서 제공하는 데이터를 원본 애플리케이션과의 연결을 유지하면서 PCB 설계에 삽입할 수 있습니다. 대부분의 경우 삽입된 PCB 데이터를 해당 데이터를 생성한 애플리케이션에서 편집할 수 있습니다.
PCB 문서에 배치할 수 있는 일반적인 OLE 개체로는 Excel 문서, Word 문서, 적절한 OLE 이미지 애플리케이션의 그래픽 개체 등이 있습니다. 지원되는 파일 형식에는 CSV 및 XLS 형식의 스프레드시트, DOC 및 RTF 형식의 워드 문서, BMP 이미지 파일과 같은 범용 형식이 포함됩니다.
OLE 개체는 PCB Editor에서 배치하거나 삽입할 수 있습니다. Place » Object From File 명령을 실행한 후 Choose File 대화 상자에서 원하는 파일을 선택하고 클릭하여 설계 공간에 개체를 배치합니다.
Altium의 스마트 Paste 기능을 사용하면 OLE 애플리케이션에서 선택한 내용을 복사하여 PCB 문서에 OLE 개체로 붙여넣을 수도 있습니다(Edit » Paste). 필요한 경우 텍스트 붙여넣기 옵션(Edit » Paste Text)을 사용하여 OLE 개체에서 텍스트 요소만 추출할 수 있습니다. 추출된 요소는 PCB 텍스트 개체로 배치됩니다.
삽입된 개체를 배치한 후에는 선택 핸들을 클릭한 상태로 드래그하여 비율을 유지하면서 크기를 조절할 수 있습니다. Word 및 Excel 문서와 같은 텍스트 기반 개체의 경우 삽입된 텍스트의 크기와 두께가 새 치수에 맞게 자동으로 조절됩니다.
- Tools » Convert » Explode OLE Object to Free Primitives 명령을 사용하면 OLE 개체를 독립 프리미티브 개체 모음으로 변환할 수도 있습니다. 이 명령은 개체를 적절한 Region 및/또는 텍스트 개체로 분리합니다.
- OLE 개체를 편집하려고 할 때 해당 OLE 애플리케이션을 찾을 수 없는 경우에도 독립 프리미티브로 변환하는 옵션이 제공됩니다.
OLE 개체 속성

Properties 패널의 OLE Object 모드입니다.
위치
- (X/Y) - 현재 설계 공간 원점을 기준으로 한 개체 기준점의 현재 X(수평) 좌표와 Y(수직) 좌표입니다. 개체의 위치를 변경하려면 이 값을 편집합니다.
- Rotation - 0도(3 o'clock 수평)를 기준으로 시계 반대 방향으로 측정한 개체의 회전 각도(도 단위)입니다. 개체의 회전을 변경하려면 이 값을 편집합니다. 최소 각도 분해능은 0.001°입니다.
속성
- Layer - 개체가 현재 할당된 레이어입니다. 드롭다운을 사용하여 다른 레이어를 선택합니다.
- Edit Data - 클릭하면 연결된 애플리케이션에서 개체를 열어 필요한 내용을 편집할 수 있습니다. 편집을 마친 후 연결된 애플리케이션을 닫고 Properties 패널에서 Save 을 클릭하여 편집 내용을 저장하거나 Cancel을 클릭합니다.
치수
PCB 및 PCB 라이브러리 편집기에는 다양한 설계 요구 사항을 충족하는 여러 치수 기입 도구가 포함되어 있습니다.
| 치수 개체 | 설명 |
|---|---|
| Angular Dimension | 각도를 치수로 기입할 수 있습니다. |
| Baseline Dimension | 하나의 기준을 기준으로 여러 참조점의 직선 거리를 치수로 기입할 수 있습니다. 처음 선택한 점이 '기준점'이 됩니다. 이후의 모든 점은 이 첫 번째 점을 기준으로 합니다. 따라서 각 치수 값은 Default 단위로 측정한 각 참조점과 '기준점' 사이의 거리입니다. 참조 대상은 트랙, Arc, 패드, 비아, 텍스트, 채우기, 폴리곤 또는 컴포넌트가 될 수 있습니다. |
| Center Dimension | Arc 또는 원의 중심을 표시할 수 있습니다. |
| Leader Dimension | 개체, 점 또는 영역에 라벨을 지정할 수 있습니다. 지시선은 자동, 원형, 사각형의 세 가지 유형을 사용할 수 있으며, 라벨 텍스트를 원이나 사각형으로 둘러싸거나 아무 테두리 없이 표시할 수 있습니다. 포인터는 화살표 또는 점으로 표시할 수 있습니다. |
| Linear Dimension | 직선 거리를 치수로 기입할 수 있습니다. 치수 값은 Default 단위로 측정한 시작 마커와 끝 마커(사용자가 선택한 참조점) 사이의 거리입니다. 참조 대상은 개체(트랙, Arc, 패드, 비아, 텍스트, 채우기, 폴리곤 또는 컴포넌트) 또는 빈 공간의 점이 될 수 있습니다. |
| Linear Diameter Dimension | Arc 또는 원에 대해 반지름 대신 지름을 치수로 기입할 수 있습니다. 치수는 내부 또는 외부에 배치할 수 있습니다. |
| Ordinate Dimension | 하나의 기준 개체를 기준으로 여러 개체의 직선 거리를 치수로 기입할 수 있습니다. 처음 선택한 개체가 '기준 개체'가 됩니다. 이후의 모든 개체는 이 첫 번째 개체를 기준으로 합니다. 따라서 각 치수 값은 Default 단위로 측정한 각 참조 개체와 '기준 개체' 사이의 거리입니다. 참조 대상은 트랙, Arc, 패드, 비아, 텍스트, 채우기, 폴리곤 또는 컴포넌트가 될 수 있습니다. |
| Radial Dimension | Arc 또는 원의 반지름을 치수로 기입할 수 있습니다. 치수는 내부 또는 외부에 배치할 수 있습니다. |
| Radial Diameter Dimension | Arc 또는 원에 대해 반지름 대신 지름을 치수로 기입할 수 있습니다. 치수는 Arc/원의 둘레를 기준으로 내부 또는 외부에 배치할 수 있습니다. |
| Standard Dimension | 현재 PCB 레이어에 치수 정보를 배치합니다. 치수 값은 Default 단위로 측정한 시작 마커와 끝 마커 사이의 거리입니다. |
치수 개체는 기본 메뉴의 Place » Dimension 하위 메뉴에서 사용할 수 있습니다. 개체에 치수를 기입할 때는 치수를 연결할 수 있는 위치를 강조 표시하는 앵커 포인트가 나타납니다. 상태 표시줄에는 전체 과정에서 각 단계에 필요한 작업 정보가 표시됩니다. 커서에 가장 가까운 점이 사용되며, 클릭하거나 Enter을 누르면 해당 지점에 치수가 연결됩니다.
아래 동영상에서 몇 가지 치수 배치 예를 확인할 수 있습니다.
배치 중에 수행할 수 있는 추가 작업은 다음과 같습니다.
- 숫자 키패드의 + 및 - 키를 누르면 설계에 표시된 모든 레이어를 각각 정방향 및 역방향으로 순환하여 배치 레이어를 빠르게 변경할 수 있습니다.
- 기준선, 중심, 선형 지름, 선형 또는 좌표 치수를 배치할 때 Spacebar 키를 누르면 치수가 시계 반대 방향으로 회전하고, Shift+Spacebar 키를 누르면 시계 방향으로 회전합니다. 회전은 Preferences 대화 상자의 PCB Editor – 일반 페이지에 정의된 Rotation Step 값에 따라 이루어집니다.
- 표준 치수를 배치할 때 L 키를 누르면 치수가 기판 반대쪽으로 뒤집힙니다. 이 작업은 치수의 시작점을 고정하기 전에만 가능합니다.
치수의 시작점이나 끝점을 이동하면 치수 값이 자동으로 업데이트됩니다(해당하는 경우). 마찬가지로, 치수의 참조점이 고정된 객체의 위치가 변경되면 치수가 업데이트되고 늘어나거나 줄어들어 변경 사항을 반영합니다. 반지름/지름 기반 치수의 경우 참조 Arc 또는 원의 지름이 변경되면 값이 자동으로 업데이트됩니다.
치수 객체가 연결된 참조 객체를 삭제하면 치수도 함께 삭제할지 묻는 대화 상자가 열립니다. 치수를 삭제하지 않으면 설계 공간에 남아 있지만 참조가 없는 상태가 됩니다.
치수 객체는 다음과 같은 방법으로 이동할 수 있습니다.
- Selecting both the dimension object and the dimensioned object(s). 필요에 따라 치수 전체를 새 위치로 드래그할 수 있습니다.
- Selecting a dimensioned object only. 치수 텍스트는 정렬 평면 내에서만 객체를 따라 이동합니다. 치수 보조선(반지름형 지름 또는 반지름 치수의 경우 포인터와 꼬리)은 치수와 측정 대상 객체 간의 관계를 유지하도록 늘어나거나 줄어듭니다. 중심 치수 또는 지시선 치수의 경우 객체와 함께 이동합니다. 지시선 치수의 선분(화살표/점과 처음 정의된 꺾임점 사이)은 치수와 측정 대상 객체 간의 관계를 유지하도록 늘어나거나 줄어듭니다.
- Selecting the dimension object only. 치수가 설계 객체를 참조하는 경우 치수만 단독으로 이동할 수 없다는 점에 유의해야 합니다. 치수만 이동하려면 먼저 측정 대상 객체와의 연결을 해제해야 합니다.
치수 객체를 선택하면 편집 핸들이 표시됩니다. 이 핸들을 사용하면 텍스트 위치 및 참조점과 같은 속성을 그래픽 방식으로 변경하여 설계 공간에서 배치된 치수 객체를 직접 편집할 수 있습니다. 아래는 일부 치수의 편집 핸들 예시입니다.
|
선형 치수 객체를 선택하면 다음 편집 핸들을 사용할 수 있습니다.
각도 치수 객체를 선택하면 다음 편집 핸들을 사용할 수 있습니다.
반지름 치수 객체를 선택하면 다음 편집 핸들을 사용할 수 있습니다.
좌표 치수 객체를 선택하면 다음 편집 핸들을 사용할 수 있습니다.
|
측정 대상 객체 위에 있거나 가장 가까이에 있는 핸들(예: 위 그림에서 선형 치수의 C 및 D, 각도 치수의 C & E 및 D & F)을 사용하면 참조를 다시 정의할 수 있습니다. 참조 객체에서 치수의 연결을 해제하면 참조가 없는 상태가 되며, 다른 참조점이나 객체에 연결하도록 이동할 수 있습니다. 참조가 없는 선형, 좌표 또는 기준선 치수의 편집 핸들을 드래그하는 동안 치수를 회전할 수 있습니다.
치수 객체의 속성
치수에는 다양한 구성 옵션이 있어 화살표와 텍스트를 폭넓게 사용자 지정할 수 있습니다. 하나 이상의 치수 객체를 선택한 다음 Properties Panel을 열어 속성을 편집합니다.
| 속성 | 적용 대상 객체 | 설명 |
|---|---|---|
스타일 |
||
| Width | 중심 및 좌표 치수를 제외한 모든 치수 | 현재 치수선 너비입니다. |
| Width (Extension Line Region 내) | 각도 치수 기준선 치수 선형 치수 선형 지름 치수 좌표 치수 |
현재 치수 보조선 너비입니다. |
| Gap | 각도 치수 기준선 치수 지시선 치수 선형 치수 선형 지름 치수 좌표 치수 |
|
| Offset | 각도 치수 기준선 치수 선형 치수 선형 지름 치수 |
치수 보조선을 기준으로 한 현재 화살표 선 오프셋입니다. |
| Text Gap | 중심 및 표준 치수를 제외한 모든 치수 |
|
| Leader Shape | 지시선 치수 | 드롭다운을 사용하여 치수 텍스트를 둘러쌀 도형을 지정합니다. 사용 가능한 옵션은 Automatic, Round, Square입니다. Round 또는 Square를 선택한 경우 원하는 Size을(를) 입력합니다. |
| Arrow Style | 지시선 치수 | 드롭다운을 사용하여 원하는 지시선 스타일을 선택합니다. 선택 가능한 옵션은 Arrow 또는 Dot입니다. 원하는 Size을(를) 입력합니다. |
| Height | 표준 치수 | 현재 치수 보조선 높이입니다. |
| Arrow Size | 각도 치수 기준선 치수 선형 치수 선형 지름 치수 반지름 치수 방사형 지름 치수 |
현재 화살촉 크기입니다. 크기는 화살표 끝점과 화살촉을 이루는 두 선의 끝 사이 거리로 측정됩니다. |
| Arrow Length | 각도 치수 기준선 치수 선형 치수 선형 지름 치수 반지름 치수 방사형 지름 치수 |
현재 화살표 길이입니다. 이 필드에 입력한 값은 Arrow Position( Properties 영역에 있음)이 Outside(으)로 설정된 경우에만 적용됩니다. |
속성 |
||
| Text | 지시선 치수 | 원하는 텍스트를 입력합니다. |
| Layer | 모두 | 치수가 현재 할당된 레이어입니다. 드롭다운을 사용하여 원하는 레이어를 선택합니다. 치수는 사용 가능한 모든 레이어에 할당할 수 있습니다. |
| Text Position | 중심 치수 및 표준 치수를 제외한 모두 | 치수 텍스트의 현재 위치입니다. 연결된 드롭다운 목록을 사용하여 다음 옵션 중 하나를 선택합니다(사용 가능한 옵션은 치수 객체 유형에 따라 달라짐).
|
| Arrow Position | 각도 치수 기준선 치수 선형 치수 선형 지름 치수 반지름 치수 방사형 지름 치수 |
치수 화살표의 현재 위치입니다. 사용 가능한 옵션은 다음과 같습니다.
|
| Angular Step | 방사형 지름 치수 | 치수의 현재 각도 간격 설정입니다. 치수의 화살표 부분을 배치할 때 사용되는 회전 간격입니다. 치수 배치 중 원이나 호를 따라 화살표를 이동하면, 이 각도 간격 값에 따라 치수를 고정할 수 있는 위치의 수와 위치가 결정됩니다. |
| Text Height | 중심 치수를 제외한 모두 | 치수 텍스트 문자의 현재 높이입니다. 텍스트를 표시하거나 인쇄하는 데 사용되는 문자 너비는 이 높이에 비례하여 자동으로 조정됩니다. 최소 높이를 36mil (0.9mm)로 설정하면 포토플로팅 시 텍스트를 읽기 쉽게 출력할 수 있습니다. |
| Rotation | 중심 치수 선형 치수 선형 지름 치수 좌표 치수 |
치수의 정렬 각도이며, 수평을 기준으로 반시계 방향으로 측정한 도 단위 값입니다. |
| Size | 중심 치수 | 치수의 십자선의 현재 길이(또는 이를 둘러싼 원의 지름)입니다. |
| Font Type | 중심 치수를 제외한 모두 |
|
단위 |
||
| Primary Units | 각도 치수 기준선 치수 선형 치수 선형 지름 치수 좌표 치수 반지름 치수 방사형 지름 치수 |
치수 값의 계산 및 표시에 사용하도록 현재 선택된 단위입니다.
|
| Value Precision | 각도 치수 기준선 치수 선형 치수 선형 지름 치수 좌표 치수 반지름 치수 방사형 지름 치수 |
치수를 표시할 때 소수점 오른쪽에 표시할 자릿수의 현재 설정입니다. |
값 |
||
| Format | 중심 치수 및 지시선 치수를 제외한 모든 치수 |
치수 텍스트 형식의 현재 설정입니다. 필요에 따라 연결된 드롭다운을 사용하여 형식을 변경합니다. 나열되는 옵션은 선택한 Unit 에 따라 달라지며, 현재 치수의 실제 값을 기반으로 표시됩니다. 일반적으로 사용할 수 있는 옵션은 다음과 같습니다(사용 가능한 옵션은 치수 객체 유형에 따라 다름).
|
| Prefix | 각도 치수 기준선 치수 선형 치수 선형 지름 치수 좌표 치수 반지름 치수 방사형 지름 치수 |
치수 값의 접두사입니다. 선형 지름 치수 또는 방사형 지름 치수의 경우 이 필드는 ø 문자로 고정됩니다. |
| Suffix | 각도 치수 기준선 치수 선형 치수 선형 지름 치수 좌표 치수 반지름 치수 방사형 지름 치수 |
치수 값의 접미사입니다. |
| Sample | 중심 치수 및 지시선 치수를 제외한 모든 치수 |
이 필드는 지정된 Format 및 정의된 Prefix 및/또는 Suffix에 따라 치수 텍스트가 어떻게 표시되는지 보여주는 예시를 제공합니다. |
| Start point (X/Y) | 표준 치수 | 치수 시작점의 X(첫 번째 값) 및 Y(두 번째 값) 좌표입니다. |
| End point (X/Y) | 표준 치수 | 치수 끝점의 X(첫 번째 값) 및 Y(두 번째 값) 좌표입니다. |
치수를 프리미티브로 변환
치수는 그룹 설계 객체로, 하나 이상의 문자열 및 트랙 세그먼트로 구성됩니다. Tools » Convert » Explode Dimension to Free Primitives 명령을 사용하여 치수를 구성 프리미티브 객체로 변환할 수 있습니다.



