Trabalhando com corpos 3D extrudados, esféricos e cilíndricos
Num relance
- Conheça as diferenças entre objetos de corpo 3D extrudados, cilíndricos e esféricos, e saiba como cada um é definido e inserido.
- Veja como usar o painel Properties e os atalhos disponíveis durante a execução de comandos para controlar as dimensões, a aparência e o comportamento de inserção das formas.
- Entenda como gerar e gerenciar corpos 3D a partir de formas existentes no footprint usando o Component Body Manager, incluindo opções para componentes individuais e atualizações em lote.
Embora posicionar modelos 3D genéricos seja uma maneira recomendada de usar objetos de corpo 3D, pois isso fornece uma representação precisa e detalhada do componente na PCB e permite testes de colisão 3D mais precisos no editor de PCB, um objeto de corpo 3D também pode ser usado para posicionar formas de corpo 3D extrudadas, esféricas e cilíndricas. Há três tipos de objetos de corpo 3D simples que podem ser posicionados:
| Extruded | No plano X-Y (vista superior), o objeto extrudado é definido interativamente, da mesma forma que outros objetos poligonais são definidos no editor de PCB. O objeto é então extrudado para cima (ou para baixo) no plano Z, com base nas propriedades Overall Height e Standoff Height definidas no modo 3D Body do painel Properties e na opção Body Projection. Você também pode aplicar um arquivo de textura, como um logotipo, à superfície de um objeto de corpo 3D extrudado. |
| Cylindrical | As propriedades desta forma são definidas no modo 3D Body do painel Properties. |
| Spherical | As propriedades desta forma são definidas no modo 3D Body do painel Properties. |
Posicionamento de objetos de corpo 3D extrudados, esféricos ou cilíndricos
Posicionamento direto
Os objetos de corpo 3D extrudados, esféricos e cilíndricos podem ser posicionados tanto no editor de PCB quanto no editor de footprints de PCB das seguintes maneiras:
- Selecionando o comando Place » Extruded 3D Body nos menus principais.
- Localizando e usando o comando Corpo 3D extrudado em Active Bar.
Para posicionar um objeto de corpo 3D extrudado, esférico ou cilíndrico:
- Após iniciar o comando, o cursor mudará para uma cruz e você estará no modo de posicionamento padrão, posicionando um objeto de corpo 3D extrudado.
- Pressione Tab para pausar o posicionamento e exibir o painel Properties no modo Corpo 3D. O botão de pausa sobreposto aparecerá na área de projeto, indicando que você pode acessar os campos do painel Properties.
- No painel Properties, insira um nome para o corpo 3D no campo Identifier. Isso é opcional; o identificador pode ajudar quando vários corpos 3D estiverem sendo posicionados e também pode ser usado para especificar este corpo 3D em uma regra de projeto, se necessário.
-
Selecione o Board Side desejado; normalmente, ele é definido como
Top. No editor de bibliotecas de PCB, o footprint é criado para o lado superior da placa; ele pode ser invertido para o lado inferior durante o processo de projeto da PCB, se necessário. - Selecione a Layer mecânica na qual o corpo 3D será posicionado. As camadas mecânicas do tipo componente devem ser pareadas com uma segunda camada mecânica para que, se o componente for invertido do lado superior da placa para o lado inferior, seus detalhes mecânicos, como o corpo 3D, sejam movidos para a camada mecânica pareada. As camadas mecânicas são pareadas na aba Layers and Colors do painel Configuração de visualização. Consulte a página do painel para obter mais informações.
- Selecione o 3D Model Type entre as formas disponíveis: Extruded, Cylinder ou Sphere.
-
Cada forma deve ter um tamanho definido antes de poder ser posicionada. Se a forma escolhida for:
- Extruded – então defina o Overall Height.
- Cylinder – defina o Height e o Radius.
- Sphere – defina o Radius.
- Na região Display do painel, clique no botão Color para definir a cor e ajuste o Opacity conforme necessário.
-
Quando concluir a edição, clique no botão de pausa sobreposto para retornar à área de projeto.
-
Se a forma for um Cylinder ou Sphere:
- O cursor se moverá na área de projeto com uma forma retangular anexada; clique para posicionar o corpo 3D.
- Clique com o botão direito do mouse ou pressione Esc para encerrar o posicionamento de objetos de corpo 3D.
-
Se a forma for Extruded, o cursor aparecerá pronto para definir a forma poligonal da base do corpo 3D extrudado:
- Clique para definir o primeiro vértice.
- Mova o cursor para posicionar o segundo vértice. O comportamento padrão é posicionar duas arestas a cada clique, com um formato de canto definido pelo usuário entre elas. Consulte a seção Modos de posicionamento de corpos 3D extrudados abaixo para saber mais.
- Continue movendo o mouse e clicando para posicionar mais vértices.
- Após posicionar o último vértice, clique com o botão direito do mouse ou pressione Esc para fechar e concluir o posicionamento do corpo 3D. Não é necessário fechar o corpo 3D manualmente, pois o software completará automaticamente a forma conectando o ponto inicial ao último ponto posicionado.
-
Se a forma for um Cylinder ou Sphere:
Modos de posicionamento de corpos 3D extrudados
Ao posicionar um corpo 3D extrudado, há cinco modos de canto disponíveis, quatro dos quais também possuem submodos de direção do canto. Durante o posicionamento:
- Pressione Shift+Spacebar para alternar entre os cinco modos de canto disponíveis.
- Pressione Spacebar para alternar entre os dois submodos de direção do canto.
-
Em qualquer um dos modos de canto em arco, mantenha pressionadas as teclas
ou
para diminuir ou aumentar o arco. Mantenha a tecla Shift pressionada ao pressionar essas teclas para acelerar o redimensionamento do arco.
- Pressione a tecla de atalho 1 para alternar entre posicionar duas arestas por clique ou uma aresta por clique. No segundo modo, a aresta tracejada é chamada de look-ahead segment.
- Pressione a tecla Backspace para remover o último vértice.

Um objeto de corpo 3D extrudado; observe o ponto de referência mostrado nas vistas 2D e 3D.
Criação a partir de formas fechadas
Para acelerar o processo de construção da forma do componente a partir de corpos 3D, o software pode criar uma série de objetos de corpo 3D extrudados com base em formas fechadas detectadas no footprint. Esse recurso pode ser útil se o componente tiver uma forma incomum, já representada nas formas definidas na serigrafia do componente no footprint. Você também pode adicionar objetos ao footprint em camadas mecânicas e usá-los para criar objetos de corpo 3D adicionais, por exemplo, para criar os pinos.
As imagens abaixo mostram um footprint de transistor TO-92. A partir dele, o contorno desenhado na camada Top Overlay é usado para definir o corpo do transistor no par de camadas de corpo 3D escolhido (denominado Registration Layer na caixa de diálogo). Também foram criados três pequenos quadrados em uma camada mecânica (cada quadrado formado por quatro linhas), usados para definir os pinos do componente no par de camadas de corpo 3D escolhido – as configurações são mostradas na imagem da caixa de diálogo abaixo.

Objetos existentes no footprint podem ser usados para criar novos objetos de corpo 3D.
Para criar objetos de corpo 3D a partir de formas no footprint, execute o comando Tools » Manage 3D Bodies for Current Component; a caixa de diálogo Component Body Manager será aberta. Use-a para ver quais corpos 3D estão sendo usados no componente e quais não estão. Os corpos podem ser adicionados ao componente e/ou removidos dele conforme necessário. Os corpos podem ser de três tipos distintos:
- Um corpo 3D inserido intencionalmente (denominado Component Body em sua descrição).
- Uma forma retangular criada automaticamente pelo software a partir de um retângulo delimitador.
- Uma forma poligonal fechada criada automaticamente pelo software a partir de primitivas de projeto.
Você também pode modificar outras propriedades de um corpo, como alturas, projeção do corpo, camada de referência, cor e opacidade. Observe que a coluna Body State mostra que quatro formas serão usadas para criar objetos de corpo 3D.
Depois que os corpos 3D do componente forem definidos conforme necessário, clicar no botão Close aplicará as alterações.

O software pode criar objetos de corpo 3D com base na forma de objetos existentes.
Observações sobre o uso desta caixa de diálogo:
- O algoritmo de detecção oferecerá uma das seguintes opções: uma forma retangular criada a partir do retângulo delimitador ou uma forma poligonal que acompanha o contorno formado pelas primitivas (traçado ao longo da linha central das trilhas/arcos, se suas extremidades forem coincidentes).
- Para criar um corpo 3D a partir de um objeto existente, clique no texto azul na coluna Body State.
- O Overall Height assume, por padrão, o Height definido no painel Propriedades do footprint.
- Para um pino de componente que atravessa a placa para baixo, defina o Body Projection como Bottom Side.
- Os objetos de corpo 3D são criados quando você clica no botão Close na caixa de diálogo. Se a visualização já estiver no modo 3D, talvez seja necessário atualizá-la (atalho End), alternar para 2D e depois voltar para 3D, ou alternar a opção Show 3D Bodies entre Off e On na guia View Options do painel Configurações de visualização para ver os novos objetos.
- Para editar os corpos 3D de todos os componentes na biblioteca ativa de footprints de PCB atualmente aberta no editor de footprints de PCB, escolha o comando Tools » Manage 3D Bodies for Library nos menus principais.
- Para editar corpos 3D no editor de PCB usando esta caixa de diálogo, você pode acessá-la selecionando o comando Tools » Manage 3D Bodies for Components on Board nos menus principais ou clicando com o botão direito em um componente e selecionando Ações do componente » Gerenciar corpos 3D no menu de contexto.
-
Quando a caixa de diálogo é acessada pelo comando Tools » Manage 3D Bodies for Components on Board (no editor de PCB) ou pelo comando Tools » Manage 3D Bodies for Library (editor de footprints de PCB), a região Components estará disponível na parte superior da caixa de diálogo. Essa região lista cada footprint de componente na biblioteca ativa (no projeto propriamente dito, seria uma lista de todos os componentes da placa). Para cada entrada, são exibidos o designador (disponível apenas no projeto), o nome do footprint, a altura e as informações da biblioteca de origem.
Além disso, uma guia Batch Update adicional estará disponível. Essa guia permite adicionar rapidamente objetos de corpo 3D a todos os componentes ou aos componentes selecionados, em lote. Você pode definir critérios de busca para detectar e criar corpos 3D e para definir suas propriedades. Depois de definir todas as opções do processamento em lote conforme necessário, clique no botão Execute Batch Update . A busca será realizada para cada componente incluído no processo e, quando uma forma de corpo 3D for detectada e criada, esse corpo será adicionado ao componente usando os critérios de propriedades definidos. Nesse modo, as alterações são aplicadas ao executar a atualização em lote.
- A caixa de diálogo permite gerenciar os corpos 3D do componente em um único local, eliminando a necessidade de abrir o painel Properties para cada corpo 3D.
Opções e controles da caixa de diálogo do Gerenciador de corpos de componentes

A caixa de diálogo Component Body Manager (ao fundo) e a caixa de diálogo Gerenciador de corpos do componente (à frente)
Componentes
A região superior da caixa de diálogo lista cada footprint de componente na biblioteca ativa (no projeto propriamente dito, seria uma lista de todos os componentes da placa). Para cada entrada, são exibidos o designador (disponível apenas no projeto), o nome do footprint, a altura e as informações da biblioteca de origem.
Guia Interativa

A guia Interactive da caixa de diálogo Component Body Manager
A versão Component Body Manager da caixa de diálogo apresenta duas guias: a guia Interactive e a guia Batch Update. A guia Interactive permite visualizar facilmente informações sobre o componente selecionado, incluindo pré-visualizações dos corpos do componente e do corpo selecionado.
Corpos de componente existentes e potenciais
-
Existing and Potential Component Bodies - esta região lista todos os corpos de componente existentes (corpos 3D) que estão sendo usados ou que poderiam ser usados para o componente. Cada corpo de componente é listado com as seguintes informações:
-
Description - uma descrição de como o corpo foi criado. Pode ser um corpo 3D inserido intencionalmente (denominado Component Body em sua descrição), uma forma retangular criada a partir de um retângulo delimitador ou uma forma poligonal fechada criada a partir de primitivas de projeto. A descrição de cada corpo (inserido ou criado automaticamente) também incluirá a camada mecânica na qual ele se encontra (ou na qual se encontram os objetos a partir dos quais ele foi criado) e o tamanho de sua área. Os corpos retangulares e poligonais são diferenciados pelos
e
ícones, respectivamente.
- Body State - indica se o corpo está sendo usado no componente (In Component <ComponentDesignator>) ou não (Not In Component <ComponentDesignator>). Clique na entrada para alternar o estado conforme necessário.
- Standoff Height - a distância entre a superfície da placa e a face inferior do Corpo Extrudado. Use um valor negativo para Corpos Extrudados que devem atravessar a PCB para baixo.
- Overall Height - a distância entre a superfície da placa e a face superior do Corpo Extrudado.
- Body Projection - o lado da placa a partir do qual o Corpo 3D será projetado. Use a lista suspensa do campo para escolher Top Side ou Bottom Side (projetar para cima ou para baixo). Essa configuração é alterada automaticamente se o objeto Corpo 3D for invertido para o outro lado da placa como parte da inversão de um componente.
- Registration Layer - a camada mecânica na qual o Corpo 3D se encontra. Use a lista suspensa do campo para escolher entre todas as camadas mecânicas atualmente habilitadas. Se a camada mecânica escolhida estiver pareada, quando o corpo for invertido para o outro lado da placa junto com seu componente, ele também será movido para a camada mecânica pareada.
- Body 3D Color - a cor atual usada para o Corpo 3D. Clique na amostra de cor para acessar a caixa de diálogo padrão Choose Color e atribuir uma cor diferente conforme necessário.
- Body 3D Opacity - o nível atual de transparência do Corpo 3D. Use a lista suspensa do campo para escolher entre Solid (completamente opaco), Hide (torna o corpo invisível), 25% Opacity, 50% Opacity e 75% Opacity.
-
Description - uma descrição de como o corpo foi criado. Pode ser um corpo 3D inserido intencionalmente (denominado Component Body em sua descrição), uma forma retangular criada a partir de um retângulo delimitador ou uma forma poligonal fechada criada a partir de primitivas de projeto. A descrição de cada corpo (inserido ou criado automaticamente) também incluirá a camada mecânica na qual ele se encontra (ou na qual se encontram os objetos a partir dos quais ele foi criado) e o tamanho de sua área. Os corpos retangulares e poligonais são diferenciados pelos
- Component bodies in: <ComponentDesignator> - mostra o footprint 2D do componente com os Corpos 3D sobrepostos cujo Body State está atualmente definido como In Component <ComponentDesignator>. A visualização é dinâmica e muda à medida que corpos são incluídos ou excluídos.
- Selected Body - mostra o corpo atualmente selecionado na lista acima. A área de título da janela também reflete a descrição do corpo.
Aba Atualização em Lote

A aba Batch Update da caixa de diálogo Component Body Manager
A aba Batch Update oferece um recurso para adicionar rapidamente objetos de corpo 3D a todos os footprints ou aos footprints selecionados em uma biblioteca, ou a todos os footprints posicionados ou aos footprints posicionados selecionados em um projeto.
Área da Grade
Use esta região para definir os critérios de busca para detectar e criar corpos 3D e para definir as propriedades dos corpos 3D, como Projection side (também chamado de Projeção do Corpo), Registration Layer, Standoff Height, Overall Height e 3D Body Color.
Cada entrada na lista oferece um escopo diferente quanto às camadas que serão pesquisadas ao detectar e criar possíveis formas de corpo 3D. Cada busca é habilitada individualmente usando a opção da coluna Enabled. É possível habilitar várias buscas; no entanto, lembre-se de que um corpo 3D será adicionado para cada busca bem-sucedida. Normalmente, você habilitaria uma busca em uma camada específica — ou conjunto de camadas — dependendo de onde costuma colocar as primitivas ou as informações de contorno do componente para um footprint. Por padrão, será realizada uma busca em All Layers.
O campo Detection Method permite controlar como cada forma de corpo 3D é definida:
- Bounding Rectangle - usar o retângulo delimitador do footprint.
- Closed Shapes - usar uma forma poligonal fechada criada a partir das primitivas do footprint do componente.
- Both (Prefer Closed Shapes) - detectar um retângulo delimitador ou uma forma poligonal fechada com base nas primitivas do footprint. Se ambos forem detectados, usar a forma poligonal fechada.
A coluna de opção Prefer component height if not 0 permite controlar se o atributo de altura definido para o footprint de um componente será usado como Overall Height do corpo 3D. Com essa opção habilitada, para cada componente com um atributo de altura definido maior que zero, essa altura será definida como Overall Height do corpo 3D adicionado, e seu Standoff Height será definido como zero.
O Body 3-D Color especifica a cor usada para renderizar o corpo 3D. Clique na cor para alterá-la na caixa de diálogo Choose Color.
Opções
- Apply Only To Selected Components - habilite esta opção se quiser aplicar os critérios de corpo 3D apenas a um grupo selecionado de footprints. Certifique-se de que esses componentes estejam selecionados na região superior da caixa de diálogo (use os recursos padrão Ctrl+Click e Shift+Click para selecionar vários itens). Se esta opção estiver desabilitada, o processo de adição em lote será aplicado a todos os footprints da biblioteca (ou a todos os componentes da placa).
- Delete Existing Bodies In Components - habilite esta opção para remover quaisquer corpos 3D atualmente definidos para os footprints abrangidos pelo processo em lote. Use a janela de visualização no canto inferior direito da aba para ter uma ideia de como ficará o corpo 3D adicionado com base no footprint de componente atualmente selecionado e na entrada de busca atualmente selecionada (e habilitada). Depois de definir todas as opções do processo em lote conforme necessário, clique no botão Execute Batch Update. A busca será realizada para cada footprint incluído no processo e, quando uma forma de corpo 3D for detectada e criada, esse corpo será adicionado ao footprint usando os critérios de propriedades definidos.
Visualização da Operação em Lote
Use para visualizar os corpos 3D definidos em diferentes camadas.
Controle Adicional
- Execute Batch Update - clique para prosseguir com a atualização de cada footprint incluído no processo e, quando uma forma de corpo 3D for detectada e criada, esse corpo será adicionado ao footprint usando os critérios de propriedades definidos.
Criação a partir de Primitivas Selecionadas
Além de posicionar um Corpo 3D interativamente, também é possível criá-lo a partir de um conjunto de objetos existentes de trilha, arco e região sólida que definam uma forma fechada. Essa é uma excelente opção quando o modelo é simples. Para definir um Corpo 3D a partir de uma forma fechada existente:
- Selecione todas as primitivas que formam a forma fechada.
- Clique em Tools » Convert » Create 3D Body From selected primitives.
O Corpo 3D será criado a partir do contorno fechado formado pelas primitivas na camada superior (Top Layer), independentemente da camada em que as trilhas selecionadas estejam localizadas. Isso significa que você pode definir a forma em uma camada mecânica. Observe que as primitivas originalmente selecionadas continuarão existindo após a criação da região e permanecerão selecionadas. O contorno do Corpo 3D segue a linha central dos objetos de trilha que o delimitam, e o Corpo 3D não fica selecionado.
Como o algoritmo Create 3D Body From selected primitives usa a linha central dos objetos selecionados, ele exige que as posições final e inicial dos objetos que se tocam coincidam exatamente (na mesma posição X, Y). Se isso não ocorrer, uma caixa de diálogo Confirm será exibida, indicando o local onde o algoritmo falhou e também oferecendo a possibilidade de instruir o algoritmo a tentar definir o Corpo 3D a partir das bordas dos objetos. Desde que os objetos selecionados se sobreponham ligeiramente, essa opção deverá criar um Corpo 3D cuja borda acompanhe a borda externa dos objetos selecionados.
Edição Gráfica
O método de edição gráfica permite selecionar um objeto de corpo 3D posicionado diretamente no espaço de projeto e alterar graficamente seu tamanho, forma ou localização.
Para um corpo 3D extrudado, clique uma vez no objeto para selecioná-lo, colocando-o no modo de edição. A forma externa do objeto de corpo 3D é definida por uma série de arestas: cada aresta é representada por um vértice em cada extremidade, mostrado como um quadrado branco preenchido (A na imagem abaixo), e um vértice central no meio, mostrado como um quadrado branco vazio (B na imagem abaixo). Cada vértice de extremidade representa o local onde duas arestas se encontram.
As técnicas padrão de edição de formas poligonais estão disponíveis para editar a forma.
Ao editar um objeto poligonal, há três modos de edição disponíveis: Slide/Miter, Incurvate (arco) e Move. O modo atual pode ser alterado while dragging a vertex or an edge pressionando Shift+Spacebar para alternar entre os 3 modos.
- Slide/Miter – clique e mantenha pressionado em uma aresta ou em um vértice central para deslizar essa aresta; clique e mantenha pressionado em um vértice de extremidade para chanfrar o canto.
- Incurvate – clique e mantenha pressionado em uma aresta ou em um vértice central para curvar essa aresta; clique e mantenha pressionado em um vértice de extremidade para arredondar o canto (chanfro em arco).
- Move – clique e mantenha pressionado em uma aresta ou em um vértice central para dividir essa aresta em duas; clique e mantenha pressionado em um vértice de extremidade para mover esse canto livremente.
Durante a edição, você também pode:
- Ctrl+click and hold em qualquer ponto ao longo de uma aresta longe das alças de edição para inserir um novo vértice.
- Para remover um vértice, clique e mantenha pressionado sobre ele e, em seguida, pressione a tecla Delete.
-
Clique em qualquer ponto do corpo 3D longe das alças de edição e arraste para reposicioná-lo. Durante o arraste, o corpo 3D pode ser girado ou espelhado:
- Pressione Spacebar para girar o corpo 3D no sentido anti-horário ou Shift+Spacebar para girá-lo no sentido horário. O valor de Rotation Step é definido na página Editor de PCB – Geral da caixa de diálogo Preferences.
- Pressione as teclas X ou Y para espelhar o corpo 3D ao longo do eixo X ou Y.
Conversão para STEP
Um objeto de corpo 3D extrudado/cilíndrico/esférico selecionado para um modelo STEP. O modelo STEP é incorporado automaticamente ao arquivo de projeto. Para converter um objeto de corpo 3D livre, selecione-o no espaço de projeto, clique com o botão direito e escolha o comando Convert To STEP no menu de contexto. O comando não estará disponível se nenhum objeto estiver selecionado ou se houver mais de um objeto selecionado. Depois que um objeto for convertido para STEP, ele não poderá mais ser redimensionado no espaço de projeto.

Converta uma forma extrudada para STEP se precisar girá-la em torno dos eixos X ou Y.
Ponto de referência de um objeto de corpo 3D extrudado, esférico ou cilíndrico
Um objeto de corpo 3D extrudado, esférico ou cilíndrico tem um ponto de referência ou origem.
- Para um cilindro e uma esfera, a referência é o ponto central da forma circular do objeto no plano X-Y.
- Para um objeto extrudado, a referência é definida na posição Comprimento em X/2, Comprimento em Y/2 quando visto de cima.
- É a posição desse ponto de referência no espaço de projeto que é mostrada em X/Y Location no painel Properties.

Os objetos de corpo 3D extrudado, esférico e cilíndrico têm um ponto de referência, conforme mostrado nas imagens. Observe que as linhas do ponto de referência são curtas e, por isso, podem não aparecer fora do objeto.
Inclusão de uma textura em um corpo 3D extrudado
Os objetos extrudados também podem incluir uma imagem sobreposta à superfície superior — proporcionando maior realismo à sua placa quando visualizada em 3D. Quando um Texture File é adicionado, ele é esticado automaticamente para cobrir toda a superfície superior do corpo 3D, conforme mostrado na imagem abaixo. Observe que o arquivo de textura é vinculado ao arquivo da biblioteca ou da placa.
Os formatos de arquivo de textura compatíveis incluem: *.bmp; *.dds; *.dib; *.hdr; *.jpg; *.pfm; *.png; *.ppm; e *.tga.

Uma textura ou um logotipo pode ser adicionado a um objeto de corpo 3D extrudado.
Isso pode ser ajustado alterando a localização Center e as configurações Size e Rotation no modo 3D Body do painel Properties.
Você também pode modificar a posição de um objeto de textura associado a um modelo 3D extrudado escolhido selecionando o comando Tools » 3D Body Placement » Move Texture Location nos menus principais quando o editor estiver configurado no modo de layout 3D. Após iniciar o comando, o cursor mudará para cones azuis (indicando o modo de seleção 3D) e você será solicitado a selecionar um corpo 3D extrudado que tenha uma textura associada. Posicione o cursor sobre o corpo 3D desejado e clique ou pressione Enter. Clique ou pressione Enter uma segunda vez para “pegar” a textura pelo canto mais próximo. Mova a textura para a posição desejada e clique ou pressione Enter para posicioná-la. As ações adicionais padrão para movimentação de objetos (Spacebar/Shift+Spacebar para girar, X ou Y para espelhar, teclas de seta para deslocar a textura em pequenos incrementos) podem ser executadas durante a movimentação, enquanto a textura ainda estiver presa ao cursor.
Como alternativa, você pode mover a textura em um corpo 3D extrudado selecionado usando o mouse para clicar e arrastar.