Доступ, определение и управление опциями проекта
Altium Essentials: Schematic Electrical Rules Validation
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Вкладки General, Error Reporting и Options диалогового окна Project Options
Общие сведения
Существующий или вновь созданный проект имеет набор настроек, характерных именно для этого проекта. Они хранятся в файле проекта (например, *.PrjPcb) и зависят от типа проекта. Настройка параметров выполняется в диалоговом окне Project Options.
Доступ
Диалоговое окно Project Options можно открыть одним из следующих способов:
- Щелкните правой кнопкой мыши запись проекта на панели Projects, затем выберите Project Options в контекстном меню.
-
Нажмите значок
на панели Projects, когда на ней выбран нужный проект.
- В любом редакторе выберите Project » Project Options в главном меню.
Вкладки диалогового окна
Общие

Вкладка General диалогового окна Project Options
Вкладка General диалогового окна Project Options позволяет управлять доступностью проекта в интернете и его синхронизацией с рабочим пространством.
Параметры и элементы управления
При открытии для проекта без подключения к его рабочему пространству доступна только кнопка Turn Off Synchronization.
При открытии для проекта, не связанного с рабочим пространством, на вкладке General диалогового окна Project Options будет отображаться только кнопка Make Project Available Online. Нажмите ее, чтобы открыть диалоговое окно Make Available Online, с помощью которого можно добавить проект в рабочее пространство, выполнив необходимые действия. После завершения этой процедуры станут доступны все параметры на вкладке диалогового окна.
Общие
- Description — в этом поле можно указать необязательное описание проекта, которое будет отображаться в поле описания при просмотре проекта в веб-интерфейсе рабочего пространства.
Доступность в интернете и синхронизация
-
Version Control — состояние этого флажка отражает текущий режим доступности в интернете. Установите его, чтобы хранить проект под управлением системы контроля версий (VCS) в Git-репозитории проектов Versioned Storage рабочего пространства, или снимите его, чтобы использовать простую синхронизацию. Включение полноценного контроля версий позволяет нескольким пользователям работать над проектом: он становится доступен всем остальным участникам, подключенным к вашему рабочему пространству.
-
Migrate to Altium 365 Versioned Storage — включите этот параметр, чтобы перенести проект, использующий внешнюю систему VCS, во встроенную систему VCS рабочего пространства Altium 365. После преобразования проект сохранит историю коммитов VCS и сможет использовать встроенные функции рабочего пространства, основанные на контроле версий, например хронологию событий. Этот параметр доступен только для зеркалируемого проекта.
-
Server Folder — папка рабочего пространства, в которой находится проект.
-
Enable Conflict Prevention Notifications — включите этот параметр, чтобы управлять доступом к редактированию файлов: если участник команды редактирует тот же документ проекта рабочего пространства, вы получите предупреждение, что поможет избежать конфликтов данных.
-
Turn Off Synchronization — нажмите эту кнопку, чтобы отключить синхронизацию. После этого локальная копия проекта больше не будет связана с проектом в рабочем пространстве. Сам проект в рабочем пространстве останется без изменений.
Требования
-
Link Requirements — если блок Requirements Portal не связан с проектом, нажмите эту кнопку, чтобы открыть диалоговое окно Link Requirements и выбрать блок для связи с проектом.
-
Linked Requirements — если блок Requirements Portal связан с проектом, здесь отображается связанный блок Нажмите ссылку, чтобы изменить текущее сопоставление проекта и блока. Нажмите кнопку Unlink, чтобы удалить связь.
Подробнее см. на странице Требования в проекте.
Отчеты об ошибках

Вкладка Error Reporting диалогового окна Project Options (для проекта печатной платы)
Вкладка Error Reporting диалогового окна Project Options позволяет задать уровни отчетности для каждого из возможных нарушений электрических правил и правил оформления, которые могут присутствовать в исходных документах схемы при проверке проекта. Во время проверки проекта эти настройки нарушений используются совместно с настройками на вкладке Connection Matrix для проверки исходных документов на нарушения связности.
Параметры и элементы управления
Список нарушений
В этом списке представлены все возможные нарушения электрических правил и правил оформления, которые могут присутствовать в исходных документах проекта. Нарушения сгруппированы по следующим категориям:
PCB Design:
Multi-board Design:
Harness Design:
Для каждого типа нарушения представлены следующие поля:
- Violation Type Description — краткое описание типа нарушения.
-
Report Mode — используйте это поле, чтобы указать уровень серьезности нарушения, выявленного при проверке. В раскрывающемся списке можно выбрать один из следующих уровней отчетности:
-
Контекстное меню
В контекстном меню доступны следующие команды:
- All Off — установить для Report Mode значение No Report для всех типов нарушений.
- All Warning — установить для Report Mode значение Warning для всех типов нарушений.
- All Error — установить для Report Mode значение Error для всех типов нарушений.
- All Fatal — установить для Report Mode значение Fatal Error для всех типов нарушений.
- Selected Off — установить для Report Mode значение No Report для всех выбранных типов нарушений.
- Selected To Warning — установить для Report Mode значение Warning для всех выбранных типов нарушений.
- Selected To Error - установите Report Mode для всех выбранных типов нарушений в значение Error.
- Selected To Fatal - установите Report Mode для всех выбранных типов нарушений в значение Fatal Error.
- Default - восстановите значения по умолчанию для Report Mode для всех типов нарушений.
- Report Suppressed Violations in Messages Panel - включите этот параметр, чтобы отображать нарушения на панели Messages, даже если они были подавлены на этой вкладке.
Дополнительный параметр
- Set To Installation Defaults - нажмите, чтобы восстановить исходные настройки вкладки, заданные при установке.
Матрица соединений

Вкладка Connection Matrix диалогового окна Project Options
Вкладка Connection Matrix диалогового окна Project Options содержит матрицу, позволяющую задавать правила соединения выводов компонентов и идентификаторов цепей, таких как порты и входы листов. Она определяет логические или электрические условия, о которых следует сообщать как о предупреждениях или ошибках. Например, соединение одного выходного вывода с другим обычно считается ошибкой, а соединение двух пассивных выводов — нет. При проверке проекта эти настройки нарушений используются совместно с настройками, заданными на вкладке Отчеты об ошибках, для проверки исходных документов на наличие нарушений.
Параметры и элементы управления
Матрица соединений
Матрица охватывает все возможные проверки электрических соединений между различными сочетаниями выводов, портов и входов листов, а также проверки наличия неподключенных объектов. Матрица читается по строкам и столбцам, а цвет элемента на пересечении строки и столбца определяет реакцию компилятора при обнаружении соответствующего условия.
Чтобы изменить режим уведомления для проверки нарушения в матрице, щелкните цветной квадрат на пересечении строки и столбца двух объектов. При каждом щелчке выбирается следующий уровень уведомления. Поддерживаются следующие уровни:
- No Report
- Warning
- Error
- Fatal Error
Контекстное меню
В контекстном меню, вызываемом правой кнопкой мыши, доступны следующие команды:
- All Off - установите для всех элементов матрицы значение No Report.
- All Warning - установите для всех элементов матрицы значение Warning.
- All Error - установите для всех элементов матрицы значение Error.
- All Fatal - установите для всех элементов матрицы значение Fatal Error.
- Default - восстановите значения по умолчанию для всех элементов.
Дополнительный параметр
- Set To Installation Defaults - нажмите, чтобы восстановить исходные настройки вкладки, заданные при установке.
Создание классов

Вкладка Class Generation диалогового окна Project Options
Вкладка Class Generation диалогового окна Project Options позволяет настраивать создание классов и управлять им. Классы представляют собой логические объединения объектов проекта определенного типа. Например, группу взаимосвязанных компонентов можно объединить в отдельный класс компонентов, который затем можно использовать для создания правила, применяемого именно к этой группе. На этой вкладке можно указать, какие классы создаются автоматически и какие пользовательские классы создаются при синхронизации исходных документов схемы с документом печатной платы.
Параметры и элементы управления
Автоматически создаваемые классы
-
Generate Net Classes for Buses - установите этот флажок, чтобы автоматически создавать класс цепей для каждой шины в проекте. В класс войдут отдельные цепи, составляющие шину, на основе которой был создан этот класс.
-
Generate Net Classes for Components - установите этот флажок, чтобы автоматически создавать класс цепей для каждого компонента в проекте. В класс войдут цепи, к которым подключены выводы компонента, на основе которого был создан этот класс.
-
Generate Separate Net Classes for Bus Sections - установите этот флажок, чтобы автоматически создавать отдельный класс цепей для каждой секции шины. Секция шины создается путем задания шины, которая фактически является частью более крупной шины, например
D[15..8]из шиныD[15..0]. -
Generate Net Classes for Named Signal Harnesses - включите этот параметр, чтобы автоматически создавать класс цепей для каждого именованного сигнального жгута в проекте. В класс войдут цепи, соответствующие сигналам, объединенным в именованный сигнальный жгут, на основе которого был создан этот класс.
-
Sheet-Level Class Generation Grid - эта область позволяет управлять автоматическим созданием классов компонентов и/или цепей на уровне отдельных листов схемы. Здесь перечислены все исходные листы схемы проекта со следующей информацией для каждого из них:
- Sheet Name - имя документа схемы.
- Full Path - абсолютный путь к папке, в которой находится документ.
-
Component Classes - установите этот флажок, чтобы создать класс компонентов для листа.
- Generate Rooms - установите этот флажок, чтобы создать область размещения (Room) для класса компонентов.
-
Net Classes Scope - в этом поле задайте, нужно ли создавать класс цепей для листа и, если да, какие цепи в него включать. В раскрывающемся списке доступны следующие варианты:
- None - не создавать класс цепей для этого листа.
- Local Nets Only - создать класс цепей для этого листа, включив в него только локальные цепи листа.
- All Nets - создать класс цепей для этого листа, включив в него все связанные с листом цепи (локальные и выходящие за его пределы).
-
Structure Classes Generate Structure - установите этот флажок, чтобы создать структурный класс для листа.
Структурный класс — это особый тип класса, элементами которого могут быть классы любого типа (классы цепей, классы компонентов и т. д.). Автоматическое создание структурного класса для каждого листа схемы проекта, содержащего компоненты и/или цепи, при передаче проекта на печатную плату позволяет точно воспроизвести структуру проекта на стороне платы. Структурные классы позволяют не только воспроизвести структуру документов схемы в редакторе печатных плат для удобной навигации, но и использовать ее в логических запросах, например при задании области действия правил проектирования или фильтрации.
Пользовательские классы
- Generate Component Classes - установите этот флажок, чтобы создавать пользовательские классы компонентов при передаче проекта на печатную плату. Классы компонентов задаются на схеме вручную: для этого к нужным компонентам добавляют параметр ClassName и присваивают ему значение, соответствующее требуемому имени класса.
- Generate Rooms for Component Class - установите этот флажок, чтобы создавать области размещения на основе пользовательских классов компонентов. У этих компонентов должен быть параметр с именем 'ClassName'.
- Generate Net Classes - установите этот флажок, чтобы создавать пользовательские классы цепей при передаче проекта на печатную плату. Классы цепей задаются на схеме вручную с помощью директивы Net Class. Чтобы включить цепь в класс цепей, прикрепите директиву Net Class к соответствующему проводу или шине (либо к области Blanket) и задайте для ее параметра ClassName значение, соответствующее требуемому имени класса.
► Узнайте, как создать пользовательский класс цепей
► Узнайте, как создать пользовательский класс компонентов
Дополнительная опция
- Set To Installation Defaults - нажмите, чтобы восстановить для настроек вкладки значения по умолчанию, заданные при установке.
Примечания
-
Для создания классов (автоматических и/или пользовательских) при передаче проекта на печатную плату убедитесь, что для соответствующих настроек сравнения на вкладке Comparator диалогового окна Project Options установлено значение Find Differences следующим образом:
- Классы цепей — задайте для типа сравнения Extra Net Classes (в категории Differences Associated with Nets) значение Find Differences.
- Классы компонентов — задайте для типа сравнения Extra Component Classes (в категории Differences Associated with Components) значение Find Differences.
-
Кроме того, на вкладке ECO Generation диалогового окна Project Options необходимо убедиться, что для соответствующих настроек ECO установлено значение Generate Change Orders.
- Классы цепей — задайте для типа изменения Add Net Classes (в категории Modifications Associated with Nets) значение Generate Change Orders.
- Классы компонентов — задайте для типа изменения Add Component Classes (в категории Modifications Associated with Components) значение Generate Change Orders.
Сравнение

Вкладка Comparator диалогового окна Project Options
Вкладка Comparator диалогового окна Project Options позволяет определить, какие типы различий следует искать, а какие игнорировать при сравнении документов. Для каждого возможного типа сравнения можно выбрать поиск или игнорирование различий с помощью соответствующего раскрывающегося списка в столбце Mode. При необходимости можно настроить поиск различий в компонентах, цепях, параметрах и физических объектах.
Параметры и элементы управления
Это диалоговое окно разделено на две основные области:
- В верхней области под названием Comparison Type Description/Mode приведены описания и режимы сравнения для каждого доступного типа сравнения.
- Нижняя область под названием Object Matching Criteria используется для задания критериев сопоставления для Net, Net Class, Component Class, Differential Pair и Structure Class.
Описание типа сравнения / режим
- Comparison Type Description - в этой области приведены описания всех доступных в проекте типов сравнения. Используйте полосу прокрутки справа, чтобы перейти к Differences Associated with Components, Differences Associated with Nets, Differences Associated with Parameters, Differences Associated with Physical и Differences Associated with Structure Classes для просмотра или изменения режимов сравнения в каждой категории.
-
Mode - нажмите на запись, чтобы изменить режим сравнения с помощью раскрывающегося списка:
-
Find Differences- выберите этот вариант для поиска различий данного типа. -
Ignore Differences- выберите этот вариант, чтобы игнорировать все различия данного типа (сравнение по этому типу выполняться не будет).
-
Критерии сопоставления объектов
- Object Type - список типов объектов, таких как Net, Net Class, Component Class, Differential Pair и Structure Class.
- Min Match % - введите требуемый минимальный процент совпадения или нажмите в правой части столбца, а затем используйте клавиши со стрелками вверх и вниз для увеличения или уменьшения значения.
- Min Matched Members - введите требуемое минимальное количество совпадающих элементов или нажмите в правой части столбца, а затем используйте клавиши со стрелками вверх и вниз для увеличения или уменьшения значения.
- Use Name Matching - нажмите на запись или используйте раскрывающийся список, чтобы выбрать After member matching или Never.
- Show Manual Matching Dialog - щелкните запись или выберите For unmatched objects либо Never в раскрывающемся списке.
Дополнительные параметры
- Ignore Rules Defined in PCB Only — установите этот флажок, чтобы игнорировать правила, заданные только на печатной плате в рамках проекта. Например, при выполнении извещения об изменениях изменения могут переноситься со схемы на печатную плату; если этот параметр включен, правила, существующие только на печатной плате, игнорируются. Если на листах схемы того же проекта нет соответствующих правил, компаратор не будет пытаться добавить новые правила.
- Set To Installation Defaults — нажмите, чтобы восстановить для параметров вкладки значения по умолчанию, заданные при установке.
Формирование ECO

Вкладка ECO Generation диалогового окна Project Options
Вкладка ECO Generation диалогового окна Project Options позволяет настроить типы изменений, которые могут включаться в извещение об изменениях (Engineering Change Order, ECO), формируемое на основе различий, обнаруженных компаратором.
Параметры и элементы управления
Список типов изменений
В этом списке представлены все возможные изменения, которые можно внести с помощью извещения об изменениях при синхронизации исходных документов схемы с документом печатной платы. В списке представлены категории типов изменений, связанных с Components, Nets, Parameters, Structure Classes и т. д.
Для каждого типа изменений предусмотрены следующие поля:
- Modification Type Description — краткое описание типа изменения (действия, которое должен выполнить синхронизатор).
-
Mode — это поле позволяет указать, следует ли включать данный тип изменений в формируемые ECO. Выберите в раскрывающемся списке один из следующих вариантов:
- Generate Change Orders — включать данный тип изменений в формируемое ECO.
- Ignore Differences — исключать данный тип изменений из формируемого ECO.
Контекстное меню
В контекстном меню, открываемом щелчком правой кнопки мыши, доступна следующая команда:
- Report — используйте эту команду для формирования отчета о текущих настройках режимов внесения изменений. Откроется диалоговое окно Report Preview с уже загруженным отчетом. В этом окне можно просмотреть отчет, используя различные средства управления страницами и масштабом, а затем экспортировать его в файл или распечатать.
Дополнительные параметры
- Push Component Designator Changes to Annotation File (if any) — установите флажок, чтобы включать изменения позиционных обозначений компонентов в файл аннотирования.
- Set To Installation Defaults — нажмите, чтобы восстановить для параметров вкладки значения по умолчанию, заданные при установке.
Параметры

Вкладка Options диалогового окна Project Options
Вкладка Options диалогового окна Project Options позволяет задать путь для выходных файлов проекта и связанные с ними параметры. Также можно задать различные параметры формирования списка соединений и область действия идентификаторов цепей.
Параметры и элементы управления
-
Output Path — путь по умолчанию для выходных файлов, формируемых из текущего проекта (
*.PrjPcb). - ECO Log Path — путь по умолчанию для файлов журнала ECO.
-
Schematic Template Location — в этом поле укажите папку, в которой следует искать файлы шаблонов схем (
*.SchDot,*.SchDoc) для проекта.
Параметры выходных файлов
- Open outputs after compile — включите, чтобы открывать файлы, сформированные после компиляции проекта. Для проекта пакета интегрированной библиотеки включите этот параметр, чтобы устанавливать интегрированную библиотеку после компиляции проекта пакета.
-
Timestamp folder — включите, чтобы создавать папку с отметкой времени для формируемых выходных файлов, например отчета по спецификации BOM (Reports » Bill of Materials). Имя папки имеет формат
<FolderName> Date Time, где<FolderName>задается в поле Output Path, аDateиTimeимеют формат, соответствующий системным настройкам. - Archive project document — включите, чтобы архивировать документ проекта. Например, при формировании производственных файлов из проекта печатной платы (File » Fabrication Outputs и File » Assembly Outputs) в целевую папку выходных файлов будет включена копия соответствующего документа печатной платы.
- Use separate folder for each output type — включите, чтобы создавать отдельные папки для каждого типа выходных файлов, формируемых для проекта. Эта структура папок также будет отображаться на панели Projects.
Параметры списка соединений
- Allow Ports to Name Nets — включите, чтобы присваивать цепи имя из свойства Name подключенного порта вместо имени по умолчанию, автоматически сформированного системой.
- Allow Sheet Entries to Name Nets — включите, чтобы присваивать цепи имя входа листа вместо имени по умолчанию, автоматически сформированного системой.
- Allow Single Pin Nets — включите, чтобы разрешить существование цепей, содержащих только один вывод.
-
Append Sheet Numbers to Local Net — включите, чтобы добавлять значение параметра Sheet Number документа схемы (параметра уровня документа) к именам цепей, локальных для этого листа. Локальная цепь — это цепь, которая не выходит за пределы листа. Для цепи, выходящей за пределы листа и, следовательно, не являющейся локальной, этот параметр не применяется.
- Higher Level Names Take Priority — включите, чтобы метки цепей на листах более высокого уровня иерархии задавали имена цепей на листах более низкого уровня.
-
Power Port Names Take Priority — программа позволяет сделать глобальную цепь питания локальной, соединив порт питания с обычным портом. При этом все выводы на данном листе, подключенные к этому порту питания, будут выделены в отдельную цепь. Включение этого параметра принудительно задает имя цепи по имени цепи, назначенному порту питания.
Область действия идентификаторов цепей
На электрическом уровне (уровне соединений) многолистовые проекты определяются идентификаторами цепей. Идентификаторы цепей (метки цепей, порты, входы листов, порты питания и скрытые выводы) создают логические соединения между точками одной цепи. Такие соединения могут существовать как в пределах одного листа, так и между несколькими листами. Физические соединения возникают, когда один объект соединён проводом непосредственно с другим электрическим объектом. Логические соединения создаются, когда два идентификатора цепи одного типа (например, две метки цепи) имеют одинаковое значение свойства Net .
При создании модели соединений проекта необходимо определить, как идентификаторы цепей должны соединяться друг с другом. Для этого задаётся Net Identifier Scope. Существует два основных способа соединения листов в многолистовом проекте: горизонтальный — напрямую от одного листа к другому, затем к следующему и т. д., и вертикальный — от дочернего листа к обозначающему его символу листа на родительском листе. При горизонтальном соединении связи устанавливаются между портами (также доступны соединения между метками цепей). При вертикальном соединении связи устанавливаются между входами листов и портами.
В раскрывающемся списке выберите одну из следующих областей действия:
-
Automatic (Based on project contents) — в этом режиме способ соединения идентификаторов цепей выбирается автоматически по следующим критериям: если на верхнем листе есть входы листов, используется Hierarchical; если входов листов нет, но есть порты, используется Flat; если нет ни входов листов, ни портов, используется Global.
- Flat (Only ports global) — порты соединяются глобально на всех листах проекта. При выборе этого варианта метки цепей действуют локально в пределах каждого листа, то есть не создают соединений между листами. Все порты с одинаковым именем соединяются на всех листах. Этот вариант можно использовать для плоских многолистовых проектов. Он не рекомендуется для крупных проектов, поскольку проследить цепь по листам может быть затруднительно.
- Hierarchical (Sheet entry <-> port connections, power ports global) — соединения устанавливаются вертикально между портом и соответствующим входом листа. В этом режиме межлистовые соединения создаются только через входы символов листов и соответствующие порты дочерних листов. Порты на листах используются для передачи цепей или шин вверх, к входам соответствующих символов листов на родительском листе. Порты без соответствующего входа листа не соединяются, даже если порт с таким же именем существует на другом листе. Метки цепей действуют локально в пределах каждого листа, то есть не создают соединений между листами. Однако порты питания являются глобальными: все порты питания с одинаковым именем соединяются во всём проекте. Этот вариант позволяет создавать проекты с любой глубиной иерархии и прослеживать цепи по всему проекту на распечатанной схеме.
- Strict Hierarchical (Sheet entry <-> port connections, power ports local) — этот режим соединений работает так же, как режим Hierarchical , за исключением того, что порты питания действуют локально в пределах каждого листа, то есть не соединяются с одноимёнными портами питания на других листах.
- Global (Netlabels and ports global) — порты и метки цепей соединяются на всех листах проекта. При выборе этого варианта все цепи с одинаковой меткой соединяются друг с другом на всех листах. Все порты с одинаковым именем также соединяются на всех листах. Если у цепи, подключённой к порту, также есть метка цепи, имя цепи определяется этой меткой. Этот вариант также можно использовать для плоских многолистовых проектов, однако проследить соединения от одного листа к другому бывает сложно, поскольку визуально найти имена цепей на схеме не всегда легко.
Разрешить перестановку выводов следующими способами
В редакторе печатных плат перестановка выводов, дифференциальных пар и секций компонентов выполняется путём обмена цепями на контактных площадках компонентов и соответствующих медных элементах. При переносе изменений на схемы перестановка выводов может обрабатываться двумя способами:
-
Adding / Removing Net-Labels — включите, чтобы разрешить перестановку выводов на символе компонента. Выполнить перестановку на схеме путём перестановки меток цепей можно только в том случае, если соединения заданы с помощью меток цепей, то есть если выводы не соединены непосредственно проводами.
-
Changing Schematic Pins — включите, чтобы разрешить перестановку меток цепей на проводах, подключённых к выводам компонента. Если цепи физически соединены проводами с компонентом, доступен только вариант перестановки выводов. Этот метод можно использовать для простых компонентов (например, резисторной сборки) или в случаях, когда структура схемы не оставляет другого выбора.
Общие
- Automatic Sheet Numbering — включите этот параметр для автоматической нумерации листов схемы в этом проекте. Это позволяет управлять обозначениями листов и сохранять их в виде параметров в соответствующих документах схем.
-
Automatic Cross References — включите этот параметр, чтобы автоматически добавлять информацию о перекрёстных ссылках для портов, межлистовых соединителей и входов листов во все исходные документы схем активного проекта. Эта функция помогает прослеживать соединения цепей в неиерархическом проекте.
- New Indexing of Sheet Symbols — включите, чтобы использовать любую цифру или число в качестве первого или последнего индекса повторяющегося символа листа, включая 0. Отрицательные числа не допускаются. Последний индекс всегда должен быть больше первого.
Перекрёстные ссылки
-
Sheet Style – выберите один из следующих вариантов обозначения листов для перекрестных ссылок портов на одном или нескольких листах схемы в проекте.
-
None– обозначение листа не добавляется в строку перекрестной ссылки для всех портов. -
Name– в строки перекрестных ссылок добавляются имена листов, с которыми связаны порты. -
Number– в строки перекрестных ссылок добавляются номера листов, с которыми связаны порты.
-
-
Location Style – выберите один из следующих вариантов обозначения местоположения для перекрестных ссылок портов на одном или нескольких листах схемы в проекте.
-
None– обозначение местоположения не добавляется в строку перекрестной ссылки для всех портов. -
Zone– в строки перекрестных ссылок всех портов, связанных с родительскими объектами, добавляются обозначения координатных зон (зоны размечены на рамке листа), например зоны расположения символов листов. -
Location X,Y– в строках перекрестных ссылок всех портов, связанных с родительскими объектами, в скобках указывается местоположение портов, например местоположение символов листов.
-
- Follow Cross References settings in Preferences – если этот параметр включен, значения параметров Sheet Style и Location Style наследуются из параметров в области Port Cross References на странице «Схема — Общие» диалогового окна Preferences.
-
Display Cross References for:
-
Ports – выберите в раскрывающемся списке режим отображения перекрестных ссылок для портов.
-
Disabled– перекрестные ссылки не добавляются к портам. -
Only Related Sheet Entry– отображать перекрестную ссылку на соответствующий вход листа на родительском листе схемы. -
Only Related Ports– отображать перекрестные ссылки на соответствующие порты. -
Sheet Entry & Ports– отображать перекрестные ссылки как на вход листа, так и на порты.
-
- Off-sheet Connectors – включите этот параметр, чтобы отображать перекрестные ссылки для объектов межлистовых соединителей.
- Sheet Entries – включите этот параметр, чтобы отображать перекрестные ссылки для объектов входов листов.
-
Ports – выберите в раскрывающемся списке режим отображения перекрестных ссылок для портов.
Дифференциальные пары
-
Custom Diff Pair Suffix Grid – здесь перечислены суффиксы дифференциальных пар по умолчанию (
_P/_N) и все заданные пользовательские суффиксы дифференциальных пар со следующими характеристиками:- Positive Suffix – суффикс положительной цепи дифференциальной пары.
- Negative Suffix – суффикс отрицательной цепи дифференциальной пары.
- Add – нажмите, чтобы добавить новую пару суффиксов в список.
- Remove – нажмите, чтобы удалить выбранные пары суффиксов из списка.
Создание xNets
- Sources/Destinations – задайте через запятую список префиксов позиционных обозначений компонентов, которые могут использоваться в качестве исходных или конечных компонентов в xNets.
- Discretes – задайте через запятую список префиксов позиционных обозначений компонентов, которые могут использоваться в качестве последовательных компонентов в xNets.
Многоканальное проектирование

Вкладка Multi-Channel диалогового окна Project Options
Вкладка Multi-Channel диалогового окна Project Options позволяет задать схему именования областей размещения и формат позиционных обозначений компонентов для многоканальных проектов. Многоканальное проектирование позволяет многократно ссылаться на один и тот же подчиненный лист в проекте. Для этого можно разместить несколько символов листов, ссылающихся на один и тот же подчиненный лист, или включить ключевое слово Repeat в обозначение символа листа, чтобы создать несколько его экземпляров.
Altium Designer обеспечивает полноценное многоканальное проектирование: вы можете многократно ссылаться на отдельные листы в проекте. Все необходимые изменения можно внести в одном месте, а затем повторно скомпилировать проект, чтобы распространить эти изменения на каждый экземпляр. Altium Designer не только поддерживает несколько каналов, но и позволяет вкладывать их друг в друга.
Соответствие между единственным логическим компонентом на схеме и несколькими его физическими экземплярами на печатной плате определяется схемой позиционных обозначений для многоканального проекта, заданной на этой вкладке.
Параметры и элементы управления
Именование областей размещения
-
Room Naming Style – используйте это поле, чтобы задать стиль именования областей размещения. При выборе стиля из списка изображение ниже обновляется и показывает, как будут формироваться имена в проекте. При компиляции проекта область размещения создается для каждого листа проекта, включая каждую группу и каждый канал нижнего уровня. Доступны пять стилей: два плоских и три иерархических (содержащих путь):
- Flat Numeric With Names
- Flat Alpha With Names
- Numeric Name Path
- Alpha Name Path
- Mixed Name Path
-
Level Separator for Paths – используйте это поле, чтобы задать символ для разделения элементов пути при использовании иерархических стилей именования (стилей, содержащих путь). По умолчанию используется символ подчеркивания (_).
- Preview – при изменении Room Naming Style и/или Designator Format изображение в этой области динамически обновляется и показывает, как будут формироваться имена в проекте. На изображении приведен пример проекта с вложенными каналами 2 x 2. Большие области с перекрестной штриховкой обозначают два канала верхнего уровня (или группы), а затененные области внутри них — каналы нижнего уровня (в каждом показаны два примера компонентов).
Именование компонентов
-
Designator Format - используйте это поле, чтобы указать формат позиционных обозначений, присваиваемых компонентам проекта. В раскрывающемся списке поля доступны восемь предопределенных форматов: пять плоских и три, которые можно использовать в иерархическом контексте (с указанием имени канала):
- $Component_$RoomName
- $RoomName_$Component
- $Component$ChannelAlpha
- $Component_$ChannelPrefix$ChannelAlpha
- $Component_$ChannelIndex
- $Component_$ChannelPrefix$ChannelIndex
- $ComponentPrefix_$ChannelIndex_$ComponentIndex
- $ComponentPrefix_$RoomName_$ComponentIndex
Определение собственного формата позиционных обозначений
Вы также можете определить собственный формат позиционных обозначений компонентов, введя его непосредственно в поле Designator Format. При составлении строки формата можно использовать следующие ключевые слова:
- $RoomName - имя соответствующего канала, определяемое стилем, выбранным в поле Room Naming Style .
- $Component- логическое позиционное обозначение компонента.
- $ComponentPrefix - префикс логического позиционного обозначения компонента (например, U для U1).
- $ComponentIndex - индекс логического позиционного обозначения компонента (например, 1 для U1).
- $ChannelPrefix - логическое позиционное обозначение символа листа.
- $ChannelIndex - индекс канала.
- $ChannelAlpha - индекс канала, представленный буквой.
Примечания
- Буквенная индексация каналов полезна только в том случае, если проект содержит менее 26 каналов или если используется иерархический формат позиционных обозначений.
- В многоканальном проекте в нижней части листа схемы в окне проекта отображаются вкладки — по одной для каждого канала (или группы каналов). Имена вкладок состоят из имен символов листов и номера канала, например, BANKA. Это скомпилированные представления (физические представления) проекта, тогда как логический проект по-прежнему остается на вкладке Editor.
Настройки печати по умолчанию

Вкладка Default Prints диалогового окна Project Options
Вкладка Default Prints диалогового окна Project Options позволяет настроить вывод на печать по умолчанию для различных редакторов Altium Designer. Именно эти настройки используются при выполнении следующих команд печати из главных меню редакторов:
- File » Print
- File » Print Preview » Print
Вкладку Default Prints диалогового окна Project Options также можно открыть из редактора схем и редактора печатных плат, выбрав команду File » Default Prints в главном меню.
Параметры и элементы управления
В основной области вкладки представлен список всех поддерживаемых типов вывода на печать, которые можно сформировать в редакторах схем и печатных плат. Типы вывода сгруппированы по следующим категориям:
-
Assembly Outputs -
Documentation Outputs -
Fabrication Outputs -
Other Outputs -
Report Outputs -
Validation Outputs
Для каждой записи отображается следующая информация:
- Output Description – содержимое, выводимое на печать при использовании этого типа вывода.
- Supports – редактор, в котором поддерживается этот тип вывода на печать.
-
Default Print – указывает, используется ли этот тип вывода на печать по умолчанию (включено) или нет (выключено).
Дополнительные параметры
-
Configure – нажмите эту кнопку, чтобы открыть соответствующее диалоговое окно для настройки выбранного типа вывода на печать. Используются следующие диалоговые окна:
- Диалоговое окно печати – для настройки печати сборочных чертежей, совмещенного чертежа, печатной платы, библиотеки посадочных мест, схем, совмещенного чертежа сверловки, чертежа сверловки/направляющих, окончательных фотошаблонов, слоев питания, а также паяльной маски и маски паяльной пасты.
- Диалоговое окно настроек 3D-печати платы – для настройки печати 3D-видов платы.
- Диалоговое окно 3D-видео платы – для настройки вывода 3D-видео платы.
- Диалоговое окно PDF3D – для настройки вывода PDF3D и PDF3D MBA.
- Диалоговое окно расширенных свойств печати текста – для настройки печати отчетов и текста. Задайте параметры печати (например, верхний колонтитул и нумерацию страниц/строк). Также можно указать конкретный шрифт.
- Wave Print Properties Form Диалоговое окно — для настройки печати SimView.
- Диалоговое окно настройки отчета о стеке слоев – для настройки вывода отчета о стеке платы.
- Диалоговое окно диспетчера отчетов – для настройки спецификации и отчетов о сравнении спецификаций.
- Диалоговое окно настройки экспорта комментариев – для настройки отчета экспорта комментариев.
- Диалоговое окно настройки различий – для настройки отчета о различиях.
- Диалоговое окно настройки проверки электрических правил – для настройки отчета о проверке электрических правил.
- Page Setup – нажмите, чтобы открыть диалоговое окно параметров страницы для выбранного типа вывода на печать. В этом окне можно настроить бумагу, масштаб и цвета для печати на выбранном принтере. Также можно открыть соответствующее диалоговое окно настройки вывода, диалоговое окно настройки принтера, просмотреть результат перед печатью и отправить его на выбранный принтер.
Пути поиска

Вкладка Search Paths диалогового окна Project Options
Вкладка Search Paths диалогового окна Project Options позволяет указать пути поиска файлов библиотек и моделей для проекта.
Параметры и элементы управления
Упорядоченный список путей поиска
В этой таблице отображается упорядоченный список путей поиска файлов библиотек и моделей (например, библиотек посадочных мест, моделей для моделирования и анализа целостности сигналов). Для каждого пути можно задать фильтр и параметры рекурсивного поиска.
- Path - расположение, в котором выполняется поиск.
- Filter - фильтр поиска. По умолчанию поиск выполняется по всем файлам.
- Recursive - установите флажок, чтобы выполнять поиск во всех подкаталогах каталога, указанного в пути поиска. Дважды щелкните путь поиска, чтобы изменить его.
Поддерживаются следующие типы файлов: библиотеки посадочных мест (*.PcbLib), файлы моделей моделирования (*.mdl), файлы подсхем моделирования (*.ckt), файлы моделей IBIS (*.ibs).
- Delete - удаляет выбранный путь поиска.
- Properties - открывает диалоговое окно Edit Search Path для изменения свойств выбранного пути поиска.
- Move Up - перемещает выбранный путь поиска на одну строку вверх.
- Move Down - перемещает выбранный путь поиска на одну строку вниз.
Файлы, найденные по всем путям поиска
В этой таблице отображаются файлы библиотек и моделей, найденные по путям из списка Ordered List of Search Paths. Нажмите кнопку Refresh List, чтобы обновить список.
Параметры

Вкладка Parameters диалогового окна Project Options
Вкладка Parameters диалогового окна Project Options позволяет управлять параметрами, заданными для проекта, которые часто называют project-level parameters. Параметры, заданные на уровне проекта, доступны на всех листах схемы и во всех документах печатных плат проекта благодаря специальным строкам: =<ProjectParameterName> на схеме (например, =Project) и .<ProjectParameterName> на печатной плате (например, .Project). Параметры позволяют указывать дополнительную информацию о проекте. Например, параметры уровня проекта можно глобально использовать как источник параметрических данных для специальных строк, добавляемых на листы схемы и/или в документ печатной платы, который не поддерживает локальные параметры.
Параметры проекта на стороне Workspace сохраняются в Workspace вместе с проектом, и их можно редактировать только через браузерный интерфейс Workspace (подробнее о Editing a Project в Altium 356 Workspace или On-Prem Enterprise Workspace). Напротив, параметры проекта на стороне проектирования сохраняются в файле проекта (*.PrjPcb) и могут редактироваться в Altium Designer. Параметры проекта на стороне Workspace отображаются на вкладке Parameter диалогового окна Project Options с синим значком , а параметры на стороне проектирования — с оранжевым значком
Параметры и элементы управления
-
Parameters Grid – в основной области перечислены все параметры, заданные в данный момент для проекта, со следующими атрибутами:
- Name – имя параметра.
- Value – значение параметра.
-
Add – нажмите, чтобы открыть диалоговое окно Parameter Properties, в котором можно добавить параметр. В полях Name и Value укажите соответственно понятное имя параметра, отражающее его назначение, и его значение. Максимальная длина каждого поля — 255 символов.
- Remove – нажмите, чтобы удалить выбранные параметры из списка. Эта функция недоступна для параметров проекта на стороне Workspace, поскольку удалять и редактировать их можно только в Workspace.
- Edit – нажмите, чтобы открыть диалоговое окно Parameter Properties, в котором можно изменить содержимое выбранного параметра. Эта функция недоступна для параметров проекта на стороне Workspace, поскольку удалять и редактировать их можно только в Workspace.
- Refresh – нажмите, чтобы отменить последние изменения параметра проекта на стороне проектирования. Для параметров проекта на стороне Workspace нажмите, чтобы получить актуальную версию параметра. Изменения параметров проекта, внесенные в Workspace, не отобразятся в этом диалоговом окне, пока вы не воспользуетесь этой функцией.
Контекстное меню
В контекстном меню доступны следующие команды:
-
Edit – позволяет изменить выбранный параметр в диалоговом окне Parameter Properties. Эта команда недоступна для параметров проекта на стороне Workspace, поскольку удалять и редактировать их можно только в Workspace.
-
Add – позволяет добавить в список новый параметр на стороне проектирования в диалоговом окне Parameter Properties.
-
Remove – используется для удаления выбранных параметров из списка. Эта команда недоступна для параметров проекта, хранящихся в Workspace, поскольку удалить или изменить их можно только в Workspace.
-
Copy – используется для копирования выбранных параметров в буфер обмена Windows.
-
Paste – используется для вставки параметров из буфера обмена Windows в список параметров. Эта команда недоступна для параметров проекта, хранящихся в Workspace, поскольку удалить или изменить их можно только в Workspace.
Листы устройств

Вкладка Device Sheets диалогового окна Project Options
Вкладка Device Sheets диалогового окна Project Options позволяет указать папки, в которых находятся листы устройств, и порядок этих папок.
Параметры и элементы управления
- Main region — список Device Sheet Folders путей для текущего проекта. Установите флажок Include Sub-folders , чтобы включить вложенные папки перечисленных родительских папок.
- Move Up — используется для перемещения выбранной папки листов устройств вверх на одну позицию.
- Move Down — используется для перемещения выбранной папки листов устройств вниз на одну позицию.
- Add — используется для открытия диалогового окна поиска новой папки для добавления.
- Remove — используется для удаления выбранной папки листов устройств.
Управляемые задания формирования выходных данных

Вкладка Managed OutputJobs диалогового окна Project Options
Вкладка Managed OutputJobs диалогового окна Project Options позволяет настроить список шаблонов заданий формирования выходных данных, доступных в подключенном Workspace, для использования в проекте.
Параметры и элементы управления
- Outputjob List — список всех заданий формирования выходных данных из Workspace с указанием Item Revision, Revision State, Description и Name.
- Add — нажмите, чтобы открыть диалоговое окно Select configuration item (Output Jobs) и выбрать нужные задания формирования выходных данных.
- Remove — нажмите, чтобы удалить выбранные задания формирования выходных данных.
Параметры библиотеки

Вкладка Library Options диалогового окна Project Options
Вкладка Library Options диалогового окна Project Options позволяет выбрать формат проекта интегрированной библиотеки.
Параметры и элементы управления
-
Integrated Library Format
- Original — выберите для использования исходного формата интегрированной библиотеки. Этот формат используется для совместимости с программным обеспечением Protel DXP (DXP 2002), выпущенным до появления Altium Designer.
-
Altium Designer— выберите для использования формата интегрированной библиотеки Altium Designer (используется во всех версиях программного обеспечения начиная с первой версии Altium Designer 2004).
).
