Praca z wytłaczanymi, sferycznymi i cylindrycznymi bryłami 3D
W skrócie
- Poznaj różnice między wyciągniętymi, walcowymi i kulistymi bryłami 3D oraz dowiedz się, jak definiować i umieszczać każdą z nich.
- Zobacz, jak korzystać z panelu Properties i skrótów dostępnych podczas wykonywania polecenia, aby kontrolować wymiary i wygląd kształtów oraz sposób ich umieszczania.
- Dowiedz się, jak generować bryły 3D na podstawie istniejących kształtów footprintu i zarządzać nimi za pomocą narzędzia Component Body Manager, z uwzględnieniem opcji dla pojedynczych komponentów i aktualizacji zbiorczych.
Chociaż umieszczanie ogólnych modeli 3D jest zalecanym sposobem korzystania z obiektów 3D Body, ponieważ zapewnia dokładne i szczegółowe odwzorowanie komponentu na PCB oraz umożliwia dokładniejsze sprawdzanie kolizji 3D w edytorze PCB, obiekt 3D Body można również wykorzystać do umieszczania brył wyciąganych, kulistych i walcowych. Dostępne są trzy rodzaje prostych obiektów 3D Body:
| Extruded | W płaszczyźnie X-Y (widok z góry) obiekt wyciągany definiuje się interaktywnie, tak samo jak inne obiekty wielokątne w edytorze PCB. Następnie obiekt jest wyciągany w górę (lub w dół) wzdłuż osi Z, na podstawie właściwości Overall Height i Standoff Height określonych w trybie 3D Body panelu Properties oraz opcji Body Projection. Na powierzchnię wyciąganego obiektu 3D Body można również nałożyć plik tekstury, na przykład logo. |
| Cylindrical | Właściwości tej bryły definiuje się w trybie 3D Body panelu Properties. |
| Spherical | Właściwości tej bryły definiuje się w trybie 3D Body panelu Properties. |
Umieszczanie wyciąganych, kulistych i walcowych obiektów 3D Body
Umieszczanie bezpośrednie
Wyciągane, kuliste i walcowe obiekty 3D Body można umieszczać zarówno w edytorze PCB, jak i w edytorze footprintów PCB poprzez:
- Wybranie polecenia Place » Extruded 3D Body z menu głównego.
- Odszukanie i użycie polecenia Extruded 3D Body na Active Bar.
Aby umieścić wyciągany, kulisty lub walcowy obiekt 3D Body:
- Po uruchomieniu polecenia kursor przyjmie postać krzyżyka i zostanie włączony domyślny tryb umieszczania wyciąganego obiektu 3D Body.
- Naciśnij Tab, aby wstrzymać umieszczanie i wyświetlić panel Properties w trybie 3D Body. W obszarze projektowym pojawi się nakładka z przyciskiem pauzy , wskazująca, że można korzystać z pól panelu Properties.
- W panelu Properties wpisz nazwę obiektu 3D Body w polu Identifier. Jest to opcjonalne; identyfikator może być pomocny podczas umieszczania wielu obiektów 3D Body i można go również użyć do wskazania tego obiektu 3D Body w regule projektowej, jeśli zajdzie taka potrzeba.
-
Wybierz wymagane ustawienie Board Side; zwykle jest ono ustawione na
Top. W edytorze bibliotek PCB footprint tworzy się dla górnej strony płytki; w razie potrzeby można go przenieść na dolną stronę podczas projektowania PCB. - Wybierz warstwę mechaniczną Layer, na której ma zostać umieszczony obiekt 3D Body. Warstwy mechaniczne typu komponentowego powinny być sparowane z drugą warstwą mechaniczną tak, aby po przeniesieniu komponentu z górnej strony płytki na dolną jego elementy mechaniczne, takie jak obiekt 3D Body, zostały przeniesione na sparowaną warstwę mechaniczną. Warstwy mechaniczne paruje się na karcie Layers and Colors panelu View Configuration. Więcej informacji znajduje się na stronie dokumentacji tego panelu.
- Wybierz 3D Model Type spośród dostępnych kształtów: Extruded, Cylinder lub Sphere.
-
Przed umieszczeniem każdej bryły należy określić jej rozmiar. Jeśli wybrany kształt to:
- Extruded — określ Overall Height.
- Cylinder — określ Height i Radius.
- Sphere — określ Radius.
- W sekcji Display panelu kliknij przycisk Color, aby ustawić kolor, i dostosuj Opacity według potrzeb.
-
Po zakończeniu edycji kliknij nakładkę z przyciskiem pauzy, aby powrócić do obszaru projektowego.
-
Jeśli kształt to Cylinder lub Sphere:
- Kursor będzie poruszał się w obszarze projektowym z dołączonym prostokątnym kształtem; kliknij, aby umieścić obiekt 3D Body.
- Kliknij prawym przyciskiem myszy lub naciśnij Esc, aby zakończyć umieszczanie obiektów 3D Body.
-
Jeśli kształt to Extruded, kursor będzie gotowy do zdefiniowania wielokątnej podstawy wyciąganego obiektu 3D Body:
- Kliknij, aby zdefiniować pierwszy wierzchołek.
- Przesuń kursor do miejsca, w którym chcesz umieścić drugi wierzchołek. Domyślnie każde kliknięcie umieszcza dwie krawędzie, połączone narożnikiem o kształcie zdefiniowanym przez użytkownika. Więcej informacji znajdziesz w sekcji Tryby umieszczania wyciąganych obiektów 3D Body poniżej.
- Przesuwaj mysz i klikaj, aby umieszczać kolejne wierzchołki.
- Po umieszczeniu ostatniego wierzchołka kliknij prawym przyciskiem myszy lub naciśnij Esc, aby zamknąć kształt i zakończyć umieszczanie obiektu 3D Body. Nie trzeba ręcznie zamykać obiektu 3D Body, ponieważ oprogramowanie automatycznie uzupełni kształt, łącząc punkt początkowy z ostatnim umieszczonym punktem.
-
Jeśli kształt to Cylinder lub Sphere:
Tryby umieszczania wyciąganych obiektów 3D Body
Podczas umieszczania wyciąganego obiektu 3D Body dostępnych jest pięć trybów narożników, z których cztery mają również podtryby kierunku narożnika. Podczas umieszczania:
- Naciskaj Shift+Spacebar, aby przełączać się kolejno między pięcioma dostępnymi trybami narożników.
- Naciśnij Spacebar, aby przełączyć się między dwoma podtrybami kierunku narożnika.
-
W jednym z trybów narożników łukowych przytrzymaj klawisz
lub
, aby zmniejszyć lub zwiększyć łuk. Przytrzymaj dodatkowo klawisz Shift, aby przyspieszyć zmianę rozmiaru łuku.
- Naciśnij klawisz skrótu 1, aby przełączać się między umieszczaniem dwóch krawędzi na kliknięcie a jednej krawędzi na kliknięcie. W drugim trybie przerywana krawędź jest określana jako look-ahead segment.
- Naciśnij klawisz Backspace, aby usunąć ostatni wierzchołek.

Wyciągany obiekt 3D Body; zwróć uwagę na punkt odniesienia widoczny w widokach 2D i 3D.
Tworzenie z zamkniętych kształtów
Aby przyspieszyć tworzenie kształtu komponentu z brył 3D, oprogramowanie może utworzyć serię wyciągniętych obiektów 3D Body na podstawie zamkniętych kształtów wykrytych w obudowie PCB. Funkcja ta może być przydatna, jeśli komponent ma nietypowy kształt, który jest już odwzorowany przez kształty zdefiniowane na warstwie opisowej jego obudowy PCB. Można również dodać do obudowy PCB dodatkowe obiekty na warstwach mechanicznych, a następnie użyć ich do utworzenia kolejnych obiektów 3D Body, na przykład wyprowadzeń.
Poniższe ilustracje przedstawiają obudowę PCB tranzystora TO-92. Kontur narysowany na warstwie Top Overlay służy do zdefiniowania korpusu tranzystora na wybranej parze warstw 3D Body (określanej w oknie dialogowym jako Registration Layer). Na warstwie mechanicznej utworzono również trzy małe kwadraty (każdy z czterech linii), które służą do zdefiniowania wyprowadzeń komponentu na wybranej parze warstw 3D Body — ustawienia przedstawiono na poniższej ilustracji okna dialogowego.

Istniejące obiekty w obudowie PCB można wykorzystać do tworzenia nowych obiektów 3D Body.
Aby utworzyć obiekty 3D Body z kształtów w obudowie PCB, uruchom polecenie Tools » Manage 3D Bodies for Current Component. Otworzy się okno dialogowe Component Body Manager. Można w nim sprawdzić, które bryły 3D są obecnie używane w komponencie, a które nie. W razie potrzeby bryły można dodawać do komponentu lub z niego usuwać. Bryły mogą być trzech różnych typów:
- Celowo umieszczony obiekt 3D Body (określany w opisie jako Component Body).
- Kształt prostokątny tworzony automatycznie przez oprogramowanie na podstawie prostokąta ograniczającego.
- Zamknięty kształt wielokątny tworzony automatycznie przez oprogramowanie na podstawie podstawowych obiektów projektowych.
Można również modyfikować inne właściwości bryły, takie jak wysokości, kierunek projekcji bryły, warstwa odniesienia, kolor i nieprzezroczystość. Zwróć uwagę, że kolumna Body State wskazuje cztery kształty, które zostaną użyte do utworzenia obiektów 3D Body.
Po zdefiniowaniu brył 3D komponentu zgodnie z wymaganiami kliknięcie przycisku Close spowoduje zastosowanie zmian.

Oprogramowanie może tworzyć obiekty 3D Body na podstawie kształtu istniejących obiektów.
Uwagi dotyczące korzystania z tego okna dialogowego:
- Algorytm wykrywania zaproponuje kształt prostokątny utworzony na podstawie prostokąta ograniczającego albo kształt wielokątny odwzorowujący obrys utworzony przez podstawowe obiekty projektowe (prowadzony wzdłuż osi ścieżek i łuków, jeśli ich punkty końcowe pokrywają się).
- Aby utworzyć obiekt 3D Body z istniejącego obiektu, kliknij niebieski tekst w kolumnie Body State.
- Wartość Overall Height jest domyślnie ustawiana na Height zdefiniowaną w panelu Properties obudowy PCB.
- W przypadku wyprowadzenia komponentu przechodzącego w dół przez płytkę ustaw Body Projection na Bottom Side.
- Obiekty 3D Body są tworzone po kliknięciu przycisku Close w oknie dialogowym. Jeśli widok jest już ustawiony na tryb 3D, aby zobaczyć nowe obiekty, może być konieczne jego odświeżenie (skrót End), przełączenie do trybu 2D i ponownie do 3D lub przełączenie opcji Show 3D Bodies między Off a On na karcie View Options w panelu View Configurations.
- Aby edytować bryły 3D wszystkich komponentów w aktywnej bibliotece obudów PCB otwartej obecnie w edytorze obudów PCB, wybierz z menu głównego polecenie Tools » Manage 3D Bodies for Library.
- Aby edytować bryły 3D w edytorze PCB za pomocą tego okna dialogowego, wybierz polecenie Tools » Manage 3D Bodies for Components on Board z menu głównego lub kliknij komponent prawym przyciskiem myszy i wybierz Działania na komponencie » Zarządzaj bryłami 3D z menu kontekstowego.
-
Gdy okno dialogowe zostanie otwarte za pomocą polecenia Tools » Manage 3D Bodies for Components on Board (w edytorze PCB) lub polecenia Tools » Manage 3D Bodies for Library (w edytorze obudów PCB), u góry okna będzie dostępna sekcja Components. Zawiera ona listę wszystkich obudów komponentów w aktywnej bibliotece (w projekcie byłaby to lista wszystkich komponentów na płytce). Dla każdej pozycji wyświetlane są: oznaczenie komponentu (dostępne tylko w projekcie), nazwa obudowy PCB, wysokość oraz informacje o bibliotece źródłowej.
Dostępna będzie także dodatkowa karta Batch Update. Umożliwia ona szybkie, zbiorcze dodawanie obiektów 3D Body do wszystkich lub wybranych komponentów. Można zdefiniować kryteria wyszukiwania służące do wykrywania i tworzenia brył 3D oraz określania ich właściwości. Po skonfigurowaniu wszystkich opcji przetwarzania wsadowego zgodnie z wymaganiami kliknij przycisk Execute Batch Update. Wyszukiwanie zostanie przeprowadzone dla każdego komponentu objętego procesem. Jeśli kształt bryły 3D zostanie wykryty i utworzony, bryła zostanie dodana do komponentu z zastosowaniem zdefiniowanych kryteriów właściwości. W tym trybie zmiany są stosowane podczas wykonywania aktualizacji wsadowej.
- Okno dialogowe umożliwia zarządzanie bryłami 3D komponentu w jednym miejscu, bez konieczności otwierania panelu Properties dla każdego obiektu 3D Body.
Opcje i elementy sterujące okna dialogowego Component Body Manager

Okno dialogowe Component Body Manager (w tle) i okno dialogowe Menedżer brył komponentu dla komponentu (na pierwszym planie)
Komponenty
Górna sekcja okna dialogowego zawiera listę wszystkich obudów komponentów w aktywnej bibliotece (w projekcie byłaby to lista wszystkich komponentów na płytce). Dla każdej pozycji wyświetlane są: oznaczenie komponentu (dostępne tylko w projekcie), nazwa obudowy PCB, wysokość oraz informacje o bibliotece źródłowej.
Karta interaktywna

Karta Interactive okna dialogowego Component Body Manager
Wersja Component Body Manager okna dialogowego zawiera dwie karty: Interactive i Batch Update. Karta Interactive umożliwia wygodne przeglądanie informacji o wybranym komponencie, w tym podglądu brył komponentu oraz wybranej bryły.
Istniejące i potencjalne bryły komponentu
-
Existing and Potential Component Bodies — ta sekcja zawiera listę wszystkich istniejących brył komponentu (3D Body), które są używane lub mogą zostać użyte w komponencie. Dla każdej bryły komponentu podane są następujące informacje:
-
Description — opis sposobu utworzenia bryły. Może to być celowo umieszczony obiekt 3D Body (określany w opisie jako Component Body), kształt prostokątny utworzony na podstawie prostokąta ograniczającego lub zamknięty kształt wielokątny utworzony z podstawowych obiektów projektowych. Opis każdej bryły (zarówno umieszczonej ręcznie, jak i utworzonej automatycznie) zawiera również warstwę mechaniczną, na której się znajduje (lub na której znajdują się obiekty użyte do jej utworzenia), oraz jej pole powierzchni. Bryły prostokątne i wielokątne są rozróżniane za pomocą
i
odpowiednio ikony.
- Body State - wskazuje, czy bryła jest używana w komponencie (In Component <ComponentDesignator>), czy nie (Not In Component <ComponentDesignator>). Kliknij wpis, aby zmienić ten stan według potrzeb.
- Standoff Height - odległość od powierzchni płytki do dolnej powierzchni bryły wyciągniętej. Użyj wartości ujemnej dla brył wyciągniętych, które muszą przechodzić w dół przez PCB.
- Overall Height - odległość od powierzchni płytki do górnej powierzchni bryły wyciągniętej.
- Body Projection - strona płytki, z której będzie wystawać bryła 3D. Z listy rozwijanej pola wybierz Top Side lub Bottom Side (wystawanie w górę lub w dół). To ustawienie zmienia się automatycznie, jeśli obiekt bryły 3D zostanie przeniesiony na drugą stronę płytki podczas odwracania komponentu.
- Registration Layer - warstwa mechaniczna, na której znajduje się bryła 3D. Z listy rozwijanej pola wybierz jedną z aktualnie włączonych warstw mechanicznych. Jeśli wybrana warstwa mechaniczna jest sparowana, podczas przenoszenia bryły wraz z komponentem na drugą stronę płytki zostanie ona również przeniesiona na sparowaną warstwę mechaniczną.
- Body 3D Color - aktualny kolor bryły 3D. Kliknij próbkę koloru, aby otworzyć standardowe okno dialogowe Choose Color i przypisać inny kolor według potrzeb.
- Body 3D Opacity - aktualny poziom przezroczystości bryły 3D. Z listy rozwijanej pola wybierz Solid (całkowicie nieprzezroczysta), Hide (bryła niewidoczna), 25% Opacity, 50% Opacity lub 75% Opacity.
-
Description — opis sposobu utworzenia bryły. Może to być celowo umieszczony obiekt 3D Body (określany w opisie jako Component Body), kształt prostokątny utworzony na podstawie prostokąta ograniczającego lub zamknięty kształt wielokątny utworzony z podstawowych obiektów projektowych. Opis każdej bryły (zarówno umieszczonej ręcznie, jak i utworzonej automatycznie) zawiera również warstwę mechaniczną, na której się znajduje (lub na której znajdują się obiekty użyte do jej utworzenia), oraz jej pole powierzchni. Bryły prostokątne i wielokątne są rozróżniane za pomocą
- Component bodies in: <ComponentDesignator> - pokazuje footprint 2D komponentu wraz z nałożonymi bryłami 3D, których Body State jest obecnie ustawione na In Component <ComponentDesignator>. Podgląd jest dynamiczny i zmienia się wraz z uwzględnianiem lub wykluczaniem brył.
- Selected Body - pokazuje bryłę aktualnie wybraną na powyższej liście. Obszar tytułu okna również zawiera opis bryły.
Karta aktualizacji zbiorczej

Karta Batch Update w oknie dialogowym Component Body Manager
Karta Batch Update umożliwia szybkie dodawanie obiektów brył 3D do wszystkich lub wybranych footprintów w bibliotece albo do wszystkich lub wybranych footprintów umieszczonych w projekcie.
Obszar tabeli
W tym obszarze można określić kryteria wyszukiwania służące do wykrywania i tworzenia brył 3D oraz właściwości brył 3D, takie jak Projection side (określane również jako kierunek wystawania bryły), Registration Layer, Standoff Height, Overall Height i 3D Body Color.
Każdy wpis na liście określa inny zakres warstw przeszukiwanych podczas wykrywania i tworzenia możliwych kształtów brył 3D. Każde wyszukiwanie jest włączane osobno za pomocą opcji w kolumnie Enabled. Można włączyć wiele wyszukiwań, ale należy pamiętać, że bryła 3D zostanie dodana dla każdego wyszukiwania zakończonego powodzeniem. Zazwyczaj włącza się wyszukiwanie na jednej konkretnej warstwie lub w zestawie warstw — w zależności od tego, gdzie zwykle umieszczane są obiekty podstawowe lub informacje o obrysie komponentu w footprincie. Domyślnie wykonywane jest wyszukiwanie All Layers.
Pole Detection Method pozwala określić sposób definiowania kształtu każdej bryły 3D:
- Bounding Rectangle - użyj prostokąta ograniczającego footprint.
- Closed Shapes - użyj zamkniętego kształtu wielokątnego utworzonego z obiektów podstawowych footprintu komponentu.
- Both (Prefer Closed Shapes) - wykryj prostokąt ograniczający lub zamknięty kształt wielokątny na podstawie obiektów podstawowych footprintu. Jeśli zostaną wykryte oba, użyj zamkniętego kształtu wielokątnego.
Kolumna opcji Prefer component height if not 0 pozwala określić, czy atrybut wysokości zdefiniowany dla footprintu komponentu ma być używany jako Overall Height bryły 3D. Gdy ta opcja jest włączona, dla każdego komponentu ze zdefiniowanym atrybutem wysokości większym od zera wysokość ta zostanie ustawiona jako Overall Height dodanej bryły 3D, a jej Standoff Height zostanie ustawione na zero.
Body 3-D Color określa kolor wyświetlania bryły 3D. Kliknij kolor, aby zmienić go w oknie dialogowym Choose Color.
Opcje
- Apply Only To Selected Components - włącz tę opcję, jeśli chcesz zastosować kryteria brył 3D tylko do wybranej grupy footprintów. Upewnij się, że te komponenty są zaznaczone w górnym obszarze okna dialogowego (użyj standardowych funkcji Ctrl+Click i Shift+Click , aby zaznaczyć wiele elementów). Jeśli ta opcja jest wyłączona, proces zbiorczego dodawania obejmie wszystkie footprinty w bibliotece (lub wszystkie komponenty na płytce).
- Delete Existing Bodies In Components - włącz tę opcję, aby usunąć wszystkie aktualnie zdefiniowane bryły 3D z footprintów objętych procesem zbiorczym. Skorzystaj z okna podglądu w prawym dolnym rogu karty, aby zobaczyć, jak będzie wyglądać dodana bryła 3D na podstawie aktualnie wybranego footprintu komponentu oraz aktualnie wybranego (i włączonego) wpisu wyszukiwania. Po skonfigurowaniu wszystkich opcji procesu zbiorczego według potrzeb kliknij przycisk Execute Batch Update. Wyszukiwanie zostanie przeprowadzone dla każdego footprintu objętego procesem, a jeśli kształt bryły 3D zostanie wykryty i utworzony, bryła ta zostanie dodana do footprintu zgodnie ze zdefiniowanymi kryteriami właściwości.
Podgląd operacji zbiorczej
Umożliwia podgląd zdefiniowanych brył 3D na różnych warstwach.
Dodatkowy element sterujący
- Execute Batch Update - kliknij, aby przeprowadzić aktualizację każdego footprintu objętego procesem. Jeśli kształt bryły 3D zostanie wykryty i utworzony, bryła ta zostanie dodana do footprintu zgodnie ze zdefiniowanymi kryteriami właściwości.
Tworzenie z zaznaczonych obiektów podstawowych
Bryłę 3D można nie tylko umieścić interaktywnie, ale także utworzyć z zestawu istniejących obiektów ścieżek, łuków i pełnych regionów definiujących zamknięty kształt. To doskonałe rozwiązanie w przypadku prostych modeli. Aby zdefiniować bryłę 3D na podstawie istniejącego zamkniętego kształtu:
- Zaznacz wszystkie obiekty podstawowe tworzące zamknięty kształt.
- Kliknij Tools » Convert » Create 3D Body From selected primitives.
Bryła 3D zostanie utworzona na warstwie Top Layer na podstawie zamkniętego obrysu utworzonego przez obiekty podstawowe, niezależnie od warstwy, na której znajdują się zaznaczone ścieżki. Oznacza to, że kształt można zdefiniować na warstwie mechanicznej. Pamiętaj, że po utworzeniu regionu pierwotnie zaznaczone obiekty podstawowe nadal będą istnieć i pozostaną zaznaczone. Obrys bryły 3D przebiega wzdłuż osi ścieżek wyznaczających granicę, a sama bryła nie jest zaznaczona.
Ponieważ algorytm Create 3D Body From selected primitives wykorzystuje osie zaznaczonych obiektów, wymaga, aby punkty końcowe i początkowe stykających się obiektów dokładnie się pokrywały (miały te same współrzędne X, Y). Jeśli tak nie jest, pojawi się okno dialogowe Confirm wskazujące miejsce, w którym algorytm napotkał problem, oraz umożliwiające podjęcie próby zdefiniowania bryły 3D na podstawie krawędzi obiektów zamiast ich osi. O ile zaznaczone obiekty nieznacznie na siebie nachodzą, ta opcja powinna utworzyć bryłę 3D, której krawędź biegnie wzdłuż zewnętrznej krawędzi zaznaczonych obiektów.
Edycja graficzna
Graficzna metoda edycji pozwala zaznaczyć umieszczony obiekt bryły 3D bezpośrednio w obszarze projektowania i graficznie zmienić jego rozmiar, kształt lub położenie.
Aby edytować wyciągniętą bryłę 3D, kliknij obiekt raz, aby go zaznaczyć i przełączyć w tryb edycji. Zewnętrzny kształt obiektu bryły 3D jest zdefiniowany przez szereg krawędzi. Każda krawędź ma na obu końcach wierzchołki końcowe, wyświetlane jako pełne białe kwadraty (A na poniższym obrazie), oraz wierzchołek środkowy, wyświetlany jako pusty biały kwadrat (B na poniższym obrazie). Każdy wierzchołek końcowy wyznacza miejsce, w którym łączą się dwie krawędzie.
Do edycji kształtu dostępne są standardowe techniki edycji kształtów wielokątnych.
Podczas edycji obiektu wielokątnego dostępne są trzy tryby edycji: Slide/Miter, Incurvate (łuk) i Move. Bieżący tryb można zmienić while dragging a vertex or an edge, naciskając Shift+Spacebar, aby przełączać się między tymi trzema trybami.
- Slide/Miter – kliknij i przytrzymaj krawędź lub wierzchołek środkowy, aby przesunąć tę krawędź; kliknij i przytrzymaj wierzchołek końcowy, aby ściąć narożnik.
- Incurvate – kliknij i przytrzymaj krawędź lub wierzchołek środkowy, aby wygiąć tę krawędź w łuk; kliknij i przytrzymaj wierzchołek końcowy, aby zaokrąglić narożnik.
- Move – kliknij i przytrzymaj krawędź lub wierzchołek środkowy, aby podzielić tę krawędź na dwie; kliknij i przytrzymaj wierzchołek końcowy, aby swobodnie przesuwać ten narożnik.
Podczas edycji można również:
- Ctrl+click and hold w dowolnym miejscu wzdłuż krawędzi z dala od uchwytów edycji, aby wstawić nowy wierzchołek.
- Aby usunąć wierzchołek, kliknij go i przytrzymaj, a następnie naciśnij klawisz Delete.
-
Kliknij dowolne miejsce bryły 3D z dala od uchwytów edycji, a następnie przeciągnij ją, aby zmienić jej położenie. Podczas przeciągania bryłę 3D można obracać lub odbijać lustrzanie:
- Naciśnij Spacebar, aby obrócić bryłę 3D przeciwnie do ruchu wskazówek zegara, lub Shift+Spacebar, aby obrócić ją zgodnie z ruchem wskazówek zegara. Wielkość Rotation Step jest określana na stronie PCB Editor – General w oknie dialogowym Preferences.
- Naciśnij klawisz X lub Y, aby odbić bryłę 3D lustrzanie względem osi X lub Y.
Konwersja do STEP
Zaznaczony obiekt bryły 3D typu wyciągniętego, walcowego lub kulistego można przekonwertować na model STEP. Model STEP jest automatycznie osadzany w pliku projektu. Aby przekonwertować niezależny obiekt bryły 3D, zaznacz go w obszarze projektowania, a następnie kliknij prawym przyciskiem myszy i wybierz polecenie Convert To STEP z menu kontekstowego. Polecenie nie będzie dostępne, jeśli nie zaznaczono żadnego obiektu lub zaznaczono więcej niż jeden obiekt. Po przekonwertowaniu obiektu do STEP nie można już zmieniać jego rozmiaru w obszarze projektowania.

Przekonwertuj wyciągnięty kształt do STEP, jeśli chcesz obracać go wokół osi X lub Y.
Punkt odniesienia wyciągniętego, kulistego lub walcowego obiektu bryły 3D
Wyciągnięty, kulisty lub walcowy obiekt bryły 3D ma punkt odniesienia, czyli początek układu współrzędnych.
- W przypadku walca i kuli punktem odniesienia jest środek kołowego kształtu obiektu na płaszczyźnie X-Y.
- W przypadku obiektu wyciągniętego punkt odniesienia znajduje się w położeniu długość w osi X/2, długość w osi Y/2 w widoku z góry.
- To właśnie położenie tego punktu odniesienia w obszarze projektowania jest wyświetlane jako X/Y Location w panelu Properties.

Wyciągnięte, kuliste i walcowe obiekty brył 3D mają punkt odniesienia, jak pokazano na ilustracjach. Należy pamiętać, że linie punktu odniesienia są krótkie, więc mogą nie być widoczne poza obiektem.
Dodawanie tekstury do wyciągniętej bryły 3D
Obiekty wyciągnięte mogą również zawierać obraz nałożony na ich najwyższą powierzchnię, co zwiększa realizm wyglądu płytki w widoku 3D. Po dodaniu Texture File jest ona automatycznie rozciągana tak, aby pokryć całą górną powierzchnię bryły 3D, jak pokazano na poniższym obrazie. Należy pamiętać, że plik tekstury jest powiązany z plikiem biblioteki lub płytki.
Obsługiwane formaty plików tekstur to: *.bmp; *.dds; *.dib; *.hdr; *.jpg; *.pfm; *.png; *.ppm; oraz *.tga.

Do wyciągniętego obiektu bryły 3D można dodać teksturę lub logo.
Można je dostosować, zmieniając położenie Center oraz ustawienia Size i Rotation w trybie 3D Body panelu Properties.
Można również zmienić położenie obiektu tekstury powiązanego z wybranym wyciągniętym modelem 3D, wybierając polecenie Tools » 3D Body Placement » Move Texture Location z menu głównego, gdy edytor pracuje w trybie układu 3D. Po uruchomieniu polecenia kursor zmieni się w niebieskie stożki (oznaczające tryb zaznaczania 3D) i pojawi się monit o wybranie wyciągniętej bryły 3D z przypisaną teksturą. Umieść kursor nad odpowiednią bryłą 3D, a następnie kliknij lub naciśnij Enter. Kliknij lub naciśnij Enter po raz drugi, aby „chwycić” teksturę za najbliższy narożnik. Przesuń teksturę w żądane miejsce, a następnie kliknij lub naciśnij Enter, aby ją umieścić. Podczas przesuwania, gdy tekstura nadal jest przyczepiona do kursora, można wykonywać standardowe dodatkowe operacje związane z przemieszczaniem obiektów (Spacebar/Shift+Spacebar — obrót, X lub Y — odbicie lustrzane, klawisze strzałek — przesuwanie tekstury małymi krokami).
Można też przesunąć teksturę w zaznaczonej wyciągniętej bryle 3D, klikając ją i przeciągając myszą.