Przypisywanie punktów testowych na tablicy

W skrócie

W tym artykule wyjaśniamy, dlaczego punkty testowe są ważne w produkcji PCB oraz jak Altium Designer pomaga przypisywać je zarówno do testowania płytek bez zamontowanych elementów, jak i płytek po montażu. Omawiamy praktyczne różnice między strategiami testowania na etapie produkcji i po montażu, ograniczenia wpływające na rozmieszczenie punktów testowych oraz sposoby ręcznego wyznaczania padów i przelotek jako punktów testowych lub korzystania w tym celu z narzędzia Testpoint Manager. Jeśli chcesz zaprojektować płytkę łatwiejszą do testowania i lepiej zrozumieć, jak Altium Designer wspiera ten proces, ten artykuł zapewni Ci solidne podstawy. Czytaj dalej, aby skuteczniej planować rozmieszczenie punktów testowych.

- Poznaj różnice między testowaniem na etapie produkcji płytek a testowaniem po montażu oraz ich wpływ na rozmieszczenie punktów testowych.
- Dowiedz się, jakie kluczowe czynniki i ograniczenia kształtują dobrą strategię rozmieszczenia punktów testowych, w tym dostęp do poszczególnych stron płytki, odstępy, wymagania dotyczące siatki oraz dostęp dla sond testowych.
- Zobacz, jak Altium Designer umożliwia ręczne i automatyczne przypisywanie punktów testowych z wykorzystaniem funkcji padów, przelotek i narzędzia Testpoint Manager.
Zagłęb się w temat dzięki AI:

Testowanie jest ważnym elementem procesu produkcji płytek. Po wytworzeniu płytka jest zwykle testowana pod kątem zwarć i przerw w obwodach. Po zamontowaniu wszystkich komponentów często przeprowadza się kolejne testy, aby sprawdzić integralność sygnałów i działanie urządzenia. Aby ułatwić ten proces, warto przewidzieć na płytce układ punktów testowych — Testpoints — z którymi sprzęt testujący może nawiązać kontakt za pomocą sond i wykonać wymagane testy.

Rozmieszczenie punktów testowych na płytce zależy między innymi od etapu testowania (np. testowanie nieobsadzonej płytki po jej wytworzeniu, testowanie wewnątrzukładowe po montażu itp.) oraz metody testowania (np. testy automatyczne z użyciem sond latających lub adapterów igłowych, testy ręczne itp.). Na przykład podczas testowania nieobsadzonej płytki nie ma na niej jeszcze komponentów, więc wszystkie pola lutownicze i przelotki mogą zostać przypisane jako punkty testowe. Natomiast lokalizacje punktów wykorzystywanych do testowania wewnątrzukładowego po montażu niemal zawsze będą inne. Po obsadzeniu płytki dostęp sond do pól lutowniczych komponentów może być ograniczony, a do pól i przelotek znajdujących się pod komponentem z pewnością nie będzie dostępu!

Altium Designer udostępnia rozbudowany system obsługi punktów testowych, który ułatwia testowanie płytek i pozwala, zależnie od potrzeb, oddzielnie przypisywać punkty testowe do testowania nieobsadzonej płytki po wytworzeniu i/lub do testowania wewnątrzukładowego po montażu. Punkty testowe można przypisywać ręcznie lub w sposób bardziej usprawniony i zautomatyzowany, korzystając z okna dialogowego Testpoint Manager.

Planowanie strategii rozmieszczania punktów testowych

Zanim przystąpisz do przypisywania pól lutowniczych i przelotek jako punktów testowych, warto poświęcić chwilę na przeanalizowanie wymagań. Poniżej przedstawiono kilka kwestii, które należy rozważyć przy opracowywaniu strategii uwzględnienia punktów testowych w projekcie:

  • Wybierając stronę płytki, na której będzie można umieszczać punkty testowe, należy uwzględnić stosowane procesy testowania i związane z nimi adaptery testowe. Na przykład: czy sondy będą miały dostęp do płytki tylko od spodu, tylko od góry, czy z obu stron?
  • Punkt testowy znajdujący się pod komponentem (po tej samej stronie płytki co komponent) jest zwykle wykorzystywany na etapie testowania nieobsadzonej płytki. Należy to uwzględnić podczas planowania lokalizacji punktów testowych do testowania płytki po montażu.
  • Zaleca się umieszczanie wszystkich punktów testowych tylko po jednej stronie płytki, w razie potrzeby z wykorzystaniem przelotek. Wynika to z faktu, że dwugłowicowy adapter testowy jest droższy od adaptera jednogłowicowego.
  • Im bardziej niestandardowy i złożony jest układ punktów testowych, tym większy będzie koszt przygotowania adaptera do testowania płytki. Najlepszym podejściem jest opracowanie metodyki zapewniającej uniwersalną testowalność. Dopracowane i elastyczne zasady rozmieszczania punktów testowych pozwolą sprawnie i ekonomicznie testować różne projekty.
  • Należy dokładnie przeanalizować wszelkie wymagania projektu dotyczące zakrywania przelotek maską lutowniczą. Zakrycie przelotki wyznaczonej jako punkt testowy skutecznie uniemożliwi kontakt z sondą testową. Nawet częściowe zakrycie płynną fotoobrazowalną maską lutowniczą (LPI) spowoduje problemy z kontaktem, ponieważ płynna maska ma tendencję do spływania przez otwór przelotki. Do tymczasowego zakrywania takich przelotek można wprawdzie zastosować zrywalną maskę lutowniczą, jednak często okazuje się to dość kosztowne.
  • Ściśle współpracuj z producentem płytek i zakładem montażowym, aby przy wyznaczaniu punktów testowych uwzględnić wszystkie specyficzne parametry projektowe. Mogą one obejmować odstępy między punktami testowymi oraz między punktami testowymi a komponentami, dla których wymagania bywają bardziej rygorystyczne niż standardowe wymagania dotyczące rozmieszczania komponentów i prowadzenia ścieżek.

W kolejnych sekcjach omówiono bardziej szczegółowo testowanie po wytworzeniu i po montażu, w tym ograniczenia dotyczące punktów testowych oraz kwestie charakterystyczne dla każdego z tych etapów.

Testowanie po wytworzeniu

Testowanie po wytworzeniu dotyczy płytki drukowanej na etapie produkcji poprzedzającym montaż, zanim zostaną na niej umieszczone jakiekolwiek komponenty. Z tego powodu często określa się je jako testowanie nieobsadzonej płytki. W tej metodzie zazwyczaj wykorzystuje się tester z sondami latającymi, który sprawdza kolejno poszczególne sieci. Zasadniczo dwie sondy są programowane tak, aby współpracowały: jedna podaje impuls sygnałowy do sieci, a druga wykrywa obecność (lub brak) tego sygnału.

Dwa typowe scenariusze testowania nieobsadzonej płytki po wytworzeniu to:

  1. Sprawdzenie, czy zaprojektowane ciągłe połączenia miedziane przewodzą prawidłowy sygnał na całej długości (bez przekraczania maksymalnego dopuszczalnego progu impedancji) i nie mają przerw.
  2. Sprawdzenie, czy między sieciami nie występują zwarcia.

Testowanie po montażu

Testowanie po montażu dotyczy płytki drukowanej na etapie produkcji po zamontowaniu na niej wszystkich komponentów wyszczególnionych w powiązanym zestawieniu materiałowym (BOM). Z tego powodu często określa się je jako testowanie wewnątrzukładowe lub elektryczne. Ta metoda testowania zazwyczaj obejmuje użycie ręcznie konfigurowanego adaptera igłowego, choć w żadnym razie nie ogranicza się wyłącznie do niego! W zależności od rodzaju testów wykonywanych za pomocą adaptera płytka może być zasilana lub nie.

Dwa typowe scenariusze testowania wewnątrzukładowego po montażu to:

  1. Jednoczesne podłączenie sond do jednego dedykowanego punktu testowego w każdej sieci (lub w każdej sieci objętej testem). Polega to na podawaniu impulsu sygnałowego kolejno przez każdą sondę i wykrywaniu jego odbioru przez wszystkie pozostałe sondy.
  2. Testowanie określonych komponentów lub magistral w celu upewnienia się, że samo urządzenie działa prawidłowo. Są to specjalistyczne testy, które można przeprowadzać różnymi metodami. W najprostszym przypadku do wykonywania pomiarów między polami lutowniczymi komponentów można wykorzystać przyrząd typu „łoże igłowe”.

Obsługa pól lutowniczych i przelotek jako punktów testowych

Altium Designer zapewnia pełną obsługę punktów testowych, umożliwiając wskazanie pól lutowniczych (przewlekanych lub SMD) i/lub przelotek, które mają służyć jako punkty testowe podczas testów produkcyjnych i/lub testów po montażu. Pole lutownicze lub przelotkę wyznacza się jako punkt testowy przez ustawienie odpowiednich właściwości punktu testowego i udzielenie odpowiedzi na dwa kluczowe pytania:

  • Czy pole lutownicze lub przelotka mają być używane jako punkt testowy podczas testów produkcyjnych i/lub testów po montażu?
  • Po której stronie płytki pole lutownicze lub przelotka mają być używane jako punkt testowy — górnej, dolnej czy po obu stronach?

Właściwości te można znaleźć w panelu Properties po wybraniu w obszarze projektowym obiektu pola lutowniczego (patrz Właściwości pola lutowniczego) lub przelotki (patrz Właściwości przelotki).

Wybrane pole lutownicze lub przelotkę wyznacza się jako punkt testowy za pomocą odpowiednich opcji dostępnych w panelu Properties.Wybrane pole lutownicze lub przelotkę wyznacza się jako punkt testowy za pomocą odpowiednich opcji dostępnych w panelu Properties.

Aby usprawnić ten proces i wyeliminować konieczność ręcznego ustawiania właściwości punktów testowych dla pól lutowniczych i przelotek, Altium Designer udostępnia metodę automatycznego przypisywania punktów testowych na podstawie zdefiniowanych reguł projektowych, z wykorzystaniem narzędzia Menedżer punktów testowych. Automatyczne przypisywanie ustawia w każdym przypadku odpowiednie właściwości punktu testowego dla pola lutowniczego lub przelotki. Można również ręcznie wskazywać punkty testowe — indywidualnie dla poszczególnych pól lutowniczych i przelotek — co zapewnia pełną kontrolę nad układem punktów testowych zastosowanym na płytce.
Podczas otwierania projektów PCB utworzonych w wersji oprogramowania wcześniejszej niż Summer 09 wszystkie włączone opcje punktów testowych staną się włączonymi Fabrication opcjami punktów testowych.

Reguły projektowe dotyczące punktów testowych

Ograniczenia projektu PCB należy przemyśleć i wdrożyć w postaci dopracowanego zestawu reguł projektowych. Aby uzyskać prawidłowy układ punktów testowych, w którym wszystkie zdefiniowane punkty są dostępne i mogą być używane podczas testów nieobsadzonej płytki i/lub testów wewnątrzukładowych, należy wprowadzić odpowiednie ograniczenia. W tym celu w systemie reguł projektowych edytora PCB można zdefiniować następujące typy reguł:

Reguły tych typów można otwierać i definiować w oknie dialogowym edytora reguł i ograniczeń PCB (Design » Rules).

Zdefiniuj oddzielne reguły projektowe określające, które pola lutownicze i/lub przelotki w projekcie mogą być używane jako punkty testowe do testów produkcyjnych i testów po montażu oraz które sieci wymagają punktów testowych.Zdefiniuj oddzielne reguły projektowe określające, które pola lutownicze i/lub przelotki w projekcie mogą być używane jako punkty testowe do testów produkcyjnych i testów po montażu oraz które sieci wymagają punktów testowych.

Reguły stylu i wykorzystania punktów testowych są identyczne pod względem ograniczeń dla obu trybów testowania (produkcyjnego i po montażu). Reguła stylu określa zasadniczo ograniczenia, które musi spełniać pole lutownicze lub przelotka, aby można było je rozważyć jako lokalizację punktu testowego. Reguła wykorzystania określa, które sieci wymagają punktu testowego.

Domyślne ograniczenia reguł wykorzystania punktów testowych (u góry) i stylu punktów testowych (u dołu).Domyślne ograniczenia reguł wykorzystania punktów testowych (u góry) i stylu punktów testowych (u dołu).

Podczas definiowania reguły stylu można szybko określić jej zakres tak, aby obejmowała dokładnie te pola lutownicze i/lub przelotki, które mają być rozpatrywane jako punkty testowe, korzystając z opcji dostępnych w sekcji Rule Scope Helper.

Reguły projektowe dotyczące punktów testowych są używane przez Menedżera punktów testowych, autorouter, procesy sprawdzania reguł projektowych (DRC) w trybie online i wsadowym, a także podczas generowania danych wyjściowych.

Dostępne są domyślne reguły stylu i wykorzystania punktów testowych do testów produkcyjnych oraz testów po montażu. Należy sprawdzić, czy reguły te spełniają wymagania płytki, i w razie potrzeby wprowadzić zmiany. Jeśli wymaganych jest wiele reguł tego samego typu, należy wykorzystać ich priorytety, aby reguły o bardziej szczegółowym zakresie były stosowane jako pierwsze (na przykład podczas sprawdzania DRC).

Aby Testpoint Manager mógł prawidłowo przypisać punkty testowe, musi always istnieć co najmniej jedna odpowiednia reguła stylu punktów testowych o zakresie All.
Podczas otwierania projektów PCB lub importowania reguł projektowych utworzonych w wersji oprogramowania wcześniejszej niż Summer 09 reguły stylu punktów testowych staną się regułami stylu punktów testowych do testów produkcyjnych, a reguły wykorzystania punktów testowych staną się regułami wykorzystania punktów testowych do testów produkcyjnych.

Zarządzanie punktami testowymi

Ręczne przypisywanie punktów testowych może być żmudnym i pracochłonnym zadaniem, zwłaszcza w przypadku złożonej płytki z setkami komponentów rozmieszczonych po obu jej stronach. Aby usprawnić zarządzanie punktami testowymi w projektach płytek, Altium Designer udostępnia w edytorze PCB narzędzie Testpoint Manager. Narzędzie Testpoint Manager umożliwia automatyczne przypisywanie punktów testowych — do testowania nieobsadzonych płytek na etapie produkcji i/lub testowania wewnątrzukładowego po montażu — na podstawie zdefiniowanych reguł projektowych. Automatyczne przypisywanie ustawia w każdym przypadku odpowiednie właściwości punktu testowego dla pola lutowniczego lub przelotki.

Aby uzyskać dostęp, wybierz polecenie Tools » Testpoint Manager z menu głównego.

Szybko i sprawnie zarządzaj wymaganiami dotyczącymi punktów testowych na etapie produkcji i montażu za pomocą narzędzia Testpoint Manager.Szybko i sprawnie zarządzaj wymaganiami dotyczącymi punktów testowych na etapie produkcji i montażu za pomocą narzędzia Testpoint Manager.

Okno dialogowe umożliwia automatyczne przypisywanie i usuwanie przypisań punktów testowych w jednym wygodnym miejscu. W obszarze Testpoint Net Status znajduje się lista wszystkich sieci w projekcie wraz ze statusem wskazującym pokrycie punktami testowymi — Complete lub Incomplete — zarówno dla testowania nieobsadzonych płytek na etapie produkcji, jak i testowania wewnątrzukładowego po montażu. Kliknij przycisk Fabrication Testpoints lub Assembly Testpoints albo kliknij prawym przyciskiem myszy w tabeli, aby uzyskać dostęp do poleceń przypisywania lub usuwania przypisań punktów testowych danego typu. Pamiętaj, że w górnym obszarze okna dialogowego można ręcznie wybrać sieci, aby selektywnie przypisać punkty testowe lub usunąć ich przypisania.

Niezależnie od tego, czy punkty testowe są przypisywane do wybranych, czy do wszystkich sieci w projekcie, narzędzie Testpoint Manager przestrzega reguł stylu i użycia zdefiniowanych dla punktów testowych na etapie produkcji i montażu. Aby zobaczyć kolejność wyszukiwania odpowiednich obiektów, kliknij przycisk Search Order.

Aby zmienić kolejność, kliknij prawym przyciskiem myszy pozycję na liście kolejności wyszukiwania i użyj poleceń menu kontekstowego lub skrótów Shift+Up Arrow i Shift+Down Arrow, aby przesunąć ją w górę lub w dół listy.
Jeśli do sieci przypisano punkt testowy naruszający obowiązującą regułę projektową dotyczącą punktów testowych, zostanie to oznaczone Illegal w obszarze Testpoint Net Status okna dialogowego Testpoint Manager. Użyj funkcji sprawdzania reguł projektowych w edytorze PCB, aby sprawdzić poprawność przypisanych punktów testowych.

Obszar Status Summaries zawiera pełne podsumowanie stanu punktów testowych na płytce dla obu trybów testowania. Obszar ten jest aktualizowany po każdym przypisaniu lub usunięciu przypisania. Więcej szczegółów można znaleźć w obszarze Assignment Results. Zawiera on na przykład informacje o liczbie pól lutowniczych i przelotek po górnej i dolnej stronie płytki objętych przypisywaniem lub usuwaniem przypisań, a także informacje o niepowodzeniach.

Sprawdzanie poprawności punktów testowych

Zdefiniowane reguły dotyczące punktów testowych na etapie produkcji i montażu są uwzględniane przez funkcję sprawdzania reguł projektowych (DRC) edytora PCB. Dla poszczególnych typów reguł można włączyć sprawdzanie DRC w trybie online i/lub wsadowym w oknie dialogowym Design Rule Checker (Tools » Design Rule Check).

Uwzględnij reguły projektowe dotyczące punktów testowych w procesach DRC w trybie online lub wsadowym.Uwzględnij reguły projektowe dotyczące punktów testowych w procesach DRC w trybie online lub wsadowym.

Pola zapytań dotyczące punktów testowych

Aby umożliwić obsługę różnych punktów testowych na etapie produkcji i montażu, które można przypisać w projekcie, dostępne są następujące słowa kluczowe służące do wyszukiwania punktów testowych za pomocą logicznych wyrażeń zapytań. Każde z nich można znaleźć w kategorii Funkcje PCB — pola podczas korzystania z narzędzia Asystent zapytań:

  • IsAssyTestpoint — jest punktem testowym na etapie montażu.
  • IsFabTestpoint — jest punktem testowym na etapie produkcji.
  • IsTestpoint — jest punktem testowym po górnej lub dolnej stronie płytki.
  • Testpoint — czy jest punktem testowym po górnej lub dolnej stronie płytki?
  • TestpointAssy — czy jest punktem testowym na etapie montażu?
  • TestpointAssyBottom — czy jest punktem testowym na etapie montażu po dolnej stronie płytki?
  • TestpointAssyTop — czy jest punktem testowym na etapie montażu po górnej stronie płytki?
  • TestpointBottom — czy jest punktem testowym po dolnej stronie płytki?
  • TestpointFab — czy jest punktem testowym na etapie produkcji?
  • TestpointFabBottom — czy jest punktem testowym na etapie produkcji po dolnej stronie płytki?
  • TestpointFabTop — czy jest punktem testowym na etapie produkcji po górnej stronie płytki?
  • TestpointTop — czy jest punktem testowym po górnej stronie płytki?

Twórz wyrażenia logiczne zapytań, aby wyszukiwać i uzyskiwać punkty testowe w projekcie zgodnie z potrzebami. Oto kilka przykładów logicznych wyrażeń zapytań wyszukujących punkty testowe na etapie produkcji i montażu:

  1. (ObjectKind = 'Pad') And (TestpointAssy = 'True')
    Wyszukuje wszystkie pola lutownicze będące punktami testowymi na etapie montażu.
  2. IsPad And (TestpointAssyTop = 'True')
    Wyszukuje wszystkie pola lutownicze będące punktami testowymi na etapie montażu po górnej stronie płytki.
  3. (ObjectKind = 'Pad') And (TestpointFab = 'True')
    Wyszukuje wszystkie pola lutownicze będące punktami testowymi na etapie produkcji.
  4. ((IsPad Or IsVia)) And (TestpointAssy = 'True')
    Wyszukuje wszystkie pola lutownicze i przelotki będące punktami testowymi na etapie montażu.
  5. ((IsPad Or IsVia)) And IsFabTestpoint
    Wyszukuje wszystkie pola lutownicze i przelotki będące punktami testowymi na etapie produkcji.

Generowanie raportów punktów testowych

Altium Designer zawiera dedykowane generatory raportów punktów testowych odpowiednio dla etapu produkcji i montażu. Oba generatory wykorzystują odpowiednie właściwości punktów testowych przypisane do obiektów podstawowych pól lutowniczych i przelotek w projekcie.

Raport punktów testowych na etapie produkcji wykorzystuje wyłącznie ustawienia punktów testowych Fabrication pól lutowniczych i przelotek. Raport punktów testowych na etapie montażu wykorzystuje wyłącznie ustawienia punktów testowych Assembly .

Raporty można generować na dwa sposoby:

  • Bezpośrednio z dokumentu PCB za pomocą poleceń File » Fabrication Outputs » Test Point Report i File » Assembly Outputs » Test Point Report.
  • Za pomocą odpowiednio skonfigurowanych danych wyjściowych zdefiniowanych w pliku konfiguracji zadań wyjściowych (*.OutJob).
Więcej informacji na temat plików konfiguracji zadań wyjściowych można znaleźć w artykule Przygotowywanie danych produkcyjnych za pomocą zadań wyjściowych.

Dodaj i skonfiguruj raporty punktów testowych na etapie produkcji i montażu w samodzielnym, wszechstronnym pliku konfiguracji zadań wyjściowych. Po ich zdefiniowaniu uzyskasz raporty za naciśnięciem jednego przycisku!Dodaj i skonfiguruj raporty punktów testowych na etapie produkcji i montażu w samodzielnym, wszechstronnym pliku konfiguracji zadań wyjściowych. Po ich zdefiniowaniu uzyskasz raporty za naciśnięciem jednego przycisku!

Niezależnie od metody generowania raportu jego opcje definiuje się w tym samym oknie dialogowym. W przypadku raportu punktów testowych na etapie produkcji jest to okno dialogowe Fabrication Testpoint Setup. W przypadku raportu punktów testowych na etapie montażu używane jest okno dialogowe Assembly Testpoint Setup. Opcje raportów w obu oknach są identyczne.

Zdefiniuj opcje raportu, w tym format generowanego pliku, w odpowiednim oknie dialogowym konfiguracji raportu. 
Zdefiniuj opcje raportu, w tym format generowanego pliku, w odpowiednim oknie dialogowym konfiguracji raportu.

Ustawienia zdefiniowane w oknie dialogowym Testpoint Setup podczas generowania danych wyjściowych bezpośrednio z PCB są odrębne i niezależne od ustawień zdefiniowanych dla tego samego typu danych wyjściowych w pliku konfiguracji zadań wyjściowych. W pierwszym przypadku ustawienia są przechowywane w pliku projektu, natomiast w drugim — w pliku zadań wyjściowych.
Opcje w obszarze Coordinate Positions okna dialogowego umożliwiają eksportowanie położeń punktów testowych we wszystkich formatach raportów względem bezwzględnego lub bieżącego początku układu współrzędnych płytki.
Wszystkie typy raportów punktów testowych obsługują osadzone panele płytek. Podczas eksportowania z dokumentu PCB zawierającego wiele osadzonych paneli płytek generowanych jest wiele plików listy połączeń IPC-D-356A.

Rola pliku listy połączeń IPC-D-356A

Jednym z trzech formatów wyjściowych raportów punktów testowych jest plik listy połączeń IPC-D-356A. Plik ten jest zwykle używany do testowania nieobsadzonych płytek na etapie produkcji. Plik IPC jest następnie przetwarzany na polecenia sterujące testerem z ruchomymi sondami.

Niezależnie od tego, które elementy są konkretnie oznaczone jako lokalizacje punktów testowych w pliku IPC-D-356A, producenci płytek mogą zazwyczaj wykorzystać dane z tego pliku do przeprowadzenia dowolnego rodzaju testów. Jednak w zależności od okoliczności i zawartości pliku może to wymagać pewnych czynności ręcznych.

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Nav
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents