W tym szczegóły projektu
W skrócie
- Dowiedz się, jakie elementy dokumentacji PCB można dodawać w edytorze PCB lub edytorze bibliotek PCB oraz jak wykorzystać warstwy mechaniczne do ich uporządkowania.
- Zobacz, co zawierają tabele stosu warstw i tabele otworów, gdzie można je umieszczać oraz jak się aktualizują lub odzwierciedlają bieżący projekt płytki.
- Poznaj najważniejsze opcje umieszczania, przesuwania, zmiany rozmiaru i ustawiania właściwości, które decydują o wyglądzie tych elementów w dokumentacji wyjściowej PCB.
Wiele generowanych dokumentów wyjściowych wymaga dodatkowych szczegółów. Na przykład rysunek produkcyjny będzie wymagał wymiarów, rysunek montażowy może wymagać powiększonego widoku określonego obszaru płytki, a rysunek wykonawczy będzie wymagał tabeli stosu warstw oraz tabeli otworów. Tego rodzaju szczegóły można dodawać w edytorze PCB lub w edytorze bibliotek PCB.
Warstwy rysunkowe ogólnego przeznaczenia
W edytorze PCB szczegóły, takie jak wymiary oraz instrukcje wykonawcze i montażowe, dodaje się na warstwach mechanicznych. Oprogramowanie obsługuje nieograniczoną liczbę warstw mechanicznych ogólnego przeznaczenia, które włącza się w panelu View Configuration. Warstwom tym można nadawać dowolne nazwy (kliknij nazwę prawym przyciskiem myszy, a następnie wybierz Edit Layer), a także uwzględniać je na wydrukach i w danych wyjściowych do produkcji opartych na warstwach.
Tabela stosu warstw

Tabelę stosu warstw można umieścić w dokumencie PCB obok samego projektu. Zawiera ona szczegółowe zestawienie stosów warstw płytki oraz sposobu przypisania grup warstw.
Tabela stosu warstw to tabelaryczny obiekt graficzny dokumentujący warstwy, materiały, grubości i stałe dielektryczne zastosowane w bieżącym projekcie PCB. Umieszcza się ją w przestrzeni projektowej obok projektu płytki. Zawiera ona również legendę graficzną i mapę wariantów pokazującą stos warstw używany w każdym obszarze płytki. Tabela stosu warstw odzwierciedla konfiguracje warstw zdefiniowane za pomocą Layer Stack Manager i jest ważnym elementem dokumentacji projektów o złożonej strukturze stosu warstw, takich jak projekty sztywno-elastyczne.
Tabela stosu warstw jest dostępna w edytorze PCB, gdy widok przestrzeni projektowej jest ustawiony na standardowy tryb 2D (skrót 2). Po uruchomieniu polecenia umieszczania tabeli stosu warstw (Place » Layer Stack Table) kursor zmieni się w krzyżyk i zostanie włączony tryb umieszczania tabeli stosu warstw. Aby umieścić tabelę, wykonaj następujące czynności:
- Kliknij, aby umieścić tabelę.
- Edytor pozostaje w trybie umieszczania tabeli stosu warstw, umożliwiając w razie potrzeby umieszczenie kolejnej tabeli. Jeśli nie jest to konieczne, kliknij prawym przyciskiem myszy lub naciśnij Esc, aby wyjść z trybu umieszczania.
Podczas umieszczania, gdy tabela stosu warstw jest jeszcze dołączona do kursora i zanim jej punkt środkowy zostanie zakotwiczony, można wykonać następujące dodatkowe czynności:
- Naciśnij klawisz Alt, aby ograniczyć kierunek ruchu do osi poziomej lub pionowej, zależnie od początkowego kierunku ruchu.
- Naciśnij Spacebar, aby obrócić tabelę stosu warstw przeciwnie do ruchu wskazówek zegara, lub Shift+Spacebar, aby obrócić ją zgodnie z ruchem wskazówek zegara. Obrót odbywa się w krokach co 90°.
Aby przenieść tabelę stosu warstw, kliknij ją i, przytrzymując przycisk myszy, przeciągnij w żądane miejsce.

Zaznacz i przeciągnij tabelę stosu warstw, aby zmienić jej położenie.
Właściwości tabeli stosu warstw

Tryb Layer Stack Table panelu Properties.
Położenie
-
(X/Y)
- X (pierwsze pole) — bieżąca współrzędna X (pozioma) punktu odniesienia obiektu względem bieżącego początku układu współrzędnych przestrzeni projektowej. Edytuj ją, aby zmienić położenie obiektu w osi X. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych. Jeśli używasz jednostek innych niż domyślne, podaj je wraz z wartością.
- Y (drugie pole) — bieżąca współrzędna Y (pionowa) punktu odniesienia obiektu względem bieżącego początku układu współrzędnych. Edytuj ją, aby zmienić położenie obiektu w osi Y. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych. Jeśli używasz jednostek innych niż domyślne, podaj je wraz z wartością.
- Rotation — kąt obrotu obiektu (w stopniach), mierzony przeciwnie do ruchu wskazówek zegara od zera (poziomy kierunek 3 o'clock). Edytuj go, aby zmienić obrót obiektu. Minimalna rozdzielczość kątowa wynosi 0,001°.
Właściwości
- Layer — warstwa, do której tabela jest obecnie przypisana. Użyj listy rozwijanej, aby wybrać inną warstwę.
- Alignment — użyj listy rozwijanej, aby wybrać żądane wyrównanie.
-
Units — użyj listy rozwijanej, aby wybrać
Metric (mm)lubImperial (mil). - Show Board Map — włącz, aby wyświetlić obrys płytki pokazujący, jak poszczególne stosy warstw są przypisane do jej obszarów. Użyj suwaka, aby zmienić skalę wyświetlanego obrysu płytki.
- Show Total Board Thickness — włącz, aby wyświetlić całkowitą grubość płytki pod siatką tabeli stosu warstw.
- Line Width — określ grubość linii tekstu w tabeli. Line Width wpływa na grubość linii tekstu.
- Text Height — bieżąca wysokość znaków tekstu. Określ wysokość tekstu w tabeli. Text Height wpływa również na rozmiar tabeli. Jeśli ustawisz większą wysokość tekstu, tabela zostanie automatycznie powiększona.
Typ czcionki
-
TrueType — użyj tego pola, aby wybrać żądaną czcionkę TrueType. Lista rozwijana Font zawiera czcionki TrueType i OpenType (rozszerzenie standardu TrueType) znalezione w folderze
\Windows\Fonts. Należy pamiętać, że lista zawiera wyłącznie pozycje wykrytych czcionek podstawowych o unikatowych nazwach. Użyj opcji B (bold) i I (Italic), aby wyróżnić tekst. -
Stroke
-
Font - użyj tego pola, aby wybrać wymaganą czcionkę kreskową. Dostępne opcje:
-
Default- prosta czcionka wektorowa obsługująca kreślenie pisakiem i fotokreślenie wektorowe. -
Serif- bardziej złożona czcionka, która spowalnia generowanie danych wyjściowych w formacie wektorowym, np. Gerber. -
Sans Serif- bardziej złożona czcionka, która spowalnia generowanie danych wyjściowych w formacie wektorowym, np. Gerber.
-
-
Font - użyj tego pola, aby wybrać wymaganą czcionkę kreskową. Dostępne opcje:
-
Stroke Width - wyświetla bieżącą szerokość kreski.
Kolumny
W tej sekcji można określić, które kolumny mają być wyświetlane w tabeli stosu warstw, wyrównanie tekstu w danej kolumnie oraz jej całkowitą szerokość.
- Caption - tytuł wyświetlanej kolumny.
- Align - kliknij komórkę wyrównania dla nagłówka, którego wyrównanie chcesz zmienić. Kolejne kliknięcia przełączają dostępne opcje wyrównania (do lewej, do środka i do prawej). Każde kliknięcie pola wyrównania zmienia wyrównanie tekstu w danej kolumnie tabeli.
-
Width - kliknij pole, aby edytować szerokość wybranego nagłówka. Gdy wybrano
Auto, system automatycznie dostosowuje szerokość kolumny do wprowadzonego w niej tekstu. W razie potrzeby można wprowadzić wymaganą szerokość. - Add - użyj listy rozwijanej, aby dodać kolumnę do tabeli stosu warstw, wybierając jedną z dostępnych opcji. Na liście rozwijanej kliknij nagłówek, który ma pojawić się w tabeli.
- Up - kliknij, aby przesunąć wybrany nagłówek o jedną kolumnę w lewo w tabeli. Klikaj przycisk Up wielokrotnie, aby przesunąć wybraną kolumnę o kolejne kolumny w lewo.
- Down - kliknij, aby przesunąć wybrany nagłówek o jedną kolumnę w prawo w tabeli. Klikaj przycisk Down wielokrotnie, aby przesunąć wybraną kolumnę o kolejne kolumny w prawo.
-
- kliknij, aby usunąć wybrany nagłówek z tabeli. W tabeli pojawi się prośba o potwierdzenie usunięcia wybranego elementu. Kliknij Yes , jeśli chcesz go usunąć, lub No , jeśli nie chcesz tego robić.
Tabela wierceń

Tabela wierceń przedstawia aktualizowane na bieżąco zestawienie wszystkich otworów w płytce
Tabela wierceń (znana również jako tabela rysunku wierceń lub legenda rysunku wierceń) jest standardowym elementem wymaganym do produkcji płytki drukowanej. Tabela wierceń zawiera rozmiary i liczbę otworów dla każdego wiertła używanego do wykonania płytki. Każdy rozmiar wiertła może być reprezentowany przez symbol, literę lub rzeczywisty rozmiar otworu. Podczas generowania rysunku wierceń dla płytki każde miejsce wiercenia jest oznaczane symbolem. Tabela wierceń jest aktualizowana w czasie rzeczywistym, tj. podczas umieszczania w projekcie PCB lub usuwania z niego obiektów zawierających otwory, takich jak pola lutownicze i przelotki.
Tabelę wierceń można umieścić wyłącznie w edytorze PCB. Po uruchomieniu polecenia tabela wierceń pojawi się przy kursorze. Ustaw tabelę w odpowiednim miejscu poza obrysem płytki, a następnie kliknij lub naciśnij Enter, aby ją umieścić.
Dodatkowe czynności, które można wykonać podczas umieszczania, gdy tabela wierceń nadal jest dołączona do kursora i nie została jeszcze osadzona, to:
- Naciśnij klawisz Tab, aby wstrzymać umieszczanie i przejść do trybu Tabela wierceń panelu Properties , w którym można na bieżąco zmieniać jej właściwości. Kliknij nałożony przycisk pauzy , aby wznowić umieszczanie.
- Naciśnij klawisz Alt, aby ograniczyć kierunek ruchu do osi poziomej lub pionowej, zależnie od początkowego kierunku ruchu.
Przenoszenie tabeli wierceń
Kliknij i przytrzymaj w dowolnym miejscu tabeli wierceń, a następnie przenieś ją w żądane miejsce w obszarze projektowym edytora PCB.
Interaktywna zmiana rozmiaru tabeli wierceń
Rozmiar tabeli wierceń jest ustalany automatycznie na podstawie określonego ustawienia Text Height, a także liczby różnych rozmiarów otworów (wierszy) i liczby zdefiniowanych kolumn. Aby interaktywnie zmienić rozmiar tabeli, kliknij ją raz, aby ją zaznaczyć, a następnie kliknij i przytrzymaj wierzchołek narożny i przeciągnij go, aby uzyskać wymagany rozmiar. Pamiętaj, że interaktywna zmiana rozmiaru tabeli powoduje również zwiększenie lub zmniejszenie rozmiaru czcionki.
Interaktywne przełączanie pary warstw do podglądu
Jeśli płytka zawiera pary warstw, wyświetlaną parę określa opcja Layers Pairs w trybie Drill Table panelu Properties .
Wybraną parę warstw można również przełączyć za pomocą:
-
Menu kontekstowego edytora PCB — kliknij tabelę wierceń prawym przyciskiem myszy, a następnie wybierz wymaganą parę warstw w podmenu Drill Table, jak pokazano na ilustracji poniżej.

Kliknij tabelę wierceń prawym przyciskiem myszy, aby wyświetlić w niej inną parę warstw -
Menu wyboru pary warstw dostępnego z karty warstwy u dołu obszaru projektowego, jak pokazano na ilustracji poniżej.
Właściwości tabeli wierceń

Tryb Drill Table panelu Properties
Działania
Refresh – kliknij przycisk, aby zaktualizować tabelę wierceń bieżącymi danymi symboli wierceń z PCB.
Położenie
-
(X/Y) – bieżące współrzędne X i Y punktu odniesienia tabeli otworów. Punktem odniesienia jest lewy dolny narożnik, jeśli Alignment =
Bottom, lub lewy górny narożnik, jeśli Alignment =Top. - Rotation – kąt obrotu tabeli otworów w stopniach.
Właściwości
-
Layer Pairs – tabela otworów obsługuje płytki wielowarstwowe, w których stosuje się wiercenie między parami warstw. Z listy rozwijanej wybierz parę warstw zdefiniowaną na karcie Via Types w menedżerze stosu warstw lub jedną z następujących opcji:
- All Layer Pairs (Composite table) – wyświetla informacje dla wszystkich par warstw.
-
All Layer Pairs (Separate tables) – wyświetla informacje dla każdej pary warstw w osobnej tabeli.
- Top - Bottom – wyświetla tylko otwory przelotowe.
- Counterhole Bottom – wyświetla tylko pogłębienia otworów (walcowe/stożkowe) po dolnej stronie płytki PCB.
- Counterhole Top – wyświetla tylko pogłębienia otworów (walcowe/stożkowe) po górnej stronie płytki PCB.
- Text Height – wyświetla wysokość tekstu.
Typ czcionki
-
TrueType – wybierz, aby korzystać z czcionek dostępnych na komputerze (w folderze \Windows\Fonts). Czcionki TrueType zapewniają pełną obsługę standardu Unicode. Domyślnie oprogramowanie tworzy odwołanie do używanej czcionki TrueType (czcionki nie są zapisywane w pliku PCB), co oznacza, że ta sama czcionka musi być dostępna na każdym komputerze, na który przenoszony jest projekt. Możesz też osadzić używane czcionki TrueType w pliku PCB za pomocą opcji na stronie PCB Editor – True Type Fonts okna dialogowego Preferences, gdzie można również wybrać Substitution Font do użycia w przypadku niedostępności nieosadzonej czcionki.
- Font – z listy rozwijanej wybierz żądaną czcionkę TrueType. Użyj B, aby pogrubić tekst, lub I, aby zastosować kursywę.
-
Stroke
-
Font – z listy rozwijanej wybierz żądaną czcionkę kreskową. Dostępne opcje:
-
Default– prosta czcionka wektorowa przeznaczona do ploterów pisakowych i fotoploterów wektorowych. -
Sans Serif -
Serif
-
- Stroke Width – wyświetla szerokość kreski.
-
Font – z listy rozwijanej wybierz żądaną czcionkę kreskową. Dostępne opcje:
- Show Footer – przełącz, aby włączyć/wyłączyć wyświetlanie stopki tabeli.
- Alignment – tabela może być tworzona od dołu do góry (Bottom) lub od góry do dołu (Top). To ustawienie pozwala zmieniać rozmiar tabeli bez wpływu na otaczające ją obiekty w obszarze projektowym.
- Table Border Width – szerokość linii tworzących obramowanie tabeli.
-
Drill Symbols – kliknij, aby otworzyć okno dialogowe Drill Symbols, w którym można przypisać symbole/litery do rozmiarów otworów.
Opcje i elementy sterujące okna dialogowego symboli otworów
Grid Area
Obszar tabeli zawiera szczegółowe informacje o przypisaniu symbolu do rozmiaru otworu. Można go dostosować, przeciągając nagłówek kolumny w celu zmiany kolejności kolumn oraz klikając nagłówek kolumny prawym przyciskiem myszy i zaznaczając/odznaczając pole wyboru, aby pokazać/ukryć kolumnę.
Grouping
Kliknij przycisk Grouping, aby określić właściwości sterujące przypisywaniem symboli do operacji wiercenia (otworów). Otwory są początkowo grupowane według rozmiaru, a następnie przypisywane są im osobne symbole po włączeniu opcji grupowania, która pozwala je jednoznacznie rozróżnić. Na przykład projekt może zawierać okrągły pad z otworem o średnicy 1 mm oraz kwadratowy pad z otworem o średnicy 1 mm. Jeśli opcja Pad Shape nie jest włączona w Grouping, zostanie im przypisany ten sam symbol. Jeśli jednak opcja Pad Shape jest włączona w Grouping, zostaną im przypisane osobne symbole.
Graphic Symbol
Każde miejsce otworu może być oznaczone symbolem, literą lub ciągiem znaków wskazującym rzeczywisty rozmiar otworu. Poniższe opcje określają styl i rozmiar symbolu:
-
Symbol – wybierz, aby używać symbolu w każdym miejscu otworu. Oprogramowanie zawiera 15 predefiniowanych stylów symboli, pokazanych na poniższej ilustracji. Jeśli liczba rozmiarów otworów przekracza 15, automatycznie przypisywane są litery.
- Character – wybierz, aby używać litery w każdym miejscu otworu.
- Symbol Size – wysokość symbolu/litery wyświetlanej na warstwie rysunku wierceń. Należy pamiętać, że ustawienie to dotyczy wszystkich symboli/liter używanych na rysunku wierceń.
Draw Symbols
Poniższe opcje określają styl symboli otworów oraz warunki ich wyświetlania:
- Show Symbols – wyświetla symbol w każdym miejscu otworu.
- Show Hole Size – wyświetla rzeczywisty rozmiar wiercenia w każdym miejscu otworu jako wartość liczbową.
- Show Drill Symbols – domyślnie symbole otworów nie są wyświetlane na warstwie rysunku wierceń. Włącz tę opcję, aby je wyświetlić.
-
-
– kliknij, aby odświeżyć tabelę po wprowadzeniu zmian w projekcie, które wpływają na tabelę otworów. Należy pamiętać, że tabela jest automatycznie aktualizowana podczas generowania plików wyjściowych.
Jednostki
-
Primary Units – z listy rozwijanej wybierz jednostki podstawowe:
Metric (mm)lubImperial (mil). -
Dual Units – z listy rozwijanej wybierz jednostki dodatkowe:
Metric (mm)lubImperial (mil). Użyj
lub
, aby odpowiednio wyświetlić lub ukryć te jednostki w obszarze projektowym.
Precyzja
- Primary Precision – z listy rozwijanej wybierz wymaganą precyzję (liczbę cyfr po przecinku).
- Dual Precision – z listy rozwijanej wybierz precyzję dla jednostek dodatkowych (liczbę cyfr po przecinku).
Kolumny
- Grid – wyświetla wszystkie nagłówki kolumn (Caption) w tabeli otworów, ustawienie Align, które zmienia położenie zawartości w siatce, Width oraz Order, według którego wyświetlane są informacje w każdej kolumnie. Aby zmienić kolejność z rosnącej na malejącą lub odwrotnie, kliknij w kolumnie Order, aby otworzyć menu rozwijane, a następnie wybierz żądaną kolejność: Asc – rosnąca lub Dsc – malejąca.
-
Edit Columns – kliknij, aby otworzyć okno dialogowe Columns, w którym możesz dodawać nowe kolumny do tabeli otworów lub edytować istniejące.
Okno dialogowe przedstawia wszystkie istniejące kolumny wraz z powiązanymi danymi (tylko do odczytu). Użyj poniższych przycisków pod siatką, aby wybrać dane prezentowane w tabeli:
- Add Column – służy do dodawania nowej kolumny do tabeli otworów. Kliknij, aby otworzyć menu dostępnych kolumn. Kolumny, które są już używane lub niedostępne, są w menu wyszarzone. To polecenie jest również dostępne w menu wyświetlanym po kliknięciu prawym przyciskiem myszy.
- Remove Column – kliknij, aby usunąć zaznaczone kolumny. Pamiętaj, że nie pojawi się okno dialogowe z potwierdzeniem; po kliknięciu przycisku kolumna zostanie usunięta. To polecenie jest również dostępne w menu wyświetlanym po kliknięciu prawym przyciskiem myszy.
- Change Header – kliknij, aby otworzyć okno dialogowe zmiany nagłówka kolumny, w którym możesz zmienić tytuł zaznaczonej kolumny. To polecenie (o nazwie Change column header) jest również dostępne w menu wyświetlanym po kliknięciu prawym przyciskiem myszy.
W menu kontekstowym wyświetlanym po kliknięciu prawym przyciskiem myszy dostępne są następujące dodatkowe polecenia:
-
Text Alignment – służy do wyrównywania tekstu w zaznaczonej kolumnie. Dostępne opcje to:
Left,CenteriRight. -
Set column width – służy do ustawiania szerokości zaznaczonej kolumny. Dostępne opcje to:
Autosize(domyślnie) orazManual. KliknięcieManualotwiera okno dialogowe ustawiania szerokości kolumny, w którym można wprowadzić żądaną szerokość.
Widok projektu

Umieść widok projektu, aby pokazać określony obszar płytki. W tym przykładzie zastosowano skalę 200%.
Obiekt widoku projektu PCB jest graficznym odwzorowaniem dowolnego prostokątnego obszaru bieżącej lub innej płytki. Można go umieścić w dowolnym miejscu obszaru projektowego i przeskalować do dowolnego rozmiaru.
Widok projektu można umieścić tylko w edytorze PCB. Po uruchomieniu polecenia umieszczania widoku projektu (Place » Design View) widok projektu zostanie dołączony do kursora. Ustaw widok projektu w odpowiednim miejscu, a następnie kliknij lub naciśnij Enter, aby go umieścić.
Podczas umieszczania, gdy widok projektu jest nadal dołączony do kursora i nie został jeszcze zakotwiczony, można wykonać następujące dodatkowe czynności:
- Naciśnij klawisz Alt, aby ograniczyć kierunek ruchu do osi poziomej lub pionowej, zależnie od początkowego kierunku ruchu.
Po umieszczeniu widoku projektu możesz określić, które warstwy mają być wyświetlane, wykonując następujące czynności:
- Po zaznaczeniu widoku projektu w obszarze projektowym otwórz panel właściwości, klikając dwukrotnie lub klikając prawym przyciskiem myszy i wybierając Properties z menu kontekstowego.
- Użyj przycisku Define w panelu Properties , aby interaktywnie określić interesujący Cię obszar.
-
W sekcji Layers panelu Properties kliknij (przełącz) ikonę
, aby włączyć wyświetlanie żądanych warstw. Po włączeniu w panelu Properties przy wybranych warstwach będzie wyświetlana ikona
.
Widoki projektu są uwzględniane na wydrukach i w plikach PDF. Widok projektu zachowuje własne ustawienia widoczności warstw w danych wyjściowych, dzięki czemu może być prezentowany zgodnie z wymaganiami na wydruku lub w pliku PDF. Pamiętaj, że obiekty podstawowe na warstwach używanych w widoku projektu nadal podlegają ustawieniom wyświetlania zdefiniowanym dla danej warstwy w oknie dialogowym drukowania. Na przykład, jeśli w widoku projektu wyświetlana jest warstwa Top Overlay, a w zadaniu wyjściowym skonfigurowano wyświetlanie ścieżek tej warstwy w trybie roboczym dla danego wyjścia, ścieżki warstwy Top Overlay w widoku projektu również będą wyświetlane w trybie roboczym.
Po umieszczeniu widoku projektu w obszarze projektowym możesz interaktywnie dostosowywać jego położenie, skalę, rozmiar i wyświetlany obszar.
- Change the position – Click+Drag obiekt widoku projektu w nowe miejsce w obszarze projektowym PCB.
- Adjusting the Scale – kliknij raz, aby zaznaczyć widok projektu, a następnie Click+Drag na uchwycie narożnym, aby powiększyć widok projektu (przeciągnij na zewnątrz) lub go pomniejszyć (przeciągnij do wewnątrz).
- Adjusting the View Size – kliknij raz, aby zaznaczyć widok projektu, a następnie Ctrl+Click+Drag na uchwycie narożnym, aby zmienić rozmiar widoku projektu.
- Changing the Focus – Ctrl+Click+Drag w dowolnym miejscu widoku projektu, aby przesunąć aktualnie wyświetlany obszar w oknie widoku projektu.

Ctrl+Click+Drag aby przesunąć i dostosować obszar aktualnie wyświetlany w widoku projektu.
Właściwości widoku projektu

Tryb Design View panelu Properties.
Położenie
- (X/Y) – bieżące współrzędne X i Y punktu odniesienia widoku projektu.
Właściwości
- This document – wybierz, aby określić właściwości aktualnie aktywnego dokumentu.
-
Specify document – wybierz, aby określić właściwości innego dokumentu. Po wybraniu tej opcji kliknij
w polu Document , a następnie wyszukaj żądany dokument.
-
Document – kliknij
, aby wyszukać i wybrać żądany dokument, gdy wybrano Specify document .
- Mirrored – kliknij, aby włączyć lustrzane odbicie obszaru płytki w widoku projektu.
- Scale – kliknij, aby określić rozmiar obiektu za pomocą współczynnika skali.
- Title – wprowadź tytuł widoku projektu.
- Text Height – wprowadź wysokość tekstu tytułu widoku projektu.
- Font – użyj listy rozwijanej, aby wybrać żądaną czcionkę tytułu. Użyj pola koloru, aby otworzyć okno wyboru koloru tekstu tytułu. Pamiętaj, że kolor musi kontrastować z kolorem tła obszaru projektowego, aby tekst był widoczny.
- Define – kliknij, aby wrócić do obszaru projektowego z kursorem krzyżowym, a następnie kliknij i przeciągnij, aby zdefiniować prostokątny obszar widoku.
Warstwy
Ta sekcja zawiera listę wszystkich warstw płytki, którą można skonfigurować tak, aby wyświetlać określone warstwy w widoku projektu.
-
Name – nazwa warstwy. Użyj
lub
, aby odpowiednio pokazać lub ukryć wymienioną warstwę w widoku projektu.
- Type — typ warstwy.
Obiekt OLE

Umieszczona sekwencja obiektów OLE — obraz, komórki arkusza kalkulacyjnego i tekst dokumentu Word (od góry do dołu)
Technologia Object Linking and Embedding (OLE) w edytorze PCB umożliwia osadzanie w projekcie PCB danych dostarczanych przez aplikacje OLE systemu Windows przy zachowaniu aktywnego połączenia z aplikacją źródłową. W wielu przypadkach pozwala to edytować osadzone dane PCB w aplikacji, w której zostały utworzone.
Typowe obiekty OLE, które można umieszczać w dokumencie PCB, to standardowe dokumenty Excel, dokumenty Word lub obiekty graficzne z odpowiedniej aplikacji graficznej obsługującej OLE. Obsługiwane typy plików obejmują uniwersalne formaty, takie jak arkusze kalkulacyjne CSV i XLS, dokumenty tekstowe DOC i RTF oraz pliki obrazów BMP.
Obiekty OLE można umieszczać i osadzać w edytorze PCB. Po uruchomieniu polecenia Place » Object From File wybierz żądany plik w oknie dialogowym Choose File, a następnie kliknij, aby umieścić obiekt w obszarze projektowym.
Funkcja inteligentnego wklejania Altium umożliwia również skopiowanie zaznaczenia w aplikacji OLE i wklejenie go (Edit » Paste) do dokumentu PCB jako obiektu OLE. W razie potrzeby można użyć opcji wklejania tekstu (Edit » Paste Text), aby wyodrębnić elementy tekstowe z obiektu OLE. Zostaną one umieszczone jako obiekty tekstowe PCB.
Po umieszczeniu osadzone obiekty można proporcjonalnie skalować, klikając, przytrzymując i przeciągając ich uchwyty zaznaczenia. W przypadku obiektów tekstowych, takich jak dokumenty Word i Excel, rozmiar i grubość osadzonego tekstu są automatycznie skalowane w celu dopasowania do nowych wymiarów.
- Obiekt OLE można również przekształcić w zbiór niezależnych obiektów podstawowych za pomocą polecenia Tools » Convert » Explode OLE Object to Free Primitives. Spowoduje to rozbicie obiektu na odpowiednie obiekty regionów i/lub tekstu.
- Opcja przekształcenia w niezależne obiekty podstawowe jest również dostępna, jeśli podczas próby edycji obiektu OLE nie można znaleźć odpowiedniej aplikacji OLE.
Właściwości obiektu OLE

Tryb OLE Object panelu Properties.
Położenie
- (X/Y) — bieżąca współrzędna X (pozioma) i bieżąca współrzędna Y (pionowa) punktu odniesienia obiektu względem bieżącego początku układu współrzędnych obszaru projektowego. Edytuj, aby zmienić położenie obiektu.
- Rotation — kąt obrotu obiektu (w stopniach), mierzony przeciwnie do ruchu wskazówek zegara od zera (poziomu 3 o'clock). Edytuj, aby zmienić obrót obiektu. Minimalna rozdzielczość kątowa wynosi 0,001°.
Właściwości
- Layer — warstwa, do której obiekt jest obecnie przypisany. Użyj listy rozwijanej, aby wybrać inną warstwę.
- Edit Data — kliknij, aby otworzyć obiekt (w powiązanej aplikacji) i wprowadzić wymagane zmiany. Po wprowadzeniu zmian i zamknięciu powiązanej aplikacji kliknij w panelu Właściwości Save , aby zapisać zmiany, lub Cancel.
Wymiary
Edytory PCB i bibliotek PCB zawierają szereg narzędzi do wymiarowania dostosowanych do różnych wymagań projektowych.
| Obiekt wymiarowy | Opis |
|---|---|
| Angular Dimension | Umożliwia wymiarowanie odległości kątowych. |
| Baseline Dimension | Umożliwia wymiarowanie odległości liniowych zbioru punktów odniesienia względem jednego bazowego punktu odniesienia. Pierwszy wybrany punkt jest „bazą”. Wszystkie kolejne punkty odnoszą się do tego pierwszego punktu. Wartość wymiaru jest więc w każdym przypadku odległością między danym punktem odniesienia a „bazą”, mierzoną w jednostkach domyślnych. Odniesieniami mogą być ścieżki, łuki, pady, przelotki, teksty, wypełnienia, poligony lub komponenty. |
| Center Dimension | Umożliwia oznaczenie środka łuku lub okręgu. |
| Leader Dimension | Umożliwia opisanie obiektu, punktu lub obszaru. Dostępne są trzy typy odnośników: automatyczny, okrągły i kwadratowy, które określają, czy tekst etykiety jest otoczony okręgiem, kwadratem, czy nie ma obramowania. Wskaźnik może mieć postać strzałki lub kropki. |
| Linear Dimension | Umożliwia wymiarowanie odległości liniowej. Wartość wymiaru to odległość między znacznikiem początkowym a końcowym (punktami odniesienia wybranymi przez użytkownika), mierzona w jednostkach domyślnych. Odniesieniami mogą być obiekty (ścieżki, łuki, pady, przelotki, teksty, wypełnienia, poligony lub komponenty) albo punkty w wolnej przestrzeni. |
| Linear Diameter Dimension | Umożliwia wymiarowanie łuku lub okręgu na podstawie średnicy, a nie promienia. Wymiar można umieścić wewnątrz lub na zewnątrz. |
| Ordinate Dimension | Umożliwia wymiarowanie odległości liniowych zbioru obiektów względem jednego obiektu odniesienia. Pierwszy wybrany obiekt jest „bazą”. Wszystkie kolejne obiekty odnoszą się do tego pierwszego obiektu. Wartość wymiaru jest więc w każdym przypadku odległością między danym obiektem odniesienia a „bazą”, mierzoną w jednostkach domyślnych. Odniesieniami mogą być ścieżki, łuki, pady, przelotki, teksty, wypełnienia, poligony lub komponenty. |
| Radial Dimension | Umożliwia wymiarowanie promienia łuku lub okręgu. Wymiar można umieścić wewnątrz lub na zewnątrz. |
| Radial Diameter Dimension | Umożliwia wymiarowanie łuku lub okręgu na podstawie średnicy, a nie promienia. Wymiar można umieścić wewnątrz lub na zewnątrz względem obwodu łuku/okręgu. |
| Standard Dimension | Umieszcza informacje wymiarowe na bieżącej warstwie PCB. Wartość wymiaru to odległość między znacznikiem początkowym a końcowym, mierzona w jednostkach domyślnych. |
Obiekty wymiarowe są dostępne w podmenu Place » Dimension menu głównego. Podczas wymiarowania obiektu dostępne stają się punkty zaczepienia, które wskazują miejsca, w których można dołączyć wymiar. Pasek stanu wyświetla informacje o czynnościach wymaganych na każdym etapie procesu. Użyty zostanie punkt znajdujący się najbliżej kursora i to do niego zostanie dołączony wymiar po kliknięciu lub naciśnięciu Enter.
Przykłady umieszczania wybranych wymiarów przedstawiono w poniższym filmie.
Dodatkowe czynności, które można wykonać podczas umieszczania:
- Naciśnij klawisze + i - (na klawiaturze numerycznej), aby przechodzić odpowiednio do przodu i do tyłu przez wszystkie widoczne warstwy projektu — pozwala to szybko zmieniać warstwę umieszczania.
- Podczas umieszczania wymiaru od bazy, znacznika środka, liniowego wymiaru średnicy, wymiaru liniowego lub współrzędnościowego naciśnij Spacebar, aby obrócić wymiar przeciwnie do ruchu wskazówek zegara, lub Shift+Spacebar, aby obrócić go zgodnie z ruchem wskazówek zegara. Obrót odbywa się zgodnie z wartością parametru Rotation Step zdefiniowaną na stronie PCB Editor – General okna dialogowego Preferences.
- Podczas umieszczania wymiaru standardowego naciśnij klawisz L, aby przenieść wymiar na drugą stronę płytki — jest to możliwe tylko przed zakotwiczeniem punktu początkowego wymiaru.
Wartość wymiaru (jeśli dotyczy) aktualizuje się automatycznie po przesunięciu jego punktu początkowego lub końcowego. Podobnie, jeśli zmieni się położenie obiektu, do którego zakotwiczono punkt odniesienia wymiaru, wymiar zostanie zaktualizowany i odpowiednio wydłużony lub skrócony. W przypadku wymiaru promienia lub średnicy wartość aktualizuje się automatycznie wraz ze zmianą średnicy łuku lub okręgu odniesienia.
Po usunięciu obiektu lub obiektów odniesienia, do których dołączony jest obiekt wymiaru, otworzy się okno dialogowe z pytaniem, czy wymiar również ma zostać usunięty. Jeśli wymiar nie zostanie usunięty, pozostanie w obszarze projektowym, ale bez powiązania z obiektem odniesienia.
Obiekt wymiaru można przesuwać w następujący sposób:
- Selecting both the dimension object and the dimensioned object(s). Cały obiekt można przeciągnąć w nowe położenie.
- Selecting a dimensioned object only. Tekst wymiaru będzie podążał za obiektem wyłącznie w płaszczyźnie wyrównania. Pomocnicze linie wymiarowe (lub, w przypadku promieniowego wymiaru średnicy albo wymiaru promienia, jego wskaźnik i ogon) będą się wydłużać lub skracać, aby zachować powiązanie między wymiarem a wymiarowanym obiektem. W przypadku znacznika środka lub wymiaru z odnośnikiem wymiar będzie przesuwał się wraz z obiektem. Odcinek wymiaru z odnośnikiem (między strzałką/kropką a pierwszym zdefiniowanym załamaniem) będzie się wydłużać lub skracać, aby zachować powiązanie między wymiarem a wymiarowanym obiektem.
- Selecting the dimension object only. Należy pamiętać, że nie można przesunąć samego wymiaru, jeśli jest on powiązany z obiektem projektu. Aby przesunąć tylko wymiar, trzeba najpierw odłączyć go od wymiarowanych obiektów.
Po zaznaczeniu obiektu wymiaru dostępne są uchwyty edycji, które umożliwiają edytowanie umieszczonego wymiaru bezpośrednio w obszarze projektowym poprzez graficzną zmianę właściwości, takich jak położenie tekstu i punktów odniesienia. Poniżej przedstawiono przykłady uchwytów edycji dla wybranych wymiarów.
|
Po zaznaczeniu obiektu wymiaru liniowego dostępne są następujące uchwyty edycji:
Po zaznaczeniu obiektu wymiaru kątowego dostępne są następujące uchwyty edycji:
Po zaznaczeniu obiektu wymiaru promienia dostępne są następujące uchwyty edycji:
Po zaznaczeniu obiektu wymiaru współrzędnościowego dostępne są następujące uchwyty edycji.
|
Uchwyty znajdujące się na wymiarowanych obiektach (lub najbliżej nich) (na przykład C i D dla wymiaru liniowego lub C i E oraz D i F dla wymiaru kątowego, jak pokazano powyżej) umożliwiają ponowne definiowanie odniesień — po odłączeniu wymiaru od obiektu odniesienia traci on powiązanie i można go przesunąć, aby dołączyć do innego punktu lub obiektu odniesienia. Podczas przeciągania dowolnego uchwytu edycji niepowiązanego wymiaru liniowego, współrzędnościowego lub od bazy można obracać wymiar.
Właściwości obiektów wymiarów
Wymiary mają szereg opcji konfiguracji, które umożliwiają szerokie dostosowanie strzałek i tekstu. Otwórz panel Properties dla jednego lub kilku zaznaczonych obiektów wymiarów, aby edytować ich właściwości.
| Właściwość | Dotyczy obiektów | Opis |
|---|---|---|
Styl |
||
| Width | Wszystkie z wyjątkiem znaczników środka i wymiarów współrzędnościowych | Bieżąca szerokość linii wymiarowej. |
| Width (w sekcji Extension Line) | Wymiar kątowy Wymiar od bazy Wymiar liniowy Liniowy wymiar średnicy Wymiar współrzędnościowy |
Bieżąca szerokość pomocniczych linii wymiarowych. |
| Gap | Wymiar kątowy Wymiar od bazy Wymiar z odnośnikiem Wymiar liniowy Liniowy wymiar średnicy Wymiar współrzędnościowy |
|
| Offset | Wymiar kątowy Wymiar od bazy Wymiar liniowy Liniowy wymiar średnicy |
Bieżące przesunięcie linii strzałki względem pomocniczej linii wymiarowej. |
| Text Gap | Wszystkie z wyjątkiem znaczników środka i wymiarów standardowych |
|
| Leader Shape | Wymiar z linią odniesienia | Użyj listy rozwijanej, aby określić kształt otaczający tekst wymiarowy. Dostępne opcje to Automatic, Round i Square. Jeśli wybrano Round lub Square, wprowadź żądaną wartość Size. |
| Arrow Style | Wymiar z linią odniesienia | Użyj listy rozwijanej, aby wybrać żądany styl linii odniesienia. Dostępne opcje to Arrow lub Dot. Wprowadź żądaną wartość Size. |
| Height | Wymiar standardowy | Bieżąca wysokość pomocniczej linii wymiarowej. |
| Arrow Size | Wymiar kątowy Wymiar od bazy Wymiar liniowy Liniowy wymiar średnicy Wymiar promienia Promieniowy wymiar średnicy |
Bieżący rozmiar grotu strzałki. Rozmiar jest mierzony jako odległość między wierzchołkiem strzałki a końcem jej ramion. |
| Arrow Length | Wymiar kątowy Wymiar od bazy Wymiar liniowy Liniowy wymiar średnicy Wymiar promienia Promieniowy wymiar średnicy |
Bieżąca długość strzałki. Pamiętaj, że wartość wprowadzona w tym polu jest stosowana tylko wtedy, gdy opcja Arrow Position (w sekcji Properties ) jest ustawiona na Outside. |
Właściwości |
||
| Text | Wymiar z linią odniesienia | Wprowadź żądany tekst. |
| Layer | Wszystkie | Warstwa, do której wymiar jest obecnie przypisany. Użyj listy rozwijanej, aby wybrać żądaną warstwę. Wymiary można przypisywać do dowolnej dostępnej warstwy. |
| Text Position | Wszystkie z wyjątkiem wymiarów środka i standardowych | Bieżące położenie tekstu wymiarowego. Użyj powiązanej listy rozwijanej, aby wybrać jedną z poniższych opcji (zestaw dostępnych opcji zależy od typu obiektu wymiarowego):
|
| Arrow Position | Wymiar kątowy Wymiar od bazy Wymiar liniowy Liniowy wymiar średnicy Wymiar promienia Promieniowy wymiar średnicy |
Bieżące położenie strzałek wymiarowych. Dostępne opcje:
|
| Angular Step | Promieniowy wymiar średnicy | Bieżące ustawienie kroku kątowego wymiaru. Jest to krok obrotu stosowany podczas umieszczania części wymiaru ze strzałką. Podczas przesuwania strzałki wokół okręgu lub łuku w trakcie umieszczania wymiaru liczba i położenie możliwych punktów zakotwiczenia wymiaru są określane przez tę wartość kroku kątowego. |
| Text Height | Wszystkie z wyjątkiem wymiaru środka | Bieżąca wysokość znaków tekstu wymiarowego. Szerokość znaków używana do wyświetlania lub drukowania tekstu jest automatycznie dobierana proporcjonalnie do tej wysokości. Minimalna wysokość 36mil (0.9mm) umożliwia czytelne odwzorowanie tekstu na fotoploterze. |
| Rotation | Wymiar środka Wymiar liniowy Liniowy wymiar średnicy Wymiar współrzędnościowy |
Kąt ustawienia wymiaru, mierzony w stopniach przeciwnie do ruchu wskazówek zegara względem poziomu. |
| Size | Wymiar środka | Bieżąca długość linii krzyża wymiarowego (lub średnica otaczającego go okręgu). |
| Font Type | Wszystkie z wyjątkiem wymiaru środka |
|
Jednostki |
||
| Primary Units | Wymiar kątowy Wymiar od bazy Wymiar liniowy Liniowy wymiar średnicy Wymiar współrzędnościowy Wymiar promienia Promieniowy wymiar średnicy |
Aktualnie wybrana jednostka używana do obliczania i wyświetlania wartości wymiaru.
|
| Value Precision | Wymiar kątowy Wymiar od bazy Wymiar liniowy Liniowy wymiar średnicy Wymiar współrzędnościowy Wymiar promienia Promieniowy wymiar średnicy |
Bieżące ustawienie liczby miejsc po przecinku, z jaką będzie wyświetlana wartość wymiaru. |
Wartość |
||
| Format | Wszystkie z wyjątkiem oznaczeń środka i linii odniesienia |
Bieżące ustawienie formatu tekstu wymiarowego. Użyj powiązanej listy rozwijanej, aby zmienić format zgodnie z potrzebami. Dostępne opcje zależą od wybranego ustawienia Unit i są prezentowane na podstawie rzeczywistej wartości bieżącego wymiaru. Ogólnie dostępne są następujące opcje (ich zestaw zależy od typu obiektu wymiarowego):
|
| Prefix | Wymiar kątowy Wymiar od bazy Wymiar liniowy Liniowy wymiar średnicy Wymiar współrzędnościowy Wymiar promienia Promieniowy wymiar średnicy |
Przedrostek wartości wymiaru. W przypadku liniowego lub promieniowego wymiaru średnicy pole to zawiera stały znak ø. |
| Suffix | Wymiar kątowy Wymiar od bazy Wymiar liniowy Liniowy wymiar średnicy Wymiar współrzędnościowy Wymiar promienia Promieniowy wymiar średnicy |
Przyrostek wartości wymiaru. |
| Sample | Wszystkie z wyjątkiem oznaczeń środka i linii odniesienia |
To pole przedstawia przykład wyglądu tekstu wymiarowego zgodnie z określonym ustawieniem Format oraz zdefiniowanymi elementami Prefix i/lub Suffix. |
| Start point (X/Y) | Wymiar standardowy | Punkt początkowy wymiaru: współrzędna X (pierwsza wartość) i Y (druga wartość). |
| End point (X/Y) | Wymiar standardowy | Punkt końcowy wymiaru: współrzędna X (pierwsza wartość) i Y (druga wartość). |
Konwertowanie wymiarów na obiekty podstawowe
Wymiary są grupowymi obiektami projektowymi, tzn. składają się z co najmniej jednego obiektu tekstowego i odcinków ścieżek. Wymiar można przekształcić w składowe obiekty podstawowe za pomocą polecenia Tools » Convert » Explode Dimension to Free Primitives.


