Altium Designer Documentation

Additional Options for a Project in Altium Designer

Created: 10.01.2022 | Updated: 10.01.2022

Вкладка Options диалогового окна Project Options
Вкладка Options диалогового окна Project Options

Общая информация

Эта вкладка диалогового окна Project Options позволяет определить расположение выходных файлов, а так же содержит опции связанные с созданием выходных файлов проекта. Вы так же можете настроить параметры списка цепей (Netlist Options) и области действия идентификатора цепей (Net Identifier Scope).

Доступ

Это одна из множества доступных при настройке свойств проекта вкладок, доступ к которой можно получить из диалогового окна Project Options. Для доступа к диалоговому окну:

  • Перейдите в раздел Project » Project Options в редакторе схемы или печатной платы.
  • Нажмите ПКМ на названии проекта на панели Projects затем выберите Project Options из контекстного меню.

Настройки/Управление

  • Output Path – выбранный по умолчанию путь, для сохранения созданных выходных файлов текущего проекта (*.PrjPcb).
  • ECO Log Path – выбранный по умолчанию путь, для файлов ECO.
  • Schematic Template Location – используйте это поле для настройки директории в которой будут храниться файлы шаблонов документов схем для вашего проекта(*.SchDot, *.SchDoc).
Используйте иконку Browse в правой части каждой из областей упомянутых выше, для поиска и выбора различных путей/расположений.

Настройки выходных файлов (Outputs)

  • Open outputs after compile – включите, чтобы открывать созданные файлы после компиляции дизайн проекта.
  • Timestamp folder – включите для создания папки с временной отметкой для созданных выходных файлов, таких как отчет BOM (Reports » Bill of Materials). Папка будет названа в формате <ИмяПапки> Дата Время где <ИмяПапки> определено в поле Output Path, а Дата и Время будут заданы в формате, определенном вашей системой.
  • Archive project document – позволяет архивировать документы проекта. Например, при создании выходных файлов для производства из проекта печатной платы (File » Fabrication Outputs и File » Assembly Outputs) целевая выходная папка (Output folder) будет содержать копию файлов проекта печатной платы.
  • Use separate folder for each output type – позволяет создавать отдельные папки для каждого типа выходных файлов сгенерированных из вашего дизайн проекта. Эта структура папок так же будет отражена на панели Projects.

Настройки списка цепей (Netlist options)

  • Allow Ports to Name Nets – включите чтобы называть цепи используя свойство Name присоединенного объекта Port, вместо использования имени по умолчанию, сгенерированного системой.
  • Allow Sheet Entries to Name Nets – включите чтобы называть цепи используя название входа в лист (sheet entry) вместо использования имени по умолчанию, сгенерированного системой.
  • Allow Single Pin Nets – включите чтобы разрешить существование цепей с единственным выводом.
  • Append Sheet Numbers to Local Net – позволяет распространять значение параметра листа схемы Sheet Number (параметр уровня документа) на локальные цепи листа. Локальные цепи это цепи которые полностью содержатся на одном листе. Для цепей которые покидают пределы листа (таким образом переставая быть локальными), эта опция не применяется.

    Если опция Net Identifier Scope установлена в занчение Global, тогда все цепи с одинаковым именем (Net label) будут соединены вместе на всех листах. Поскольку эти сети не локальные, опция Append Sheet Numbers to Local Net не применяется.
    Опция Append Sheet Numbers to Local Nets будет работать только если каждому листу схемы был присвоен уникальный SheetNumber. Параметр SheetNumber присваивается на вкладке Parameters панели Properties в режиме Document Options для каждого листа схемы. В качестве альтернативы ручному присвоению уникального номера каждому листу схемы, можно использовать команду Number Schematic Sheets, которая откроет диалоговое окно Sheet Numbering for Project. Это можно использовать для присвоения уникальных SheetNumbers (простое числовое значение для каждого листа схемы) и DocumentNumbers (обычно используется для нумерации документов согласно политике компании) для всех листов.
  • Higher Level Names Take Priority – включите для использования имен цепей (Net labels), листов расположенных выше по иерархии для именования цепей на листах ниже по иерархии.
  • Power Port Names Take Priority – программное обеспечение имеет возможность локализовать глобальную цепь питания, подключив порт питания к обычному порту. Это заставит все контакты на этом листе, подключенные к этому порту питания, быть в отдельной цепи. Включение этой опции приведет к принудительному именованию цепи с использованием имени цепи, назначенной порту питания.

    Если включена только опция Higher Level Names Take Priority, порядок именования согласно приоритетам будет следующим: Net labels, power ports, ports, pins. Однако, если так же включена опция Power Port Names Take Priority, тогда порядок именования согласно приоритетам изменится и будет следующим Power ports, net labels, ports, pins.

Область действия идентификатора цепей

Проекты на нескольких листах, на электрическом уровне (или уровне соединений) определяются идентификаторами цепей (Net Identifiers). Идентификаторы цепей ( имена цепей, порты, входы в лист, порты питания, и скрытые контакты) формируют логические соединения между точками одной цепи. Это может происходить на одном или на нескольких листах. Физические соединения создаются, когда один объект напрямую соединен с другим с помощью проводника. Логические соединения создаются когда два идентификатора цепи одного типа (например, два Net label) имеют одинаковое свойство цепи (Net property).

Когда создана модель соединений проекта, вы должны определить как будут связаны друг с другом идентификаторы цепей – эта связь определяется настройкой Net Identifier Scope. Существует два способа соединения листов в многолистовом проекте: горизонтальный, напрямую от одного листа к другому, и так далее, или вертикальный, от зависимого листа к символу листа, который представляет его на родительском листе. При горизонтальном соединении, соединения идут от порта к порту (соединение net label к net label так же возможно). При вертикальном соединении, соединения идут от входа в лист к порту.

Область действия идентификатора цепей должна быть определена в начале процесса проектирования.

Используйте выпадающий список для выбора из следующих вариантов:

  • Automatic (Based on project contents) – этот вариант автоматически выбирает какой из методов работы идентификатора цепей использовать, основываясь на следующих критериях: если на верхнем листе иерархии присутствуют входы в лист, то будет применен иерархический тип (Hierarchical); если входов в лист нет, но есть порты, тогда будет применен тип Flat; если нет ни входов в листы ни портов, то будет использован тип Global.

    Вариант Automatic используется по умолчанию, стандартный вариант Hierarchical будет использован при наличии портов питания соединенных глобально. Чтобы использовать вариант Strict Hierarchical, установите требуемое значение в поле Net Identifier Scope. Скрытые контакты всегда считаются глобальными.
  • Flat (Only ports global) – порты соединяются глобально на всех листах проекта. При включении этого режима, имена цепей будут локальными для каждого листа, т.е. они не будут соединяться между листами. Все порты с одинаковыми именами будут соединены на всех листах. Этот режим может быть использован для горизонтальных многолистовых проектов. Не рекомендуется для больших проектов, так как может быть сложно отслеживать цепи на всех листах проекта.
  • Hierarchical (Sheet entry <-> port connections, power ports global) – обеспечивает вертикальное соединение порта и соответствующего входа в лист. Этот режим реализует межлистовые соединения только при соответствии символа входа в лист и порта на зависимом листе. Он использует порты на листах чтобы провести цепи или шины цепей до соответствующего символ входа в лист на родительском листе. Порты без соответствующих входов в лист не будут присоединены даже если на другом листе существует порт с таким же именем. Имена цепей локальны для каждого листа, т.е. они не будут соединяться между листами. Однако, порты питания являются глобальными – все порты питания с одинаковыми именами в проекте будут соединяться. Этот вариант может использоваться для создания проектов любой глубины или иерархии и позволяет отслеживать цепь в проекте даже на распечатанной схеме.
  • Strict Hierarchical (Sheet entry <-> port connections, power ports local) – этот вариант подключения ведёт себя так же как и вариант Hierarchical, за исключением того что порты питания остаются локальными для каждого листа, т.е. соединения между листами не будет даже если на них будут порты с одинаковыми именами.
  • Global (Netlabels and ports global) –порты и имена цепей соединены во всем проекте. При таком варианте, все цепи с одинаковыми именами будут соединены друг с другом на всех листах проекта. Так же, все порты с одинаковыми именами будут соединены на всех листах. Если цепь присоединенная к порту так же имеет собственное имя (Net label), будет отображен Net label. Этот вариант так же можно использовать для горизонтальных многолистовых проектов, однако, однако будет тяжело отслеживать цепи от одного листа к другому так как визуально отследить имена цепей на схеме не всегда является простой задачей.
Если в проекте используются символы листов с входами в листы, параметр Net Identifier Scope должен быть установлен в положение Hierarchical или Strict Hierarchical. При этих вариантах, верхний лист иерархии должен быть соединен. Если символы листов и входы в лист не используются,  подключение может осуществляться с помощью портов (Ports) и/или наименований цепей (Net labels), таким образом, должен быть использован один из двух других вариантов идентификации цепей (Flat или Global) в зависимости от ситуации.
Помните что наименования цепей (net labels) не присоединяются к одноименным портам.

Возможность перестановки выводов (Pin-Swapping) при использовании этих вариантов

В редакторе плат, перестановка вывода (Pin), дифференциальной пары (Differential Pair) и компонента (Part)  выполняется путем изменения цепи на контактной площадке компонента и соответственно на нужном участке меди. Когда эти изменения передаются на схему, существует два способа выполнения перестановки выводов:

  • Adding / Removing Net-Labels – включите чтобы разрешить перестановку выводов на символе компонента. Выполнение перестановки в схеме путем перемещения наименований цепей (Net labels) может быть выполнено только если реализовано подключение через Net labels, т.е. если контакты жестко не присоединены друг к другу.

    Преимущество такого подхода в том, что символ компонента не меняется и может быть обновлён позднее. Этот подход является наилучшим выбором для сложных компонентов, таких как ПЛИС, так как физическое перемещение двух контактов на схемном символе может привести к некорректному определению структуры входов/выходов.
  • Changing Schematic Pins – включите чтобы разрешить перестановку наименований цепей (Net labels) на проводниках присоединенных к выводам компонента. Перестановка выводов будет единственным вариантом, доступным, когда цепи физически подключены к компоненту. Этот метод можно использовать с простыми компонентами (такими как массив резисторов) или там, где нет альтернативы из-за структуры схемы проекта.

    Перестановку выводов всегда можно выполнить на схеме, но это может означать что конкретный экземпляр символа компонента больше не соответствует экземпляру определенному в библиотеке. В такой ситуации, это значит что символ теперь нельзя обновить из библиотеки без удаления информации о перестановке выводов. Так же это значит, что другие экземпляры этого компонента в проекте будут иметь другое расположение выводов, что может стать причиной недопонимания если схему будет читать кто-то другой.

Общее (General)

  • Automatic Sheet Numbering – включите эту опцию для автоматической нумерации листов схемы в проекте. Это позволяет контролировать обозначения листов и сохранять их как параметры в соответствующих документах схемы.
  • Automatic Cross References – включите эту опцию для автоматического добавление информации о перекрестных ссылках порта, межлистового перехода и входа в лист, во все исходные документы схем в активном проекте. Эта опция позволяет отслеживать соединение цепей в неиерархическом проекте.

    Значения перекрестных ссылок (Cross Reference) отображаются на панели Properties для портов (Ports), межлистовых соединителей (Off Sheet Connectors), и входов в лист (Sheet Entries), упрощая задачу идентификации перекрестной ссылки (Cross Reference) которая применена к порту или межлистовому соединителю.

Перекрестные ссылки

  • Sheet Style – выберите один из перечисленных стилей листа для реализации перекрестных ссылок портов на листе схемы или листах схемы в проекте.
    • None – стиль листа не был добавлен в строку Cross reference всех портов.
    • Name – имена листов с которыми связаны порты были добавлены в строки Cross reference.
    • Number – номера листов с которыми связаны порты были добавлены в строки Cross reference.
  • Location Style – выберите один из перечисленных стилей расположения перекрестных ссылок портов на листе схемы или листах схемы в проекте.
    • None – стиль расположения не был добавлен в строки Cross reference всех портов.
    • Zone – нумерация ссылочных зон на листе (на границах листа схемы имеются зоны) была добавлена в строки Cross reference всех портов которые связаны с родительскими объектами такими как расположение символов листа.
    • Location X,Y – расположения портов публикуются в скобках в строках Cross reference всех портов которые связаны с родительскими объектами такими как расположение символов листа.
  • Follow Cross References settings in Preferences – при включении этой опции, значения опций Sheet Style и Location Style будут унаследованы из опций в области Port Cross References страницы Schematic – General диалогового окна Preferences.
  • Display Cross References for:
    • Ports – используйте выпадающее меню для выбора режима отображения перекрестных ссылок портов.
      • Disabled – перекрестные ссылки не добавлены к портам.
      • Only Related Sheet Entry – отображать перекрестные ссылки на связанные входы в лист на родительском листе схемы.
      • Only Related Ports – отображать перекрестные ссылки на связанные порты.
      • Sheet Entry & Ports – отображать перекрестные ссылки и на входы в лист, и на порты.
    • Off-sheet Connectors – включите данную опцию для отображения перекрестных ссылок для объектов межлистовых соединителей.
    • Sheet Entries – включите данную опцию для отображения перекрестных ссылок для объектов входа в лист.

Дополнительная опция

  • Set To Installation Defaults – нажмите чтобы вернуться к настройкам по умолчанию.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: