ActiveRoute
Num relance
- Entenda como o ActiveRoute se diferencia de um roteador automático e por que ele é mais adequado para o roteamento guiado e de alta qualidade de redes selecionadas.
- Conheça os principais recursos do ActiveRoute, incluindo guias de roteamento, roteamento em múltiplas camadas, otimização do traçado, ajuste de comprimentos, controle de serpentinas e troca de pinos.
- Veja como usar o painel PCB ActiveRoute para configurar e executar o ActiveRoute com base nas regras do seu projeto e nos seus objetivos de roteamento.
Uma das fases mais demoradas do projeto de placas é o roteamento das redes. Embora o sistema de regras gerencie as restrições do projeto, como larguras, tamanhos de vias, folgas e assim por diante, cabe ao projetista posicionar os milhares de segmentos de trilha necessários para rotear completamente uma placa.
Os roteadores automáticos podem facilitar essa tarefa, mas geralmente são considerados inadequados porque:
-
Não conseguem considerar corretamente a infinidade de restrições sutis de projeto que um projetista aplica instintivamente durante o roteamento.
-
Sua configuração completa leva tanto tempo que, muitas vezes, é mais eficiente simplesmente rotear a placa interativamente.
-
A limpeza do roteamento pode ser um processo tão longo e difícil que, muitas vezes, é mais eficiente rotear a placa interativamente.
O objetivo máximo do roteamento de PCBs é produzir rapidamente resultados de alta qualidade que atendam às regras de projeto, sob o controle do projetista. Esse é o desafio que o ActiveRoute se propõe a superar.
O que é o ActiveRoute?
O ActiveRoute é uma tecnologia de roteamento interativo automatizado que oferece algoritmos eficientes para o roteamento de múltiplas redes e é aplicada às redes ou conexões específicas que você seleciona. O ActiveRoute também permite que o projetista defina interativamente um caminho de roteamento ou uma guia, que então define the river por onde passarão as novas rotas.
Os principais recursos do ActiveRoute que tornam essa abordagem significativamente melhor do que uma combinação de roteamento interativo convencional e roteamento automático incluem:
- Otimização automática das rotas de escape de matrizes de pinos/vias — o aspecto mais demorado do roteamento manual.
- Alto desempenho — redes de sinal roteadas em < 1 segundo cada.
- Respeita as regras de projeto de largura, folga, camadas, topologia e regiões por rede e classe de redes, observando as prioridades.
- Roteia em várias camadas simultaneamente e distribui as rotas entre elas.
- Uma guia de roteamento intuitiva que o projetista pode usar para orientar o posicionamento das rotas.
- Usa uma abordagem de roteamento em feixe para proporcionar altas taxas de conclusão sem a necessidade de vias.
- Permite rotear através de planos poligonais e recalcular seu preenchimento (se a opção de recalcular o preenchimento estiver ativada).
- Oferece suporte tanto a redes de sinais single-ended quanto a pares diferenciais.
- Finaliza com uma poderosa ferramenta de suavização que reduz ainda mais o número de cantos e encurta o roteamento.
O painel PCB ActiveRoute
O ActiveRoute segue os critérios e as restrições definidos pelas regras de projeto da PCB, portanto, para usá-lo, basta selecionar as conexões ou redes de interesse e executá-lo. Ele possui vários recursos de controle específicos que são configurados no painel PCB ActiveRoute. O painel PCB ActiveRoute é usado para configurar e operar os diversos recursos oferecidos pelo ActiveRoute, incluindo: executar um ActiveRoute interativo; definir uma guia de roteamento e o espaçamento das rotas dentro dela; habilitar o ajuste automático de comprimento; e habilitar a troca automática de pinos. É altamente recomendável abrir o painel PCB ActiveRoute antes de iniciar o ActiveRoute.
Para abrir o painel PCB ActiveRoute, quando uma PCB for o documento ativo:
-
Clique no botão
no canto inferior direito da área de trabalho e, em seguida, selecione a opção de menu PCB ActiveRoute.
-
Clique em View » Panels » PCB ActiveRoute.
Use o painel PCB ActiveRoute para controlar o processo do ActiveRoute.
O painel PCB ActiveRoute é usado para:
- Habilitar as camadas de sinal nas quais o ActiveRoute pode rotear conexões.
- Executar o ActiveRoute nas conexões selecionadas.
- Habilitar uma etapa de Glossing após o ActiveRoute.
-
Definir uma guia de roteamento.
- Configurar o espaçamento entre trilhas que você deseja usar dentro da guia de roteamento.
- Configurar e habilitar o ajuste de comprimento das rotas criadas pelo ActiveRoute.
- Configurar a opção Meander, permitindo que o ActiveRoute defina um caminho de roteamento mais longo, o que pode ajudar a aumentar a taxa de conclusão.
- Configurar e habilitar a troca de pinos. O ActiveRoute pode trocar pinos durante o roteamento para ajudar a melhorar sua qualidade.
O conteúdo do painel PCB ActiveRoute é organizado em seções recolhíveis, que são abertas e fechadas usando o ícone ► associado ao título de cada seção. As informações sobre os controles de propriedades incluídas abaixo são organizadas em seções correspondentes, e cada seção recolhível é aberta/fechada da mesma maneira.
Ação
Estas são as principais opções usadas para controlar o ActiveRoute.
-
ActiveRoute - clique no botão
no painel para executar o ActiveRoute nas conexões selecionadas. O ActiveRoute tenta rotear as conexões selecionadas ou, se pads ou vias estiverem selecionados, todas as conexões dessas redes. Consulte a página do ActiveRoute para saber mais sobre Técnicas de seleção.
-
Route Guide - uma guia de roteamento é um caminho definido pelo usuário dentro do qual as conexões selecionadas devem ser roteadas pelo ActiveRoute. Um dos principais objetivos do ActiveRoute é encontrar o conjunto de rotas com o menor comprimento total, o que pode não ser o caminho desejado para todos os conjuntos de conexões. A guia de roteamento oferece ao projetista uma ferramenta para traçar um caminho específico que ele deseja que as conexões selecionadas sigam. A cor da guia de roteamento é determinada pelas camadas disponibilizadas para o roteamento das conexões selecionadas pelo ActiveRoute — se houver apenas uma camada habilitada, ela será desenhada na cor dessa camada; se houver várias camadas habilitadas, ela será desenhada na cor padrão da guia de roteamento.
-
Para definir uma guia de roteamento, primeiro selecione as conexões que devem ser roteadas dentro da guia e clique em
botão no painel, depois clique para definir o local de início da guia e continue movendo o mouse e clicando para definir o caminho. Quando o caminho estiver definido, clique no botão ActiveRoute para rotear as conexões selecionadas ao longo desse caminho.
-
Durante o posicionamento da guia de roteamento, é possível aumentar ou diminuir sua largura pressionando as teclas
ou
. A largura padrão é a soma das regras de projeto de largura+folga aplicáveis às conexões selecionadas, dividida pelo número de camadas e multiplicada por 1,3. Pressione a tecla Backspace para desfazer o traçado da guia se precisar definir um caminho diferente.
- O ActiveRoute tentará espaçar as trilhas de acordo com as regras de projeto; ele não tenta distribuí-las por todo o espaço disponível em uma guia de roteamento. Para distribuir as trilhas dentro de uma guia de roteamento, use o recurso Espaçamento entre trilhas na guia de roteamento, conforme descrito mais adiante nesta página.
-
Para definir uma guia de roteamento, primeiro selecione as conexões que devem ser roteadas dentro da guia e clique em
-
Tune Selected - quando esta opção está habilitada, aplica-se a regra de comprimentos correspondentes de maior prioridade que seja aplicável e esteja habilitada na seção Ajuste do painel.
-
Pin Swap Routing – a troca de pinos é compatível com o editor de PCB. Habilite esta opção para permitir que o ActiveRoute realize trocas de pinos durante o processo de roteamento. Além de habilitar esta opção, os componentes necessários também devem ser habilitados na seção Pin Swap do painel, conforme descrito abaixo. Para saber mais sobre o sistema de troca de pinos, consulte a página Troca de pinos, pares e partes.
-
Gloss Results – habilite esta opção para otimizar automaticamente os resultados do ActiveRoute. A otimização também pode ser aplicada a trilhas existentes selecionadas; para isso, execute o comando Route » Gloss Selected (Ctrl+Alt+G). Consulte a página Otimização e retraçado de trilhas existentes para saber mais.
Camadas
O ActiveRoute pode rotear em várias camadas simultaneamente. Embora não possa inserir vias para realizar uma mudança de camada, ele pode distribuir conexões e redes entre as camadas disponíveis. As camadas disponíveis são configuradas na seção Camadas do painel.
- Show Signal Layers Only – por padrão, todas as camadas de sinal e de plano disponíveis são exibidas. Habilite esta opção para exibir apenas as camadas de sinal.
- List of Layers – habilite as camadas de sinal nas quais o ActiveRoute pode rotear sinais. O ActiveRoute distribuirá as conexões entre as camadas de sinal disponíveis. Observe que o ActiveRoute não insere vias para realizar uma mudança de camada.
Controle
Estes controles são usados para flexibilizar o foco do ActiveRoute no espaçamento das trilhas para atender à regra de projeto de folga aplicável e para permitir que ele use um caminho menos direto para concluir uma conexão.
- Track-Track Space in Route Guide – este controle é usado para informar ao ActiveRoute a distância que ele deve tentar manter entre as conexões roteadas ao longo da guia de roteamento (do centro de uma trilha ao centro da outra). Essa configuração deve ser feita antes de definir a guia de roteamento, para que a largura da guia possa ser calculada corretamente de acordo com o espaçamento. Use o controle deslizante para selecionar um valor ou digite uma distância no campo de edição.
-
Meander % Over Manhattan Length – o ActiveRoute tenta rotear as conexões selecionadas pelo caminho mais curto possível, ou seja, usando o mínimo de sinuosidade. Se a taxa de conclusão do ActiveRoute for menor que a esperada, aumentar a sinuosidade permitida pode ajudar a elevar essa taxa. A configuração máxima padrão de Sinuosidade é 100%, o que significa que as trilhas podem ter um comprimento total de
Manhattan Length + 100% of Manhattan Length. Use o controle deslizante para selecionar um valor ou digite uma porcentagem no campo de edição. Observe que a configuração de sinuosidade é ignorada ao usar a guia de roteamento, pois ela se destina a definir um caminho que pode aumentar significativamente a sinuosidade.
Ajuste
O ActiveRoute pode aplicar o ajuste de comprimento às conexões que estão sendo roteadas ou às trilhas existentes selecionadas.
-
Match Length Rules for Selected – todas as regras de projeto de comprimentos correspondentes definidas são listadas aqui. Habilite a regra a ser usada pelo ActiveRoute para as conexões selecionadas.
-
Single Ended – propriedades da serpentina de ajuste a ser usada para ajustar sinais de terminação única.
- Max Amplitude - amplitude máxima permitida da serpentina de ajuste. A amplitude é reduzida automaticamente quando há obstáculos, como pads, vias ou trilhas existentes, para garantir que as folgas das regras de projeto sejam mantidas.
- Min Space - espaçamento mínimo entre bordas nos cruzamentos por zero da serpentina.
-
Differential Pair - propriedades da serpentina de ajuste a ser usada para ajustar pares diferenciais.
- Max Amplitude - amplitude máxima permitida da serpentina de ajuste para o membro externo do par diferencial. A amplitude é reduzida automaticamente quando há obstáculos ao posicionamento, para garantir que as folgas das regras de projeto sejam mantidas.
- Min Space - espaçamento mínimo entre bordas nos cruzamentos por zero da serpentina para o membro interno do par diferencial.
Troca de pinos
Pinos funcionalmente equivalentes em um componente podem ser configurados para permitir a troca entre si. Selecione o comando Tools » Pin/Part Swapping » Configure para fazer isso. Antes que qualquer troca de pinos possa ser realizada (interativamente ou pelo ActiveRoute), o projeto deve ser compilado (menu Project) sempre que for aberto.
- Components with Pin Swap Enabled – todos os componentes habilitados para troca de pinos serão listados aqui. Habilite aqueles que você deseja disponibilizar para troca automática durante uma execução do ActiveRoute.
Recursos adicionais do ActiveRoute
O ActiveRoute é um roteador interativo automatizado, e seu uso é simples e direto: selecione as conexões e pressione Shift+A para roteá-las com o ActiveRoute de acordo com as regras de projeto. O ActiveRoute inclui vários outros recursos e controles, oferecendo ao projetista maior controle sobre determinadas funcionalidades e capacidades.
Entre eles:
- Definir o caminho de roteamento e o espaçamento entre trilhas posicionando uma guia de roteamento.
- Permitir um caminho de roteamento mais longo com o controle de Sinuosidade.
- Igualar automaticamente os comprimentos das trilhas com o ajuste de comprimento.
- Permitir a troca de pinos para simplificar o desafio de roteamento.
Vamos examinar cada um deles com mais detalhes.
Defina o caminho com a guia de roteamento
Um dos principais objetivos do ActiveRoute é encontrar o conjunto de trilhas com o menor comprimento total, o que pode não representar o caminho desejado para todos os conjuntos de conexões. A guia de roteamento oferece ao projetista uma ferramenta para traçar um caminho específico pelo qual deseja que as conexões selecionadas passem, mesmo que esse caminho não seja o mais curto.
-
Defining the Route Guide - primeiro, selecione as conexões que devem ser roteadas dentro da guia e clique em
botão no painel PCB ActiveRoute, depois clique para definir o local inicial da guia e continue movendo o mouse e clicando para definir o caminho. Depois de definir o caminho, clique no botão ActiveRoute para rotear as conexões selecionadas ao longo desse caminho. Consulte a seção Definir uma guia de roteamento mais adiante nesta página para obter mais detalhes.
-
Changing the Route Guide Width - durante o posicionamento da guia de roteamento, é possível aumentar ou diminuir sua largura pressionando as teclas
ou
. A largura padrão é a soma das regras de projeto de largura + folga aplicáveis às conexões selecionadas, dividida pelo número de camadas e multiplicada por 1,3. Pressione a tecla Backspace para desfazer os trechos da guia se precisar definir um caminho diferente.
- The Route Guide color - determinada pelas camadas disponibilizadas para o ActiveRoute das conexões selecionadas. Se houver apenas uma camada habilitada, a guia será desenhada na cor dessa camada; se houver várias camadas habilitadas, ela será desenhada na cor padrão da guia de roteamento.
- The track spacing within the Route Guide - o comportamento padrão do ActiveRoute é espaçar as trilhas de acordo com as regras de projeto, sem tentar distribuí-las ou usar todo o espaço disponível dentro de uma guia de roteamento. Para distribuir as trilhas dentro de uma guia de roteamento, use o recurso Espaçamento entre trilhas na guia de roteamento, conforme descrito mais adiante nesta página.

Um vídeo mostrando o posicionamento de uma guia de roteamento, com a largura sendo alterada interativamente durante o posicionamento.
Espaçamento entre trilhas dentro da guia de roteamento
Usando o recurso Espaçamento entre trilhas na guia de roteamento, você pode instruir o ActiveRoute a distribuir as trilhas ao longo da largura da guia de roteamento. Use o controle deslizante para selecionar um valor de espaçamento ou digite um valor na caixa de edição. A guia de roteamento será dimensionada automaticamente para levar essa configuração em consideração. Para isso, você deve configurar a opção Track-Track Space in Route Guide antes de posicionar a guia de roteamento. Você também pode ajustar a largura da guia de roteamento durante o posicionamento pressionando as teclas
e
.

Use o recurso Espaçamento entre trilhas para distribuir as trilhas na guia de roteamento.
Permitir desvios nas trilhas
O ActiveRoute tenta rotear as conexões selecionadas pelo caminho mais curto possível, ou seja, com o mínimo de desvios. Se a taxa de conclusão do ActiveRoute for menor que a esperada, o controle de desvios permite aumentar a quantidade de desvios permitida ao ActiveRoute, o que pode ajudar a elevar a taxa de conclusão. A configuração máxima padrão de desvios é de 100%, o que significa que as trilhas podem ter um comprimento total de Manhattan Length + 100% of Manhattan Length. Use o controle deslizante para selecionar um valor de desvio ou digite uma porcentagem na caixa de edição.
Observe que a configuração de desvios é ignorada quando a guia de roteamento é usada porque a finalidade da guia de roteamento é definir um caminho que pode aumentar significativamente os desvios.
Ajuste dos comprimentos das trilhas
O ActiveRoute pode aplicar o ajuste de comprimento às conexões que estão sendo roteadas ou às trilhas existentes selecionadas. O ActiveRoute tentará atender à regra de projeto de comprimentos correspondentes selecionada.
Para configurar o ActiveRoute para ajustar comprimentos:
-
Marque a caixa de seleção Tune Selected na região Action do painel.
-
Habilite a regra de projeto de comprimentos correspondentes necessária na região Tune do painel.
-
Defina as configurações Max Amplitude e Min Space necessárias (sinal simples ou par diferencial) na região Tune do painel.
Troca de pinos
O software inclui um poderoso sistema de troca de pinos e partes, com integração entre os editores de esquemático e de PCB. O ActiveRoute pode acessar as configurações de troca de pinos e trocar pinos durante o roteamento se isso reduzir o comprimento total das trilhas e melhorar a qualidade do roteamento.
Para usar a troca de pinos:
- Antes de realizar qualquer troca de pinos (interativamente ou pelo ActiveRoute), o projeto deve ser compilado (menu Project) sempre que for aberto.
- Para configurar e gerenciar as configurações de troca de pinos dos componentes, execute o comando Tools » Pin/Part Swapping » Configure para abrir a caixa de diálogo Configure Swapping Information in Components.
- Habilite a opção Pin Swap Routing na região Action do painel PCB ActiveRoute.
- Habilite os componentes necessários na região Pin Swap do painel PCB ActiveRoute.
Preparação para usar o ActiveRoute
1. Criar classes de nets
O ActiveRoute exige que as nets sejam selecionadas. Ter classes de nets pode ajudar bastante no processo de seleção quando há um grande número de nets a serem roteadas pelo ActiveRoute. Consulte a seção Técnicas de seleção mais adiante neste artigo para saber mais sobre as melhores maneiras de selecionar conexões.
2. Oculte temporariamente os polígonos existentes
O ActiveRoute pode rotear através de polígonos existentes se a opção Repour Polygons after Modification estiver habilitada na página Editor de PCB - Geral da caixa de diálogo Preferences. Como alternativa, os polígonos podem ser ocultados temporariamente (ficam invisíveis, mas são mantidos no projeto) usando o comando Tools » Polygon Pours » Shelve Polygons.
3. Configure as regras de projeto
- Folgas – O ActiveRoute respeita as regras de projeto de folga aplicáveis, aplicando-as em ordem de prioridade.
- Larguras de roteamento – Ele usa a configuração Preferred das regras de largura aplicáveis. Assim como no roteamento interativo, para alterar as larguras em uma área, por exemplo, quando o roteamento passa sob um BGA, defina uma Room que aplique uma regra de projeto de largura com uma largura preferencial menor. Se você não conseguir rotear manualmente com a largura preferencial, o ActiveRoute também não conseguirá.
- Pares diferenciais – O ActiveRoute pode rotear pares diferenciais. Certifique-se de que os pares diferenciais estejam definidos corretamente (verifique no modo Editor de pares diferenciais do painel PCB) e confirme se as regras de roteamento de pares diferenciais estão configuradas corretamente (são usados os valores Preferred).
- Entrada no pad – O ActiveRoute tenta usar o caminho mais direto de entrada/saída de um pad que respeite as regras sem criar ângulos agudos. Ele respeita as regras SMT até o canto e Entrada em pad SMT, mas nem sempre centraliza a trilha no pad (como faz o roteador interativo quando a regra SMT até o canto está habilitada). Ele inclui algoritmos especiais para pads de pares diferenciais, com foco no acoplamento do par, mantendo a organização.
4. Configure a topologia das nets
O ActiveRoute seguirá o padrão das linhas de conexão. Se você tiver um conjunto de nets que exija uma topologia específica, por exemplo, uma topologia fly-by DDR3/4, poderá definir a ordem de origem e destino usando xSignals. O Assistente xSignals Multi-Chip (Design » xSignals » Run xSignals Wizard) pode criar xSignals para projetos que incluam sinalização do tipo DDR3/4 e USB 3.0. Como alternativa, padrões de linhas de conexão ponto a ponto podem ser definidos para uma net criando From-Tos no modo Editor From-To do painel PCB.
5. Crie os fanouts do projeto
O ActiveRoute não insere vias, portanto, você deve criar fanouts para BGAs, conectores e componentes discretos que usem pinos SMT (exceto para os pinos que serão roteados nas camadas externas).
6. Roteie a alimentação e o terra
O ActiveRoute é destinado a nets de sinal; ele ignora nets atribuídas a planos de alimentação e nets que contenham mais de 20 pinos (estas são consideradas nets de alimentação). Se quiser usar o ActiveRoute em um projeto já concluído, exclua o roteamento dos sinais, mas mantenha o roteamento de alimentação e terra e os fanouts.
7. Habilite as camadas de roteamento necessárias
Habilite as camadas de roteamento necessárias no painel PCB ActiveRoute. Mais informações sobre isso abaixo.
Executando o ActiveRoute
Para executar o ActiveRoute:
1. Selecione as conexões a serem roteadas
Usando as técnicas descritas na página Estratégias para selecionar o roteamento, selecione as conexões/nets a serem roteadas. As conexões podem ser selecionadas diretamente ou selecionando um objeto de roteamento, como um pino, uma trilha, uma via ou um componente. A barra de status exibirá o número de conexões que acabaram de ser selecionadas até que o cursor passe sobre outro objeto.
- Quando conexões são selecionadas, elas são roteadas com a largura preferencial definida na regra de projeto de largura de roteamento aplicável.
- Quando um roteamento existente é selecionado, a conexão ligada à trilha selecionada é roteada usando a largura dessa trilha.
- Quando pads de componentes são selecionados, todas as conexões dos pads selecionados são roteadas com a configuração preferencial da regra.
2. Habilite as camadas para o roteamento com o ActiveRoute
No painel PCB ActiveRoute, habilite as camadas nas quais as conexões selecionadas devem ser roteadas. O ActiveRoute distribuirá o roteamento entre essas camadas.
Se nenhuma camada for selecionada, ele fará o roteamento na camada ativa, que corresponde à aba selecionada na parte inferior da janela principal do editor de PCB.
O painel PCB ActiveRoute permite selecionar as camadas nas quais rotear, criar uma guia de roteamento e iniciar o ActiveRoute.
3. Defina uma guia de roteamento, se necessário
Para inserir uma guia de roteamento:
- Selecione as conexões que deseja rotear ao longo da guia de roteamento. A barra de status exibirá o número de conexões que acabaram de ser selecionadas até que o cursor passe sobre outro objeto.
- Clique no botão Route Guide no painel PCB ActiveRoute.
- O cursor parecerá estar holding todas as conexões selecionadas, indicando que esse conjunto de conexões deve passar pela guia. Mova o cursor para um local inicial adequado, em qualquer uma das extremidades do caminho que deseja definir.
- Clique para definir o local inicial da guia, deixando espaço para que as conexões de entrada cheguem à extremidade curva da guia.
- A guia é inserida como se fosse uma trilha muito larga. Mova o cursor até o local do primeiro canto que a guia deve fazer e clique para definir esse canto.
- Continue esse processo de definição do caminho, parando a alguma distância de onde as linhas de conexão terminam, deixando espaço para que as conexões saiam da guia em direção aos seus pads/vias/extremidades de trilhas de destino.
- Pressione a tecla Up Arrow para alargar a guia ou a tecla Down Arrow para estreitá-la.
- Pressione Backspace para remover o último canto da guia.
- Clique com o botão direito para sair do modo de inserção da guia.
Apenas um guia de roteamento pode ser definido por vez.
4. Execute o ActiveRoute
Para executar o ActiveRoute, você pode:
- Selecionar o comando Route » ActiveRoute.
-
Clicar no botão ActiveRoute (
) em Active Bar.
- Clicar no botão ActiveRoute no painel PCB ActiveRoute.
- Usar o atalho Shift+A.
5. Monitore o progresso e verifique o feedback
- A barra de status do editor de PCB mostra o progresso do ActiveRoute.
- O painel Messages informa as taxas de conclusão.
Aprimorando suas habilidades
-
Um fator essencial para dominar o ActiveRoute é adquirir fluência no uso dos atalhos. As sequências de teclas que você usará com mais frequência são:
- Alt+Click - para selecionar uma linha de conexão individual.
- Alt+Click&Drag - para selecionar conexões dentro de uma área, arraste da direita para a esquerda para selecionar todas as conexões tocadas ou da esquerda para a direita para selecionar apenas o que estiver inteiramente dentro do retângulo de seleção. Pressione Tab para ampliar a seleção e incluir outras conexões da(s) mesma(s) rede(s). A barra de status exibirá o número de conexões recém-selecionadas até que o cursor passe sobre outro objeto.
- Ctrl+Click&Drag - para selecionar pads em um componente, arraste da direita para a esquerda para selecionar todos os pads tocados ou da esquerda para a direita para selecionar apenas o que estiver inteiramente dentro do retângulo de seleção. Pressione Tab para ampliar a seleção e incluir outros objetos de roteamento da(s) mesma(s) rede(s). Continue pressionando Tab para percorrer todos os estados de seleção possíveis.
- Click&Drag - para selecionar segmentos de trilha existentes, arraste da direita para a esquerda para selecionar todas as trilhas tocadas ou da esquerda para a direita para selecionar apenas o que estiver inteiramente dentro do retângulo de seleção. Pressione Tab para ampliar a seleção e incluir outros objetos de roteamento da(s) mesma(s) rede(s). Continue pressionando Tab para percorrer todos os estados de seleção possíveis.
- Inclua Shift para manter a seleção atual ao realizar outra seleção.
- Shift+A para rotear a seleção atual com o ActiveRoute.
- Ctrl+Alt+G - para otimizar a seleção atual com o Gloss.
-
As ações de seleção são realizadas apenas em objetos visíveis (exceto para Ctrl+A):
- Pressione Shift+S para entrar no modo de camada única ou sair dele, de modo que apenas a camada de interesse seja exibida.
- Se o projeto usar regiões de posicionamento (rooms), elas poderão ser bloqueadas como parte de sua definição nas regras de projeto ou ocultadas para impedir que sejam selecionadas/movidas durante ações de clicar e arrastar. As regiões podem ser ocultadas na aba View Options do painel Configuração de visualização.
-
Crie fanouts para os pads SMD. O ActiveRoute não muda de camada, portanto, você precisará criar fanouts para os pads SMD. Para acelerar o processo de fanout:
- Ao rotear uma conexão, pressione o atalho / (teclado numérico) para inserir uma via e encerrar o roteamento dessa conexão. Use o atalho 2 se não tiver um teclado numérico (insere uma via sem interromper o roteamento).
- Copie e cole um fanout existente; o editor de PCB atualizará automaticamente os nomes das redes. Isso pode ser feito para vários fanouts.
-
Preserve os fanouts existentes. O ActiveRoute modificará os fanouts se encontrar uma solução melhor; bloqueie-os se não quiser que sejam alterados. A maneira mais fácil de bloquear fanouts é selecionar suas trilhas e vias (use Selection Filter na parte superior do painel Properties para ajudar nesse processo), pressionar F11 para abrir o painel Properties e marcar a caixa de seleção Locked. Isso bloqueará todos os objetos selecionados em uma única ação.
-
Se você usar um guia de roteamento e perceber que a taxa de conclusão está baixa, pode haver obstáculos demais ao longo do caminho, exigindo um guia mais largo. Pressione a tecla de seta Up para alargar o guia durante seu posicionamento.
-
Quando o ActiveRoute termina, ele aplica a otimização de trilhas (se estiver habilitada no painel PCB ActiveRoute). Para examinar as trilhas como estavam ao término do roteamento pelo ActiveRoute, pressione Ctrl+Z uma vez para desfazer a otimização. O comando Gloss (Route » Gloss Selected) pode ser usado para suavizar as trilhas e melhorar suas entradas nos pads em qualquer roteamento, não apenas nos realizados pelo ActiveRoute. Foi dada atenção especial à garantia de entradas de alta qualidade nos pads para pares diferenciais. Para saber mais sobre a otimização de trilhas, consulte a página Otimização e retraçado de trilhas existentes.
-
Se o ActiveRoute não funcionar, geralmente é porque as regras não estão configuradas corretamente. O motivo mais comum de falha do ActiveRoute é a falta de espaço para acomodar as trilhas. Verifique se as regras são adequadas; por exemplo, os valores das regras padrão de um novo arquivo de PCB podem ser grandes demais para um projeto de alta densidade com componentes BGA.
-
O ActiveRoute respeita as regras de roteamento configuradas para larguras, folgas e espaçamentos entre trilhas de pares diferenciais, por camada, região e classe. O ActiveRoute não roteia com arcos nem com trilhas em ângulos arbitrários.