ActiveRoute

Num relance

Este artigo explica como o ActiveRoute no Altium Designer ajuda a acelerar o roteamento de PCBs ao combinar automação com o controle do projetista, em vez de depender de um roteador automático tradicional. Ele apresenta o que o ActiveRoute é, o que ele não é, seus principais benefícios e como usar o painel PCB ActiveRoute para selecionar redes, definir guias de roteamento, escolher camadas, habilitar a otimização do traçado, o ajuste de comprimentos e a troca de pinos, além de ajustar o comportamento do roteamento. Se você quer entender melhor como obter um roteamento mais rápido, mais limpo e em conformidade com as regras, mantendo o controle do processo, este guia mostra por onde começar. Continue lendo para descobrir como o ActiveRoute pode melhorar seu fluxo de trabalho.

- Entenda como o ActiveRoute se diferencia de um roteador automático e por que ele é mais adequado para o roteamento guiado e de alta qualidade de redes selecionadas.
- Conheça os principais recursos do ActiveRoute, incluindo guias de roteamento, roteamento em múltiplas camadas, otimização do traçado, ajuste de comprimentos, controle de serpentinas e troca de pinos.
- Veja como usar o painel PCB ActiveRoute para configurar e executar o ActiveRoute com base nas regras do seu projeto e nos seus objetivos de roteamento.
Aprofunde-se com a IA:

Concept image showing routing

Uma das fases mais demoradas do projeto de placas é o roteamento das redes. Embora o sistema de regras gerencie as restrições do projeto, como larguras, tamanhos de vias, folgas e assim por diante, cabe ao projetista posicionar os milhares de segmentos de trilha necessários para rotear completamente uma placa.

Os roteadores automáticos podem facilitar essa tarefa, mas geralmente são considerados inadequados porque:

  • Não conseguem considerar corretamente a infinidade de restrições sutis de projeto que um projetista aplica instintivamente durante o roteamento.

  • Sua configuração completa leva tanto tempo que, muitas vezes, é mais eficiente simplesmente rotear a placa interativamente.

  • A limpeza do roteamento pode ser um processo tão longo e difícil que, muitas vezes, é mais eficiente rotear a placa interativamente.

O objetivo máximo do roteamento de PCBs é produzir rapidamente resultados de alta qualidade que atendam às regras de projeto, sob o controle do projetista. Esse é o desafio que o ActiveRoute se propõe a superar.

Improving the Completed Routes

Os recursos Glossing e Retrace complementam o ActiveRoute, mas são independentes dele. Eles podem ser usados para melhorar a qualidade de qualquer roteamento existente, independentemente de como ele foi criado.

O Glossing fica ativado por padrão e é executado quando o ActiveRoute termina — isso pode ser desativado no painel PCB ActiveRoute, se necessário. O Glossing também tem seu próprio conjunto de opções, incluindo a capacidade de arredondar os cantos do roteamento.

► Saiba mais sobre Suavização e retraçado de rotas existentes

O que é o ActiveRoute?

O ActiveRoute é uma tecnologia de roteamento interativo automatizado que oferece algoritmos eficientes para o roteamento de múltiplas redes e é aplicada às redes ou conexões específicas que você seleciona. O ActiveRoute também permite que o projetista defina interativamente um caminho de roteamento ou uma guia, que então define the river por onde passarão as novas rotas.

Os principais recursos do ActiveRoute que tornam essa abordagem significativamente melhor do que uma combinação de roteamento interativo convencional e roteamento automático incluem:

  • Otimização automática das rotas de escape de matrizes de pinos/vias — o aspecto mais demorado do roteamento manual.
  • Alto desempenho — redes de sinal roteadas em < 1 segundo cada.
  • Respeita as regras de projeto de largura, folga, camadas, topologia e regiões por rede e classe de redes, observando as prioridades.
  • Roteia em várias camadas simultaneamente e distribui as rotas entre elas.
  • Uma guia de roteamento intuitiva que o projetista pode usar para orientar o posicionamento das rotas.
  • Usa uma abordagem de roteamento em feixe para proporcionar altas taxas de conclusão sem a necessidade de vias.
  • Permite rotear através de planos poligonais e recalcular seu preenchimento (se a opção de recalcular o preenchimento estiver ativada).
  • Oferece suporte tanto a redes de sinais single-ended quanto a pares diferenciais.
  • Finaliza com uma poderosa ferramenta de suavização que reduz ainda mais o número de cantos e encurta o roteamento.

O que o ActiveRoute não é

O ActiveRoute não é um roteador automático. É um roteador interativo guiado que se concentra no roteamento limpo e de alta qualidade de um conjunto de redes selecionadas. Use o ActiveRoute da mesma forma que você abordaria a tarefa de roteamento interativo: escolha as redes de interesse, habilite as camadas nas quais deseja rotear essas redes, pense no caminho que elas devem seguir e faça o roteamento.

Se você selecionar todas as redes da placa e usar o ActiveRoute para roteá-las, provavelmente ficará decepcionado. O ActiveRoute não é um roteador automático; ele não pode posicionar vias e não inclui estratégias de roteamento para redes de alimentação.

O painel PCB ActiveRoute

O ActiveRoute segue os critérios e as restrições definidos pelas regras de projeto da PCB, portanto, para usá-lo, basta selecionar as conexões ou redes de interesse e executá-lo. Ele possui vários recursos de controle específicos que são configurados no painel PCB ActiveRoute. O painel PCB ActiveRoute é usado para configurar e operar os diversos recursos oferecidos pelo ActiveRoute, incluindo: executar um ActiveRoute interativo; definir uma guia de roteamento e o espaçamento das rotas dentro dela; habilitar o ajuste automático de comprimento; e habilitar a troca automática de pinos. É altamente recomendável abrir o painel PCB ActiveRoute antes de iniciar o ActiveRoute.

Para abrir o painel PCB ActiveRoute, quando uma PCB for o documento ativo: 

  • Clique no botão  Panels button, click to enable the display of workspace panels available in the current editor no canto inferior direito da área de trabalho e, em seguida, selecione a opção de menu PCB ActiveRoute.

  • Clique em View » Panels » PCB ActiveRoute.

Para acessar os recursos do ActiveRoute no Altium Designer, a extensão de software ActiveRoute deve estar instalada. Ela pode ser instalada ou removida manualmente.

Para obter mais informações sobre o gerenciamento de extensões, consulte a página Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Use o painel PCB ActiveRoute para controlar o processo do ActiveRoute.Use o painel PCB ActiveRoute para controlar o processo do ActiveRoute.

O painel PCB ActiveRoute é usado para:

  • Habilitar as camadas de sinal nas quais o ActiveRoute pode rotear conexões.
  • Executar o ActiveRoute nas conexões selecionadas.
  • Habilitar uma etapa de Glossing após o ActiveRoute.
  • Definir uma guia de roteamento.
    • Configurar o espaçamento entre trilhas que você deseja usar dentro da guia de roteamento.
  • Configurar e habilitar o ajuste de comprimento das rotas criadas pelo ActiveRoute.
  • Configurar a opção Meander, permitindo que o ActiveRoute defina um caminho de roteamento mais longo, o que pode ajudar a aumentar a taxa de conclusão.
  • Configurar e habilitar a troca de pinos. O ActiveRoute pode trocar pinos durante o roteamento para ajudar a melhorar sua qualidade.
O ActiveRoute opera nas conexões selecionadas; alguns controles do painel só ficam ativos quando há conexões selecionadas.

O conteúdo do painel PCB ActiveRoute é organizado em seções recolhíveis, que são abertas e fechadas usando o ícone ► associado ao título de cada seção. As informações sobre os controles de propriedades incluídas abaixo são organizadas em seções correspondentes, e cada seção recolhível é aberta/fechada da mesma maneira.

Recursos adicionais do ActiveRoute

O ActiveRoute é um roteador interativo automatizado, e seu uso é simples e direto: selecione as conexões e pressione Shift+A para roteá-las com o ActiveRoute de acordo com as regras de projeto. O ActiveRoute inclui vários outros recursos e controles, oferecendo ao projetista maior controle sobre determinadas funcionalidades e capacidades.

Entre eles:

  • Definir o caminho de roteamento e o espaçamento entre trilhas posicionando uma guia de roteamento.
  • Permitir um caminho de roteamento mais longo com o controle de Sinuosidade.
  • Igualar automaticamente os comprimentos das trilhas com o ajuste de comprimento.
  • Permitir a troca de pinos para simplificar o desafio de roteamento.

Vamos examinar cada um deles com mais detalhes.

Defina o caminho com a guia de roteamento

Um dos principais objetivos do ActiveRoute é encontrar o conjunto de trilhas com o menor comprimento total, o que pode não representar o caminho desejado para todos os conjuntos de conexões. A guia de roteamento oferece ao projetista uma ferramenta para traçar um caminho específico pelo qual deseja que as conexões selecionadas passem, mesmo que esse caminho não seja o mais curto.

  • Defining the Route Guide - primeiro, selecione as conexões que devem ser roteadas dentro da guia e clique em  Route Guide button, click to define a route guide that ActiveRoute will then attempt to route the selected nets along botão no painel PCB ActiveRoute, depois clique para definir o local inicial da guia e continue movendo o mouse e clicando para definir o caminho. Depois de definir o caminho, clique no botão ActiveRoute para rotear as conexões selecionadas ao longo desse caminho. Consulte a seção Definir uma guia de roteamento mais adiante nesta página para obter mais detalhes.

Evite desenhar as extremidades da guia de roteamento sobre os pads que deseja rotear. As saídas dos pads terão melhor qualidade se eles não estiverem incluídos na guia de roteamento.

  • Changing the Route Guide Width - durante o posicionamento da guia de roteamento, é possível aumentar ou diminuir sua largura pressionando as teclas  Keyboard Up arrow key ou  Keyboard Down arrow key. A largura padrão é a soma das regras de projeto de largura + folga aplicáveis às conexões selecionadas, dividida pelo número de camadas e multiplicada por 1,3. Pressione a tecla Backspace para desfazer os trechos da guia se precisar definir um caminho diferente.
  • The Route Guide color - determinada pelas camadas disponibilizadas para o ActiveRoute das conexões selecionadas. Se houver apenas uma camada habilitada, a guia será desenhada na cor dessa camada; se houver várias camadas habilitadas, ela será desenhada na cor padrão da guia de roteamento.
  • The track spacing within the Route Guide - o comportamento padrão do ActiveRoute é espaçar as trilhas de acordo com as regras de projeto, sem tentar distribuí-las ou usar todo o espaço disponível dentro de uma guia de roteamento. Para distribuir as trilhas dentro de uma guia de roteamento, use o recurso Espaçamento entre trilhas na guia de roteamento, conforme descrito mais adiante nesta página.

Um vídeo mostrando o posicionamento de uma guia de roteamento, com a largura sendo alterada interativamente durante o posicionamento.
Um vídeo mostrando o posicionamento de uma guia de roteamento, com a largura sendo alterada interativamente durante o posicionamento.

Largura da guia de roteamento

A largura padrão é a soma das regras de projeto de largura + folga aplicáveis às conexões selecionadas, dividida pelo número de camadas e multiplicada por 1,3. 

  • RouteGuideWidth = ((W+C)/#Layers)*1.3)
  • A guia é expandida pelo fator padrão de 1,3 para garantir que as trilhas caibam nela e possam contornar obstáculos, como vias, ao longo do caminho. A largura é um limite rígido para o roteamento; se as trilhas não couberem, elas não serão posicionadas.
  • Durante o posicionamento da guia, a largura pode ser aumentada ou diminuída pressionando as teclas  Keyboard Up arrow key ou  Keyboard Down arrow key no teclado. O tamanho mínimo usa um multiplicador de 1,0; o tamanho máximo usa um multiplicador de 10,0.

Edição da guia

A guia de roteamento é um conjunto de trilhas posicionadas em uma camada mecânica.

  • Os segmentos de trilha são bloqueados por padrão. Se você os desbloquear, poderá alterar a forma da guia usando as técnicas padrão de arraste de trilhas.
  • Para remover a guia, clique duas vezes em qualquer segmento para selecioná-lo e pressione a tecla Delete.

Espaçamento entre trilhas dentro da guia de roteamento

Usando o recurso Espaçamento entre trilhas na guia de roteamento, você pode instruir o ActiveRoute a distribuir as trilhas ao longo da largura da guia de roteamento. Use o controle deslizante para selecionar um valor de espaçamento ou digite um valor na caixa de edição. A guia de roteamento será dimensionada automaticamente para levar essa configuração em consideração. Para isso, você deve configurar a opção Track-Track Space in Route Guide antes de posicionar a guia de roteamento. Você também pode ajustar a largura da guia de roteamento durante o posicionamento pressionando as teclas  Keyboard Up arrow key e  Keyboard Down arrow key.

Use o recurso Espaçamento entre trilhas para distribuir as trilhas na guia de roteamento.
Use o recurso Espaçamento entre trilhas para distribuir as trilhas na guia de roteamento.

Permitir desvios nas trilhas

O ActiveRoute tenta rotear as conexões selecionadas pelo caminho mais curto possível, ou seja, com o mínimo de desvios. Se a taxa de conclusão do ActiveRoute for menor que a esperada, o controle de desvios permite aumentar a quantidade de desvios permitida ao ActiveRoute, o que pode ajudar a elevar a taxa de conclusão. A configuração máxima padrão de desvios é de 100%, o que significa que as trilhas podem ter um comprimento total de Manhattan Length + 100% of Manhattan Length. Use o controle deslizante para selecionar um valor de desvio ou digite uma porcentagem na caixa de edição.

Observe que a configuração de desvios é ignorada quando a guia de roteamento é usada porque a finalidade da guia de roteamento é definir um caminho que pode aumentar significativamente os desvios. 

Ajuste dos comprimentos das trilhas

O ActiveRoute pode aplicar o ajuste de comprimento às conexões que estão sendo roteadas ou às trilhas existentes selecionadas. O ActiveRoute tentará atender à regra de projeto de comprimentos correspondentes selecionada.

Para configurar o ActiveRoute para ajustar comprimentos:

  • Marque a caixa de seleção Tune Selected na região Action do painel.

  • Habilite a regra de projeto de comprimentos correspondentes necessária na região Tune do painel.

  • Defina as configurações Max Amplitude e Min Space necessárias (sinal simples ou par diferencial) na região Tune do painel.

PCB ActiveRoute panel, Tune section is used to configure the tuning shapes added by ActiveRoute to match the route lengths

Atualmente, apenas o estilo de ajuste com linhas chanfradas está disponível, com um chanfro nos cantos de aproximadamente 20%. As serpentinas posicionadas pelo ActiveRoute também não são uniões. O suporte ao ajuste de comprimento do ActiveRoute está em desenvolvimento contínuo, com outros estilos de ajuste e uniões de serpentinas sendo avaliados.

► Para saber mais sobre as configurações de ajuste de comprimento do ActiveRoute, consulte a seção Ajuste de comprimento na página do painel PCB ActiveRoute.

► Para saber mais sobre o ajuste de comprimento de trilhas existentes usando formas de serpentina ajustáveis, consulte o artigo Ajuste de comprimento.

Troca de pinos

O software inclui um poderoso sistema de troca de pinos e partes, com integração entre os editores de esquemático e de PCB. O ActiveRoute pode acessar as configurações de troca de pinos e trocar pinos durante o roteamento se isso reduzir o comprimento total das trilhas e melhorar a qualidade do roteamento.

Para usar a troca de pinos:

  • Antes de realizar qualquer troca de pinos (interativamente ou pelo ActiveRoute), o projeto deve ser compilado (menu Project) sempre que for aberto.
  • Para configurar e gerenciar as configurações de troca de pinos dos componentes, execute o comando Tools » Pin/Part Swapping » Configure para abrir a caixa de diálogo Configure Swapping Information in Components.
  • Habilite a opção Pin Swap Routing na região Action do painel PCB ActiveRoute.
  • Habilite os componentes necessários na região Pin Swap do painel PCB ActiveRoute.

Para saber mais sobre o recurso de troca de pinos, consulte Troca de pinos, pares e partes.

Preparação para usar o ActiveRoute

O ActiveRoute tem acesso ao recurso Gloss (Route » Gloss Selected), que é executado automaticamente como parte do processo do ActiveRoute se estiver habilitado no painel PCB ActiveRoute .

O motivo mais comum para uma falha do ActiveRoute é a falta de espaço para acomodar as trilhas. Portanto, é importante garantir que as regras de largura e folga estejam configuradas corretamente.

Executando o ActiveRoute

Para executar o ActiveRoute:

Aprimorando suas habilidades

  1. Um fator essencial para dominar o ActiveRoute é adquirir fluência no uso dos atalhos. As sequências de teclas que você usará com mais frequência são:

    • Alt+Click - para selecionar uma linha de conexão individual.
    • Alt+Click&Drag - para selecionar conexões dentro de uma área, arraste da direita para a esquerda para selecionar todas as conexões tocadas ou da esquerda para a direita para selecionar apenas o que estiver inteiramente dentro do retângulo de seleção. Pressione Tab para ampliar a seleção e incluir outras conexões da(s) mesma(s) rede(s). A barra de status exibirá o número de conexões recém-selecionadas até que o cursor passe sobre outro objeto.
    • Ctrl+Click&Drag - para selecionar pads em um componente, arraste da direita para a esquerda para selecionar todos os pads tocados ou da esquerda para a direita para selecionar apenas o que estiver inteiramente dentro do retângulo de seleção. Pressione Tab para ampliar a seleção e incluir outros objetos de roteamento da(s) mesma(s) rede(s). Continue pressionando Tab para percorrer todos os estados de seleção possíveis.
    • Click&Drag - para selecionar segmentos de trilha existentes, arraste da direita para a esquerda para selecionar todas as trilhas tocadas ou da esquerda para a direita para selecionar apenas o que estiver inteiramente dentro do retângulo de seleção. Pressione Tab para ampliar a seleção e incluir outros objetos de roteamento da(s) mesma(s) rede(s). Continue pressionando Tab para percorrer todos os estados de seleção possíveis.
    • Inclua Shift para manter a seleção atual ao realizar outra seleção.
    • Shift+A para rotear a seleção atual com o ActiveRoute.
    • Ctrl+Alt+G - para otimizar a seleção atual com o Gloss.
  2. As ações de seleção são realizadas apenas em objetos visíveis (exceto para Ctrl+A):

    • Pressione Shift+S para entrar no modo de camada única ou sair dele, de modo que apenas a camada de interesse seja exibida.
    • Se o projeto usar regiões de posicionamento (rooms), elas poderão ser bloqueadas como parte de sua definição nas regras de projeto ou ocultadas para impedir que sejam selecionadas/movidas durante ações de clicar e arrastar. As regiões podem ser ocultadas na aba View Options do painel Configuração de visualização.
  3. Crie fanouts para os pads SMD. O ActiveRoute não muda de camada, portanto, você precisará criar fanouts para os pads SMD. Para acelerar o processo de fanout:

    • Ao rotear uma conexão, pressione o atalho / (teclado numérico) para inserir uma via e encerrar o roteamento dessa conexão. Use o atalho 2 se não tiver um teclado numérico (insere uma via sem interromper o roteamento).
    • Copie e cole um fanout existente; o editor de PCB atualizará automaticamente os nomes das redes. Isso pode ser feito para vários fanouts.
  4. Preserve os fanouts existentes. O ActiveRoute modificará os fanouts se encontrar uma solução melhor; bloqueie-os se não quiser que sejam alterados. A maneira mais fácil de bloquear fanouts é selecionar suas trilhas e vias (use Selection Filter na parte superior do painel Properties para ajudar nesse processo), pressionar F11 para abrir o painel Properties e marcar a caixa de seleção Locked. Isso bloqueará todos os objetos selecionados em uma única ação.

  5. Se você usar um guia de roteamento e perceber que a taxa de conclusão está baixa, pode haver obstáculos demais ao longo do caminho, exigindo um guia mais largo. Pressione a tecla de seta Up para alargar o guia durante seu posicionamento.

  6. Quando o ActiveRoute termina, ele aplica a otimização de trilhas (se estiver habilitada no painel PCB ActiveRoute). Para examinar as trilhas como estavam ao término do roteamento pelo ActiveRoute, pressione Ctrl+Z uma vez para desfazer a otimização. O comando Gloss (Route » Gloss Selected) pode ser usado para suavizar as trilhas e melhorar suas entradas nos pads em qualquer roteamento, não apenas nos realizados pelo ActiveRoute. Foi dada atenção especial à garantia de entradas de alta qualidade nos pads para pares diferenciais. Para saber mais sobre a otimização de trilhas, consulte a página Otimização e retraçado de trilhas existentes.

  7. Se o ActiveRoute não funcionar, geralmente é porque as regras não estão configuradas corretamente. O motivo mais comum de falha do ActiveRoute é a falta de espaço para acomodar as trilhas. Verifique se as regras são adequadas; por exemplo, os valores das regras padrão de um novo arquivo de PCB podem ser grandes demais para um projeto de alta densidade com componentes BGA.

  8. O ActiveRoute respeita as regras de roteamento configuradas para larguras, folgas e espaçamentos entre trilhas de pares diferenciais, por camada, região e classe. O ActiveRoute não roteia com arcos nem com trilhas em ângulos arbitrários.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents